Guest

IP Routing

Understanding IS-IS Pseudonode LSP

Document ID: 49627

Updated: Aug 10, 2005

   Print

Introduction

This document describes the link-state packet (LSP) pseudonode. A pseudonode is a logical representation of the LAN which is generated by a Designated Intermediate System (DIS) on a LAN segment. The document also describes the propagation of information to the routers.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the software and hardware versions associated with:

  • Cisco IOS® Software Release 12.1(5)T9.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

DIS and the Pseudonode

This section describes DIS and the pseudonode.

What is the DIS?

On broadcast multi-access networks, a single router is elected as the DIS. There is no backup DIS elected. The DIS is the router that creates the pseudonode and acts on behalf of the pseudonode.

Two major tasks are performed by the DIS:

  • Creating and updating pseudonode LSP for reporting links to all systems on the broadcast subnetwork. See the Pseudenode LSP section for more information.

  • Flooding LSPs over the LAN.

Flooding over the LAN means that the DIS sends periodic complete sequence number protocol data units (CSNPs) (default setting of 10 seconds) summarizing the following information:

  • LSP ID

  • Sequence Number

  • Checksum

  • Remaining Lifetime

The DIS is responsible for flooding. It creates and floods a new pseudonode LSP for each routing level in which it is participating (Level 1 or Level 2) and for each LAN to which it is connected. A router can be the DIS for all connected LANs or a subset of connected LANs, depending on the IS-IS priority or the Layer 2 address. The DIS will also create and flood a new pseudonode LSP when a neighbor adjacency is established, torn down, or the refresh interval timer expires. The DIS mechanism reduces the amount of flooding on LANs.

Election of the DIS

On a LAN, one of the routers elects itself the DIS, based on interface priority (the default is 64). If all interface priorities are the same, the router with the highest subnetwork point of attachment (SNPA) is selected. The SNPA is the MAC address on a LAN, and the local data link connection identifier (DLCI) on a Frame Relay network. If the SNPA is a DLCI and is the same at both sides of a link, the router with the higher system ID becomes the DIS. Every IS-IS router interface is assigned both a L1 priority and a L2 priority in the range from 0 to 127.

The DIS election is preemptive (unlike OSPF). If a new router boots on the LAN with a higher interface priority, the new router becomes the DIS. It purges the old pseudonode LSP and floods a new set of LSPs.

What is the Pseudonode (PSN)?

In order to reduce the number of full mesh adjacencies between nodes on multiaccess links, the multiaccess link itself is modeled as a pseudonode. This is a virtual node, as the name implies. The DIS creates the pseudonode. All routers on the broadcast link, including the DIS, form adjacencies with the pseudonode.

Representation of a Pseudonode:

pseodonode.gif

In IS-IS, a DIS does not synchronize with its neighbors. After the DIS creates the pseudonode for the LAN, it sends hello packets for each Level (1 and 2) every three seconds and CSNPs every ten seconds. The hello packets indicate that it is the DIS on the LAN for that level, and the CSNPs describe the summary of all the LSPs, including the LSP ID, sequence number, checksum, and remaining lifetime. The LSPs are always flooded to the multicast address and the CSNP mechanism only corrects for any lost protocol data units (PDUs). For example, a router can ask the DIS for a missing LSP using a partial sequence number packet (PSNP) or, in turn, give the DIS a new LSP.

CSNPs are used to tell other routers about all the LSPs in one router's database. Similar to an OSPF database descriptor packet, PSNPs are used to request an LSP and acknowledge receipt of an LSP.

Pseudonode LSP

The pseudonode LSP is generated by the DIS. The DIS reports all LAN neighbors (including the DIS) in the pseudonode LSP with a metric of zero. All LAN routers, including the DIS, report connectivity to the pseudonode in their LSPs. This is similar in concept to the network LSA in OSPF.

Example

We'll use the following network diagram to demonstrate how the pseudonode LSP, generated by the DIS, is used to report all LAN neighbors.

Note: In the example below, the dynamic hostname feature is enable. Therefore, the system IDs are automatically mapped to the router hostnames shown in the resulting output of the show commands below.

Network Diagram

isis-pnode.jpg

Configurations

These configurations were used for the routers shown in the network diagram:

Router ISIS
Router 6
  
       interface e0
       ip address 172.16.126.6 255.255.255.0 
       ip router isis
       Isis priority 127
	   
       router isis
       net 49.0001.0000.0c4a.4598.00
       is-type level-1

  
  Router 2

       interface e0
       ip address 172.16.126.2 255.255.255.0
       ip router isis
	
       router isis
       net 49.0001.0000.0c8d.e6b4.00
       is-type level-1
	   
  Router 1

       interface e0
       ip address 172.16.126.1 255.255.255.0
       ip router isis


       interface s1
       ip address 172.16.1.1 255.255.255.0
       ip router isis

       router isis
       net 49.0001.0000.5c75.d0e9.00
       is-type level-1
	   
  Router 8
 
       interface s1
       ip address 172.16.1.8 255.255.255.0
       ip router isis
	  
       router isis
       net 49.0001.0000.0c31.c2fd.00
       is-type level-1c

The following table breaks down the area, MAC address, and network for each of the routers configured above. Notice that all of the routers are in the same area.

Router Area MAC Address NET (Network Entity Title)
6 49.0001 0000.0c4a.4598 49.0001.0000.0c4a.4598.00
2 0000.0c8d.e6b4 49.0001.0000.0c8d.e6b4.00
1 0000.5c75.d0e9 49.0001.0000.5c75.d0e9.00
8 0000.0c31.c2fd 49.0001.0000.0c31.c2fd.00

With the routers configured as described in this section, you can use the show clns is-neighbor command to view the IS-IS neighbors:

router-6# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-6#

router-2# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-2#

router-1# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-8       Se1         Up     L1   0         00                 Phase V
router-1#

router-8# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
Router-1       Se1         Up     L1   0         00                 Phase V
router-8#

In the preceding neighbor lists, notice the routers connected to the multiaccess network (Ethernet) all have the same circuit ID. The circuit ID is a one-octet number that the router uses to uniquely identify the IS-IS interface. If the interface is attached to a multiaccess network, the circuit ID is concatenated with the system ID of the DIS. This is known as the pseudonode ID. Notice also, that the DIS is Router 6 because of the IS-IS priority configured under its Ethernet interface.

IS-IS Database

This output displays the IS-IS database from each of the routers described in the previous section:

Router-6# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        960               0/0/0
router-6.00-00      * 0x0000006D   0xDD58        648               0/0/0
router-6.01-00      * 0x00000069   0x6DCB        1188              0/0/0
router-2.00-00        0x0000006D   0x59DE        589               0/0/0
router-1.00-00        0x00000074   0xC4B0        759               0/0/0
router-6#

router-2# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        947               0/0/0
router-6.00-00        0x0000006D   0xDD58        633               0/0/0
router-6.01-00        0x00000069   0x6DCB        1172              0/0/0
router-2.00-00      * 0x0000006D   0x59DE        577               0/0/0
router-1.00-00        0x00000074   0xC4B0        746               0/0/0
router-2#

router-1# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        934               0/0/0
router-6.00-00        0x0000006D   0xDD58        619               0/0/0
router-6.01-00        0x00000069   0x6DCB        1158              0/0/0
router-2.00-00        0x0000006D   0x59DE        561               0/0/0
router-1.00-00      * 0x00000074   0xC4B0        734               0/0/0
router-1#

router-8# show isis database
IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
router-8.00-00*       0x0000006E   0xFF1A        927           0/0/0
router-6.00-00        0x0000006D   0xDD58        607           0/0/0
router-6.01-00        0x00000069   0x6DCB        1147          0/0/0
router-2.00-00        0x0000006D   0x59DE        550           0/0/0
router-1.00-00        0x00000074   0xC4B0        723           0/0/0
router-8#

As the preceding output indicates, the show isis database command displays a list of LSPs in the database. In this case, all routers are Level 1 routers in the same area, so they all have the same LSPs in their IS-IS database. Notice that each of the routers generates an LSP. The DIS generates an LSP for itself, and it also generates an LSP on behalf of the pseudonode. The pseudonode LSP in this example is 0000.0C4A.4598.01-00.

We mentioned that the routers on the LAN only send advertisements to the pseudonode of the LAN. The pseudonode reports all LAN neighbors, in the pseudonode LSP, with a metric of zero—as shown in these show isis database lsp detail command output examples:

  • Router 6 LSP (as seen from Router 8)

    Notice that router 6 advertises that it can only reach its directly-connected network and the pseudonode. In this case, the pseudonode has a metric of 10. As we mentioned, routers on the LAN will advertise that they can be reached to the pseudonode of the LAN only.

    router-8# show isis database router-6.00-00 detail
    IS-IS Level-1 LSP router-6.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.00-00        0x00000071   0xD55C        456           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.6
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • Pseudonode LSP (as seen from Router 8)

    The pseudonode LSP advertises all the LAN neighbors with a metric of zero. The pseudonode LSP is generated by the DIS, Router 6 in this case, on behalf of the pseudonode.

    Router-8# show isis database router-6.01-00 detail
    IS-IS Level-1 LSP router-6.01-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.01-00        0x0000006D   0x65CF        759           0/0/0
      Metric: 0  IS router-6.00
      Metric: 0  IS router-2.00
      Metric: 0  IS router-1.00
    router-8#
  • Router 2 LSP (as seen from Router 8)

    Again, the Router 2 LSP contains information as to whether it can reach its directly-connected network and the pseudonode only.

    Router-8# show isis database router-2.00-00 detail
    IS-IS Level-1 LSP router-2.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-2.00-00        0x00000072   0x4FE3        791           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.2
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • Router 1 LSP (as seen from Router 8)

    The only information the Router 1 LSP contains for the LAN network is the network itself and whether it can reach the pseudonode. Since Router 1 is also connected to another network, the serial network, this directly-connected network is also advertised.

    Router-8# show isis database router-1.00-00 detail
    IS-IS Level-1 LSP router-1.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-1.00-00        0x00000079   0xBAB5        822           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.1.1
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-6.01
      Metric: 10 IS router-8.00
    router-8#
  • Router 8 LSP

    In this case, Router 8 is not connected to the LAN, so it does not advertise to the pseudonode that it can be reached. It does, however, advertise (that it can be reached) to itself, router 1, and to the directly-connected network.

    Router-8# show isis database router-8.00-00 detail
    IS-IS Level-1 LSP router-8.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-8.00-00*       0x00000072   0xF71E        554           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      IP Address:  172.16.1.8
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-1.00
      Metric: 0  ES router-8
    router-8#

Related Information

Updated: Aug 10, 2005
Document ID: 49627