Guest

IP Routing

Mutual Redistribution Between EIGRP and BGP Configuration Example

Document ID: 113506

Updated: May 02, 2012

   Print

Introduction

This document describes how to configure mutual redistribution between Enhanced Interior Gateway Routing Protocol (EIGRP) and Border Gateway Protocol (BGP).

Prerequisites

  • Basic knowledge of EIGRP

  • Basic knowledge of BGP

Hardware and Software Versions

The configurations in this document are based on the Cisco 7200 Series Router with Cisco IOS® Software Release 15.0(1).

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this example, routers R1 and R2 communicate with each other using EIGRP. Routers R2 and R3 use eBGP. In order to mutually redistribute the eBGP routes in to EIGRP, use the redistribute bgp command with EIGRP metrics. Similarly, in order to redistribute EIGRP routes in to BGP, use the redistribute eigrp AS number command.

Note: Use the Command Lookup Tool (registered customers only) in order to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

failover-eigrp-bgp-01.gif

Configurations

This document uses these configurations:

Router R1
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.101 255.255.255.0
 duplex auto
 speed auto

!
router eigrp 100
 network 30.0.0.0
 network 192.168.1.0
 no auto-summary
!
end

Router R2
!
hostname R2
!
ip cef
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.100.50 255.255.255.0
 serial restart-delay 0
 clock rate 2000000

!
router eigrp 100
 redistribute static
 redistribute bgp 1000 metric 100 1 255 1 1500
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary
!
router bgp 1000
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.20 mask 255.255.255.255
 redistribute connected
 redistribute static
 redistribute eigrp 100
 neighbor 172.16.100.51 remote-as 2000
 neighbor 172.16.100.51 next-hop-self

 
 no auto-summary
!
end

Router R3
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 22.22.22.22 255.255.255.255

!
interface Serial0/0
 ip address 172.16.100.51 255.255.255.0
 serial restart-delay 0
 clock rate 2000000
!
router bgp 2000
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 network 172.16.100.0 mask 255.255.255.0
 neighbor 172.16.100.50 remote-as 1000
 neighbor 172.16.100.50 default-originate
 default-information originate

!--- Default route is configured!


 no auto-summary

!
end

Verify

Use this section in order to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT in order to view an analysis of show command output.

Show Commands

In order to verify that EIGRP is receiving the redistributed routes, use the show ip route eigrp command.

show ip route eigrp
In router R1
R1#show ip route eigrp
20.0.0.0/32 is subnetted, 1 subnets
D EX    20.20.20.20
           [170/25625856] via 192.168.1.100, 01:00:33, FastEthernet0/0
     22.0.0.0/32 is subnetted, 1 subnets
D EX    22.22.22.22
           [170/25625856] via 192.168.1.100, 00:59:49, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/409600] via 192.168.1.100, 00:55:17, FastEthernet0/0
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:46:24, FastEthernet0/0


!--- Shows the default route from router R3.



!--- EX indicates that the routes are EIGRP external routes.



In order to verify that EIGRP routes are redistributed in BGP properly, use the show ip route bgp command in router R3.

show ip route bgp
In router R3
R3#show ip route bgp
show ip route bgp
     20.0.0.0/32 is subnetted, 1 subnets
B       20.20.20.20 [20/0] via 172.16.100.50, 01:03:02
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.100.50, 01:03:02
B    192.168.1.0/24 [20/0] via 172.16.100.50, 01:03:02
     30.0.0.0/32 is subnetted, 1 subnets
B       30.30.30.30 [20/409600] via 172.16.100.50, 00:59:06

!--- The output indicates that the EIGRP routes are
!--- redistributed in BGP.


Related Information

Updated: May 02, 2012
Document ID: 113506