Guest

Cisco Services Modules

Communication Media Module IP Connectivity

Cisco - Communication Media Module IP Connectivity

Introduction

This document provides detailed information about how IP connectivity is established with the Communication Media Module (CMM).

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on Cisco IOS 12.4.

Conventions

Refer to the Cisco Technical Tips Conventions for information on document conventions.

Background Information

Communication Media Module is a voice communication module that provides voice termination, transcoding, and conferencing services. It can be installed on the chassis of a 6500 switch or a 7600 router.

These adaptors can be installed on the CMM base module:

  • 6-Port T1 / E1 Port Adaptor

  • 24-Port FXS Port Adaptor

  • Ad-Hoc Conferencing and Transcoding (ACT) Port Adaptor

Typically, a SUP2 or Sup720 is installed in a 6500 switch or 7600 router that runs either CatOS software or native IOS software.

The CMM base module is connected to the backplane of the 6500 or 7600 with an internal Gigabit Ethernet interface. In addition, each ACT module has an internal Fast Ethernet connection to the 6500 or 7600.

This table describes the port mapping:

Backplane Connection CMM Interface Name Native IOS Interface Name CatOS Interface Name
CMM base module Gig1/0 Gig x/1 x/1
ACT Media card 1 Fas0/0 Fas x/2 x/2
ACT Media card 2 Fas1/0 Fas x/3 x/3
ACT Media card 3 Fas2/0 Fas x/4 x/4
ACT Media card 4 Fas3/0 Fas x/5 x/5

Note: “x” is the slot number on the 6500 or 7600 chassis in which the CMM is installed.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) in order to obtain more information on the commands used in this section.

Configurations

This document uses these configurations:

  • The IP addresses of the Gigabit and Fast Ethernet interfaces are “statically” configured. DHCP is not supported.

  • The IP addresses of the Gigabit and Fast Ethernet interfaces belong to the same subnet.

  • The Gigabit interface is configured with an IP address and subnet mask.

  • The Fast Ethernet interface(s) are configured with an IP address and subnet mask of 255.255.255.255.

  • The Gigabit and Fast Ethernet interfaces are configured as “switchport” on the 6500 switch and 7600 router.

  • The Gigabit and Fast Ethernet interfaces are configured to be part of the same virtual LAN (VLAN).

  • CMM is configured with a default IP route such that all traffic is sent to the default gateway. The default gateway might be the IP address of the VLAN interface configured on the 6500 switch or the 7600 router.

  • CMM with ACT modules in slot 2, 3, and 4. The Gigabit and Fast Ethernet interfaces are configured with IP addresses from 172.168.1.0 network.

Communication Media Module
interface GigabitEthernet1/0
 ip address 172.168.1.16 255.255.255.0
 no ip proxy-arp
 no negotiation auto
 no keepalive
!
interface FastEthernet1/0
 description ACT Media card – Slot 2
 ip address 172.168.1.17 255.255.255.255
 no ip proxy-arp
!
interface FastEthernet2/0
 description ACT Media card – Slot 3
 ip address 172.168.1.18 255.255.255.255
 no ip proxy-arp
!
interface FastEthernet3/0
 description ACT Media card – Slot 4
 ip address 172.168.1.19 255.255.255.255
 no ip proxy-arp
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.168.1.1

6500 / 7600 Supervisor running IOS (Native Mode)

!--- CMM is installed on Slot 2 and VLAN 2 is used


interface GigabitEthernet2/1
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface FastEthernet2/3
 description ACT Media card – Slot 2
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface FastEthernet2/4
 description ACT Media card – Slot 3
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface FastEthernet2/5
 description ACT Media card – Slot 4
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface Vlan2
 ip address 172.168.1.1 255.255.255.0

6500 / 7600 Supervisor running CatOS (Hybrid Mode)

!--- CMM is installed on Slot 2 and VLAN 2 is used


!--- Configuration in the Supervisor

#module 2 : 5-port Communication Media Mod.		
set vlan 2 2/3-5


!--- Configuration in the MSFC

interface Vlan2
 ip address 172.168.1.1 255.255.255.0

Packet Flow

The Fast Ethernet interface of the ACT module is used only to send and receive RTP packets of the ACT module (for transcoding and conference calls). All other non-RTP packets (such as ICMP ping request and reply) from the ACT module are sent to the supervisor via the Gigabit Ethernet interface. If the RTP packets that originated from the ACT module are sent via the Gigabit Ethernet interface instead of Fast Ethernet interface, the transcoding and conferencing call might experience one-way audio.

When the IP address of the CMM’s Fast Ethernet interface is pinged from the Cat 6500 switch or from anywhere outside the CMM, the ICMP echo request reaches the CMM via the Fast Ethernet interface. However, the ICMP echo reply from the ACT module is sent via the Gigabit interface since ICMP is a non-RTP packet.

The RTP packets of the voice calls terminated or originated from the T1 or E1 port adapter and FXS module are sent via the Gigabit Ethernet interface.

Troubleshoot

Commands

You can use these show and debug commands in order to troubleshoot IP connectivity issues:

  • In the MSFC, use these commands:

    • show arp

    • debug ip arp

    • debug ip icmp

  • In the CMM, use these commands:

    • show arp

    • debug ip arp

    • debug ip icmp

In addition, SUP 720 provides an internal sniffer tool that can be used to capture frames and packets. Contact TAC for assistance with this tool.

Example Outputs

Scenario 1: IP connectivity is not established.

Show output:

MSFC#show arp        
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.168.1.16           0   0011.92b7.3fe6  ARPA   Vlan2
Internet  172.168.1.1            -   000b.45b6.aa3c  ARPA   Vlan2
Internet  14.1.16.1              0   000f.232c.f3bf  ARPA   Vlan1
Internet  172.168.1.17           0   Incomplete      ARPA   
Internet  14.1.17.149            -   000b.45b6.aa3c  ARPA   Vlan1
Router#

Debugs from MSFC:


No response from CMM


MSFC#ping 172.168.1.17

5d00h: IP ARP: sent req src 172.168.1.1 000b.45b6.aa3c,
                 dst 172.168.1.17 0000.0000.0000 Vlan2
5d00h: IP ARP throttled out the ARP Request for 172.168.1.17

5d00h: IP ARP: creating incomplete entry for IP address: 10.1.1.46 interface Vlan101


CMM sends ARP reply, but the 6500 is not installing the ARP

5d00h: IP ARP: sent req src 172.168.1.1 000b.45b6.aa3c,
       dst 172.168.1.17 0000.0000.0000 Vlan2
5d00h: IP ARP rep filtered src 172.168.1.17 0011.92b7.3fe8, 
       dst 172.168.1.1 000b.45b6.aa3c it's our address

Scenario 2: IP connectivity is established.

Show output:

MSFC#show arp        
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.168.1.16           0   0011.92b7.3fe6  ARPA   Vlan2
Internet  172.168.1.1            -   000b.45b6.aa3c  ARPA   Vlan2
Internet  14.1.16.1              0   000f.232c.f3bf  ARPA   Vlan1
Internet  172.168.1.17           0   0011.92b7.3fe8  ARPA   Vlan2
Internet  14.1.17.149            -   000b.45b6.aa3c  ARPA   Vlan1
Router#

Debugs from MSFC:


Debugs from MSFC

MSFC#

5d00h: IP ARP: sent req src 172.168.1.1 000b.45b6.aa3c,
               dst 172.168.1.17 0000.0000.0000 Vlan2
5d00h: IP ARP: rcvd rep src 172.168.1.17 0011.92b7.3fe8, dst 172.168.1.17 Vlan2
5d00h: ICMP: echo reply rcvd, src 172.168.1.17, dst 172.168.1.1

Debugs from CMM

CMM#
*Mar  6 00:03:19.134: IP ARP: sent rep src 172.168.1.17 0011.92b7.3fe8,
                      dst 172.168.1.17 ffff.ffff.ffff FastEthernet1/0
*Mar  6 00:03:19.134: IP ARP rep filtered src 172.168.1.17 0011.92b7.3fe8, 
                      dst 172.168.1.17 ffff.ffff.ffff it's our address
*Mar  6 00:03:21.082: ICMP: echo reply sent, src 172.168.1.17, dst 172.168.1.1
*Mar  6 00:03:21.082: ICMP: echo reply sent, src 172.168.1.17, dst 172.168.1.1
  

Related Information

Updated: Nov 16, 2007
Document ID: 91263