Guest

Cisco Services Modules

RHI on the Content Switching Module Configuration Example

Document ID: 60043

Updated: Nov 30, 2005

   Print

Introduction

This document provides a configuration example for route health injection (RHI) on a Cisco Content Switching Module (CSM).

RHI allows the CSM to advertise the availability of a virtual IP (VIP) address throughout the network. Multiple CSM devices with identical VIP addresses and services can exist throughout the network. One CSM can override the server load-balancing (SLB) services over the other devices if the services are no longer available on the other devices. One CSM also can provide the services because it is logically closer to the client systems than other SLB devices. The CSM advertises the VIP address as a host route.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the CSM running version 3.x or 4.x.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

rhi_csm.jpg

Configurations

This document uses these configurations:

  • Catalyst A

  • Catalyst B

Catalyst A
hostname Catalyst A
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.1.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.1.20.1 255.255.255.0
  gateway 10.1.20.2
!
 probe LINUXPING icmp


!--- This probe is to verify that the servers are alive. This could be any 
!--- type of probe.

!
 serverfarm MYLINUX
  nat server
  no nat client
  real 10.1.10.3
   inservice
  real 10.1.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20


!--- The VLAN is important. When the VIP address is not part of the subnet
!--- of any VLAN configured on the CSM, the VLAN is used to tell the CSM on 
!--- which VLAN the traffic is coming in. This allows the CSM to set the 
!--- next-hop correctly when configuring the static route on the MSFC.

  serverfarm MYLINUX
advertise active



!--- The advertise command tells the CSM to create the static route.
!--- If you specify the active option, the static route is created only 
!--- if the vserver is operational.

  inservice
!    
interface Vlan20
 ip address 10.1.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.1.30.97 255.255.254.0
 no ip proxy-arp
!
router ospf 1


!--- In this example, OSPF is used to advertise the VIP through the network.
!--- You can use any IGP however.

 log-adjacency-changes
 redistribute static metric 10 subnets


!--- Since the CSM creates a static route on the MSFC, you simply need to 
!--- redistribute static routes to advertise the VIP.

 network 10.1.0.0 0.0.255.255 area 1
!

The configuration of Catalyst B is identical to Catalyst A. The IP addressing is slightly different because Catalyst B is in a different area of the network. The VIP address is the same however. The metric of the redistributed static routes was also changed so that Catalyst A is the preferred path to the VIP, and Catalyst B is the backup solution.

Catalyst B
hostname Catalyst B
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.2.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.2.20.1 255.255.255.0
  gateway 10.2.20.2
!
 probe LINUXPING icmp
!
 serverfarm MYLINUX
  nat server
  no nat client
  predictor hash address source
  real 10.2.10.3
   inservice
  real 10.2.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20
  serverfarm MYLINUX
  advertise active
  inservice
!    
interface Vlan20
 ip address 10.2.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.2.30.97 255.255.254.0
 no ip redirects
 no ip proxy-arp
!
router ospf 1
 log-adjacency-changes
 redistribute static metric 20 subnets
 network 10.2.0.0 0.0.255.255 area 2
!

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show ip route static — Issue this command to view the static routes created by the CSM for each vserver configured with the advertise command. If you do not see any routes, make sure the vserver is operational and that there is a VLAN specified under the vserver.

    SwitchA#show ip route static 
         192.168.1.0/32 is subnetted, 1 subnets
    S       192.168.1.1 [1/0] via 10.1.20.1, Vlan20
    SwitchA#
  • show mod csm X vserver name NAME detail

    SwitchB#sho mod csm 4 vservers name rhitest
    
    vserver         type  prot virtual                  vlan state        conns
    ---------------------------------------------------------------------------
    RHITEST         SLB   any  192.168.1.1/32:0         20   OPERATIONAL  0       
    SwitchA#show mod csm 4 probe name linuxping detail
    probe           type    port  interval retries failed  open   receive
    ---------------------------------------------------------------------
    LINUXPING       icmp          120      3       300            10     
     real                  vserver         serverfarm      policy          status
     ------------------------------------------------------------------------------
     10.1.10.4:0        RHITEST         MYLINUX         (default)       OPERABLE
     10.1.10.3:0        RHITEST         MYLINUX         (default)       OPERABLE
  • show mod csm X probe name NAME detail

  • show ip ospf database self-originate — Issue this command to verify that OSPF is advertising the VIP address.

    SwitchA#sho ip ospf database self-originate 
    
                OSPF Router with ID (10.1.30.97) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    10.1.30.97      10.1.30.97      5           0x80000001 0x00B9BE 2
    
                    Type-5 AS External Link States
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    192.168.1.1     10.1.30.97      5           0x80000001 0x00CCC7 0
  • show ip route x.x.x.x

  • show ip ospf database extern x.x.x.x

    lsd#sho ip ospf database external 192.168.1.1
    
                OSPF Router with ID (200.200.200.200) (Process ID 1)
    
    
                    Type-5 AS External Link States
    
      Routing Bit Set on this LSA
      LS age: 39
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.20.97
      LS Seq Number: 80000001
      Checksum: 0x8310
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 20 
            Forward Address: 10.2.20.1
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 89
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.30.97
      LS Seq Number: 80000001
      Checksum: 0xCCC7
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 10 
            Forward Address: 10.1.20.1
            External Route Tag: 0

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Nov 30, 2005
Document ID: 60043