Guest

Cisco Interface Processors

Running OROUTED to Exchange RIP Routing Updates

Cisco - Running OROUTED to Exchange RIP Routing Updates

Document ID: 12258

Updated: Sep 09, 2005

   Print

Introduction

This document gives an example of the configuration required on the router and on the mainframe to exchange RIP routing updates through the use of the OROUTED procedure. OROUTED is a procedure which runs on the mainframe and which performs essentially the same function as when you run the ROUTED daemon on a UNIX host. OROUTED runs from either the OpenEdition/Multiple Virtual Storage (OMVS) address space or as a started task.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This configuration was developed and tested with these software and hardware versions:

  • Cisco IOS® Software Release 12.1(2) with Mainframe Channel Port Adapter (XCPA) microcode xcpa27-7.

    This was the latest version of code released at the time, but these features should be supported in all currently maintained major versions of code.

  • The router is a Cisco 7206 with a PCPA (Parallel Channel Port Adapter).

OROUTED requires these two configuration files on the mainframe in the OMVS address space, with environment variables that point to their location:

  • export ROUTED_PROFILE=/etc/orouted.profile

  • export RESOLVER_CONF=/etc/resolv.conf

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Background Information

In order to start OROUTED, issue these commands from within OMVS:

cd /usr/lpp/tcpip/sbin

orouted

On the MVS console, you can issue this command in order to find the process number of the OROUTED process:

d omvs,u=p390

Note:  p390 is the logon identification under which OROUTED was started.

You can also start the OROUTED process through job control language (JCL), as a started task. If you start it from OMVS, change the 520 port in the TCP/IP profile dataset to OMVS.

These are examples of the datasets:

/etc/orouted.profile
RIP_SUPPLY_CONTROL: RIP1
RIP_RECEIVE_CONTROL: ANY
RIP2_AUTHENTICATION_KEY:
/etc/resolv.conf
TCPIPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

TCP/IP profile dataset configuration changes
--------------------------------------------

; ----------------------------------------------------------------------- ;

;
orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask      Dest Addr
BSDROUTINGPARMS false
LDIPTG         1500       0     255.255.255.240  10.64.3.33
VIPALINK       1500       0     255.255.255.240  0
ENDBSDROUTINGPARMS
; -----------------------------------------------------------------------
RIP

Configuration

Channel Interface Processor (CIP) Router
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname diplodocus
!
boot system flash slot1:c7200-a3js-mz.121-2.bin
!
!
!
!
!
microcode pcpa slot1:xcpa27-9
microcode reload
!
interface Channel2/0
ip address 10.64.3.33 255.255.255.240
no keepalive
csna 0100 41
csna 0100 42
cmpc 0100 24 DIPTG READ
cmpc 0100 25 DIPTG WRITE
lan TokenRing 0
source-bridge 4 1 1
adapter 0 4000.0000.0001
adapter 1 4000.0000.0002
adapter 2 4000.0000.0003
adapter 3 4000.0000.0004
adapter 4 4000.0000.0005
lan TokenRing 1
source-bridge 5 1 1
adapter 7 4000.0000.0001
tn3270-server
pu PU1	    01712444 10.64.3.35      token-adapter 1  04 rmac
4000.0000.0001   lu-seed DIPL###
pu PU2	    01712555 10.64.3.36      token-adapter 1  08 rmac
4000.0000.0001   lu-seed DIPL2##
tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
!
!
router eigrp 1
redistribute rip
passive-interface Channel2/0
network 10.0.0.0
passive-interface Ethernet6/1
passive-interface Ethernet6/3
network 10.0.0.0
!
no auto-summary
!
router rip
redistribute eigrp 1
passive-interface Serial1/3
  
 passive-interface TokenRing5/0

Related Information

Updated: Sep 09, 2005
Document ID: 12258