Guest

Cisco Network Modules

Catalyst 6500 EIGRP Over VRF-Lite Configuration Example

Cisco - Catalyst 6500 EIGRP Over VRF-Lite Configuration Example

Document ID: 112245

Updated: Jan 03, 2011

   Print

Introduction

This document describes how to configure EIGRP over virtual route forwarding (VRF)-lite on a Cisco Catalyst 6500 Series Switch. Static route is configured on the switches and are redistributed via EIGRP between the switches.

Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

  • Basic knowledge of EIGRP

  • Basic knowledge of the Catalyst 6500 configuration

Components Used

The information in this document is based on Catalyst 6500 Series Switches that run software version 12.2(33).SXH6.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

VRF-lite allows a service provider to support two or more VPNs with an overlapping IP address using one interface. VRF-lite is also termed multi-VRF CE or multi-VRF Customer Edge Device. In the past, VRF-lite was supported only with RIP, OSPF, and BGP. But in recent versions, VRF-lite is also supported with EIGRP. This document provides an example of an EIGRP over VRF-lite CLI configuration where static VRF routes are redistributed via EIGRP to other switches.

Configure VRF-Lite over Catalyst 6500

These are the guidelines to configure VRF-lite over Catalyst 6500:

  • A switch with VRF-lite is shared by multiple customers, and all customers have their own routing tables.

  • Because customers use different VRF tables, the same IP addresses can be reused. Overlapped IP addresses are allowed in different VPNs.

  • VRF-lite lets multiple customers share the same physical link between the PE and the CE. Trunk ports with multiple VLANs separate packets among customers. All customers have their own VLANs.

  • For the PE router, there is no difference between using VRF-lite or using multiple CEs.

  • A customer can use multiple VLANs as long as they do not overlap with those of other customers. A customer's VLANs are mapped to a specific routing table ID that is used to identify the appropriate routing tables stored on the switch.

  • VRF-lite does not affect the packet switching rate.

CLI Configuration

This section shows the CLI configuration:

 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248
 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248

 6500c(config)#ip vrf TEST-LAB
 6500c(config)#rd 10.244.0.10:100
!
 6500c(config-if)#interface Loopback0
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 1.1.1.1 255.255.255.0
!         
 6500c(config-if)#interface GigabitEthernet1/1
 6500c(config-if)#switchport
 6500c(config-if)#switchport access vlan 129
 6500c(config-if)#no ip address
!                  
 6500c(config-if)#interface Vlan129
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 10.244.129.251 255.255.255.248

Troubleshoot EIGRP

A common issue seen with EIGRP is the local router does not establish an EIGRP neighbor relationship with neighboring routers.

Static Route Not Redistriubted to EIGRP

  1. Use the default metric value for the static routes in the redistribute static command.

  2. Remove and add the redistribute static command on the router; the static route 10.0.0.0/8 shows under EIGRP topology.

Related Information

Updated: Jan 03, 2011
Document ID: 112245