Guest

Cisco Modem Cards

Configuring Dialin with the NM-8AM or NM-16AM Analog Modem Module

Cisco - Configuring Dialin with the NM-8AM or NM-16AM Analog Modem Module

Introduction

This document provides a sample configuration for dialin using a modem with the NM-xAM analog modem network module. In this scenario, a router with the NM-8AM modem module acts as a remote access server for dialin into the corporate network.

Note: This document does not cover using an NM-8AM or NM-16AM for dialout. For such an example, refer to the document Configuring Dialout with the NM-8AM or NM-16AM Analog Modem Module.

Prerequisites

Requirements

This document assumes you have a good understanding of the various issues associated with modem configurations. If you need more information on these issues, please refer to the Modem-Router Connection Guide.

The NM-AM module requires individual analog plain old telephone service (POTS) lines to be plugged into the ports. Please ensure that the POTS line is functioning properly by connecting a phone to the line and testing it for incoming and outgoing calls before plugging it into the NM-AM ports.

  • Individual ports can have individual phone numbers (in this example we are using eight different phone numbers), or can have all eight in a hunt group with a single dialin number (the phone provider needs to do this). With the first option, users get a busy signal if a prior call is still connected on that particular number. With the second option, calls are automatically rolled over to the next available port.

  • Be absolutely sure to use a properly-grounded power source for Cisco 2600 and 3600 routers with NM-AM modules; otherwise, the NM-AM modem calls have a buzzing sound that manifests itself as poor or failed connections. Refer to the document Installing the Grounding Lug on Cisco 2600 Series and Cisco 3600 Series Routers for more information.

  • It is recommended to have the latest firmware version on the NM-AMs. Use the show modem version command to check this.

Components Used

The information in this document is based on these software and hardware versions:

  • A Cisco 3640 router with the NM-8AM card running Cisco IOS® Software Release 12.2(8)T.

  • Modem Firmware Version 1.2.8.

    Note: Modem Firmware Version 1.2.8 is bundled into Cisco IOS.

  • Cisco IOS Software Releases 12.1(5)T and 12.2. It is not available unbundled.

  • A PC with Microsoft Windows 2000 OS.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

nm-xam_dialin.gif

Configurations

This document uses this configuration:

Remote Access Server (Cisco 3640 Router)
Current configuration : 1251 bytes
 !
 version 12.2
 service timestamps debug datetime msec
 service timestamps log uptime
 no service password-encryption
 !
 hostname cisco3640
 !
 boot system flash:c3640-i-mz.122-8.T
 enable secret 5 <deleted>
 !
 username abc password 0 abc

! -- Usernames for local authentication of the call.
! -- The client presents the username/password and the NAS
! -- authenticates the peer.

 ip subnet-zero
 !
 no ip domain-lookup
 ip domain-name cisco.com
 !
 async-bootp dns-server 5.5.5.1 5.5.5.2
 
! --  Specifies (for async clients) the IP address of domain name server.

 !
 !     
 interface Loopback0
  ip address 1.1.1.1 255.255.255.0
 !
 interface Ethernet2/0
  ip address 20.20.20.1 255.255.255.0
  half-duplex
 !
 
! <<--Unused interface configuration omitted.

 !
 interface Group-Async1

! -- This group-async interface is the configuration template for all modems.
! -- Individual async interface do not have to be configured since they
! -- can be cloned from one managed copy.

  ip unnumbered Loopback0
  encapsulation ppp
  dialer in-band
  dialer idle-timeout 600

! -- Sets Idle timer to 600 seconds (10 minutes).

  dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
! -- Note: The specified dialer-group number must be the same as
! -- the dialer-list number; in this example, defined to be "1".
! -- Interesting traffic specifies the packets that should reset the idle timer. 

  async mode interactive

! -- If the async interface is to answer different connection types 
! -- (exec,ppp,slip), use this command in conjunction with autoselect ppp
! -- under the line configuration to auto detect the connection type.
! -- To prevent users from establishing an "EXEC session" to the router.
! -- use the command async modem dedicated instead.

 peer default ip address pool DIALIN

! -- Clients are assigned addresses from the ip address pool named "DIALIN".

  ppp authentication chap
  group-range 1 8

! -- Modems/lines 1 to 8 are members of this group async interface.
! -- If you want, for example, only 4 modems for incoming and the rest 
! -- for outgoing then configure the group range for any set of
! -- four consecutive modems in the module.
! -- Note: this range must be included within the line configuration below.

 !
 ip local pool DIALIN 10.1.1.1 10.1.1.10

! -- IP address pool for dialin clients.

 ip classless
 ip route 0.0.0.0 0.0.0.0 20.20.20.100
 ip http server
 ip pim bidir-enable
 !
 !
 dialer-list 1 protocol ip permit

! -- Specifies all IP traffic as interesting. Interesting traffic
! -- specifies the packets that should reset the idle timer.
! -- This is applied to interface Group-Async 1 using dialer-group 1.
! -- Note: The specified dialer-list number must be the same as the
! -- dialer-group number; in this example, defined to be "1".

 !
 line con 0
  password abc
 line 1 8

! -- TTY lines for the NM-8AM Modems.
! -- Note the line number range matched the group-range 
! -- under the group-async config.

 modem InOut

! -- Support incoming and outgoing modem calls.

  transport input all
  autoselect ppp

! -- Launch PPP if PPP packets are detected. This is used in conjunction
! -- with async mode interactive under the group-async configuration.

  flowcontrol hardware
 line aux 0
 line vty 0 4
  login
 !
 !
 end

Note: In this 3600 router chassis, the NM-8AM card is installed in slot 0. We can refer to How Async Lines are Numbered in Cisco 3600 Series Routers to ascertain that slot 1 has lines 1 to 32 reserved. To determine which specific async interface you should configure, use the show line command to find out the available lines. In this configuration, note that only lines 1 to 8 (eight lines) are available within that range. To configure the first modem in the card, configure line 1 (and interface async 1) while the last modem is line 8 / interface async 8.

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show diag—To display hardware information for the router, use the show diag command in privileged EXEC mode. Particularly useful in modular routers where the line number or interface number is dependent on which slot the NM or WIC is inserted.

  • show modem version—This command is useful for verifying the version of modem firmware running on the system before or after a modem firmware upgrade.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, refer to Important Information on Debug Commands.

  • debug modem—To display the modem line activity, modem control, and process activation messages on the router.

  • debug ppp negotiation—To display information on PPP traffic and exchanges while negotiating the PPP components including Link Control Protocol (LCP), authentication, and Network Control Protocol (NCP). A successful PPP negotiation first opens the LCP state, then authenticate, and finally negotiate NCP.

Sample Debug Output

cisco3640#show debug
 General OS:
   Modem control/process activation debugging is on
 PPP:
   PPP protocol negotiation debugging is on
 
 cisco3640#
 *Mar  1 00:14:05.479: CSM_ANALOG_MODEM_IDLE: 
MODEM_STARTING_CONNECT at slot 0, port 0 

! -- Incoming call

 *Mar  1 00:14:05.479: Modem 0/0 Mcom: in modem state 'Dialing/Answering'

! -- Modem answers the call

 *Mar  1 00:14:06.131: ANALOG_CONNECT_INITIATED: 
MODEM_ANALOG_CALL_IN at slot 0, port 0
 *Mar  1 00:14:06.131: Modem 0/0 Mcom: in modem state 'Incoming ring'
 *Mar  1 00:14:08.403: Modem 0/0 Mcom: in modem state 'Waiting for Carrier'
 *Mar  1 00:14:19.807: Modem 0/0 Mcom: in modem state 'Connected'

! -- Modem trainup complete. Note the 10+ seconds the modems took to trainup

 *Mar  1 00:14:20.363: ANALOG_CONNECT_INITIATED: 
MODEM_CONNECTED at slot 0, port 0
 *Mar  1 00:14:20.363: Call Handle failed for Modem 0/0
 *Mar  1 00:14:20.363: Modem 0/0 Mcom: 
CONNECT at 26400/26400(Tx/Rx), V34, LAPM, V42bis, Answer

! -- Modem speeds, modulation, framing protocol,compression for this 
! -- connection are displayed

 *Mar  1 00:14:21.187: TTY1: DSR came up
 *Mar  1 00:14:21.187: tty1: Modem: IDLE->(unknown)
 *Mar  1 00:14:21.187: TTY1: Autoselect started
 *Mar  1 00:14:21.187: TTY1: create timer type 0, 120 seconds
 *Mar  1 00:14:22.559: TTY1: Autoselect sample 7E
 *Mar  1 00:14:22.559: TTY1: Autoselect sample 7EFF
 *Mar  1 00:14:22.559: TTY1: Autoselect sample 7EFF7D
 *Mar  1 00:14:22.559: TTY1: Autoselect sample 7EFF7D23

! -- The router has received a PPP packet. It will now start PPP

 *Mar  1 00:14:22.559: TTY1 Autoselect cmd:  ppp negotiate

! -- The router kicks off ppp since the command autoselect ppp is 
! -- in the line configuration

 *Mar  1 00:14:22.559: TTY1: destroy timer type 0
 *Mar  1 00:14:22.563: TTY1: EXEC creation
 *Mar  1 00:14:22.563: TTY1: create timer type 1, 600 seconds
 *Mar  1 00:14:22.563: TTY1: destroy timer type 1
 *Mar  1 00:14:22.563: TTY1: no timer type 0 to destroy
 *Mar  1 00:14:22.567: As1 IPCP: Install route to 10.1.1.2
 *Mar  1 00:14:22.567: As1 IPCP: Add link info for cef entry 10.1.1.2
 00:14:24: %LINK-3-UPDOWN: Interface Async1, changed state to up
 *Mar  1 00:14:24.563: As1 PPP: Treating connection as a callin
 *Mar  1 00:14:24.563: As1 PPP: Phase is ESTABLISHING, Passive Open
 *Mar  1 00:14:24.563: As1 LCP: State is Listen

! -- PPP LCP negotiation begins

 *Mar  1 00:14:25.559: As1 LCP: I CONFREQ [Listen] id 2 len 50
 *Mar  1 00:14:25.559: As1 LCP:    ACCM 0x00000000 (0x020600000000)
 *Mar  1 00:14:25.559: As1 LCP:    MagicNumber 0x7E346973 (0x05067E346973)
 *Mar  1 00:14:25.559: As1 LCP:    PFC (0x0702)
 *Mar  1 00:14:25.559: As1 LCP:    ACFC (0x0802)
 *Mar  1 00:14:25.559: As1 LCP:    Callback 6  (0x0D0306)
 *Mar  1 00:14:25.559: As1 LCP:    MRRU 1614 (0x1104064E)
 *Mar  1 00:14:25.559: As1 LCP:    EndpointDisc 1 Local
 *Mar  1 00:14:25.559: As1 LCP:     (0x1317012531B2C62B044C08A4E6C70075)
 *Mar  1 00:14:25.563: As1 LCP:     (0x69040F00000000)
 *Mar  1 00:14:25.563: Modem 0/0 Mcom: switching to PPP mode
 *Mar  1 00:14:25.563: Modem 0/0 Mcom: PPP escape map: Tx map = FFFFFFFF, 
 Rx map = 0
 *Mar  1 00:14:25.563: As1 LCP: O CONFREQ [Listen] id 3 len 25
 *Mar  1 00:14:25.563: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
 *Mar  1 00:14:25.563: As1 LCP:    AuthProto CHAP (0x0305C22305)
 *Mar  1 00:14:25.563: As1 LCP:    MagicNumber 0x014F4F18 (0x0506014F4F18)
 *Mar  1 00:14:25.563: As1 LCP:    PFC (0x0702)
 *Mar  1 00:14:25.563: As1 LCP:    ACFC (0x0802)
 *Mar  1 00:14:25.563: As1 LCP: O CONFREJ [Listen] id 2 len 11
 *Mar  1 00:14:25.563: As1 LCP:    Callback 6  (0x0D0306)
 *Mar  1 00:14:25.563: As1 LCP:    MRRU 1614 (0x1104064E)
 *Mar  1 00:14:25.731: As1 LCP: I CONFACK [REQsent] id 3 len 25
 *Mar  1 00:14:25.731: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
 *Mar  1 00:14:25.731: As1 LCP:    AuthProto CHAP (0x0305C22305)
 *Mar  1 00:14:25.731: As1 LCP:    MagicNumber 0x014F4F18 (0x0506014F4F18)
 *Mar  1 00:14:25.731: As1 LCP:    PFC (0x0702)
 *Mar  1 00:14:25.731: As1 LCP:    ACFC (0x0802)
 *Mar  1 00:14:27.551: As1 LCP: TIMEout: State ACKrcvd
 *Mar  1 00:14:27.551: As1 LCP: O CONFREQ [ACKrcvd] id 4 len 25
 *Mar  1 00:14:27.551: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
 *Mar  1 00:14:27.551: As1 LCP:    AuthProto CHAP (0x0305C22305)
 *Mar  1 00:14:27.551: As1 LCP:    MagicNumber 0x014F4F18 (0x0506014F4F18)
 *Mar  1 00:14:27.551: As1 LCP:    PFC (0x0702)
 *Mar  1 00:14:27.551: As1 LCP:    ACFC (0x0802)
 *Mar  1 00:14:27.683: As1 LCP: I CONFREQ [REQsent] id 3 len 43
 *Mar  1 00:14:27.683: As1 LCP:    ACCM 0x00000000 (0x020600000000)
 *Mar  1 00:14:27.683: As1 LCP:    MagicNumber 0x7E346973 (0x05067E346973)
 *Mar  1 00:14:27.687: As1 LCP:    PFC (0x0702)
 *Mar  1 00:14:27.687: As1 LCP:    ACFC (0x0802)
 *Mar  1 00:14:27.687: As1 LCP:    EndpointDisc 1 Local
 *Mar  1 00:14:27.687: As1 LCP:     (0x1317012531B2C62B044C08A4E6C70075)
 *Mar  1 00:14:27.687: As1 LCP:     (0x69040F00000000)
 *Mar  1 00:14:27.687: As1 LCP: O CONFACK [REQsent] id 3 len 43
 *Mar  1 00:14:27.687: As1 LCP:    ACCM 0x00000000 (0x020600000000)
 *Mar  1 00:14:27.687: As1 LCP:    MagicNumber 0x7E346973 (0x05067E346973)
 *Mar  1 00:14:27.687: As1 LCP:    PFC (0x0702)
 *Mar  1 00:14:27.687: As1 LCP:    ACFC (0x0802)
 *Mar  1 00:14:27.687: As1 LCP:    EndpointDisc 1 Local
 *Mar  1 00:14:27.687: As1 LCP:     (0x1317012531B2C62B044C08A4E6C70075)
 *Mar  1 00:14:27.687: As1 LCP:     (0x69040F00000000)
 *Mar  1 00:14:27.691: As1 LCP: I CONFACK [ACKsent] id 4 len 25
 *Mar  1 00:14:27.691: As1 LCP:    ACCM 0x000A0000 (0x0206000A0000)
 *Mar  1 00:14:27.691: As1 LCP:    AuthProto CHAP (0x0305C22305)
 *Mar  1 00:14:27.691: As1 LCP:    MagicNumber 0x014F4F18 (0x0506014F4F18)
 *Mar  1 00:14:27.691: As1 LCP:    PFC (0x0702)
 *Mar  1 00:14:27.691: As1 LCP:    ACFC (0x0802)
 *Mar  1 00:14:27.691: As1 LCP: State is Open

! -- LCP negotiation begins

 *Mar  1 00:14:27.691: Modem 0/0 Mcom: PPP escape map: Tx map = 0, Rx map = 0
 *Mar  1 00:14:27.691: As1 PPP: Phase is AUTHENTICATING, by this end
 *Mar  1 00:14:27.691: As1 CHAP: O CHALLENGE id 2 len 30 from "cisco3640"
 *Mar  1 00:14:27.851: As1 LCP: I IDENTIFY [Open] id 4 len 18 magic 0x7E346973 
MSRASV5.00
 *Mar  1 00:14:27.863: As1 LCP: I IDENTIFY [Open] id 5 len 28 magic 0x7E346973 
MSRAS-W2K
 *Mar  1 00:14:27.879: As1 CHAP: I RESPONSE id 2 len 24 from "mak"
 *Mar  1 00:14:27.883: As1 CHAP: O SUCCESS id 2 len 4

! -- CHAP is successful

 *Mar  1 00:14:27.883: As1 PPP: Phase is UP
 *Mar  1 00:14:27.883: As1 IPCP: O CONFREQ [Closed] id 2 len 10
 *Mar  1 00:14:27.883: As1 IPCP:    Address 1.1.1.1 (0x030601010101)
 *Mar  1 00:14:28.019: As1 CCP: I CONFREQ [Not negotiated] id 6 len 10
 *Mar  1 00:14:28.019: As1 CCP:    MS-PPC supported bits 0x00000001 
(0x120600000001)
 *Mar  1 00:14:28.019: As1 LCP: O PROTREJ [Open] id 5 len 16 protocol CCP 
 (0x80FD0106000A120600000001)
 *Mar  1 00:14:28.035: As1 IPCP: I CONFREQ [REQsent] id 7 len 40
 *Mar  1 00:14:28.035: As1 IPCP:    CompressType VJ 15 slots CompressSlotID 
(0x0206002D0F01)
 *Mar  1 00:14:28.035: As1 IPCP:    Address 0.0.0.0 (0x030600000000)
 *Mar  1 00:14:28.035: As1 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
 *Mar  1 00:14:28.035: As1 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)
 *Mar  1 00:14:28.035: As1 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
 *Mar  1 00:14:28.035: As1 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)
 *Mar  1 00:14:28.035: As1 IPCP: O CONFREJ [REQsent] id 7 len 22
 *Mar  1 00:14:28.035: As1 IPCP:    CompressType VJ 15 slots CompressSlotID 
 (0x0206002D0F01)
 *Mar  1 00:14:28.035: As1 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)
 *Mar  1 00:14:28.039: As1 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)
 *Mar  1 00:14:28.039: As1 IPCP: I CONFACK [REQsent] id 2 len 10
 *Mar  1 00:14:28.043: As1 IPCP:    Address 1.1.1.1 (0x030601010101)
 *Mar  1 00:14:28.175: As1 IPCP: I CONFREQ [ACKrcvd] id 8 len 22
 *Mar  1 00:14:28.175: As1 IPCP:    Address 0.0.0.0 (0x030600000000)
 *Mar  1 00:14:28.175: As1 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
 *Mar  1 00:14:28.175: As1 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
 *Mar  1 00:14:28.175: As1 IPCP: O CONFNAK [ACKrcvd] id 8 len 22
 *Mar  1 00:14:28.175: As1 IPCP:    Address 10.1.1.2 (0x03060A010102)
 *Mar  1 00:14:28.175: As1 IPCP:    PrimaryDNS 5.5.5.1 (0x810605050501)
 *Mar  1 00:14:28.175: As1 IPCP:    SecondaryDNS 5.5.5.2 (0x830605050502)
 *Mar  1 00:14:28.311: As1 IPCP: I CONFREQ [ACKrcvd] id 9 len 22
 *Mar  1 00:14:28.311: As1 IPCP:    Address 10.1.1.2 (0x03060A010102)
 *Mar  1 00:14:28.311: As1 IPCP:    PrimaryDNS 5.5.5.1 (0x810605050501)
 *Mar  1 00:14:28.311: As1 IPCP:    SecondaryDNS 5.5.5.2 (0x830605050502)
 *Mar  1 00:14:28.311: As1 IPCP: O CONFACK [ACKrcvd] id 9 len 22
 *Mar  1 00:14:28.311: As1 IPCP:    Address 10.1.1.2 (0x03060A010102)
 *Mar  1 00:14:28.311: As1 IPCP:    PrimaryDNS 5.5.5.1 (0x810605050501)
 *Mar  1 00:14:28.311: As1 IPCP:    SecondaryDNS 5.5.5.2 (0x830605050502)
 *Mar  1 00:14:28.311: As1 IPCP: State is Open

! -- IPCP negotiation is complete

 *Mar  1 00:14:28.311: As1 IPCP: Add link info for cef entry 10.1.1.2
 00:14:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async1, 
changed state to up

Related Information

Updated: Feb 04, 2010
Document ID: 24393