Guest

ISDN, CAS

Configuring PPP Callback Over ISDN

Cisco - Configuring PPP Callback Over ISDN

Document ID: 9575

Updated: Nov 03, 2005

   Print

Introduction

This document provides a sample configuration for Point-to-Point Protocol (PPP) callback over Integrated Services Digital Network (ISDN). You can use Callback for:

  • Consolidation and centralization of phone billing.

  • Cost savings on toll calls.

  • Access control.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco IOS® Software Release 11.0(3) or later.

  • Cisco 3640 (maui-nas-04) with Cisco IOS Software Release 12.0(5)XK1.

  • Cisco 1604 (maui-soho-01) with Cisco IOS Software Release 12.0(4)T.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Background Information

In this sample configuration, callback uses PPP and the facilities that RFC 1570 leavingcisco.com specifies. ISDN PPP callback completion occurs in this order:

  1. Router A brings up a circuit-switched connection to Router B.

  2. Routers A and B negotiate PPP Link Control Protocol (LCP). Router A can request a callback or Router B can initiate a callback.

  3. Router A authenticates itself to Router B through PPP Password Authentication Protocol (PAP) or Challenge Handshake Authentication Protocol (CHAP). Router B can optionally authenticate to Router A.

  4. Both routers drop the circuit-switched connection.

  5. Router B brings up a circuit-switched connection to Router A.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup tool

Network Diagram

This document uses this network setup:

isdn-ppp-callback.gif

Configurations

This document uses these configurations:

maui-soho-01: callback client
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local

!--- Basic AAA configuration for PPP calls.

!
username maui-nas-04 password 0 happy

!--- Username for remote router (maui-nas-04) and shared secret password.
!--- Shared secret (for CHAP authentication) must be the same on both sides.

username admin password 0 <deleted>
!
ip subnet-zero
!
isdn switch-type basic-ni
!
interface Ethernet0
 ip address 172.22.85.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
 ip address 172.22.82.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer map ip 172.22.82.1 name maui-nas-04 20007

!--- Dialer map statements for the remote router.
!--- The name must match the name that the remote router uses to identify itself.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 20009
 ppp callback request

!--- Request PPP callback from the server.

 ppp authentication chap

!--- Use CHAP authentication.

!
no ip http server
ip classless
ip route 172.22.80.0 255.255.255.0 172.22.82.1
!
dialer-list 1 protocol ip permit

!--- Interesting traffic definition.
!--- Apply this to BRI0 with dialer-group 1.

line con 0
 transport input none
 stopbits 1
line vty 0 4
!
end

maui-nas-04: callback server
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-04
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin password <deleted>
username maui-soho-01 password happy

!--- Username for remote router (maui-soho-01) and shared secret password.
!--- Shared secret(for CHAP authentication) must be the same on both sides.

!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
process-max-time 200
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 10

!--- Assign BRI 1/1 to the rotary-group 10.
!--- Rotary-group properties are defined in interface Dialer 10.

 isdn switch-type basic-ni
 isdn spid1 20007
!
interface dialer10

!--- Interface for the dialer rotary-group 10 configuration.

 ip address 172.22.82.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer callback-secure 

!--- Disconnect calls that are not properly configured for callback.
!--- Disconnects any unconfigured dial-in users. 

dialer map ip 172.22.82.2 name maui-soho-01 class dial1 20009

!--- Dialer map statements for the callback.
!--- The name must match the name that the remote router uses to identify itself.
!--- Use map-class dialer dial1 for this connection.

 dialer-group 1
 ppp callback accept

!--- Allows the interface to accept a callback request to a remote host.

 ppp authentication chap
!
ip classless
ip route 172.22.85.0 255.255.255.0 172.22.82.2
no ip http server
!
map-class dialer dial1

!--- The dialer map statement uses this map class for the callback.

 dialer callback-server username

!--- Use authenticated username to identify return call dial string.

dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line 65 70
line aux 0
line vty 0 4
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

  • show dialer interface type number —displays general diagnostic information for interfaces that you configure for dial-on-demand routing (DDR). The source and destination addresses of the packet that initiated the dialing are shown in the dial reason line. This command also displays the connection timers.

  • show isdn status—ensures that the router properly communicates with the ISDN switch. In the output, verify that Layer 1 Status is ACTIVE, and that the Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED appears. This command also displays the number of active calls.

  • dialer enable-timeout seconds —enables the timeout of the callback server, and determines the time between call call disconnect and callback initiation.

  • dialer hold-queue—allows the callback client and server to hold packets destined to the remote destination until the connection is made.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug ppp [ packet | negotiation | error | authentication ]—displays information on traffic and exchanges in an internetwork that implements PPP.

    • packet —displays PPP packets being sent and received. (This command displays low-level packet dumps.)

    • negotiation —displays PPP packets transmitted during PPP startup, where PPP options are negotiated.

    • error —displays protocol errors and error statistics associated with PPP connection negotiation and operation.

    • authentication — displays authentication protocol messages, and includes Challenge Handshake Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges.

  • debug isdn q931—shows call setup and tear down of the ISDN network connection (Layer 3).

  • debug isdn q921—shows data link layer messages (Layer 2) on the D channel between the router and the ISDN switch. Use this debug command if the show isdn status command does not display Layer 1 and Layer 2 up.

  • debug dialer [ events | packets ]—displays DDR debugging information about the packets received on a dialer interface.

Sample debug Output


!--- maui-soho-01 (callback client:172.22.82.2) pings maui-nas-04. 
!--- (Callback server:172.22.80.4 - Ethernet interface).
!--- and starts the callback process.
!--- Debugs are collected on maui-soho-01.



maui-soho-01#debug dialer events 
maui-soho-01#show debugging 
Dial on demand: 
  Dial on demand events debugging is on
maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   *Mar 8 23:13:02.117: BRI0 DDR: Dialing cause ip (s=172.22.82.2, d=172.22.80.4)    
   *Mar 8 23:13:02.117: BRI0 DDR: Attempting to dial 20007 
   *Mar 8 23:13:02.333: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:02.353: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.417: BRI0:1 DDR: Callback negotiated - waiting for
    server disconnect 
   *Mar 8 23:13:02.493: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down.    
   *Mar 8 23:13:02.509: DDR: Callback client for maui-nas-04 20007 created 
   *Mar 8 23:13:02.509: isdn_call_disconnect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.513: BRI0:1 DDR: disconnecting call.... 
   Success rate is 0 percent (0/5) 

   
!--- A few seconds later, maui-soho-01 receives the callback from maui-nas-04. 

   
   maui-soho-01# 
   *Mar 8 23:13:17.537: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:17.553: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:19.697: BRI0:1 DDR: No callback negotiated 
   *Mar 8 23:13:19.717: BRI0:1 DDR: dialer protocol up 
   *Mar 8 23:13:19.717: BRI0:1 DDR: Callback received from maui-nas-04 20007 
   *Mar 8 23:13:19.721: DDR: Freeing callback to maui-nas-04 20007 
   *Mar 8 23:13:20.697: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
       changed state to up 
   *Mar 8 23:13:23.553: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 
       20007 maui-nas-04 
   
!--- Verifies that the connection was successful


maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   !!!!! 
   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

Related Information

Updated: Nov 03, 2005
Document ID: 9575