Guest

ISDN, CAS

Configuring BRI Backup Interface with Dialer Profiles

Cisco - Configuring BRI Backup Interface with Dialer Profiles

Document ID: 5721

Updated: Sep 14, 2005

   Print

Introduction

This configuration demonstrates the use of an ISDN Basic Rate Interface (BRI) circuit to back up a leased line, WAN, or serial connection.

Before You Begin

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

This document is not restricted to specific software and hardware versions.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Background Theory

The backup interface command places the interface into standby mode until such time as the primary interface goes down. For more information on the backup interface feature, refer to Evaluating Backup Interfaces, Floating Static Routes, and Dialer Watch for DDR Backup.

This example uses dialer profiles with the backup interface feature. Using the backup interface command forces the configured physical or logical interface to be in standby mode. With dialer profiles, only the logical (dialer interface) is placed in the standby mode while the physical interface (BRI) can still be used for other connections by making it a member of another pool. For more information on dialer profiles, refer to Configuring ISDN DDR with Dialer Profiles.

Configure

In this section, you are presented with the information to configure the features described in this document.

Configuring dial-on-demand routing (DDR) backup involves these distinct steps:

  1. Configure DDR. You can use either legacy DDR (dialer maps) or dialer profiles. This configuration employs dialer profiles. Verify that your DDR connection functions correctly before implementing the backup configuration. This allows you to verify that the dial method used, the Point-to-Point Protocol (PPP) negotiation, and authentication are successful before configuring backup. For a dialer map based backup configuration, refer to the document DDR Backup using BRIs and the Backup Interface Command.

  2. Configure one of the routers to initiate the DDR connection when the primary link fails. This configuration uses a backup interface command to trigger the dialout.

  3. Define the interesting traffic that will trigger the backup connection when the primary link fails.

We recommend that you refer to the document Configuring and Troubleshooting DDR Backup for more information.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

bri-to-bri-backup.gif

Configurations

This configuration uses a BRI circuit to back up a serial link. It also uses the Open Shortest Path First (OSPF) routing protocol between the two routers. Once the backup connection is activated, you must ensure that the routing table is updated to use the new backup link. Only one side (maui-soho-01) is configured to dial out. The other side (maui-nas-05) is configured to only accept the call.

In this configuration we have a Cisco 1604 router connected to a Cisco 3640 router using a serial connection. Both routers are also equipped with BRI interfaces that are used for the backup link. The Cisco 1604 is running Cisco IOS® Software Release 12.1(5)T and the Cisco 3640 is using Cisco IOS 12.1(2).

Note: Configure the DDR connection (dialer 1 with BRI0) and verify that it is working properly before you configure the backup interface and backup delay commands. This will allow you to effectively manage troubleshooting dialer profiles, ISDN, PPP and authentication issues before you configure the backup.

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret(used for
!--- CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary Interface

 backup delay 10 30

!--- Backup link will be activated 10 seconds after primary link goes down.
!--- Backup link will be deactivated 30 seconds after primary link is restored.

 backup interface Dialer1

!--- Interface Dialer 1 will provide backup. Dialer 1 will be placed in Standby
!--- until the primary link goes down.

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 no fair-queue
 clockrate 64000
 ppp authentication chap
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 10

!--- Assign BRI0 as member of dialer pool 10.
!--- Dialer pool 10 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112
 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- This interface will be in standby until the primary link is down.

 ip address 172.20.10.2 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer pool 10

!--- Defines Dialer pool 10.
!--- BRI 0 is a member of this pool.

 dialer remote-name maui-nas-05

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- The link will be disconnected if there is no interesting traffic for 900 secs.
!--- Since OSPF hellos are interesting traffic, this will reset the idle timeout
!--- and cause the link to stay up until the primary link is restored and the dialer
!--- returns to standby mode.

 dialer string 5552222

!--- Defines the destination routers phone number.

 dialer load-threshold 80 outbound

!--- This sets the outbound load level for traffic at which 
!--- additional connections will be added to the MP bundle load level.
!--- Values range from 1 (unloaded) to 255 (fully loaded). The threshold
!--- in this case is 80/255=32%.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
router ospf 5

!--- OSPF configuration. You can use any routing protocol here without any other
!--- changes to the configuration.

 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.
!--- OSPF hello packets will trigger the dial.

!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!
end

Note the following points in the configuration of maui-soho-01:

  • The backup link uses dialer profiles. This allows the backup interface (Dialer 1) to be in standby mode while the physical interface (BRI 0) is not. This allows one to use the physical interface (by making it a member of different dialer pool) while the primary link is active. For more information on dialer profiles, refer to the document Configuring and Troubleshooting Dialer Profiles.

  • The router uses OSPF as the routing protocol. You can use any other routing protocol (for example, RIP, EIGRP) here as well. Refer to the appropriate routing protocol configuration guide IPC: Part 2: IP Routing Protocols. Make sure that you include the primary interface network and backup interface network in the routing protocol configuration so that information can be propagated by the routing protocol. If you wish to use static routes instead of a routing protocol, create a static route with the next hop being the remote BRI interface (you may have to make it a floating static route depending on the scenario).

  • Any IP traffic will trigger the dial (based on dialer-list 1 and dialer-group 1). This works well in a backup interface DDR backup environment since the backup link will be in standby mode and unable to dial when the primary is up anyway. Since the backup link requires interesting traffic to dial the backup link, verify that you do have a traffic source generating interesting traffic. In this example, OSPF hello packets will trigger the dial. If you are not using a routing protocol you can use ICMP pings to dial the backup link. Adjust the interesting traffic depending on your needs.

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret
!---(used for CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0
 ip unnumbered Loopback0

!--- Unnumbered to the Loopback 0 address.

 encapsulation ppp
 dialer pool-member 20

!--- Assign BRI0 as member of dialer pool 20.
!--- Dialer pool 20 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223
 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!

! <<-- Unused interface configurations have been removed.

!
interface Serial2/0

!--- Primary interface.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
!

! <<--Unused interface configurations have been removed.

!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- Notice that there is no dialer string on this router. This prevents the NAS
!--- from attempting to dialout using the backup circuit when the primary is up.

 ip address 172.20.10.1 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer remote-name maui-soho-01

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer pool 20

!--- Defines dialer pool 20.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- This is equal to the idle timeout set on maui-soho-01.

 dialer max-call 4096
 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate

!--- Transmit ospf default information. 
!--- This may be required for remote router to use the BRI DDR link.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Verify the following points in the configuration of the server maui-nas-05 (3640):

  • The configuration is similar to any dialin configuration. As far as the NAS is concerned the backup link is just another incoming call.

  • The dialer interface does not have a dialer string, hence cannot dialout.

  • All traffic is interesting. Since the backup link cannot dialout anyway (see previous bullet) this is acceptable. If you make the interesting traffic more restrictive (for example, the routing protocol is uninteresting), then there is the possibility that the NAS could disconnect the call if no interesting traffic across the link. In backup scenarios it is best to let one side (either the dialout or dialin side) control the backup link to avoid link instability.

Testing the Backup Link

The backup interface requires that the primary interface protocol be down before the backup interface is even brought out of standby mode. Hence, it is not possible to test the backup link without physically brining the primary link down. The options are:

  • Use the shutdown command to turn off the primary interface. However, do not use the shutdown command on the router with the backup interface command configured. This will not cause the Cisco IOS software to dial the backup link. You can activate the backup by shutting down the primary interface on the router that does not have the backup interface command. In our scenario, the backup interface command is configured on maui-soho-01 (1600). Therefore, performing a shutdown command on the primary interface of maui-nas-05 (3640) will activate the backup link.

  • Physically bring down the primary connection by unplugging cables or some equivalent method in order to bring up the backup interface.

Show Commands

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

  • show isdn status - Ensure that the router is properly communicating with the ISDN switch. In the output, verify that Layer 1 Status is ACTIVE, and that the Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED appears. This command also displays the number of active calls.

  • show ip interface brief - This will show dialer 1 (on maui-soho-01) in standby mode. Using dialer 1 as the backup interface means the physical interface (BRI0) is not dedicated to the backup. Therefore, BRI 0 can be used for normal DDR while the primary link is up.

Sample Show Output

The following outputs show the routing table on the client side. The output below shows the routing table with the primary link active.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
O       172.20.10.0 [110/1849] via 192.168.10.1, 00:00:10, Serial0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 00:00:11, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 00:00:11, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:00:11, Serial0

The output of show ip route (shown above) displays the OSPF routes learned from the peer using the primary link (Serial 0). Now let's bring down the primary link and activate the backup link.

After the backup link is activated, the OSPF table is exchanged and the new routes using the backup link is installed. Traffic now flows across the backup link.

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, Dialer1
C       172.20.10.1/32 is directly connected, Dialer1
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:00:01, Dialer1
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:00:02, Dialer1
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:00:02, Dialer1

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Debug Commands

Before issuing debug commands, please see Important Information on Debug Commands.

  • debug dialer - This is used to display DDR information about the packets received on the dialer interface.

  • debug isdn events - This is used to see ISDN activity occurring on the user side of the ISDN interface.

  • debug isdn q931 - Shows call setup and tear down of the ISDN network connection (Layer 3) between the router and the ISDN switch.

  • debug ppp negotiation - Displays information on PPP traffic and exchanges while negotiating the PPP components including Link Control Protocol (LCP), Authentication, and NCP. A successful PPP negotiation will first open the LCP state, then Authenticate, and finally negotiate NCP.

  • debug ppp authentication - Displays the PPP authentication protocol messages, including Challenge Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges. If you observe a failure verify that the chap username and password are configured correctly.

  • debug ppp error - This is used to display protocol errors and error statistics associated with PPP connection negotiation and operation.

Troubleshooting DDR Backup

Configure and verify that the DDR connection (Dialer 1 and BRI0) is working properly before you configure the backup interface and backup delay commands. This allows you to verify that dialer profile, ISDN, PPP, and authentication is functioning correctly before configuring a backup. To troubleshoot the DDR link, refer to Dialup Technology: Troubleshooting Techniques.

Now that you have verified that the DDR connection is working properly, you can proceed to the following backup troubleshooting steps outlined below:

  • Bring down the primary link. Do not use the shutdown command on the router with the backup interface command configured. This does not cause the Cisco IOS software to dial the backup link. You can activate the backup by shutting down the primary interface on the router that does not have the backup interface command. In our scenario, the backup interface command is configured on maui-soho-01 (1600). Therefore, performing a shutdown command on the primary interface of maui-nas-05 (3640) activates the backup link. Also, you can physically bring down the primary connection by unplugging cables or some equivalent method in order to bring up the backup interface.

  • You should see a console message indicating that the backup interface (interface dialer 1) is up. This message only appears after the interval time specified by the backup delay command has expired. In this configuration, the backup activation delay is 10 seconds. If you do not see this console message, check the backup delay timer.

    *Mar  1 03:37:31.788: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    *Mar  1 03:37:42.719: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
    
  • Use the show ip route command to view the routing table with the primary link down. You should observe a directly-connected route to Dialer 1. Ping the IP address of the remote router's dialer interface (which is on the same subnet as interface dialer 1). You should see the link dial and connect.

    • If the link does not dial, verify that your interesting traffic definition permits ICMP (pings).

    • If the link is brought up, we can conclude that the problem occurred because there was no traffic destined for that subnet. However, it is not realistic to force the backup link to dial based on a ping to a particular host. To get around this problem you can configure a floating static route for default traffic.

      maui-soho-01(config)#ip route 0.0.0.0 0.0.0.0 172.20.10.1 200 
      

      The above default route has a next-hop address of the remote router's dialer interface and an administrative distance of 200. This floating route allows the router to route packets to the dialer interface if a better default route (that is, with a lower administrative distance) does not exist. Remember that we previously verified that packets routed to the dialer interface cause the link to dial.

  • If the router dials the link, but fails to connect, then it is no longer a DDR backup issue and you should refer to Dialup Technology: Troubleshooting Techniques for further assistance.

Refer to the section Troubleshooting Backup Interface in the document Configuring and Troubleshooting DDR Backup for more troubleshooting information.

Sample Debug Output

The following debug output (from the client) shows the primary link failing and the backup link activating:

Note: Some debug output lines are broken into multiple lines for printing purposes.

maui-soho-01#show debug

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#debug isdn q931
ISDN Q931 packets debugging is on
maui-soho-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-soho-01#debug ppp authentication 
PPP authentication debugging is on
maui-soho-01#
*Mar  1 01:09:24.872: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary link is unplugged.
!--- Refer to the section Testing the Backup Link for the appropriate procedure.

*Mar  1 01:09:24.880: Se0 IPCP: State is Closed
*Mar  1 01:09:24.884: Se0 CDPCP: State is Closed
*Mar  1 01:09:24.888: Se0 PPP: Phase is TERMINATING [0 sess, 0 load]
*Mar  1 01:09:24.892: Se0 LCP: State is Closed
*Mar  1 01:09:24.892: Se0 PPP: Phase is DOWN [0 sess, 0 load]
*Mar  1 01:09:24.908: Se0 IPCP: Remove route to 192.168.10.1
*Mar  1 01:09:24.916: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on Serial0
 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:09:25.864: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
 changed state to down

!--- Primary interface line protocol is down. This must happen before the backup
!--- interface is brought out of standby.

*Mar  1 01:09:34.824: Di1 DDR is shutdown, could not clear interface.
*Mar  1 01:09:34.840: BR0 DDR: rotor dialout [priority]

!--- Note: The backup interface was activated 10 seconds after the primary
!--- link went down. This interval was defined with the backup delay command
!--- in maui-soho-01 (1600).

*Mar  1 01:09:34.848: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=224.0.0.5)

!--- OSPF hellos cause the router to dial.

*Mar  1 01:09:34.852: BR0 DDR: Attempting to dial 5552222

!--- Phone number of the remote router that is dialed.

*Mar  1 01:09:34.876: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0A
*Mar  1 01:09:34.888:         Bearer Capability i = 0x8890
*Mar  1 01:09:34.895:         Channel ID i = 0x83
*Mar  1 01:09:34.903:         Keypad Facility i = '5552222'
*Mar  1 01:09:35.169: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8A
*Mar  1 01:09:35.177:         Channel ID i = 0x89
*Mar  1 01:09:35.415: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8A

!--- Call is connected.

*Mar  1 01:09:35.439: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 01:09:35.447: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 01:09:35.463: BR0:1 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 01:09:35.467: BR0:1 PPP: Phase is ESTABLISHING, Active Open
 [0 sess, 0 load]
*Mar  1 01:09:35.479: BR0:1 LCP: O CONFREQ [Closed] id 14 len 34
*Mar  1 01:09:35.483: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.487: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.491: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.495: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.511: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0A
*Mar  1 01:09:35.566: BR0:1 LCP: I CONFREQ [REQsent] id 6 Len 33
*Mar  1 01:09:35.570: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.574: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.578: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.582: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.590: BR0:1 LCP: O CONFACK [REQsent] id 6 Len 33
*Mar  1 01:09:35.598: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.602: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.606: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.610: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.618: BR0:1 LCP: I CONFACK [ACKsent] id 14 Len 34
*Mar  1 01:09:35.622: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.626: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.630: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.637: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.641: BR0:1 LCP: State is Open
*Mar  1 01:09:35.645: BR0:1 PPP: Phase is AUTHENTICATING, by both
 [0 sess, 1 load]

!--- PPP authentication begins.

*Mar  1 01:09:35.649: BR0:1 CHAP: O CHALLENGE id 6 Len 33 from "maui-soho-01"

!--- This is the username used for outgoing CHAP challenge. The remote router
!--- must have this username configured along with shared secret.

*Mar  1 01:09:35.657: BR0:1 CHAP: I CHALLENGE id 6 Len 32 from "maui-nas-05"

!--- This is the username for incoming CHAP challenge.
!--- This username must be locally configured.

*Mar  1 01:09:35.760: BR0:1 CHAP: O RESPONSE id 6 Len 33 from "maui-soho-01"
*Mar  1 01:09:35.804: BR0:1 CHAP: I SUCCESS id 6 Len 4
*Mar  1 01:09:35.808: BR0:1 CHAP: I RESPONSE id 6 Len 32 from "maui-nas-05"
*Mar  1 01:09:35.820: BR0:1 CHAP: O SUCCESS id 6 Len 4

!--- CHAP authentication is successful.

*Mar  1 01:09:35.828: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
*Mar  1 01:09:35.844: Di1 DDR: Authenticated host maui-nas-05 with no matching
 dialer map
*Mar  1 01:09:35.848: Di1 PPP: Phase is UP [0 sess, 1 load]
*Mar  1 01:09:35.856: Di1 IPCP: O CONFREQ [Closed] id 6 Len 10
*Mar  1 01:09:35.860: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.872: Di1 CDPCP: O CONFREQ [Closed] id 6 Len 4
*Mar  1 01:09:35.876: BR0:1 MLP: maui-nas-05, multilink up, first link
*Mar  1 01:09:35.884: BR0:1 IPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.887: BR0:1 IPCP: Redirect packet to Di1
*Mar  1 01:09:35.891: Di1 IPCP: I CONFREQ [REQsent] id 6 Len 10
*Mar  1 01:09:35.895: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.903: Di1 IPCP: O CONFACK [REQsent] id 6 Len 10
*Mar  1 01:09:35.907: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.911: BR0:1 CDPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.915: BR0:1 CDPCP: Redirect packet to Di1
*Mar  1 01:09:35.919: Di1 CDPCP: I CONFREQ [REQsent] id 6 Len 4
*Mar  1 01:09:35.927: Di1 CDPCP: O CONFACK [REQsent] id 6 Len 4
*Mar  1 01:09:35.931: Di1 IPCP: I CONFACK [ACKsent] id 6 Len 10
*Mar  1 01:09:35.935: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.939: Di1 IPCP: State is Open

!--- IPCP state is open and route will be installed.

*Mar  1 01:09:35.951: Di1 CDPCP: I CONFACK [ACKsent] id 6 Len 4
*Mar  1 01:09:35.955: Di1 CDPCP: State is Open
*Mar  1 01:09:35.959: Di1 DDR: dialer protocol up
*Mar  1 01:09:35.971: Di1 IPCP: Install route to 172.20.10.1

!--- Route to remote side is installed.

*Mar  1 01:09:36.840: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
*Mar  1 01:09:36.844: Di1 LCP: Not allowed on a Dialer Profile
*Mar  1 01:09:36.848: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
*Mar  1 01:09:41.411: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552222
 maui-nas-05

!--- Connection is up.

*Mar  1 01:09:44.931: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on
 Dialer1 from LOADING to FULL, Loading Done

!--- OSPF database exchange is complete.

Related Information

Updated: Sep 14, 2005
Document ID: 5721