Guest

ISDN, CAS

Configuring DDR Backup using BRIs and Dialer Watch

Document ID: 5600

Updated: Sep 14, 2005

   Print

Introduction

This document demonstrates the use of an ISDN Basic Rate Interface (BRI) line to back up a leased line, WAN, or serial connection using the dialer watch feature. For more information on the features of dialer watch, refer to Evaluating Backup Interfaces, Floating Static Routes, and Dialer Watch for DDR Backup.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • A Cisco 1604 with 1 BRI U interface running Cisco IOS® Software Release 12.1(5)T.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Background Theory

This example uses legacy dial-on-demand routing (DDR), which uses the dialer map command for the BRI connection. You can also use dialer profiles instead of legacy DDR (dialer maps). For more information on dialer profiles refer to Configuring ISDN DDR with Dialer Profiles.

Configuring DDR backup involves two distinct steps:

  1. Configure the DDR with either legacy DDR or dialer profiles. Verify that your DDR connection functions correctly before implementing the backup configuration. This will allow you to verify the dial method used, the Point-to-Point Protocol (PPP) negotiation, and authentication are successful before configuring backup.

  2. Configure the router to initiate the backup DDR connection when the primary link fails. This configuration uses the dialer watch feature to trigger the dialout.

For more information on the steps necessary to configure backup refer to the document Configuring and Troubleshooting DDR Backup

Dialer Watch Operation

With dialer watch, the router monitors the existence of a specified route and if that route is not present, it initiates dialing of the backup link. Unlike the other backup methods (such as backup interface or floating static routes) dialer watch does not require interesting traffic to trigger the dial. The process used by dialer watch is described below:

  • When a watched route is deleted, dialer watch checks for at least one valid route for any of the IP addresses or networks being watched.

    • If there is no valid route, the primary line is considered down and unusable.

      • Dialer watch then initiates the call, and the routers connect and exchange routing information. All traffic for the remote network will now use the backup link.

    • If there is a valid route for at least one of the watched IP networks defined and the route is pointing to an interface other than the backup interface configured for dialer watch, the primary link is considered up and dialer watch does not initiate the backup link.

  • After the backup link is up, the primary link is checked again at the expiration of each idle timeout. If the primary link remains down, the idle timer is reset. Since the router should periodically check whether the primary link has been reestablished, configure a small value for the dialer idle-timeout. When the primary link is reestablished, the routing protocol will update the routing table and all traffic should once again pass on the primary link. Since traffic will no longer pass across the backup link, the idle timeout will expire and router will deactivate the backup link.

    Note: When defining interesting traffic, deny the routing protocol traffic to prevent periodic hellos from resetting the idle timeout.

  • If the primary link is reactivated, the secondary backup link will be disconnected. However a disable timer can be implemented so that there is a delay before the backup link is dropped once the primary link recovers. This delay timer is started when the idle timer expires, and the primary route is found to be up. This delay timer can ensure stability, especially for flapping interfaces or interfaces experiencing frequent route changes.

For more information on the features of dialer watch, refer to Evaluating Backup Interfaces, Floating Static Routes, and Dialer Watch for DDR Backup .

Configure

In this section, you are presented with the information to configure the features described in this document.

Network Diagram

This document uses the network setup shown in the diagram below.

bri-backup-map-watch.gif

Configurations

This configuration uses a BRI circuit to backup a serial link. This configuration is also using the Open Shortest Path First (OSPF) routing protocol between the two routers. Once the backup connection is activated, you must ensure that the routing table is updated to use the new backup route.

For more information on command conventions, see the Cisco Technical Tips Conventions.

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1546 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for ppp calls.

enable secret 5 <deleted>!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret.
!--- Shared secret (used for CHAP) must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary link

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link)

 encapsulation ppp
 dialer idle-timeout 30

!--- Idle timeout (in seconds) for this backup link.
!--- Dialer watch checks the status of the primary link every time the
!--- idle-timeout expires.

 dialer watch-disable 15

!--- Delays disconnecting the backup interface for 15 seconds after the
!--- primary interface is found to be up, that is 15 seconds after the idle 
!--- timeout expired after the primary link came UP.

 dialer load-threshold 1 outbound

!--- This sets the load level for traffic at which additional connections
!--- will be added to the Multilink PPP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

!--- Dialer map for the BRI interface of the remote router.

 dialer map ip 172.22.53.0 name maui-nas-05 broadcast 5551111

!--- Map statement for the route/network being watched by the
!--- dialer watch-list command
!--- This address must exactly match the network configured with the
!--- dialer watch-list command.
!--- When the watched route disappears, this dials the specified
!--- phone number.  

 dialer watch-group 8

!--- Enable dialer watch on this backup interface.
!--- Watch the route specified with dialer watch-list 8.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required. 
!--- In such cases, omit the above two commands.

 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Enable Multilink.

!
router ospf 5
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer watch-list 8 ip 172.22.53.0 255.255.255.0

!--- This defines the route(s) to be watched.
!--- This exact route (including subnet mask) must exist in the 
!--- routing table. Use the dialer watch-group 8 command to apply this
!--- list to the backup interface.

access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any

!--- Mark OSPF as uninteresting.
!--- This will prevent OSPF hellos from keeping the link up.

access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to BRI0 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!         
end

maui-nas-05 (3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted> !
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret.
!--- Shared secret(used for CHAP authentication) must be the same on
!--- both sides.

!
ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0

!--- Interface for backup link.

 ip address 172.20.10.1 255.255.255.0
 encapsulation ppp
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- This is the dialer map with IP address and authenticated username
!--- for the remote destination. The name should match the authentication
!--- username provided by the remote side. The dialer map statement is
!--- used even though this router is not dialing out
!--- (that is, the phone number is not specified).

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required.
!--- In such cases, omit the above two commands.

 ppp authentication chap
 ppp multilink
!

!--- Output removed.

!
interface Serial2/0

!--- Primary link.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- This defines all IP traffic as interesting. OSPF does not need 
!--- to be marked uninteresting since this link does not dial out.
!--- Adjust the interesting traffic definition depending on your needs.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

Note: The configuration of maui-nas-05 does not include any backup related commands. From the point of view of maui-nas-05, the backup link is just another dialin client. This can simplify the configuration of the central site in situations where many devices establish a backup link to the same central site. In backup scenarios, it is ideal to have only one side initiate the dial, while the other side only accepts calls.

Dialer Watch Commands

The following is a list of the commands available for dialer watch. Some of these commands have been included in the configuration above, while others are provided for reference.

  • dialer watch-list group-number ip ip-address address-mask : Defines the IP addresses or networks to be watched. The address or network (with the correct mask) that is configured must exist in the routing table. You can also watch multiple routes with the dialer watch-list command. An example is shown:

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0       
    
    
  • dialer watch-group group-number : Enable dialer watch on the backup interface. The group number used here matches the group number of the dialer watch-list command defining the routes to be watched. The dialer watch-group command with a particular group number can only be configured on one interface. This means that the router cannot use multiple interfaces to provide backup for a particular route. However, one interface can have multiple dialer watch-group commands, with different group-numbers. Therefore, one interface can be used to provide backup for multiple routes.

  • dialer watch-disable seconds : Apply a disable delay time to the interface. After the primary interface recovers, this delay prevents disconnecting the backup interface for the specified time period. This delay timer is started when the idle timer expires, and the status of the primary route is checked and found to be up. This delay can ensure stability, especially for flapping interfaces or interfaces experiencing frequent route changes.

  • dialer watch-list group-number delay route-check initial seconds : This command enables the router to check whether the primary route is up after the initial startup of the router is complete and the timer (in seconds) expires. Without this command, dialer watch is only triggered when the primary route is removed from the routing table. If the primary link fails to come up during initial startup of the router, the route is never added to the routing table and hence cannot be watched. Therefore, with this command, dialer watch will dial the backup link in the event of a primary link failure during the initial start up of the router.

Verify

For more information, refer to Using the show isdn status Command for BRI Troubleshooting.

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter took, which allows you to view an analysis of show command output.

  • show dialer [interface type number] - Displays general diagnostic information for interfaces configured for DDR and displays the timer's configuration and the time before the connection times out. You should verify the following messages:

    • "Dialer state is data link layer up" - The dialer came up properly.

      • "Physical layer up" - The line protocol came up, but the Network Control Protocol (NCP) did not.

    • "Dial reason" This displays the source and destination addresses of the packet that initiated the dialing.

  • show isdn status - Ensure that the router is properly communicating with the ISDN switch. This command also displays the number of active calls You should verify the following messages:

    • "Layer 1 Status is ACTIVE",

    • "Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED"

Sample Show Output

The routing table of the client, maui-soho-01 (1600), with the primary link functioning is shown below:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.10.0 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 02:48:10, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 02:48:10, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 02:48:10, Serial0

The output of show ip route shown above, displays the OSPF routes learned from the peers using the primary link (serial 0). Notice that the route being watched (172.22.53.0 with mask 255.255.255.0) exists in the routing table. This must be verified for dialer watch to function correctly.

Now we bring down the primary link and activate the backup link. After the backup link is activated, the OSPF table is exchanged and the new routes using the backup link is installed. Traffic now passes across the backup link.

An example of this is shown below:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:26, BRI0
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:27, BRI0
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:27, BRI0

The output above shows that the routing table has been updated and all traffic will use the backup link (BRI0)

The show dialer command can be used to verify that the DDR interface came up properly. Notice that the BRI interface was dialed because the router detected that the watched route was lost.

maui-soho-01#  show dialer

BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
5551111                 10          0    00:01:49       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect 11 secs
Connected to 5551111 (maui-nas-05)

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Troubleshoot

Troubleshooting Dialer Watch

Configure and verify that the DDR connection is working properly before you configure dialer watch. This will help you to isolate and troubleshoot DDR issues before you tackle backup related problems. When configuring Dialer Watch it is recommenced that you use Cisco IOS® Software Release 12.1(7) or higher. We will now discuss several problems and possible solutions:

Problem: The router does not dial the backup link when the primary link goes down.

Possible Solution #1: Use the show ip route command to verify that the route you are watching exists in the routing table. The route configured for dialer watch must exactly match the one in the routing table. This includes verifying that the network as well as the masks are identical. For example, if the routing table shows 10.0.0.0/8 and you use dialer watch-list 1 ip 10.0.0.0 255.255.255.0 (which is 10.0.0.0/24), the dialer watch feature will not be able to detect that 10.0.0.0/8 is no longer in the routing table.

Possible Solution #2: Verify there are two dialer map statements on the backup interface.

  • There should be one map statement for the route/network specified by the dialer watch-list command

  • There should be one map statement for the IP address of the remote router's interface.

Possible Solution #3: Configure the command dialer watch-list group-number delay route-check initial seconds . Refer to the section Dialer Watch Commands for more information.

Problem: The backup link is established but no routing information is transmitted across the backup link.

Possible Solution: Verify that the backup interface IP network is included in the routing protocol configuration

Problem: The backup link is not deactivated when the primary link recovers.

Note: With dialer watch, interesting traffic is only used to control the idle-timeout which in turn controls the interval used to poll the status of the primary route.

Possible Solution #1: Lower the dialer idle-timeout. The default is 120 seconds, but you may wish to lower this value depending on your needs.

Possible Solution #2: Use the show dialer command to verify the idle timeout is not being reset.

Change your interesting traffic definition (configured with the dialer-list command) to be more restrictive. Routing Protocol traffic should be marked uninteresting.

As a last resort, you can configure all IP traffic as uninteresting using the command dialer-list 1 protocol ip deny. With this interesting traffic definition, the idle timeout will never be reset, and the router will check the status of the primary link at the specified interval.

Possible Solution #3: Check to make sure that the backup link is less desirable than the primary link from the perspective of the routing protocol in use. This is so that when the primary link recovers, the dynamic routing protocol will prefer the primary over the backup link and not load balance across the two links. Failure to do this can cause the backup link to stay up persistently. Use show ip route to determine if the router is using both the primary and backup links to route traffic between the routers. In such a case the router will keep identical duplicate routes; one for the primary and one for the backup link You can use the any of the following methods to ensure that the backup link is less desirable from the perspective of the routing protocol: bandwidth, delay, or distance. Refer to the Cisco IOS software Command Reference for more details.

For general ISDN Layers 1,2 and 3 Troubleshooting refer to the document Using the show isdn status Command for BRI Troubleshooting.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug dialer - This is used to display DDR information about the packets received on a dialer interface.

  • debug isdn q931 - This shows call setup and tear down of the ISDN network connection (Layer 3) between the router and ISDN switch.

  • debug ppp negotiation - This displays information on PPP traffic and exchanges while negotiating the PPP components including link control protocol (LCP), authentication, and NCP. A successful PPP negotiation will first open the LCP state, then authenticate, and finally negotiate the NCP.

  • debug ppp authentication - This displays the PPP authentication protocol messages, including Challenge Handshake Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges. If you observe a failure verify that the chap username and password are configured correctly.

  • debug ppp error - This displays protocol errors and error statistics associated with PPP connection negotiation and operation.

Sample Debug Output

The debug dialer output below shows the primary link failing and dialer watch recognizing the lost route. The router then initiates the backup link. After each time the idle-timeout expires, the router checks whether the primary link is down. If the primary link is found to be up, dialer watch disconnects the backup link after the disable timer expires. In the debugs, pay attention to the timestamp in each message as they can provide information on the various timers and idle timeouts that are active.

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#
03:47:07: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is brought down

03:47:07: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from FULL to DOWN,
 Neighbor Down: Interface down or detached
03:47:07: DDR: Dialer Watch: watch-group = 8

!--- Use dialer watch-group 8. 

03:47:07: DDR:    network 172.22.53.0/255.255.255.0 DOWN,
03:47:07: DDR:    primary DOWN

!--- The primary network is down.

03:47:07: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

!--- Dialing Reason is that the primary route is down.

03:47:07: DDR: Dialer Watch: watch-group = 8, 
03:47:07: DDR:    dialing secondary by dialer map 172.22.53.0 on BR0

!--- Indicates which dialer map statement is used for the dialout.

03:47:07: BR0 DDR: Attempting to dial 5551111
03:47:08: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:47:08: BR0:1 DDR: Dialer Watch: resetting call in progress
03:47:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to down
03:47:08: BR0:1 DDR: dialer protocol up
03:47:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state
 to up
03:47:14: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 maui-nas-05

!--- BRI link is connected.

03:47:17: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on BRI0 from LOADING to FULL,
 Loading Done
03:47:38: BR0:1 DDR: idle timeout

!--- Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:47:38: DDR: Dialer Watch: watch-group = 8
03:47:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:47:38: DDR:    primary DOWN

!--- The primary network is still down.

03:48:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:48:08: DDR: Dialer Watch: watch-group = 8
03:48:08: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:48:08: DDR:    primary DOWN

!--- The primary network is still down.

...
...
...
03:50:38: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:50:38: DDR: Dialer Watch: watch-group = 8
03:50:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:50:38: DDR:    primary DOWN

!--- The primary network is still down.

03:50:44: %LINK-3-UPDOWN: Interface Serial0, changed state to up

!--- Primary link is re-established.

03:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to up
03:50:54: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from LOADING
 to FULL, Loading Done
03:51:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.


!--- The router will check to see if the primary link has come up.

03:51:08: DDR: Dialer Watch: watch-group = 8
03:51:08: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists. 

03:51:08: DDR:    primary UP

!--- The primary network is UP. Dialer watch will initiate a disconnect of


!--- the backup link.

03:51:08: BR0:1 DDR: starting watch disable timer

!--- Delays disconnecting the backup interface after the primary interface recovers.
!--- This timer is 15 seconds as configured with the dialer watch-disable 15 command

03:51:23: BR0:1 DDR: watch disable timeout

!--- 15 second disconnect delay expires. The link will be brought down.

03:51:23: BR0:1 DDR: disconnecting call

!--- Backup link is disconnected.

03:51:23: BR0:1 DDR: Dialer Watch: resetting call in progress
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP

!--- The primary network is UP.

03:51:23: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 5551111
 maui-nas-05, call lasted 255 seconds
03:51:23: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
03:51:23: BR0:1 DDR: disconnecting call
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP
03:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
maui-soho-01#

Related Information

Updated: Sep 14, 2005
Document ID: 5600