Guest

ISDN, CAS

Using an ADTRAN Terminal Adapter with Cisco Routers

Document ID: 28080

Updated: Nov 19, 2007

   Print

Introduction

ADTRAN ISDN terminal adapters (TAs) can be used to provide basic rate interface (BRI) connectivity to routers without BRI interfaces. The TA (connected to the serial port) terminates the BRI call and transmits the data to the router as a synchronous data stream.

This document outlines how to ADTRAN ISU™ TAs to work with Cisco routers. We recommend that you refer to the product documentation on the ADTRAN leavingcisco.com web site prior to proceeding.

Prerequisites

Requirements

Verify that the BRI circuit is working correctly. You may wish to use the circuit on a router with a BRI port to test the circuit prior to deploying it in this configuration. Also verify and test the peer device to ensure that it functions properly.

For some applications, the ADTRAN ISU must support synchronous Multilink PPP (MPPP). The ISUs that support synchronous MP include the ISU Express (Part Numbers 1200.081L5, 1200.081L6, and 1202.081 L6), ISU 2x64 (1200.051L1 and 1200.051L2), and the second generation ISU 128 (1202.029L2 and 1202.029L3.)

To use MPPP on a Cisco router, the software revision of the ISU must be up to date. A list of minimum software revisions is presented by product in the table below:

Unit Part Number Software Revision
ISU 128 1202.029 E.00
ISU 2x64 1200.051 D.00 or G.00
ISU Express L6 1200.081L6 K.28
ISU Express L6 1202.081L6 D.43

Note: Since requirements may change, verify the firmware requirements with Using ADTRAN ISUs With Cisco Routers leavingcisco.com.

Components Used

The information in this document is based on the software and hardware versions below.

  • A router with a synchronous serial interface. The serial interface can be built-in or on a WIC/Network Module.

  • There are no Cisco IOS® software restrictions for this configuration.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Dialing Method

There are three methods that can be used to initiate a dial by the TA:

  • V.25 or V.25bis dialing

  • Data Terminal Ready (DTR) dialing

  • Keypad dialing

V.25 or V.25bis Dialing

Using this method, the router sends a phone number to the TA. This method allows the router to place and receive ISDN calls. To activate V.25/V,.25bis dialing, you must configure the dialer in-band command on the router interface. For example:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast 5551212&5551213
   ppp authentication chap
   dialer-group 1

You should configure the ISU for V.25bis dialing and MPPP.

When the router receives interesting traffic, it raises DTR and Request To Send (RTS), which causes the TA to initiate a dial on the first B-channel. However, the router does not ask the TA to initiate the second B-channel connection. In this case, the ADTRAN must be programmed to dial the second B-channel or have the second number passed within the same dialer string. The router serial interface is a Point-to-Point interface and has no idea of the number of B-channels configured on the ADTRAN.

Do not configure the command ppp multilink on the router, since the TA actually handles the multilink connection, while the router need only process the synchronous stream from the TA.

Note: Using multiple dialer maps (as we would on BRI interfaces) does not help for this multilink issue.

DTR Dialing

Using this method, the router can only place calls to one particular phone number, it cannot receive incoming calls. With this method, the phone number(s) of the remote site must be stored in the memory of the TA. When the TA sees the DTR go high, it dials the number that is stored in the TA. This requires the dialer dtr command under the serial interface. For example:

Example:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer dtr
   dialer idle-timeout 300
   ppp authentication chap

The ADTRAN must be configured for DTR dialing, multilink PPP, and so on, and have the destination phone number programmed.

Both B-channels are dialed by the ADTRAN.

Keypad Dialing

Some TAs have keypads on them to allow for interactive dialing directly from the TA. With this method, the user must input the number to dial in the TA keypad every time a connection is to be made. This method is primarily used for testing purposes to verify connectivity. The required router configuration is shown below:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast
   ppp authentication chap

Cabling

To connect the serial port of the router to the TA use a V.35 DTE cable (with DB-60 serial port or smart serial on one side). The following diagram shows a sample cable:

adtran_ta1.gif

If the TA only has an RS-232 port, then you also need a V.35 to RS-232 (DB-25) Cable in addition to the cable shown above. Alternately, you can use just one DB-60-to-DB-25 RS-232 Cable.

Refer to Product Catalog sections on Serial Cables for more information on cabling.

Configuration Example using V.25bis

This section shows a configuration example using V.25bis.

adtran_ta2.gif

ADTRAN ISU Configuration

This section includes some tips on configuring the ADTRAN ISU. However, please consult the ADTRAN Web site leavingcisco.com before configuring the TA, as functionality, features and configuration parameters may have changed.

  1. Connect the ADTRAN TA to a PC. This step is necessary so that you can access the TA and configure the various parameters prior to hooking it up to the router.

    Attach an RJ-45-to-DB-9 adapter marked "Terminal" to the communications (COM) port of the PC. From the RJ-45 end of the adapter, connect a flat-satin Rolled RJ-45-- RJ-45 cable (part number CAB-500RJ= ), which is provided with every Cisco router for console connections. You also need a RJ-45 to DB-25 adapter marked "MODEM" (part number CAB-25AS-MMOD) to connect the rolled cable to the DB-25 port labeled RS-232 on the back of the ADTRAN.

  2. Enter AT!V (or if connected to the RS366/Maintenance port, use !V) to obtain the main menu. Then press Ctrl+C to enter the configuration menu.

    You should see the menu similar to the one below (this may vary depending on the TA model):

     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
                             ISU 128 Configuration Menu
    
     1) Netw. options = Dial Line           17) RTS Options = 1 ms delay
     2) Switch Protocl = National ISDN1     18) CTS Options = Forced CTS
     3) Call type = Data 64Kbps             19) CD Options = Normal
     4) SPID 1 = 51255511110101             20) DTR Options = Idle when Off
     5) SPID 2 = 51255511120101             21) DSR Options = OFF Idle+Test
     6) LDN 1 = 5551111                     22) Transmit Clock = Normal
     7) LDN 2 = 5551112                     23) Protocol = PPP asyn-sync
     8) Dial options = V.25                 24) Method = Multilink
     9) V.25 = V.25 HDLC FLAGS              25) Quick setup
    10) Auto answer = Enabled
    11) Answer tone = No Answer tone
    12) Connect Timout = 30 sec (def)
    13) Call Screening = Answer any
    14) DTE options = Synchronous
    15) Bit Rate = 128000
    16) Connector Type = RS-232
    ____________________________________________________________________________
    
    Select =                                    Enter SELECT    Esc NO CHANGE
    ____________________________________________________________________________
    
     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
  3. Use the corresponding numbers to enter the configuration mode for the various attributes.

    The following attributes (at a minimum) should be configured:

    • Switch Protocol: The switch type specified by the Telco.

    • Call Type: Specify either 64 k or 56 k data (depending on the type of circuit).

    • SPID1, SPID2, LDN1, LDN2: If applicable, assign the SPIDs and LDNs provided by the Telco.

    • Dial Options: V.25.

    • V.25: V.25 HDLC (if using sync serial) or V.25 ASYNC (if using async serial).

    • DTE options: Synchronous (if using sync serial) or Asynchronous (if using async serial).

    • Bit Rate: 128000 (or 112000 for 56 k calls).

    • Protocol: PPP asyn-sync.

    • Method: Multilink.

    We recommend that you refer to the ISU Data Sheet/Manuals on the ADTRAN web site leavingcisco.com for the possible options for each parameter. The example shown above should work for most situations.

Router Configuration and Testing

Use the following procedure to configure and test the router.

  1. Connect a V.35 or RS-232 DTE Cable to the router serial port. Refer to the section Cabling for more information on the types of cable you should use.

  2. Use show controller serial x (which indicates the type of cable the router is connected to) to verify that the cable on the router side is DTE. For example:

    Router#show controller serial 1
    HD unit 1, idb = 0xCF6E8, driver structure at 0xD4A30
    buffer size 1524  HD unit 1, RS-232 DTE cable
    cpb = 0xE3, eda = 0x940, cda = 0x800
    ...
    ...

    You should also verify that the connector type setting on the ADTRAN (option 16 in the example above) matches the cabling used.

  3. Configure the router as follows:

    username peer password 0 cisco
    !
    interface Serial1 
    ip address 192.168.180.2 255.255.255.0 
    encapsulation ppp 
    dialer in-band
     
    !--- Enable V.25bis dialing. 
    
    dialer map ip 192.168.180.22 name peer 5551111&5551112
     
    !--- Dialer map for the peer. 
    !--- Note the multiple numbers separated by "&"
     
    dialer-group 1 
    pulse-time 1 
    ppp authentication chap
    !
    ip classless
    ip route 192.168.180.22 255.255.255.255 Serial1
    dialer-list 1 protocol ip permit

    Note: For the TA to bring up both channels, you have to store the second number in the ADTRAN, or use [phonenumber1]&[phonenumber2] in the Cisco dialer map statement (recommended). The serial interface is just one point-to-point interface, so having multiple dialer maps does not affect multilink connections .

    The ADTRAN dials the first number, negotiates and authenticates, and then immediately dials the second. Notice that the command ppp multilink is not configured on the router, since the TA handles multilink

    Note: If you wish to use the serial interface in async mode, use the command physical-layer async under the serial interface configuration. However, some serial interface hardware do not support async communication. To connect a modem to this interface, refer to Configuring Dialout using a Modem on the AUX Port. This document uses the AUX port. However, the configurations are very similar.

  4. Initiate a ping to the remote router. The router sends the dialer strings to the TA, which then initiates the ISDN link. Once the ISDN link is up, the routers negotiate PPP and and authentication occurs. You should be able to pass traffic at this time.

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug dialer - To display debugging information about the packets received on a dialer capable interface. When Dial-on-Demand Routing (DDR) is enabled on the interface, information concerning the cause of any call (called the dialing cause) is also displayed. For more information, see the debug dialer information in the Debug Commands documentation.

  • debug interface serial - Use the debug serial interface EXEC command to display information on a serial connection failure. For more information, see the debug interface serial information in the Debug Commands documentation.

  • debug ppp negotiation - Displays information on PPP traffic and exchanges while negotiating the PPP components including Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation will first open the LCP state, then authenticate, and finally negotiate NCP. For more information on reading debug ppp negotiation output please refer to the document Understanding debug ppp negotiation Output.

  • debug ppp authentication - Displays the PPP authentication protocol messages, including Challenge Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges. Refer to the following document for more information: Troubleshooting PPP (CHAP or PAP) Authentication.

Debug Output

Activate debug dialer and debug ppp negotiation, then initiate a ping to the peer. The router should attempt to dial. Once the ISDN connection is established PPP negotiation should begin. The following debug output shows a successful call.

Router#show debug
Dial on demand:  Dial on demand events debugging is on
PPP:  
  PPP authentication debugging is on  
  PPP protocol negotiation debugging is on
Router#ping 192.168.180.22
  Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 192.168.180.22, timeout is 2 seconds:
 Serial1: Dialing cause ip (s=192.168.180.2,d=192.168.180.22)

!--- Dialing cause is ping to 192.168.180.22.

   Serial1: Attempting to dial 5551111&5551112
   
!--- Call is dialed out using Serial1 
   !---(which is connected to the ADTRAN).
   !--- Remember that ADTRAN handles the ISDN L1-L3, so ISDN messages
   !--- will not be visible on the router.

   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet.
   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet
   Se1 LCP: I CONFREQ [Closed] id 49 len 15

!--- PPP Negotiation begins.

   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: Lower layer not up, discarding packet
   %LINK-3-UPDOWN: Interface Serial1, changed state to up.
   Se1 PPP: Treating connection as a callout
   Se1 PPP: Phase is ESTABLISHING, Active Open
   Se1 LCP: O CONFREQ [Closed] id 47 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFACK [REQsent] id 48 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFREQ [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: O CONFACK [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: State is Open
   Se1 PPP: Phase is AUTHENTICATING, by both
   Se1 CHAP: O CHALLENGE id 11 len 42 from "Router"
   Se1 CH.AP: I CHALLENGE id 11 len 30 from "peer"
   Se1 CHAP: O RESPONSE id 11 len 42 from "Router"
   Se1 CHAP: I SUCCESS id 11 len 4
   Se1 CHAP: I RESPONSE id 11 len 30 from "peer"
   Se1 CHAP: O SUCCESS id 11 len 4 
   
!--- Authentication is successful.

   Se1 PPP: Phase is UP
   Se1 IPCP: O CONFREQ [Closed] id 16 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFREQ [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   Se1 IPCP: O CONFACK [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, 
   changed state to up
   Se1 IPCP: TIMEout: Time 0x476F808 State ACKsent
   Se1 IPCP: O CONFREQ [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFACK [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: State is Open
   Se1 IPCP: Install route to 192.168.180.22
   dialer Protocol up for Se1

Note: For more information on reading debug ppp negotiation output, please refer to the document Understanding debug ppp negotiation Output.

Troubleshooting Procedure

This section includes some common troubleshooting procedures. If you encounter issues at any step refer to the ADTRAN technical documentation for more information:

  1. Verify that the display on the front of the ADTRAN reads as follows:

    Adtran ISU 128
    [Switch-type] Ready

    This ensures that the ISDN configuration, such as switchtypes, service profile identifiers (SPIDs) and local directory number (LDN) have been correctly configured and accepted by the Telco.

  2. Initiate a test connection to the peer using the keypad on the ADTRAN. This can help ensure that the ISDN circuit, and ISDN related configuration on the TA is correct.

  3. Initiate a ping to the peer. You should see the following on front panel display of the ADTRAN: "CALLING [PHONENUMBER". This indicates that at least V.25bis is working correctly. If you do not see the message, try swapping cables and even TAs. This can help isolate bad cables and V.35 interfaces on the TA.

  4. Activate debug dialer. Initiate a ping. Verify that you see the following in the debug output:

    Serial1: Dialing cause ip (s=192.168.180.2, d=192.168.180.22)
    Serial1: Attempting to dial 5551111&5551112

    If you do not see the message, then the issue is DDR-related. Verify that the router configuration is as shown above. Make sure that the routing and interesting traffic definition is configured as well.

  5. Activate debug serial interface, initiate a ping and verify that the TA raises data set ready (DSR).

    Only when the router detects a high DSR, will the router attempt to negotiate PPP. If DSR does not go up, then we must troubleshoot a lower layer such as ISDN, hardware and cabling.

Related Information

Updated: Nov 19, 2007
Document ID: 28080