Guest

ISDN, CAS

Configuring Data Over Voice (DoV) using isdn incoming-voice data and dialer voice-call

Document ID: 14964

Updated: Nov 19, 2007

   Print

Introduction

This document provides a sample configuration for configuring Data Over Voice (DoV) using the isdn incoming-voice data and dialer voice-call commands.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco IOS® Software Release 11.3 or later.

  • You can use any router with an ISDN interface. However you must ensure that the Telco supports DOV, and that there will no corruption of data

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Background Theory

Data over Voice (DOV) allows you to send data over a voice call using an ISDN line. An ISDN line can support both data calls and voice calls. Two routers that interconnect with ISDN lines typically use data calls (64 kbps or 56 kbps). Voice calls are expected to be generated by a telephone or fax. Voice calls can also be generated by a device connected to an analog modem (for example, a PC dialing up using a plain old telephone service [POTS] line).

In some circumstances, a user may be interested in connecting two routers with voice calls using ISDN lines, especially when considering the price difference between a data call and a voice call. ISDN lines commonly have per-call charges for all calls (local, long distance, and international).

In some instances the pricing of voice calls is lower than the pricing of data calls. In order for routers to be able to communicate using voice calls between two ISDN lines, careful configuration is necessary to make the routers aware that the calls need to be initiated as voice calls and that incoming voice calls should be handled as data calls. On the outbound (calling) side, use the map-class option to define calls as voice calls:

map-class dialer name

dialer voice-call

This map-class defines a behavior and must be applied to the ISDN interfaces where this behavior is needed. Here is an example of the map-class behavior on dialer map or dialer string commands.

dialer map protocol address class map class name host name [broadcast] phone number

dialer string phone number class map class

See the Cisco IOS software documentation for the complete syntax of these two commands.

On the inbound (called) side, add the isdn incoming-voice data command under the physical interface. Remember that all incoming voice calls will be treated as data calls. If you are using a platform that supports modem calls on BRIs, you cannot configure a particular interface to support either feature. A particular interface could either handle voice calls as modem calls or voice calls as DOV calls, but not both.

Note: It is possible to configure a particular interface to handle voice calls as modem calls or voice calls as DOV calls. However, this requires you to configure Resource Pool Management (RPM). For more information on RPM, refer to the following document: Resource Pool Management.

It is important to understand that DOV has limited reliability. A call between two ISDN lines is expected to supply an end-to-end digital path. The equipment, lines, and other resources that the telephone company uses to set up data and voice calls are usually the same. However, they can be different. The transport of digital voice is more flexible than the transport of data. For ISDN data calls, the telephone network guarantees bit transport along a 64 kbps or 56 kbps digital path. For voice calls, the telephone network can route and manipulate the bit stream in different ways without affecting voice quality, but all data is corrupted when sent this way. Therefore, DOV does not work with some ISDN lines. Verify that your Telco can handle DOV calls before you configure this feature, else the call setup may succeeed but tht data will be corrupted.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

briipun.gif

Configurations

This document uses the configurations shown below.

Router 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.10.186.133 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5556700 class DOV

! --- The router will use the map-class DOV when dialing this number
! --- The map-class named DOV is defined below

 dialer load-threshold 5 outbound
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
map-class dialer DOV

! --- map class named DOV is applied to the dialer string under 
! --- the physical interface

 dialer voice-call

! --- Outgoing call is treated as a voice call

!
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Router 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice data

! --- Incoming voice calls will be treated as data calls
! --- An interface cannot accept modem calls and DOV calls without RPM

 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.186.129
ip route 10.10.186.128 255.255.255.240 BRI0
no ip http server

dialer-list 1 protocol ip permit

line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show isdn status - The status should be:

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    If Layer 1 is not active, then the wiring adapter or port may be bad or not plugged in. If Layer 2 is in a state of TEI_Assign, then the router is not talking to the switch. Refer to Using the show isdn status Command for BRI Troubleshooting for more information on troublehooting ISDN connections

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug dialer - To display information concerning the cause of any call. This would primarilty be used to determine if the router initiated the call.

  • debug isdn q931 - To check ISDN connections as users dial in to see what is happening with the ISDN call (for example, if the connection is being dropped). You can also ascertain the bearer cap (which indicates whether the call is digital or voice) from this debug output.

  • debug ppp nego - To see if the details of the PPP negotiation.

  • debug ppp chap - To check authentication.

Debug Output

The following debug isdn q931 output shows the call connecting using DOV. maui-soho-01 (the client) dials maui-nas-08 (the server). Notice the bearer cap of the calls indicate that they are voice calls, as expected. maui-nas-08 is configured to treat incoming voice calls as data calls (as opposed to modem calls) and the call is connected.

maui-soho-01#ping 10.8.186.134 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.8.186.134, timeout is 2 seconds:
Aug 17 15:48:12.523: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x03

! --- Setup message for outgoing call

Aug 17 15:48:12.531:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.543:         Channel ID i = 0x83
Aug 17 15:48:12.550:         Keypad Facility i = '5556700'
Aug 17 15:48:12.908: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x83

Aug 17 15:48:12.916:         Channel ID i = 0x89

Aug 17 15:48:12.927:         Locking Shift to Codeset 5
Aug 17 15:48:12.931:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098001, '<'
Aug 17 15:48:13.130: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x83

! --- maui-nas-08 has accepted the call and responded with the 
! --- CONNECT message

Aug 17 15:48:13.142:         Locking Shift to Codeset 5
Aug 17 15:48:13.150:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098909, 'Connected', 0x80010B8001, '('
Aug 17 15:48:13.217: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
Aug 17 15:48:13.249: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x03
Aug 17 15:48:14.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up
Aug 17 15:48:19.185: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5556700

The following debug is obtained from the maui-nas-08 (server). Notice that the bearer cap indicates that the the call is a voice call. The NAS has been configured to treat incoming voice calls as data calls on that interface.

maui-nas-08#
Aug 17 15:48:12.765: ISDN BR2/0: RX <-  SETUP pd = 8  callref = 0x13

! --- Setup message for incoming call

Aug 17 15:48:12.765:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.765:         Channel ID i = 0x89
Aug 17 15:48:12.765:         Signal i = 0x40 - Alerting on - pattern 0 
Aug 17 15:48:12.765:         Called Party Number i = 0xC1, '5556700', 
Plan:ISDN, Type:Subscriber(local)
Aug 17 15:48:12.765:         Locking Shift to Codeset 5
Aug 17 15:48:12.765:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'

Aug 17 15:48:12.769: ISDN BR2/0: Event: Received a DATA call from  
on B1 at 64 Kb/s

! --- The incoming voice call (on int bri 2/0) is treated as a data call
! --- This is configured (in interface config mode) using 
! --- isdn incoming-voice data

Aug 17 15:48:12.769: ISDN BR2/0: TX ->  CALL_PROC pd = 8  callref = 0x93
Aug 17 15:48:12.773:         Channel ID i = 0x89
Aug 17 15:48:12.773: %LINK-3-UPDOWN: Interface BRI2/0:1, changed state to up
Aug 17 15:48:12.773: BR2/0:1 PPP: Treating connection as a callin
Aug 17 15:48:12.773: BR2/0:1 PPP: Phase is ESTABLISHING, Passive Open
Aug 17 15:48:12.773: BR2/0:1 LCP: State is Listen
Aug 17 15:48:13.073: ISDN BR2/0: TX ->  CONNECT pd = 8  callref = 0x93

! --- The call is accepted and nas-08 responds with the CONNECT message

Aug 17 15:48:13.073:         Channel ID i = 0x89
Aug 17 15:48:13.121: ISDN BR2/0: RX <-  CONNECT_ACK pd = 8  callref = 0x13


! ---Output omitted

...

Related Information

Updated: Nov 19, 2007
Document ID: 14964