Guest

Dial-on-Demand Routing (DDR)

BRI ISDN Backup With Backup Interface

Document ID: 11047

Updated: Feb 04, 2010

   Print

Introduction

This document provides a sample configuration for ISDN backup, and provides basic troublehooting information for this type of configuration.

For information on the most common implementations of ISDN backup, and comparisons between these, refer to the following document: Evaluating Backup Interfaces, Floating Static Routes, and Dialer Watch for DDR Backup.

Prerequisites

Requirements

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Two Cisco 2500 routers (Frame Relay data terminal equipment [DTEs] ) running Cisco IOS® Software Releases 12.2(3) and 12.2(5).

  • One Cisco 4500 router acting as a Frame Relay switch.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

bri_isdn_11047.gif

Configurations

This document uses the configurations shown below.

krimson (Cisco 2500 Router)
krimson#show running-config
Building configuration...

!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
         
!
hostname krimson
!
!
username kevin password 0 <password> !
isdn switch-type basic-net3
!
!
interface Loopback0
ip address 10.7.7.1 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0
ip address 10.200.16.30 255.255.255.0
!
interface Serial1
bandwidth 64
no ip address
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
!
interface Serial1.1 point-to-point
backup interface Dialer0
ip address 10.5.5.2 255.255.255.0
no ip route-cache
frame-relay interface-dlci 20 
!
interface BRI0
description Testanschluss ISDN(intern), Nr. 4420038
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
load-interval 30
no keepalive
dialer pool-member 1
isdn switch-type basic-net3
no fair-queue
no cdp enable
ppp authentication chap
!
interface Dialer0
ip address 10.9.9.1 255.255.255.0
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 1
dialer remote-name kevin
dialer string 6120
dialer-group 1
no cdp enable
ppp authentication chap
!
router ospf 10
log-adjacency-changes
network 10.5.5.0 0.0.0.255 area 0
network 10.7.7.0 0.0.0.255 area 0
network 10.9.9.0 0.0.0.255 area 0
!
ip default-gateway 10.200.16.1
no ip classless
no ip http server
!
access-list 105 permit ip any host 10.7.7.1
access-list 105 permit ip any host 10.8.8.1
access-list 105 permit ip any any
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
privilege level 15
line aux 0
transport input all
line vty 0 4
exec-timeout 0 0
password <password> login
!
end

kevin (Cisco 2500 Router)
kevin#show running-config
Building configuration...

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname kevin
!
!
username krimson password 0 <password> !
isdn switch-type basic-net3
!
!
interface Loopback0
ip address 10.8.8.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
ip address 172.19.0.1 255.255.255.255
!
interface Ethernet0
ip address 10.200.16.26 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 point-to-point
ip address 10.5.5.1 255.255.255.0
no cdp enable
frame-relay interface-dlci 20 
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
!
interface Dialer0
ip address 10.9.9.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name krimson
dialer-group 1
no cdp enable
ppp authentication chap
!
router ospf 10
log-adjacency-changes
network 10.5.5.0 0.0.0.255 area 0
network 10.8.8.0 0.0.0.255 area 0
network 10.9.9.0 0.0.0.255 area 0
!
ip default-gateway 10.200.16.1
ip classless
!
dialer-list 1 protocol ip permit
no cdp run
!        
line con 0        
exec-timeout 0 0
line aux 0
modem InOut
line vty 0 4
exec-timeout 0 0
password <password> login
!
ntp clock-period 17180102
ntp server 10.200.20.134
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Use the following commands to verify your configuration:

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

  • show interfaces serial- Displays information about the multicast data-link connection identifier (DLCI), the DLCIs used on the interface, and the DLCI used for the Local Management Interface (LMI).

  • show interface dialer- Displays information about the dialer interface.

  • show ip route- Displays IP routing table entries.

   krimson#show interface serial 1.1 

   ! --- The initial state before the simulated Frame Relay network failure. 
   ! --- The primary link is up and functional. 

   
   Serial1.1 is up, line protocol is up 
   Hardware is HD64570
   Internet address is 10.5.5.2/24
   Backup interface Dialer0, failure delay 0 sec, 
   secondary disable delay 0 sec
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   krimson#show int dialer 0 

   ! --- Initial state. The backup interface is in standby mode and inactive.

   Dialer0 is standby mode (spoofing), line protocol is down (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 6w4d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   596 packets input, 48924 bytes
   600 packets output, 49280 bytes
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   
   192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/24 is subnetted, 6 subnets
   O 10.9.9.0 [110/3347] via 10.5.5.1, 00:03:34, Serial1.1
   O 10.8.8.0 [110/1563] via 10.5.5.1, 00:03:34, Serial1.1 

   ! --- The route to the tested destination network points to the 
   ! --- still-active primary link.

   
   C 10.5.5.0 is directly connected, Serial1.1
   C 10.7.7.0 is directly connected, Loopback0
   C 10.9.8.0 is directly connected, Dialer1
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Here, we can see that the Frame Relay interface is going down.

   krimson#
   *Apr 16 23:56:47.840: %LINK-3-UPDOWN: Interface Serial1, 
   changed state to down
   *Apr 16 23:56:47.848: OSPF: Interface Serial1.1 going Down 

   ! --- Here we have simulated a failure within the Frame Relay network.
   ! --- We can see what was conducted to the Frame Relay DTE router, 
   ! --- and the subinterface going down.

   *Apr 16 23:56:47.852: %OSPF-5-ADJCHG: Process 10, 
   Nbr 172.19.0.1 on Serial1.1    
   from FULL to DOWN, Neighbor Down: Interface down or detached
   *Apr 16 23:56:48.736: BACKUP(Serial1.1): event = primary went down
   *Apr 16 23:56:48.740: BACKUP(Serial1.1): changed state to 
   "waiting to backup"
   *Apr 16 23:56:48.744: BACKUP(Serial1.1): event = timer expired
   *Apr 16 23:56:48.748: Di0 DDR is shutdown, could not clear interface.
   *Apr 16 23:56:48.752: BACKUP(Serial1.1): 
   secondary interface (Dialer0) made active 

   ! --- The configured backup interface is active.

   *Apr 16 23:56:48.752: BACKUP(Serial1.1): changed state to "backup mode"
   *Apr 16 23:56:48.756: OSPF: Interface Dialer0 going Up
   *Apr 16 23:56:48.760: BR0 DDR: rotor dialout [priority]
   *Apr 16 23:56:48.764: BR0 DDR: Dialing cause ip (s=10.9.9.1, d=224.0.0.5) 

   ! --- OSPF packets trigger the call.

   *Apr 16 23:56:48.768: BR0 DDR: Attempting to dial 6120
   *Apr 16 23:56:48.784: ISDN BR0: TX -> SETUP pd = 8 callref = 0x3E
   *Apr 16 23:56:48.792: Bearer Capability i = 0x8890
   *Apr 16 23:56:48.796: Channel ID i = 0x83
   *Apr 16 23:56:48.804: Called Party Number i = 0x80, '6120', 
   Plan:Unknown, Type:Unknown
   *Apr 16 23:56:48.844: %LINEPROTO-5-UPDOWN: Line protocol on  
   Interface Serial1, changed state to down
   *Apr 16 23:56:48.884: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xBE
   *Apr 16 23:56:48.892: Channel ID i = 0x89
   *Apr 16 23:56:49.144: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xBE
   *Apr 16 23:56:49.160: %LINK-3-UPDOWN: Interface BRI0:1, 
   changed state to up
   *Apr 16 23:56:49.168: %DIALER-6-BIND: 
   Interface BR0:1 bound to profile Di0
   *Apr 16 23:56:49.176: BR0:1 PPP: Treating connection as a callout
   *Apr 16 23:56:49.180: BR0:1 PPP: Phase is ESTABLISHING, Active Open 
   [0 sess, 0 load]
   *Apr 16 23:56:49.184: BR0:1 LCP: O CONFREQ [Closed] id 49 len 15
   *Apr 16 23:56:49.188: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.188: BR0:1 LCP: MagicNumber 0xF2143EDB (0x0506F2143EDB)
   *Apr 16 23:56:49.196: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x3E
   *Apr 16 23:56:49.224: BR0:1 LCP: I CONFREQ [REQsent] id 83 len 15
   *Apr 16 23:56:49.228: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.232: BR0:1 LCP: MagicNumber 0x9ADACD69 (0x05069ADACD69)
   *Apr 16 23:56:49.236: BR0:1 LCP: O CONFACK [REQsent] id 83 len 15
   *Apr 16 23:56:49.236: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.240: BR0:1 LCP: MagicNumber 0x9ADACD69 (0x05069ADACD69)
   *Apr 16 23:56:49.244: BR0:1 LCP: I CONFACK [ACKsent] id 49 len 15
   *Apr 16 23:56:49.248: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.252: BR0:1 LCP: MagicNumber 0xF2143EDB (0x0506F2143EDB)
   *Apr 16 23:56:49.252: BR0:1 LCP: State is Open
   *Apr 16 23:56:49.256: BR0:1 PPP: Phase is AUTHENTICATING, by both 
   [0 sess, 0 load]
   *Apr 16 23:56:49.260: BR0:1 CHAP: O CHALLENGE id 49 len 28 from "krimson"
   *Apr 16 23:56:49.276: BR0:1 CHAP: I CHALLENGE id 51 len 26 from "kevin"
   *Apr 16 23:56:49.284: BR0:1 CHAP: O RESPONSE id 51 len 28 from "krimson"
   *Apr 16 23:56:49.332: BR0:1 CHAP: I SUCCESS id 51 len 4
   *Apr 16 23:56:49.344: BR0:1 CHAP: I RESPONSE id 49 len 26 from "kevin"
   *Apr 16 23:56:49.352: BR0:1 CHAP: O SUCCESS id 49 len 4
   *Apr 16 23:56:49.356: BR0:1 PPP: Phase is UP [0 sess, 0 load]
   *Apr 16 23:56:49.360: BR0:1 IPCP: O CONFREQ [Not negotiated] id 41 len 10
   *Apr 16 23:56:49.364: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Apr 16 23:56:49.376: BR0:1 IPCP: I CONFREQ [REQsent] id 29 len 10
   *Apr 16 23:56:49.380: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Apr 16 23:56:49.384: BR0:1 IPCP: O CONFACK [REQsent] id 29 len 10
   *Apr 16 23:56:49.388: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Apr 16 23:56:49.396: BR0:1 IPCP: I CONFACK [ACKsent] id 41 len 10
   *Apr 16 23:56:49.400: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Apr 16 23:56:49.400: BR0:1 IPCP: State is Open
   *Apr 16 23:56:49.408: BR0:1 DDR: dialer protocol up
   *Apr 16 23:56:49.416: Di0 IPCP: Install route to 10.9.9.2
   *Apr 16 23:56:49.960: OSPF: Rcv hello from 172.19.0.1 area 0 from 
   Dialer0 10.9.9.2
   *Apr 16 23:56:49.964: OSPF: End of hello processing
   *Apr 16 23:56:50.356: %LINEPROTO-5-UPDOWN: 
   Line protocol on Interface BRI0:1, changed state to up
   *Apr 16 23:56:50.748: %LINK-3-UPDOWN: Interface Dialer0, 
   changed state to up
   *Apr 16 23:56:50.752: Di0 LCP: Not allowed on a Dialer Profile
   *Apr 16 23:56:50.752: BACKUP(Dialer0): event = primary came up
   *Apr 16 23:56:55.176: %ISDN-6-CONNECT: 
   Interface BRI0:1 is now connected to 6120 kevin
   *Apr 16 23:56:58.804: OSPF: Rcv DBD from 172.19.0.1 on Dialer0 
   seq 0x988 opt 0x42 flag 0x7 len 32 mtu 1500 state INIT
   *Apr 16 23:56:58.808: OSPF: 2 Way Communication to 172.19.0.1 
   on Dialer0, state 2WAY
   
   krimson#show interface serial 1.1
   Serial1.1 is down, line protocol is down 
   
! --- The primary link is down.

   Hardware is HD64570
   Internet address is 10.5.5.2/24
   Backup interface Dialer0, failure delay 0 sec, 
   secondary disable delay 0 sec
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   krimson#show interface dialer 0
   Dialer0 is up, line protocol is up (spoofing) 

   ! --- The backup interface is active and bearing traffic.

   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Interface is bound to BR0:1
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 6w4d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   614 packets input, 50240 bytes
   618 packets output, 50584 bytes
   Bound to:
   BRI0:1 is up, line protocol is up 
   Hardware is BRI
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive not set
   DTR is pulsed for 1 seconds on reset
   Time to interface disconnect: idle 00:01:57
   Interface is bound to Di0 (Encapsulation PPP)
   LCP Open
   Open: IPCP
   Last input 00:00:01, output 00:00:02, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   30 second input rate 0 bits/sec, 0 packets/sec
   30 second output rate 0 bits/sec, 0 packets/sec
   3910 packets input, 394443 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   29 input errors, 18 CRC, 0 frame, 0 overrun, 0 ignored, 11 abort
   3613 packets output, 222417 bytes, 0 underruns
   0 output errors, 0 collisions, 27 interface resets
   0 output buffer failures, 0 output buffers swapped out
   607 carrier transitions
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

Gateway of last resort is 10.200.16.1 to network 0.0.0.0
 
192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
   C 10.9.9.2/32 is directly connected, Dialer0
   O 10.8.8.0/24 [110/1786] via 10.9.9.2, 00:00:53, Dialer0 
   
! --- The route entry to the destination network is now pointing to 
   ! --- the backup interface as a next hop.

   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.9.8.0/24 is directly connected, Dialer1
   C 10.200.16.0/24 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1
   
   krimson#ping 10.8.8.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.8.8.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/40 ms

Here we can see the system reverting back to its initial state once the failure in the Frame Relay network has been cleared:

krimson#show interface serial 1.1
   Serial1.1 is up, line protocol is up 
   Hardware is HD64570
   Internet address is 10.5.5.2/24
   Backup interface Dialer0, failure delay 0 sec, 
   secondary disable delay 0 sec
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   krimson#show interface dialer 0
   Dialer0 is standby mode (spoofing), line protocol is down (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 6w5d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   665 packets input, 54008 bytes
   671 packets output, 54548 bytes
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/24 is subnetted, 6 subnets
   O 10.9.9.0 [110/3347] via 10.5.5.1, 00:08:39, Serial1.1
   O 10.8.8.0 [110/1563] via 10.5.5.1, 00:08:39, Serial1.1
   C 10.5.5.0 is directly connected, Serial1.1
   C 10.7.7.0 is directly connected, Loopback0
   C 10.9.8.0 is directly connected, Dialer1
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1
   krimson# 

Note: No specific configuration is needed on called side.

The same show output recorded during normal operation contains the following information:

kevin#show interface serial 0.1
   Serial0.1 is up, line protocol is up 

   ! --- The primary interface is up and running.

   Hardware is HD64570
   Internet address is 10.5.5.1/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   kevin#show interface dialer 0
   Dialer0 is up (spoofing), line protocol is up (spoofing) 

   ! --- Note: On the called side, the dialer interface is active 
   ! --- and not in standby mode.

   Hardware is Unknown
   Internet address is 10.9.9.2/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 4w2d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   598 packets input, 49252 bytes
   596 packets output, 48924 bytes

   kevin#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   
   172.17.0.0/32 is subnetted, 1 subnets
   S 172.17.247.195 [1/0] via 10.200.16.1
   172.19.0.0/32 is subnetted, 1 subnets
   C 172.19.0.1 is directly connected, Loopback1
   10.0.0.0/24 is subnetted, 5 subnets
   C 10.5.5.0 is directly connected, Serial0.1
   O 10.7.7.0 [110/65] via 10.5.5.2, 00:04:27, Serial0.1
   C 10.9.9.0 is directly connected, Dialer0
   C 10.8.8.0 is directly connected, Loopback0
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Here is the same same information recorded during the failure:

kevin#show interface serial 0.1
   Serial0.1 is down, line protocol is down 
   Hardware is HD64570
   Internet address is 10.5.5.1/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   kevin#show interface dialer 0
   Dialer0 is up, line protocol is up (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.2/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Interface is bound to BR0:1
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 4w2d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   618 packets input, 50700 bytes
   616 packets output, 50384 bytes
   Bound to:
   BRI0:1 is up, line protocol is up 
   Hardware is BRI
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive set (10 sec)
   DTR is pulsed for 1 seconds on reset
   Time to interface disconnect: idle 00:01:57
   Interface is bound to Di0 (Encapsulation PPP)
   LCP Open
   Open: IPCP
   Last input 00:00:03, output 00:00:02, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   1280 packets input, 138077 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   9789 input errors, 9789 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   1309 packets output, 138487 bytes, 0 underruns
   0 output errors, 0 collisions, 15 interface resets
   0 output buffer failures, 0 output buffers swapped out
   351 carrier transitions
   
   kevin#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   172.17.0.0/32 is subnetted, 1 subnets
   S 172.17.247.195 [1/0] via 10.200.16.1
   172.19.0.0/32 is subnetted, 1 subnets
   C 172.19.0.1 is directly connected, Loopback1
   10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
   O 10.7.7.0/24 [110/1786] via 10.9.9.1, 00:01:21, Dialer0
   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.8.8.0/24 is directly connected, Loopback0
   C 10.9.9.1/32 is directly connected, Dialer0
   C 10.200.16.0/24 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

The Frame Relay configurations with point-to-point subinterfaces and Open Shortest Path First (OSPF) as a routing protocol used here are specific to this setup. However, the troubleshooting steps shown are more general and can be used with different configurations such as Frame Relay point-to-multipoint or a primary link with High-Level Data Link Control (HDLC) or Point to Point Protocol (PPP) encapsulation, regardless of the routing protocol used.

To verify the backup functionality, one of the interfaces on the Cisco 4500 router that is acting as a Frame Relay switch has been placed in shutdown state in order to simulate problem within the Frame Relay network. Consequently, this leads to the PVC inactive state being conducted to the DTE router via the Frame Relay network, and a Frame Relay subinterface down event. This activates the backup interface.

Troubleshooting Commands

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug isdn q931

  • debug backup- Debugs backup events.

  • debug dialer- Displays debugging information about the packets or events on a dialer interface.

  • debug ppp negotiation - Causes the debug ppp command to display PPP packets transmitted during PPP startup, where PPP options are negotiated.

  • debug ppp authentication - Causes the debug ppp command to display authentication protocol messages, including Challenge Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges.

  • debug ip ospf events - Displays information on OSPF-related events, such as adjacencies, flooding information, designated router selection, and shortest path first (SPF) calculation

  • debug frame-relay events - Displays debugging information about Frame Relay ARP replies on networks that support a multicast channel and use dynamic addressing.

Related Information

Updated: Feb 04, 2010
Document ID: 11047