Guest

Asynchronous Connections

Router-to-Router Async Multilink PPP

Cisco - Router-to-Router Async Multilink PPP

Document ID: 9585

Updated: Oct 25, 2005

   Print

Introduction

This configuration describes a remote Cisco 3640 with an internal 8 port analog modem card (NM-8AM) dialing into a Cisco AS5300 with a Primary Rate Interface (PRI). The configuration describes a multilink connection composed of two analog phone lines at the remote site. More phone lines can be configured for MP if they are available.

Prerequisites

Requirements

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • A Cisco 3640 running Cisco IOS Software Release 12.1(3)

  • A Cisco AS5300 running Cisco IOS Software Release 12.07(T)

Note: MP was first introduced in Cisco IOS Software Release 11.0(3).

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Background Theory

Multilink PPP (MP) allows devices to send data over multiple point-to-point data links to the same destination by implementing a virtual link. The MP connection has a maximum bandwidth equal to the sum of the bandwidths of the component links. MP can be configured for either multiplexed links, such as ISDN and Frame Relay, or for multiple async lines. Refer to RFC 1990 leavingcisco.com for more information on MP.

Note: RFC 1990 refers to Multilink PPP as MP. Other names by which MP is known include MPPP, MLP, and Multilink.

Async MP can be used to connect remote clients at a greater speed than is available through a single analog connection. In Async MP, the remote client uses multiple modems, and therefore multiple phone lines, to dial in to the central router and access the network. Because multiple phone lines are often cheaper than ISDN Basic Rate Interface (BRI) service, Async MP provides an effective way to increase connection speeds for remote users while controlling costs. Async MP is also an effective way to obtain higher access speeds for remote areas that cannot be serviced by ISDN.

Async MP bundles together separate modem connections to an Access Server. PPP software on each peer fragments the packets and then transmits the pieces to the other side through the multiple analog connections. The receiving end gathers these pieces from the separate connections and, based on MP information embedded in them, reassembles the pieces into valid data packets, thus providing an end-to-end virtual link with higher bandwidth. Async MP can be configured between either two routers or between a router and a client PC.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup tool

Network Diagram

This document uses the network setup shown in the diagram below.

router2router.gif

Configurations

This document uses the configurations shown below.

Cisco 3640
clearlake-lan-01#show runnning-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
!
hostname clearlake-lan-01
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local
!
username bobslake-nas-01 password <deleted>

!--- Remote router and password for CHAP authentication.
!--- Dialer interface must also be configured to use 
!--- this username and password.

username admin privilege 15 password <deleted>
!         
no ip domain-lookup
!
chat-script async-mppp ABORT ERROR ABORT BUSY 
"" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT \c

!--- Chat script used for dialing out.

!
interface Loopback0
 ip address 172.21.126.254 255.255.255.0
!
interface Ethernet0/0
 ip address 172.21.125.1 255.255.255.0
!
interface Group-Async1

!--- Interface to configure modems used for dialout.

 no ip address
 encapsulation ppp

!--- Use PPP encapsulation for members of this 
!--- group-async interface.

 dialer in-band

!--- Permit DDR on this interface.

 dialer pool-member 10

!--- All members of this group-async interface belong 
!--- to dialer pool 10.

 ppp multilink

!--- Enable PPP multilink on physical interface.

 group-range 33 34

!--- Assign async 33 and 34 to this group-async interface.
!--- This can be adjusted depending on the number of POTS lines available.

! 
 interface Dialer1

!--- Dialer interface to dialout to bobslake-nas-01.

 ip address negotiated

!--- Obtain an IP address from central site.

 encapsulation ppp
 dialer remote-name bobslake-nas-01

!--- Identify central site router for CHAP authentication.
!--- Shared secret password is defined above.

 dialer pool 10

!--- Defines the pool of physical resources that the Dialer 
!--- interface may use.

 dialer idle-timeout 600

!--- Specifies number of seconds without interesting traffic that 
!--- the connection is kept up.

 dialer string 5551212

!--- Number to be dialed; this number belongs to the PRI 
!--- of the central router.

 dialer load-threshold 15 either

!--- Load level for either inbound or outbound traffic 
!--- at which additional lines will be added to the MP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer-group 8

!--- Uses dialer-list 8 to determine interesting traffic.

 ppp authentication chap callin

!--- Use CHAP authentication for incoming calls only
!--- This router will not challenge remote routers for outgoing calls.

 ppp multilink

!--- Activates the interface for MP operation.

 ppp timeout multilink link remove 300

!--- Keeps the multilink connections up for 300 seconds 
!--- after the load drops below the threshold.
!--- This command should be used to control flapping.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1

!--- Use Interface Dialer1 for all networks.

no ip http server
!
access-list 188 remark define interesting traffic
access-list 188 deny   udp any any eq ntp
access-list 188 permit ip any any
dialer-list 8 protocol ip list 188

!--- Assign access-list 188 to dialer-list 8.  

!
line con 0
 transport input none
line 33 34

!--- Async lines to be used for dialout. 
!--- This number should match the group-range in the 
!--- Group-Async interface.

 script dialer async-mppp

!--- Use chat script called async-mppp for dialout.

 modem InOut
 modem autoconfigure discovery
 transport preferred none
 transport input all
line 35 40
 transport preferred none
 transport input all
line aux 0
line vty 0 4
!
ntp clock-period 17179871
ntp server 172.22.255.1 prefer
end

Cisco AS5300
bobslake-nas-01#show running-config 

Building configuration...

Current configuration:
  
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service tcp-small-servers
!
hostname bobslake-nas-01
!
logging buffered 10000 debugging
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local

!--- Authenticate for PPP if not authenticated during login.
!--- Allows users with Terminal Window after Dial to initiate PPP.

!
username clearlake-lan-01 password <deleted>

!--- Remote router and password for Challenge Handshake 
!--- Authentication Protocol (CHAP) authentication.
!--- The password must be identical on both sides.

spe 1/0 1/7
firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
ip subnet-zero
!
multilink virtual-template 1

!--- Use virtual-template 1 for multilink connections.

isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
 interface Loopback0
  ip address 172.21.10.10 255.255.255.255
  no ip directed-broadcast
!
interface Loopback1
 ip address 172.21.104.254 255.255.255.0

!--- Summarizes addresses in address pool. 
!--- Loopback 1 is in the same subnet as the address pool.

 no ip directed-broadcast
!
 interface Virtual-Template1
 description Template for Multilink Users
 ip unnumbered Loopback0 
 no ip directed-broadcast
 peer default ip address pool addr-pool

!--- Use IP pool called addr-pool for incoming calls.

 ppp authentication chap

!--- Authenticate using CHAP.

 ppp multilink

!--- Allow multilink sessions.

!

!--- Configure D channel on PRI.

interface Serial0:23
 description Headquarters 555-1212 active PRI line
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-5ess
 isdn incoming-voice mode
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 ip address 172.21.101.23 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Group-Async1
 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 600 either

!--- Specifies number of seconds without interesting 
!--- traffic that the connection is kept up.
!--- Configure the same idle-timeout on both routers.

 dialer map ip 172.21.125.1 name clearlake-nas-01
 dialer-group 5

!--- Uses dialer-list 5 to determine interesting traffic.

 async mode interactive
 peer default ip address pool addr-pool

!--- Use IP pool called addr-pool for incoming calls.

 ppp authentication chap callin

!--- Issue CHAP challenges for dialin users only.  

ppp multilink
 group-range 1 48

!--- Assign modems 1-48 to the Group-Async 1 configuration template.

! 
 router eigrp 1
 passive-interface Group-Async1

!--- To prevent routing traffic on async lines. 

 network 172.21.0.0
!
ip local pool addr-pool 172.21.104.1 172.21.104.48

!--- Define IP address pool range for dialin clients.
 
ip classless
no ip http server
!
access-list 105 permit ip any any

!--- Define interesting traffic.

dialer-list 5 protocol ip list 105

!--- Assign access list 105 to dialer list 5.

!
line con 0
 transport input none
line 1 48
 autoselect during-login

!--- Permits user login prompts after dialin.

 autoselect ppp

!--- Automatically launches PPP on the line.

 modem InOut

!--- Modems can be used to dialin and dialout.

 transport preferred none
 transport output telnet
line aux 0
line vty 0 4
!
ntp clock-period 17180374
ntp update-calendar
ntp server 172.22.255.1 prefer
end

Tuning and Optional Commands

The following commands can be used to adjust the behavior of the MP connection. Careful adjustment of such parameters can help control costs by avoiding wasteful and unnecessary use of data links.

  • dialer load-threshold load [outbound | inbound | either]

    MP can be configured so that additional channels come up immediately after the primary channel is established. To setup this scenario, set the load threshold value in the dialer load-thershold load command to 1. In this case, the additional channels are brought up and continue to stay up (that is, they do not flap). If the load-threshold is set to any other value, the multiple channels may flap depending on the load across the link. If you want to have additional channels added as necessary, depending on the traffic, set the load-threshold to the appropriate value between 1 and 255. For example, for additional channels to come up at 50 percent, the threshold should be set to 128 (0.50*255). When determining the threshold, consideration must be given to the setup time for async calls because longer setup times may necessitate lower thresholds.

    The load can be calculated based on outbound, inbound, or either the higher of the inbound or outbound traffic on the interface. If you base the load on inbound or either, ensure that the central site has passive-interface Group-Async1 configured so routing updates from the core are not sent via the async line. Preventing routing traffic from passing on the link provides more bandwidth for other data on the line.

  • ppp timeout multilink link remove seconds

    This command may be used to prevent the multilink connections from flapping when the load varies. For example, when the load threshold is set to 15 (that is, 15/255=6%) and the traffic exceeds the threshold, additional lines are brought up. When the traffic falls below the threshold, the additional lines are dropped. In situations where data rates are highly variable, it is advantageous for the multiple channels to stay up for a specified period of time even if the load-threshold falls below the specified value. Assign this multilink timeout to be less than that specified for dialer idle-timeout which controls the timeout for all links.

  • ppp timeout multilink link add seconds

    This command can be used to prevent multiple links from being added to the MP bundle until high traffic is received for a specified interval. This can prevent bursts of traffic from unnecessarily bringing up additional lines.

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

  • show ppp multilink - To display information on multilink bundles that are active. This command should be used to verify the multilink connection.

  • show caller - To display information on individual users and consumed resources on the NAS. This command displays active call statistics for large pools of connections, and shows the absolute and idle times for each user. If your version of Cisco IOS Software does not support this command, use the show user command.

  • show caller user - To show parameters for the particular user such as the TTY line used, asynchronous interface (shelf/slot/port), DS0 channel number, modem number, IP address assigned, PPP and PPP bundle parameters, and so on. If your version of Cisco IOS Software does not support this command, use the show user command.

Sample show Output

The following show command outputs are taken from the Cisco 3640 that is dialing into the AS5300. It shows that the multilink connection is up

clearlake-lan-01#show ppp multilink
Virtual-Access1, bundle name is bobslake-nas-01

!--- Virtualized MP bundle. Bundle name is derived from the 
!--- username used during authentication.

  Dialer interface is Dialer1

!--- This Virtual Access Interface used Interface Dialer1.

  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x4 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Async34
    Async33

!--- Members of the MP bundle.


clearlake-lan-01#show dialer


As33 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 10, priority 0

!--- Member of dialer pool 10.

Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: Multilink bundle overloaded

!--- Interface was not the first link in the MP bundle. 

Interface bound to profile Di1
Current call connected 00:00:54

!--- Current call duration

Connected to <deleted>5551212 (bobslake-nas-01) 

!--- Phone number that was dialed.


As34 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 10, priority 0

!--- Member of dialer pool 10.

Idle timer (600 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: ip (s=172.21.125.1, d=172.21.104.254)

!--- Interface was the first link in the bundle, triggered by 
!--- interesting traffic.

Interface bound to profile Di1
Current call connected 00:00:54

!--- Current Call duration.

Connected to 5551212 <deleted> (bobslake-nas-01)

!--- Phone number that was dialed.


Gr1 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle


Dial String      Successes   Failures    Last DNIS   Last status

Di1 - dialer type = DIALER PROFILE
Load threshold for dialing additional calls is 15

!--- Load threshold.

Idle timer (600 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 2

Dial String      Successes   Failures    Last DNIS   Last status
            15          0    00:00:56       successful   Default
clearlake-lan-01#show caller
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        tarpon             TTY           00:09:11  00:00:00  
  tty 33       -                  Async         -         00:00:01  
  TTY 34       -                  Async         -         00:00:06  
  As33         bobslake-nas-01    PPP           00:00:24  00:00:00  

!--- Second connection.

  As34         bobslake-nas-01    PPP           00:01:05  00:00:00  

!--- First connection. 

  Vi1          bobslake-nas-01    PPP   Bundle  00:01:05  00:01:04  

!--- MP bundle
!--- bobslake-nas-01 has two async lines, two TTY, and one virtual 
!--- interface bundle.


clearlake-lan-01#show caller user bobslake-nas-01

  User: bobslake-nas-01, line As33, service PPP

!--- PPP setting for bobslake-nas-01.

        Active time 00:00:34, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (-> AAA)

!--- Multilink is up.

  Dialer: Connected 00:01:09 to <deleted>, outbound

!--- Dialer interface was used to dialout.

          Type is IN-BAND ASYNC, group Dialer1
          Cause: Multilink bundle overloaded

!--- This interface was not the first member of the MP bundle.

  IP: Local 172.21.104.48/32
  Bundle: Member of bobslake-nas-01, last input 00:00:00
  Counts: 59 packets input, 3529 bytes, 0 no buffer
          0 input errors, 22 CRC, 0 frame, 0 overrun
          31 packets output, 1515 bytes, 0 underruns
          0 output errors, 0 collisions, 4 interface resets

!--- Packets are passing through the connection.


  User: bobslake-nas-01, line As34, service PPP

!--- PPP setting for user bobslake-nas-01.

        Active time 00:01:15, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (-> AAA)

!--- MP state is open.

  Dialer: Connected 00:01:10 to <deleted>, outbound
          Type is IN-BAND ASYNC, group Dialer1
          Cause: ip (s=172.21.125.1, d=172.21.104.254)

!--- Dialing cause was interesting traffic; this was the 
!--- first link in the bundle.

  IP: Local 172.21.104.48/32
  Bundle: Member of bobslake-nas-01, last input 00:00:00
  Counts: 172 packets input, 20699 bytes, 0 no buffer
          0 input errors, 81 CRC, 0 frame, 0 overrun
          80 packets output, 14347 bytes, 0 underruns
          0 output errors, 0 collisions, 6 interface resets

!--- Packets are passing through the connection.


  User: bobslake-nas-01, line Vi1, service PPP Bundle

!--- Bundle information for user bobslake-nas-01.

        Active time 00:01:16, Idle time 00:01:15
  Timeouts:            Absolute  Idle
      Limits:          -         00:10:00  
      Disconnect in:   -         00:08:44  

!--- Idle-timeout is 600 seconds(10 minutes).

  PPP: LCP Open, multilink Open, IPCP
  Dialer: Connected 00:01:10 to <deleted>, outbound
          Idle timer 600 secs, idle 75 secs
          Type is IN-BAND SYNC, group Dialer1
  IP: Local 172.21.104.48/32, remote 172.21.104.254

!--- IP address assigned to the bundle and loopback address 
!--- of the remote router.

  Bundle: First link of bobslake-nas-01, 2 links, last input 00:01:16
  Counts: 23 packets input, 4758 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          7 packets output, 3734 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

Some show command outputs from the AS5300 are shown below. For more outputs refer to the document Async Multilink PPP Dialup from Microsoft Windows Clients documentation. The show and debug output from the AS5300 (central site) will be similar for PC-Router Async MP and Router-Router Async MP.

bobslake-nas-01#show ppp multilink

Virtual-Access1, bundle name is clearlake-lan-01
  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x1/0x10 rcvd/sent
  0 discarded, 0 lost received, 1/255 load
  Member links: 2 (max not set, min not set)
    Async47
    Async45

bobslake-nas-01#show caller
                                                Active    Idle
  Line         User               Service       Time      Time
  TTY 45       clearlake-lan-01   Async         00:01:12  00:01:03  
  TTY 47       clearlake-lan-01   Async         00:01:51  00:00:06  
  vty 0        admin              VTY           00:11:02  00:00:00  
  As45         clearlake-lan-01   PPP           00:01:02  00:00:00  
  As47         clearlake-lan-01   PPP           00:01:49  00:00:00  
  Vi1          clearlake-lan-01   PPP   Bundle  00:01:43  00:01:10  

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Procedure

When troubleshooting a MP connection, proceed in the same manner the call proceeds:

A Sample debug Output, marked with explanations on what to look for, is provided below.

When testing your MP configuration, ensure that you are generating enough traffic across the link to trigger the load threshold. You can adjust the load-threshold value during your test as necessary.

  1. Use the debug dialer and debug chat commands to verify that the the dialer is dialing correctly.

  2. Verify that PPP negotiation and authentication is successful. Pay attention to the LCP negotiation where MP parameters line Maximum Receive Reconstructed Unit (MRRU) and the Endpoint Discriminator (EndpointDisc) are negotiated.

  3. Verify that the link is virtualized correctly. A Virtual Access interface will be created by the Cisco IOS Software to represent the MP bundle.

  4. Verify that Internet Protocol Control Protocol (IPCP) negotiation was successful. Note whether correct IP addresses were assigned and whether the proper routes were installed.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter tool, which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • debug vtemplate - To display a cloning information for a virtual access interface from the time it is cloned from a virtual template to the time it is taken down.

  • debug ppp multilink events - To display information about events affecting multilink bundles.

  • debug ppp negotiation - To display information on the PPP traffic and exchanges while negotiating Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation will first open the LCP state, then Authenticate, and finally negotiate NCP. Multilink Parameters such as Maximum Receive Reconstructed Unit (MRRU) are established during LCP negotiation.

  • debug ppp authentication - To display PPP authentication protocol messages, including Challenge Handshake Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges.

  • debug ppp error - To display protocol errors and error statistics associated with PPP connection negotiation and operation.

  • debug modem - To display modem line activity on an Access Server.

Sample debug Output

The following outputs were obtained from the Cisco 3640. They show the Cisco 3640 dialing the PRI of the AS5300 and establishing a MP connection. For an example of the debug output of the AS5300 refer to the Async Multilink PPP Dialup from Microsoft Windows Clients document.

clearlake-lan-01#debug dialer
Dial on demand events debugging is on
clearlake-lan-01#debug ppp negotiation
PPP protocol negotiation debugging is on
clearlake-lan-01#debug ppp authentication 
PPP authentication debugging is on
clearlake-lan-01#debug vtemplate 
Virtual Template debugging is on
clearlake-lan-01#debug ppp multilink events
clearlake-lan-01#show debug
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on
  Multilink events debugging is on
VTEMPLATE:
  Virtual Template debugging is on
clearlake-lan-01#ping ip   
Target IP address: 172.21.104.254
Repeat count [5]: 20
Datagram size [100]: 1200
Timeout in seconds [2]: 
Extended commands [n]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 20, 1200-byte ICMP Echos to 172.21.104.254, timeout is 2 seconds:

Jul 25 13:20:29.047 UTC: As34 DDR: rotor dialout [priority]
Jul 25 13:20:29.047 UTC: As34 DDR: Dialing cause ip (s=172.21.125.1, 
d=172.21.104.254)

!--- Dialing Reason

Jul 25 13:20:29.047 UTC: As34 DDR: Attempting to dial <deleted>5551212

!--- Number being dialed

Jul 25 13:20:29.047 UTC: CHAT34: Attempting async line dialer script
Jul 25 13:20:29.047 UTC: CHAT34: Dialing using Modem script: 
async-mppp & System script: none

!--- Using chat script async-mppp for dialout

Jul 25 13:20:29.051 UTC: CHAT34: process started
Jul 25 13:20:29.051 UTC: CHAT34: Asserting DTR
Jul 25 13:20:29.051 UTC: CHAT34: Chat script async-mppp started

!--- Call is being established; 
!--- note the time elapsed for call setup

Jul 25 13:20:54.831 UTC: CHAT34: Chat script async-mppp finished, 
status = Success.
Jul 25 13:20:56.831 UTC: 
%LINK-3-UPDOWN: Interface Async34, changed state to up
Jul 25 13:20:56.831 UTC: 
Async34 DDR: Dialer statechange to up
Jul 25 13:20:56.831 UTC: 
%DIALER-6-BIND: Interface As34 bound to profile Di1
Jul 25 13:20:56.831 UTC: 
Async34 DDR: Dialer call has been placed

!--- PPP negotiation begins

Jul 25 13:20:56.831 UTC: As34 PPP: Treating connection as a callout
Jul 25 13:20:56.831 UTC: As34 PPP: Phase is ESTABLISHING, Active Open
Jul 25 13:20:56.831 UTC: As34 PPP: No remote authentication for call-out

!--- CHAP challenge is configured for callin only
!--- LCP negotiation begins; Multilink parameters are also negotiated

Jul 25 13:20:56.835 UTC: As34 LCP: O CONFREQ [Closed] id 43 len 43
Jul 25 13:20:56.835 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:20:56.835 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:20:56.835 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:20:56.835 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:20:56.835 UTC: As34 LCP:    MRRU 1524 (0x110405F4)

!--- Negotiate Maximum Receive Reconstructed Unit (MRRU)
!--- MRRU is the maximum packet size this end will reconstruct

Jul 25 13:20:56.835 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:20:56.835 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:20:56.835 UTC: As34 LCP:     (0x2D3031).
Jul 25 13:20:58.831 UTC: As34 LCP: TIMEout: State REQsent
Jul 25 13:20:58.831 UTC: As34 LCP: O CONFREQ [REQsent] id 44 Len 43
Jul 25 13:20:58.831 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:20:58.831 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:20:58.831 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:20:58.831 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:20:58.831 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:20:58.831 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:20:58.831 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:20:58.831 UTC: As34 LCP:     (0x2D3031).
Jul 25 13:21:00.831 UTC: As34 LCP: TIMEout: State REQsent
Jul 25 13:21:00.831 UTC: As34 LCP: O CONFREQ [REQsent] id 45 Len 43
Jul 25 13:21:00.831 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:00.831 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:21:00.831 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:00.831 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:00.831 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:00.831 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:00.831 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:00.831 UTC: As34 LCP:     (0x2D3031)
Jul 25 13:21:01.135 UTC: As34 LCP: I CONFACK [REQsent] id 45 Len 43
Jul 25 13:21:01.135 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:01.135 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:21:01.135 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:01.135 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:01.135 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.135 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.135 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:01.135 UTC: As34 LCP:     (0x2D3031)
Jul 25 13:21:01.139 UTC: As34 LCP: I CONFREQ [ACKrcvd] id 6 Len 47
Jul 25 13:21:01.139 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:01.143 UTC: As34 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:01.143 UTC: As34 LCP:    MagicNumber 0xE16DFC8D (0x0506E16DFC8D)
Jul 25 13:21:01.143 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:01.143 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:01.143 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.143 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x3031)
Jul 25 13:21:01.143 UTC: As34 LCP: O CONFACK [ACKrcvd] id 6 Len 47
Jul 25 13:21:01.143 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:01.143 UTC: As34 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:01.143 UTC: As34 LCP:    MagicNumber 0xE16DFC8D (0x0506E16DFC8D)
Jul 25 13:21:01.143 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:01.143 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:01.143 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.143 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x3031)

!--- Both sides have CONFACKed the parameters 
!--- MRRU of 1524 bytes and the Endpoint Discriminator have been negotiated

Jul 25 13:21:01.143 UTC: As34 LCP: State is Open

!--- LCP negotiation complete

Jul 25 13:21:01.147 UTC: As34 PPP: Phase is AUTHENTICATING, by the peer

!--- Received a challenge from the remote router

Jul 25 13:21:01.351 UTC: As34 CHAP: I CHALLENGE id 3 Len 36 
from "bobslake-nas-01"
Jul 25 13:21:01.351 UTC: As34 CHAP: O RESPONSE id 3 Len 
Jul 25 13:21:01.539 UTC: As34 CHAP: I SUCCESS id 3 Len 4

!--- CHAP authentication successful

Jul 25 13:21:01.539 UTC: As34 PPP: Phase is VIRTUALIZED

!--- Virtualize Async 34 
!--- Virtual Access interface will represent the MP bundle

Jul 25 13:21:01.543 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0
Jul 25 13:21:01.543 UTC: Vi1 VTEMPLATE: Hardware address 0030.9401.f101
Jul 25 13:21:01.543 UTC: Vi1 PPP: Phase is DOWN, Setup
Jul 25 13:21:01.543 UTC: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
Jul 25 13:21:01.543 UTC: Vi1 VTEMPLATE: Has a new cloneblk dialer, 
now it has dialer
Jul 25 13:21:01.547 UTC: %LINK-3-UPDOWN: Interface Virtual-Access1, 
changed state to up
Jul 25 13:21:01.547 UTC: Virtual-Access1 DDR: Dialer statechange to up

!--- Virtual Access Interface is up
!--- Negotiate LCP and PPP parameters for Virtual-Access Interface

Jul 25 13:21:01.547 UTC: Virtual-Access1 DDR: Dialer call has been placed
Jul 25 13:21:01.547 UTC: Vi1 PPP: Treating connection as a callout
Jul 25 13:21:01.547 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open
Jul 25 13:21:01.547 UTC: Vi1 PPP: No remote authentication for call-out
Jul 25 13:21:01.547 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 Len 33
Jul 25 13:21:01.547 UTC: Vi1 LCP:    MagicNumber 0x439575FC (0x0506439575FC)
Jul 25 13:21:01.547 UTC: Vi1 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.551 UTC: Vi1 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.551 UTC: Vi1 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:01.551 UTC: Vi1 LCP:     (0x2D3031)
Jul 25 13:21:01.551 UTC: Vi1 PPP: Phase is UP
Jul 25 13:21:01.551 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 Len 10
Jul 25 13:21:01.551 UTC: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
Jul 25 13:21:01.551 UTC: 
As34 MLP: bobslake-nas-01, multilink up, first link

!--- First multilink connection is virtualized

Jul 25 13:21:01.651 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 Len 10
Jul 25 13:21:01.651 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jul 25 13:21:01.651 UTC: Vi1 IPCP: O CONFACK [REQsent] id 1 Len 10
Jul 25 13:21:01.651 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jul 25 13:21:01.731 UTC: Vi1 IPCP: I CONFNAK [ACKsent] id 1 Len 10
Jul 25 13:21:01.731 UTC: Vi1 IPCP:    Address 172.21.104.48 (0x0306AC156830)
Jul 25 13:21:01.731 UTC: Vi1 IPCP: O CONFREQ [ACKsent] id 2 Len 10
Jul 25 13:21:01.731 UTC: Vi1 IPCP:    Address 172.21.104.48 (0x0306AC156830)
Jul 25 13:21:01.915 UTC: Vi1 IPCP: I CONFACK [ACKsent] id 2 Len 10
Jul 25 13:21:01.915 UTC: Vi1 IPCP:    Address 172.21.104.48 (0x0306AC156830)
Jul 25 13:21:01.915 UTC: Vi1 IPCP: State is Open
Jul 25 13:21:01.915 UTC: Di1 IPCP: Install negotiated IP interface 
address 172.21.104.48

!--- IP address is assigned to virtual-access interface

Jul 25 13:21:01.919 UTC: Vi1 DDR: dialer protocol up
Jul 25 13:21:01.919 UTC: Di1 IPCP: Install route to 172.21.104.254

!--- Route to loopback address of remote router

Jul 25 13:21:02.539 UTC: 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Async34, 
changed state to up
Jul 25 13:21:02.551 UTC: 
%LINEPROTO-5-UPDOWN: Line protocol on Interface 
Virtual-Access1, changed state to up

!--- Full connectivity with first async connection
!--- Begin dialout using second async interface

Jul 25 13:21:08.191 UTC: As33 DDR: rotor dialout [priority]
Jul 25 13:21:08.191 UTC: 
As33 DDR: Attempting to dial <deleted>5551212

!--- Number to be dialed; this number is the PRI on the remote router

Jul 25 13:21:08.191 UTC: CHAT33: Attempting async line dialer script
Jul 25 13:21:08.191 UTC: CHAT33: Dialing using Modem script: 
async-mppp & System script: none

!--- Use chat script async-mppp for dialout

Jul 25 13:21:08.191 UTC: CHAT33: process started
Jul 25 13:21:08.191 UTC: CHAT33: Asserting DTR
Jul 25 13:21:08.191 UTC: CHAT33: Chat script async-mppp started
Jul 25 13:21:33.859 UTC: CHAT33: Chat script async-mppp finished, 
status = Success

!--- Chat script successful

Jul 25 13:21:35.859 UTC: %LINK-3-UPDOWN: Interface Async33, 
changed state to up
Jul 25 13:21:35.859 UTC: Async33 DDR: Dialer statechange to up
Jul 25 13:21:35.859 UTC: %DIALER-6-BIND: Interface As33 bound to 
profile Di1
Jul 25 13:21:35.859 UTC: Async33 DDR: Dialer call has been placed

!--- PPP negotiation begins

Jul 25 13:21:35.859 UTC: As33 PPP: Treating connection as a callout
Jul 25 13:21:35.859 UTC: As33 PPP: Phase is ESTABLISHING, Active Open
Jul 25 13:21:35.859 UTC: As33 PPP: No remote authentication for call-out

!--- CHAP challenge is configured for callin only
!--- LCP negotiation begins; Multilink parameters are also negotiated

Jul 25 13:21:35.863 UTC: As33 LCP: O CONFREQ [Closed] id 21 Len 43
Jul 25 13:21:35.863 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:35.863 UTC: As33 LCP:    MagicNumber 0x4395FC05(0x05064395FC05)
Jul 25 13:21:35.863 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:35.863 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:35.863 UTC: As33 LCP:    MRRU 1524 (0x110405F4)

!--- negotiate Maximum Receive Reconstructed Unit (MRRU)

Jul 25 13:21:35.863 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:35.863 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:35.863 UTC: As33 LCP:     (0x2D3031)
Jul 25 13:21:37.859 UTC: As33 LCP: TIMEout: State REQsent
Jul 25 13:21:37.859 UTC: As33 LCP: O CONFREQ [REQsent] id 22 Len 43
Jul 25 13:21:37.859 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:37.859 UTC: As33 LCP:    MagicNumber 0x4395FC05 (0x05064395FC05)
Jul 25 13:21:37.859 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:37.859 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:37.859 UTC: As33 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:37.859 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:37.859 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:37.859 UTC: As33 LCP:     (0x2D3031)
Jul 25 13:21:39.859 UTC: As33 LCP: TIMEout: State REQsent
Jul 25 13:21:39.859 UTC: As33 LCP: O CONFREQ [REQsent] id 23 Len 43
Jul 25 13:21:39.859 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:39.859 UTC: As33 LCP:    MagicNumber 0x4395FC05 (0x05064395FC05)
Jul 25 13:21:39.859 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:39.859 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:39.859 UTC: As33 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:39.859 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:39.859 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:39.859 UTC: As33 LCP:     (0x2D3031)
Jul 25 13:21:40.199 UTC: As33 LCP: I CONFREQ [REQsent] id 6 Len 47
Jul 25 13:21:40.199 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:40.203 UTC: As33 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:40.203 UTC: As33 LCP:    MagicNumber 0xE16E950F (0x0506E16E950F)
Jul 25 13:21:40.203 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:40.203 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:40.203 UTC: As33 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:40.203 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x3031)
Jul 25 13:21:40.203 UTC: As33 LCP: O CONFACK [REQsent] id 6 Len 47

!--- PPP parameters are agreed on (CONFACKed) by both sides

Jul 25 13:21:40.203 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:40.203 UTC: As33 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:40.203 UTC: As33 LCP:    MagicNumber 0xE16E950F (0x0506E16E950F)
Jul 25 13:21:40.203 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:40.203 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:40.203 UTC: As33 LCP:    MRRU 1524 (0x110405F4)

!--- MRRU of 1524 bytes is accepted

Jul 25 13:21:40.203 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x3031)
Jul 25 13:21:40.207 UTC: As33 LCP: I CONFACK [ACKsent] id 23 Len 43
!--- PPP parameters are agreed on (CONFACKed) by both sides
Jul 25 13:21:40.207 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:40.207 UTC: As33 LCP:    MagicNumber 0x4395FC05 (0x05064395FC05)
Jul 25 13:21:40.207 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:40.207 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:40.207 UTC: As33 LCP:    MRRU 1524 (0x110405F4)

!--- MRRU of 1524 bytes is accepted

Jul 25 13:21:40.207 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:40.207 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:40.207 UTC: As33 LCP:     (0x2D3031)

!--- LCP negotiation is complete

Jul 25 13:21:40.207 UTC: As33 LCP: State is Open
Jul 25 13:21:40.207 UTC: As33 PPP: Phase is AUTHENTICATING, by the peer

!--- CHAP authentication begins

Jul 25 13:21:40.419 UTC: As33 CHAP: I CHALLENGE id 3 Len 36 
from "bobslake-nas-01"

!--- Received challenge from bobslake-nas-01

Jul 25 13:21:40.423 UTC: As33 CHAP: O RESPONSE id 3 Len 37 
from "clearlake-lan-01"
Jul 25 13:21:42.528 UTC: As33 CHAP: I SUCCESS id 3 Len 4

!--- CHAP authentication is successful

Jul 25 13:21:42.528 UTC: As33 PPP: Phase is VIRTUALIZED

!--- Async 33 is added to Virtualized MP bundle

Jul 25 13:21:42.528 UTC: As33 MLP: bobslake-nas-01, multilink up

!--- Multilink connection is up

Jul 25 13:21:43.528 UTC: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Async33, 
changed state to up
clearlake-lan-01#
Jul 25 13:23:52.028 UTC: Vi1 MLP: Disabling particle-fastswitching 
in 'bobslake-nas-01'
Jul 25 13:23:52.028 UTC: Vi1 MLP: Enabling particle-fastswitching 
on 'bobslake-nas-01'

!--- Cisco IOS adjusting fast switching strategy to keep in step 
!--- with delivery of packet fragments

Jul 25 13:23:53.872 UTC: Vi1 MLP: Disabling particle-fastswitching 
in 'bobslake-nas-01'
Jul 25 13:23:53.884 UTC: Vi1 MLP: Enabling particle-fastswitching 
on 'bobslake-nas-01'

Related Information

Updated: Oct 25, 2005
Document ID: 9585