Guest

Asynchronous Connections

Sync-Async Ports for Async Modem Dial-in On Cisco 1600, 1700, 2600, and 3600 Platforms

Document ID: 19065

Updated: Feb 04, 2010

   Print

Introduction

This document provides a sample configuration for using sync and async ports for modem dial-in on Cisco 1600, 1700, 2600, and 3600 routers. The following configuration enables you to connect the sync and async interfaces of a router to external client modems that are attached to the router with DB-60 to RS-232 cables.

Note: If you have USR sportster modems, only dip switches 3 and 8 should be down.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software version below.

  • Cisco IOS® Software Release 12.1

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

For more information on installing network modules and port numbering, refer to Connecting Serial Network Modules.

Network Diagram

This document uses the network setup shown in the diagram below.

sync-async.gif

Configurations

This document uses the configuration shown below.

Router 1
show running-config

!
version 12.1
service timestamps debug datetime msec
no service password-encryption
!
hostname router1
!
boot system slot1:c3640-i-mz.121-20
!
username test password 0 test

!--- Local database entries for authentication.

!
memory-size iomem 10
ip subnet-zero
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0
!
interface Serial3/0
 no ip address
!
interface Serial3/1
 no ip address
 shutdown
!
interface Serial3/2
 no ip address
 shutdown
!
interface Serial3/3
 no ip address
 shutdown
!
interface Serial3/4
 no ip address
 shutdown
!
interface Serial3/5
 no ip address
 shutdown
!
interface Serial3/6
 no ip address
 shutdown
!
interface Serial3/7

!--- Interface attached to modem.
 
 physical-layer async

!--- Put the interface into async mode. 
!--- A line appears at the bottom of the configuration.
!--- All the other serial ports on this module are in sync mode.

 ip unnumbered Loopback0

!--- IP address for the interface.

 encapsulation ppp
 async mode interactive

!--- Allow both EXEC and PPP sessions.

 peer default ip address pool default
 
!--- Assign IP address to client.

 ppp authentication chap

!--- Authenticate using Challenge Handshake 
!--- Authentication Protocol (CHAP).

!
ip local pool default 1.1.1.2 

!--- Local IP pool of one IP address for client connect 
!--- on the external modem connected to serial3/7.


ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.100
ip default-gateway 
ip http server
!
line con 0
line 104  

!--- Line 104 associated with serial 3/7.

modem InOut  

!--- Modem attached to line.
 
modem autoconfigure discovery

!--- We are hoping that the modem is a standard hayes 
!--- compatible modem. The configuration worked fine.

transport input all
autoselect during-login
autoselect ppp
transport input all
speed 115200  

line aux 0
 password <removed>                    
 login
line vty 0 4
 password <removed>
 login
!
end
router1#

Notice that after physical-layer async is configured on an interface, a new line number appears in the configuration which needs to be configured (in this example 104). If you do not know which line number is associated with which interface, issue a show line EXEC command to view the mappings. After all of this is configured and all hardware is installed, you must reverse Telnet to the modems to lock data terminal equipment (DTE) speed between the two devices. To do this, Telnet to any IP address on the box which is in an up/up state (loopback interfaces are great for this) with the port number 2000+x where x is the line number the modem is attached to. In this example, the modem is on line 104, so Telnet to the loopback address (1.1.1.1) port 2104. You can then issue an AT command at the blank line and the modem should echo back 'OK'. To disconnect, hit Ctrl-Shift-6 and then x to get back to the router prompt and then type in disconnect to close the connection.

Note: Make sure you close the connection or it will not work.

For example:

router1#telnet 1.1.1.1 2104
Trying 1.1.1.1, 2104 ... Open
at
OK
router1#disconnect
Closing connection to 1.1.1.1 [confirm]
router1#

Sometimes you need to issue the command at&b0&w0 to the modem before the DTE speed is locked completely. After the reverse Telnet is complete, dial into the router with a hyperterminal (or other ASCII program) and see if you can get a router prompt. The settings should be 8N1. If this works, then PPP connectivity should work also.

Verify

This section provides information you can use to confirm any cabling issue. Below is a cabling diagram for the sync/async card. Also, please make sure that your modem hardware states under the line (104) are similar to what is explained below.

Sync/async port(DB60 female)<------( CAB-232MT=, Part# 72-0793-01)-------->External Modem 

Note: The CAB-232MT cable is a DTE cable, which makes the router act as a DTE device. You need it to connect to a modem (DCE device). If you are connecting sync/async ports to a terminal device (DTE), you need to use DCE cable (CAB-232FC=) which makes the router act as a DCE device.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show diag - Displays diagnostic information about the controller, interface processor, and port adapters for a networking device.

  • show interfaces serial - Displays information about a serial interface.

  • show line - Displays the parameters of a terminal line.

router1#show diag 
Slot 0: 
.... 
.... 
<snipped> 
.... 
Slot 3: 
        Sync/Async Port adapter, 8 ports 
        Port adapter is analyzed 
        Port adapter insertion time unknown 
        EEPROM contents at hardware discovery: 
        Hardware revision 1.0           Board revision H0 
        Serial number     10532987      Part number    800-01225-02 
        Test history      0x0           RMA number     00-00-00 
        EEPROM format version 1 
        EEPROM contents (hex): 
          0x20: 01 25 01 00 00 A0 B8 7B 50 04 C9 02 00 00 00 00 
          0x30: 88 00 00 00 98 10 23 17 FF FF FF FF FF FF FF FF 
router1#show interfaces serial 3/7 
Serial3/7 is down, line protocol is down 
  Hardware is CD2430 in async mode 
  MTU 1500 bytes, BW 9 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
.... 
router1#show interfaces serial 3/0 
Serial3/0 is down, line protocol is down 
  Hardware is CD2430 in sync mode 
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
router1#show line
   Tty  Typ    Tx/Rx      A  Modem  Roty AccO AccI   Uses  Noise  Overruns   Int
*    0  CTY     -  -      -    -     -     0     0      0/0         -
I   104 TTY 115200/115200 - inout    -     -     -      0    0      0/0      Se3/7
    129 AUX  9600/9600    -    -     -     -     -      0    0      0/0        -
    130 VTY               -    -     -     -     -      0    0      0/0        -
    131 VTY               -    -     -     -     -      0    0      0/0        -
    132 VTY               -    -     -     -     -      0    0      0/0        -
    133 VTY               -    -     -     -     -      0    0      0/0        -    
    134 VTY               -    -     -     -     -      0    0      0/0        -

Line(s) not in async mode -or- with no hardware support:
1-96, 98-128
router1#show line 104 
   Tty Typ   Tx/Rx      A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
I 104  TTY 115200/115200- inout   -    -    -      0       0      0/0      Se3/7 

Line 104, Location: "", Type: "" 
Length: 24 lines, Width: 80 columns 
Baud rate (TX/RX) is 115200/115200, no parity, 2 stopbits, 8 databits 
Status: No Exit Banner 
Capabilities: Modem Callout, Modem RI is CD, 
  Line usable as async interface 
Modem state: Idle 
Modem hardware state: noCTS noDSR  DTR RTS         

!--- External connected modem is off.
 
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation 
                ^^x    none   -     -       none 
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch 
               00:10:00        never                        none     not set 
                            Idle Session Disconnect Warning 
                              never 
                            Login-sequence User Response 
                             00:00:30 
                            Autoselect Initial Wait 
                              not set 
Modem type is unknown. 
Session limit is not set. 
Time since activation: never 
Editing is enabled. 
History is enabled, history size is 10. 
DNS resolution in show commands is enabled 
Full user help is disabled 
Allowed input transports are pad v120 lapb-ta telnet rlogin udptn. 
Allowed output transports are pad v120 lapb-ta telnet rlogin. 
Preferred transport is telnet. 
No output characters are padded 
No special data dispatching characters 
router1# 
router1#show line 104 
   Tty Typ Tx/Rx         A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
   104 TTY 115200/115200 -  inout  -    -    -      0       0       0/0     Se3/7 

Line 104, Location: "", Type: "" 
Length: 24 lines, Width: 80 columns 
Baud rate (TX/RX) is 115200/115200, no parity, 2 stopbits, 8 databits 
Status: No Exit Banner, CTS Raised 
Capabilities: Modem Callout, Modem RI is CD 
Modem state: Idle 
Modem hardware state: CTS noDSR  DTR RTS            

!--- External connected modem is ON, without any call on it.
 
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation 
                ^^x    none   -     -       none 
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch 
               00:10:00        never                        none     not set 
                            Idle Session Disconnect Warning 
                              never 
                            Login-sequence User Response 
                             00:00:30 
                            Autoselect Initial Wait 
                              not set 
Modem type is unknown. 
Session limit is not set. 
Time since activation: never 
Editing is enabled. 
History is enabled, history size is 10. 
DNS resolution in show commands is enabled 
Full user help is disabled 
Allowed input transports are pad v120 lapb-ta telnet rlogin udptn. 
Allowed output transports are pad v120 lapb-ta telnet rlogin. 
Preferred transport is telnet. 
No output characters are padded 
No special data dispatching characters 
route1# 
router1#show line 104 
   Tty Typ  Tx/Rx       A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
* 104 TTY 115200/115200 - inout   -    -    -       0      1       0/0     Se3/7 

Line 104, Location: "", Type: "" 
Length: 24 lines, Width: 80 columns 
Baud rate (TX/RX) is 115200/115200, no parity, 2 stopbits, 8 databits 
Status: PSI Enabled, Ready, Active, No Exit Banner, CTS Raised 
  Automore On 
Capabilities: Modem Callout, Modem RI is CD 
Modem state: Ready 
Modem hardware state: CTS DSR  DTR RTS              

!--- External connected modem is ON,  with an active EXEC call on it.
 
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation 
                ^^x    none   -     -       none 
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch 
               00:10:00        never                        none     not set 
                            Idle Session Disconnect Warning 
                              never 
                            Login-sequence User Response 
                             00:00:30 
                            Autoselect Initial Wait 
                              not set 
Modem type is unknown. 
Session limit is not set. 
Time since activation: 00:01:17 
Editing is enabled. 
History is enabled, history size is 10. 
DNS resolution in show commands is enabled 
Full user help is disabled 
Allowed input transports are pad v120 lapb-ta telnet rlogin udptn. 
Allowed output transports are pad v120 lapb-ta telnet rlogin. 
Preferred transport is telnet. 
No output characters are padded 
No special data dispatching characters 
router1#show interfaces serial 3/7 
Serial3/7 is down, line protocol is down                                      

!--- External connected modem is ON,  with an active call in EXEC mode.
 
  Hardware is CD2430 in async mode 
  Interface is unnumbered. Using address of Loopback0 (10.10.10.10) 
  MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation PPP, loopback not set 
  Keepalive not set 
  DTR is pulsed for 5 seconds on reset 
  LCP Closed 
  Closed: IPCP 
  Last input 00:50:32, output 00:51:29, output hang never 
  Last clearing of "show interface" counters 00:00:38 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: weighted fair 
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/1/16 (active/max active/max total) 
     Reserved Conversations 0/0 (allocated/max allocated) 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     0 packets input, 0 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     0 packets output, 0 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
     0 carrier transitions 
router1# 

Troubleshoot

The verification section above provides most of the infomation as far as cable connection and async communication control signals (CTS DSR DTR RTS ) are concerned. With the above configuration of Router 1, the user should be able to dial.

  • EXEC Mode - In EXEC mode, the user can dial from a modem using a serial terminal utility (like hyperterm/procomm) to the extermal modem connected to sync/async port. After successful trainup between modems, a user should get a router1 prompt . All of the above show commands in verification section are collected during EXEC connection to the router.

  • PPP Mode - In PPP mode, a user can dial from a modem using Windows dialup networking to the external modem connected on the sync/async port. If dialing in EXEC mode is working, PPP should also work without any issue. Please make sure the configuration is exactly the same as mentioned above. To troubleshoot PPP mode, dialin using the following debug commands which are needed to turn on along with the milliseconds time stamping. Follow the debug lines which are in bold to see how far you are going in the debugs. Please use the following PPP Troubleshooting Flowchart if you need further information.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, please see Important Information on Debug Commands.

  • service timestamps debug datetime msec - Used to turn on millisecond time stamping for debugs.

  • debug modem - Used to observe modem line activity on an access server.

  • debug ppp negotiation - Used to see if a client is passing PPP negotiation.

  • debug ppp authentication - Used to see if a client is passing authentication.

  • debug chat - Used to display chat script activity.

  • debug confmodem - Used to display information associated with the discovery and configuration of the modem attached to the router.

  • show debugging - Used to display information about the types of debugging that are enabled for your router.

  • show users - Used to display information about the active lines on the router.

Please see the command output below for troubleshooting command examples.

router1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z. 
router1(config)#service timestamps debug datetime msec       

!--- Turned on millisecond time stamping for debugs.
 
router1(config)#end 
router1# 
router1#debug modem 
router1#debug ppp negotiation 
router1#debug ppp authentication 
router1#debug chat 
router1#debug confmodem 

router1#show debugging 
General OS: 
  Modem control/process activation debugging is on 
PPP: 
  PPP authentication debugging is on 
  PPP protocol negotiation debugging is on 
Chat Scripts: 
  Chat scripts activity debugging is on 
router1# 


!--- The following is the above mentioned 
!--- debugs log collected from rotuer, 
!--- when a PPP user tried to dialin with a username = test, password = test. 


router1# 
router1#clear line 104 
[confirm] 
 [OK] 
router1# 
*Mar  1 00:06:34.563: TTY104: Line reset by "Exec" 
*Mar  1 00:06:34.567: TTY104: Modem: IDLE->HANGUP 
*Mar  1 00:06:34.567: TTY104: destroy timer type 0 
*Mar  1 00:06:34.567: TTY104: destroy timer type 1 
*Mar  1 00:06:34.567: TTY104: destroy timer type 3 
*Mar  1 00:06:34.567: TTY104: destroy timer type 4 
*Mar  1 00:06:34.567: TTY104: destroy timer type 2 
*Mar  1 00:06:35.139: TTY104: dropping DTR, hanging up 
*Mar  1 00:06:35.139: tty104: Modem: HANGUP->IDLE 
*Mar  1 00:06:40.139: TTY104: restoring DTR 
*Mar  1 00:06:41.139: TTY104: autoconfigure probe started 
*Mar  1 00:06:41.139: TTY104: Modem command:  --AT&F&C1&D2S0=1H0-- 
*Mar  1 00:06:43.675: TTY104: Modem configuration succeeded 
*Mar  1 00:06:43.675: TTY104: Detected modem speed 115200 
*Mar  1 00:06:43.675: TTY104: Done with modem configuration 
router1# 
router1#                              

!--- Below are debugs when the PPP user tried to dialin.
 
*Mar  1 00:08:43.163: TTY104: DSR came up 
*Mar  1 00:08:43.163: tty104: Modem: IDLE->(unknown) 
*Mar  1 00:08:43.163: TTY104: Autoselect started 
*Mar  1 00:08:43.163: TTY104: create timer type 0, 120 seconds 
*Mar  1 00:08:44.699: TTY104: Autoselect sample 7E 
*Mar  1 00:08:44.699: TTY104: Autoselect sample 7EFF 
*Mar  1 00:08:44.699: TTY104: Autoselect sample 7EFF7D 
*Mar  1 00:08:44.699: TTY104: Autoselect sample 7EFF7D23 
*Mar  1 00:08:44.699: TTY104 Autoselect cmd:  ppp negotiate 
*Mar  1 00:08:44.699: TTY104: destroy timer type 0 (OK) 
*Mar  1 00:08:44.703: TTY104: EXEC creation 
*Mar  1 00:08:44.703: TTY104: create timer type 1, 600 seconds 
*Mar  1 00:08:44.707: TTY104: destroy timer type 1 (OK) 
*Mar  1 00:08:44.707: TTY104: destroy timer type 0 
00:08:46: %LINK-3-UPDOWN: Interface Serial3/7, changed state to up 
*Mar  1 00:08:46.707: Se3/7 PPP: Treating connection as a dedicated line 
*Mar  1 00:08:46.707: Se3/7 PPP: Phase is ESTABLISHING, Active Open 
*Mar  1 00:08:46.707: Se3/7 LCP: O CONFREQ [Closed] id 3 len 25 
*Mar  1 00:08:46.707: Se3/7 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Mar  1 00:08:46.707: Se3/7 LCP:    AuthProto CHAP (0x0305C22305) 
*Mar  1 00:08:46.707: Se3/7 LCP:    MagicNumber 0x0014A697 (0x05060014A697) 
*Mar  1 00:08:46.707: Se3/7 LCP:    PFC (0x0702) 
*Mar  1 00:08:46.707: Se3/7 LCP:    ACFC (0x0802) 
*Mar  1 00:08:46.863: Se3/7 LCP: I CONFACK [REQsent] id 3 len 25 
*Mar  1 00:08:46.863: Se3/7 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Mar  1 00:08:46.863: Se3/7 LCP:    AuthProto CHAP (0x0305C22305) 
*Mar  1 00:08:46.863: Se3/7 LCP:    MagicNumber 0x0014A697 (0x05060014A697) 
*Mar  1 00:08:46.863: Se3/7 LCP:    PFC (0x0702) 
*Mar  1 00:08:46.863: Se3/7 LCP:    ACFC (0x0802) 
*Mar  1 00:08:47.703: Se3/7 LCP: I CONFREQ [ACKrcvd] id 2 len 50 
*Mar  1 00:08:47.703: Se3/7 LCP:    ACCM 0x00000000 (0x020600000000) 
*Mar  1 00:08:47.703: Se3/7 LCP:    MagicNumber 0x44B3482A (0x050644B3482A) 
*Mar  1 00:08:47.703: Se3/7 LCP:    PFC (0x0702) 
*Mar  1 00:08:47.703: Se3/7 LCP:    ACFC (0x0802) 
*Mar  1 00:08:47.703: Se3/7 LCP:    Callback 6  (0x0D0306) 
*Mar  1 00:08:47.703: Se3/7 LCP:    MRRU 1614 (0x1104064E) 
*Mar  1 00:08:47.703: Se3/7 LCP:    EndpointDisc 1 Local 
*Mar  1 00:08:47.703: Se3/7 LCP:     (0x131701362F5B168BFB407785EE942EB8) 
*Mar  1 00:08:47.703: Se3/7 LCP:     (0xEF5D0700000000) 
*Mar  1 00:08:47.703: Se3/7 LCP: O CONFREJ [ACKrcvd] id 2 len 11 
*Mar  1 00:08:47.703: Se3/7 LCP:    Callback 6  (0x0D0306) 
*Mar  1 00:08:47.707: Se3/7 LCP:    MRRU 1614 (0x1104064E) 
*Mar  1 00:08:47.855: Se3/7 LCP: I CONFREQ [ACKrcvd] id 3 len 43 
*Mar  1 00:08:47.855: Se3/7 LCP:    ACCM 0x00000000 (0x020600000000) 
*Mar  1 00:08:47.855: Se3/7 LCP:    MagicNumber 0x44B3482A (0x050644B3482A) 
*Mar  1 00:08:47.855: Se3/7 LCP:    PFC (0x0702) 
*Mar  1 00:08:47.855: Se3/7 LCP:    ACFC (0x0802) 
*Mar  1 00:08:47.855: Se3/7 LCP:    EndpointDisc 1 Local 
*Mar  1 00:08:47.855: Se3/7 LCP:     (0x131701362F5B168BFB407785EE942EB8) 
*Mar  1 00:08:47.855: Se3/7 LCP:     (0xEF5D0700000000) 
*Mar  1 00:08:47.855: Se3/7 LCP: O CONFACK [ACKrcvd] id 3 len 43 
*Mar  1 00:08:47.855: Se3/7 LCP:    ACCM 0x00000000 (0x020600000000) 
*Mar  1 00:08:47.855: Se3/7 LCP:    MagicNumber 0x44B3482A (0x050644B3482A) 
*Mar  1 00:08:47.855: Se3/7 LCP:    PFC (0x0702) 
*Mar  1 00:08:47.859: Se3/7 LCP:    ACFC (0x0802) 
*Mar  1 00:08:47.859: Se3/7 LCP:    EndpointDisc 1 Local 
*Mar  1 00:08:47.859: Se3/7 LCP:     (0x131701362F5B168BFB407785EE942EB8) 
*Mar  1 00:08:47.859: Se3/7 LCP:     (0xEF5D0700000000) 
*Mar  1 00:08:47.859: Se3/7 LCP: State is Open 
*Mar  1 00:08:47.859: Se3/7 PPP: Phase is AUTHENTICATING, by this end 
*Mar  1 00:08:47.859: Se3/7 CHAP: O CHALLENGE id 2 len 28 from "router1" 
*Mar  1 00:08:48.015: Se3/7 LCP: I IDENTIFY [Open] id 4 len 18 magic 0x44B3482A MSRASV5.00 
*Mar  1 00:08:48.031: Se3/7 LCP: I IDENTIFY [Open] id 5 len 27 magic 0x44B3482A MSRAS-1-IRAH-W2K 
*Mar  1 00:08:48.043: Se3/7 CHAP: I RESPONSE id 2 len 25 from "test" 
*Mar  1 00:08:48.043: Se3/7 CHAP: O SUCCESS id 2 len 4 
*Mar  1 00:08:48.047: Se3/7 PPP: Phase is UP 
*Mar  1 00:08:48.047: Se3/7 IPCP: O CONFREQ [Closed] id 2 len 10 
*Mar  1 00:08:48.047: Se3/7 IPCP:    Address 10.10.10.10 (0x03060A0A0A0A) 
*Mar  1 00:08:48.175: Se3/7 CCP: I CONFREQ [Not negotiated] id 6 len 10 
*Mar  1 00:08:48.175: Se3/7 CCP:    MS-PPC supported bits 0x00000001 (0x120600000001) 
*Mar  1 00:08:48.175: Se3/7 LCP: O PROTREJ [Open] id 4 len 16 protocol CCP (0x80FD0106000A120600000001) 
*Mar  1 00:08:48.191: Se3/7 IPCP: I CONFREQ [REQsent] id 7 len 40 
*Mar  1 00:08:48.191: Se3/7 IPCP:    CompressType VJ 15 slots CompressSlotID (0x0206002D0F01) 
*Mar  1 00:08:48.191: Se3/7 IPCP:    Address 0.0.0.0 (0x030600000000) 
*Mar  1 00:08:48.191: Se3/7 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000) 
*Mar  1 00:08:48.195: Se3/7 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000) 
*Mar  1 00:08:48.195: Se3/7 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000) 
*Mar  1 00:08:48.195: Se3/7 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000) 
*Mar  1 00:08:48.195: Se3/7 IPCP: O CONFREJ [REQsent] id 7 len 34 
*Mar  1 00:08:48.195: Se3/7 IPCP:    CompressType VJ 15 slots CompressSlotID (0x0206002D0F01) 
*Mar  1 00:08:48.195: Se3/7 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000) 
*Mar  1 00:08:48.195: Se3/7 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000) 
*Mar  1 00:08:48.195: Se3/7 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000) 
*Mar  1 00:08:48.195: Se3/7 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000) 
*Mar  1 00:08:48.199: Se3/7 IPCP: I CONFACK [REQsent] id 2 len 10 
*Mar  1 00:08:48.199: Se3/7 IPCP:    Address 10.10.10.10 (0x03060A0A0A0A) 
*Mar  1 00:08:48.343: Se3/7 IPCP: I CONFREQ [ACKrcvd] id 8 len 10 
*Mar  1 00:08:48.343: Se3/7 IPCP:    Address 0.0.0.0 (0x030600000000) 
*Mar  1 00:08:48.343: Se3/7 IPCP: O CONFNAK [ACKrcvd] id 8 len 10 
*Mar  1 00:08:48.343: Se3/7 IPCP:    Address 1.1.1.2 (0x030601010102) 
*Mar  1 00:08:48.483: Se3/7 IPCP: I CONFREQ [ACKrcvd] id 9 len 10 
*Mar  1 00:08:48.483: Se3/7 IPCP:    Address 1.1.1.2 (0x030601010102) 
*Mar  1 00:08:48.483: Se3/7 IPCP: O CONFACK [ACKrcvd] id 9 len 10 
*Mar  1 00:08:48.483: Se3/7 IPCP:    Address 1.1.1.2 (0x030601010102) 
*Mar  1 00:08:48.487: Se3/7 IPCP: State is Open 
*Mar  1 00:08:48.487: Se3/7 IPCP: Install route to 1.1.1.2
00:08:49: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/7, 
changed state to up 
router1# 
router1#show interfaces serial 3/7 
Serial3/7 is up, line protocol is up 
  Hardware is CD2430 in async mode 
  Interface is unnumbered. Using address of Loopback0 (10.10.10.10) 
  MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation PPP, loopback not set 
  Keepalive not set 
  DTR is pulsed for 5 seconds on reset 
  LCP Open 
  Open: IPCP 
  Last input 00:00:00, output 00:00:09, output hang never 
  Last clearing of "show interface" counters 00:08:42 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: weighted fair 
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/1/16 (active/max active/max total) 
     Reserved Conversations 0/0 (allocated/max allocated) 
  5 minute input rate 0 bits/sec, 1 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     157 packets input, 10790 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     2 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     26 packets output, 975 bytes, 0 underruns 
     0 output errors, 0 collisions, 1 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
     0 carrier transitions
router1#show users 
      Line      User       Host(s)         Idle     Location 
*  0 con 0                  idle           00:00:00 
 104 tty 104   test       Async interface  00:00:01  PPP: 1.1.1.2 

  Interface      User        Mode           Idle     Peer Address 
router1#ping  1.1.1.2 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 156/163/172 ms 
router1# 

Related Information

Updated: Feb 04, 2010
Document ID: 19065