Guest

Cable Modems

Configuring Cable Modem Bridging

Cisco - Configuring Cable Modem Bridging

Document ID: 12173

Updated: Nov 21, 2007

   Print

Introduction

In general bridges operate at the data link layer (Layer 2) of the Open System Interconnection (OSI) reference model. A bridge will filter, forward, or flood an incoming frame based on the Media Access Control (MAC) address of that frame.

Bridging is the default configuration that cable modems get when they come online.

In bridging applications, the Cisco uBR900 series cable access router acts as a transparent bridge for up to 254 devices on the ethernet port when running Cisco IOS® Software Release 12.0.5T1 and later. Earlier versions of Cisco IOS Software support a maximum of three devices on the Ethernet port of the Cisco uBR900 series router.

This configuration was tested with a uBR904 running Cisco IOS Software Release 12.0(7)T and Cisco uBR7223 running Cisco IOS Software Release 12.1(2)T.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • A uBR904 running Cisco IOS Software Release 12.0(7)T

  • A Cisco uBR7223 running Cisco IOS Software Release 12.1(2)T

Configuration

Network Diagram

bridging_cm_sample_config.gif

Configuration

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

uBR900
Current configuration:
!
! No configuration change since last restart
!version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
clock timezone - 0
ip subnet-zero
no ip routing  

!--- Router is operating in bridging mode.
     
!
!
!         
!
!
interface Ethernet0
 ip address 10.1.1.26 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 cable-modem downstream saved channel 453000000 28 1
 cable-modem mac-timer t2 60000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.10

ip classless
no ip http server
!         
!
line con 0
 transport input none
line vty 0 4
!
end

Router#

Note: The above configuration was obtained after powering up the Cable Modem and achieving online status. There has been no configuration changes since factory defaults . Also note that in older Cisco IOS versions the Cable Interface will show an actual IP address, as opposed to "ip address negotiated."

uBR7200
Current configuration:
!
! Last configuration change at 16:55:41 UTC Mon Nov 20 2000
! NVRAM config last updated at 16:55:12 UTC Mon Nov 20 2000
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sniper
!
boot system flash ubr7200-ik1s-mz_121-2_T.bin
no logging buffered
enable password cisco
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
!
!
!         
ip subnet-zero
no ip domain-lookup
!
no lane client flush
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.139 255.255.255.224
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown 
!         
interface Ethernet1/3
 no ip address
 shutdown 
!         
interface Ethernet1/4
 no ip address
 shutdown 
!         
interface Ethernet1/5
 no ip address
 shutdown 
!         
interface Ethernet1/6
 no ip address
 shutdown 
!         
interface Ethernet1/7
 no ip address
 shutdown 
!         
interface Cable2/0
 ip address 10.10.1.1 255.255.255.0 secondary
 ip address 10.1.1.10 255.255.255.0
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 451250000
 cable upstream 0 frequency 28000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy
 cable helper-address 172.17.110.136
!         
interface Cable3/0
 no ip address
 no keepalive
 shutdown 
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!         

ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!         

!         
line con 0
exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 login    
line vty 1 4
 password cisco
 login    
!         
end

Verification

Note: Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

To make sure things are working enter the show cable modem command on Cisco uBR7200. This will list the status of the cable modems that are attached to this Cisco uBR7200. Below is an output display taken from the uBR7200 router above:

sniper#sh cable modem 
Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 11   online     2287    0.25  5   0   10.1.1.25       0050.7366.2223
Cable2/0/U0 12   online     2812    0.25  5   0   10.1.1.28       0001.9659.4415
Cable2/0/U0 13   online     2810   -0.50  5   0   10.1.1.20       0030.96f9.65d9
Cable2/0/U0 14   online     2290    0.50  5   0   10.1.1.26       0050.7366.2221
Cable2/0/U0 15   online     2292    0.25  5   0   10.1.1.30       0050.7366.1fb9
Cable2/0/U0 16   online     2815    0.00  5   0   10.1.1.27       0001.9659.4461

If the state does not show "online" we need to troubleshoot this. From the Cisco uBR900, you can enter debug cable-modem mac log verbose. For more information on troubleshooting see Troubleshooting uBR Cable Modems Not Coming Online.

Related Information

Updated: Nov 21, 2007
Document ID: 12173