Guest

LAN Emulation (LANE)

LAN Emulation Using the ATM Router Module

Cisco - LAN Emulation Using the ATM Router Module

Document ID: 10403

Updated: Nov 15, 2007

   Print

Introduction

This document provides a sample configuration for LAN emulation using the ATM router module (ARM).

ARM provides the Catalyst 8540 Multiservice Switch Router (MSR) and 8510 MSR with high-speed internetworking between the Layer 2 and Layer 3 network topologies. When ARM is installed, you no longer need to choose Layer 3 or ATM technology, as is frequently the case with enterprise and metropolitan area applications. Instead, you can have both Layer 3 and ATM technologies in the same multiservice ATM switch router chassis.

A Catalyst 8510 or 8540 MSR equipped with ARM functionality provides bridging and routing from Ethernet to ATM and from ATM to ATM.

ARM offers interoperability between the Layer 3 switching interface modules used in the Catalyst 8510 or 8540 CSR (Campus Switch Router) and the ATM port adapters and interface modules used in the Catalyst 8510 or 8540 MSR chassis. You can therefore combine Layer 3 and ATM port adapters and interface modules in a Catalyst 8510 or 8540 MSR chassis equipped with ARM. Refer to Major Differences Between Cisco Catalyst 8540 CSR and Cisco Catalyst 8540 MSR to learn more about the differences between Catalyst 8500 MSR and Catalyst 8500 CSR.

You can install up to two ARMs in the slots numbered from 0 to 3 and from 9 to 12 in the Catalyst 8510 or 8540 MSR chassis.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

LAN emulation using ARM was introduced on the Catalyst 8510 MSR in Cisco IOS® Software Release12.0(10)W5(18b) and on the Catalyst 8540 MSR in Cisco IOS Software Release12.0(4a)W5(11a).

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Features Supported

ARM is based on Cisco express forwarding (CEF) and supports these features:

  • Open Shortest Path First (OSPF), Routing Information Protocol (RIP), RIP2, Interior Gateway Routing Protocol (IGRP), and Enhanced IGRP.

  • Internet Control Message Protocol (ICMP) Destination Unreachable and Redirect messages.

  • Load balancing up to two equal paths.

  • Integrated routing and bridging (IRB).

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup. There is an ARM card in slot 9.

atm_arm_rt.gif

Configurations

This document uses these configurations:

Note: These configurations only show the commands relevant for LANE.

Catalyst 5500 (Switch)
set vlan 3 4/5
set vlan 2 4/4

Catalyst 5500 (LANE Card)
hostname ATM
!
!
!
lane database ARM
 name elan2 server-atm-address 47.009181000000009021449C01.00E01E2EE861.02
 name elan3 server-atm-address 47.009181000000009021449C01.00E01E2EE861.03
!
interface Ethernet0
!
interface ATM0
 atm preferred phy B
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database ARM
!
interface ATM0.2 multipoint
 lane server-bus ethernet elan2
 lane client ethernet 2 elan2
!
interface ATM0.3 multipoint
 lane server-bus ethernet elan3
 lane client ethernet 3 elan3

Cisco 7000
hostname 7000a
!
interface Loopback0
 ip address 140.40.40.1 255.255.255.0
!
interface Ethernet0/3
 ip address 45.45.45.2 255.255.255.0
!
router eigrp 1
 network 45.0.0.0
 network 140.40.0.0

Cisco 7206
hostname 7206B
!
interface Loopback0
 ip address 150.50.50.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet6/0
 ip address 40.40.40.2 255.255.255.0
 no ip directed-broadcast
!
router eigrp 1
 network 40.0.0.0
 network 150.50.0.0

Catalyst 8540 MSR
hostname C8540-MSR
!
interface Loopback0
 ip address 160.60.60.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM9/0/0
 no ip address
 no ip directed-broadcast
!
interface ATM9/0/0.2 multipoint
 ip address 40.40.40.1 255.255.255.0
 no ip directed-broadcast
 lane client ethernet elan2
!
interface ATM9/0/0.3 multipoint
 ip address 45.45.45.1 255.255.255.0
 no ip directed-broadcast
 lane client ethernet elan3
!
router eigrp 1
 network 40.0.0.0
 network 45.0.0.0
 network 160.60.0.0
 no auto-summary

show Commands

This section provides information that you can use to confirm that your configuration is working properly.

Issue these commands to test whether your network is operating properly:

  • ping

  • show ip route

  • show ip cef

  • show lane le-arp interface atm card/subcard/port[.subinterface-number]

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

The next sample output is a result of entering these commands on the devices shown in the network diagram. This output shows that the network is operating properly. The ping goes from the ATM9/0/0.3 interface of the Catalyst 8540 MSR to the Ethernet0/3 interface of the Cisco 7000 Router.

C8540-MSR# ping 45.45.45.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 45.45.45.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

You can also test connectivity between the Catalyst 8540 MSR and the Cisco 7200 Router by pinging the Ethernet6/0 interface of the Cisco 7206 from the Catalyst 8540. This sample output shows that the ping is successful.

C8540-MSR# ping 40.40.40.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.40.40.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Another way to test connectivity is by issuing the show ip route command. The Catalyst 8540 MSR has a route to the network behind the Cisco 7200 Router by the address 150.50.0.0—learned by IGRP—and has a route to the network behind the Cisco 7000 Router by the address 140.40.0.0—learned via IGRP as well.

C8540-MSR# show ip route

D  140.40.0.0/16 [90/130816] via 45.45.45.2, 00:34:58, ATM9/0/0.3
   172.16.0.0/24 is subnetted, 1 subnets
   160.60.0.0/24 is subnetted, 1 subnets
C  160.60.60.0 is directly connected, Loopback0
C  40.40.40.0 is directly connected, ATM9/0/0.2
D  150.50.0.0/16 [90/130816] via 40.40.40.2, 00:29:50, ATM9/0/0.2
   45.0.0.0/24 is subnetted, 1 subnets
C  45.45.45.0 is directly connected, ATM9/0/0.3

C8540-MSR# show ip cef

40.40.40.0/24       attached               ATM9/0/0.2
40.40.40.0/32       receive
40.40.40.1/32       receive
40.40.40.2/32       40.40.40.2             ATM9/0/0.2
40.40.40.255/32     receive
45.45.45.0/24       attached               ATM9/0/0.3
45.45.45.0/32       receive
45.45.45.1/32       receive
45.45.45.2/32       45.45.45.2             ATM9/0/0.3
45.45.45.255/32     receive
140.40.0.0/16       45.45.45.2             ATM9/0/0.3
150.50.0.0/16       40.40.40.2             ATM9/0/0.2
160.60.60.0/24      attached               Loopback0
160.60.60.0/32      receive
160.60.60.1/32      receive
160.60.60.255/32    receive

To see the LANE ARP table for the subinterfaces on the Catalyst 8540, issue the show lane le-arp command.

C8540-MSR# show lane le-arp interface atm 9/0/0.2

Hardware Addr   ATM Address                                  VCD  Interface
0030.7b1e.90a8  47.009181000000009021449C01.00E01E2EE860.02  878  ATM9/0/0.2

C8540-MSR# show lane le-arp interface atm 9/0/0.3

Hardware Addr   ATM Address                                  VCD  Interface
0000.0c0d.fdcb  47.009181000000009021449C01.00E01E2EE860.03  876  ATM9/0/0.3

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Nov 15, 2007
Document ID: 10403