Guest

Cisco 500 Series Content Engines

Configuring Transparent and Proxy Media Redirection Using ACNS Software 4.x

Cisco - Configuring Transparent and Proxy Media Redirection Using ACNS Software 4.x

Introduction

This document describes how to configure the Cisco Cache/Content Engine for transparent and proxy media caching using Web Cache Coordination Protocol (WCCP) version 2. Cisco ACNS Release 4.x, includes, as an option, the RealProxy from RealNetworks, Inc. leavingcisco.com to support both stream splitting (distributing live feeds) and streaming media caching (on-demand content) in both Real-Time Streaming Protocol (RTSP)-based streaming and other Real PNM (RealNetworks metafile) formats.

The Content Engine can be configured to transparently accept RTSP requests redirected from the WCCP router, as well as traditional proxy-style RTSP requests from RealPlayer client software. Streaming media caching provides content on demand to the extend that, if a user has already viewed a cached streaming media file, it can be served to subsequent users without the requirement to connect to the origin server. Be aware that live broadcasts cannot be cached.

To configure the Content Engine to accept RTSP traffic, complete these steps:

  1. Issue the rtsp proxy command in global configuration mode for entering the IP address, port, and the license used in the RealProxy of the Content Engine.

  2. Issue the wccp media-cache global configuration command to register the Content Engine with any WCCP-enabled routers.

Streaming media objects are cached in the media file system (mediafs) disk partitions while the RealProxy software is copied to the software file system (swfs) partition as part of the installation procedure. Issue the disk command to create the mediafs partitions; issue the mediafs command to maintain these partitions (refer to Maintaining the Hard Disk Storage for further information on disk partitions). The RealProxy software can be administered with the RealAdministrator GUI (to access this page, the default username/password is admin/diamond).

To configure WCCP-enabled routers, you need to issue the wccp service-group 80 command. Command output is shown in the Configurations section.

Before You Begin

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Requirements

Readers of this document should have knowledge of these topics:

  • Content Engine running ACNS Software Release 4.x or later

  • RealProxy software installed with mediafs partitions mounted

Note: You must purchase a license key in order to activate the RealProxy features in the Cache software. For ordering on Cisco.com, refer to Ordering.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco Content Engine 590 running Cisco ACNS Software Release 4.x or later in a lab environment with cleared configurations

  • Cisco 7513 Router running Cisco IOS Software Release 12.0.18(S)

Configure

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

media_redir.jpg

Configurations

Cisco Cache Engine 560 (Cisco ACNS Software Release 4.x )
hostname disaster

!

ip domain-name cisco.com

!

interface FastEthernet 0/0

ip address 172.17.241.108 255.255.255.0

exit

interface FastEthernet 0/1

shutdown

exit

!

ip default-gateway 172.17.241.45

!

ip name-server 144.254.6.77

!

!

wccp router-list 1 172.17.241.29 172.17.241.31 172.17.241.45

wccp web-cache router-list-num 1

wccp media-cache router-list-num 1

wccp version 2

!

!

rtsp proxy media-real license-key <removed>

rtsp proxy media-real ip-address 172.17.241.108

rtsp proxy media-real enable 

rtsp proxy incoming 554 

rtsp proxy l4-switch enable

!

!

username admin password 1 Gn1nQzm/arxcI

username admin privilege 15

username cisco password 1 714DWnzYTRHC.

username cisco privilege 15

!

!
Building configuration...

Current configuration : 3071 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service single-slot-reload-enable

!

hostname lsd

!

ip subnet-zero

ip wccp web-cache

ip wccp 80

ip cef

no ip domain-lookup

ip domain-name cisco.com.

ip name-server 144.254.6.77

!

interface Ethernet5/0

 ip address 172.17.241.45 255.255.255.0

 no ip directed-broadcast

 ip wccp 80 redirect out

!

interface Ethernet5/1

 ip address 10.10.10.1 255.255.255.0

 no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.241.1

!

line con 0

 exec-timeout 0 0

line aux 0

line vty 0 4

 password <removed>

 login

!

end

debug and show Commands

Before issuing debug commands, refer to Important Information on Debug Commands.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

disaster#show mediafs volumes

disk00/03 :    mounted  size: 10669934

disk01/00 :    mounted  size: 14226579

disk01/02 :   formatted  size: 7113289
disaster#show statistics mediacache real requests

                  Media Cache Statistics - Requests

                                                Total             % of Requests

                            ---------------------------------------------------

     Total Received Requests:                       5                         -

            Demand Cache Hit:                       3                      60.0

           Demand Cache Miss:                       2                      40.0

         Demand Pass-Through:                       0                       0.0

                  Live Split:                       0                       0.0

           Live Pass-Through:                       0                       0.0

disaster#show statistics mediacache real savings

             Media Cache Statistics - Savings

                        Requests                          Bytes

         -----------------------------------------------------------

  Total:                       5                       14617438

   Hits:                       3                        6458830

   Miss:                       2                        8158608

Savings:                    60.0 %                         44.2 %

disaster#show rtsp all

Media Types:

  Servicing Real Media

Real Proxy License Key:

  Installed

Media Specific Info:

  Real Proxy IP address: 172.17.241.108

Incoming Proxy-Mode:

  Servicing Proxy mode RTSP connections on port: 554

RTSP Transparent Proxy (WCCP):

  Configured for port: 554

RTSP Transparent Proxy (L4 Switch):

  Configured for port: 554
disaster#show wccp 80 detail



Service Details for Media Cache Service

        Service Enabled                    : Yes

        Service Priority                   : 200

        Service Protocol                   : 6

        Application                        : Streaming

        Service Flags (in Hex)             : 512

        Service Ports                      :    554     0     0     0

                                           :      0     0     0     0

        Security Enabled for Service       : No

        Multicast Enabled for Service      : No

        Weight for this Web-CE: 0
lsd#show ip wccp 80 detail

WCCP Cache-Engine information:

        IP Address:            172.17.241.108

        Protocol Version:      2.0

        State:                 Usable

        Redirection:           GRE

        Initial Hash Info:     00000000000000000000000000000000

                               00000000000000000000000000000000

        Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                               FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

        Hash Allotment:        256 (100.00%)

        Packets Redirected:    35

        Connect Time:          23:41:34
lsd#show ip wccp

Global WCCP information:

    Router information:

        Router Identifier:                   172.17.241.45

        Protocol Version:                    2.0



    Service Identifier: web-cache

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            0

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        0

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none



    Service Identifier: 80

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            35

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        35

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none

Cache Engine show Commands

show Command Description
show wccp content-engines Displays WCCP Content Engine information.
show wccp flows media-cache Displays media caching service packet flows.
show wccp routers Displays WCCP router list.
show wccp services Displays WCCP services configured.
show wccp slowstart Displays WCCP slow start.
show wccp status Displays WCCP running status.
show statistics mediacache real savings Displays savings statistics.
show statistics mediacache real requests Displays request statistics.
show rtsp all Displays all RTSP configuration.
show rtsp proxy Displays proxy mode configuration.
show mediafs volumes Displays mediafs volumes.

Cache Engine debug Commands

debug Command Description
debug wccp all Enables WCCP to turn on all debugging.
debug wccp events Enables WCCP events.
debug wccp packets Enables WCCP packet-related information.

Router show commands

show Command Description
show ip wccp 80 detail Displays Cache Engine and WCCP router statistics for a particular service group.
show ip wccp 80 view Displays service group view information

Router debug commands

debug Command Description
debug ip wccp events Displays WCCP events.
debug ip wccp packets Displays WCCP packet-related information.

Command Summary

These Cache Engine commands were used in this configuration:

  • wccp version {1 | 2}

  • wccp router-list number ip-address

  • wccp media-cache router-list-num number

  • rtsp proxy media-real license-key key

  • rtsp proxy media-real ip-address ip-address

  • rtsp proxy media-real enable

  • rtsp proxy incoming port

These are the router commands that were used in this configuration:

  • ip wccp {web-cache | service-number}

  • ip wccp {web-cache | service-number} redirect out

Related Information

Updated: May 24, 2004
Document ID: 4717