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Configuring Features, Templates, 
Services, and Users

After you install and configure your wireless voice network, you can add 
wireless IP phones by using Cisco Unified Communications Manager 
Administration to configure telephony features, modify softkey templates, set up 
services, and assign users.

This chapter provides an overview of these configuration and setup procedures. 
Cisco Unified Communications Manager documentation provides detailed 
instructions for these procedures.

For suggestions about providing users with information for using the phone and 
features, see Appendix A, “Providing Information to Users By Using a Website.”

For information about setting up phones in non-English environments, see 
Appendix B, “Supporting International Users.”

This chapter includes these topics: 

• Configuring Cisco Unified Wireless IP Phones in Cisco 
Unified Communications Manager, page 7-2

• Telephony Features Available for the Phone, page 7-2

• Specific Configuration Options for the Cisco Unified Wireless IP Phone 
7921G, page 7-22

• Configuring Softkey Templates, page 7-23

• Modifying Phone Button Templates, page 7-25

• Setting Up Services, page 7-26

• Configuring Corporate and Personal Directories, page 7-27
7-1
o Unified Communications Manager



 

Chapter 7      Configuring Features, Templates, Services, and Users
Configuring Cisco Unified Wireless IP Phones in Cisco Unified Communications Manager
• Adding Users to Cisco Unified Communications Manager, page 7-29

• Managing the User Options Web Pages, page 7-30

• Creating Custom Phone Rings, page 7-32

Configuring Cisco Unified Wireless IP Phones in 
Cisco Unified Communications Manager

To provide telephony call routing and call control features for the Cisco Unified 
Wireless IP Phone 7921G, you must use to the Cisco Unified Communications 
Manager Administration application. For instructions about adding these devices, 
refer to the “Cisco Unified IP Phone Configuration” chapter in the Cisco Unified 
Communications Manager Administration Guide.

Telephony Features Available for the Phone
Table 7-1 describes supported telephony features, that you can configure using 
Cisco Unified Communications Manager Administration for the Cisco Unified 
Wireless IP Phone 7921G. The table provides references to documentation that 
contains configuration procedures and feature information.

For information about using the features on the phone, refer to Cisco 
Unified Wireless IP Phone 7921G Guide. For a comprehensive listing of features 
on the phone, refer to Cisco Unified IP Phone Features A-Z. 

Note Cisco Unified Communications Manager Administration also provides several 
service parameters that you can use to configure various telephony functions. For 
more information about service parameters and the functions that they control, 
you can use the I or ? button on the Cisco Unified Communications Manager 
configuration page. 
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Telephony Features Available for the Phone
Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G

Feature Description Configuration Reference

Abbreviated 
Dialing

Allows users to speed dial a phone number by 
entering an assigned index code (1-99) on the 
phone keypad. 

Users assign index codes from the User Options 
web pages. 

For more information, refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phone” chapter.

Auto Answer Connects incoming calls automatically after a 
ring or two. 

Auto Answer works with either the speaker or 
the headset mode.

For more information, refer to the 
Cisco Unified Communications 
Manager Administration Guide:

• For Cisco Unified 
Communications Manager 5.0 
or later, refer to the 
“Configuring Directory 
Numbers” chapter.

• For Cisco Unified 
Communications Manager 4.x, 
refer to the “Phone 
Configuration” chapter.
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Auto-pickup Allows a user to use one-touch, pickup 
functionality for call pickup, group call pickup, 
and other group call pickup.

For more information, refer to: 

• Cisco Unified 
Communications Manager 4.x 
Administration Guide, “Call 
Pickup Group Configuration” 
chapter.

• Cisco Unified 
Communications Manager 4.x 
System Guide, “Call Pickup” 
chapter.

• Cisco Unified 
Communications Manager 5.x 
Features and Services Guide, 
“Call Pickup Group” chapter.

Barge Allows a user to join a non-private call on a 
shared phone line. Barge features include 
cBarge and Barge.

• cBarge adds a user to a call and converts it 
into a conference, allowing the user and 
other parties to access conference features.

• Barge adds a user to a call but does not 
convert the call into a conference.

The phones support Barge in two conference 
modes:

• Built-in conference bridge at the target 
device (the phone that is being barged). 
This mode uses the Barge softkey.

• Shared conference bridge. This mode uses 
the cBarge softkey.

For more information, refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Barge and Privacy” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Block external 
to external 
transfer

Prevents users from transferring an external call 
to another external number.

For more information, refer to 
Cisco Unified Communications 
Manager Features and Services 
Guide, “External Call Transfer 
Restrictions” chapter.

Busy Lamp 
Field (BLF) 
speed dial

Allows a user to monitor the call state of a 
directory number (DN) associated with a 
speed-dial button.

For more information, refer to 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Presence” chapter.

Call display 
restrictions

Determines the information that will display for 
calling or connected lines, depending on the 
parties who are involved in the call.

For more information, refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, 
“Understanding Route Plans” 
chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Call Display Restrictions” 
chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Call Forward Allows users to redirect incoming calls to 
another number.

For more information, refer to:

• Cisco Unified 
Communications Manager 4.x 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 5.x 
Administration Guide, 
“Configuring Directory 
Numbers” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

Call park Allows users to park (temporarily store) a call 
and then retrieve the call by using another phone 
in the Cisco Unified Communications 
ManagerCommunications Manager system.

For more information, refer to:

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Call Park” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Call pickup Allows users to redirect a call that is ringing on 
another phone within their pickup group to their 
phone.

You can configure an audio and/or visual alert 
for the primary line on the phone. This alert 
notifies the users that a call is ringing in their 
pickup group.

Note The audio/visual alert is only available 
for phones on Cisco Unified 
Communications Manager release 4.2 
and later.

For more information, refer to:

• Cisco Unified 
Communications Manager 4.x 
Administration Guide, “Call 
Pickup Group Configuration” 
chapter.

• Cisco Unified 
Communications Manager 4.x 
System Guide, “Call Pickup” 
chapter.

• Cisco Unified 
Communications Manager 5.x 
Features and Services Guide, 
“Call Pickup Group” chapter.

Call waiting Indicates (and allows users to answer) an 
incoming call that rings while on another call.

Displays incoming call information on the 
phone screen.

For more information, refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Caller ID Displays caller identification such as a phone 
number, name, or other descriptive text on the 
phone screen.

For more information, refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, 
“Configuring Cisco Unified IP 
Phones” chapter.

• Cisco Unified 
Communications Manager 
System Guide, 
“Understanding Route Plans” 
chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Call Display Restrictions” 
chapter.

Cisco Call 
Back

Provides users with an audio and visual alert on 
the phone when a busy or unavailable party 
becomes available.

For more information, refer to:

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco 
Unified Communications 
Manager Features and 
Services Guide, “Cisco Call 
Back” chapter.

Client matter 
codes (CMC)

Enables a user to specify that a call relates to a 
specific client matter.

For more information, refer to the 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Client Matter Codes and 
Forced Authorization Codes” 
chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Conference • Allows a user to talk simultaneously with 
multiple parties by calling each participant 
individually. Conference features include 
Conference, Join, cBarge, and Meet-Me.

• Allows a non-initiator in a standard (ad hoc) 
conference to add or remove participants; 
also allows any conference participant to 
join together two standard conferences on 
the same line.

• For more information, refer to 
Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• The Service parameter, 
AdvanceAdhocConference, 
(disabled by default in Cisco 
Unified Communications 
Manager Administration) 
allows you to enable these 
features. For more 
information, refer to the 
Cisco Unified 
Communications Manager 
System Guide “Conference 
Bridges” chapter.

Note Be sure to inform your 
users whether these 
features are activated.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
7-9
Cisco Unified Wireless IP Phone 7921G Administration Guide for Cisco Unified Communications Manager

OL-15164-01



 

Chapter 7      Configuring Features, Templates, Services, and Users
Telephony Features Available for the Phone
Configurable 
call forward 
display

Allows you to specify information that appears 
on a phone when a call is forwarded. This 
information can include the caller name, caller 
number, redirected number, and original dialed 
number.

For more information, refer to:

• Cisco Unified 
Communications Manager 5.0 
or later—Cisco Unified 
Communications Manager 
Administration Guide, 
“Directory Number 
Configuration” chapter

• Cisco Unified 
Communications Manager 
4.x—Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

Direct transfer Allows users to connect two calls to each other 
(without remaining on the line).

For more information, refer to 
Cisco Unified Communications 
Manager System Guide, “Cisco 
Unified IP Phones” chapter.

Directed Call 
Park

Allows a user to transfer an active call to an 
available directed call park number that the user 
dials or speed dials. 

A Call Park BLF button indicates whether a 
directed call park number is occupied and 
provides speed-dial access to the directed call 
park number.

Note If you implement Directed Call Park, 
avoid configuring the Park softkey. This 
prevents users from confusing the two 
Call Park features. 

For more information refer to:

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Call Park and Directed Call 
Park” chapter.

• Modifying Phone Button 
Templates, page 7-25

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Do Not Disturb 
(DND) 

When DND is turned on, no audible rings occur 
during the ringing-in state of a call.

You can configure the phone to have a softkey 
template with a DND softkey. 

Note DND is available in Cisco Unified 
Communications Manager 6.0 or later.

The following DND-related parameters are 
configurable in Cisco Unified Communications 
Manager Administration:

• Do Not Disturb—This checkbox allows you 
to enable DND on a per-phone basis. Use 
Cisco Unified CallManager 
Administration > Device > Phone > 
Phone Configuration.

• DND Incoming Call Alert—Choose the 
type of alert to play on a phone for incoming 
calls when DND is active. This parameter is 
located on both the Common Phone Profile 
page and the Phone configuration page 
(Phone page value takes precedence).

Cisco Unified CallManager 
Features and Services Guide, “Do 
Not Disturb” chapter.

Extension 
Mobility 
Service

Allows a user temporarily to apply a phone 
number and user profile settings to a Cisco 
Wireless Unified IP Phone by logging into the 
Extension Mobility service on that phone.

Extension Mobility can be useful if users work 
from a variety of locations within your company 
or if they share a workspace with coworkers.

For more information, refer to: 

• Cisco Unified Communications 
Manager Features and 
Services Guide, “Cisco 
Unified Communications 
Manager Extension Mobility” 
chapter.

Fast Dial 
Service

Allows a user to enter a Fast Dial code to place 
a call. Fast Dial codes can be assigned to phone 
numbers or Personal Address Book entries. (See 
“Services” in this table.)

For more information, refer to 
Cisco Unified Communications 
Manager System Guide, “Cisco 
Unified IP Phone Services” 
chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Forced 
authorization 
codes (FAC)

Controls the types of calls that certain users can 
place.

For more information, refer to 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Client Matter Codes and 
Forced Authorization Codes” 
chapter.

Group call 
pickup

Allows a user to answer a call ringing on a 
phone in another group by using a group pickup 
code.

For more information, refer to: 

• Cisco Unified 
Communications Manager 4.x 
Administration Guide, “Call 
Pickup Group Configuration” 
chapter.

• Cisco Unified 
Communications Manager 4.x 
System Guide, “Call Pickup” 
chapter.

• Cisco Unified 
Communications Manager 5.x 
Features and Services Guide, 
“Call Pickup Group” chapter.

Hold Allows users to move connected calls from an 
active state to a held state.

Requires no configuration, unless 
you want to use music on hold; see 
“Music-on- hold” in this table for 
information.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Hold Reversion Limits the amount of time that a call can be on 
hold before reverting back to the phone that 
put the call on hold and alerting the user.

Reverting calls are distinguished from incoming 
calls by a single ring (or beep, depending on the 
new call indicator setting for the line). This 
notification repeats at intervals if not resumed.

A call that triggers Hold Reversion displays a 
brief message on the status line.

You can configure call focus priority to favor 
incoming or reverting calls.

For more information about 
configuring this feature, refer to 
Cisco Unified CallManager 
Features and Services Guide, 
“Hold Reversion” chapter.

Hunt group Provides load sharing for calls to a main 
directory number. A hunt group contains a series 
of directory numbers that can answer the 
incoming calls. When the first directory number 
in the hunt group is busy, the system hunts in a 
predetermined sequence for the next available 
directory number in the group and directs the 
call to that phone. 

For more information, refer to: 

• Cisco Unified 
Communications Manager 
Administration Guide, “Hunt 
Group Configuration” chapter. 

• Cisco Unified 
Communications Manager 
System Guide, “Understanding 
Route Plans” chapter. 

Immediate 
Divert

Allows a user to transfer a ringing, connected, or 
held call directly to a voice-messaging 
system.When a call is diverted, the line becomes 
available to make or receive new calls.

For more information, refer to: 

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Call Park and Directed Call 
Park” chapter

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Immediate 
Divert—Enhan
ced

Allows users to transfer incoming calls directly to 
their voice messaging system or to the voice 
messaging system of the original called party.

For more information, refer to: 

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Call Park and Directed Call 
Park” chapter

Intercom Allows users to place and receive intercom calls 
from the line view. You can configure intercom 
lines to:

• Directly dial a specific intercom extension.

• Initiate an intercom call and then prompt 
the user to enter a valid intercom number.

Users can view the intercom call history from 
the Directory menu.

Note If your user logs into the same phone on 
a daily basis using their Cisco Extension 
Mobility profile, assign the phone 
button template that contains intercom 
information to their profile, and assign 
the phone as the default intercom device 
for the intercom line.

Cisco Unified CallManager 
Feature and Services Guide, 
“Intercom” chapter

Join Allows user to join two or more calls that are on 
one line to crate a conference call and remain on 
the call.

For more information, refer to 
Cisco Unified Communications 
Manager System Guide, “Cisco 
Unified IP Phones” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Log out of hunt 
groups

Allows users to log out of hunt groups and 
temporarily block calls from ringing their phone 
when they are not available to take calls. 
Logging out of hunt groups does not prevent 
non-hunt group calls from ringing their phones. 

For more information, refer to 
Cisco Unified Communications 
Manager System Guide, 
“Understanding Route Plans” 
chapter. 

Malicious 
caller 
identification 
(MCID)

Allows users to notify the system administrator 
about suspicious calls that are received.

For more information refer to: 

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco 
Unified Communications 
Manager Features and 
Services Guide, “Malicious 
Call Identification” chapter.

Meet-Me 
conference

Allows a user to host a Meet-Me conference in 
which other participants call a predetermined 
number at a scheduled time.

For more information refer to 
Cisco Unified Communications 
Manager Administration Guide, 
“Meet-Me Number/Pattern 
Configuration” chapter.

Message 
waiting 
indicator

A light on the handset that indicates that 
indicates that a user has one or more new voice 
messages.

For more information refer to: 

• Cisco Unified 
Communications Manager 
Administration Guide, 
“Message Waiting 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Voice Mail 
Connectivity to Cisco Unified 
Communications Manager” 
chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Mobile 
Connect

Enables users to manage business calls using a 
single phone number and pick up in-progress 
calls on the desktop phone and a remote device 
such as a cellular phone. 

For more information, refer to the 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Mobile Connect and 
Mobile Voice Access” chapter.

Mobile Voice 
Access

Extends Mobile Connect capabilities by 
allowing users to access an interactive voice 
response (IVR) system to originate a call from a 
remote device such as a cellular phone to 
enterprise IP phones. 

For more information, refer to the 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Mobile Connect and 
Mobile Voice Access” chapter.

Multilevel 
Precedence and 
Preemption 
(MLPP)

Provides a method of prioritizing calls within 
your phone system. Use this feature when users 
work in an environment where they need to 
make and receive urgent or critical calls.

For more information refer to 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Multilevel Precedence and 
Preemption” chapter.

Music-on- hold Plays music while callers are on hold. For more information refer to 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Music On Hold” chapter.

Onhook call 
transfer

Allows a user to press a single Transfer softkey 
and then go onhook to complete a call transfer.

For more information refer to 
Cisco Unified Communications 
Manager System Guide, “Cisco 
Unified IP Phones” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Other group 
pickup

Allows a user to answer a call ringing on a 
phone in another group that is associated with 
the user's group.

(See also “Call pickup” and “Group call pickup” 
in this table.)

For more information refer to:

• Cisco Unified 
Communications Manager 4.x 
Administration Guide, “Call 
Pickup Group Configuration” 
chapter.

• Cisco Unified 
Communications Manager 4.x 
System Guide, “Call Pickup” 
chapter.

• Cisco Unified 
Communications Manager 5.x 
Features and Services Guide, 
“Call Pickup Group” chapter.

Presence-enabl
ed directories

Allows a user to monitor the call state of another 
directory number (DN) listed in call logs, 
speed-dials, and corporate directories. The Busy 
Lamp Field (BLF) for the DN displays the call 
state.

For more information, refer to 
Cisco Unified Communications 
Manager Features and Services 
Guide, “Presence” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Privacy Prevents users who share a line from adding 
themselves to a call and from viewing 
information on their phone screens about the 
other user’s calls. 

For more information refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco 
Unified Communications 
Manager Features and 
Services Guide “Barge and 
Privacy” chapter.

Push to Talk Allows users to call a target phone number or 
group and announce a message (similar to a 
two-way radio) by using a configurable 
applications button.

For more information, see “Setting 
Up Services” section on page 7-26.

Requires an XML application to 
provide Push to Talk service.

Quality 
Reporting Tool 
(QRT)

Allows users to use the QRT softkey on a phone 
to submit information about problem phone 
calls. QRT can be configured for either of two 
user modes, depending upon the amount of user 
interaction desired with QRT.

For more information refer to:

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Quality Report Tool” 
chapter.

Redial Allows users to call the most recently dialed 
phone number by using a softkey option.

Requires no configuration.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)
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Ring setting Identifies ring type used for a line when a phone 
has another active call.

For more information refer to:

• Cisco Unified 
Communications Manager 4.x 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 5.x 
Administration Guide, 
“Configuring Directory 
Numbers” chapter.

• Cisco Unified 
Communications Manager 
Features and Services Guide, 
“Custom Phone Rings” 
chapter.

• “Creating Custom Phone 
Rings” section on page 7-32.

Services Allows you to use the Cisco Unified IP Phone 
Services Configuration menu in Cisco 
Unified Communications Manager 
Administration to define and maintain the list of 
phone services to which users can subscribe.

For more information refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phone Services” chapter.

Shared Line Allows users to have multiple phones that share 
the same phone number or allows users to share 
a phone number with a coworker.

For more information refer to 
Cisco Unified Communications 
Manager System Guide, “Cisco 
Unified IP Phones” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)
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Speed-dialing Dials a specified number that has been 
previously stored.

Speed dialing includes these features:

• Speed-dial hot keys configured and stored 
in the local Phone Book on the wireless IP 
phone.

• Line view speed-dial numbers configured 
from the User Options web page.

• Abbreviated Dialing (in this table).

• Fast Dial Service (in this table).

For more information refer to:

• Cisco Unified Wireless IP 
Phone 7921G Guide for Cisco 
Unified Communications 
Manager 4.3, 5.1, 6.0 and 
Later, “Advanced Call 
Handling” chapter, “Speed 
Dialing” section.

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Unified IP Phone 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Cisco Unified 
IP Phones” chapter.

Time-of-Day 
Routing

Restricts access to specified telephony features 
by time period.

For more information refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Time 
Period Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Time-of-Day 
Routing” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
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Telephony Features Available for the Phone
Note For detailed information about using telephony features on the wireless IP phone, 
refer to the Cisco Unified Wireless IP Phone 7921G Guide.

Related Topics

• Configuring Softkey Templates, page 7-23

• Setting Up Services, page 7-26

• Configuring Corporate and Personal Directories, page 7-27

• Adding Users to Cisco Unified Communications Manager, page 7-29

• Creating Custom Phone Rings, page 7-32

Transfer Allows users to redirect connected calls from 
their phones to another number.

Requires no configuration.

Voice message 
system

Enables callers to leave messages if calls are 
unanswered.

For more information refer to:

• Cisco Unified 
Communications Manager 
Administration Guide, “Cisco 
Voice-Mail Port 
Configuration” chapter.

• Cisco Unified 
Communications Manager 
System Guide, “Voice Mail 
Connectivity to Cisco 
Unified Communications 
Manager” chapter.

Table 7-1 Telephony Features for the Cisco Unified Wireless IP Phone 7921G (continued)

Feature Description Configuration Reference
7-21
Cisco Unified Wireless IP Phone 7921G Administration Guide for Cisco Unified Communications Manager

OL-15164-01

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_ipphon/english/wip7920/guid7920/index.htm


 

Chapter 7      Configuring Features, Templates, Services, and Users
Specific Configuration Options for the Cisco Unified Wireless IP Phone 7921G
Specific Configuration Options for the Cisco Unified 
Wireless IP Phone 7921G

Each Cisco Unified IP Phone has special configuration options that are available 
for that phone model. You can configure the specific options by using Cisco 
Unified Communications Manager Administration. These product specific 
configuration options are available for the 7921 device type:

• Disable Speakerphone—Turns off the speakerphone capability of the 
handset. Options are False or True.

• Gratuitous ARP—Enables or disables the ability for the phone to learn MAC 
addresses from Gratuitous ARP. This capability is required to monitor or 
record voice streams. Options are Enabled or Disabled.

• Settings Access—Enables, disables, or restricts access to local configuration 
settings in the Settings menus. With restricted access, only the Phone Settings 
menu is accessible. With disabled access, no options appear when you access 
the Settings menu on the phone. Options are Enabled, Disabled, and 
Restricted.

• Web Access—Determines the level of access to the web pages for the phone. 
Provides Disabled, Read only, and Full access to a phone’s web pages through 
a web browser. Options are Read Only, Full, Disabled.

• Profile 1-4—Locks or unlocks the network profiles. If locked, the phone user 
cannot modify the network profile. Options are Unlocked and Locked.

• Load Server—Identifies the alternate server that the phone will use to obtain 
firmware loads and upgrades. Enter an IP address or host name for the server.

• Admin Password (Cisco Unified Communications Manager 5.0 and 
later)—Password to access the configuration web pages for the phone. 
Default password is “CiscoCisco.” Password must be 8-32 characters.

Caution When setting the Administration Password in the Product Specific Configuration 
section in Cisco Unified Communications Manager Administration 5.0 or later, 
you must enable TFTP encryption. Otherwise, the password appears in readable 
text in the phone configuration file and can be viewed from any host that has 
access to TFTP server.
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Configuring Softkey Templates
• Special Numbers—Identifies special phone numbers that do not require 
unlocking the keypad to call, such as 911 or an emergency number. Enter 
numbers up to 16 digits in length.

• Push-to-talk URL—Specifies the URL that the phone contacts when pressing 
the configurable Applications button for services such as Push to Talk or 
directories.

To configure product specific options, follow these steps:

Procedure

Step 1 Do one of the following from Cisco Unified Communications Manager 
Administration:

• For Cisco Unified Communications Manager 4.x or earlier, choose Device > 
Phone. Click Add a Phone, then choose Phone Type > Cisco 7921. 

• For Cisco Unified Communications Manager 5.0 and later, choose Device > 
Phone. Click Add Phone, then choose Phone Type > Cisco 7921. 

Step 2 In the Phone Configuration page, locate the Product Specific Configuration 
area.

Step 3 Make changes to the settings as needed. 

Note For detailed information about these settings, click the I or ? button for 
Product Specific Configuration Help. 

Step 4 You must reset the phone before the changes take effect.

Configuring Softkey Templates
Administrators can change the order of softkeys for the Cisco Unified Wireless IP 
Phone 7921G by using Cisco Unified Communications Manager Administration. 
Unlike other Cisco Unified IP Phones that have buttons for some functions, the 
Cisco Unified Wireless IP Phone 7921G has two non-configurable softkeys that 
are set for: 
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Configuring Softkey Templates
• Message

• Options

When you configure a softkey template for the Cisco Unified Wireless IP Phone 
7921G, you can only configure the Cisco Unified Communications Manager 
softkeys and their sequence in the Options menu. The order of softkeys in the 
softkey template corresponds to the phone softkey list in the Options menu. When 
you set up the softkey template for users that prefer to have a particular softkey 
appear during a connected call, place the desired softkey in the first position for 
the Connected phone state. 

Softkey Templates for the Cisco Unified Wireless IP Phone 7921G
The standard softkey template displays the Hold softkey when connected to a call. 
Some users want the Transfer softkey to appear for a connected call instead of 
Hold. 

The administrator sets up a non-standard softkey template that places Transfer in 
the first position for the Connected state. The administrator assigns this 
non-standard softkey template to the 7921G devices assigned to users that want 
these softkeys. 

Note To ensure that users hear the voice-messaging greeting when they are transferred 
to the voice message system, you must set up a softkey template with Transfer as 
the first softkey for a connected call.

Changing Softkeys in a Template
Use the procedures in the online Help topic, “Adding Non-Standard Softkey 
Templates” to change the softkeys and their sequence. Softkey templates now 
support up to 16 softkeys when using applications. For more information about 
softkey templates, see the “Softkey Templates” Chapter in the Cisco 
Unified Communications Manager System Guide.
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Modifying Phone Button Templates
To configure softkey templates, select Device > Device Settings > Softkey 
Template from Cisco Unified Communications Manager Administration. You 
can modify a standard softkey template by making a copy of it, giving it a new 
name, and making updates to that copied softkey template. You can also modify 
a nonstandard softkey template.

To assign a softkey template to a phone, use the Softkey Template field in the 
Cisco Unified Communications Manager Administration Phone Configuration 
page. Refer to the “Softkey Template Configuration” chapter in the Cisco 
Unified Communications Manager Administration Guide and the Cisco Unified 
Communications Manager System Guide for more information.

Related Topics

• Configuring Cisco Unified Wireless IP Phones in Cisco 
Unified Communications Manager, page 7-2

• Setting Up Services, page 7-26

• Configuring Corporate and Personal Directories, page 7-27

• Adding Users to Cisco Unified Communications Manager, page 7-29

Modifying Phone Button Templates
Phone button templates let you assign lines and features to positions in the Line 
View.

Ideally, you modify templates before registering phones on the network. In this 
way, you can access customized phone button template options from 
Cisco Unified Communications Manager during registration.

To modify a phone button template, choose Device > Device Settings > Phone 
Button Template from Cisco Unified Communications Manager Administration. 
To assign a phone button template to a phone, use the Phone Button Template field 
in the Cisco Unified Communications Manager Administration Phone 
Configuration page. For more information about modifying phone button 
templates, refer to “Cisco Unified IP Phones” chapter in the 
Cisco Unified Communications Manager System Guide for your release.
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Setting Up Services
The Cisco Unified Wireless IP Phone 7921G can have up to six lines and up to 24 
connected calls. The default button template uses position 1 for lines and assigns 
position 2 through 6 as speed dial. You can assign these features to button 
positions:

• Service URL

• Privacy

• Speed dial

Use softkey features in the Options menu to access other phone features, such as 
call park, call forward, redial, hold, resume, conferencing, and so on.

Setting Up Services
The Services menu on the Cisco Unified Wireless IP Phone 7921G gives users 
access to Cisco Unified IP Phone Services. These services comprise XML 
applications that enable the display of interactive content with text and graphics 
on the phone. Examples of services include Push to Talk, directories, stock 
quotes, and weather reports. Some services, such as Push to Talk, can use the 
configurable Applications button located on the side of the phone.

To create customized XML applications for your site, refer to the Cisco Unified 
IP Phone Service Application Development Notes.

Before a user can access any service, two important tasks must be completed:

• You as the system administrator must use Cisco Unified Communications 
Manager Administration to configure available services.

• The user must subscribe to services using the Cisco Unified IP Phone User 
Options application. This web-based application provides a graphical user 
interface (GUI) for limited, end-user configuration of IP Phone applications.

To set up IP Phone services, follow these steps:

Procedure

Step 1 Before you set up services, gather the URLs for the sites you want to set up and 
verify that users can access those sites from your corporate IP telephony network. 
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Configuring Corporate and Personal Directories
Step 2 To set up these services in Cisco Unified Communications Manager 4.x 
Administration, choose Feature > Cisco IP Phone Services
or
To set up these services in Cisco Unified Communications Manager 5.x 
Administration, choose Device > Device Settings > Phone Services

For more information about phone services, refer to the” Cisco Unified IP Phone 
Services” chapter in the Cisco Unified Communications Manager System Guide 
for more information.

Step 3 After you configure these services, verify that your users have access to the 
Cisco Unified Communications Manager User Options web-based application, 
from which they can select and subscribe to configured services. See the “How 
Users Configure Phone Features and Services” section on page A-6 for a 
summary of the information that you must provide to end users.

Note For information about extension mobility services for users, refer to the “Cisco 
Extension Mobility” chapter in the Cisco Unified Communications Manager 
Features and Services Guide.

Related Topics

• Configuring Cisco Unified Wireless IP Phones in Cisco 
Unified Communications Manager, page 7-2

• Configuring Softkey Templates, page 7-23

• Configuring Corporate and Personal Directories, page 7-27

• Adding Users to Cisco Unified Communications Manager, page 7-29

• Creating Custom Phone Rings, page 7-32

Configuring Corporate and Personal Directories
The Directory menu on the Cisco Unified Wireless IP Phone 7921G gives users 
access to several directories. These directories can include:

• Corporate Directory—Allows a user to look up phone numbers for 
co-workers.
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Configuring Corporate and Personal Directories
To support this feature, you must configure corporate directories. See the 
“Configuring Corporate Directories” section on page 7-28 for more 
information.

• Personal Directory—Allows a user to store a set of personal numbers.

To support this feature, you must provide the user with software to configure 
the personal directory. See the “Configuring Personal Directory” section on 
page 7-28 for more information.

Configuring Corporate Directories
Cisco Unified Communications Manager uses a Lightweight Directory Access 
Protocol (LDAP) directory to store authentication and authorization information 
about users of Cisco Unified Communications Manager applications that interface 
with Cisco Unified Communications Manager. Authentication establishes the 
users’ rights to access the system. Authorization identifies the telephony 
resources that a user is permitted to use, such as a specific telephone extension.

To install and set up these features, refer to the Cisco Unified Communications 
Manager Administration Guide, LDAP System Configuration, LDAP Directory 
Configuration, and LDAP Authentication Configuration chapters. That manual 
guides you through the configuration process for integrating Cisco Unified 
Communications Manager with Microsoft Active Directory, Sun ONE Directory, 
Netscape Directory, and iPlanet Directory Server.

After the LDAP directory configuration completes, users can use the Corporate 
Directory service on your Cisco Unified Wireless IP Phone 7921G to look up 
users in the corporate directory. 

Configuring Personal Directory
Personal Directory consists of the following features:

• Personal Address Book (PAB)

• Personal Fast Dials (Fast Dials)

• Address Book Synchronization Tool (TABSynch)
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Adding Users to Cisco Unified Communications Manager
Users can access Personal Directory features by these methods: 

• From a web browser—Users can access the PAB and Fast Dials features from 
the Cisco Unified Communications Manager User Options web pages

• From the Cisco Unified IP Phone—Users can choose Directories > Personal 
Directory to access the PAB and Fast Dials features from their phones

• From a Microsoft Windows application—Users can use the TABSynch tool 
to synchronize their PABs with Microsoft Windows Address Book (WAB). 
Customers who want to use the Microsoft Outlook Address Book (OAB) 
should begin by importing the data from the OAB into the Windows Address 
Book (WAB). TabSync can then be used to synchronize the WAB with 
Personal Directory. 

To configure Personal Directory from a web browsers, users must access their 
User Options web pages. You must provide users with a URL and login 
information. 

To synchronize with Microsoft Windows Address Book, users must install the 
TABSynch utility, provided by you. To obtain the TABSynch software to 
distribute to users:

• From Cisco Unified Communications Manager 4.x Administration, choose 
Application > Install Plugins, then locate and click Cisco IP Phone 
Address Book Synchronizer.

• From Cisco Unified Communications Manager 5.x Administration, choose 
Application > Plugins > Find, then locate and click Cisco IP Phone 
Address Book Synchronizer.

Adding Users to Cisco Unified Communications 
Manager

Adding users to Cisco Unified Communications Manager allows you to display 
and maintain information about users and allows each user to perform the 
following actions:

• Access the corporate directory and other customized directories from a Cisco 
Unified IP Phone

• Create a personal directory
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Managing the User Options Web Pages
• Set up speed dial and call forwarding numbers 

• Subscribe to services that are accessible from a Cisco Unified IP Phone

You can add users to Cisco Unified Communications Manager using either of 
these methods:

• To add users individually from Cisco Unified Communications Manager 
Administration for 5.0 or later, choose User Management > End User > 
Add New.

To add users individually from Cisco Unified Communications Manager 
Administration for 4.x, choose User > Add a New User.

Refer to “Adding a New User” chapter in Cisco Unified Communications 
Manager Administration Guide for more information about adding users. 
Refer to Cisco Unified Communications Manager System Guide for details 
about user information.

• To add users in batches, use the Bulk Administration Tool. This method also 
enables you to set an identical default password for all users.

For detailed information, refer to Bulk Administration Tool User Guide 
(Cisco Unified Communications Manager 4.1 or later) or Cisco Unified 
Communications Manager Bulk Administration Guide (Cisco Unified 
Communications Manager 5.0 or later).

Related Topics

• Configuring Cisco Unified Wireless IP Phones in Cisco 
Unified Communications Manager, page 7-2

• Configuring Softkey Templates, page 7-23

• Setting Up Services, page 7-26

• Configuring Corporate and Personal Directories, page 7-27

• Creating Custom Phone Rings, page 7-32

Managing the User Options Web Pages
From the User Options web page, users can customize and control several phone 
features and settings. For detailed information about the User Options web pages, 
refer to Cisco Unified Wireless IP Phone 7921G Guide.
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Managing the User Options Web Pages
Giving Users Access to the User Options Web Pages
Before a user can access the User Options web pages, you must use Cisco 
Unified Communications Manager Administration to add the user to a standard 
Cisco Unified Communications Manager end user group. To do so, choose User 
Management > User Group. You must also associate appropriate phones with 
the user. 

To perform these procedures, do one of the following:

• From Cisco Unified Communications Manager Administration for 5.0 or 
later, choose User Management > End User.

• From Cisco Unified Communications Manager Administration for 4.x, 
choose User > Add a New User.

For additional information, refer to Cisco Unified Communications Manager 
Administration Guide, “End User Configuration” section.

Note You can use Cisco Unified Communications Manager Administration to control 
user access to the phone web pages. For information about setting Web Access for 
users, see “Specific Configuration Options for the Cisco Unified Wireless IP 
Phone 7921G” section on page 7-22.

Specifying Options that Appear on the User Options Web Pages
Most options that are on the User Options web pages appear by default. However, 
the following options must be set by the system administrator by using Enterprise 
Parameters Configuration settings in Cisco Unified Communications Manager 
Administration:

• Show Ring Settings

• Show Line Text Label Settings

• Show Call Forwarding

Note The settings apply to all User Options web pages at your site.
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Creating Custom Phone Rings
To specify the options that appear on the User Options web pages, follow these 
steps:

Procedure

Step 1 From Cisco Unified Communications Manager Administration, choose System > 
Enterprise Parameters.

The Enterprise Parameters Configuration window displays.

Step 2 In the CCMUser Parameters area, specify whether a parameter appears on the 
User Options web pages by choosing one of these values from the Parameter 
Value drop-down list box for the parameter:

• True—Option displays on the User Options web pages (default).

• False—Option does not display on the User Options web pages.

• Show All Settings—All call forward settings display on the User Options 
web pages (default).

• Hide All Settings—No call forward settings display on the User Options web 
pages.

• Show Only Call Forward All—Only call forward all calls displays on the 
User Options web pages.

Creating Custom Phone Rings
You can customize the phone ring types available at your site by using a set of 
phone ring sounds that are provided by Cisco Unified Communications Manager 
or by creating your own pulse code modulation (PCM) files and editing the 
RingList.xml file. Refer to the “Custom Phone Rings” chapter in the Cisco 
Unified Communications Manager Features and Services Guide for more 
information about customized ring tones.

Related Topics

• Configuring Cisco Unified Wireless IP Phones in Cisco 
Unified Communications Manager, page 7-2

• Configuring Softkey Templates, page 7-23
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Creating Custom Phone Rings
• Setting Up Services, page 7-26

• Configuring Corporate and Personal Directories, page 7-27

• Adding Users to Cisco Unified Communications Manager, page 7-29
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Creating Custom Phone Rings
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