Configuring EtherChannels

Contents

Configuring EtherChannels

This chapter contains the following topics:

Configuring EtherChannels

You can configure EtherChannels on Layer 2 and Layer 3 ports on the switch. EtherChannel provides fault-tolerant high-speed links between switches, routers, and servers. You can use Etherchannels to increase the bandwidth between the wiring closets and the data center, and you can deploy it anywhere in the network where bottlenecks are likely to occur. EtherChannel provides automatic recovery for the loss of a link by redistributing the load across the remaining links. If a link fails, EtherChannel redirects traffic from the failed link to the remaining links in the channel without intervention.

Feature Information for EtherChannels

Feature Information for EtherChannels

Releases Feature Information

Cisco IOS XE 3.2SE

This feature was introduced.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to http:/​/​www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for EtherChannels

The following are restrictions for EtherChannels:

  • Layer 3 EtherChannels are not supported if running the LAN Base license feature set.

Information About EtherChannels

EtherChannel Overview

An EtherChannel consists of individual Gigabit Ethernet links bundled into a single logical link.

Figure 1. Typical EtherChannel Configuration

The EtherChannel provides full-duplex bandwidth up to 8 Gb/s (Gigabit EtherChannel) or 80 Gb/s (10-Gigabit EtherChannel) between your switch and another switch or host.

Each EtherChannel can consist of up to eight compatibly configured Ethernet ports. The number of EtherChannels is limited to 128. All ports in each EtherChannel must be configured as either Layer 2 or Layer 3 ports. The EtherChannel Layer 3 ports are made up of routed ports. Routed ports are physical ports configured to be in Layer 3 mode by using the no switchport interface configuration command.

EtherChannel Modes

You can configure an EtherChannel in one of these modes: Port Aggregation Protocol (PAgP), Link Aggregation Control Protocol (LACP), or On. Configure both ends of the EtherChannel in the same mode:

  • When you configure one end of an EtherChannel in either PAgP or LACP mode, the system negotiates with the other end of the channel to determine which ports should become active. If the remote port cannot negotiate an EtherChannel, the local port is put into an independent state and continues to carry data traffic as would any other single link. The port configuration does not change, but the port does not participate in the EtherChannel.
  • When you configure an EtherChannel in the on mode, no negotiations take place. The switch forces all compatible ports to become active in the EtherChannel. The other end of the channel (on the other switch) must also be configured in the on mode; otherwise, packet loss can occur.

EtherChannel Link Failover

If a link within an EtherChannel fails, traffic previously carried over that failed link moves to the remaining links within the EtherChannel. If traps are enabled on the switch, a trap is sent for a failure that identifies the switch, the EtherChannel, and the failed link. Inbound broadcast and multicast packets on one link in an EtherChannel are blocked from returning on any other link of the EtherChannel.

Port-Channel Interfaces

When you create an EtherChannel, a port-channel logical interface is involved:

  • With Layer 2 ports, use the channel-group interface configuration command to dynamically create the port-channel logical interface. You also can use the interface port-channel port-channel-number global configuration command to manually create the port-channel logical interface, but then you must use the channel-group channel-group-number command to bind the logical interface to a physical port. The channel-group-number can be the same as the port-channel-number, or you can use a new number. If you use a new number, the channel-group command dynamically creates a new port channel.
  • With Layer 3 ports, you should manually create the logical interface by using the interface port-channel global configuration command followed by the no switchport interface configuration command. You then manually assign an interface to the EtherChannel by using the channel-group interface configuration command.
Figure 2. Relationship of Physical Ports, Logical Port Channels, and Channel Groups.

The channel-group command binds the physical port and the logical interface together. Each EtherChannel has a port-channel logical interface numbered from 1 to 48. This port-channel interface number corresponds to the one specified with the channel-group interface configuration command.



After you configure an EtherChannel, configuration changes applied to the port-channel interface apply to all the physical ports assigned to the port-channel interface. Configuration changes applied to the physical port affect only the port where you apply the configuration. To change the parameters of all ports in an EtherChannel, apply configuration commands to the port-channel interface, for example, spanning-tree commands or commands to configure a Layer 2 EtherChannel as a trunk.

Port Aggregation Protocol

The Port Aggregation Protocol (PAgP) is a Cisco-proprietary protocol that can be run only on Cisco switches and on those switches licensed by vendors to support PAgP. PAgP facilitates the automatic creation of EtherChannels by exchanging PAgP packets between Ethernet ports. PAgP can be enabled on cross-stack EtherChannels.

By using PAgP, the switch or switch stack learns the identity of partners capable of supporting PAgP and the capabilities of each port. It then dynamically groups similarly configured ports (on a single switch in the stack) into a single logical link (channel or aggregate port). Similarly configured ports are grouped based on hardware, administrative, and port parameter constraints. For example, PAgP groups the ports with the same speed, duplex mode, native VLAN, VLAN range, and trunking status and type. After grouping the links into an EtherChannel, PAgP adds the group to the spanning tree as a single switch port.

PAgP Learn Method and Priority

Network devices are classified as PAgP physical learners or aggregate-port learners. A device is a physical learner if it learns addresses by physical ports and directs transmissions based on that knowledge. A device is an aggregate-port learner if it learns addresses by aggregate (logical) ports. The learn method must be configured the same at both ends of the link.

When a device and its partner are both aggregate-port learners, they learn the address on the logical port-channel. The device sends packets to the source by using any of the ports in the EtherChannel. With aggregate-port learning, it is not important on which physical port the packet arrives.

PAgP cannot automatically detect when the partner device is a physical learner and when the local device is an aggregate-port learner. Therefore, you must manually set the learning method on the local device to learn addresses by physical ports. You also must set the load-distribution method to source-based distribution, so that any given source MAC address is always sent on the same physical port.

You also can configure a single port within the group for all transmissions and use other ports for hot-standby. The unused ports in the group can be swapped into operation in just a few seconds if the selected single port loses hardware-signal detection. You can configure which port is always selected for packet transmission by changing its priority with the pagp port-priority interface configuration command. The higher the priority, the more likely that the port will be selected.


Note


The switch supports address learning only on aggregate ports even though the physical-port keyword is provided in the CLI. The pagp learn-method command and the pagp port-priority command have no effect on the switch hardware, but they are required for PAgP interoperability with devices that only support address learning by physical ports, such as the Catalyst 1900 switch.

When the link partner of the switch is a physical learner, we recommend that you configure the switch as a physical-port learner by using the pagp learn-method physical-port interface configuration command. Set the load-distribution method based on the source MAC address by using the port-channel load-balance src-mac global configuration command. The switch then sends packets to the physcial learner using the same port in the EtherChannel from which it learned the source address. Only use the pagp learn-method command in this situation.


PAgP Interaction with Virtual Switches and Dual-Active Detection

A virtual switch can be two or more core switches connected by virtual switch links (VSLs) that carry control and data traffic between them. One of the switches is in active mode. The others are in standby mode. For redundancy, remote switches are connected to the virtual switch by remote satellite links (RSLs).

If the VSL between two switches fails, one switch does not know the status of the other. Both switches could change to the active mode, causing a dual-active situation in the network with duplicate configurations (including duplicate IP addresses and bridge identifiers). The network might go down.

To prevent a dual-active situation, the core switches send PAgP protocol data units (PDUs) through the RSLs to the remote switches. The PAgP PDUs identify the active switch, and the remote switches forward the PDUs to core switches so that the core switches are in sync. If the active switch fails or resets, the standby switch takes over as the active switch. If the VSL goes down, one core switch knows the status of the other and does not change state.

PAgP Interaction with Other Features

The Dynamic Trunking Protocol (DTP) and the Cisco Discovery Protocol (CDP) send and receive packets over the physical ports in the EtherChannel. Trunk ports send and receive PAgP protocol data units (PDUs) on the lowest numbered VLAN.

In Layer 2 EtherChannels, the first port in the channel that comes up provides its MAC address to the EtherChannel. If this port is removed from the bundle, one of the remaining ports in the bundle provides its MAC address to the EtherChannel. For Layer 3 EtherChannels, the MAC address is allocated by the active switch as soon as the interface is created (through the interface port-channel global configuration command).

PAgP sends and receives PAgP PDUs only from ports that are up and have PAgP enabled for the auto or desirable mode.

Link Aggregation Control Protocol

The LACP is defined in IEEE 802.3ad and enables Cisco switches to manage Ethernet channels between switches that conform to the IEEE 802.3ad protocol. LACP facilitates the automatic creation of EtherChannels by exchanging LACP packets between Ethernet ports.

By using LACP, the switch or switch stack learns the identity of partners capable of supporting LACP and the capabilities of each port. It then dynamically groups similarly configured ports into a single logical link (channel or aggregate port). Similarly configured ports are grouped based on hardware, administrative, and port parameter constraints. For example, LACP groups the ports with the same speed, duplex mode, native VLAN, VLAN range, and trunking status and type. After grouping the links into an EtherChannel, LACP adds the group to the spanning tree as a single switch port.

LACP Modes

LACP modes specify whether a port can send LACP packets or only receive LACP packets.

Table 1 EtherChannel LACP Modes

Mode

Description

active

Places a port into an active negotiating state in which the port starts negotiations with other ports by sending LACP packets.

passive

Places a port into a passive negotiating state in which the port responds to LACP packets that it receives, but does not start LACP packet negotiation. This setting minimizes the transmission of LACP packets.

Both the active and passive LACP modes enable ports to negotiate with partner ports to an EtherChannel based on criteria such as port speed, and for Layer 2 EtherChannels, based on trunk state and VLAN numbers.

Ports can form an EtherChannel when they are in different LACP modes as long as the modes are compatible. For example:

  • A port in the active mode can form an EtherChannel with another port that is in the active or passive mode.
  • A port in the passive mode cannot form an EtherChannel with another port that is also in the passive mode because neither port starts LACP negotiation.

LACP Interaction with Other Features

The DTP and the CDP send and receive packets over the physical ports in the EtherChannel. Trunk ports send and receive LACP PDUs on the lowest numbered VLAN.

In Layer 2 EtherChannels, the first port in the channel that comes up provides its MAC address to the EtherChannel. If this port is removed from the bundle, one of the remaining ports in the bundle provides its MAC address to the EtherChannel. For Layer 3 EtherChannels, the MAC address is allocated by the active switch as soon as the interface is created through the interface port-channel global configuration command.

LACP sends and receives LACP PDUs only from ports that are up and have LACP enabled for the active or passive mode.

EtherChannel On Mode

EtherChannel on mode can be used to manually configure an EtherChannel. The on mode forces a port to join an EtherChannel without negotiations. The on mode can be useful if the remote device does not support PAgP or LACP. In the on mode, a usable EtherChannel exists only when the switches at both ends of the link are configured in the on mode.

Ports that are configured in the on mode in the same channel group must have compatible port characteristics, such as speed and duplex. Ports that are not compatible are suspended, even though they are configured in the on mode.


Caution


You should use care when using the on mode. This is a manual configuration, and ports on both ends of the EtherChannel must have the same configuration. If the group is misconfigured, packet loss or spanning-tree loops can occur.


Load-Balancing and Forwarding Methods

EtherChannel balances the traffic load across the links in a channel by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the channel. EtherChannel load-balancing can use several methods of load balancing that include MAC addresses or IP addresses, source or destination addresses, or both source and destination addresses. The selected mode applies to all EtherChannels configured on the switch. You configure the load-balancing and forwarding method by using the port-channel load-balance global configuration command.

MAC Address Forwarding

With source-MAC address forwarding, when packets are forwarded to an EtherChannel, they are distributed across the ports in the channel based on the source-MAC address of the incoming packet. Therefore, to provide load-balancing, packets from different hosts use different ports in the channel, but packets from the same host use the same port in the channel.

With destination-MAC address forwarding, when packets are forwarded to an EtherChannel, they are distributed across the ports in the channel based on the destination host’s MAC address of the incoming packet. Therefore, packets to the same destination are forwarded over the same port, and packets to a different destination are sent on a different port in the channel.

With source-and-destination MAC address forwarding, when packets are forwarded to an EtherChannel, they are distributed across the ports in the channel based on both the source and destination MAC addresses. This forwarding method, a combination source-MAC and destination-MAC address forwarding methods of load distribution, can be used if it is not clear whether source-MAC or destination-MAC address forwarding is better suited on a particular switch. With source-and-destination MAC-address forwarding, packets sent from host A to host B, host A to host C, and host C to host B could all use different ports in the channel.

IP Address Forwarding

With source-IP address-based forwarding, when packets are forwarded to an EtherChannel, they are distributed across the ports in the EtherChannel based on the source-IP address of the incoming packet. Therefore, to provide load-balancing, packets from different IP addresses use different ports in the channel, but packets from the same IP address use the same port in the channel.

With destination-IP address-based forwarding, when packets are forwarded to an EtherChannel, they are distributed across the ports in the EtherChannel based on the destination-IP address of the incoming packet. Therefore, to provide load-balancing, packets from the same IP source address sent to different IP destination addresses could be sent on different ports in the channel. But packets sent from different source IP addresses to the same destination IP address are always sent on the same port in the channel.

With source-and-destination IP address-based forwarding, when packets are forwarded to an EtherChannel, they are distributed across the ports in the EtherChannel based on both the source and destination IP addresses of the incoming packet. This forwarding method, a combination of source-IP and destination-IP address-based forwarding, can be used if it is not clear whether source-IP or destination-IP address-based forwarding is better suited on a particular switch. In this method, packets sent from the IP address A to IP address B, from IP address A to IP address C, and from IP address C to IP address B could all use different ports in the channel.

Load Balancing Advantages

Different load-balancing methods have different advantages, and the choice of a particular load-balancing method should be based on the position of the switch in the network and the kind of traffic that needs to be load-distributed.

Figure 3. Load Distribution and Forwarding Methods. In the following figure, an EtherChannel of four workstations communicates with a router. Because the router is a single-MAC-address device, source-based forwarding on the switch EtherChannel ensures that the switch uses all available bandwidth to the router. The router is configured for destination-based forwarding because the large number of workstations ensures that the traffic is evenly distributed from the router EtherChannel.

Use the option that provides the greatest variety in your configuration. For example, if the traffic on a channel is going only to a single MAC address, using the destination-MAC address always chooses the same link in the channel. Using source addresses or IP addresses might result in better load-balancing.

Default EtherChannel Configuration

The default EtherChannel configuration is described in this table.

Table 2 Default EtherChannel Configuration

Feature

Default Setting

Channel groups

None assigned.

Port-channel logical interface

None defined.

PAgP mode

No default.

PAgP learn method

Aggregate-port learning on all ports.

PAgP priority

128 on all ports.

LACP mode

No default.

LACP learn method

Aggregate-port learning on all ports.

LACP port priority

32768 on all ports.

LACP system priority

32768.

LACP system ID

LACP system priority and the switch or stack MAC address.

Load-balancing

Load distribution on the switch is based on the source-MAC address of the incoming packet.

EtherChannel Configuration Guidelines

If improperly configured, some EtherChannel ports are automatically disabled to avoid network loops and other problems. Follow these guidelines to avoid configuration problems:

  • Do not try to configure more than 48 EtherChannels on the switch or switch stack.
  • Configure a PAgP EtherChannel with up to eight Ethernet ports of the same type.
  • Configure a LACP EtherChannel with up to 16 Ethernet ports of the same type. Up to eight ports can be active, and up to eight ports can be in standby mode.
  • Configure all ports in an EtherChannel to operate at the same speeds and duplex modes.
  • Enable all ports in an EtherChannel. A port in an EtherChannel that is disabled by using the shutdown interface configuration command is treated as a link failure, and its traffic is transferred to one of the remaining ports in the EtherChannel.
  • When a group is first created, all ports follow the parameters set for the first port to be added to the group. If you change the configuration of one of these parameters, you must also make the changes to all ports in the group:
    • Allowed-VLAN list
    • Spanning-tree path cost for each VLAN
    • Spanning-tree port priority for each VLAN
    • Spanning-tree Port Fast setting
  • Do not configure a port to be a member of more than one EtherChannel group.
  • Do not configure an EtherChannel in both the PAgP and LACP modes. EtherChannel groups running PAgP and LACP can coexist on the same switch or on different switches in the stack. Individual EtherChannel groups can run either PAgP or LACP, but they cannot interoperate.
  • Do not configure a secure port as part of an EtherChannel or the reverse.
  • Do not configure a port that is an active or a not-yet-active member of an EtherChannel as an IEEE 802.1x port. If you try to enable IEEE 802.1x on an EtherChannel port, an error message appears, and IEEE 802.1x is not enabled.
  • If EtherChannels are configured on switch interfaces, remove the EtherChannel configuration from the interfaces before globally enabling IEEE 802.1x on a switch by using the dot1x system-auth-control global configuration command.
  • For cross-stack EtherChannel configurations, ensure that all ports targeted for the EtherChannel are either configured for LACP or are manually configured to be in the channel group using the channel-group channel-group-number mode on interface configuration command. The PAgP protocol is not supported on cross- stack EtherChannels.
  • If cross-stack EtherChannel is configured and the switch stack partitions, loops and forwarding issues can occur.

Layer 2 EtherChannel Configuration Guidelines

When configuring Layer 2 EtherChannels, follow these guidelines:

  • Assign all ports in the EtherChannel to the same VLAN, or configure them as trunks. Ports with different native VLANs cannot form an EtherChannel.
  • If you configure an EtherChannel from trunk ports, verify that the trunking mode (ISL or IEEE 802.1Q) is the same on all the trunks. Inconsistent trunk modes on EtherChannel ports can have unexpected results.
  • An EtherChannel supports the same allowed range of VLANs on all the ports in a trunking Layer 2 EtherChannel. If the allowed range of VLANs is not the same, the ports do not form an EtherChannel even when PAgP is set to the auto or desirable mode.
  • Ports with different spanning-tree path costs can form an EtherChannel if they are otherwise compatibly configured. Setting different spanning-tree path costs does not, by itself, make ports incompatible for the formation of an EtherChannel.

Layer 3 EtherChannel Configuration Guidelines

When configuring Layer 3 EtherChannels, follow this guideline:

  • For Layer 3 EtherChannels, assign the Layer 3 address to the port-channel logical interface, not to the physical ports in the channel.

How to Configure EtherChannels

This section describes how to configure EtherChannels, PAgP, and LACP.

After you configure an EtherChannel, configuration changes applied to the port-channel interface apply to all the physical ports assigned to the port-channel interface, and configuration changes applied to the physical port affect only the port where you apply the configuration.

Configuring Layer 2 EtherChannels

You configure Layer 2 EtherChannels by assigning ports to a channel group with the channel-group interface configuration command. This command automatically creates the port-channel logical interface.

If you enabled PAgP on a port in the auto or desirable mode, you must reconfigure it for either the on mode or the LACP mode before adding this port to a cross-stack EtherChannel. PAgP does not support cross-stack EtherChannels.

SUMMARY STEPS

    1.    configure terminal

    2.    interface interface-id

    3.    switchport mode {access | trunk}

    4.    switchport access vlan vlan-id

    5.    channel-group channel-group-number mode {auto [non-silent] | desirable [non-silent ] | on } | { active | passive}

    6.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1configure terminal


    Example:
    Switch# configure terminal
    
    
     

    Enters global configuration mode.

     
    Step 2 interface interface-id


    Example:
    Switch(config)# interface gigabitethernet2/0/1
    
    
     

    Specifies a physical port, and enters interface configuration mode.

    Valid interfaces are physical ports.

    For a PAgP EtherChannel, you can configure up to eight ports of the same type and speed for the same group.

    For a LACP EtherChannel, you can configure up to 16 Ethernet ports of the same type. Up to eight ports can be active, and up to eight ports can be in standby mode.

     
    Step 3 switchport mode {access | trunk}


    Example:
    Switch(config-if)# switchport mode access
    
    
     

    Assigns all ports as static-access ports in the same VLAN, or configure them as trunks.

    If you configure the port as a static-access port, assign it to only one VLAN. The range is 1 to 4094.

     
    Step 4 switchport access vlan vlan-id


    Example:
    Switch(config-if)# switchport access vlan 22
    
    
     

    (Optional) If you configure the port as a static-access port, assign it to only one VLAN. The range is 1 to 4094.

     
    Step 5 channel-group channel-group-number mode {auto [non-silent] | desirable [non-silent ] | on } | { active | passive}


    Example:
    Switch(config-if)# channel-group 5 mode auto
    
    
     

    Assigns the port to a channel group, and specifies the PAgP or the LACP mode.

    For channel-group-number, the range is 1 to 128.

    For mode, select one of these keywords:

    • auto Enables PAgP only if a PAgP device is detected. It places the port into a passive negotiating state, in which the port responds to PAgP packets it receives but does not start PAgP packet negotiation. This keyword is not supported when EtherChannel members are from different switches in the switch stack.
    • desirable Unconditionally enables PAgP. It places the port into an active negotiating state, in which the port starts negotiations with other ports by sending PAgP packets. This keyword is not supported when EtherChannel members are from different switches in the switch stack.
    • on Forces the port to channel without PAgP or LACP. In the on mode, an EtherChannel exists only when a port group in the on mode is connected to another port group in the on mode.
    • non-silent (Optional) If your switch is connected to a partner that is PAgP-capable, configures the switch port for nonsilent operation when the port is in the auto or desirable mode. If you do not specify non-silent, silent is assumed. The silent setting is for connections to file servers or packet analyzers. This setting allows PAgP to operate, to attach the port to a channel group, and to use the port for transmission.
    • active—Enables LACP only if a LACP device is detected. It places the port into an active negotiating state in which the port starts negotiations with other ports by sending LACP packets.
    • passive Enables LACP on the port and places it into a passive negotiating state in which the port responds to LACP packets that it receives, but does not start LACP packet negotiation.
     
    Step 6end


    Example:
    Switch(config-if)# end
    
    
     

    Returns to privileged EXEC mode.

     

    Configuring EtherChannel Load-Balancing

    You can configure EtherChannel load-balancing by using source-based or destination-based forwarding methods.

    This task is optional.

    SUMMARY STEPS

      1.    configure terminal

      2.    port-channel load-balance { dst-ip | dst-mac | dst-mixed-ip-port | dst-port | extended [dst-ip | dst-mac | dst-port | ipv6-label | l3-proto | src-ip | src-mac | src-port ] | src-dst-ip | src-dst-mac src-dst-mixed-ip-port src-dst-portsrc-ip | src-mac | src-mixed-ip-port | src-port}

      3.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1configure terminal


      Example:
      Switch# configure terminal
      
      
       

      Enters global configuration mode.

       
      Step 2 port-channel load-balance { dst-ip | dst-mac | dst-mixed-ip-port | dst-port | extended [dst-ip | dst-mac | dst-port | ipv6-label | l3-proto | src-ip | src-mac | src-port ] | src-dst-ip | src-dst-mac src-dst-mixed-ip-port src-dst-portsrc-ip | src-mac | src-mixed-ip-port | src-port}


      Example:
      Switch(config)# port-channel load-balance src-mac
      
      
       

      Configures an EtherChannel load-balancing method.

      The default is src-mac.

      Select one of these load-distribution methods:

      • dst-ip—Specifies destination-host IP address.
      • dst-mac—Specifies the destination-host MAC address of the incoming packet.
      • dst-mixed-ip-port—Specifies the host IP address and TCP/UDP port.
      • dst-port—Specifies the destination TCP/UDP port.
      • extended—Specifies extended load balance methods.
      • ipv6-label—Specifies the IPv6 flow label.
      • l3-proto—Specifies the Layer 3 protocol.
      • src-dst-ip—Specifies the source and destination host IP address.
      • src-dst-mac—Specifies the source and destination host MAC address.
      • src-dst-mixed-ip-port—Specifies the source and destination host IP address and TCP/UDP port.
      • src-dst-port—Specifies the source and destination TCP/UDP port.
      • src-ip—Specifies the source host IP address.
      • src-mac—Specifies the source MAC address of the incoming packet.
      • src-mixed-ip-port—Specifies the source host IP address and TCP/UDP port.
      • src-port—Specifies the source TCP/UDP port.
       
      Step 3end


      Example:
      Switch(config)# end
      
      
       

      Returns to privileged EXEC mode.

       

      Configuring the PAgP Learn Method and Priority

      This task is optional.

      SUMMARY STEPS

        1.    configure terminal

        2.    interface interface-id

        3.    pagp learn-method physical-port

        4.    pagp port-priority priority

        5.    end


      DETAILED STEPS
         Command or ActionPurpose
        Step 1configure terminal


        Example:
        Switch# configure terminal
        
        
         

        Enters global configuration mode.

         
        Step 2 interface interface-id


        Example:
        Switch(config)# interface gigabitethernet 1/0/2
        
        
         

        Specifies the port for transmission, and enters interface configuration mode.

         
        Step 3 pagp learn-method physical-port


        Example:
        Switch(config-if)# pagp learn-method physical port
        
        
         

        Selects the PAgP learning method.

        By default, aggregation-port learning is selected, which means the switch sends packets to the source by using any of the ports in the EtherChannel. With aggregate-port learning, it is not important on which physical port the packet arrives.

        Selects physical-port to connect with another switch that is a physical learner. Make sure to configure the port-channel load-balance global configuration command to src-mac.

        The learning method must be configured the same at both ends of the link.

         
        Step 4 pagp port-priority priority


        Example:
        Switch(config-if)# pagp port-priority 200
        
        
         

        Assigns a priority so that the selected port is chosen for packet transmission.

        For priority, the range is 0 to 255. The default is 128. The higher the priority, the more likely that the port will be used for PAgP transmission.

         
        Step 5end


        Example:
        Switch(config-if)# end
        
        
         

        Returns to privileged EXEC mode.

         

        Monitoring EtherChannel, PAgP, and LACP Status

        Display EtherChannel, PAgP, and LACP status using the commands described in this table.

        Table 3 Commands for Monitoring EtherChannel, PAgP, and LACP Status

        Command

        Description

        clear lacp { channel-group-number counters | counters }

        Clears LACP channel-group information and traffic counters.

        clear pagp { channel-group-number counters | counters }

        Clears PAgP channel-group information and traffic counters.

        show etherchannel [ channel-group-number { detail | port | port-channel | protocol | summary }] { detail | load-balance | port | port-channel | protocol | summary }

        Displays EtherChannel information in a brief, detailed, and one-line summary form. Also displays the load-balance or frame-distribution scheme, port, port-channel, and protocol information.

        show pagp [ channel-group-number ] { counters | internal | neighbor }

        Displays PAgP information such as traffic information, the internal PAgP configuration, and neighbor information.

        show pagp [ channel-group-number ] dual-active

        Displays the dual-active detection status.

        show lacp [ channel-group-number ] { counters | internal  | neighbor | sys-id}

        Displays LACP information such as traffic information, the internal LACP configuration, and neighbor information.

        show running-config

        Verifies your configuration entries.

        show etherchannel load-balance

        Displays the load balance or frame distribution scheme among ports in the port channel.

        Configuration Examples for Configuring EtherChannels

        Configuring Layer 2 EtherChannels: Examples

        This example shows how to configure an EtherChannel on a single switch in the stack. It assigns two ports as static-access ports in VLAN 10 to channel 5 with the PAgP mode desirable:

        		Switch# configure terminal
        		Switch(config)# interface range gigabitethernet2/0/1 -2
        		Switch(config-if-range)# switchport mode access
        		Switch(config-if-range)# switchport access vlan 10
        		Switch(config-if-range)# channel-group 5 mode desirable non-silent
        		Switch(config-if-range)# end
        		
        	

        This example shows how to configure an EtherChannel on a single switch in the stack. It assigns two ports as static-access ports in VLAN 10 to channel 5 with the LACP mode active:

        		Switch# configure terminal
        		Switch(config)# interface range gigabitethernet2/0/1 -2 
        		Switch(config-if-range)# switchport mode access
        		Switch(config-if-range)# switchport access vlan 10
        		Switch(config-if-range)# channel-group 5 mode active
        		Switch(config-if-range)# end
        		
        	

        This example shows how to configure a cross-stack EtherChannel. It uses LACP passive mode and assigns two ports on stack member 2 and one port on stack member 3 as static-access ports in VLAN 10 to channel 5:

        		Switch# configure terminal
        		Switch(config)# interface range gigabitethernet2/0/4 -5 
        		Switch(config-if-range)# switchport mode access
        		Switch(config-if-range)# switchport access vlan 10
        		Switch(config-if-range)# channel-group 5 mode active 
        		Switch(config-if-range)# exit
        		Switch(config)# interface gigabitethernet3/0/3 
        		Switch(config-if)# switchport mode access
        		Switch(config-if)# switchport access vlan 10
        		Switch(config-if)# channel-group 5 mode active 
        		Switch(config-if)# exit
        		
        

        Configuring Port-Channel Logical Interfaces: Example

        This example shows how to create the logical port channel 5 and assign 172.10.20.10 as its IP address:

        		Switch# configure terminal 
        		Switch(config)# interface port-channel 5
        		Switch(config-if)# no switchport
        		Switch(config-if)# ip address 172.10.20.10 255.255.255.0
        		Switch(config-if)# end 
        		
                 

        Configuring EtherChannel Physical Interfaces: Examples

        This example shows how to configure an EtherChannel. It assigns two ports to channel 5 with the LACP mode active:

        		Switch# configure terminal 
        		Switch(config)# interface range gigabitethernet2/0/1 -2 
        		Switch(config-if-range)# no ip address 
        		Switch(config-if-range)# no switchport
        		Switch(config-if-range)# channel-group 5 mode active
        		Switch(config-if-range)# end
        		
        		
                 

        This example shows how to configure a cross-stack EtherChannel. It assigns two ports on stack member 2 and one port on stack member 3 to channel 7 using LACP active mode:

        		Switch# configure terminal 
        		Switch(config)# interface range gigabitethernet2/0/4 -5 
        		Switch(config-if-range)# no ip address 
        		Switch(config-if-range)# no switchport 
        		Switch(config-if-range)# channel-group 7 mode active 
        		Switch(config-if-range)# exit
        		Switch(config)# interface gigabitethernet3/0/3 
        		Switch(config-if)# no ip address 
        		Switch(config-if)# no switchport 
        		Switch(config-if)# channel-group 7 mode active 
        		Switch(config-if)# exit
        		
        		
                 

        Additional References for EtherChannels

        Related Documents

        Related Topic Document Title
        Layer 2 command reference Layer 2/3 Command Reference (Catalyst 3850 Switches)

        Standards and RFCs

        Standard/RFC Title

        None

        MIBs

        MIB MIBs Link

        All supported MIBs for this release.

        To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

        http:/​/​www.cisco.com/​go/​mibs

        Technical Assistance

        Description Link

        The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

        To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

        Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

        http:/​/​www.cisco.com/​support

        Feature Information for EtherChannels

        Feature Information for EtherChannels

        Releases Feature Information

        Cisco IOS XE 3.2SE

        This feature was introduced.