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Using Cisco Fabric Manager and Device 
Manager

This chapter describes how to use Cisco Fabric Manager and Device Manager, and it includes the 
following sections:

• Summary of Fabric and Device Management Tasks, page 2-1

• Using Fabric Manager, page 2-2

• Using Device Manager, page 2-19

• Using Summary View, page 2-26

Summary of Fabric and Device Management Tasks
Table 2-1 summarizes the tasks that you can perform using Fabric Manager and Device Manager. In 
general, you can perform tasks using Fabric Manager for multiple devices. Device Manager is more 
convenient to use when you are working with a single switch.

Table 2-1 Fabric and Device Management Tasks

Task Tool See

Troubleshoot connectivity and switch 
configuration.

Fabric Manager “Troubleshooting Switch Configuration” 
section on page 2-9

Perform fabric discovery and view 
network topology

Fabric Manager Chapter 1, “Getting Started with Cisco Fabric 
Manager”

Manage zones and activate zone sets Fabric Manager Chapter 3, “Managing Zones and Zone Sets”

Manage VSANs. Fabric Manager or Device 
Manager

Chapter 4, “Managing VSANs”

Enable or disable ports. Device Manager’s Device View “Managing Ports” section on page 2-24

Manage SNMP events and alarms. Fabric Manager or Device 
Manager

Chapter 8, “Managing Events and Alarms”

Manage SNMP and CLI Security Fabric Manager or Device 
Manager

Chapter 5, “Managing Administrator Access”

Copy and save configuration and image 
files

Fabric Manager or Device 
Manager

Chapter 6, “Managing Software and 
Configuration Files”
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Using Fabric Manager
This section describes how to use Fabric Manager and summarizes the tasks that you can perform with 
it. It includes the following sections:

• Fabric Mangaer Main Window, page 2-2

• Locating Other Switches, page 2-6

• Modifying Device Grouping, page 2-7

• Troubleshooting Switch Configuration, page 2-9

• Setting Preferences, page 2-14

• Viewing Reports in Fabric Manager, page 2-16

Fabric Mangaer Main Window
The Fabric Manager displays a view of your network fabric, including Cisco 9000 or third-party switches 
and end devices. To launch the Fabric Manager from your desktop, double-click the Fabric Manager 
icon and follow the instructions described in the “Launching Views” section on page 1-11. Figure 2-1 
shows the Fabric Manager main window.

Note Changes made using Fabric Manager are applied to the running configuration of the switches you are 
managing and the changes may not be saved when the switch restarts. After you make a change to the 
configuration or perform an operation (such as activating zones), the system prompts you to save your 
changes before you exit.

View hardware configuration Fabric Manager or Device 
Manager

Chapter 9, “Managing the System and 
Components”

Manage Fibre Channel routing and FSPF. Fabric Manager or Device 
Manager

Chapter 10, “Managing Fibre Channel 
Routing and FSPF”

Manage advanced features Fabric Manager or Device 
Manager

Chapter 11, “Managing Advanced Features”

Table 2-1 Fabric and Device Management Tasks (continued)

Task Tool See
2-2
Cisco MDS 9000 Family Fabric Manager User Guide

78-14895-02, Cisco MDS SAN-OS Release 1.0(3a)



Send  documenta t ion  comments  to  

Chapter 2      Using Cisco Fabric Manager and Device Manager
Using Fabric Manager
Figure 2-1 Fabric Manager Main Window

The menu bar at the top of the Fabric Manager window provides access to options, that are organized by 
menus. The toolbar provides icons that duplicate the most commonly used options on the File, Tools, 
and Help menus.

The main window has a menu bar, toolbar, message bar, status bar, and three panes:

• VSAN/Switch pane—Displays a tree of configured VSANs and zones on the VSANs/Zones tab and 
a menu tree of available configuration tasks on the Switch tab.

• Information pane—Displays information about whatever option is selected in the menu tree.

• Map pane—Displays a map of the network fabric, including switches, hosts, and storage. It also 
provides tabs for displaying log and event data.

You can resize each pane by dragging the boundaries between each region or by clicking the Minimize 
or Maximize controls. (See Figure 2-1.)
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Menu Bar, Toolbars, and Message Bar

The menu bar at the top of the Fabric Manager window provides options for managing and 
troubleshooting the current fabric and for controlling the display of information on the Map pane. The 
menu bar provides the following menus:

• File—Open a new fabric, rediscover the current fabric, locate switches, set preferences, print the 
map, and clear or export the Map pane log.

• Edit—Manage zones, zonesets, and various elements on the Fabric Manager map.

• View—Change the appearance of the map (these options are duplicated on the Map pane toolbar).

• Reports—Display summary reports, as described in the “Viewing Reports in Fabric Manager” 
section on page 2-16.

• Troubleshooting—Verify and troubleshoot connectivity and configuration, as described in the 
“Troubleshooting Switch Configuration” section on page 2-9.

• Help—Display on-line help topics for specific dialog boxes in the Information pane.

The Fabric Manager main toolbar provides buttons for accessing the most commonly used menu bar 
options. The Map pane toolbar provides buttons for managing the appearance of the map.  The 
Information pane toolbar provides buttons for editing and managing the Information pane.

The message bar shows the last entry displayed by the discovery process, and the possible error message. 
It displays a dialog stating that something has changed in the fabric and a new discovery is needed. The 
status bar shows both short-term, transient messages (such as the number of rows displayed in the table), 
and long-term discovery issues.

VSAN/Switch Pane

Use the VSAN tab on the VSAN/Switch pane to manage VSANs and zones in the currently discovered 
fabric. For information about managing VSANs see Chapter 4, “Adding and Configuring VSANs.”

To manage zones, right-click one of the folders in the VSAN tree and click Edit Zones from the pop-up 
menu. You see the Edit Zones dialog box. For information about managing zones and zone sets, see 
Chapter 3, “Managing Zones and Zone Sets.”

Use the Switch tab on the VSAN/Switch pane to display a menu tree of the options available for 
managing the switches in the currently discovered fabric. You see the menu tree shown in Figure 2-2.
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Figure 2-2 Menu Tree and Dialog Box

To select an option, click a folder to display the options available and then click the option. You see the 
dialog box for the selected option in the Information pane. The menu tree provides the following main 
folders:

• Physical—View and configure hardware components.

• Interface—View, monitor, and configure ports and PortChannel interfaces.

• FC—View and configure Fibre Channel network configurations.

• IP—View and configure TCP/IP (management) network configurations.

• Events—View and configure events, alarms, thresholds, notifications, and informs.

• Security—View and configure SNMP and CLI security.

• Admin—Download software images; copy and save configuration files.

Information Pane

The Information pane displays tables or other information associated with the option selected from the 
menu tree. The Information pane toolbar provides buttons for performing one or more of the following 
operations:

• Create—Insert a new row into a table.

• Delete Row—Delete the selected row from a table.

• Copy…Ctrl+C — Copy data from one row to another.

• Paste…Ctrl +V—Paste the data from one row to another.

• Apply Changes—Apply configuration changes.

Note After making changes you must save the configuration or the changes will be lost when the 
device is restarted.

• Refresh Values—Refresh table values.

• Undo Changes…Ctrl-Z—Undo the most recent change.

• Print Table —Print the contents of the Information pane.

• Export—Export and save information to a tab-delimited file.
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• Log—Displays messages describing system operations, such as fabric discovery.

Note The buttons that appear on the toolbar vary according to the option you select. They are activated or 
deactivated (grayed) according to the field or other object that you select in the Information pane. 

Map Pane

There are three tabs on the bottom of the Map pane:

• Map—Displays a graphical view of the network fabric with switches, hosts, and storage subsystems.

• Events—Displays information about the SNMP traps received by the management station.

When you right-click an icon, you see a pop-up menu with options that vary depending on the type of 
icon selected. The various options available for different objects include the following:

• Open an instance of Device Manager for the selected switch.

• Open a CLI session for the selected switch.

• Copy the display name of the selected object.

• Execute a ping or traceroute command for the device.

• Show or hide end devices.

• Create or delete an enclosure.

• Set the VSAN ID for an edge port (link).

• Set the trunking mode for an ISL.

• Create or add to a PortChannel for selected ISLs.

The Map pane has its own toolbar with options for saving, printing, and changing the appearance of the 
map. When you right-click on the map, a pop-up menu appears that provides options (duplicated on the 
toolbar) for changing the appearance of the map.

Note When a VSAN, zone, or zone member is selected in the VSAN tree, the map highlighting changes to 
identify the selected objects. To remove this highlighting, click the Clear Highlight button on the Map 
pane toolbar or choose Clear Highlight  from the pop-up menu. 

Locating Other Switches
The Locate Switches option uses SNMPv2 and discovers devices responding to SNMP requests with the 
read-only community string public. To enable your Cisco MDS 9000 Family switches to respond to 
SNMPv2 requests, see Chapter 5, “Managing Administrator Access.”

To locate switches that are not included in the currently discovered fabric, follow these steps:

Step 1 Choose File > Locate Switches from the Fabric View main window.

You see the Locate Devices dialog box. 

Step 2 Enter a range of specific addresses belonging to a specific subnet which limit the research for the 
switches. To look for a Cisco MDS 9000 switch belonging to subnet 192.168.199.0, use the follwing 
string:
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192.168.100.[1-254]

Multiple ranges can be specified, separated by commas. For example, to look for all the devices in the 
two subnets 192.168.199.0 and 192.169.100.0, use the following string:

192.168.100.[1-254], 192.169.100.[1-254]

Step 3 Enter the appropriate read community string in the Read Community field. 

The default value for this string is “public.”

Step 4 Click Display Cisco MDS 9000 Only to display only the Cisco MDS 9000 Family switches in your 
network fabric.

Step 5 Click Search to discover switches and devices in your network fabric. You see the results of the discover 
in the Locate Devices window.

Note The number in the lower left corner of the screen increments as the device locator attempts to 
discover the devices in your network fabric. When the discovery process is complete, the number 
indicates the number of rows displayed.

To manage the discovered switches, follow these steps:

Step 1 Choose File > Open from the Fabric Manager menu bar.

Step 2 Enter the IP address of a switch in the Device Name field on the Open dialog box.

Step 3 Enter your user name and password in the User Name and Auth Password fields. 

If the SNMPv3 Privacy feature is implemented, enter the encryption password as well. 

Step 4 Check the SNMPv3 check box to select SNMP version 3.

Step 5 Click Open.

Modifying Device Grouping
Because of not all the devices are capable of responding to FC-GS3 requests, different ports of a single 
server or storage subsystem may be displayed as individual end devices on the Fabric Manager map. To 
group end devices in a single enclosure in order to have them represented by a single icon on the map, 
follow these steps:

Step 1 Select the end devices in the Fabric Manager map (optional).

Step 2 Choose Edit > Map > Create Enclosure from the Fabric Manager menu bar.

You see the window shown in Figure 2-3.
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Figure 2-3 Create Enclosure Window

Step 3 Enter a name to identify the new icon on the Fabric Manager Map pane in the Name field.

Step 4 Select the type of icon to use for Type:

• host—Servers and other devices containing host bus adapters (HBAs)

• storageDevice—Storage enclosures

• gateway—Routers 

Step 5 Enter the IP address of the device in the IpAddress field (optional).

Step 6 Select the ports on the target device connected to the Cisco MDS 9000 switch in the NxPort(s) field.

The list of all ports in a fabric that are not already assigned to en enclosure are shown.

Step 7 Check the FabricWide checkbox if you want the information about the enclosure to be distributed across 
the fabric, in order to guarantee uniqueness for the enclosure in the all fabric for a particular VSAN. To 
keep the enclosure information locally on the configured switch and not have it propagated on the fabric, 
uncheck the FabricWide checkbox.

Step 8 Click OK.

Note To delete an enclosure, choose Edit > Map > Delete Enclosure from the menu bar. 

Note To change an existing enclosure, delete the enclosure and create a new one. 
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Troubleshooting Switch Configuration
This section describes how to use the tools provided by the Fabric Manager and Device Manager to 
verify and troubleshoot fabric connectivity and switch configuration. It includes the following sections:

• Analyzing Switch Device Health, page 2-9

• Analyzing End-to-End Connectivity, page 2-10

• Analyzing Switch Fabric Configuration, page 2-11

• Analyzing the Results of Merging Zones, page 2-12

• Using Other Troubleshooting Tools, page 2-13

Analyzing Switch Device Health

The Switch Health option lets you determine the status of the components of a specific switch. 

To use the Switch Health option, follow these steps:

Step 1 Click Switch Health from the Fabric Manager Troubleshooting menu.

You see the window shown in Figure 2-4.

Figure 2-4 Switch Health Analysis Window

Step 2 Click Start to identify any problems that may currently be affecting the selected switch.

The Switch Health Analysis window displays any problems affecting the selected switches.

Step 3 Fix these problems.

Step 4 Click Clear to remove the contents of the Switch Health Analysis window.

Step 5 Click Close to close the window.
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Analyzing End-to-End Connectivity

You can use the End to End Connectivity option to determine connectivity and routes among devices 
with the switch fabric. The connectivity tool checks to see that every pair of end devices can talk to each 
other, using a Ping test and by determining if they are in the same VSAN or in the same active zone.

This option uses versions of the ping and traceroute commands modified for Fibre Channel networks. 

To use this option, follow these steps:

Step 1 Choose Troubleshooting > End to End Connectivity from the Fabric Manager menu bar.

You see the window shown in Figure 2-5.

Figure 2-5 End to End Connectivity Analysis Window

Step 2 Enter the identifier of the VSAN in which you want to verify connectivity in the VSAN field.

Step 3 Identify any latency issues in the network fabric by clicking the option, Report average latencies 
greater than and entering the number of microseconds. 

Step 4 Click Ensure that members can communicate to perform a Fibre Channel ping between the selected 
end points.

Step 5 Identify the number of packets, the size of each packet, and the timeout in milliseconds.

Step 6 Analyze the redundant paths between endpoints by clicking Ensure that redundant paths exist 
between members.

Step 7 Click Analyze.

The End to End Connectivity Analysis window displays the selected end points with the switch to which 
each is attached, and the source and target ports used to connect it.

The output shows all the requests which have failed. The possible descriptions are:

• Ignoring empty zone—No requests are issued for this zone.

• Ignoring zone with single member—No requests are issued for this zone.

• Source/Target are unknown—No nameserver entries exist for the ports or we have not discovered 
the port during discovery.

• Both devices are on the same switch.

• No paths exist between the two devices.

• VSAN does not have an active zone set and the default zone is denied.
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• Average time ... micro secs—The latency value was more than the threshold supplied.

Step 8 Click Clear to remove the contents of the window. 

Step 9 Click Close to close the window.

Analyzing Switch Fabric Configuration

The Fabric Configuration option lets you analyze the configuration of a switch by comparing the current 
configuration to a specific switch or to a policy file. You can save a switch configuration to a file and 
then compare all switches against the configuration in the file. 

To use the Fabric Configuration option to analyze the configuration of a switch, follow these steps:

Step 1 Click Fabric Configuration from the Fabric Manager Troubleshooting menu.

You see the window shown in Figure 2-6.

Figure 2-6 Fabric Configuration Analysis Window

Step 2 Choose if you want to compare the selected switch to another switch or to a Policy File.

• If you are making a switch comparison, click Switch and then click the drop-down arrow to see a 
list of switches.

• If you are making a policy comparison, click Policy File. Then the button to the right of this option 
to browse your file system and select a policy file (*.XML).

Step 3 Click Rules to set the rules to apply when running the Fabric Configuration Analysis tool.

You see the window shown in Figure 2-7.
2-11
Cisco MDS 9000 Family Fabric Manager User Guide

78-14895-02, Cisco MDS SAN-OS Release 1.0(3a)



Send  documenta t ion  comments  to  

Chapter 2      Using Cisco Fabric Manager and Device Manager
Using Fabric Manager
Figure 2-7 Fabric Configuration Rules

Step 4 Change the default rules as required and click OK.

Step 5 Click Compare.

The system analyzes the configuration and displays issues that arise as a result of the comparison.

Step 6 Click Clear to remove the contents of the window. 

Step 7 Click Close to close the window.

You use a policy file to define the rules to be applied when running the Fabric Configuration Analysis 
tool. When you create a policy file, the system saves the rules selected for the selected switch.

To create a policy file, follow these steps:

Step 1 Choose Tools > Fabric Configuration from the Fabric Manager menu bar.

Step 2 Click Policy File and enter a name for the policy in the field provided.

Step 3 Click Create Policy and confirm the operation when prompted.

Analyzing the Results of Merging Zones

You can use the Zone Merge option on the Fabric Manager Troubleshooting menu to determine if two 
connected switches have compatible zone configurations. 

To use the Zone Merge option, follow these steps:

Step 1 Choose Zone Merge from the Fabric Manager Troubleshooting menu.

You see the window shown in Figure 2-8.
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Figure 2-8 Zone Merge Analysis Window

Step 2 Select a switch from each pull-down list.

Step 3 Identify the VSAN for which you want to perform the zone merge analysis.

Step 4 Click Analyze.

The Zone Merge Analysis window displays any inconsistencies between the zone configuration of the 
two selected switches.

Step 5 Click Clear to remove the contents of the window. 

Step 6 Click Close to close the window.

Using Other Troubleshooting Tools

You can use the following options on the Troubleshooting menu to verify connectivity to a selected 
object or to open other management tools: 

• Traceroute—Verify connectivity between two end  devices that are currently selected on the Map 
pane.

• Device Manager— Launch the Device Manager for the switch selected on the Map pane.

• Command Line Interface—Open a Telnet or SSH session for the switch selected on the Map pane.

To use the Traceroute option to verify connectivity, follow these steps:

Step 1 Select two or more endpoints on the Fabric Manager map.

Step 2 Click Traceroute from the Troubleshooting menu, or right-click one of the endpoints and click 
Traceroute from the pop-up menu.

You see the window shown in Figure 2-9.
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Figure 2-9 Traceroute Window

Step 3 Change the timeout value if the default (30 seconds) is too short or too long.

Step 4 Click OK.

The results of the Traceroute operation appear in the Results box.

Setting Preferences
To set your preferences for the behavior of the Fabric Manager, choose File > Preferences from the 
Fabric Manager menu bar. You see the dialog box shown in Figure 2-10.

Figure 2-10 Fabric View Preferences
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This dialog box has the following four tabs, which let you set your preferences for different components 
of the application:

• General

• SNMP

• Discovery

• Map

Table 2-2 describes the configurable attributes on each tab.

Table 2-2 Fabric Manager Preferences—Configurable Attributes

Attributes Effect

General tab

Confirm Row Deletion The system prompts you and requires a 
confirmation before deleting any row in a table.

Show Switch DNS Name The DNS host names (if any) for switches are 
displayed in the map and in tables.

Show WorldWideName (WWN) Vendor

• replace

• prepend

Show the vendor portion of the world wide name, 
either instead of the node portion (replace) or 
preceding that portion (prepend)

Show Timestamps as Date/Time Show the time of events in Date/Time format.

Use Secure Shell(sshclient) instead of Telnet Use SSH when making a console (CLI) 
connection to a device. The field below this radio 
button allows you to identify the location of the 
SSH application that you want to use.

Snmp tab

Retry requests Specifies the number of times an SNMP request 
will be issued.

Enable status polling every Specifies the length of time (in seconds) between 
SNMP polling requests.

Trace SNMP packets in Log Capture SNMP queries/replies in the Fabric 
Manager log.

Register for Events after Open, listen on Port 
2162

Causes the system to listen for fabric events and 
display the changes automatically or prompt you 
to start a new discovery.

Discovery tab

Trace Topology Discovery in Log Enable the logging of discovery messages in the 
Fabric View log.

Use FCS Discovery Cache Cache FCS discovery information instead of 
rediscovering the information every time.

Use DNS Name if No Management IP Address Use any DNS name found during discovery if no 
management IP addess is configured for the 
device.

Max FCS Vsan Discovery Time Specifies the time (in seconds) to allow discovery 
of a single VSAN.
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Viewing Reports in Fabric Manager
The Fabric Manager provides a series of tables grouped under the Reports menu. To open the tables to 
view this information, click Reports on the Fabric Manager menu bar and select one of the following 
options:

• ISL Statistics, page 2-16

• ISLs, page 2-17

• Switches, page 2-17

• Hosts, page 2-18

• Storage, page 2-18

• LUNs, page 2-19

When you select one of these options, you see the available information in tabular form in the 
Information pane of the Fabric Manager main window. The following sections describe the tables 
provided by each option.

ISL Statistics

Choose Reports > ISL Statistics from the Fabric Manager menu bar to display information about the 
Inter-Switch Links in the currently discovered fabric. See Table 2-3.

Max Lun Discovery Time Specifies the time (in seconds) to allow discovery 
of a single LUN.

Map tab

Display End Devices Displays end devices in the Fabric Manager map.

Display Node Labels Display node labels in the Fabric Manager map.

Collapse Loops Collapse private or public loops in the Fabric 
Manager map.

Collapse Multiple Links Collapse multiple links between devices into a 
single line in the Fabric Manager map.

Table 2-2 Fabric Manager Preferences—Configurable Attributes (continued)

Attributes Effect

Table 2-3 Reports > ISL Statistics

Field Description

Between: Switch Displays the IP address or host name of the switch from which the 
link originates.

Between: Interface Displays the interface from which the link originates.

And: Switch Displays the IP address or host name of the switch to which the link 
is destined.

And: Interface Displays the interface to which the link is destined.

Speed Displays the maximum bandwidth (in Mbits per second) of the link.
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You can use the controls at the top of the table to change the following report parameters:

• Poll interval

• Scale

ISLs

Choose Reports > ISLs from the Fabric Manager menu bar to display information about the 
Inter-Switch links in the currently discovered fabric. See Table 2-4.

Switches

Choose Reports > Switches from the Fabric Manager menu tree to display information about the 
switches in the currently discovered fabric. See Table 2-5.

Bandwidth %: Between Displays the percentage of bandwidth utilized on the originating 
link. 

Bandwidth %: And Displays the percentage of bandwidth utilized on the destination 
link. 

Errors Displays the number of errors occurring on the link.

Discards Displays the number of frames discarded on the link.

Table 2-3 Reports > ISL Statistics (continued)

Field Description

Table 2-4 Reports > ISLs

Field Description

Between: Switch Displays the IP address or host name of the switch from which the 
link originates.

Between: Interface Displays the interface from which the link originates.

And: Switch Displays the IP address or host name of the switch to which the link 
is destined.

And: Interface Displays the interface to which the link is destined.

Mode Displays the mode of the ISL trunk.

Speed Displays the maximum bandwidth of the link.

Vsan: Port Displays the VSAN to be configured on the interface from which 
the ISL originates.

Vsan: Active Displays the active VSANs on the link in case trunking is enabled.

Vsan: Allowed(Between) Displays the allowed VSANs on the interface from where the ISL is 
generated in case trunking is enabled.

Vsan: Allowed(And) Displays the allowed VSANs on the interface to where the ISL is 
destined, in case truning is enabled.
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Hosts

Choose Reports > Hosts from the Fabric Manager menu tree to display information about the hosts in 
the currently discovered fabric. See Table 2-6.

Storage

Choose Reports > Storage from the Fabric Manager menu tree to display information about the links to 
hosts and storage in the currently discovered fabric. See Table 2-7.

Table 2-5 Reports > Switches

Field Description

Name Displays the host name of the switch.

IP Address Displays the IP address of the switch.

Vendor Displays the manufacturer of the switch, as derived from the 
hardware address of the device.

Model Displays the model of the switch (if discovered).

Release Displays the release of the switch software.

WWN Displays the world wide name (WWN) of the switch.

Table 2-6 Reports > Hosts

Field Description

Name Displays the name of the host.

IP Address Displays the IP address of the host.

Vsan Displays the VSAN to which the host belongs.

Port WWN Displays the Nx Port WWN for this host.

Attached To Displays the switch name and Fx port through which this host is 
connected to the fabric.

Table 2-7 Reports > Storage

Field Description

Name Displays the assigned name for the selected storage device.

IP Address Displays the IP address assigned to the selected storage device.

Vsan Displays the VSAN containing the selected storage device.

Port WWN Displays the Port WWN of the storage device interface.

FcId Displays the Fibre Channel ID of the storage device interface.

Attached To Displays the switch through which the selected device is attached.

Type Displays the type of the storage device. 

Vendor Displays the vendor name for the selected storage device.

ProductID Displays the product ID of the storage device.
2-18
Cisco MDS 9000 Family Fabric Manager User Guide

78-14895-02, Cisco MDS SAN-OS Release 1.0(3a)



Send  documenta t ion  comments  to  

Chapter 2      Using Cisco Fabric Manager and Device Manager
Using Device Manager
LUNs

Choose the Reports > LUNs option from the Fabric Manager menu tree to display information about 
the LUNs in the currently discovered fabric. See Table 2-8.

Using Device Manager
This section describes how to use the Device Manager to manage the configuration of specific devices. 
It includes the following sections:

• Overview of Device Manager, page 2-20

• Launching Device Manager from Fabric Manager, page 2-20

• Comparing Device Manager to Fabric Manager, page 2-21

• Managing Ports, page 2-24

RevLevel Displays the revision level of the software running on the storage 
device.

Details Displays other information that may be available about the storage 
device.

Total Capacity (M) Displays the total capacity in Mbytes for the selected storage 
device.

Number LUNs Displays the number of LUNs on the selected storage device.

Table 2-7 Reports > Storage (continued)

Field Description

Table 2-8 Reports > LUNs

Field Description

Port WWN Displays the Port WWN of the storage device interface where the 
LUN is exported.

Fcid Displays the Fibre Channel identifier of the storage device interface 
where the LUN is exported.

Attached To Displays the switch through which the LUN is connected.

Number Displays the numerical identifier of the LUN.

Capacity Displays the capacity (in Mbytes) of the LUN.

SerialNum Displays the serial number of the LUN device.
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Overview of Device Manager
Device Manager provides a physical representation of your switch chassis, with the modules, ports, 
power supplies, and fan assemblies (Figure 2-11). The menu bar at the top of the Device Manager 
window provides access to options, organized into menus that correspond to the menu tree in Fabric 
Manager (Figure 2-12). 

The legend at the bottom right of the Device Manager indicates port status, as follows:

• Green—The port is up.

• Brown—The port is administratively down.

• Red—The port is down or has failed.

• Gray—The port is unreachable. 

Launching Device Manager from Fabric Manager
Device Manager gives a graphic representation of a Cisco MDS 9000 Family switch, including the 
installed switching modules, the supervisor modules, the power supplies, and the status of each port 
within each module.

To launch the Device Manager from your desktop, double-click the Device Manager icon and follow the 
instructions described in the “Launching Views” section on page 1-11. 

To launch Device Manager from Fabric Manager , right-click the switch you want to manage on the 
Fabric Manager map and click Device Manager from the pop-up menu that appears. The Device 
Manager main window is shown in Figure 2-11.

Device Manager can also be started by double-clicking on a switch in the Fabric Manager topology view.
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Figure 2-11 Device Manager, Deview Tab

Comparing Device Manager to Fabric Manager
As shown in Figure 2-12, the menu bar at the top of the Device Manager contains the same menus as the 
Fabric Manager menu tree. 
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Figure 2-12 Device Manager Menu Bar Compared to the Fabric Manager Menu Tree

For information about the options provided by these menus, see the “VSAN/Switch Pane” section on 
page 2-4. The Device menu, which is unique to the Device View and Summary View, provides the 
following options:

• Open—Open the Device Manager for a different switch.

• Open Last—Open the Device Manager for the most recently managed switch.

• Preferences—Set management preferences for controlling the behavior and appearance of the 
Device Manager.

• Refresh—Update the current display.

• Message Log—Display messages regarding the current operation of the Device Manager 
application.

• Command Line Interface—Open a Telnet/SSH session with the current switch.

• Exit—Close the Device Manager application.

As shown in Figure 2-13, the tables in the Fabric Manager correspond to the dialog boxes that appear in 
Device Manager. However, the Fabric Manager tables show values for multiple switches and so the first 
column identifies the specific switch. The Device Manager dialog box shows values for a single switch, 
while the Fabric Manager shows the same values for one or more switches. 
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Figure 2-13 Device Manager Dialog Box Compared to Fabric Manager 

The toolbar on the Device Manager dialog box provides the same options as the toolbar on the 
Information pane in Fabric Manager , as summarized here:

• Create—Insert a new row into a table (if applicable).

• Delete Row—Delete the selected row from a table (if applicable).

• Copy…Ctrl+C — Copy data from one row to another.

• Paste…Ctrl +V—Paste the data from one row to another.

• Apply Changes—Apply configuration changes.

Note After making changes you must save the configuration the changes will be lost when the 
device is restarted.

• Refresh Values—Refresh table values.

• Reset Changes…Ctrl-Z—Undo the most recent change.

• Print table…— Print the contents of the Information pane.

Tip You can copy values from one cell in a table to the rest of the column. Copy the value to the clipboard, 
hold down the shift key while pressing the down arrow key (or click on the bottom cell in the column). 
Then paste the value to all the selected cells and click Apply. 

When you click the Create button, you see a dialog box that lets you enter the values required for the 
specific table. Figure 2-14 shows dialog boxes for creating a new VSAN. As you can see the fields and 
options are the same from both views, but the appearance of the window may vary slightly. For instance, 
the dialog box from Fabric Manager may have an option for selecting a specific switch, while the dialog 
box from Device Manager may have additional port-level detail.
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Figure 2-14 Create Dialog Boxes in Fabric Manager and Device Manager

Managing Ports

Tip You can select multiple ports in Device Manager and apply options to all the selected ports at one time. 
Either select the ports by dragging the mouse around them, or hold down the shift key and click on each 
port.

To enable or disable a port, right-click the port and click Enable or Disable from the pop-up menu. To 
enable or disable multiple ports, drag the mouse to select the ports and then right-click the selected ports. 
Then click Enable or Disable from the pop-up menu.

To manage trunking on one or more ports, right-click the ports and click Configure. On the dialog box 
that appears, in the Trunk column, right-click the current value and click nonTrunk, trunk, or auto from 
the pull-down list.

To create PortChannels using Device Manager, click PortChannels from the Interface menu. For 
detailed instructions, see the “Managing PortChannel Interfaces” section on page 7-12. You can also use 
Fabric Manager to conveniently create a PortChannel.

Note To create a PortChannel, all the ports on both ends of the link must have the same port speed, trunking 
type, and administrative state.

Setting Preferences
To set your preferences for the behavior of the Device Manager application, choose Preferences from 
the Device menu. You see the dialog box shown in 
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Figure 2-15 Device Manager Preferences

Table 2-9 describes the configurable attributes on this dialog box.

Table 2-9 Fabric Manager Preferences—Configurable Attributes

Attributes Effect

General tab

Retry requests Specifies the number of times an SNMP request 
will be issued.

Enable status polling every Specifies the length of time (in seconds) between 
SNMP polling requests.

Trace SNMP packets in Message Log Capture SNMP packets in the message log.

Register for Events after Open, listen on Port 
2162

Causes the system to listen for events and display 
changes in port status.

Confirm Row Deletion The system prompts you and requires a 
confirmation before deleting any row in a table.

Show WorldWideName (WWN) Vendor

• replace

• prepend

Show the vendor portion of the world wide name, 
either instead of the node portion (replace) or 
preceding that portion (prepend)

Show Timestamps as Date/Time Show the time of events in Date/Time format.

Use Secure Shell(sshclient) instead of Telnet Use SSH when making a console (CLI) 
connection to a device. The field below this radio 
button allows you to identify the location of the 
SSH application that you want to use.

Show Tooltips in Device View Show tooltips for different graphic elements in the 
Device Manager .
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Using Summary View
Click the Summary tab on the Device Manager main window to see a summary of xEPorts, FxPorts, and 
NxPorts on a single switch. Figure 2-16 shows the Summary View.

Figure 2-16 Summary View

The Summary View displays attributes for a single switch, such as port speed, link utilization, and other 
traffic statistics. It has the same menu bar and toolbar buttons as the Device View. 

To monitor traffic for selected objects, click the Monitor icon. To display detailed statistics for selected 
objects, click the Detailed Statistics icon.

The Summary View provides the same menus and options that are available from the Device View and 
shows the display-only information described in Table 2-10.

Table 2-10 Summary View Display-Only Attributes

Display-Only Attribute Description

CPU % Displays percentage of CPU utilization for the 
active supervisor module.

Disk % Displays percentage of disk utilization for the 
active supervisor module.

Memory % Displays percentage of memory utilization for the 
active supervisor module.

xEPorts (Inter-Switch Links)

Port Displays the port ID.
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Channel Displays the channel ID.

Speed Displays port speed.

ActiveVsans Displays active VSANs.

Nbr Switch WWN Displays the neighbor switch world wide name 
(WWN).

Rx Utilization% Displays the percentage of receive transmission 
utilization or bandwidth.

Tx Utilization% Displays the percentage of transmit utilization or 
bandwidth.

Errors Displays the errors for this link.

Discards Displays the frames (or packets) discarded for this 
link.

FxPorts (Switch Side)

Port Displays the port ID.

Speed Displays port speed.

VSAN Displays the VSAN to which this port is assigned.

Rx Utilization% Displays the percentage of receive transmission 
utilization or bandwidth.

Tx Utilization% Displays the percentage of transmit utilization or 
bandwidth.

Errors Displays the errors for this link.

Discards Displays the frames (or packets) discarded for this 
link.

NxPorts (Attached Hosts and Storage)

Port Displays the port ID.

Type Displays the device type; for example, disk, node, 
etc.

Node WWN Displays the WWN for this node.

Port WWN Displays the WWN for this port.

Fcid Displays the Fibre Channel ID for this port.

Table 2-10 Summary View Display-Only Attributes (continued)

Display-Only Attribute Description
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Table 2-11 describes the configurable attributes on the Summary View.

Table 2-11 Summary View—Configurable Attributes

Configurable Attribute Description

Poll Interval Sets polling intervals at:

• 10 or 30 seconds

• 1, 5, or 30 minutes

• 1 hour

Scale% Specifies when the Rx and Tx bars should change 
from green to orange (warning) to red (danger) in 
the inline bar chart feature.

For example, setting the orange scale to 50% 
indicates that the Rx and Tx bars should change 
from green to orange when Rx and Tx utilization 
exceeds 50%.
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