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Preface

Who Should Read This Guide
This Cisco® Smart Business Architecture (SBA) guide is for people who fill a 
variety of roles:

•	 Systems engineers who need standard procedures for implementing 
solutions

•	 Project managers who create statements of work for Cisco SBA 
implementations

•	 Sales partners who sell new technology or who create implementation 
documentation

•	 Trainers who need material for classroom instruction or on-the-job 
training

In general, you can also use Cisco SBA guides to improve consistency 
among engineers and deployments, as well as to improve scoping and 
costing of deployment jobs.

Release Series
Cisco strives to update and enhance SBA guides on a regular basis. As we 
develop a new series of SBA guides, we test them together, as a complete 
system. To ensure the mutual compatibility of designs in Cisco SBA guides, 
you should use guides that belong to the same series.

All Cisco SBA guides include the series name on the cover and at the 
bottom left of each page. We name the series for the month and year that we 
release them, as follows:

month year Series

For example, the series of guides that we released in August 2011 are  
the “August 2011 Series”.

You can find the most recent series of SBA guides at the following sites:

Customer access: http://www.cisco.com/go/sba

Partner access: http://www.cisco.com/go/sbachannel

How to Read Commands
Many Cisco SBA guides provide specific details about how to configure 
Cisco network devices that run Cisco IOS, Cisco NX-OS, or other operating 
systems that you configure at a command-line interface (CLI). This section 
describes the conventions used to specify commands that you must enter.

Commands to enter at a CLI appear as follows:

configure terminal

Commands that specify a value for a variable appear as follows:

ntp server 10.10.48.17

Commands with variables that you must define appear as follows:

class-map [highest class name]

Commands shown in an interactive example, such as a script or when the 
command prompt is included, appear as follows:

Router# enable

Long commands that line wrap are underlined. Enter them as one command:

wrr-queue random-detect max-threshold 1 100 100 100 100 100 
100 100 100

Noteworthy parts of system output or device configuration files appear 
highlighted, as follows:

interface Vlan64
  ip address 10.5.204.5 255.255.255.0

Comments and Questions
If you would like to comment on a guide or ask questions, please use the 
forum at the bottom of one of the following sites:

Customer access: http://www.cisco.com/go/sba

Partner access: http://www.cisco.com/go/sbachannel

An RSS feed is available if you would like to be notified when new comments 
are posted.

http://www.cisco.com/go/sba
http://www.cisco.com/go/sbachannel
http://www.cisco.com/go/sba
http://www.cisco.com/go/sbachannel
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What’s In This SBA Guide

About SBA
Cisco SBA helps you design and quickly deploy a full-service business 
network. A Cisco SBA deployment is prescriptive, out-of-the-box, scalable, 
and flexible. 

Cisco SBA incorporates LAN, WAN, wireless, security, data center, application 
optimization, and unified communication technologies—tested together as a 
complete system. This component-level approach simplifies system integration 
of multiple technologies, allowing you to select solutions that solve your  
organization’s problems—without worrying about the technical complexity. 

For more information, see the How to Get Started with Cisco SBA 
document: 

http://www.cisco.com/en/US/docs/solutions/Enterprise/Borderless_Networks/
Smart_Business_Architecture/SBA_Getting_Started.pdf

About This Guide
This additional deployment guide includes the following sections:

•	 Business Overview—The challenge that your organization faces. 
Business decision makers can use this section to understand the rel-
evance of the solution to their organizations’ operations.

•	 Technology Overview—How Cisco solves the challenge. Technical 
decision makers can use this section to understand how the solution 
works.

•	 Deployment Details—Step-by-step instructions for implementing the 
solution. Systems engineers can use this section to get the solution up 
and running quickly and reliably.

This guide presumes that you have read the prerequisites guides, as shown 
on the Route to Success below. 
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Route to Success
To ensure your success when implementing the designs in this guide, 
you should read any guides that this guide depends upon—shown to 
the left of this guide on the route above. Any guides that depend upon 
this guide are shown to the right of this guide.

For customer access to all SBA guides: http://www.cisco.com/go/sba 
For partner access: http://www.cisco.com/go/sbachannel

Collaboration
Foundation
Design Overview

Collaboration Foundation
Deployment Guide

Help Desk
Deployment Guide

You are HerePrerequisite Guides

http://www.cisco.com/en/US/docs/solutions/Enterprise/Borderless_Networks/Smart_Business_Architecture/SBA_Getting_Started.pdf
http://www.cisco.com/en/US/docs/solutions/Enterprise/Borderless_Networks/Smart_Business_Architecture/SBA_Getting_Started.pdf
http://www.cisco.com/go/sba
http://www.cisco.com/go/sbachannel
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Introduction

Business Overview
The ability to easily add functionality into the telephony environment for 
corporate help desks has been challenging. Corporations use help desks 
in their Human Resources departments to answer personnel questions, in 
IT departments to help employees with their computer problems, and in 
their facilities departments to maintain and manage their buildings. A help 
desk minimizes the time it takes to answer employees’ questions and helps 
maximize the available internal resources.

Traditional contact center solutions are difficult to implement because of the 
additional hardware components and the complexity of the software needed 
to implement them.  The work is normally done by highly trained engineers 
who spend the majority of their time working with contact centers.  The 
complexity makes the installation a long process and the additional exper-
tise makes the installation and maintenance quite expensive.  Agents are 
required to work at the location of the contact center equipment because 
the inherent limitations of the hardware prevent them from working remotely.  
It is very difficult to integrate the overall system with the corporate data 
because common interfaces are not readily available.

Technical Overview 
The next-generation IP help desk takes advantage of a company’s internal 
network by making use of the IP private branch exchange (PBX) and other 
IP-based applications to create a better experience for the callers. Calls 
are routed to available agents who have the expertise to answer the ques-
tions, regardless of their physical location in the company. Agents can view 
information about the caller through integration with corporate databases; 
and historical data is saved and viewed in easily readable reports that help 
improve the day-to-day workings of the help desk. These are just a few of 
the benefits offered by a fully integrated IP help desk.

 

Cisco® Unified Contact Center Express (Unified CCX) is the IP-based help 
desk solution offered by Cisco Systems. It is tightly integrated with other 
Cisco Unified Communications platforms. Design and testing is performed 
on the suite of Unified Communications products as part of a complete solu-
tion. Configuration of Unified CCX is easier than traditional systems because 
the components talk to each other over the internal IP network, which helps 
streamline the procedures. For example, when a phone number is created 
on Unified CCX to reach a help desk application, no additional configuration 
is needed in the Cisco Unified Communications Manager (Unified CM). 
The configuration is sent over the network to Unified CM and the directory 
number is created. Unified CM is automatically configured to pass calls for 
the directory number to Unified CCX for further processing.

When a call is placed to the help desk, it is first processed by Cisco Unified 
CM, which recognizes that the number is destined for the Cisco Unified 
CCX application server. Unified CCX receives the incoming call and identi-
fies which application script is needed to handle the request based on the 
extension number that was dialed. The script plays prompts and collects 
digits as dictated by the steps in the script and, if necessary, uses the infor-
mation from the caller to select an appropriate agent. If an appropriate agent 
is not available, the call is put in queue and music is streamed to the caller. 
As soon as an agent is available, Unified CCX instructs Unified CM to ring 
the agent’s phone. When the agent picks up, information about the caller is 
populated into the agent’s desktop application and the conversation begins.

Cisco Unified CCX has the features of a large contact center packaged into 
a single- or dual-server deployment. The system scales up to 300 concur-
rent agents, 32 supervisors, and 150 queues. It includes email, outbound 
calling, inbound calling, workforce optimization, and reporting. 

The following diagram shows a typical Cisco Unified CCX deployment in the 
Cisco Small Business Architecture (SBA) Midsize Foundation Architecture.
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Figure 1 - Typical Cisco Unified CCX deployment in the midsize foundation architecture
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Some of the features in Cisco Unified CCX are listed in more detail below.  

Automatic Call Distribution (ACD)—Unified CCX routes calls by using skills 
or resource groups. Skills-based routing distributes the call based on the 
skill level of the agent for a particular topic. It is the method most often used. 
Resource-group routing distributes calls to agents based on the resource 
group to which the agents are assigned. 

Interactive Voice Response (IVR)—IVR controls the interaction between 
the caller, prompts, and menus. Depending on the options the caller enters 
into the system, IVR uses an application script to determine how to handle 
the call. IVR can read or write corporate database information, play informa-
tion such as tracking numbers to callers, and collect information from the 
caller via digits or speech recognition. 

Agent Email—Agent Email allows customers to contact the help desk via 
email. Agents are assigned skills, and email is distributed to agents based 
on their skills. Email agents can use preset templates in their replies to avoid 
writing repetitive emails.

Agent Desktop—Cisco Agent Desktop is an application that resides on the 
agent’s computer. Agents use the application to log in at the beginning of 
their shifts, indicate whether they are in a ready state or on a break, and log 
out at the end of the day. When an agent is logged in and ready, calls are 
sent to Agent Desktop, which presents information about the incoming call. 
The application has an integrated browser to access a customer database 
or browse the Internet to help answer a question. Agent Desktop is a great 
tool for agents because everything they need to do their job is in one place, 
which allows them to focus on answering the caller’s question. 

Supervisor Desktop—Cisco Supervisor Desktop helps supervisors keep 
track of real-time statistics such as how many calls are in queue, the number 
of agents available, and the average time a caller is spending in queue. 
Supervisors can also use Supervisor Desktop to coach agents by silently 
monitoring calls, chatting with agents, barging into a call, and pushing a 
webpage down to an Agent Desktop. Supervisor Desktop helps supervisors 
ensure that calls are being handled on a timely basis and agents are not 
giving callers incorrect information. If there is an issue, Supervisor Desktop 
allows them to quickly address the problem before it gets too far out of 
hand.

Reporting—Cisco Unified CCX saves statistics in an internal database 
that can be accessed by the historical reporting client application to create 
reports. Reports can be scheduled on a reoccurring basis or created as 
needed. Reports can be general, such as information about the entire help 
desk over a year, or specific, such as information about a particular agent for 
one day. Historical reports allow managers to get a big picture of their help 
desk and to make changes to address issues.

Workforce Management—Workforce Management is a tool that uses a 
sophisticated algorithm to look through historical data and create a schedule 
that will have the right number of agents on staff at the right times during the 
day. This tool helps ensure that more agents are on staff at busy times and 
agents have scheduled breaks during slow times.

Quality Manager—Quality Manager is a tool that records calls. Quality 
Manager randomly selects calls throughout the day to be recorded, or 
you can select specific calls to record. This tool also creates standardized 
score sheets to help determine how well the agent handled the call. Quality 
Manager is a great coaching tool designed to make the help-desk experi-
ence more satisfying for the caller.

Cisco Unified CCX is a powerful application. Through its strong scripting 
engine, easy-to-use desktops, extensive reporting tools, and sophisticated 
workforce optimization, it can successfully operate even the most compli-
cated corporate help desks. The next several sections of this document will 
guide you through the process of installing and configuring Cisco Unified 
CCX in a Unified CM environment.
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Deployment Details

Cisco Unified CCX runs on the same Linux operating systems as several 
other Unified Communications platforms from Cisco. You install the operat-
ing system with the application by using the standard installation DVD. This 
document leverages the largest server configuration, which supports up 
to 300 agents, 32 supervisors, 120 email agents, and 150 contact service 
queues. Other servers support smaller numbers; you can find details for 
each type in the Unified CCX data sheet.

For a quick and easy installation experience, it is essential to know up-front 
what information you will need. For Unified CCX, make sure you have com-
pleted the following steps before you start:

•	 If you are installing Unified CCX on a new virtual machine (VM), down-
load the Open Virtualization Archive (OVA) file from the Cisco website at: 
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&s
oftwareid=283733053

•	 Check the Cisco website to determine if there is a patch for your version 
of Unified CCX: http://www.cisco.com/cisco/software/release.html?mdfi
d=270569179&flowid=5217&softwareid=280840578

Make sure you have the following information available:

•	 Time zone for the server

•	 Host name, IP address, network mask, and default gateway

•	 Domain Name System (DNS) server IP addresses

•	 Administrator ID and password

•	 Organization and unit

•	 Location, state, and country 

•	 Network Time Protocol (NTP) server IP addresses

•	 Security password

•	 Application username and password

Preparing Server Hardware

1.	 Prepare a virtual machine

2.	 Prepare a standalone server

Process

You can deploy Cisco Unified CCX on a virtual machine or on a standalone 
server depending on your preferred option.  The steps for each type of 
installation are listed below.  

Procedure 1	 Prepare a virtual machine

When you install Cisco Unified CCX on VMware, follow the steps below to 
deploy an OVA file to define the virtual machine requirements. You use the 
Open Virtualization Format (OVF) support of VMware to import and deploy 
the OVA file.  

The Cisco Unified CCX OVA file defines the following virtual machine:

•	 Number of virtual CPUs—2 (minimum of Nehalem-class CPU)

•	 Amount of RAM—4 GB

•	 Hard disks—2 x 146 GB (contains aligned partitions for the Unified CCX 
application)

•	 ESXi support—ESXi 4.0 (VM version 7)

•	 OS support—Red Hat Enterprise Linux 4 (32-bit)

Step 1:  In the VMware vSphere client, choose File > Deploy OVF Template. 
The client imports the OVA file.

http://www.cisco.com/cisco/software/release.html?mdfid=270569179&softwareid=283733053
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&softwareid=283733053
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&flowid=5217&softwareid=280840578
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&flowid=5217&softwareid=280840578
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Step 2:  Click the Browse button next to the Deploy from a file or URL box, 
find the location of the OVA file that you downloaded from Cisco, and then 
click Next.

Step 3:  Enter the virtual machine name, and then choose the physical 
server and the data store.

Step 4:  On the next several screens, select the site-specific settings that 
will work for your environment.
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Step 5:  Verify the settings, and then click Finish.

Step 6:  After the virtual machine is created, on the Getting Started tab, 
choose Edit virtual machine settings.

Step 7:  On the Hardware tab, select CD/DVD Drive 1.

Step 8:  Select the Datastore ISO File radio button, click Browse, and then 
navigate to the location of the Cisco Unified CCX bootable installation file.

Step 9:  On the Options tab, choose Boot Options. 
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Step 10:  Select the The next time the virtual machine boots, force entry 
into the BIOS setup screen check box, and then click OK .

Step 11:  On the Getting Started tab, choose Power on the virtual 
machine, and then click the Console tab to watch the server boot

Step 12:  After the machine boots into the PhoenixBIOS Setup Utility, use 
the right arrow key to move to the Boot tab.

Step 13:  Edit the boot order with the + and - keys to make CD-ROM Drive 
the first item and Hard Drive the second.

Step 14:  To save the BIOS settings, press the F10 key.

Step 15:  To complete the installation, follow the procedures in “Installing 
and Setting Up Cisco Unified CCX,”
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Procedure 2	 Prepare a standalone server

When installing Cisco Unified CCX on a standalone server, use the system 
requirements listed below.

•	 RAM—4 GB

•	 Hard disks—2 x 146 GB 

•	 OS support—Red Hat Enterprise Linux 4 (32-bit)

Step 1:  Insert the bootable DVD into the drive, and then reboot the server.

Step 2:  After the DVD loads, follow the procedures in “Installing and Setting 
Up Cisco Unified CCX” to complete the installation.

Installing and Setting Up Cisco Unified CCX Software

1.	 Install the software

2.	 Set up application administration

Process

Procedure 1	 Install the software

The following steps will be the same whether you are installing in a virtual 
environment or on a standalone server.

Step 1:  On the DVD Found screen, choose to perform a media check by 
choosing Yes.

Step 2:  If the media check is successfully completed, choose OK in order 
to continue with the installation process. If the media check does not pass, 
contact Cisco Technical Assistance Center or your local representative to 
replace the media.  

Step 3:  On the Product Deployment Selection page, choose OK .

Step 4:  On the Proceed with Install page, verify that the version is correct, 
and then choose Yes.

Step 5:  On the Platform Installation Wizard page, choose Proceed.

Step 6:  On the Apply Patch page, do one of the following: 

If no upgrade patch exists for the version you are installing, choose No. 

If there an upgrade patch does exist, choose Yes, and then follow the 
instructions on the screens to complete the process.
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Step 7:  On the Pre-existing Configuration Information page, choose 
Continue.

Step 8:  On the Platform Installation Wizard page, choose Proceed.

Step 9:  On the Basic Install page, choose Continue.

Step 10:  On the Timezone Configuration page, choose the correct time 
zone for the server location, and then choose OK .

Step 11:  On the Auto Negotiation Configuration page, choose Yes.

Step 12:  On the MTU Configuration page, choose No. This keeps the 
default maximum transmission unit (MTU) size.

Step 13:  On the Static Network Configuration page, enter the following 
information, and then choose OK .

•	 Host Name—CCX1

•	 IP Address—10.10.48.25

•	 IP Mask—255.255.255.0

•	 GW Address—10.10.48.1

Step 14:  On the first DNS Client Configuration page, click Yes.
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Step 15:  On the second DNS Client Configuration page, enter the following 
information, and then choose OK.

•	 Primary DNS—10.10.48.10

•	 Domain—cisco.local

Step 16:  On the Administrator Login Configuration page, enter the following 
information, and then choose OK .  

•	 Administrator ID—admin

•	 Password—[password]

•	 Confirm Password—[password] 

Step 17:  On the Certificate Information page, enter the information that will 
be used to generate security certificates, and then choose OK .   
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These fields must match the information submitted to Cisco, or 
the licenses will not be valid.

Tech Tip

Step 18:  On the First Node Configuration page, choose Yes.

Step 19:  On the Network Time Protocol Client Configuration page, enter the 
following information, and then choose OK .

•	 NTP server 1—10.10.48.17

Step 20:  On the Security Configuration page, enter the password for 
server-to-server communication, and then choose OK . 
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These passwords must match the information submitted to Cisco, 
or the licenses will not be valid.

Tech Tip

Step 21:  If you plan to use Simple Mail Transfer Protocol (SMTP) in your 
environment, on the SMTP Host Configuration page, choose Yes. If you do 
not plan to use SMTP, choose No .

Step 22:  On the Application User Configuration page, enter the following 
information, and then choose OK . These values are used to initially access 
the Cisco Unified CCX Administration page and must match the license 
information submitted to Cisco. 

•	 Application User Username—ccxadmin

•	 Password—[password]

•	 Confirm Password—[password]

When specific users are given administrative rights during the 
application setup procedure, the initial username and password 
will no longer work. 

Tech Tip

Step 23:  On the Platform Configuration Confirmation page, choose OK .

Step 24:  On the Unified CCX Deployment Type Selection page, choose 
Cisco Unified Communications Manager, and then choose OK .

The system will go through the rest of the installation process without user 
input. The system will reboot a few times during installation. The process will 
take 30 minutes or more,, depending on your hardware. 

Eventually, the server will open the command-line interface (CLI). For access 
to the CLI, use the administrator credentials entered on the Administrator 
Login Configuration screen. This interface will not be used for the remaining 
procedures in this document,, but it is available when needed.
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Procedure 2	 Set up application administration

After the software is installed, use the web interface to complete the rest of 
the procedures. 

Step 1:  Using your PC, access the Cisco Unified CCX Administration 
interface at: http://ccx1.[yourdomain].com/

Step 2:  In the center of the page, click the Cisco Unified Contact Center 
Express link. 

If you receive a warning about the website’s security certificate, 
ignore it and continue to the page.

Tech Tip

Step 3:  Enter the name and password you entered on the Application User 
Configuration page in Step 22 of Procedure 1, “Install the software”, and then 
click Login. 

Step 4:  Choose Fresh Install, and then click Next.

Step 5:  On the Service Provider Configuration page, enter the IP address 
and the administrator username and password of the Cisco Unified CM 
Publisher.

•	 Unified CM server IP address—10.10.48.20

•	 AXL Admin UserName—CUCMAdmin 

•	 Password—[password]: (must match the password on Cisco Unified 
CM)

Step 6:  Enter the location of the Unified CCX license file received from 
Cisco, and then click Next.

Step 7:  After all of the components become activated, click Next. 
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Step 8:  After all of the data stores become activated, click Next.

Step 9:  On the Cisco Unified CM Configuration page in the Unified CM 
Telephony Subsystem - Unified CM Telephony Provider Configuration 
section, under Available CTI Managers, select the Unified CM servers 
(10.10.48.20 and 10.10.48.21), and then click the left-facing arrow to move 
them under Selected CTI Managers.  

Step 10:  In the Cluster Wide Parameters section, enter the following 
information: 

•	 User Profile—ccx_jtapi

•	 Password—[password]

•	 Confirm Password—[password] 

Unified CCX will send this information to the Unified CM server, and the 
application user will be created automatically.

Step 11:  In the RmCm Subsystem - RMCm Provider Configuration section, 
under Available CTI Managers, select the Unified CM servers (10.10.48.20 
and 10.10.48.21), and then click the left-facing arrow to move them under 
Selected CTI Managers.  

Step 12:  In the Cluster Wide Parameters section, enter the following 
information, and then click Next.  

•	 User Profile—ccx_rmjtapi

•	 Password—[password]

•	 Confirm Password—[password]

Unified CCX will send this information to the Unified CM server, and the 
application user will be created automatically.
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Step 13:  On the System Parameters Configuration page, enter the following 
information, and then click Next:

•	 Number of HR sessions—2

•	 Recording Count—10

•	 Codec—G.711

For historical reporting of the number of HR sessions, use the 
maximum number of supervisors or administrators who will be 
running Unified CCX reports at the same time. For the Recording 
Count, enter the maximum number of concurrent ad-hoc record-
ing sessions. 

Tech Tip

Step 14:  On the Language Configuration page, enter the language that will 
be used for default IVR prompts as well as for the Cisco Agent Desktop and 
the Cisco Supervisor Desktop, and then click Next.

Step 15:  On the Desktop Client Configuration Tool message, click OK .
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Step 16:  On the User Configuration page, configure the users who will need 
administrative rights on Unified CCX, and then click Finish.

Make sure you give your own account administrator rights. After 
you give one of the Unified CM users administrator rights, the 
admin user account created during installation will not work. 

Tech Tip

The initial application administration setup is now complete.
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Configuring Helpdesk

1.	 Create the call control group

2.	 Create skills

3.	 Assign skills to contact service queues

4.	 Create resources

5.	 Configure the user’s phone or extension

6.	 Assign skills to resources

7.	 Create the supervisors and teams

8.	 Create scripts and applications

9.	 Add a trigger

10.	Create and upload the prompts

Process

After you configure the application, your next task is to configure the help 
desk to allow the system to begin taking calls from end users.

Procedure 1	 Create the call control group

A call control group creates a group of computer telephony integration (CTI) 
ports on Cisco Unified CM that are used to send calls to Unified CCX for 
IVR treatment and queuing. The call stays on the CTI port until it is sent to an 
agent.  

Step 1:  Navigate to Subsystems > Cisco Unified CM Telephony > Call 
Control Group.

Step 2:  On the Cisco Unified UM Telephony Call Control Group search 
page, click Add New.  

Step 3:  Enter the following information, and then click Add at the bottom of 
the page:

•	 Description—Unified CM Telephony Group

•	 Number of CTI ports—4 (This is the maximum number of allowed calls, 
plus the maximum number of calls in the queue at one time.)

•	 Media Termination Support—No

•	 Group Type—Inbound

•	 Device Name Prefix—CTIP (This will be the first part of the CTI port 
device names in Unified CM.)

•	 Starting Directory Number—2010 (This will be the directory number 
of the first CTI port in this group. The rest of the ports will be assigned 
sequential, increasing directory numbers.)

•	 Device Pool—Default

•	 DN Calling Search Space—CSS_Base

•	 Location—Hub_None

•	 Partition—PAR_Base  

Leave the rest of the fields at their default settings.
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Procedure 2	 Create skills

Step 1:  Navigate to Subsystems > RmCm > Skills.  

Step 2:  On the Skills search page, click Add New.

Step 3:  On the Skill Configuration page, enter IT, and then click Save.

Step 4:  On the Skills search page, click Add New.

Step 5:  On the Skill Configuration page, enter HR, and then click Save.

Step 6:  To create additional skills, repeat Step 2 and Step 3.  

Procedure 3	 Assign skills to contact service queues

Step 1:  Navigate to Subsystems > RmCm > Contact Service Queues. 

Step 2:  On the Contact Service Queues search page, click Add New, and 
create two contact service queues (CSQs), one for the: IT skill and one for 
the HR skill.

Step 3:  On the first Contact Service Queue Configuration page, enter the 
following information, and then click Next:

•	 Contact Service Queue Name—HR

•	 Contact Service Queue Type—Voice

•	 Automatic Work—Disabled

•	 Wrap-up Time—Disabled

•	 Resource Pool Selection Model—Resource Skills

•	 Service Level—5 (seconds)

•	 Service Level Percentage—70 

•	 Prompt—No Selection
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Step 4:  On the second configuration page, enter the following, and then 
click Add at the bottom of the page:

•	 Resource Selection Criteria—Longest Available

•	 Select Required Skills—HR (and then next to the window, click Add)

•	 Minimum Competence—5  

Procedure 4	 Create resources

Perform the next two procedures on your Cisco Unified CM platform. 

Step 1:  From your browser, access the Unified CM Administration interface 
at: http://cucm1.[yourdomain].com/

Step 2:  In the center of the page, click the Cisco Unified CM 
Administration link. 

If you receive a warning about the website’s security certificate, 
ignore it and continue to the page.

Tech Tip

Step 3:  Enter the administrator username and password for Unified CM, 
and then click Login.

Step 4:  Navigate to Device > Phone, and on the Find and List Phones 
search page, click Find. If the agent phone is found, double-click it to 
proceed to the next page. If the phone does not yet exist, click Add New, 
and then create the phone.
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Step 5:  On the Phone Configuration page, click line [1] to add Unified CCX 
information for the specific line on the phone.  

If this is a new phone, fill out the other fields on the Directory Number 
Configuration page that are important to your environment.

Step 6:  Scroll down to the bottom of the page, and click Associate End 
Users. On the Find and List Users screen, click Find, and then choose the 
appropriate user for this line by selecting the check box next to their name

Step 7:  Click Add Selected and you will return to the previous page. 

Step 8:  Scroll down to the bottom of the Directory Number Configuration 
screen, select the check box to the left of the user’s name, and then click 
Save.

Procedure 5	 Configure the user’s phone or extension

Step 1:  Navigate to User Management > End User, and on the Find and List 
Users search screen, click Find. Select the user who you want to make an 
agent, and then click the user ID. 

Step 2:  On the End User Configuration page for that user, scroll down to the 
Device Information section, and then click Device Association.

Step 3:  From the User Device Association search page, click Find. 

Step 4:  Search for the agent device. The easiest way to search is by direc-
tory number. Select the check box next to the agent’s phone, and then click 
Save Selected/Changes. 

Step 5:  In the upper-right corner of this page in the Related Links drop 
down list, select Back to User, and then click Go.
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Step 6:  On the End User Configuration page, scroll down to the Extension 
Mobility section. Ensure that the Allow Control of Device from CTI check 
box is selected.  

Step 7:  Scroll down to the Directory Number Associations section, set the 
IPCC Extension to the agent directory number that you created in the previ-
ous procedure, and then click Save.

Procedure 6	 Assign skills to resources

Each Cisco Unified CM user added to Unified CCX shows up auto-
matically as a resource. Using the resource list on the Cisco Unified CCX 
Administration page, you can assign skills to resources, making resources 
available to answer calls in particular CSQs.  

Step 1:  Using your browser, access the Unified CCX Administration inter-
face at: http://ccx1.[yourdomain].com/

Step 2:  In the center of the page, click the Cisco Unified Contact Center 
Express link. 

Step 3:  Enter the name and password of one of the users who was assigned 
administrative rights to Unified CCX, and then click Login. 

Step 4:  From the Unified CCX Administration main page, navigate to 
Subsystems > RmCm > Resources. On the Resources search page, select 
the resource to which you want to add a skill, and then click the resource 
name.

Step 5:  On the Resource Configuration page, in the Unassigned Skills field, 
select the skill that you want to assign, and then choose the competency 
level. 

Step 6:  Click the left arrow to move the skill to the Assigned Skills field.

Step 7:  Choose a resource group, and then click Update. The skill is 
assigned to the resource.



23Deployment DetailsFebruary 2012 Series

Procedure 7	 Create the supervisors and teams

The first step in building a team is to create a supervisor. A supervisor has 
a full view of a team’s performance and can monitor the agents by using the 
Cisco Supervisor Desktop. 

Step 1:  Navigate to Tools > User Management > Supervisor Capability 
View.

Step 2:  On the Available Users field on the User Configuration page, select 
the user you want to designate as a supervisor, click the left arrow, and then 
click Update.  

Step 3:  Navigate to Subsystems > RmCm > Teams. On the Team search 
page, click Add New.

Step 4:  On the Team Configuration page, enter a team name.

Step 5:  In the Primary Supervisor list, choose the person who is going to be 
the supervisor of this team. The list only contains the names of supervisors 
you previously created. 

Step 6:  Assign resources to this team by selecting their names from the 
Available Resources field and clicking the left arrow. 

Step 7:  Assign queues to the team by selecting their names from the 
Available CSQs field and clicking the left arrow, and then click Save.
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Procedure 8	 Create scripts and applications

Step 1:  Navigate to Applications > Script Management. On the Script 
Management search page, click Upload New Scripts.

Step 2:  Enter the location of the script to be used, and then click Upload. 

Step 3:  After the file is uploaded, click Return to Script Management.

Step 4:  Navigate to Applications > Application Management. On the 
Application Management search page, click Add New.

Step 5:  On the Add A New Application page, select an application type of 
Cisco Script Application, and then click Next.

Step 6:  Enter a name of your choosing.
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Do not modify the ID field. Its value is generated automatically. 

Tech Tip

Step 7:  In the Maximum Number of Sessions field, enter the maximum 
number of calls that should be able to access this application concurrently.

Step 8:  In the Script list, choose the uploaded script for this application. 
Parameter variables may appear, depending on the script you select, but 
you can ignore them for now.

Step 9:  Under Enabled, select the Yes radio button, and then click Add.

Procedure 9	 Add a trigger

Step 1:  In the upper-left corner of the page, click Add New Trigger.

Step 2:  In the Trigger Type drop-down list, choose Unified CM Telephony 
Trigger, and then click Next.

Step 3:  On the Cisco Unified CM Telephony Trigger Configuration page, 
enter the following information:

•	 Directory Number—5000 (This is the extension for the CTI Route Point 
that will be automatically created in Unified CM to call this application.)

•	 Language—English (United States)

•	 Device Name—InternalIT

•	 Description—Trigger to Internal SBA IT Helpdesk

•	 Call Control Group—Choose the group of CTI ports you created in 
Procedure 1
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Step 4:  Click Show More,  enter the following information, and then click 
Add:

•	 Device Pool—Default

•	 Location—Hub_None

•	 Partition—PAR_Base

•	 Calling Search Space—CSS_Base

Leave the other fields at their defaults

Step 5:  From a new browser window, access the Cisco Unified CM 
Administration interface at: http://cucm1.[yourdomain].com/

Step 6:  In the center of the page, click the Cisco Unified CM 
Administration link. 

Step 7:  Enter the administrator username and password for Unified CM and 
then click Login.

Step 8:  Navigate to User Management > Application User.  

Step 9:  On the Application User search page click Find, and then select the 
ccx_rmjtapi application user.

Step 10:  On the Application User Configuration page, scroll down to the 
Device Information section. In the Available Devices field, select the agent 
phone, the CTI ports, and the CTI route point, click the down arrow, and then 
click Save. They will be added to the list of controlled devices. 

For more information about configuring Unified CM, see the 
Solution Reference Network Design (SRND) at this location:  
http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod-
ucts_implementation_design_guides_list.html

Reader Tip

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_implementation_design_guides_list.html
http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_implementation_design_guides_list.html
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Procedure 10	 Create and upload the prompts

Prompts are played to the customers when they call. You must record 
prompts as .wav files and save them in a location reachable by the PC 
accessing the Cisco Unified CCX Administration page. 

Step 1:  Return to the Cisco Unified CCX Administration main page.

Step 2:  Navigate to Applications > Prompt Management, and then click 
the en_US folder.

Step 3:  After the folder opens, click Upload Prompts.

Step 4:  Browse to the prompt, select it, and then click Upload. The file 
is transferred to the server, and the new prompt appears in the specified 
folder in the list of prompts.

Step 5:  For each of the prompts you need, repeat Step 3 and Step 4.

Step 6:  Navigate to Applications > Application Management , and click the 
application that you created in Procedure 8.  

Step 7:  Click Show Prompts, and for each prompt variable in the applica-
tion script, choose the appropriate prompt. Click Update. 
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Setting Up the Client Software

1.	 Download the client

2.	 Configure reason codes

3.	 Set up caution and warning levels

Process

In this process, you download Cisco Agent Desktop, Cisco Supervisor 
Desktop, and Cisco Desktop Administrator clients from the server to a user’s 
PC. You can download these applications to any PC that has network access 
to the server through the Cisco Unified CCX Administration page.

Procedure 1	 Download the client

Step 1:  Navigate to Tools > Plug-ins, and then click Cisco Unified CCX 
Desktop Suites.

Because this is the first time you’re downloading the desktop 
applications, you must run the Cisco Unified CCX Client 
Configuration Tool. You only have to do this once per installation 
or upgrade. 

Tech Tip

Step 2:  Click Cisco Unified CCX Client Configuration Tool. 

Step 3:  On the CAD Client Configuration page, enter 10.10.48.25 (the IP 
address of the Unified CCX server), and then click Next.

The Client Configuration wizard then configures the desktop applica-
tions into a format that can be downloaded by users of the system. After 
the wizard is finished, it returns to the download page of Unified CCX 
Administration.  
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Step 4:  Under Cisco Unified CCX Desktop Product Suite, click Cisco 
Unified CCX Workflow Administrator, and then follow the installation 
prompts.

Step 5:  After installing Workflow Administrator, click the link for the type 
of desktop that is appropriate for this end user’s role, and then follow the 
installation prompts.  

Install either the supervisor or agent desktop on a particular PC, 
but not both. The Supervisor Desktop installation includes both 
the agent and supervisor applications. The Agent Desktop instal-
lation includes only the agent application. 

Tech Tip

After downloading the software, the user will be able to use the desktop 
applications.

Procedure 2	 Configure reason codes

Reason codes are used to identify the different tasks an agent may be doing 
before and after taking a call.

Step 1:  Navigate to Start > Programs > Cisco > Desktop > Admin, and 
then click Cisco Desktop Workflow Administrator.

The default path to the application on your hard drive is as follows: 
C:\Program Files\Cisco\Desktop\bin\SplkView.exe

Tech Tip

Step 2:  Navigate to Call Center 1 > Work Flow Configuration > Reason 
Codes.  A screen appears in the right panel of the application window.
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Step 3:  Click Edit Master List.

Step 4:  On the Master Reason Code Editor page, enter the following 
information, and then click Add:

•	 Code—0 to 999 (Each reason must have a unique number.)

•	 Description—Describe the reason code.

Step 5:  To add more reasons, repeat Step 4, and then click Done. 

Step 6:  After you have created the master reason list, on the Logout tab, 
select the appropriate reasons for logging out, and then click the right arrow 
to make them available. 
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Step 7:  On the Not Ready tab, select the appropriate reasons that an agent 
might not be ready, and then click the left arrow to make them available. 
Click Apply.

Procedure 3	 Set up caution and warning levels 

Caution and warning levels are thresholds set up by the administrator to let 
call center agents know when the call is going on longer than what is ideal 
for the given call center. You set the thresholds by using Cisco Desktop 
Workflow Administrator. 

Step 1:  Navigate to Call Center 1 > Work Flow Configuration > Work Flow 
Groups > Enterprise Data. 

Step 2:  On the Call Activity tab, specify the time thresholds for the CSQ 
(time the caller was in queue) and agent (time the caller has been speaking 
to the agent), and then click Apply.

The baseline helpdesk configuration is now complete.
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Appendix A: Product List

The following products and software versions have been validated for the Cisco Smart Business Architecture.

Functional Area Product Part Numbers Software Version

Unified Contact Center Express Servers Cisco Unified Contact Center Express—MCS 7835  

UCS Virtual Server

MCS-7835-I3-CCX1

UCS-C200M2-VCD2

8.5.1

ESXi 4.1

Unified Communications Manager Servers Cisco Unified Communications Manager—MCS 7835  

Cisco Unified Communications Manager Business Edition 
6000 - UCS C200M2 

UCS Virtual Server

MCS7835I3-K9-CMD1  
(2 required) 

UCS-C200M2-BE6K 

UCS-C200M2-VCD2

8.6.2 

8.6.2 

ESXi 4.1
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