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Troubleshooting the Installation

This appendix provides troubleshooting information for Essentials installation and setup, 
and contains the following sections:

• If the Installer Window Does Not Appear

• Logging In after Upgrading

• Understanding Installation Error Messages

• Failure to Delete a Package During Uninstallation

• Accessing the CiscoWorks2000 Server

• Viewing Process Status

• Browser Problems

• Improving Server Performance

If the Installer Window Does Not Appear
If the Installer window does not appear after you insert the CD-ROM, you can run the 
installation program from the Run dialog box:

Step 1 Select Start > Run. The Run dialog box appears.

Step 2 In the Open field, enter:

drive:\setup.exe

where drive is the CD-ROM drive letter.
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Logging In after Upgrading
If the Login Manager dialog box on the CiscoWorks2000 desktop does not appear correctly 
when you try to log in for the first time after upgrading, clear your browser cache as 
follows, then reenter the server URL in your browser.

For Microsoft Internet Explorer:

Step 1 Select View > Internet Options. The Internet Options dialog box appears.

Step 2 Select the General tab.

Step 3 Click Delete Files.

For Netscape Navigator:

Step 1 Select Edit > Preferences. The Preferences dialog box appears.

Step 2 Select Advanced > Cache.

Step 3 Click Clear Memory Cache, then click OK in the Memory Cache dialog box.

Step 4 Click Clear Disk Cache, then click OK in the Disk Cache dialog box.

Understanding Installation Error Messages
The following types of error messages might appear during the installation:

• Information messages, which give you important details

• Warning messages, which tell you that something might be wrong with a particular 
process, but the process will complete

• Error messages, which tell you that a particular process could not complete

All of the messages that appear during installation are logged in the 
/var/tmp/ciscoinstall.log file.

Table A-1 shows error messages that might occur during installation and describes the 
reasons for the errors.
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Table A-1 Installation Error Messages

Message Reason for Message User Action

CiscoWorks 2000 installation cannot 
proceed because you are not logged in 
as an administrator.

You are not logged in to Windows NT 
with administrator privileges.

Log in with local administrator 
privileges and try installing again.

Decompression failed on <file>. The 
error was for <error code per 
CompressGet>

If Essentials was downloaded, a 
transmission error occurred, or the 
installation media is damaged.

Retry the download. If you still 
have errors, contact your technical 
support representative.

General file transmission error. Please 
check your target location and try 
again. Error number: <error code>

If Essentials was downloaded, a 
transmission error might have 
occurred. 

Retry the download. If you still 
have errors, contact your technical 
support representative.

Unable to write <infoFile> or Unable 
to create <infoFile>

A file-write operation failed. Run the file system checking 
utility, then repeat the installation.

Cannot stop service <servicename> The installation (or uninstallation) 
tried to stop the service 
<servicename> unsuccessfully.

Select Control Panel > Services 
and try to stop service 
<servicename> manually, then 
proceed with installing or 
uninstalling.

UseDLL failed for <dll> <dll> is supposed to be available at 
any time for any process, but NT 
failed to load it.

Check permissions on 
Windows NT System 32. If the 
<dll> is secure.dll or r_inst.dl, 
check the product installation 
medium for errors.

or

Reinstall Windows NT.

<function> failed: DLL function not 
found

<dll> is supposed to be available at 
any time for any process, but NT 
failed to load it.

Check permissions on 
Windows NT System 32. If <dll> 
is secure.dll or r_inst.dll, check 
product installation medium for 
errors.

or

Reinstall Windows NT.

OpenFile failed: <pathname> A file open operation failed. Run the file system checking 
utility, then repeat the installation.
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ProtectFile failed: <file>: error. 
WWW admin security may be 
incomplete

Setting file permissions failed because 
the user might not be allowed to 
change them.

Log in as administrator.

Note If you are installing on a 
FAT file system, Essentials cannot 
provide file security.

Launch of isql script failed Existing database file is broken, or the 
previous version of Essentials is 
destroyed. (This message might be 
issued during reinstallation.) 

Contact your support 
representative.

The installer requires temporary 
workspace. You have less than 8 MB 
of free space on <drive on which 
temporary directory is located>: 
Please free up some space and 
try again.

Insufficient drive space for temporary 
installation files.

Make more drive space available, 
then rerun installation.

The installer has verified the following 
on your system: Insufficient disk space 
(footprint & runtime).

Insufficient disk space available to 
install the product.

Create additional free space on the 
drive or install both CD One and 
Essentials on a different drive.

The installer has verified the following 
on your system: Insufficient memory 
(RAM).

Insufficient RAM to meet Essentials 
requirements.

Finish the installation, then 
reconfigure the system.

The installer has verified the 
following: Insufficient swap space (or 
paging file).

Insufficient swap space to meet 
Essentials recommendations.

Finish the installation, then 
increase paging file size.

The installer has verified the 
following: Insufficient CPU.

Insufficient CPU to meet Essentials 
recommendations.

Install both CD One and Essentials 
on a different system.

You have enough space to install 
Essentials. However, if you want to 
install other applications after 
installing Essentials, please check the 
system requirements for those 
products.

Possibly insufficient disk space 
available to install the other products.

If you plan to install other products 
that depend on Essentials, you 
might need to create additional 
free space on the drive or install 
CD One, Essentials, and other 
products on a different drive.

Table A-1 Installation Error Messages (continued)

Message Reason for Message User Action
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The installer has determined that the 
destination drive has an <NTFS or 
FAT> file system. You have <size and 
units> of space. The product requires 
<size and units> on this drive.

Insufficient disk space available to 
install the product.

Create additional free space on the 
drive or install both CD One and 
Essentials on a different drive.

Failed to set file permissions. Installation program is unable to set 
file permissions. The most likely 
causes are:

• Account you used to log in to the 
system has insufficient permissions.

• Drive on which you are installing 
the product has a FAT file system.

Fix problem, then rerun 
installation program.

<...> is already running! Wait for it to 
finish and press the OK button below

An installation subtask is still running. Wait for installation subtask to 
finish running, then click OK to 
proceed.

Unable to create/open log file. Installation program was unable to 
create or open installation log file 
cw2000_inxxx.log, where xxx is a 
sequential number starting from 001 
(in the root directory of the drive on 
which you are installing).

Determine why file could not be 
created or opened, fix problem, 
then rerun installation. Common 
causes of this problem are lack of 
disk space or write protection on 
the file.

Error creating user bin <... > See the 
troubleshooting section in user manual

Installation program could not create 
the user bin account.

Fix problem, then rerun the 
installation.

Can not find script to upgrade database Problem with database upgrade. Contact your technical support 
representative.

Database upgrade failed Problem with database upgrade. Contact your technical support 
representative.

Database upgrade result unknown Problem with database upgrade. Contact your technical support 
representative.

Table A-1 Installation Error Messages (continued)

Message Reason for Message User Action
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Failure to Delete a Package During Uninstallation
If you try to remove Essentials but the uninstallation program fails to delete a package, try 
running the uninstallation program again. Several circumstances can cause a package not 
to uninstall successfully. Usually, running the uninstallation program again will remove 
the package.

Accessing the CiscoWorks2000 Server
The server uses port 1741. Make sure you enter the correct URL when accessing the server:

http://server_name:1741

where server_name is the name of the server.

Verify the Server Is Running
If you still cannot access the server, enter the following command at a DOS prompt to make 
sure your server is running:

ping server_name

Proxy Server Problems
If you get a message that the server is “alive” and get a proxy error when you try to connect 
to the server, make sure the proxy is set up correctly. If your server is configured to use a 
proxy server outside the firewall, you will get proxy errors if you configured the proxy to 
ignore requests to a certain machine, set of machines, or domain. 

You specify a proxy server in Netscape Navigator under Options > Network Preferences 
> Proxies and in Internet Explorer under Tools > Internet Options > Connections > 
LAN Settings.

Your proxy is set up incorrectly if: 

• You receive an error message that you are using a proxy outside the firewall.
• The proxy server recognizes www-int as an internal server, so it does not proxy requests 

to that server.
Installing and Setting Up Resource Manager Essentials on Windows NTA-6



Daemon Manager Not Running

 

• You set up a new internal server, www-nms, but when you make a request to the proxy 
server, it does not recognize www-nms as an internal server and proxies the request.

• The proxy server outside the firewall tries to request data from a server inside the 
firewall, and the request is blocked.

• You get a “Connection Refused” error from the proxy server.

Daemon Manager Not Running
CiscoWorks2000 relies on the Daemon Manager to control its processes. If the 
Daemon Manager is not running, you cannot access the server. If you interrupt an 
installation or uninstallation, the Daemon Manager might not have restarted.

To start or stop the Daemon Manager from the GUI:

Step 1 From the Windows NT Start menu, select Start > Settings > Control Panels.

Step 2 Double-click Services.

Step 3 Select CW2000 Daemon Manager from the dialog box.

Step 4 To start the server, click Start.

Step 5 To stop the server, click Stop.

To start (or stop) the Daemon Manager from the command-line interface:

Step 1 Log in as administrator.

Step 2 Open a command prompt window or shell window.

Step 3 Start the server by entering:

net start crmdmgtd

Step 4 Stop the server by entering:

net stop crmdmgtd
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Viewing Process Status
You can check for failures of back-end server processes by selecting CiscoWorks2000 
Server > Administration > Process Management > Process Status. Only users with 
administrator privileges can start and stop processes. For details, refer to Getting Started 
with the CiscoWorks2000 Server.

Browser Problems
If the desktop buttons do not work, Java and JavaScript are not enabled. Make sure you 
enable Java and JavaScript.

Make sure the browser cache is not set to zero.

Do not resize the browser window while the desktop main page is loading. This can cause 
a Java error.

For information about setting up browsers, refer to Installing and Setting Up CD One on 
Windows NT.

Improving Server Performance
To improve server performance for Essentials, consider these options:

• Reduce the number of managed devices polled by Availability.

• Increase the interval used by Availability to poll managed devices.

• Reduce the number of syslog messages saved to the CiscoWorks2000 database.

• Increase the interval used by Configuration Management to collect information for 
managed devices.
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