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Downloading Device Packages 
to a Windows Host

Support for new devices can be added to CiscoWorks Windows any time after the initial 
installation. To add device support, go to Cisco Connection Online (CCO), the Cisco 
Systems online support channel. 

If you do not have Internet access, you can skip this chapter. To receive updated packages, 
you can order the Cisco Network Management Support CD-ROM. The CD contains the 
latest network management device and application support files. These files are organized 
into product packages and provide up-to-date management support for the latest Cisco 
devices for all supported platforms. For ordering information, see your product catalog. 

A quick reference version of the instructions in this chapter appears in the installation 
booklet that accompanies the CD. You can use the booklet if you are familiar with 
downloading device packages from CCO to the CiscoWorks Windows platform. 

This chapter describes the download process in greater detail than the quick reference and 
contains the following sections:

• Using CiscoView Packages

• Downloading from CCO

• Downloading Via FTP

• Reinstalling the Cisco Device Package File

• Removing CiscoWorks Windows Devices

• CiscoWorks Windows Uninstallation
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Using CiscoView Packages
CiscoView device support on CCO consists of packages containing application upgrades, 
graphics, device descriptions, Management Information Base (MIB) files, and other 
supporting files. Each package has a Readme file that goes with it. View the Readme file 
before downloading to ensure that the file works with your configuration. After you add the 
package file, you can view and manage the hardware device using CiscoView. 

Note This chapter refers to device support for CiscoView, but these packages also support 
the other CiscoWorks Windows applications. 

Using CiscoView Packages
There are many device packages bundled in CiscoView. Device packages are upgraded 
frequently. To ensure that you have the most recent upgrade, verify the version number 
through CCO. Always check for updated device packages on CCO, and make sure that you 
have the latest device package. The CCO directory contains the latest device code, a 
Readme file, and the help code for the device. CCO is updated dynamically as changes 
occur.

Downloading from CCO
There are two ways to access Cisco device package files from the Internet: from CCO or 
through anonymous FTP. This section describes how to download from CCO.

Caution Ensure that for new device or application support, you select CiscoView 4.0 or 
CiscoView 4.1 release packages. You can use existing CiscoView 3.1.1 packages, but they 
do not support new features, such as stackable device functionality, which are available 
only with CiscoView 4.0 and later versions.
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Downloading from CCO
System and Software Requirements
Before adding a device package, make sure of the following:

• Windows 95 or Windows NT 4.0 is installed.

• CiscoWorks Windows 3.0 or later is installed.

• Your system meets the requirements listed in the CD booklet.

• WinZip 6.1 or later is installed.

Downloading from CCO 
The following is an overview of the steps necessary for downloading a package file from 
CCO. Details about these steps are in the sections that follow.

1 Check the CiscoView and CiscoWorks Windows version.

2 Close CiscoView.

3 Create a cv_pkgs directory in the CiscoWorks Windows directory.

4 Access CCO.

5 Download the device file into the cv_pkgs directory.

6 Unzip the device tar file.

7 Install the device package.

8 View your device.

9 Delete the cv_pkgs directory.
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Downloading from CCO
Check the CiscoView and CiscoWorks Windows Versions
To check the CiscoView version, do the following: 

Step 1 If CiscoView is installed as a standalone application, click the taskbar Start 
menu, then select Programs>CiscoWorks Windows>CiscoView. CiscoView 
is initialized. 

If CiscoView is installed with Castle Rock SNMPc, HP OpenView for 
Windows, or HP OpenView Network Node Manager for Windows NT, do one 
of the following:

• Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>SNMPc/HP OpenView. From within the network map, 
double-click on a Cisco device. CiscoView is initialized.

• Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>HP OpenView Network Node Manager. From within the 
network map, select a Cisco device. From the menu bar, select 
Monitor>CiscoView. CiscoView is initialized. 

Note To start CiscoView by double-clicking on a Cisco device, you need to associate 
CiscoView with the device. Refer to CiscoWorks Windows CD Installation Instructions for 
more information on rediscovering all network maps to properly display Cisco devices.

Step 2 Select Help>About CiscoView. Make sure CiscoView is version 4.0 or later. 

Step 3 To check packages, select Help>About CiscoView, click Packages. After you 
verify the package version, compare it with the CCO version to ensure you have 
the latest upgrade.

Proceed to the next section, “Close CiscoView.”

To check the CiscoWorks Windows version, do the following:

Step 1 Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>ReadmeFile. 

The Readme file appears.

Step 2 Make sure CiscoWorks Windows is version 3.0(1) or later. 
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Downloading from CCO
Step 3 Close the Readme file.

Step 4 Proceed to the next section, “Close CiscoView.”

Close CiscoView

To close CiscoView, select File>Exit from the CiscoView Main window. 

Create a cv_pkgs Directory in the CiscoWorks Windows Directory
Before you download device packages from CCO, create a cv_pkgs directory as a target 
directory for the device files. It is suggested that you download these files to a permanent 
location, or you can copy them to the CiscoView install directory. 

Step 1 Open a DOS window.

Step 2 Change to the directory where CiscoWorks Windows is installed.

Step 3 Create the cv_pkgs directory by entering the following command:

md cv_pkgs

Access CCO
Using a Web browser, access CCO and read the Readme file to ensure you have the right 
file. Depending on the type of network access you have, you can log in as either of the 
following:

• A CCO guest user, with a special access code

• A CCO registered user 

Caution You must close CiscoView before you install a device package. The device 
package does not install correctly if CiscoView is running during installation.
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Downloading from CCO
Logging in As a Guest User and Downloading the Device File
If you are not registered on CCO, you can be granted a special access code to access the 
device file. Follow these steps to log in as a guest and download the device file:

Step 1 To get a special access code, contact the Cisco Technical Assistance Center 
(TAC):

• 800 553-2447 

• 408 526-7209

Customers outside the US should call the 408 526-7209 number or go to the 
following URL for contact information:

http://www.cisco.com/warp/public/687/Directory/DirTAC.html

When you call, select the telephone menu option for Technical Support. TAC is 
part of Technical Support. 

State the product you are downloading and you are transferred to the appropriate 
person to obtain your special access code. 

You can also send email to tac@cisco.com. Ask for a special access code for 
downloading the device file.

Step 2 From a Web browser, access CCO by entering the following URL: 

http://www.cisco.com/public/sw-center/spc_req.shtml

Step 3 Enter your special access code at the prompt.

Step 4 Click Execute to pass the security warning message. The Execute button is 
located at the top of the page.

Step 5 Select the device tar file by clicking the button to the left of the device file you 
want to download.

The device file contains the package file (*.pkg) and associated Readme file. 

Step 6 Click Execute. 

Step 7 Follow the instructions on the screen to confirm the transfer. Select the server 
nearest you. 
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Downloading from CCO
Step 8 Depending on your browser, click Save File, or select File>Save As. You might 
be prompted to save the file to your workstation, with a message “Choose How 
to Handle,” or “Save As.” Again, depending on your browser, a Filter window 
might appear, with Directories, Files, and Selection sections.

Step 9 Reenter your password if you are prompted to do so.

By default, your home directory is selected as the target directory for the device 
file download. We recommend that you download the device file to the cv_pkgs 
directory on your workstation.

Step 10 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
you are downloading, for example: 

\cww\cv_pkgs\device_name.cv4xx.Px-x.tar

Step 11 After the file is downloaded, close the Web browser window.

Step 12 Proceed to the section “Unzip the Device Tar File.” 

Logging In as a Registered User of CCO
Follow these steps to log in as a registered user:

Step 1 From a Web browser, go to the Software Center on CCO by entering the 
following URL: 

http://www.cisco.com/kobayashi/sw-center/

Step 2 At the prompts, enter your CCO user ID and password. 

Step 3 On the Software Center page, click on the link to Network Mgmt Products.

Proceed to the next section, “Download the Device File into the cv_pkgs 
Directory.”
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Downloading from CCO
Download the Device File into the cv_pkgs Directory
This section applies only to registered users. Follow these steps to download the device file 
from the CCO Software Center. 

Note These are the downloading steps as of the release of this publication. The selection 
names and filenames could change without notice.

Step 1 From the Software Center page, Network Management Products section, select 
the CiscoView Upgrade Planner pointer to the CiscoView packages. 

Links to CiscoView packages can be accessed from the CiscoView Upgrade 
Planner page. From the planner page, select a link to CiscoView packages.

Step 2 Optionally, read the Readme file, if one is available. To view the Readme, click 
on the Readme filename and select a download option. 

Note The Readme file contains installation and other important information 
about each device file; it resides next to the tar file on CCO and is embedded in 
the tar file. Reading the Readme file ensures you download the appropriate tar 
file, and install it correctly. 

To select a device tar file, click on the device filename and select a download 
option. 

Step 3 Reenter your password if required. 

Step 4 Depending on your browser, click Save File, or select File>Save As. You might 
be prompted to save the file to your workstation, with a message such as 
“Choose How to Handle,” or “Save As.” Again, depending on your browser, a 
Filter window might appear, with Directories, Files, and Selection sections.

Download the device file to the cv_pkgs directory on your workstation.
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Downloading from CCO
Step 5 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
you are downloading, for example: 

\cww\cv_pkgs\device_name.cv40x.Px-x.tar

where 40x is the version number of CiscoView.

Step 6 After the file is downloaded, close the browser window.

Unzip the Device Tar File
Use WinZip extract the device file. The device file includes a Readme and a package 
(*.pkg) file.

Step 1 Start WinZip by double-clicking the package tar file.

Step 2 From the WinZip main menu, click the Open icon. 

Step 3 In the Look in field, select the drive and directory containing the device file. 

Step 4 Select the device file, then click Open.

Step 5 Click the Extract icon.

Step 6 In the Extract dialog box, click All files and Overwrite Existing Files.

Step 7 Make sure the directory to extract to is appropriate, for example, CWW\cv_pkgs.

Step 8 Click Extract.

Step 9 Close WinZip.

Install the Device Package
To add a package file (*.pkg), do the following:

Step 1 Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>Install Device.

The Setup program starts. 

Step 2 In the Select Package dialog box, select the directory containing the package 
file.
 Downloading Device Packages to a Windows Host 3-9



Downloading from CCO
Step 3 Select the device package (*.pkg) you want to load; click OK. 

Many messages appear during installation. Creating the MIB database and 
parsing take a while. 

If errors appear, see “Check the cvinstall.log File.” 

When the Setup Complete dialog box appears, select a Readme file option, then click 
Finish.

View Your Device
View the device to ensure that the installation was successful. Go to the appropriate 
following section for the procedure for your application. 

Standalone Device
Step 1 Select the CiscoView icon from the CiscoWorks Windows program group.

Step 2 Select File>Open Device to view your device. 

You are finished with the installation.

CiscoWorks Windows and SNMPc Integration
Step 1 Double-click the SNMPc icon in the CiscoWorks Windows program group or 

click the SNMPc icon in the CiscoWorks Windows program folder.

The SNMPc login dialog box appears.

Step 2 Enter your SNMPc user ID and password.

Step 3 Click OK.

Step 4 The map appears. 

Step 5 Double-click on the device you just installed. A view of the device appears.

You are finished with downloading.
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Downloading from CCO
CiscoWorks Windows and HP OpenView for Windows Integration
Step 1 Double-click the HP OpenView icon in the CiscoWorks Windows program 

group or click the HP OpenView icon in the CiscoWorks Windows program 
folder.

The HP OpenView for Windows (HP OpenView Professional Suite) dialog box 
appears.

Step 2 Bring up the network map.

The network topology map appears.

Step 3 Double-click on the device icon. A view of the device appears.

Note Check to be sure that the CiscoView device icon is updated in the topology map after 
the new device package installation. If it is not updated, reinstall the device package.

You are finished downloading.

CiscoWorks Windows and HP OpenView Network Node Manager Integration
Step 4 Double-click the Network Node Manager icon in the CiscoWorks Windows 

program group or click the Network Node Manager icon in the CiscoWorks 
Windows program folder.

Step 5 Bring up the network topology map. 

Step 6 Double click the device icon. Select Monitor>CiscoView from the menu bar. A 
view of the device appears.

You are finished downloading.

Delete the cv_pkgs Directory
After successful installation, you can optionally delete the cv_pkgs directory. For 
information on launching devices, refer to the appendixes.
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Downloading Via FTP
Downloading Via FTP
The following is a quick-reference overview of the steps necessary for downloading a 
device file. Details about these steps are in the sections that follow.

You must complete the following steps to properly download using the FTP service:

1 Check the CiscoView and CiscoWorks Windows version.

2 Close CiscoView.

3 Create a cv_pkgs directory in the Install_Directory.

4 Download the device tar file.

5 Unzip the device tar file.

6 Install the device package.

7 Check the cvinstall.log file.

Check the CiscoView and CiscoWorks Windows Version
To check the CiscoView version, do the following:

Step 1 If CiscoView is installed as standalone, click the taskbar Start menu, then select 
Programs>CiscoWorks Windows>CiscoView. CiscoView is initialized. 

If CiscoView is installed with Castle Rock SNMPc, HP OpenView for 
Windows, or HP OpenView Network Node Manager for Windows NT, do one 
of the following:

• Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>SNMPc/HP OpenView. From within the network map, 
double-click on a Cisco device. CiscoView is initialized.

• Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>HP OpenView Network Node Manager. From within the 
network map, select a Cisco device. From the menu bar, select 
Monitor>CiscoView. CiscoView is initialized. 
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Downloading Via FTP
Note To start CiscoView by double-clicking on a Cisco device, you need to associate 
CiscoView with the device. Refer to CiscoWorks Windows CD Installation Instructions for 
more information on rediscovering all network maps to properly display Cisco devices.

Step 2 Select Help>About CiscoView. Make sure CiscoView is version 4.0 or later.

Step 3 To check packages, select Help>About CiscoView, click Packages Installed. 
After you verify the package version, compare it with the CCO version to ensure 
you have the latest upgrade.

Proceed to the next section, “Close CiscoView.”

To check the CiscoWorks Windows version, do the following:

Step 1 Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>ReadmeFile. 

The Readme file appears.

Step 2 Make sure CiscoWorks Windows is version 3.0(1) or later. 

Step 3 Close the Readme file.

Proceed to the next section, “Close CiscoView.”

Close CiscoView 

To close CiscoView, select File>Exit from the CiscoView Main window.

Caution You must close CiscoView before you install a device package. The device 
package does not install correctly if CiscoView is running during installation.
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Downloading Via FTP
Create a cv_pkgs Directory in the Install_Directory
One way to create a cv_pkgs directory in the CWW directory follows: 

Step 1 Open a DOS window.

Step 2 Change to the directory where CiscoWorks Windows is installed, for example, 
c:\CWW.

Step 3 Enter the following command:

md cv_pkgs

Download the Device Tar File
This section applies only to registered users. Follow these steps to download the device file 
from the CCO Software Center.

Note These are the downloading steps as of the release of this publication. The selection 
names and filenames could change without notice.

Step 1 Use one of the following methods to begin an FTP session:

Note If you are launching FTP from behind your own firewall, use a passive 
FTP client.

• Web browser

Using a Web browser, use your CCO user ID and password: 
ftp://userid:password@cco.cisco.com. 

For additional security, you can omit your password when you type the URL. 
You will be prompted for your password separately when the browser 
connects.
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Downloading Via FTP
• FTP client 

Use an FTP application (for example, Reflection) to connect to ftp.cisco.com 
using your CCO user ID and password.

Step 2 Navigate to the top-level CiscoView directory (/cisco/netmgmt/ciscoview), 
select a CiscoView version, and proceed to the device packages subdirectory.

For example, the CiscoView 4.0 packages and Readme files are located in 
cisco/netmgmt/ciscoview/4.0/packages.

Step 3 Optionally, read the Readme file, if one is available. If you are using a Web 
browser, click on the Readme filename and select a download option to view the 
file. 

Note The Readme file contains installation and other important information 
about each device file; it resides next to the tar file on CCO and is embedded in 
the tar file. Reading the Readme file ensures you download the appropriate tar 
file, and install it correctly. 

Step 4 through Step 7 assume you are using a Web browser. If you are not, use FTP 
commands or your FTP client user interface to download the file(s).

Step 4 To select a device tar file, click on the device filename and select a download 
option. 

Step 5 Reenter your password if required. 

Step 6 Depending on your browser, click Save File, or select File>Save As. You might 
be prompted to save the file to your workstation, with a message such as 
“Choose How to Handle” or “Save As.” Again, depending on your browser, a 
Filter window might appear, with Directories, Files, and Selection sections.

Download the device file to the cv_pkgs directory on your workstation.
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Downloading Via FTP
Step 7 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
you are downloading, for example:

\cww\cv_pkgs\device_name.cv4xx.Px-x.tar

Step 8 After the file is downloaded, close the browser window.

Unzip the Device Tar File
Use WinZip to extract the device file. The device file includes a Readme and a package 
(*.pkg) file.

Step 1 Start WinZip by double-clicking the package tar file.

Step 2 From the WinZip main menu, click the Open icon. 

Step 3 In the Look in field, select the drive and directory containing the device file. 

Step 4 Select the device file, then click Open.

Step 5 Click the Extract icon.

Step 6 In the Extract dialog box, click All files and Overwrite Existing Files.

Step 7 Make sure the directory to extract to is appropriate, for example, CWW\cv_pkgs. 

Step 8 Click Extract.

Step 9 Close WinZip.

Install the Device Package
To add a package file (*.pkg), do the following:

Step 1 Click the taskbar Start menu, then select Programs>CiscoWorks 
Windows>Install Device. 

The Setup program starts. 

Step 2 In the Select Package dialog box, select the directory containing the package 
file. 
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Reinstalling the Cisco Device Package File
Step 3 Select the device package (*.pkg) you want to load; click OK. 

Many messages appear during installation. Creating the MIB database and 
parsing take a while. 

If errors appear, see “Check the cvinstall.log File.”

When the Setup Complete dialog box appears, select a Readme file option, then click 
Finish.

Check the cvinstall.log File
If errors or warnings occur during installation, you can check the log file (cvinstall.log) in 
the temporary directory (defined by the environment variable TEMP) to determine the 
reason for the installation failure. 

After you check the log file, go to the appendixes for information on launching devices.

Reinstalling the Cisco Device Package File
You can rerun the install script at any time to reinstall the Cisco device package file.

Removing CiscoWorks Windows Devices 
To remove a device after it has been installed:

Step 1 Click the taskbar Start menu, then select Programs>CiscoWorks Windows> 
Uninstall Device.

Step 2 The Uninstall Package dialog box appears. Select the devices you want to 
remove or select Select All to remove all devices; then click OK. 

Step 3 The Setup Complete dialog box appears. Select an option; then click Finish. 

Note If CiscoWorks Windows is integrated with HP OpenView Network Node 
Manager, a message box appears stating that the MIB and trap definition files 
will not be removed.
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CiscoWorks Windows Uninstallation
CiscoWorks Windows Uninstallation
If you encounter problems during installation or any other time, you can uninstall or 
reinstall CiscoWorks Windows. If you want to reinstall CiscoWorks Windows, you must 
uninstall it first.

To uninstall CiscoWorks Windows, click the taskbar Start menu, then select 
Programs>CiscoWorks Windows>Uninstall CiscoWorks.
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