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Downloading Device Packages 
to a UNIX Host

Support for new devices can be added to CiscoView any time after the initial installation. 
To add device support, go to Cisco Connection Online (CCO), the Cisco Systems online 
support channel. 

If you do not have Internet access, you can skip this chapter. To receive updated packages, 
you can order the Cisco Network Management Support CD-ROM. The CD contains the 
latest network management device and application support files. These files are organized 
into product packages and provide up-to-date management support for the latest Cisco 
devices for all supported platforms. For ordering information, see your product catalog. 

A quick reference version of the instructions in this chapter appears in the installation 
booklet that accompanies the CD. You can use the booklet if you are familiar with the 
process of downloading device packages from CCO to the CiscoView platform. 

This chapter describes the download process in greater detail than the quick reference and 
contains the following sections:

• Using CiscoView Packages

• Downloading from CCO

• Downloading via FTP

• Uninstalling an Installed Device Package

• Removing CiscoView

CiscoView device support on CCO consists of packages containing application upgrades, 
graphics, device descriptions, Management Information Base (MIB) files, and other 
supporting files. Each package has a Readme file that goes with it. View the Readme file 
before downloading to ensure that the file works with your configuration. After you add the 
package file, you can view and manage the hardware device using CiscoView. 
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CiscoView Packages
Note The CiscoView application files are normally stored in /opt/CSCOcv (on 
Solaris/HP-UX) or /usr/nms/CVapp (on AIX). If the temporary directory /usr/nms/cv_pkgs 
does not exist, create it and store all the device packages you download from CCO there. 
You can use this temporary directory as a reference so that you can compare the version of 
the package from this directory to the latest version of the device package on CCO. If a later 
version of the package is available in the CCO, you can upgrade to the latest version by 
following the procedure described in this document.

You can proceed without having this temporary directory, but the remainder of this 
document assumes that device tar files downloaded from CCO are stored in the 
/usr/nms/cv_pkgs directory.

CiscoView Packages
There are many device packages bundled in CiscoView. Device packages are upgraded 
frequently. To ensure that you have the most recent upgrade, verify the version number 
through CCO. Always check for updated device packages on CCO and make sure that you 
have the latest device package. The CCO directory contains the latest device code, a 
Readme file, and the help code for the device. CCO is updated dynamically as changes 
occur. 

Caution Ensure that for new device or application support, you select CiscoView 4.0 or 
CiscoView 4.1 release packages. You can use existing CiscoView 3.1.1 packages, but they 
do not support new CiscoView 4.0 features such as stackable device functionality, which 
are available only with CiscoView 4.0 and later versions.
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Downloading from CCO
Downloading from CCO
There are two ways to access Cisco device package files: from CCO or through anonymous 
FTP. This section describes how to download from CCO incrementally released device 
package files for use with CiscoView. 

System and Software Requirements
Before adding the Cisco device package file to CiscoView, make sure of the following:

• CiscoView 4.1 is properly installed.

• Your system meets the requirements listed in the CD installation booklet. 

• Tar is installed on your workstation so that you can extract the device file. Tar is 
typically preinstalled on UNIX workstations.

Downloading from CCO
The following is an overview of the steps necessary for downloading a device file from 
CCO. Details about these steps are in the sections that follow.

1 Check the CiscoView and device package version.

2 Close CiscoView.

3 Create a temporary location for downloading device packages.

4 Access CCO.

5 Download the device package file and save it to the temporary location.

6 Untar the downloaded device file (in tar format).

7 Install the device package.

8 Check the cvinstall.log file for errors.
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Downloading from CCO
Check the CiscoView and Device Package Versions
Follow these steps to check the version of CiscoView and device packages:

Step 1 From any directory on your workstation, open CiscoView by entering the 
CiscoView install directory path and nmcview.

Step 2 Select Help>About CiscoView. Make sure the version number is 4.0 or later. 

To check packages, select Help>About CiscoView, click Packages. After you 
verify the package version, compare it with the CCO version to ensure you have 
the latest upgrade. 

Step 3 Proceed to the next section, “Close CiscoView.”

Close CiscoView 

To close CiscoView, select File>Exit from the CiscoView Main window.

Create Temporary Location for Downloading Device Packages
Before you download device packages from CCO, create a cv_pkgs directory as a 
destination directory for the device files. We suggest you download these files to a 
permanent location, or you can copy them to the CiscoView install directory. 

Step 1 Change to the directory containing the CiscoView application files, for example:

cd /usr/nms 

This guide refers to this directory as install_directory. 

Step 2 Create a cv_pkgs directory.

mkdir /usr/nms/cv_pkgs 

This creates the directory cv_pkgs for storing your package files.

Caution You must close CiscoView before you install a device package. The device 
package does not install correctly if CiscoView is running during installation.
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Downloading from CCO
Step 3 Change to the cv_pkgs directory.

cd /usr/nms/cv_pkgs

Access CCO
Using a Web browser, access CCO and read the Readme file to ensure you have the right 
file. Depending on the type of network access you have, you can log in as either of the 
following:

• A CCO guest user with a special access code

• A CCO registered user

Logging in As a Guest User and Downloading the Device File
If you are not registered on CCO, you can be granted a special access code to access the 
device file. Follow these steps to log in as a guest and download the device file:

Step 1 To get a special access code, contact the Cisco Technical Assistance Center 
(TAC):

• 800 553-2447 

• 408 526-7209

Customers outside the US should call the contact information number 408 
526-7209 or go to the following URL:

http://www.cisco.com/warp/public/687/Directory/DirTAC.html

When you call, select the telephone menu option for Technical Support. TAC is 
part of Technical Support. 

State the product you are downloading and you are transferred to the appropriate 
person to obtain your special access code. 

You can also send email to tac@cisco.com. Ask for a special access code for 
downloading the device file.

Step 2 From a Web browser, access CCO by entering the following URL: 

http://www.cisco.com/public/sw-center/spc_req.shtml
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Downloading from CCO
Step 3 Enter your special access code at the prompt.

Step 4 Click Execute to pass the security warning message. The Execute button is 
located at the top of the page.

Step 5 Select the device tar file by clicking the button to the left of the device file you 
want to download.

The device file contains the package file (*.pkg) and associated Readme file. 

Step 6 Click Execute.

Step 7 Follow the instructions on the screen to confirm the transfer. Select the server 
nearest you. 

Step 8 Depending on your browser, click Save File, or select File>Save As. You might 
be prompted to save the file to your workstation, with a message “Choose How 
to Handle” or “Save As.” Again, depending on your browser, a Filter window 
might appear with Directories, Files, and Selection sections.

Step 9 Reenter your password if you are prompted to do so. 

By default, your home directory is selected as the target directory for the device 
file download. We recommend that you download the device file to the cv_pkgs 
directory on your workstation.

Step 10 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
to be downloaded, for example:

/usr/nms/cv_pkgs/device_name.cvxxx.Px-x.tar

where xxx is the version number of CiscoView.

Step 11 After the file is downloaded, close the Web browser window.

Step 12 Proceed to the section “Untar the Downloaded Device File (in Tar Format).” 

Logging In as a Registered User of CCO
Follow these steps to log in as a registered user:

Step 1 From a Web browser, go to the Software Center on CCO by entering the 
following URL: 
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Downloading from CCO
http://www.cisco.com/kobayashi/sw-center/

Step 2 At the prompts, enter your CCO user ID and password. 

Step 3 On the Software Center page, click on the link to Network Mgmt Products.

Step 4 Proceed to the next section, “Download the Device Package File and Save it to 
the Temporary Location.”

Download the Device Package File and Save It to the Temporary Location
This section applies only to registered users. Follow these steps to download the device file 
from the CCO Software Center.

Note These are the downloading steps as of the release of this publication. The selection 
names and filenames could change without notice. 

Step 1 From the Software Center page, Network Management Products section, select 
the CiscoView Upgrade Planner pointer to the CiscoView packages. 

Links to CiscoView packages can be accessed from the CiscoView Upgrade 
Planner page. From the planner page, select a link to CiscoView packages.

Step 2 Optionally, read the Readme file, if one is available. To view the Readme, click 
on the Readme filename and select a download option. 

Note The Readme file contains installation and other important information 
about each device file; it resides next to the tar file on CCO and is also embedded 
in the tar file. Reading the Readme file ensures that you download the 
appropriate tar file and install it correctly. 

To select a device tar file, click on the device filename and select a download 
option. 

Step 3 Reenter your password if required. 
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Downloading from CCO
Step 4 Depending on your browser, click Save File, or select File>Save As. You might 
be prompted to save the file to your workstation, with a message such as 
“Choose How to Handle” or “Save As.” Again, depending on your browser, a 
Filter window might appear, with Directories, Files, and Selection sections.

Download the device file to the cv_pkgs directory on your workstation.

Step 5 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
you are downloading, for example:

/usr/nms/cv_pkgs/device_name

Step 6 After the file is downloaded, close the Web browser window.

Untar the Downloaded Device File (in Tar Format)
To untar the device tar file, enter the following in the cv_pkgs directory on your 
workstation:

tar -xvf tar_file_name

where tar_file_name is the name of your device file, for example:

tar -xvf device_name.cv4.0.P2-0.tar

The package file (*.pkg) and the associated Readme file are extracted. 

Install the Device Package
Follow these steps to add the package file (*.pkg) to CiscoView:

Step 1 Check the environment variable by entering the following from any directory: 

env

The reply should include NMSROOT.

Step 2 If NMSROOT does not appear in the reply, set the NMSROOT environment 
variable by entering the following from any directory:

setenv NMSROOT /opt/CSCOcv
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Downloading from CCO
/opt/CSCOcv is the directory containing the recommended cv_pkgs subdirectory 
and the CiscoView application files, for example, /usr/nms.

Step 3 Log in as root. One way to do this is to enter the following:

su root 

A prompt for your password appears; enter the root password. 

To verify that you are properly logged in, enter the following:

whoami

If the response is root, you are logged in as root, and you are a superuser.

Step 4 Add the package file to CiscoView by entering the following in the cv_pkgs 
directory:

$NMSROOT/bin/cvinstall /usr/nms/cv_pkgs/device_name.pkg 

device_name.pkg is the name of the package file. 

This cvinstall install script installs the Cisco device package file from the cv_pkgs 
directory.

If errors appear, see “Installation Troubleshooting.”

You are finished with the installation. Optionally, you can check the log file as described in 
the section, “Check the cvinstall.log File for Errors.”

Installation Troubleshooting
The following messages might appear if CiscoView is running while attempting to add the 
package file to CiscoView:

Error in creating file mib.dat 
ERROR: xxxxx ciscoProducts: no such object xxxx

If these or similar messages, close CiscoView and add the package file again.

Check the cvinstall.log File for Errors
If problems occur during the installation, you can check the log file (cvinstall.log) in your 
install_directory, which contains the application files, for example, /opt/CSCOcv.
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Downloading via FTP
After you check the log file, go to the appendixes for information on launching devices or 
see the “Using CiscoView” chapter to learn more about CiscoView features.

Downloading via FTP
This section describes how to download the device tar file to a UNIX workstation using 
FTP service. 

System and Software Requirements
Before adding the Cisco device package file to CiscoView, make sure of the following:

• CiscoView 4.2(1) is properly installed.

• Your system meets the requirements listed in the CD installation booklet. 

• Tar is installed on your workstation so that you can extract the device file. Tar is 
typically preinstalled on UNIX workstations.

Downloading from CCO
The following is a quick-reference overview of the steps necessary for downloading a 
device file. Details about these steps are in the sections that follow.

You must complete the following steps to properly download using FTP:

1 Check the CiscoView versiClose CiscoView.

2 Create a cv_pkgs directory in install_directory on your workstation.

3 Download the device tar file.

4 Untar the device tar file.

5 Install the device package.

6 Check the cvinstall.log file.
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Downloading via FTP
Check the CiscoView Version
Follow these steps to check the version of CiscoView and device packages:

Step 1 From any directory on your workstation, open CiscoView by entering nmcview.

Step 2 Select Help>About CiscoView. Make sure the version number is 4.0 or later. 

To check packages, select Help>About CiscoView, then click Packages. After 
you verify the package version, compare it with the CCO version to ensure you 
have the latest upgrade.

Step 3 Proceed to the next section, “Close CiscoView.”

Close CiscoView

To close CiscoView, select File>Exit from the CiscoView Main window.

Create a cv_pkgs Directory in the Install_Directory on Your Workstation
Use one of the following methods to begin an FTP session:

• Change to the directory containing the CiscoView application files, for example, cd 
/usr/nms. 

This guide refers to this directory as install_directory. 

• Create a cv_pkgs directory:

mkdir /usr/nms/cv_pkgs 

This creates the directory cv_pkgs for storing your package files.

• Change to the cv_pkgs directory:

cd /usr/nms/cv_pkgs

Caution You must close CiscoView before you install a device package. The device 
package does not install correctly if CiscoView is running during the installation.
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Downloading via FTP
Download the Device Tar File
This section applies only to registered users of CCO. Follow these steps to download the 
device file from the Cisco Software Center FTP site.

Note These are the downloading steps as of the release of this publication. The selection 
names and filenames could change without notice.

Step 1 Begin an FTP session with ftp.cisco.com. There are several ways to use FTP to 
access device packages. Three methods are described below.

Note If you are launching FTP from behind your own firewall, use a passive 
FTP client.

• Anonymous FTP

From a command-line prompt on a device that supports FTP, start an FTP 
session on the Cisco FTP server by entering ftp ftp.cisco.com or 
ftp cco.cisco.com. When prompted for your user ID and password, enter 
your registered CCO user ID and password. Do not connect as an anonymous 
user; CiscoView device packages are not available to anonymous login users.

• Web browser

Using a Web browser, enter your CCO user ID and password: 
ftp://userid:password@cco.cisco.com. 

For additional security, you can omit your password when you enter the 
URL. You will be prompted for your password separately when the browser 
connects.

• FTP client 

Use an FTP application (for example, Reflection) to connect to ftp.cisco.com 
using your CCO user ID and password.

Step 2 Navigate to the top-level CiscoView directory (/cisco/netmgmt/ciscoview), 
select a CiscoView version, and proceed to the device packages subdirectory.
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Downloading via FTP
For example, the CiscoView 4.0 packages and Readme files are located in 
cisco/netmgmt/ciscoview/4.0/packages

Step 3 Optionally, read the Readme file, if one is available. If you are using a Web 
browser, click on the Readme filename and select a download option to view the 
file. 

Note The Readme file contains installation and other important information 
about each device file; it resides next to the tar file on CCO and is embedded in 
the tar file. Reading the Readme file ensures that you download the appropriate 
tar file, and install it correctly. 

Step 4 through Step 7 assume you are using a Web browser. If you are not, use FTP 
commands or your FTP client user interface to download the tar file(s).

Step 4 To select a device tar file, click on the device filename and select a download 
option. 

Step 5 Reenter your password if required. 

Step 6 Depending on your browser, click Save File, or select File>Save As. You might 
be prompted to save the file to your workstation, with a message such as 
“Choose How to Handle” or “Save As.” Again, depending on your browser, a 
Filter window might appear, with Directories, Files, and Selection sections.

Download the device file to the cv_pkgs directory on your workstation.

Step 7 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
of the device you are downloading, for example:

/usr/nms/cv_pkgs/device_name

Step 8 After the file is downloaded, close the browser window.

Untar the Device Tar File
To untar the device tar file, enter the following in the cv_pkgs directory on your 
workstation:
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Downloading via FTP
tar -xvf tar_file_name

Where tar_file_name is the name of your device file, for example:

tar -xvf device_name.cv4.0.P2-0.tar

The package file (*.pkg) and the associated Readme file are untarred. 

Install the Device Package
Follow these steps to add the package file (*.pkg) to CiscoView:

Step 1 Check the environment variable by entering the following from any directory: 

env

The reply should include NMSROOT.

Step 2 If NMSROOT does not appear in the reply, set the NMSROOT environment 
variable by entering the following from any directory:

setenv NMSROOT /opt/CSCOcv

/opt/CSCOcv is the directory containing the recommended cv_pkgs subdirectory 
and the CiscoView application files, for example, /usr/nms.

Step 3 Log in as root. One way to do this is to enter the following:

su root 

A prompt for your password appears; enter the root password. 

To verify that you are properly logged in, enter the following:

whoami

If the response is root, you are logged in as root, and you are a superuser.

Step 4 Add the package file to CiscoView by entering the following in the cv_pkgs 
directory:

$NMSROOT/bin/cvinstall /usr/nms/cv_pkgs/device_name.pkg 
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Uninstalling an Installed Device Package
device_name.pkg is the name of the package file. 

This cvinstall install script installs the Cisco device package file from the 
cv_pkgs directory.

If errors appear, see “Installation Troubleshooting.”

You are finished with the installation. Optionally, you can check the log file as described in 
the section “Check the cvinstall.log File.”

Installation Troubleshooting
The following errors might appear if CiscoView is running while you are attempting to add 
the package file to CiscoView:

Error in creating file mib.dat 
ERROR: xxxxx ciscoProducts: no such object xxxx

If these errors appear or errors similar to these errors, close CiscoView, and add the package 
file again.

Check the cvinstall.log File
If problems occur during installation, you can check the log file (cvinstall.log) in your 
install_directory, which contains the CiscoView application files, for example, /usr/nms.

The cvinstall.log file can point to situations that might be resolved by reinstalling. You 
should resolve installation errors before attempting to use CiscoView.

After you check the log file, go to the appendixes for information on launching devices.

Uninstalling an Installed Device Package
You can uninstall one or more device packages. To uninstall a device package, perform the 
following steps:

Step 1 Log in to the machine as root from the login prompt or by changing user to root 
(su root).

Enter the root password when prompted for a password.
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Removing CiscoView
Step 2 Verify that the environment variable NMSROOT is set. It should be set to the 
location where CiscoView is installed. If the variable is not set, enter the 
following command:

setenv NMSROOT /opt/CSCOcv

If you are using Korn or Bourne shell, enter the following command:

NMSROOT=/opt/CSCOcv; export NMSROOT

Step 3 Remove the device package from CiscoView by entering:

$NMSROOT/bin/uninstallpkg pkg_name

Where pkg_name is the device package name.

You can specify more than one device package (for example, 
$NMSROOT/bin/uninstallpkg pkg_name1 pkg_name2 pkg_name3...).

Removing CiscoView
If you encounter problems during installation or any other time, you can remove or reinstall 
CiscoView. If you want to reinstall CiscoView, you must remove it first. 

To remove CiscoView, use one of the following procedures.

• Solaris or HP-UX

Step 1 Enter one of the following commands:

—From a Solaris workstation:

# pkgrm CSCOcv

—From a HP-UX 10.x workstation:

# swremove -v CISCOVIEW

Step 2 Verify that no user files exist in the directory tree by entering:

# find /opt/CSCOcv -type f -print
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Removing CiscoView
Step 3 If no files exist, delete the directory by entering:

# rm -rf /opt/CSCOcv 

where /opt/CSCOcv is the location of the CiscoView files. 

• AIX

Step 1 Log in as the root user.

Step 2 Start the System Management Interface Tool (SMIT) by entering the following 
command:

# smit

Step 3 From the System Management menu, select Communications Applications 
and Services.

Step 4 Select Cisco Network-Management Applications for AIX.

Step 5 Select CiscoView.

Step 6 Select Maintenance.

Step 7 Select Remove CiscoView for AIX program.

Step 8 In response to the ARE YOU SURE? prompt, click OK.

While the animated man is running, SMIT uninstalls the CiscoView product. If 
the man raises his hands and SMIT displays OK, the uninstallation process has 
succeeded. If the man falls down, uninstallation has failed, and you should 
contact the TAC.

Step 9 Exit SMIT by pressing F12 or selecting Exit>Exit SMIT.
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