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Downloading Device Packages

New device support can be added to CiscoView incrementally any time after the initial 
installation of CiscoView. To add incremental device support, access the Cisco Customer 
Connection Online (CCO). CCO is the Cisco Systems online support channel. 

If you do not have Internet access, you can skip this chapter. To receive updated packages, 
you can order the Cisco Network Management Support CD-ROM. The support CD 
contains the latest Cisco network management device and application support files. These 
files are organized into product packages and provide up-to-date management support for 
the latest Cisco devices for all supported platforms. For ordering information, see your 
Product Catalog. 

A quick reference version of these instructions appears in the CiscoView CD Installation 
Instructions booklet, which you can use if you are familiar with the process of downloading 
devices from CCO to the CiscoView platform. 

This chapter describes the download process in greater detail than the quick reference and 
includes the following sections:

• Using CiscoView Packages

• Downloading to a UNIX Workstation from CCO

• Downloading to a UNIX Workstation from Anonymous FTP

• Reinstalling the Cisco Device Package File

• Removing CiscoView

CiscoView device support on CCO consists of packages that are bundles containing 
application upgrades, graphics, device descriptions, Management Information Base (MIB) 
files as well as installation scripts and other supporting files. Each package has a README 
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Using CiscoView Packages
file that goes with it. The README file should be read prior to downloading to ensure the 
file works with your current configuration. After you add the package file to CiscoView, 
you can view and manage the hardware device using CiscoView. 

Using CiscoView Packages
There are many devices available through CiscoView, and they are upgraded frequently. To 
ensure that you have the most recent upgrade, verify the version number through CCO. 
Compare the cv_pkgs directory with the CCO device packages to make sure that you have 
the most up-to-date version of the files. The CCO directory contains the latest device code, 
a README file, the help code for the device, and CCO is updated dynamically as changes 
occur. 

Note In order to perform a download, you have to be root or the owner of the files. 

Caution Ensure that for new device or application support, you select CiscoView 4.0 
release packages. You can use existing CiscoView 3.1.1 packages, but they do not support 
new CiscoView 4.0 features such as stackable device functionality. 

Downloading to a UNIX Workstation from CCO
From the Internet there are two ways to access Cisco device package files: from CCO, or 
from the anonymous FTP service. This section describes how to download from CCO 
incremental released device package files for use with CiscoView. 

System and Software Requirements
Before adding the Cisco device package file to CiscoView, make sure of the following:

• CiscoView 4.0 is properly installed.

• Your system meets the requirements listed in the CiscoView CD Installation 
Instructions document. 
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• Since you are installing on a UNIX workstation, make sure tar is installed on your 
workstation. Tar enables you to extract the device file. Tar is typically pre-installed on 
UNIX workstations.

Downloading from CCO
The following is an overview of the steps necessary for downloading a device file from 
CCO. Details about these steps are in the sections that follow.

1 Check the Version of CiscoView and Device Packages

2 Close CiscoView

3 Create a cv_pkgs Directory in the Install_Directory on Your Workstation 

4 Access CCO

5 Download the Device File

6 Untar the Device Tar File

7 Add the Package File to CiscoView

8 Check the cvinstall.log File

Check the Version of CiscoView and Device Packages
Follow these steps to check the version of CiscoView and device packages:

Step 1 From any directory on your workstation, open CiscoView by entering nmcview.

Step 2 Select Help>About CiscoView. Make sure the version number is 4.0 or later. 

To check packages, select Help>About CiscoView and click on Packages. 
Once you have verified the version of the package, compare it with the CCO 
version to ensure you have the latest upgrade. 

Step 3 Proceed to the next section, “Close CiscoView.”

Close CiscoView
To close CiscoView, select File>Exit from the CiscoView Main window.
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Caution Closing CiscoView is important! The device package does not install correctly if 
CiscoView is running during the installation.

Create a cv_pkgs Directory in the Install_Directory on Your Workstation
Before you download device packages from CCO, create a cv_pkgs directory as a 
destination directory for the device files. We suggest you download these files to a 
permanent location, or you may copy these to the CiscoView install directory. 

Step 1 Change to the directory containing the CiscoView application files, for example:

cd /usr/nms 

This guide refers to this directory as the install_directory. 

Step 2 Create a cv_pkgs directory.

mkdir /usr/nms/cv_pkgs 

This creates the directory cv_pkgs for storing your package files.

Step 3 Change to the cv_pkgs directory.

cd /usr/nms/cv_pkgs

Access CCO
Use a Web browser to access CCO and review the README file to ensure you have the 
right file. Depending on the type of network access you have, you can log in as either of the 
following:

• A guest user of CCO with a special access code

• A registered user of CCO

Guest users are limited to seeing only files available to the public, such as Cisco’s 
Management Information Base (MIB) files. Operating system software such as Cisco IOS 
releases generally are not available to guest users. To download these types of files, you 
must be granted special file access. 

Log in as either a guest or registered user as described in the next sections.
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Logging in as a Guest User of CCO and Downloading the Device File
If you are not registered on CCO, you can be granted a special access code to access the 
device file. Follow these steps to log in as a guest and download the device file:

Step 1 To get a special access code, contact the Cisco Technical Assistance Center 
(TAC):

• 800 553-2447 

• 408 526-7209

1 For customers outside the US, you can call the 408 526-7209 number or get contact 
information at the following URL:

http://www-tac.cisco.com/CRC/freq.trans.global.html

When you call, select the telephone menu option for Technical Support. TAC is 
part of Technical Support. 

State the product you are downloading and you are transferred to the appropriate 
person to obtain your special access code. 

You can also send email to tac@cisco.com or cco-team@cisco.com. Ask for a 
special access code for downloading the device file.

Step 2 From a Web browser, access CCO by entering the following URL: 

http://www.cisco.com/public/library

Step 3 Enter your special access code at the prompt.

Step 4 Press OK to pass the security warning message.

Step 5 Select the device tar file by clicking the button to the left of the device file you 
want to download.

The device file contains the package file (*.pkg) and associated README file. 

Step 6 Locate the Execute button and click Execute. (The Execute button is located at 
the top of the page.)

Step 7 Follow the instructions on the screen to confirm the transfer. Select the server 
nearest you. 
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Step 8 Depending on your browser, click the Save File button, or select the File menu, 
then Save As. You might be prompted to save the file to your workstation, with 
a message like “Choose How to Handle,” or “Save As.” Again, depending on 
your browser, a Filter window might appear with Directories, Files, and 
Selection sections.

Step 9 Reenter your password if you are prompted to do so. 

By default, your home directory is selected as the target directory for the device 
file download. We recommend that you download the device file to the cv_pkgs 
directory on your workstation.

Step 10 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
to be downloaded. Example:

/usr/nms/cv_pkgs/device_name.cvxxx.Px-x.tar

where xxx is the version number of CiscoView.

Step 11 After the file is downloaded, close the Web browser window.

Step 12 Proceed to the section, “Untar the Device Tar File.” 

Logging in as a Registered User of CCO
Follow these steps to log in as a registered user:

Step 1 From a Web browser, access the Software Image Library on CCO by entering 
the following URL: 

http://www.cisco.com/kobayashi/sw-center/

Step 2 At the prompts, enter your CCO user ID and password. 

Step 3 Proceed to the next section, “Download the Device File.”
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Download the Device File
This section applies only to registered users. Follow these steps to download the device file 
from the CCO Software Library.

Note These are the downloading steps as of the release of this publication. The selection 
names and filenames listed below might change without notice.

Step 1 From the Software Image Library page, Network Management Products section, 
select the CiscoView Upgrade Planner pointer to the CiscoView packages. 

Step 2 Optionally, read the README file, if one is available. To view the README, 
click on the README filename and select a download option. 

Note The README file contains installation and important information about each device 
file; it resides both next to the tar file on CCO, and embedded in the tar file. Reading the 
README file ensures you download the appropriate tar file, and install it correctly. 

To select a device tar file, click on the device filename and select a download 
option. 

Step 3 Reenter your password if required. 

Step 4 Depending on your browser, click the Save File button, or select the File>Save 
As. You might be prompted to save the file to your workstation, with a message 
like “Choose How to Handle,” or “Save As.” Again, depending on your 
browser, a Filter window might appear, with Directories, Files, and Selection 
sections.

Download the device file to the cv_pkgs directory on your workstation.
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Step 5 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
of the device you are downloading. Example:

/usr/nms/cv_pkgs/device_name

Step 6 After the file is downloaded, close the Web browser window.

Step 7 Proceed to the section “Untar the Device Tar File.”

Untar the Device Tar File
Follow these steps to untar the device tar file.

Step 1 Enter the following in the cv_pkgs directory on your workstation:

tar -xvf tar_file_name

tar_file_name is the name of your device file.

Example:

tar -xvf device_name.cv4.0.P2-0.tar

The package file (*.pkg) and the associated README file are untarred. 

Step 2 Proceed to the next section, “Add the Package File to CiscoView.”

Add the Package File to CiscoView
Follow these steps to add the package file (*.pkg) to CiscoView:

Step 1 Check the environment variable by entering the following from any directory: 

env

The reply should include NMSROOT.

Step 2 If NMSROOT does not appear in the reply, set the NMSROOT environment 
variable by entering the following from any directory:

setenv NMSROOT /opt/CSCOcv
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/opt/CSCOcv is the directory containing the recommended cv_pkgs subdirectory 
and the CiscoView application files. Example: /usr/nms.

Step 3 Log in as root. One way to do this is to enter the following:

su root 

A prompt for your password appears; enter the root password. 

To check that you are properly logged in, enter the following:

whoami

If the response is root, you are logged in as root, and you are a superuser.

Step 4 Add the package file to CiscoView by entering the following in the cv_pkgs 
directory:

$NMSROOT/cvinstall /usr/nms/cv_pkgs/device_name.pkg 

device_name.pkg is the name of the package file. 

This cvinstall install script installs the Cisco device package file from the 
cv_pkgs directory.

If errors appear, see “Installation Troubleshooting” below.

You are finished with the installation. Optionally, you can check the log file as described in 
the section, “Check the cvinstall.log File.”

Installation Troubleshooting
The following errors might appear if CiscoView is running while attempting to add the 
package file to CiscoView:

Error in creating file mib.dat 
ERROR: xxxxx ciscoProducts: no such object xxxx

If these errors appear or errors similar to these errors, close CiscoView and add the package 
file again.
 Downloading Device Packages 2-9



Downloading to a UNIX Workstation from Anonymous FTP
Check the cvinstall.log File
If problems occur during the installation, you can check the log file (cvinstall.log) in your 
install_directory, which contains the application files. For example: /opt/CSCOcv.

After you check the log file, go to the appendixes for information on launching devices or 
see “Using CiscoView” to learn more about CiscoView features.

Downloading to a UNIX Workstation from Anonymous 
FTP

This section describes another way to download the device tar file to a UNIX workstation, 
using the anonymous FTP service. 

The following is a quick-reference overview of the steps necessary for downloading a 
device file. Details about these steps are in the sections that follow.

You must complete the following steps to properly download using the FTP service:

1 Check the Version of CiscoView.

2 Close CiscoView.

3 Create a cv_pkgs Directory in the Install_Directory on Your Workstation.

4 Download the Device Tar File.

5 Untar the Device Tar File.

6 Add the Package File to CiscoView.

7 Check the cvinstall.log File.

Check the Version of CiscoView
Follow these steps to check the version of CiscoView and device packages:

Step 1 From any directory on your workstation, open CiscoView by entering nmcview.

Step 2 Select Help>About CiscoView. Make sure the version number is 4.0 or later. 
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To check packages, select Help>About CiscoView and click on Packages. 
Once you have verified the version of the package, compare it with the CCO 
version to ensure you have the latest upgrade. 

Step 3 Proceed to the next section, “Close CiscoView.”

Close CiscoView
To close CiscoView, select File>Exit from the CiscoView Main window.

Caution Closing CiscoView is important! The device package does not install correctly if 
CiscoView is running during the installation.

Create a cv_pkgs Directory in the Install_Directory on Your Workstation
Before you download device packages from CCO, create a cv_pkgs directory as a 
destination directory for the device files. We suggest you download these files to a 
permanent location, or you may copy these to the CiscoView install directory. 

Step 1 Change to the directory containing the CiscoView application files, for example, 
cd /usr/nms. 

This guide refers to this directory as the install_directory. 

Step 2 Create a cv_pkgs directory:

mkdir /usr/nms/cv_pkgs 

This creates the directory cv_pkgs for storing your package files.

Step 3 Change to the cv_pkgs directory:

cd /usr/nms/cv_pkgs

Download the Device Tar File
This section applies to only registered users. Follow these steps to download the device file 
from the CCO Software Library.
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Note These are the downloading steps as of the release of this publication. The selection 
names and filenames listed below might change without notice.

Step 1 From the Software Image Library page, Network Management Products section, 
select the CiscoView Upgrade Planner pointer to the CiscoView packages. 

Step 2 Optionally, read the README file, if one is available. To view the README, 
click on the README filename and select a download option. 

Note The README file contains installation and important information about each device 
file; it resides both next to the tar file on CCO, and embedded in the tar file. Reading the 
README file ensures you download the appropriate tar file, and install it correctly. 

To select a device tar file, click on the device filename and select a download 
option. 

Step 3 Reenter your password if required. 

Step 4 Depending on your browser, click the Save File button, or select the File>Save 
As. You might be prompted to save the file to your workstation, with a message 
like “Choose How to Handle,” or “Save As.” Again, depending on your 
browser, a Filter window might appear, with Directories, Files, and Selection 
sections.

Download the device file to the cv_pkgs directory on your workstation.

Step 5 If the Filter window appears, complete this step. In the Selection section of the 
Filter window, enter the complete destination path and filename of the device file 
of the device you are downloading. Example:

/usr/nms/cv_pkgs/device_name

Step 6 After the file is downloaded, close the Web browser window.

Step 7 Proceed to the section “Untar the Device Tar File.”
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Untar the Device Tar File
Follow these steps to untar the device tar file.

Step 1 Enter the following in the cv_pkgs directory on your workstation:

tar -xvf tar_file_name

tar_file_name is the name of your device file.

Example:

tar -xvf device_name.cv4.0.P2-0.tar

The package file (*.pkg) and the associated README file are untarred. 

Step 2 Proceed to the next section, “Add the Package File to CiscoView.”

Add the Package File to CiscoView
Follow these steps to add the package file (*.pkg) to CiscoView:

Step 1 Check the environment variable by entering the following from any directory: 

env

The reply should include NMSROOT.

Step 2 If NMSROOT does not appear in the reply, set the NMSROOT environment 
variable by entering the following from any directory:

setenv NMSROOT /opt/CSCOcv

/opt/CSCOcv is the directory containing the recommended cv_pkgs subdirectory 
and the CiscoView application files. Example: /usr/nms.

Step 3 Log in as root. One way to do this is to enter the following:

su root 

A prompt for your password appears; enter the root password. 

To check that you are properly logged in, enter the following:

whoami

If the response is root, you are logged in as root, and you are a superuser.
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Step 4 Add the package file to CiscoView by entering the following in the cv_pkgs 
directory:

$NMSROOT/cvinstall /usr/nms/cv_pkgs/device_name.pkg 

device_name.pkg is the name of the package file. 

This cvinstall install script installs the Cisco device package file from the 
cv_pkgs directory.

If errors appear, see “Installation Troubleshooting” below.

You are finished with the installation. Optionally, you can check the log file as described in 
the section, “Check the cvinstall.log File.”

Installation Troubleshooting
The following errors might appear if CiscoView is running while attempting to add the 
package file to CiscoView:

Error in creating file mib.dat 
ERROR: xxxxx ciscoProducts: no such object xxxx

If these errors appear or errors similar to these errors, close CiscoView and add the package 
file again.

Check the cvinstall.log File
If problems occur during the installation, you can check the log file (cvinstall.log) in your 
install_directory, which contains the CiscoView application files. Example: /usr/nms.

After you check the log file, go to the appendixes for information on launching devices.

Reinstalling the Cisco Device Package File
You can rerun the CiscoView install script, setup.sh, at any time to reinstall the Cisco device 
package file.
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Removing CiscoView
To remove CiscoView:

Step 1 Type pkgrm CSCOcv at the prompt. 

CiscoView and all the package files are removed. 
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