CHAPTER 7

Configuring and Monitoring LANE
Services

As the network administrator, you have notified that the company will be
expanding to include two new buildings. These buildings will house additional
engineers and other employees that the company plans on hiring.

Your current network configuration consists of two segments. On each segment,
a VLAN exists for the Marketing department, called VLAN2. Both segments
belong to the same VTP domain, called “San Jose.” See Figure 7-1.

In this scenario, you want to connect these VLANSs through an ATM cloud by
creating an ATM VLAN.

Note  The network design used in this scenario is intended to illustrate how
to use Campus Manager applications to manage your network, not
as guidelines for how to design your network. Consult the network
design guidelines for that type of information.

Figure 7-1  Current Network Configuration with San Jose VTP Domain
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To do this, refer to these sections:
¢ What You Need—Prerequisites
e How to Do It—Procedure

e Where You Should End Up—Verification

What You Need—Prerequisites

Before beginning, make sure you do the following:
¢ Understand Required LANE Components
e Prepare the ATM Devices
e Create a Master LAN Emulation Configuration Server (LECS)
e Create a Backup LAN Emulation Configuration Server (LECS)
In this scenario, you will use the following applications:
e Device command line interface (CLI)

e Topology Services

Understand Required LANE Components

Before beginning, make sure you understand the components required for LANE
to function:

¢ LAN Emulation Configuration Server (LECS)
e LAN Emulation Server/Broadcast and Unknown Server (LEC/BUS)
e LAN Emulation Client (LEC)

See “LANE Components” in Chapter 7, “Configuring and Monitoring LANE
Services” for detailed informationabout these components and their requirements.

Using Campus Manager

78-6823-01 |




| Chapter7 Configuring and Monitoring LANE Services

What You Need—Prerequisites W

Prepare the ATM Devices

Step 1
Step 2

Step 3
Step 4

Step 5

To prepare the ATM devices for LANE:

Make sure that you have the correct software image version on the ATM devices.

Make sure that all ATM switches appear on the topology view. Select Campus
Manager > Topology Services > Managed Domains > ATM Domains >
fabric-2.

Select View>Display View. See Figure 7-2.

If the switches do not appear, verify SNMP connectivity on the missing LANE
devices.

Make sure ILMI is turned on and is functioning properly on the required ATM
interfaces.

The ANI Server requires SNMP and ILMI for proper discovery of ATM devices.
If the ATM devices do not appear on the topology view, you may need to increase
the SNMP timeout values. Do not increase the SNMP timeout for all devices
because the discovery process will take much longer. For more information about
increasing the SNMP timeout, refer to the Getting Started with the
CiscoWorks2000 Server publication.
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Figure 7-2 Topology View of ATM Domain Showing ATM Devices
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Create a Master LAN Emulation Configuration Server (LECS)

If the ATM Domain does not already have a master LECS, you must create one.
To do so, perform the following steps:

Step1  Select Campus Manager > Topology Services > Tools > LANE Management...
> Configure Config Server.... A window similar to the one show in Figure 7-3
appears.

Step 2 Select the ATM domain you wish to add the LECS to, in this case, fabric-2.
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Topology Services displays the host name and module/port number of the best
candidate for the LECS as the default entry in the Device column. You can accept
this choice or click on the down arrow to select another device.

Notice that the Oper Status (operating status) column shows Not Configured. This
means that the LECS has not been configured. Once you click Apply, the
configuration will be updated on the switch and the status will change to
Configured.

Click Apply.

You can add a backup LECS at this time by proceeding to Step 3 in the “Create a
Backup LAN Emulation Configuration Server (LECS)” section.

Figure 7-3  Configure Config Server Window

1 LAME Services: Configure Config Server

ATM Domain_| Device |__Master State | Oper Status |

fabric-2 172.20126.63<ATM3/0/4> |Active/Master | Configured

fabric-4 | 1722012617 2<ATM2/0/... | Inactive/Back. .. | Configured Delete

fabric-4 | 172.20.126.5¢AT1/0> |Inactive/Back... | Configured Undo

fabric-4 172 20 126.170<ATME/0/. . |ActivesMaster | Configured

fabric-5 172 20126, 34<ATM3/0/4> |ActivesMaster | Configured - Highlight Device |

Apply | | Print | | Cancel | | Help |

|Dane | | 0Ewars [Updated: 2000/01/20 1406 flacal) |
E\:\u"aming: Applet Window &

Create a Backup LAN Emulation Configuration Server (LECS)

Step 1

Step 2

If a master LECS already exists, you can add a backup LECS by performing the
following steps:

Select Campus Manager > Topology Services > Tools > LANE Management...
> Configure Config Server....

Select the ATM domain to which you want to add the backup LECS, in this case
fabric-2.
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Step 3

Step 4

The Master State column should show the state of the master LECS as
Active/Master and the Oper Status should show Configured.

Click Add Backup.

Another row is added. Notice that the fabric name is the same as the fabric you
selected.Topology Services displays the host name and module/port number of the
best candidate for the backup LECS as the default entry in the Device column.
You can accept this choice or click on the down arrow to select another device.

Click Apply.

Notice that the Oper Status (operating status) column shows Inactive/Backup.
This means that the LECS has not been configured yet. After the configuration is
updated on the switch, the status will change to Active/Backup.

Figure 7-4  Configure Config Server Window for Backup LECS

1 LAME Services: Configure Config Server

ATM Domain | Device | baster State | Oper Status | | | Add Backup |
fabric-2 | 172.20.1 26 69<ATM3/0/A | Active/Master | Configured
fabric-2 |172.20.1 26. 70<ATM2/078> | Active/Master | Configured | Delete |
fabric-4 |172.20.126.172<ATM2/0/. . | Inactive/Back. .. | Configured
fabric-4 | 172,201 26.5¢AT1/05 :InactivefBack... Configured
fabric-4 172201 26170<ATHBA0/ . | Active/Master | Configured - | Highlight Device |
Print | | Cancel | | Help |
[Done | | OEnos |Updated: 2000/01720 1410 flocdl] |
IWaming: Applet Window &
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How to Do [t—Procedure

Before creating an ATM-VLAN, make sure you have at least one LECS in the
ATM domain. See the “Prepare the ATM Devices” section.

Refer to the procedures to create an ATM-VLAN:
1. Create a LE/Broadcast Server
2. Create LAN Emulation Clients (LECs)

3. Rediscover the Network

Create a LE/Broadcast Server

Step 1

Step 2

Step 3

Step 4
Step 5

Because you have already created VLAN 2 on each segment in your network, you
need to add the LE/Broadcast server capability to the VLAN to extend the VLAN
across the ATM network.

To create a LE/Broadcast server for VLAN 2:

Select Campus Manager > Topology Services > ATM Domains > fabric name,
in this case fabric-2.

Select Tools > LANE Management > Add/Modify LANE Services... from the
main window. A window similar to the one shown in Figure 7-5 appears.

See Table 7-1 for help filling in the required information.
Select the device you wish to use as the LE/Broadcast server for the ATM-VLAN.

Topology Services displays the host name and module/port number of the best
candidate for the LE/Broadcast server as the default entry in the Device column.
You can accept this choice or click on the down arrow to select another device.
Click Apply.

The LE/Broadcast server is added to the ATM-VLAN, and its operating status
changes to Configured.

[ 78-6823-01
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Step 6

Step 7

If you want to add a backup LE/Broadcast server now, click Add Backup.

Another row is added. Notice that the fabric name is the same as the fabric you

selected. Topology Services displays the host name and module/port number of
the best candidate for the backup LE/Broadcast server as the default entry in the
Device column. You can accept this choice or click on the down arrow to select
another device.

Click Apply.

Notice that the Oper Status (operational status) column shows Not Configured.
This means that the backup LE/Broadcast server has not been configured yet.
After the configuration is updated on the switch, the status will change to
Configured and the Master State column will show Inactive/Backup.

After creating a new LE Broadcast Server, an entry for a standalone ATM VLAN
will immediately appear in the Standalone ATM VLANSs folder inside the
appropriate ATM fabric in the ATM Domains folder. To see the appropriate hybrid
ATM VLAN entry for the VLAN (under the appropriate VTP domain) for which
the LE Broadcast Server was created, you must first create a LAN Emulation
Client for the new ATM VLAN and rediscovery your network.

Figure 7-5 Add LANE Services Window
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Table 7-1 Add LANE Services Window Fields

Field Description

VTP Domain Topology Services automatically displays the
name of VTP domain that contains the associated
VLAN. This field is not modifiable.
In this scenario, San Jose is displayed.

VLAN Name Topology Services automatically displays the

name of the VLAN this ATM VLAN will be
associated with. This field is not modifiable.

In this scenario, VLAN?2 is displayed.

LE/Broadcast Server Configuration

ATM Domain

Topology Services automatically chooses and
displays the name of the ATM domain that this
LE/Broadcast server will belong to. The ATM
domain name is the same as the VLAN name.

In this scenario, VLAN?2 is displayed.

ATM-VLAN

ATM VLAN this LE/Broadcast server will belong
to.

Master State

Active/Master denotes a master LE/Broadcast
Server.

Inactive/Backup denotes an LE/Broadcast server
that is configured as a backup for the master
LE/Broadcast server.

Oper Status

The status denotes whether the LE/Broadcast
server is configured or not.
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Create LAN Emulation Clients (LECs)

You must create an LEC on each required ATM device that will participate in the
ATM-VLAN and map the VLAN to the ATM VLAN across the ATM interfaces
(LECs).

Campus Manager does not support these functions. You can do this in these two
ways:

e Manually through the device CLI.

e Automatically on some Cisco devices using VTP. (VTP performs this task
during the set-up of each VLAN within the network.)

Refer to the device Command Reference or Configuration guide for more
information about how to do this.

Rediscover the Network

If you want to view the changes you have made to your network before the next
automatically scheduled discovery cycle, perform a manual discovery that is
limited to the desired ATM domain.

To rediscover the ATM domain, perform these steps:

Step 1 Select Campus Manager > Topology Services > ATM Domains > and select
any ATM domain. In this case, you would select fabric-2.

Step2  Select View > Display View.
Step3  Select Edit > Select > All devices.

Step4  Then select Edit > Rediscover Device(s). The ANI Server begins rediscovering
only those devices that you have selected (those in the fabric-2 ATM domain).
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m. 78-6823-01 |



| Chapter7 Configuring and Monitoring LANE Services

Where You Should End Up—Verification W

Where You Should End Up—Verification

Step 1

Step 2
Step 3
Step 4

You have configured LANE components to your network and have added LANE
capability to VLAN 2. Now you need to make sure that they are correctly
configured and that the switches are operational (green icon on the topology
view).

To check this, display the LANE components in your network:

From the CiscoWorks2000 desktop, select Campus Manager > Topology
Services>Managed Views>VTP Domains>San Jose>VLAN 2.

Notice that a cloud icon has been added to the name to denote that the VLAN is
now an ATM-VLAN.

Select View>Display View.
In the Topology Filters window, select LANE.

Click the check boxes for LE Clients, LE/B’cast Server, and LE Config Server to
highlight switches with these components.
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