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CHAPTER

Working with Topology Maps

The Cisco ANA Monitoring Perspective provides views that allow you to perform operations on a group
of network elements. The topology map displays the status of the network elements and the connectivity
between them. The topology map is used as a general dashboard to view the network elements, their
status, the relationships between them, and the alarms that are raised on them.

You can create multiple topology maps to represent specific network views. Views can cover specific
network segments, customer networks, or any other mix of network elements desired. Once the maps
have been created, they are available for all connecting Cisco ANA clients.

The Cisco ANA Topology module allows you to:

View network inventory and multilayer connectivity.

Troubleshoot, monitor, and manage NEs.

Model and view topology maps.

Maintain up-to-date topological information of the network element connections and routes.

Add business attachments.

Cisco ANA provides functionality for displaying and managing the topology maps by providing:

Multiple concurrent maps per user.

Easily customizable hierarchy of nested submaps and NE aggregations with easy navigation up and
down the hierarchy.

Dual views of the network in a hierarchical tree, as well as in topological maps, including all
network connections.

NEs and links using color cues and graphic symbols to indicate status and alarms.

The tasks that you can perform using Topology are described in these sections:

Creating Static Links, page 5-6

Creating a Map, page 5-5

Opening a Topology Map, page 5-7

Adding a Network Element to an Existing Map, page 5-9
Finding the Network Elements in a Map, page 5-10
Renaming a Map, page 5-11

Deleting a Network Element from a Map, page 5-12
Aggregating the Network Elements in a Map, page 5-14
Renaming an Aggregation Node, page 5-15
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e Disaggregating the Network Elements in a Map, page 5-16

e Selecting a Map Layout, page 5-17
e Filtering Topology Links, page 5-18

e Viewing Network Element Properties, page 5-22

e Viewing Topology Link Properties, page 5-23
¢ Finding a Ticket Source, page 5-26
e Finding a Link Source, page 5-28

Understanding the Topology User Interface

Reviewers: Topology screen shots will be updated once the new icons are in the build (blue check

mark for normal, and so forth).

Figure 5-1 Topology User Interface

1 Network Domain drawer.

Topology file menu.

3 Map filename. The asterisk (*) in the
filename indicates that the map is not saved.

Aggregate node shown as a thumbnail.

5 Map workspace.

Topology local toolbar.
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7 Monitoring perspective.

8 Aggregate node shown as an icon.

9 Topology views: Overview and Outline.

Network Elements.

10 |Topology views: Link, Active Tickets, and

11 | View selection icon.

Related Topics
e Roles Required for Managing Maps

e Understanding Static and Dynamic Links
e Managing Maps
¢ Managing the Network Elements in a Map

Roles Required for Managing Maps

Table 5-1 lists the roles that are required for managing maps. For more information on roles, see Creating
and Managing Users, Passwords, and Scopes, page 14-32.

Table 5-1

Roles Required for Managing Maps

Task

Role Required

Creating a map

Configurator, Administrator

Creating static links

Configurator, Administrator

Opening a topology map

Viewer, Network Operator, Configurator,
Administrator

Adding a network element to an existing map

Configurator, Administrator

Finding the network elements in a map

Viewer, Network Operator, Configurator,
Administrator

Renaming a map

Configurator, Administrator

Deleting a network element from a map

Configurator, Administrator

Deleting a static link from a map

Configurator, Administrator

Deleting a map

Configurator, Administrator

Aggregating the network elements in a map

Configurator, Administrator

Renaming an aggregation node

Configurator, Administrator

Disaggregating the network elements in a map

Configurator, Administrator

Selecting a map layout

Network Operator, Configurator, Administrator

Filtering topology links

Configurator, Administrator

Viewing network element properties

Viewer, Network Operator, Configurator,
Administrator

Viewing topology link properties

Viewer, Network Operator, Configurator,
Administrator
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Table 5-1 Roles Required for Managing Maps (continued)

Task Role Required

Finding a ticket source Viewer, Network Operator, Configurator,
Administrator

Finding a link source Viewer, Network Operator, Configurator,
Administrator

Related Topics
¢ Understanding Static and Dynamic Links

e Managing Maps

e Managing the Network Elements in a Map

Cisco Active Network Abstraction 4.1 User and Administration Guide
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Understanding Static and Dynamic Links

The Cisco ANA Topology module enables you to manage the links between network elements and to add
a new static link between them.

A dynamic link is a link that is detected by Cisco ANA and connected automatically. A static link is a
link that you can manually create.

When adding a new link the state of the link reflects its current state. For example, if the operation status
of a port is down, the link is colored red.

For information on creating static and dynamic links, see:
e C(Creating Static Links, page 5-6
e Creating a Map, page 5-5

Managing Maps

These topics describe how to manage maps:
e Creating a Map, page 5-5
e Creating Static Links, page 5-6
e Opening a Topology Map, page 5-7
e Adding a Network Element to an Existing Map, page 5-9
¢ Finding the Network Elements in a Map, page 5-10
e Renaming a Map, page 5-11
e Saving a Map, page 5-11
e Deleting a Network Element from a Map, page 5-12
e Deleting a Static Link from a Map, page 5-13
e Deleting a Map, page 5-13

Creating a Map

Step 1
Step 2

You must create a new map, or open a map that was previously saved, to display the network. The
Cisco ANA Topology module supports the creation of multiple topology maps to represent specific
network views. The topology maps provide a graphic display of Alarm severity, network element
management state, and VNE state. See Network Element and Map Decorators, page G-2 to understand
the network element icons that are displayed in the map.

You can create a new map, and then add the network elements to the map. You cannot define the same
name for two or more maps.

To create a map:

In the Monitoring perspective, click the Task tab and select the Topology drawer.

Click New Network Domain. The Network Domain Name workspace is displayed.
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Step3  Enter a name for the map.

You can use alphanumeric values. The minimum map name length is 1 character and the maximum is 65
characters. The only special characters you can enter are an underscore (_) and dollar symbol ($).

Step4  Select the required network elements using the Network Element Selector and click Next. (You can
create a map without selecting any network elements. You can add the network elements after creating
a map.)

You can add a maximum of 999 network elements to a map.
The list of network elements that you have selected is displayed in the Summary workspace.
Step5  Click Finish.

See Opening a Topology Map, page 5-7 for information on opening maps.

Related Topics
e Roles Required for Managing Maps

¢ Understanding Static and Dynamic Links

¢ Opening a Topology Map

e Selecting a Map Layout

¢ Understanding Overview and Outline Views
e Managing Maps

e Managing the Network Elements in a Map

e Jcon Reference

Creating Static Links

When dynamic links are not visible in your topology map, you can create static links. You can create a
static link between network elements by selecting the two end ports of the network elements. You can

create a static link between two managed network elements. To create a static topological link, you have
to select the exact location of the two end ports (at both ends of the link).

The new link is validated after the two ports are selected but before the link is added. The Cisco ANA
Topology module validates the following:

e The similarity of the connector port types (for example, RJ45 on both sides).
e The Layer 2 technology type.

e The physical layer.

¢ The operation status of both ports.

¢  Whether one of the ports is part of another link.

To create a new static link:

Step1  In the Monitoring perspective, click the Object tab and select an existing map. The map appears in the
workspace.

Step2  Choose Topology > Topology Map Management > New Static Link. The Select A-Side and Z-Side
Device workspace is displayed.

Cisco Active Network Abstraction 4.1 User and Administration Guide
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Step 3

Step 4

Step 5

Select a network element in A-Side and Z-Side and click Next. The Select the Port in A-Side and Z-Side
Device workspace is displayed.

Select a port in the A-side and Z-side and click Next. The Summary workspace is displayed with the
network element and port details for A-side and Z-side.

Click Finish.

See Viewing Network Element Properties, page 5-22 and Viewing Topology Link Properties, page 5-23
for details on the element and link properties.

Related Topics
¢ Roles Required for Managing Maps

e (Creating a Map

e Opening a Topology Map

e Managing Maps

e Managing the Network Elements in a Map

e Jcon Reference

Opening a Topology Map

You can open a map that was previously saved. When you open the map, the network information is
automatically refreshed. For example, if a network element was up the last time that the map was saved
and closed, and then the network element is moved to maintenance state, the next time you open the map,
the management status of the network element is updated accordingly and the network element is
displayed in the maintenance state.
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Figure 5-2 Static and Dynamic Links

1 Outline view. See Understanding Overview |2 Map workspace.
and Outline Views, page 5-20 for more
information on Outline view.
3 Link view. 4 Detection Type column displays whether the
link is dynamic link or static link.

To open a topology map:

Step1  In the Monitoring perspective, click the Object tab.
The list of maps that are accessible to you is displayed in the Network Domain drawer.
Step2  Click a map. The map is displayed in the workspace.
If you have added a business tag to a network element, the business tag name is displayed instead of the
network element name in the topology map. See Defining Business Tags, page 6-1 to create business
tags.
The following color codes are used to display the map links:
¢ Green—Indicates the links are active. The links can be physical, data, or network links.

e Red—Indicates the links are down. You can review the Link view to troubleshoot the link.

e Blue—Indicates that the link has been selected.

Cisco Active Network Abstraction 4.1 User and Administration Guide
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If there are multiple links (for example, physical and Ethernet links) between network elements, these
links are represented in a single line. The A and Z ends of the links are displayed in the topology maps.
The details of these links are available in the Link view. See Viewing Topology Link Properties from the
Link View, page 5-25 for details on links.

After discovering the network, if the interfaces are disconnected, the physical link is still visible between
these interfaces. However, the alarm for Link Down connection is logged.

The topology map shows a different icon (a lock) for the network elements that are not within the scope
of the user. See Creating and Managing Users, Passwords, and Scopes, page 14-32 for information on
user access control.

To understand network elements representation, see Icon Reference, page G-1.

Related Topics
¢ Roles Required for Managing Maps

e Creating a Map

e Selecting a Map Layout

e Understanding Overview and Outline Views
e Managing Maps

e Managing the Network Elements in a Map

e Jcon Reference

Adding a Network Element to an Existing Map

To add a network element:

Step 1 In the Monitoring perspective, click the Task tab and select the Topology drawer.
Step2  Click Add Element to Network Domain. The Select Network Domain workspace appears.
Step3  Select a map and click Next.
Step4  Select a network element from the Select Elements to Be Added workspace and click Next.
You can add a maximum of 999 network elements to a map.
The list of network elements that you have selected is displayed in the Summary workspace.

Step5  Click Finish.

Related Topics
e Roles Required for Managing Maps

e Creating a Map

e Opening a Topology Map

e Selecting a Map Layout

¢ Understanding Overview and Outline Views

e Managing Maps

Cisco Active Network Abstraction 4.1 User and Administration Guide
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e Managing the Network Elements in a Map

e Jcon Reference

Finding the Network Elements in a Map

You can find the network elements based on the name or IP address that you entered in the Cisco ANA
database.

To find a network element in a map:

Step1  In the Monitoring perspective, click the Object tab.
Step2  Select a map.

Step3  Choose Topology > Topology Map Management > Find in Topology Map from the menu. The Enter
the Name of the Device dialog box appears.

You can enter either a complete or a partial NE name or IP address.
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Step4  Enter the network element name and click OK.

The network element name that you have entered is highlighted in the map workspace. If your search
criteria match more than one NE, you have to click OK multiple times to see all the NEs.

If the NE is inside an aggregate, the aggregate is expanded and the NE is highlighted.

Related Topics
¢ Roles Required for Managing Maps

e C(Creating a Map

¢ Opening a Topology Map

e Selecting a Map Layout

e Managing Maps

¢ Understanding Overview and Outline Views
e Managing the Network Elements in a Map

e Jcon Reference

Renaming a Map

A map name change affects all users of the map. The new name is displayed in the Network Domain
drawer.

To rename a map:

Step 1 In the Monitoring perspective, click the Object tab.

Step2  Select a map and right-click.

Step3  Select Rename Network Domain. The Rename Network Domain dialog box appears.
Step4  Enter the new name and click OK.

The new name is displayed in the Network Domain drawer.

Related Topics
e Roles Required for Managing Maps

e Creating a Map

e Opening a Topology Map

e Managing Maps

e Managing the Network Elements in a Map

e Jcon Reference

Saving a Map

You can save map layouts and change existing map layouts.

Cisco Active Network Abstraction 4.1 User and Administration Guide
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The following changes to the workspace are only saved when the Save option is selected:
e Addition or deletion of a network element.
e Addition or deletion of a link.
e Aggregation or disaggregation of elements.
e Renaming an aggregation.
¢ The location of the network elements on a map.
e The layout.
e Thumbnails.
e The size of the network elements.
The maps can then be opened later as required.
To save changes to a map, do one of the following:

¢ Go to File > Save. The map that is active in the map workspace is saved. (You can also use the
short-cut key, CTL+S.)

e Go to File > Save All. All of the maps that are opened in the map workspace are saved.

Related Topics
¢ Roles Required for Managing Maps

e C(Creating a Map

e Opening a Topology Map

e Adding a Network Element to an Existing Map
e Selecting a Map Layout

e Managing Maps

e Understanding Overview and Outline Views

e Managing the Network Elements in a Map

e Jcon Reference

Deleting a Network Element from a Map

To delete a network element:

Step 1 In the Monitoring perspective, click the Task tab and select the Topology drawer.
Step2  Click Delete Element from Network Domain. The Select Network Domain workspace appears.
Step3  Select a map and click Next.
Step4  Select a network element from the Select Elements to Be Deleted workspace and click Next.

The list of deleted network elements that you have selected is displayed in the Summary workspace.
Step5  Click Finish.

Related Topics
e Roles Required for Managing Maps

Cisco Active Network Abstraction 4.1 User and Administration Guide
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Creating a Map

Opening a Topology Map

Adding a Network Element to an Existing Map
Managing Maps

Managing the Network Elements in a Map

Icon Reference

Deleting a Static Link from a Map

Deleting a Map

Step 1

Step 2
Step 3
Step 4

Step 5
Step 6

Step 1
Step 2
Step 3

To delete a static link:

In the Monitoring perspective, click the Object tab.

Managing Maps

The list of maps that are accessible to you is displayed in the Network Domain drawer.

Click the map. The map is displayed in the workspace.

Choose Window > Show View > Links to enable the Link view.

Select the link in the map workspace.

The link properties are displayed in the Link view.

Select the static link and right-click.
Select Delete Static Link.

The static link is deleted from the map workspace and also from the Link view.

Related Topics

Roles Required for Managing Maps

Creating a Map

Opening a Topology Map

Adding a Network Element to an Existing Map
Creating Static Links

Managing Maps

Managing the Network Elements in a Map

Icon Reference

To delete a map:

In the Monitoring perspective, click the Object tab.

Select a map and right-click.

Select Delete Network Domain.
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The map is deleted from the Network Domain drawer.

Related Topics
e Roles Required for Managing Maps

e Creating a Map

¢ Opening a Topology Map

e Managing Maps

¢ Managing the Network Elements in a Map

e Jcon Reference

Managing the Network Elements in a Map

These topics describe how to manage the network elements within a map:
e Aggregating the Network Elements in a Map, page 5-14
e Renaming an Aggregation Node, page 5-15
e Disaggregating the Network Elements in a Map, page 5-16
e Selecting a Map Layout, page 5-17
¢ Filtering Topology Links, page 5-18
e Viewing Network Element Properties, page 5-22
e Viewing Topology Link Properties, page 5-23
¢ Finding a Ticket Source, page 5-26
¢ Finding a Link Source, page 5-28

Aggregating the Network Elements in a Map

Step 1
Step 2
Step 3
Step 4

Step 5

To aggregate the network elements in a map:

In the Monitoring perspective, click the Object tab.
Select a map. The network elements of the selected map are displayed in the map workspace.
Select the required network elements in the map workspace using <Ctrl> or the selection tool.

Choose Topology > Topology Map Management > New Aggregation from the menu. The New
Aggregation dialog box appears.

Enter the name for the aggregation and click OK.

The aggregated node is displayed in the map workspace. Aggregated nodes are displayed as a single
entity with the Aggregation icon. The aggregation node is appended with the alarm severity.

For example, the aggregation name SampleAggregation, appended with the alarm severity, results in the
name SampleAggregation [SM+]. This indicates that the aggregation has five major severity alarms. The
plus sign indicates that there are additional alarms of less severity associated with this aggregation.
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See Network Element and Map Decorators, page G-2 for information on alarm severity icons.

Related Topics
e Roles Required for Managing Maps

e Creating a Map

¢ Opening a Topology Map

¢ Adding a Network Element to an Existing Map
e Saving a Map

e Selecting a Map Layout

e Managing Maps

¢ Understanding Overview and Outline Views

e Managing the Network Elements in a Map

e Jcon Reference

Renaming an Aggregation Node

To rename an aggregation node:

Step 1 In the Monitoring perspective, click the Object tab.
Step2  Select a map. The network elements of the selected map are displayed in the map workspace.

Step3  Select the required aggregation node.

Cisco Active Network Abstraction 4.1 User and Administration Guide
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Stepd  Select Topology > Topology Map Management > Rename Aggregation from the menu. The Rename
Aggregate dialog box appears.

Step5  Enter the name for the aggregation and click OK.

The renamed aggregated node is displayed in the map workspace.

Related Topics
¢ Roles Required for Managing Maps

e C(Creating a Map

e Saving a Map

e Managing Maps

e Selecting a Map Layout

e Managing the Network Elements in a Map
e Understanding Overview and Outline Views

e Jcon Reference

Disaggregating the Network Elements in a Map

To disaggregate an aggregation node:

Step 1 In the Monitoring perspective, click the Object tab.
Step2  Select a map. The network elements of the selected map are displayed in the map workspace.
Step3  Select the required aggregation node.

Stepd  Choose Topology > Topology Map Management > Disaggregate from the menu. A confirmation
dialog box appears.

Step5  Click OK. The disaggregated network elements are displayed in the map workspace.

Related Topics
e Roles Required for Managing Maps

e Creating a Map

e Saving a Map

e Managing Maps

e Aggregating the Network Elements in a Map
e Understanding Overview and Outline Views
e Selecting a Map Layout

e Managing the Network Elements in a Map

e Jcon Reference
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A map contains network element names, icons, and decorators. You can select different map layouts and
different map views of the network elements using the selection tools in the map workspace.

For information on network element decorators, see Network Element Icons, page G-1.

Table 5-2 Topology Map Tool Buttons
Icon Tooltip Description
Layout Defines the way in which the map is displayed in the map

workspace; for example, Circular, Tree, Hierarchical, or
Symmetric.

Zoom Selection

Activates the zoom selection mode, which enables you to select
an area in the map workspace to be enlarged by clicking and
dragging to view the selected area.

Use this tool when there are many network elements in the map
and you want to view a particular network element name and
decorators clearly.

Zoom In

Zooms in on the topology map.

This tool increases the visibility of the network element names
and decorators in the map. The size cannot be increased beyond
a certain scale. Cisco ANA supports graphical zoom and not
textual zoom.

Zoom Out

Zooms out of the topology map.

This tool decreases the visibility of the network element names
and decorators in the map. The size cannot be decreased beyond
a certain scale. Cisco ANA supports graphical zoom and not
textual zoom.

Normal Selection

Activates the normal selection mode.

s
{m;l Pan Activates the Pan mode, which enables you to move around in
the map workspace by clicking and dragging.
To deselect the Pan icon, click the Normal Selection icon.
|E| Fit In Window Fits the entire subnetwork or map in the map workspace.
] Resize Enables you to resize the NE in the map workspace. By default,
Lo the NE size is medium.
* Small—Reduces the size to 50% from the standard size.
e Medium—Displays the standard size.
e Large—Increases the size to 200% from the standard size.
:-.-: New Aggregation |Enables you to aggregate network elements.

See Aggregating the Network Elements in a Map, page 5-14 for
more details.
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Table 5-2 Topology Map Tool Buttons (continued)

Icon Tooltip Description

T8 Disaggregate Enables you to disaggregate an aggregate node.
Lk ]

See Disaggregating the Network Elements in a Map, page 5-16
for more details.

E Show Aggregation |Enables you to look into an aggregation node in the map,
as Thumbnail including all of the aggregated elements. Thumbnails can also be
nested. This is activated only if you select an aggregation node.

This tool displays the child map (aggregated node) in the context
of the parent map. You can display the child map as the main
display map by double-clicking anywhere inside the thumbnail
bounding box region.

You can double-click anywhere in the map workspace to
navigate to the parent map. You can also use the Go to Parent
icon to navigate to the parent map.

Topology Map Enables you to filter the links.

Filter See Filtering Topology Links, page 5-18 for more details.

Go to Parent Enables you to navigate to the parent of the map. This is
activated only if you have opened the child map (aggregated
node) as the main display map.

(] [

Use this tool when you have multiple levels of aggregation and
you want to navigate to the parent of the aggregation.

[Il Go to Root Enables you to navigate to the root of the map. This is activated
only if you have opened the child map (aggregated node) as the
main display map.

Use this tool when you have multiple levels of aggregation and
you want to navigate to the root of the aggregation in a single
click.

{f Find in Topology Enables you to find the network elements in a topology map.

Map See Finding the Network Elements in a Map, page 5-10 for more

details.

Related Topics
e Roles Required for Managing Maps

e Managing Maps
e Managing the Network Elements in a Map
e Understanding Overview and Outline Views

e Jcon Reference

Filtering Topology Links

The links filter enables you to filter the links displayed in the map workspace.
To filter the topology links:
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Step1  In the Monitoring perspective, click the Object tab.
Step2  Select a map. The network elements of the selected map are displayed in the map workspace.
Step3  Choose Topology Map Filter from the icons menu. The Map Options dialog box appears.
Step4  Select a map option from the drop-down list:

e All—Displays physical, data-link, and network layer links.

e Physical Layer—Displays physical layer and Ethernet links.

e Data-Link Layer—Displays PPP links.

e Network Layer—Displays MPLS and IP links.
Step5 Click OK.

The appropriate links are displayed in the map workspace. See Viewing Topology Link Properties,
page 5-23 for more information on link properties.

Related Topics
e Roles Required for Managing Maps

e Managing Maps

e Managing the Network Elements in a Map
e Selecting a Map Layout

e Understanding Overview and Outline Views

e Jcon Reference

Cisco Active Network Abstraction 4.1 User and Administration Guide
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Understanding Overview and Outline Views

When you open a topology map, the Overview and the Outline views are displayed automatically. See
Figure 5-1Topology User Interface, page 5-2.

Figure 5-3 Topology Overview View

1 Overview view. Select the blue outline to 2 Map workspace. The selected area in the
zoom in on the map. Overview view is zoomed in in the
workspace.

The Overview view shows a scaled down version of the map that is displayed in the map workspace. The
selected area in the Overview view is zoomed in on the map workspace. This feature is useful in
navigating large maps.
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Figure 5-4 Topology Outline View

1 Outline view lists the network elements in |2 Select in Map option is used to find a
the map. network element in the map.

The Outline view shows all the network elements that are part of the selected map. The map name
represents the node for all the network elements available in the map. From this view, you can:

e View the severity of the tickets. The map name and the network element are appended with the alarm
severity.

For example (see Figure 5-4):

— The map name ANATopo, appended with the alarm severity, results in the name ANATopo
[2M+]. This indicates the total number of highest severity alarms for this map. [2M+] indicates
that there are two major severity alarms in the map. The plus sign indicates that there are
additional alarms of less severity associated with this map.

— The network element name 192.168.10.10, appended with the alarm severity, results in the name
192.168.10.10 [2M+]. This indicates that the network element has two major severity alarms.
The plus sign indicates that there are additional alarms of less severity associated with this
network element.

See Network Element and Map Decorators, page G-2 for information on alarm severity icons.

¢ Find a network element in the map by right-clicking and selecting Select in Map. The selected
network element is highlighted in the map workspace.
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e View the network element property by clicking the NE. The network element property is opened in
the Properties view. To enable the Properties view, choose Window > Show View > Properties.

See Viewing Network Element Properties, page 3-4 for information on NE properties.
e View the network element properties in the Inventory perspective by clicking the NE.

See Viewing the Network Element Inventory, page 3-3 for information on NE properties and
inventory.

Viewing Network Element Properties

The Network Elements view displays network element properties in the selected map. You can launch
the following applications from this view:

e Launch Soft Property Builder. See Customizing Network Element Information Using Soft Property
Builder, page A-1.

¢ Command Builder. See Managing and Deploying Configuration Changes, page 8-1.

¢ Set Network Element Management State. See Viewing Network Element Management States and
Inventory, page 3-1.

¢ Network Element Image Management. See Managing Software Images, page 9-1.
¢ Business tag. See Defining Business Tags, page 6-1.
¢ Config Archive. See Archiving and Managing Configuration Files, page 7-1.

To view the network element properties in a map:

Step 1 In the Monitoring perspective, click the Object tab.
The list of maps that are accessible to you is displayed in the Network Domain drawer.
Step2  Click the map. The map is displayed in the workspace.

Step3  Choose Window > Show View > Network Elements to enable the Network Elements view.
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All the network elements that are available in the map are displayed in the Network Element view:

Property Description

Device Name Element name provided by you while adding a VNE in Cisco ANA.
IP Address Management IP address of the element.

System Name System name taken from MIB II (RFC 1213).

Communication State Displays whether the VNE can reach the network element it represents; the communication state
can cause a change in the investigation state. There are two Communication states: reachable and
unreachable.

See VNE States (Investigation and Communication States), page 2-17 for more information.

Investigation State Displays the level of network element discovery that has been performed, or is being performed,
by the VNE. The Investigation states are Unknown, Initializing, Modeling in progress, Normal,
Preparing for maintenance, Maintenance, Sync in progress, Shutting down, Incomplete, and

Unsupported.
See VNE States (Investigation and Communication States), page 2-17 for more information.
Category Element category (Unknown, DSLAM, Switch, Router, and so on).
Element Type Element type mapped by the registry based on the SNMP system OID.
Vendor Vendor identity (Null, Alcatel, Cisco, Redback Networks, ECI Telecom, and so on).
Up Since Time at which this network element became activated.
Location Location taken from MIB II (RFC 1213).

Related Topics
e Roles Required for Managing Maps

e Managing Maps

e Managing the Network Elements in a Map
e Viewing Physical Inventory Properties

e Viewing Logical Inventory Properties

e Jcon Reference

Viewing Topology Link Properties

You can view the topology link properties in two ways:
e Viewing Topology Link Properties from the Map Workspace, page 5-23
e Viewing Topology Link Properties from the Link View, page 5-25

Viewing Topology Link Properties from the Map Workspace
To view the topology link properties:

Step 1 Select a link in the map workspace.
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Step2  Right-click and choose Properties.

The Properties context menu is enabled only if there is a single link between NEs. If there are multiple
links between NEs (for example, physical and Ethernet links) the Properties context menu is not enabled.
The A and Z ends of the links are displayed in the topology maps. These links details are also available
in the Link view. See Viewing Topology Link Properties from the Link View, page 5-25 for details on
links.
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The Link properties are displayed in the workspace:

Property Description

A End-Point Displays the source of the topology link between network elements.

Z End-Point Displays the destination of the topology link between network elements.

Link Type Displays the link type: Physical layer, Ethernet, PPP, MPLS, or IP.

Detection Type Displays whether the link is dynamic link or static link.

BiDirectional Displays whether the link is a bidirectional link. The values can be either
True or False.

Viewing Topology Link Properties from the Link View
To view the topology link properties:

Step1  In the Monitoring perspective, click the Object tab.

The list of maps that are accessible to you is displayed in the Network Domain drawer.
Step2  Click the map. The map is displayed in the workspace.
Step3  Go to Window > Show View > Links to enable the Link view.

Cisco Active Network Abstraction 4.1 User and Administration Guide
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All the links that are available in the map are displayed in the Link view:

Property

Description

Severity

Displays a severity icon, which is colored according to the severity of
the alarm on the link. This indicates the impact of the alarm on the
network.

e Red: Critical

e Orange: Major

e Yellow: Minor

e Sky Blue: Warning

e Green: Cleared, normal or OK
e Dark Blue: Information

e White: Indeterminate

See Tracking Faults, page 12-1 for more details on alarms.

A End-Point

Displays the source of the topology link between network elements.

Z End-Point

Displays the destination of the topology link between network elements.

Link Type

Displays the link type: Physical layer, Ethernet, PPP, MPLS, or IP.

Detection Type

Displays whether the link is dynamic link or static link.

BiDirectional

Displays whether the link is a bidirectional link. The values can be either
True or False.

Related Topics

e Roles Required for Managing Maps

e Managing Maps

e Managing the Network Elements in a Map

e Jcon Reference

Finding a Ticket Source

You can find the source of a ticket displayed in the Active Tickets view. See Tracking Faults, page 12-1

for more details on alarms.

Step 1 Go to Window > Show View > Active Tickets to enable the Active Tickets view.

Step2 In the Monitoring perspective, click the Object tab.

Step3  Select a map. All the tickets that are applicable to the selected map are displayed in the Active Tickets

view.

Stepd  Select a ticket in the Active Tickets view.

Cisco Active Network Abstraction 4.1 User and Administration Guide



| Chapter5 Working with Topology Maps

Managing the Network Elements in a Map ||

DRAFT - 31 MAY 2008 - CISCO CONFIDENTIAL

Step5  Right-click and choose Find Source. The source of the ticket is highlighted in the map workspace.

Related Topics
e Roles Required for Managing Maps

e Managing Maps
e Managing the Network Elements in a Map

e Jcon Reference
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Finding a Link Source

To find a link source:

Step 1 Go to Window > Show View > Links to enable the Link view.

Step2  In the Monitoring perspective, click the Object tab.

Step3  Select a map. All the links that are applicable to the selected map are displayed in the Links view.
Step4d  Select a link in the Links view.

Step5  Right-click and choose Find Link Source. The source of the ticket is highlighted in the map workspace.

Related Topics
e Roles Required for Managing Maps

e Managing Maps
e Managing the Network Elements in a Map
e Selecting a Map Layout

e Jcon Reference
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