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Cisco ANA Overview

The following topics will introduce you to the Cisco Active Network Abstraction (Cisco ANA) product. 
These topics explain what Cisco ANA is, how you can use it to manage your network resources, and how 
Cisco ANA differs from other network and element management systems. These topics also introduce 
you to terms with which you should become familiar, and how they make up the Cisco ANA architecture. 
Finally, you will be introduced to the perspectives provided in the Cisco ANA user interface. 

• What Is Cisco ANA?, page 1-1

• How You Can Use Cisco ANA, page 1-2

• Cisco ANA Architecture, page 1-5

• Getting Started, page 1-6

• Using the Cisco ANA UI, page 1-7

If you have already installed Cisco ANA and performed the necessary setup tasks, you can proceed to 
Cisco ANA Administration, page 13-1.

What Is Cisco ANA?
Paola: Please let me know if the references to multivendor devices are okay, or if you want me to 
“downplay” them more.

Cisco ANA is a resource management platform that serves as an active mediation layer between the 
operation and network layers. It provides a set of easy-to-use applications and well-defined APIs for 
Operations Support Systems (OSS). Cisco ANA enables service providers to efficiently respond to the 
constant market demand for new, reliable, and more complex services, while hiding the complexity of 
large, multivendor, mixed technology networks. 

Cisco ANA can manage diverse network environments. It offers an integrated process for network 
modeling, intelligent fault analysis, and a highly flexible network configuration and activation engine. 
This enables fully correlated management of global scale networks that need to support millions of 
subscribers and customers.

Cisco ANA is a network management system that provides a fully integrated, service-oriented offering 
including:

• Multivendor network element support (physical components that can be managed through an 
IP address)

• Mixed technologies (IP, Ethernet, and so on)
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• Multiple functions (network discovery, fault, activation, and configuration)

• Standards-based Northbound Interfaces (NBIs) that provide integration with assorted OSS and 
Business Support Systems (BSS) applications

Based on a patented architecture of distributed autonomous virtual network elements (VNEs), Cisco 
ANA enables integration management for multivendor, multitechnology network environments, while at 
the same time scaling according to network growth and evolution. (For a description of VNEs, see Cisco 
ANA Architecture, page 1-5.)

Cisco ANA hides the complexity of large, multivendor, mixed technology networks while allowing you 
to constantly modify your network in response to the constant market demand for new, reliable, and more 
sophisticated services. The user interface (UI) provides a normalized view of network elements and the 
network, masking differences and nuances of diverse network element types and vendors. This makes it 
easier to view the status, control the configuration, and manage the state of the network and intranetwork 
element operations. 

How You Can Use Cisco ANA
The Cisco ANA GUI client applications help you to manage assurance, configuration, and performance 
of your network. Cisco ANA provides standards-based northbound APIs for support integration with 
OSS and BSS applications. The APIs include a Web Service-based API for inventory, provisioning, and 
fault OSS integrations.

Cisco ANA also provides an SNMP trap forwarding API that provides the ability to send traps to fault 
management OSS applications. It is a fully distributed solution that implements parallel processing by 
creating a virtual model of the network. Your network can continue to grow as you add more autonomous 
VNEs and units to support network growth.

The following sections describe the main Cisco ANA functionalities.

Network Topology and Inventory

Cisco ANA provides views of network topology and inventory information for all network elements 
being managed.

A discovery program can be used to query the network using networking technologies and seed devices. 
Seed devices are the discovery program’s initial point of contact, from which the program discovers all 
network elements. The program then creates a seed file that is used to populate the Cisco ANA system 
with the information it needs to manage the network elements. 

After the network elements are managed, Cisco ANA further discovers network topology and the logical 
inventory of the network and network elements. You can then browse both the physical and logical 
inventories and view the topology. 

Cisco ANA provides rich functionality to display and manage topology by providing:

• Multiple technology topologies combined into a single view per user-created network domain.

• Easy-to-create network domain maps that support network element aggregations and business tags 
with easy navigation through the network domains.

• Dual views of the network in a hierarchical tree, as well as in topology maps, including all network 
connections.

• Network elements and links using color cues and graphic symbols to indicate status and alarms.

• Mouse point-and-click drill-down for every network element (either from the tree or from the 
topology map), providing detailed internal physical and logical inventory information.
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Administrators can create multiple network domain maps in order to represent specific network and 
topology views. These network domains can cover specific network segments, customer networks, or 
any mix of network elements desired. After the network domain maps have been created, they are 
available for all connecting clients (based on user privileges). Cisco ANA supports Cisco network 
elements, along with network elements from multiple vendors, across multiple technologies, forming a 
unified, end-to-end representation of the network. Cisco ANA also supports Layer 1 to Layer 3 
topologies. 

If you have installed [Assurance Manager product TBD], you can use Cisco ANA Service Path Trace 
to perform end-to-end route tracing. After Cisco ANA Service Path Trace receives a path's start and 
endpoint, it visually traces the route through the network. For more information about Cisco ANA 
Service Path Trace, see [Assurance Manager product docs].

Using the Soft Property Builder, you can extend and customize the set of supported properties for each 
network element by adding new soft properties to the VNEs. These properties extend the Cisco ANA 
model and are available through the GUI client.

In addition, alarm thresholding enables you to constantly monitor selected properties and generate an 
alarm every time a network element crosses a user-defined threshold or violates a condition. For more 
information on Soft Properties, see Customizing Network Element Information Using Soft Property 
Builder, page A-1.

You can also use APIs to provide physical and logical inventory information to northbound systems, 
including setting business tags, providing topology links, and subscribing to inventory change 
notifications.

Faults

Jitendra: Please let me know what of the following should be removed, given what has been taken 
out of 4.1.

Cisco ANA detects and identifies faults in the network using a combination of traps, syslogs, and 
heartbeat-type polling (polling performed at specified, fixed intervals) of the network elements. After 
interpreting these events and applying correlation rules, Cisco ANA uses the Ticket Browser and the 
Alarm and Event viewers to display active alarms in the network.

In addition, alarm status is propagated to the representation of the network element in the Object Tree 
View and network domain maps.

The following terms are central to Cisco ANA fault management:

• Events—An event is an indication of a distinct occurrence that manifests itself at a specific point in 
time. Events are derived from incoming traps, syslog notifications, and detected status changes.

• Alarms—An alarm represents a scenario, which involves a fault occurring in the network or 
management system. Alarms represent the complete fault lifecycle, from the time the alarm is 
opened (when the fault is first detected), until it is closed and acknowledged.

• Tickets—A ticket represents the complete alarm correlation tree of a specific fault scenario. A ticket 
can also be identified by the topmost “root of all roots” alarm. Cisco ANA displays tickets and 
allows drilling down to view the consequent alarm hierarchy. For an operator, the managed entity is 
always a complete ticket. Operations such as Acknowledge, Clear, or Remove are always applied to 
the entire ticket. The ticket also assumes the overall propagated severity.

When an alarm is raised, Cisco ANA correlates it using the network topology and inventory to determine 
the alarm’s root cause, and analyzes the network elements to locate any elements that may be impacted 
by the alarm.
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Cisco ANA removes duplicate alarms that result from the same cause. A ticket is identified by the 
top-most alarm. When you view a ticket in the Cisco ANA user interface, you can drill down to review 
the consequent alarms. For more information, see Tracking Faults, page 12-1.

For northbound systems, you can forward Cisco ANA events in SNMP V1and V2 trap format and 
subscribe to event and ticket notifications across the Web Service-based API.

Configuration

Cisco ANA configuration components provide the ability to monitor and make changes to network 
elements. Configuration components include:

• Configuration Archive—Allows you to automatically back up and store network element 
configurations. These configurations can be retrieved and compared for differences, and any saved 
copies can be restored to the network element on demand.

• Command Builder—Template-based configuration tool that guides you through the process of 
creating activation scripts to make physical and logical configuration changes on a network element. 
For more complex tasks, you can also create workflows of tasks, calling multiple activation scripts 
to perform configuration changes on multiple network elements. You can run activation scripts 
sequentially, in parallel, on demand, or at a scheduled time. Workflows are stored on the gateway, 
where you can check workflow properties and status.

• Network Element Image Manager (NEIM)—Provides a repository for network element images, and 
then assists you in the analysis, distribution, and activation of those images on network elements. 
You can also deactivate and, for certain devices, roll back your changes. NEIM is currently only 
available for Cisco and Redback devices. For Supported Cisco and Redback devices, see Cisco 
Active Network Abstraction VNE Reference.

Performance

You can use Cisco ANA to perform on-demand collections of performance statistics, and then display 
them in the inventory. You can extend and customize the data that is collected for different network 
elements using the Soft Property Builder. You can also customize alarm thresholds to monitor selected 
properties and generate an alarm every time a network element crosses a user-defined threshold or 
violates a condition. 

Administration

The system provides infrastructure software and tools for scheduling jobs, logging, auditing, backing up 
and restoring data on the Solaris gateway server, and managing licenses. Administrators can create users 
and control permissions by assigning these users a combination of predefined roles and scopes:

• A role defines a set of permissions and restricts the actions a user is allowed to take. The following 
predefined roles exist in Cisco ANA: Viewer, Network Operator, Configurator, and Administrator.

• A scope is a named group of managed network elements. Scopes are used to define network subsets 
that certain Cisco ANA users are authorized to access. A Cisco ANA user account can be assigned 
different roles for different scopes.

Cisco ANA also provides a high availability mechanism to protect the system in case a unit malfunctions. 
If the unit is configured for high availability (by being assigned to a protection group), Cisco ANA 
switches over to the standby unit, with no loss of information to the system. 
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Cisco ANA Architecture
Figure 1-1 illustrates the Cisco ANA platform’s three-layer architecture.

Figure 1-1 Cisco ANA Architecture

First Layer

The top layer comprises the commercial and legacy OSS and BSS applications, as well as the Cisco ANA 

clients. The Cisco ANA solution enables OSS and BSS applications to integrate with the platform, via a 
set of well-defined, standards-based APIs.

Second Layer

The second layer comprises the gateway server, through which all the OSS and BSS applications and 
Cisco ANA GUI clients access the Cisco ANA fabric. Each client connects to its designated gateway. 
The gateway acts as the portal through which all clients, including any OSS and BSS applications, access 
the system. It enforces access control and security for all connections and manages client sessions.

The gateway server maintains a repository for keeping system settings, topological data, and snapshots 
of active alarms and events. Another important function of the gateway is to map network resources to 
the business context. This enables Cisco ANA to contain information (such as VPNs and subscribers) 
that is not directly contained in the network and display it to northbound applications. 

The gateway also contains the alarms and events in the system. For information on managing the 
gateway, see Managing the Gateway, page 2-1.
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Third Layer

The third layer comprises the interconnected fabric of unit servers. Each unit manages a group of 
network elements. The units are distributed in a way that ensures proximity to their network elements. 
The gateway is connected to the units, which host the autonomous VNEs.

The units are interconnected to form a fabric of VNEs, which can intercommunicate with other VNEs 
regardless of which unit they are running on. Each unit can host thousands of autonomous VNE 
processes, depending on the server system size and VNE type. 

Cisco ANA also provides a high availability mechanism to protect the system in case a unit malfunctions. 
If the unit is configured for high availability, Cisco ANA switches over to the redundant standby unit, 
with no loss of information. For more information about high availability, see Managing Protection 
Groups and High Availability, page 13-9. For information on managing units, see Managing Units (and 
High Availability), page 2-4.

Within the units are AVMs. AVMs are Java processes that provide the necessary distribution support 
platform for executing and monitoring multiple VNEs. AVMs and VNEs should reside on a Cisco ANA 
unit (as a common configuration) but they can also reside on a Cisco ANA gateway. For information on 
managing AVMs, see Managing AVMs, page 2-9.

The VNEs are the entities that maintain a live model of each network element and of the entire network. 
A VNE is a software entity that runs as a completely autonomous process within a Cisco ANA unit. Each 
VNE is assigned to manage a single network element instance, and contains a replica of that element. 
The VNE uses whatever southbound management interfaces the network element implements (for 
example, SNMP or Telnet). For information on managing VNEs, see Managing VNEs, page 2-16.

Getting Started
To view network elements using the Cisco ANA user interface, you must do the following:

Note Administrators normally add network elements and create user accounts. 

1. Add the network elements to the Cisco ANA system so Cisco ANA can manage them. You can use 
the following methods:

– Run discovery based on a seed file. See Using Network Discovery to Add Bulk VNEs, 
page 2-27. 

– Add network elements using the user interface. See Managing VNEs, page 2-16.

2. To allow others to use Cisco ANA, configure users and scopes. See Creating and Managing Users, 
Passwords, and Scopes, page 13-34. Even though users with restricted privileges cannot use the 
Troubleshooting perspective, they can view Active tickets and perform most troubleshooting tasks 
from the Inventory and Monitoring perspectives.

Note The Cisco ANA “root” user account is used internally by multiple Cisco ANA components. This 
user account may become overloaded if you use it to log into the Cisco ANA GUI client; it may 
cause timeout-related issues that could affect system behavior. Cisco recommends that you 
create multiple superuser accounts and avoid using the root user account.

3. Create at least one network domain map that includes the elements you added, so you can view the 
elements using the Monitoring perspective. See Working with Topology Maps, page 5-1.
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Once you have added network elements and created a network map, you can begin monitoring your 
elements, viewing tickets, getting details about network elements, and so forth. 

The following list gives examples of other tasks you may want to perform, and the topics in which they 
are described.

Using the Cisco ANA UI
These topics describe basic guidelines for using the Cisco ANA UI (the GUI client). The GUI client 
connects directly to JBoss on the gateway. If JBoss goes down, the GUI client will not receive any 
information from the gateway, even if all AVMs are running normally. If you have problems with the 
GUI client, check the JBoss process (see Checking Basic System Health (CPU, Memory, JBoss), 
page 14-7).

If you want to... See...

Check the overall status of your network elements Opening a Topology Map, page 5-7

Check the status of individual network elements Working with Topology Maps, page 5-1

Customize the Inventory perspective for your 
needs

Customizing the UI, page 1-21

Generate a report of the entire inventory Creating an Inventory Report, page 5-2

Change or update software images on network 
elements

Managing Software Images, page 9-1

Back up and restore network element 
configurations on an automated basis

Archiving and Managing Configuration Files, 
page 7-1

Find out what changes occurred on a network 
element configuration by generating a comparison 
report

Comparing Configuration Files, page 7-10

Get details about a specific network element’s 
inventory

Viewing the Network Element Inventory, 
page 3-1

Change the credentials Cisco ANA uses to 
communicate with network elements, or 
unmanage an element

Viewing and Editing VNE Properties and 
Schemes, page 2-43

Configure a network element using activation 
scripts 

1. Creating User-Defined Commands, page 8-8

2. Running a Command, page 8-13

Apply an existing activation script to other 
network elements

Using the Workflow Editor to Create Task 
Workflows, page C-1

Configure Cisco ANA to raise an alarm when a 
network element attribute crosses a specific 
threshold

Creating or Editing a Soft Property, page A-5

Check the performance of the Cisco ANA system Cisco ANA System Health and Diagnostics, 
page 14-1

Manage licenses Cisco Active Network Abstraction 4.0 Installation 
and Setup Guide
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Refer to these topics for more information on the user interface:

• Perspectives, page 1-8—Provides an overview of the user interface layout and introduces you to the 
four Cisco ANA perspectives.

• Navigating the User Interface, page 1-14—Explains how to navigate within perspectives and 
describes UI elements that are common to most perspectives (Objects and Tasks tabs, search 
function, device selector, filter function, online help). This topic also explains how to customize 
your user interface.

Reviewers: Per PRD23, is automatic update disabled by default?

If a GUI client update is installed on the gateway server, the update can be automatically downloaded to 
all GUI client sessions when users subsequently log in. If auto-update is enabled, the GUI client detects 
the availability of new software, installs it, and prompts the user to log into the client again. Auto-update 
is disabled by default. Administrators can enable this auto-update feature as described in Installing 
Updates and Patches, page 13-50.

Perspectives
Related functions are grouped together in the different Cisco ANA perspectives. For example, the 
Monitoring perspective provides the functions you need to get the overall status of your network 
resources. If a problem arises, you can get detailed information about the problem from the 
Troubleshooting perspective. If you want more information on the configuration of a specific network 
element, you can go to the Inventory perspective. If you need to perform any administration tasks, you 
go to the Administration perspective.

All Cisco ANA perspectives conform to the structure shown in Figure 1-2. How the instance of a 
perspective actually looks depends on what you have selected or the function you are performing, what 
is installed, and whether you have changed or customized the user interface. 

Note Use Window > Reset Perspective to return a perspective to its default layout.
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Graphic will be updated. (Note to writer: add callout for garbage collector/communication area.)

Figure 1-2 Structure of Cisco ANA Perspectives

The icon at the bottom of the window indicates the state of the client connection with the gateway server. 
If the GUI client loses its connection to the gateway server, the GUI client displays the icon shown in 
Figure 1-2. When the connection is reestablished, Cisco ANA prompts you to log back in to the client.

Figure 1-3 GUI Client Disconnect Indicator

If there is no client activity for a period of time, the GUI client session is locked (normally after 
30 minutes). Before terminating the session, the GUI client displays a dialog box that warns you of the 
impending disconnection and the time remaining until you are logged out (by default, an additional 
30 minutes). If you do not reauthenticate, the session is terminated, unsaved changes are lost, and a 
dialog box reports that you were logged out. Administrators define both the client inactivity (lock out) 
and log out periods when they create user accounts. (For more information, see Creating User Accounts, 
page 13-36.)

1 Main menu and toolbar 4 Workspace and corresponding toolbar

2 Navigation area and corresponding toolbar 5 Perspective selector bar

3 Supporting views and their local toolbars 6 GUI client/server communication status area
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The numbers (18M of 508M) indicates the amount of the allocated Java heap that is currently in use. 
Clicking the garbage icon forces garbage collection. However, you do not have to manually perform 
collection, because Cisco ANA does it automatically.

The perspective selector bar is at the top right of the Cisco ANA window. The selector bar displays the 
name (and representative icon) of the perspective that is currently active, as shown in Figure 1-4. 

To open a new perspective, click the icon to the left of the current perspective’s name (as shown in 
Figure 1-4), and choose another perspective. You can also select a perspective by choosing 
Window > Open Perspective from the main menu.

Figure 1-4 Opening a New Perspective

Once you have opened several perspectives, you can extend the perspective selector bar so it displays 
shortcuts to the perspectives. Click-drag the perspective selector bar to the left until all perspectives are 
displayed. 

Monitoring Perspective

The Monitoring perspective displays topological network data—a “big picture” view—of elements and 
their relationships. Icons and colors indicate element types and states. Administrators can create network 
domains and maps to provide specific network views (specific network segments, customer networks, 
and so forth). The tickets and events displayed in this window are similar to those displayed in the 
Troubleshooting perspective, but with limited operations. You can use this perspective to create static 
links between elements. You can also launch reports and check on jobs using this perspective.
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Figure 1-5 Monitoring Perspective

To enable users to see a topological view in this perspective, administrators must first add some network 
elements to Cisco ANA so they can be managed, and then create a network domain map containing those 
elements. For more information on using the Monitoring perspective, see Working with Topology Maps, 
page 5-1.
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Inventory Perspective

You can use the Inventory perspective to view individual network elements and perform task-based flows 
on network elements or specific tasks on specific elements. The tickets and events displayed in this 
window are similar to those displayed in the Troubleshooting perspective, but with limited operations.

Figure 1-6 Inventory Perspective

For information on using the Inventory perspective, see Viewing Inventory and Network Element 
Management States, page 3-1.
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The Troubleshooting perspective provides tasks and views to help monitor network health and manage 
the network and network elements when problems occur. In addition to troubleshooting network and 
network element problems, you can also use this perspective to troubleshoot user and application 
problems. Most tasks are restricted to users with Administrator privileges. Tickets removed from the 
Inventory and Monitoring perspectives are not removed from this perspective.

Troubleshooting information is also available from the Monitoring and Inventory perspectives. This 
allows non-Administrator users to get detailed information about network and network element issues.

Figure 1-7 Troubleshooting Perspective

For more information on the Troubleshooting perspective, see Understanding the Troubleshooting 
Perspective, page 12-9.

Administration Perspective

The Administration perspective provides tools to create the Cisco ANA system of gateways, units, 
AVMs, and VNEs. You can use this perspective to run a discovery process to find network elements, and 
then add them to Cisco ANA using the seed file import. This perspective also controls the administration 
of users and scopes (groups of network elements which users can view and manage), and the system 
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settings that are used across Cisco ANA, such as trap forwarding, polling groups, and protection groups 
(which control unit failover). Use this perspective to administer jobs and configure default settings for 
applications (for example, the default import directory for software image uploads).

Figure 1-8 Administration Perspective

For more information on the Administration perspective, see Cisco ANA Administration, page 13-1 and 
Cisco ANA Administration, page 13-1.

Navigating the User Interface
Perspectives, page 1-8, describes how to change perspectives, and the structure of Cisco ANA 
perspectives. The following topics describe other elements and tasks that are common to all Cisco ANA 
perspectives:

• Using the Objects and Tasks Tabs, page 1-15

• Using Search, page 1-15

• Using the Device Browser and Device Selector, page 1-17

• Working with Tables: Filters and Refresh, page 1-18

• Launching Online Help, page 1-21

• Customizing the UI, page 1-21
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Using the Objects and Tasks Tabs

As illustrated in Figure 1-2 on page 1-9, the navigation area controls what is displayed in other parts of 
a perspective. Each perspective’s navigation area has an Objects tab and a Tasks tab. These tabs provide 
different work paradigms:

• The Objects tab starts with objects on which you want to perform a task, such as selecting some new 
network elements and updating their software images.

• The Tasks tab starts with tasks that you might want to perform and apply to specific objects. For 
example, you might decide that you want to create a commonly used configuration script and then 
apply that script to elements of a certain type.

If one of your tabs has disappeared, it is likely that you either minimized it or converted it to a Fast View. 
To remediate this, see Customizing the UI, page 1-21.

Cisco ANA also provides an auto-refresh feature for some tabular data. See Auto-Refresh, page 1-20.

Using Search

Cisco ANA provides a robust set of search criteria for different objects and object properties, depending 
on the features that are included with your system. For example, you can search for all devices that have 
the same string in their name, or you can search for Ethernet ports. The search function searches for 
objects across all Cisco ANA perspectives. You can perform simple searches (that use one rule) or 
compound searches (that use multiple rules).

Launch the function by either clicking the Search tab, or clicking the search icon in the main toolbar.

This procedure describes how to use the global Search function.

Step 1 Open the Search function:

• Click the Search icon in the main toolbar, or

• Click the Search tab and select Search Criteria.

If the search criteria is populated, click Clear. (The search function saves the most recent search criteria 
and search results.)

Step 2 Enter your search criteria.

a. Object Type—Select the type of entity you want to search for. The types displayed depend on the 
applications that are installed on your system (for example, more types are displayed if you have 
installed MPLS Assurance Manager). Some examples are Device, Ticket, and User. 

b. Attribute—A feature of the object. This list is populated based on the Object Type you choose. For 
example, if you choose a Device as your Object Type, you can search for devices by IP address, 
Device Name, Communication State, and other attributes.

c. Operator—The logical function you want to perform in the search. Examples are = or CONTAINS.

Note All operator values are case sensitive, and wildcards are not supported.

Icon Description

Launches the global search function.
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Table 1-1 Search and Filter Operators

Operator Meaning Usage

= Attribute definition 
exactly equals value

• Where Used—On a list of devices

• Example—System Name = 7608

• Result—Returns all devices with “7608” as their system 
name (without prefixes or suffixes)

!= Attribute definition 
does not exactly 
equal value

• Where Used—On a list of devices

• Example—System Name != sj43

• Result—Returns all devices without “sj43” as their system 
name (without prefixes or suffixes)

> Attribute definition 
is greater than value

• Where Used—On a list of tickets

• Example—Affected Devices Count > 25

• Result—Returns all tickets that affected more than 25 
devices

< Attribute definition 
is less than value

• Where Used—On a list of tickets

• Example—Time < 15-04-2007 18:00:00

• Result—Returns all tickets that were generated before 15 
April 2007 at 6:00 P.M (but not a ticket that was generated 
at that exact time)

>= Attribute definition 
is greater than or 
equal to value

• Where Used—On a list of tickets

• Example—Time Submitted >= 15-04-2007 18:00:00

• Result—Returns all tickets that were submitted before, or 
exactly at, 6:00 P.M. on 15 April 2007

<= Attribute definition 
is less than or equal 
to value

• Where Used—On a list of users

• Example— Last Login <= 15-04-2007 18:00:00

• Result—Returns all users who logged in before, or exactly 
at, 6:00 P.M. on 15 April 2007

CONTAINS Attribute definition 
contains value 
anywhere in the 
attribute string

• Where Used—On a list of devices

• Example—IP Address CONTAINS .255.255.

• Result—Returns all devices with IP addresses that contain 
the string “.255.255.” anywhere in the IP address

NOT 
CONTAINS

Attribute definition 
does not contain 
value anywhere in 
the attribute string

• Where Used—On a list of devices

• Example—Vendor NOT CONTAINS Cisco

• Result—Returns all devices that do not contain the 
case-sensitive string “Cisco” anywhere in the vendor name
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d. Value—The string for which you will search. For example, Values are case sensitive and wildcards 
are not supported. Examples are provided in Table 1-1.

Step 3 If you want to create a compound search—that is, a search using mutliple object types or 
attributes—click Compound Search and do the following:

a. Create one search string (as described in Step 2), click Add, and repeat the step so you have at least 
two search strings in the Compound Search text box.

Note Do not click Clear at this point, or you will lose all of your search criteria.

b. Create your compound search using the buttons provided:

– To use the Not operator, select one search string.

– To use the And or Or operators, select at least two search strings.

You can delete single or multiple strings by selecting them and clicking Remove.

Step 4 Click Search. The results are displayed in the workspace, with a timestamp above the search results. The 
results include all of the Attribute information for the Object Type you selected. (The results of the last 
search are also saved in the Search tab under the Results drawer, so you can compare the results with 
earlier searches.) 

Step 5 To start a new search, click Clear.

Some Cisco ANA functions provide specialized search tools, such as the search tool for finding an object 
in a topology map. These search tools are described in the topics that describe those specific functions.

Using the Device Browser and Device Selector

Reviewers: This section will be finalized when we have the final device browser; we are still 
waiting on some icons.

The Cisco ANA device browser provides a tabular list of network elements and iconic information so 
you can quickly detect any issues and get further information about a selected element. You can filter 
the list based on attributes such a network element category, name, or state. An example of the device 
browser information is displayed in Figure 1-9.

STARTS 
WITH

Attribute definition 
begins with value

• Where Used—On a list of ports

• Example—Name STARTS WITH ATM

• Result—Returns all ports with names that start with the 
case-sensitive string “ATM”

ENDS WITH Attribute definition 
terminates in value

• Where Used—On a list of customers

• Example—Contact ENDS WITH Smith

• Result—Returns all customers with contact names that end 
with the case-sensitive string “Smith”

Table 1-1 Search and Filter Operators (continued)

Operator Meaning Usage
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Figure 1-9 Device Browser

The meanings of the various icons are described in Icon Reference, page G-1. The list of network 
elements displayed in the Device Selector depends on a user’s role and scope. The Device Selector is 
dynamically updated when new network elements are imported into Cisco ANA. If a device is not 
supported in Cisco ANA, it is still displayed, but you cannot perform any operations on it. (For a list of 
network elements supported by Cisco ANA, see Cisco Active Network Abstraction VNE Reference.)

The Device Selector user interface is arranged similarly to the device browser. It provides a user-friendly 
interface for selecting devices so you can perform operations on them.

Working with Tables: Filters and Refresh 

You can filter results displayed in a specific view (rather than across perspectives) to quickly find the 
data in which you are interested. 

Simple Filter

Use the simple filter to refine any displayed data according to a single search rule. The simple filter can 
be toggled to display vertically or horizontally. Figure 1-10 illustrates the results of filtering a list of 
security events so that only the events that have the word “login” in the description are displayed. Results 
that do not meet the search criteria are removed. If you no longer want to apply any filtering, click Clear 
Filter.

1 Object type 3 Network element name

2 Network element state 4 Severity of highest ticket, if applicable

To be updated.
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Figure 1-10 Simple Filter

Note When you perform a simple filter based on time, Cisco ANA uses a greater than operator, and displays 
results that have a time stamp later than the date you specify. To use the date and time widget in the filter, 
click the drop-down arrow that appears after the date in the simple filter field.

Advanced Filter

Use the advanced filter to customize results using multiple filter rules, or rules that offer more 
granularity (for example, rules that use operators such as does not contain or greater than). Figure 1-11 
illustrates the same search criteria used in Figure 1-10. However, with the advanced filter you can add 
additional rules, such as filtering by username and location. Click Add and then OK to create the filter 
and view the results.

When a table is being filtered, the filter icon changes as described in the following table:

To restore a filtered table to its original (unfiltered) state, click the filter icon and remove all of the 
expressions. When you click OK in the Filter dialog box, the table reverts to its original state.

This procedure describes how to use the advanced filter function.

Step 1 Click the advanced filter icon:

Step 2 Enter your filter criteria.

a. Attribute—A feature of the object. This list is populated based on the type of objects that are listed 
in the table. For example, if you are viewing the Tickets table in the Troubleshooting perspective, 
you can search for devices by the Affected Devices Count, Severity, and other attributes.

b. Operator—The logical function you want to perform in the search. Examples are = or CONTAINS. 
For a description of the operators, see Table 1-1 on page 1-16.

Icon Description

Indicates that a filter is not in use. Clicking it opens the Filter dialog box.

Indicates that a filter is in use. Clicking it opens the Filter dialog box.
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c. Value—The string for which you will search. For example, Values are case sensitive and wildcards 
are not supported. Examples are provided in Table 1-1 on page 1-16.

d. Click Add.

Step 3 Repeat Step 2 so you have at least two search strings in the Expression text box.

Step 4 Create your compound filter by clicking the buttons provided:

• To use the Not operator, select one search string.

• To use the And or Or operators, select at least two search strings.

You can delete single or multiple strings by selecting them and clicking Remove.

Step 5 Click OK. The table is refreshed and displays the filtered information.

Step 6 To turn off the filtering, click the filter icon. 

Figure 1-11 Advanced Filter

Auto-Refresh

Some Cisco ANA tables, such as the Active Tickets table, provide an auto-refresh button, as shown in 
the following table.

Reviewers: Is the following correct? Or will there be a third icon for doing a ‘refresh now’?

Other areas may have a simple refresh button.

Icon Description

Indicates that auto-refresh is enabled, and content will be updated as new activities occur.

Indicates that auto-refresh is not enabled, and content will not be updated. When this icon 
blinks, it indicates new activity has occurred; click the icon to update the current display 
without enabling auto-refresh.
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Launching Online Help

The Cisco ANA online help system contains information on all installed features. The online help system 
is searchable and contains an index and printable manuals (in PDF format). You can launch the Cisco 
ANA online help in these ways:

• Choose Help > Help Contents from the main menu. A separate window opens and displays the 
online help with the full table of contents.

• Focus on an object in any perspective and press F1. This opens a small infopop window that provides 
links to relevant help topics.

The Workflow Editor also provides vendor-specific help. For information on how to launch the 
Workflow Editor vendor help, see Understanding the Workflow Editor User Interface, page C-4.

Customizing the UI

The following figures illustrate possible ways to customize the Cisco ANA GUI Client, specifically 
when you want to use both the Inventory and Monitoring perspectives.

When you customize a perspective, you can save your changes by selecting Window > Save Perspective 
from the Cisco ANA main menu. This makes your new layout the default layout for that perspective. If 
you have several windows open at one time, remember to use File > Exit to close all open windows.

These topics describe some ways to customize your UI:

• Suggested Layout for Viewing Inventory and Ticket Information, page 1-21

• Suggested Layout for Viewing Topology and Inventory Information, page 1-22

• Perspective Shortcuts, page 1-23

• Moving, Docking, Resizing, and Other Eclipse Controls, page 1-23

• Controlling the Limit for Workspaces (Tabs), page 1-23

• Using Eclipse Fast Views, page 1-24

Suggested Layout for Viewing Inventory and Ticket Information

Figure 1-12 illustrates a suggested layout for those users who prefer to use just one window to view 
Inventory and network ticket information.

Icon Description

Updates and refreshes the contents of the active drawer.
1-21
Cisco Active Network Abstraction 4.1 User and Administration Guide

OL-15593-01



DRAFT  -  8  OCTOBER  20 08  -  C ISCO CONF IDENT IAL

Chapter 1      Cisco ANA Overview
Using the Cisco ANA UI
Figure 1-12 Suggested Inventory Perspective Layout—One Window

With the layout in Figure 1-12, users can easily peruse the physical and logical inventory with more 
space for nested tree information. Users can also view ticket information without having to launch the 
Monitoring perspective. 

Suggested Layout for Viewing Topology and Inventory Information

For users who want to view topology and inventory information, without having to switch between 
perspectives, Cisco recommends using two client windows as shown in Figure 1-13. Topology and 
network element information is displayed concurrently, without having to switch between perspectives. 
The Active Tickets view is closed in the Inventory perspective, because it is already available from the 
Monitoring perspective.

Figure 1-13 Suggested Inventory Perspective Layout #2

To create a second window, select Window > Open in New Window from one of the perspectives. At 
any time you can revert to the client’s default layout by selecting Window > Reset Perspective or 
Window > Open in New Window.
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Perspective Shortcuts

You can create shortcuts to perspectives by sliding the perspective selector bar to the left. See .

Moving, Docking, Resizing, and Other Eclipse Controls

Eclipse provides many methods for customizing the layout of the user interface. The following are some 
simple ways you can customize the layout:

• Resize views by click-dragging the view border.

• Reposition views by click-dragging the view tab.

• Minimize, dock, and undock views using the view toolbar.

Once you have customized a layout, Cisco ANA will display it whenever you log in. The layout 
references are saved on a per-machine basis rather than a per-user basis. If you customize a layout and 
want to make it the default, choose Window > Save Perspective from the Cisco ANA main menu.

Note We recommend that you do not use Window > Customize Perspective or Window > Navigation unless 
you are thoroughly familiar with Eclipse user interfaces. If you do make changes using either of these 
options, you can revert to your last saved layout by choosing Window > Reset Perspective.

For information on the standard Eclipse menu items, go to http://help.eclipse.org/help32/index.jsp. On 
the left side, navigate to Workbench User Guide > Reference > User interface information > 
Workbench menus.

Controlling the Limit for Workspaces (Tabs)

You can control the number of workspaces (normally represented by tabs) that can be open at one time 
in any of the perspectives. Figure 1-11 on page 1-20 illustrates the Troubleshooting perspective with four 
open workspaces. By default, Cisco ANA limits the number to six. When you exceed the limit, the oldest 
workspace is closed (first in, first out).

To change the limit, use the following procedure. (These settings are enforced across all perspectives.)

Note Increasing the number of open workspaces can increase memory consumption and impact system 
performance. This is especially true if you are viewing multiple complex devices. If you increase the 
number, do so with caution. 

Step 1 In any perspective, choose Tools > Preferences from the window’s main menu.

Step 2 In the Preferences dialog box, expand the General tree and choose Workspaces.

Step 3 In the Workspaces area:

a. Check the Close anchor tabs automatically check box.

b. Specify the maximum number of tabs you want open in the Number of opened workspace tabs 
before closing field.

Step 4 Click Apply to apply your changes to the perspectives, and OK to save your changes for future sessions.
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Using Eclipse Fast Views

You can also use fast views to minimize views you do not want to see all the time. If a view or portion 
of the navigation disappears, most likely you changed it to a fast view by mistake. Figure 1-14 shows a 
Troubleshooting perspective with the Fast View icon (circled, under the navigation area). Note that the 
navigation area does not have a Tasks tab; the Tasks navigation area is a fast view, and can easily be 
activated by clicking the icon in the Fast View toolbar. 

Note If you create a Fast View for the Objects tab and launch it from the Fast View icon, it overwrites all other 
tabs in the navigation area. The other tab views do not adjust. To avoid this, launch the fast view by 
choosing Window > Show View from the main menu.

Figure 1-14 Fast Views

To undo a fast view, click the view’s icon and uncheck Fast View.
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