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Defining Business Tags

Business tags are records that you can use to identify managed network objects (such as, modules, 
chassis and so on), with more familiar names of your choice. These records are stored in the Cisco ANA 
gateway database. 

You can perform the following functions using the Business Tag module:

• Adding a Business Tag, page 6-2

• Editing a Business Tag, page 6-5

• Deleting a Business Tag, page 6-7

Related Topic

Viewing the Network Element Inventory

Roles Required to Define Business Tag 
Table 6-1 lists the roles that are required to define the business tag. For more information on roles, see 
Creating and Managing Users, Passwords, and Scopes, page 14-34.

Related Topic

• Adding a Business Tag

• Editing a Business Tag

• Deleting a Business Tag

• Viewing the Network Element Inventory

Table 6-1 Roles Required to Define Business Tag

Task Role Required

Adding a business tag Configurator, Administrator

Editing a business tag Configurator, Administrator

Deleting a business tag Configurator, Administrator
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Adding a Business Tag
You can add a business tag to the network elements, interfaces, modules, and chassis. The Inventory and 
Monitoring perspectives are used to add business tags.

From the Monitoring perspective, you can add a business tag to the network elements. From the 
Inventory perspective, you can add a business tag to the network elements, chassis, modules, and 
interfaces.

This section contains:

• Adding a Business Tag to a Network Element Using the Monitoring Perspective, page 6-2

• Adding a Business Tag to a Network Element, a Chassis, a Module, or an Interface Using the 
Inventory Perspective, page 6-3

Adding a Business Tag to a Network Element Using the Monitoring Perspective

Figure 6-1 shows how to add a business tag to a network element using the Monitoring perspective.

Figure 6-1 Adding a Business Tag to a Network Element Using the Monitoring Perspective

1 Monitoring perspective. 2 Network Element view.

3 Launching Business Tag. 4 View selection icon.
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To add a business tag to a network element using the Monitoring perspective:

Step 1 In the Monitoring perspective, click the Object tab. The list of maps that are accessible to you is 
displayed in the Network Domain drawer.

Step 2 Click the map. The map is displayed in the workspace.

Step 3 Choose Window > Show View > Network Elements to enable the Network Elements view.

Step 4 Right-click a network element and select Business Tag > Attach. The Business Tag dialog box appears.

Step 5 Enter the following details in the Business Tag dialog box:

• Unique Key—A unique identifier for the business tag. This is internally used by Cisco ANA to map 
the business tag information. You cannot have the same Unique Key for different network elements. 
You cannot use special characters.

• Name—The name of the business tag. You cannot use special characters.

• Description—The description for the business tag.

Step 6 Click OK.

To view the business tag details, close and reopen the map. See Opening a Topology Map, page 5-7 for 
information on opening a topology map.

To view the business tag details in the Inventory perspective, close and reopen the Object view. You can 
open the Object view by choosing Window > Show View > Other; then, in the Inventory folder, select 
Others.

The business tag’s details are not visible in the Network Element view.

Adding a Business Tag to a Network Element, a Chassis, a Module, or an Interface Using the Inventory Perspective

Figure 6-2 shows how to add a business tag to a module using the Inventory Perspective.

Reviewers: This screen shot will be replaced when the new device browser is available.
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Figure 6-2 Adding Business Tag to a Network Element, a Chassis, a Module, or an Interface Using 

the Inventory Perspective

To add a business tag to a network element, a chassis, a module, or an interface:

Step 1 In the Inventory perspective, click the Object tab and select a network element.

• To add a business tag to a network element, right-click and choose Business Tag > Attach. The 
Business Tag dialog box appears.

• To add a business tag to a chassis, a module, or an interface:

a. Go to the Physical Inventory view and select a chassis, a module, or an interface.

b. Right-click and choose Business Tag > Attach. The Business Tag dialog box appears.

1 Inventory perspective. 2 Physical Inventory view.

3 Launching Business Tag.
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Step 2 Enter the following details in the Business Tag dialog box:

• Unique Key—A unique identifier for the business tag. This is internally used by Cisco ANA to map 
the business tag information. You cannot have the same Unique Key for different network elements. 
You cannot use special characters.

• Name—The name of the business tag. You cannot use special characters.

• Description—The description for the business tag.

Step 3 Click OK.

The business tag details are auto refreshed in the Physical Inventory tab. You can see the details in the 
Monitoring perspective but not in the Network Element view.

Related Topic

• Roles Required to Define Business Tag

• Editing a Business Tag

• Deleting a Business Tag

• Viewing the Network Element Inventory

Editing a Business Tag
This section contains:

• Editing the Business Tag of a Network Element Using the Monitoring Perspective, page 6-6

• Editing the Business Tag of a Network Element, a Chassis, a Module, or an Interface Using the 
Inventory Perspective, page 6-7

Figure 6-3 displays the navigation required to edit and delete the business tag of a module.

Reviewers: This screen shot will be replaced when the new device browser is available.
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Figure 6-3 Editing and Deleting a Business Tag

This section contains:

• Editing the Business Tag of a Network Element Using the Monitoring Perspective, page 6-6

• Editing the Business Tag of a Network Element, a Chassis, a Module, or an Interface Using the 
Inventory Perspective, page 6-7

Editing the Business Tag of a Network Element Using the Monitoring Perspective

Step 1 In the Monitoring perspective, click the Object tab. The list of maps that are accessible to you is 
displayed in the Network Domain drawer.

Step 2 Click the map. The map is displayed in the workspace.

Step 3 Choose Window > Show View > Network Elements to enable the Network Elements view.

Step 4 Select the network element that contains the business tag that you want to edit.

Step 5 Right-click and select Business Tag > Edit. The business tag editing window appears in the primary 
workspace. You can edit all the fields: Unique Key, Name, and Description.

Step 6 Choose File > Save to save the business tag data.

1 Physical Inventory view. 2 Launching the Business Tag module to edit 
and delete a business tag.
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To view the edited business tag details, close and reopen the map. See Opening a Topology Map, 
page 5-7 for information on opening a topology map.

Editing the Business Tag of a Network Element, a Chassis, a Module, or an Interface Using the Inventory Perspective

Step 1 In the Inventory perspective, click the Object tab and select the network element that contains the 
business tag.

• To edit a business tag of a network element, right-click and choose Business Tag > Edit. The 
business tag editing window appears in the primary workspace. You can edit all the fields: Unique 
Key, Name, and Description.

• To edit a business tag of a chassis, a module, or an interface:

a. Go to the Physical Inventory view and select the chassis, module, or interface that contains the 
business tag that you want to edit.

b. Right-click and choose Business Tag > Edit. The business tag editing window appears in the 
primary workspace. You can edit all the fields: Unique Key, Name, and Description.

Step 2 Choose File > Save to save the business tag data.

The edited business tag details are auto refreshed in the Physical Inventory tab. 

Related Topic

• Roles Required to Define Business Tag

• Adding a Business Tag

• Deleting a Business Tag

• Viewing the Network Element Inventory

Deleting a Business Tag
This section contains:

• Deleting the Business Tag of a Network Element Using the Monitoring Perspective, page 6-7

• Deleting the Business Tag of a Network Element, a Chassis, a Module, or an Interface Using the 
Inventory Perspective, page 6-8

Deleting the Business Tag of a Network Element Using the Monitoring Perspective

Step 1 In the Monitoring perspective, click the Object tab. The list of maps that are accessible to you is 
displayed in the Network Domain drawer.

Step 2 Click the map. The map is displayed in the workspace.

Step 3 Go to Window > Show View > Network Elements to enable the Network Elements view.

Step 4 Select the network element that contains the business tag that you want to delete.
6-7
Cisco Active Network Abstraction 4.1 User and Administration Guide

OL-15593-01



DRAFT  -  31  MAY 20 08  -  C ISCO CONF IDENT IAL

Chapter 6      Defining Business Tags
Deleting a Business Tag
Step 5 Right-click and select Business Tag > Detach. The business tag details are deleted.

Deleting the Business Tag of a Network Element, a Chassis, a Module, or an Interface Using the Inventory Perspective

Step 1 In the Inventory perspective, click the Object tab and select the network element that contains the 
business tag.

• To delete a business tag of a network element, right-click and choose Business Tag > Detach. 

• To delete a business tag of a chassis, a module, or an interface:

a. Go to the Physical Inventory view and select the chassis, module, or interface that contains the 
business tag that you want to delete.

b. Right-click and choose Business Tag > Detach. 

The business tag details are deleted.

Related Topic

• Roles Required to Define Business Tag

• Adding a Business Tag

• Editing a Business Tag

• Viewing the Network Element Inventory
6-8
Cisco Active Network Abstraction 4.1 User and Administration Guide

OL-15593-01


	Defining Business Tags
	Roles Required to Define Business Tag
	Adding a Business Tag
	Editing a Business Tag
	Deleting a Business Tag



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveEPSInfo true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /Description <<
    /FRA <>
    /ENU (Use these settings to create PDF documents with higher image resolution for improved printing quality. The PDF documents can be opened with Acrobat and Reader 5.0 and later.)
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308000200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e30593002537052376642306e753b8cea3092670059279650306b4fdd306430533068304c3067304d307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e30593002>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
  >>
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


