IPv6 Routing: EIGRP Support

IPv6 Routing: EIGRP Support

Last Updated: July 26, 2012

Customers can configure Enhanced Interior Gateway Routing Protocol (EIGRP) to route IPv6 prefixes. EIGRP IPv4 runs over an IPv4 transport, communicates only with IPv4 peers, and advertises only IPv4 routes, and EIGRP for IPv6 follows the same model. EIGRP for IPv4 and EIGRP for IPv6 are configured and managed separately. However, the configuration of EIGRP for IPv4 and IPv6 is similar and provides operational familiarity and continuity.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Restrictions for IPv6 Routing EIGRP Support

This section lists ways in which EIGRP for IPv6 differs from EIGRP IPv4 and lists EIGRP for IPv6 restrictions:

  • EIGRP for IPv6 is directly configured on the interfaces over which it runs. This feature allows EIGRP for IPv6 to be configured without the use of a global IPv6 address. There is no network statement in EIGRP for IPv6.

In per-interface configuration at system startup, if EIGRP has been configured on an interface, then the EIGRP protocol may start running before any EIGRP router mode commands have been executed.

  • An EIGRP for IPv6 protocol instance requires a router ID before it can start running.
  • EIGRP for IPv6 has a shutdown feature. The routing process should be in "no shut" mode in order to start running.
  • When a user uses a passive-interface configuration, EIGRP for IPv6 need not be configured on the interface that is made passive.
  • EIGRP for IPv6 provides route filtering using the distribute-list prefix-list command. Use of the route-map command is not supported for route filtering with a distribute list.

Information About IPv6 Routing EIGRP Support

Cisco EIGRP for IPv6 Implementation

EIGRP is an enhanced version of the IGRP developed by Cisco. EIGRP uses the same distance vector algorithm and distance information as IGRP. However, the convergence properties and the operating efficiency of EIGRP have improved substantially over IGRP.

The convergence technology is based on research conducted at SRI International and employs an algorithm called the diffusing update algorithm (DUAL). This algorithm guarantees loop-free operation at every instant throughout a route computation and allows all devices involved in a topology change to synchronize at the same time. Devices that are not affected by topology changes are not involved in recomputations. The convergence time with DUAL rivals that of any other existing routing protocol.

EIGRP provides the following features:

  • Increased network width--With Routing Information Protocol (RIP), the largest possible width of your network is 15 hops. When EIGRP is enabled, the largest possible width is 224 hops. Because the EIGRP metric is large enough to support thousands of hops, the only barrier to expanding the network is the transport layer hop counter. Cisco works around this limitation by incrementing the transport control field only when an IPv4 or an IPv6 packet has traversed 15 devices and the next hop to the destination was learned by way of EIGRP. When a RIP route is being used as the next hop to the destination, the transport control field is incremented as usual.
  • Fast convergence--The DUAL algorithm allows routing information to converge as quickly as any other routing protocol.
  • Partial updates--EIGRP sends incremental updates when the state of a destination changes, instead of sending the entire contents of the routing table. This feature minimizes the bandwidth required for EIGRP packets.
  • Neighbor discovery mechanism--This is a simple hello mechanism used to learn about neighboring devices. It is protocol-independent.
  • Arbitrary route summarization.
  • Scaling--EIGRP scales to large networks.
  • Route filtering--EIGRP for IPv6 provides route filtering using the distribute-list prefix-listcommand. Use of the route-map command is not supported for route filtering with a distribute list.

EIGRP has the following four basic components:

  • Neighbor discovery--Neighbor discovery is the process that devices use to dynamically learn of other devices on their directly attached networks. Devices must also discover when their neighbors become unreachable or inoperative. EIGRP neighbor discovery is achieved with low overhead by periodically sending small hello packets. EIGRP neighbors can also discover a neighbor that has recovered after an outage because the recovered neighbor will send out a hello packet. As long as hello packets are received, the Cisco software can determine that a neighbor is alive and functioning. Once this status is determined, the neighboring devices can exchange routing information.
  • Reliable transport protocol--The reliable transport protocol is responsible for guaranteed, ordered delivery of EIGRP packets to all neighbors. It supports intermixed transmission of multicast and unicast packets. Some EIGRP packets must be sent reliably and others need not be. For efficiency, reliability is provided only when necessary. For example, on a multiaccess network that has multicast capabilities, it is not necessary to send hello packets reliably to all neighbors individually. Therefore, EIGRP sends a single multicast hello with an indication in the packet informing the receivers that the packet need not be acknowledged. Other types of packets (such as updates) require acknowledgment, which is indicated in the packet. The reliable transport has a provision to send multicast packets quickly when unacknowledged packets are pending. This provision helps to ensure that convergence time remains low in the presence of varying speed links.
  • DUAL finite state machine--The DUAL finite state machine embodies the decision process for all route computations. It tracks all routes advertised by all neighbors. DUAL uses several metrics including distance and cost information to select efficient, loop-free paths. When multiple routes to a neighbor exist, DUAL determines which route has the lowest metric (named the feasible distance), and enters this route into the routing table. Other possible routes to this neighbor with larger metrics are received, and DUAL determines the reported distance to this network. The reported distance is defined as the total metric advertised by an upstream neighbor for a path to a destination. DUAL compares the reported distance with the feasible distance, and if the reported distance is less than the feasible distance, DUAL considers the route to be a feasible successor and enters the route into the topology table. The feasible successor route that is reported with the lowest metric becomes the successor route to the current route if the current route fails. To avoid routing loops, DUAL ensures that the reported distance is always less than the feasible distance for a neighbor device to reach the destination network; otherwise, the route to the neighbor may loop back through the local device.
  • Protocol-dependent modules--When there are no feasible successors to a route that has failed, but there are neighbors advertising the route, a recomputation must occur. This is the process in which DUAL determines a new successor. The amount of time required to recompute the route affects the convergence time. Recomputation is processor-intensive; it is advantageous to avoid unneeded recomputation. When a topology change occurs, DUAL will test for feasible successors. If there are feasible successors, DUAL will use them in order to avoid unnecessary recomputation.

The protocol-dependent modules are responsible for network layer protocol-specific tasks. For example, the EIGRP module is responsible for sending and receiving EIGRP packets that are encapsulated in IPv4 or IPv6. It is also responsible for parsing EIGRP packets and informing DUAL of the new information received. EIGRP asks DUAL to make routing decisions, but the results are stored in the IPv4 or IPv6 routing table. Also, EIGRP is responsible for redistributing routes learned by other IPv4 or IPv6 routing protocols.

How to Configure IPv6 Routing EIGRP Support

Enabling EIGRP for IPv6 on an Interface

EIGRP for IPv6 is directly configured on the interfaces over which it runs, which allows EIGRP for IPv6 to be configured without the use of a global IPv6 address.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    ipv6 unicast-routing

4.    interface type number

5.    no shut

6.    ipv6 enable

7.    ipv6 eigrp as-number

8.    ipv6 router eigrp as-number

9.    router-id ip-address

10.    exit

11.    show ipv6 eigrp [as-number] interfaces [type number] [detail]


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
ipv6 unicast-routing


Example:

Device(config)# ipv6 unicast-routing

 

Enables the forwarding of IPv6 unicast datagrams.

 
Step 4
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is to be configured.

 
Step 5
no shut


Example:

Device(config-if)# no shut

 

Enables no shut mode so the routing process can start running.

 
Step 6
ipv6 enable


Example:

Device(config-if)# ipv6 enable

 

Enables IPv6 processing on an interface that has not been configured with an explicit IPv6 address.

 
Step 7
ipv6 eigrp as-number


Example:

Device(config-if)# ipv6 eigrp 1

 

Enables EIGRP for IPv6 on a specified interface.

 
Step 8
ipv6 router eigrp as-number


Example:

Device(config-if)# ipv6 router eigrp 1

 

Enters router configuration mode and creates an EIGRP IPv6 routing process.

 
Step 9
router-id ip-address


Example:

Device(config-router)# router-id 10.1.1.1

 

Enables the use of a fixed router ID.

Use this command only if an IPv4 address is not defined on the router eligible for router ID.

 
Step 10
exit


Example:

Device(config-router)# exit

 

Enter three times to return to privileged EXEC mode.

 
Step 11
show ipv6 eigrp [as-number] interfaces [type number] [detail]


Example:

Device# show ipv6 eigrp interfaces

 

Displays information about interfaces configured for EIGRP for IPv6 .

 

Configuring the Percentage of Link Bandwidth Used by EIGRP

By default, EIGRP packets consume a maximum of 50 percent of the link bandwidth, as configured with the bandwidth interface command. You might want to change that value if a different level of link utilization is required or if the configured bandwidth does not match the actual link bandwidth (it may have been configured to influence route metric calculations).

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no shut

5.    ipv6 bandwidth-percent eigrp as-number percent


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is configured.

 
Step 4
no shut


Example:

Device(config)# no shut

 

Enables no shut mode so the routing process can start running.

 
Step 5
ipv6 bandwidth-percent eigrp as-number percent


Example:

Device(config-if)# ipv6 bandwidth-percent eigrp 1 75

 

Configures the percentage of bandwidth that may be used by EIGRP for IPv6 on an interface

 

Configuring Summary Addresses

This task configures a summary address for a specified interface. If other specific routes are in the routing table, EIGRP for IPv6 will advertise the summary address out the interface with a metric equal to the minimum of all more specific routes.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no shut

5.    ipv6 summary-address eigrp as-number ipv6-address [admin-distance]


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is configured.

 
Step 4
no shut


Example:

Device(config)# no shut

 

Enables no shut mode so the routing process can start running.

 
Step 5
ipv6 summary-address eigrp as-number ipv6-address [admin-distance]


Example:

Device(config-if)# ipv6 summary-address eigrp 1 2001:DB8:0:1::/64

 

Configures a summary aggregate address for a specified interface.

 

Configuring EIGRP Route Authentication

EIGRP route authentication provides message digest algorithm 5 (MD5) authentication of routing updates from the EIGRP routing protocol. The MD5 keyed digest in each EIGRP packet prevents the introduction of unauthorized or false routing messages from unapproved sources.

Each key has its own key identifier, which is stored locally. The combination of the key identifier and the interface associated with the message uniquely identifies the authentication algorithm and MD5 authentication key in use.

You can configure multiple keys with lifetimes. Only one authentication packet is sent, regardless of how many valid keys exist. The software examines the key numbers in order from lowest to highest, and uses the first valid key it encounters. Note that the device needs to know the time.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no shut

5.    ipv6 authentication mode eigrp as-number md5

6.    ipv6 authentication key-chain eigrp as-number key-chain

7.    exit

8.    key chain name-of-chain

9.    key key-id

10.    key-string text

11.    accept-lifetime start-time infinite | end-time| duration seconds

12.    send-lifetime start-time infinite | end-time | duration seconds


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is configured.

 
Step 4
no shut


Example:

Device(config)# no shutdown

 

Enables no shut mode so the routing process can start running.

 
Step 5
ipv6 authentication mode eigrp as-number md5


Example:

Device(config-if)# ipv6 authentication mode eigrp 1 md5

 

Specifies the type of authentication used in EIGRP for IPv6 packets.

 
Step 6
ipv6 authentication key-chain eigrp as-number key-chain


Example:

Device(config-if)# ipv6 authentication key-chain eigrp 1 chain1

 

Enables authentication of EIGRP for IPv6 packets.

 
Step 7
exit


Example:

Device(config-if)# exit

 

Exits to global configuration mode.

 
Step 8
key chain name-of-chain


Example:

Device(config)# key chain chain1

 

Identifies a group of authentication keys.

  • Use the name specified in Step 5.
 
Step 9
key key-id


Example:

Device(config-keychain)# key 1

 

Identifies an authentication key on a key chain.

 
Step 10
key-string text


Example:

Device(config-keychain-key)# key-string chain 1

 

Specifies the authentication string for a key.

 
Step 11
accept-lifetime start-time infinite | end-time| duration seconds


Example:

Device(config-keychain-key)# accept-lifetime 14:30:00 Jan 10 2006 duration 7200

 

Sets the time period during which the authentication key on a key chain is received as valid.

 
Step 12
send-lifetime start-time infinite | end-time | duration seconds


Example:

Device(config-keychain-key)# send-lifetime 15:00:00 Jan 10 2006 duration 3600

 

Sets the time period during which an authentication key on a key chain is valid to be sent.

 

Overriding the Next Hop in EIGRP

EIGRP will, by default, set the IPv6 next-hop value to be itself for routes that it is advertising, even when advertising those routes back out the same interface where it learned them. Perform this task to change this default and instruct EIGRP to use the received next-hop value when advertising these routes.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no shut

5.    no ipv6 next-hop-self eigrp as-number


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is configured.

 
Step 4
no shut


Example:

Device(config)# no shutdown

 

Enables no shut mode so the routing process can start running.

 
Step 5
no ipv6 next-hop-self eigrp as-number


Example:

Device(config-if)# no ipv6 next-hop-self eigrp 1

 

Changes the default IPv6 next-hop value and instructs EIGRP to use the received next-hop value.

 

Adjusting the Interval Between Hello Packets in EIGRP for IPv6

Routing devices periodically send hello packets to each other to dynamically learn of other devices on their directly attached networks. This information is used to discover neighbors and learn when neighbors become unreachable or inoperative.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no shut

5.    ipv6 hello-interval eigrp as-number seconds


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is configured.

 
Step 4
no shut


Example:

Device(config)# no shutdown

 

Enables no shut mode so the routing process can start running.

 
Step 5
ipv6 hello-interval eigrp as-number seconds


Example:

Device(config)# ipv6 hello-interval eigrp 1 10

 

Configures the hello interval for the EIGRP for IPv6 routing process designated by an autonomous system number.

 

Adjusting the Hold Time in EIGRP for IPv6

On very congested and large networks, the default hold time might not be sufficient time for all devices to receive hello packets from their neighbors. In this case, you may want to increase the hold time.

This task configures the hold time on a specified interface for a particular EIGRP routing process designated by the autonomous system number. The hold time is advertised in hello packets and indicates to neighbors the length of time they should consider the sender valid. The default hold time is 3 times the hello interval, or 15 seconds. For slow-speed nonbroadcast multi-access (NBMA) networks, the default hold time is 180 seconds. The hold time should be changed if the hello-interval value is changed.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no shut

5.    ipv6 hold-time eigrp as-number seconds


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is configured.

 
Step 4
no shut


Example:

Device(config)# no shutdown

 

Enables no shut mode so the routing process can start running.

 
Step 5
ipv6 hold-time eigrp as-number seconds


Example:

Device(config)# ipv6 hold-time eigrp 1 40

 

Configures the hold time for a particular EIGRP for IPv6 routing process designated by the autonomous system number.

 

Disabling Split Horizon in EIGRP for IPv6

By default, split horizon is enabled on all interfaces. Split horizon controls the sending of EIGRP update and query packets. When split horizon is enabled on an interface, update and query packets are not sent for destinations for which this interface is the next hop. Controlling update and query packets in this manner reduces the possibility of routing loops.

Split horizon blocks route information from being advertised by a device out of any interface from which that information originated. This behavior usually optimizes communications among multiple routing devices, particularly when links are broken. However, with nonbroadcast networks (such as multipoint GRE), situations can arise for which this behavior is not ideal. For these situations, including networks in which you have EIGRP configured, you may want to disable split horizon.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no shut

5.    no ipv6 split-horizon eigrp as-number


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface FastEthernet 0/0

 

Specifies the interface on which EIGRP is configured.

 
Step 4
no shut


Example:

Device(config)# no shutdown

 

Enables no shut mode so the routing process can start running.

 
Step 5
no ipv6 split-horizon eigrp as-number


Example:

Device(config-if)# no ipv6 split-horizon eigrp 101

 

Disables EIGRP for IPv6 split horizon on the specified interface.

 

Configuring EIGRP Stub Routing for Greater Network Stability

The EIGRP stub routing feature can help to provide greater network stability. In the event of network instability, this feature prevents EIGRP queries from being sent over limited bandwidth links to nontransit devices. Instead, distribution devices to which the stub device is connected answer the query on behalf of the stub device. This feature greatly reduces the chance of further network instability due to congested or problematic WAN links. The EIGRP stub routing feature also simplifies the configuration and maintenance of hub-and-spoke networks. When stub routing is enabled in dual-homed remote configurations, it is no longer necessary to configure filtering on remote devices to prevent those remote devices from appearing as transit paths to the hub devices.


Caution


EIGRP stub routing should be used only on stub devices. A stub device is defined as a device connected to the network core or distribution layer through which core transit traffic should not flow. A stub device should not have any EIGRP neighbors other than distribution devices.


Configuring a Device for EIGRP Stub Routing

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    ipv6 router eigrp as-number

4.    eigrp stub receive-only | leak-map | connected | static | summary | redistributed


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
ipv6 router eigrp as-number


Example:

Device(config)# ipv6 router eigrp 1

 

Specifies the EIGRP for IPv6 routing process to be configured.

 
Step 4
eigrp stub receive-only | leak-map | connected | static | summary | redistributed


Example:

Device(config-router)# eigrp stub

 

Configures a device as a stub using EIGRP.

 

Verifying EIGRP Stub Routing

SUMMARY STEPS

1.    enable

2.    show ipv6 eigrp neighbors detail interface-type | as-number | static


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
show ipv6 eigrp neighbors detail interface-type | as-number | static


Example:

Device# show ipv6 eigrp neighbors detail

 

Displays the neighbors discovered by EIGRP for IPv6.

This command is performed on the distribution layer device to view the status of the remote device.

 

Customizing an EIGRP for IPv6 Routing Process

Logging EIGRP Neighbor Adjacency Changes

You can enable the logging of neighbor adjacency changes to monitor the stability of the routing system and to help you detect problems. By default, adjacency changes are logged.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    ipv6 router eigrp as-number

4.    eigrp log-neighbor-changes


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
ipv6 router eigrp as-number


Example:

Device(config)# ipv6 router eigrp 1

 

Specifies the EIGRP for IPv6 routing process to be configured.

 
Step 4
eigrp log-neighbor-changes


Example:

Device(config-router)# eigrp log-neighbor-changes

 

Enables the logging of changes in EIGRP for IPv6 neighbor adjacencies.

 

Configuring Intervals Between Neighbor Warnings

When neighbor warning messages occur, they are logged by default.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    ipv6 router eigrp as-number

4.    eigrp log-neighbor-warnings [seconds]


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
ipv6 router eigrp as-number


Example:

Device(config)# ipv6 router eigrp 1

 

Specifies the EIGRP for IPv6 routing process to be configured.

 
Step 4
eigrp log-neighbor-warnings [seconds]


Example:

Device(config-router)# eigrp log-neighbor-warnings 300

 

Configures the logging intervals of EIGRP neighbor warning messages.

 

Adjusting EIGRP for IPv6 Metric Weights

EIGRP for IPv6 uses the minimum bandwidth on the path to a destination network and the total delay to compute routing metrics. You can use the metric weights command to adjust the default behavior of EIGRP for IPv6 routing and metric computations. EIGRP for IPv6 metric defaults have been carefully selected to provide optimal performance in most networks.


Note


Adjusting EIGRP metric weights can dramatically affect network performance. Because of the complexity of this task, we recommend that you do not change the default values without guidance from an experienced network designer.

By default, the EIGRP composite metric is a 32-bit quantity that is a sum of the segment delays and the lowest segment bandwidth (scaled and inverted) for a given route. For a network of homogeneous media, this metric reduces to a hop count. For a network of mixed media (e.g., GigabitEthernet, FastEthernet, Ethernet), the route with the lowest metric reflects the most desirable path to a destination.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    ipv6 router eigrp as-number

4.    metric weights tos k1 k2 k3 k4 k5


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
ipv6 router eigrp as-number


Example:

Device(config)# ipv6 router eigrp 1

 

Specifies the EIGRP for IPv6 routing process to be configured.

 
Step 4
metric weights tos k1 k2 k3 k4 k5


Example:

Device(config-router)# metric weights 0 2 0 2 0 0

 

Tunes EIGRP metric calculations.

 

Deleting Entries from EIGRP for IPv6 Routing Tables

SUMMARY STEPS

1.    enable

2.    clear ipv6 eigrp [ as-number ] [neighbor [ipv6-address | interface-type interface-number]]


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
clear ipv6 eigrp [ as-number ] [neighbor [ipv6-address | interface-type interface-number]]


Example:

Device# clear ipv6 eigrp neighbor 3FEE:12E1:2AC1:EA32

 

Deletes entries from EIGRP for IPv6 routing tables.

The routes that are cleared are the routes that were learned by the specified device.

 

Configuration Examples for IPv6 Routing EIGRP Support

Example: Configuring EIGRP to Establish Adjacencies on an Interface

EIGRP for IPv6 is configured directly on the interfaces over which it runs. This example shows the minimal configuration required for EIGRP for IPv6 to send hello packets in order to establish adjacencies on Ethernet 0/0:

ipv6 unicast-routing
interface ethernet0/0
no shut
  ipv6 enable 
  ipv6 eigrp 1
!
ipv6 router eigrp 1
  eigrp router-id 10.1.1.1

Additional References

Related Documents

Related Topic Document Title

IPv6 addressing and connectivity

IPv6 Configuration Guide

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

IPv6 commands

Cisco IOS IPv6 Command Reference

Cisco IOS IPv6 features

Cisco IOS IPv6 Feature Mapping
Configuring EIGRP EIGRP Configuration Guide

Standards and RFCs

Standard/RFC Title

RFCs for IPv6

IPv6 RFCs

MIBs

MIB

MIBs Link

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

Technical Assistance

Description Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for IPv6 Routing: EIGRP Support

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1Feature Information for IPv6 Routing: EIGRP Support
Feature Name Releases Feature Information

IPv6 Routing: EIGRP Support

12.4(6)T

12.2(33)SRB

12.2(33)SXI

15.0(1)S

Cisco IOS XE Release 2.1

Customers can configure EIGRP to route IPv6 prefixes. There is no linkage between EIGRP for IPv4 and EIGRP for IPv6; they are configured and managed separately. However, the configuration of EIGRP for IPv4 and IPv6 is similar and provides operational familiarity and continuity.

The following commands were introduced or modified: accept-lifetime, clear ipv6 eigrp, eigrp log-neighbor-changes, eigrp log-neighbor-warnings, eigrp router-id, eigrp stub, ipv6 authentication key-chain eigrp, ipv6 authentication mode eigrp, ipv6 eigrp, ipv6 hello-interval eigrp, ipv6 hold-time eigrp, ipv6 next-hop-self eigrp, ipv6 router eigrp, ipv6 split-horizon eigrp, ipv6 summary-address eigrp, ipv6 unicast-routing, key, key chain, key-string, metric weights, send-lifetime, show ipv6 eigrp, show ipv6 eigrp neighbors.

EIGRP IPv6 VRF Lite

15.1(1)S

The EIGRP IPv6 VRF Lite feature provides EIGRP IPv6 support for multiple VRFs. EIGRP for IPv6 can operate in the context of a VRF. The EIGRP IPv6 VRF Lite feature provides separation between routing and forwarding, providing an additional level of security because no communication between devices belonging to different VRFs is allowed unless it is explicitly configured. The EIGRP IPv6 VRF Lite feature simplifies the management and troubleshooting of traffic belonging to a specific VRF.

The EIGRP IPv6 VRF Lite feature is available only in EIGRP named configurations.

There are no new or modified commands for this feature.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.