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Cisco Voice Log Translator User Guide

Cisco Voice Log Translator (Cisco VLT) is a troubleshooting tool that reads complex System Diagnostic
Interface (SDI) trace log message files from a Cisco Unified Communications Manager and translates them
into a user-friendly, English-based format. You can sort, organize, analyze, and interpret messages and
display raw or translated message text using offline message files on your system.

Cisco VLT version 2.7(9) provides support for the following features and support:

• Support for Cisco Unified Communications Manager version 10.0(1).

• Runs as a standalone application on Linux andWindows systems and as a plug-in in the trace collection
tool Cisco Unified Communications Manager Real-Time Monitoring Tool (RTMT) on both Linux and
Windows systems.

• Fully supports trace log messages for these additional protocols:

◦H.323 version 5 (Q.931, H.225, ASN.1)

◦Session Initiation Protocol (SIP)

• Continues support of SDI trace log file formats from Cisco CallManager version 3.3, Cisco Unified
CallManager versions 4.0, 4.1, 5.0, 5.1, and Cisco Unified CommunicationsManager 6.0, 7.0, 7.1, 8.0,
9.0, and 10.0(1).

• Support for Windows 8 Operating System (32-bt and 64-bit)

• Support for Windows 8.1 Operating System (32 bit and 64-bit)

• Support for Windows Server 2012 R2 Operating System (64-bit)

You can access more information about Cisco VLT, including how to download and install the latest version,
in the Cisco VLT Software, on page 3 section. If you require further assistance, send email to:
voice-log-translator-support@external.cisco.com.

This document describes how to use Cisco VLT. Primary users include Cisco Systems Engineers, Technical
Assistance Center (TAC) Engineers, Channel Partners, and others who performCiscoUnified Communications
Manager administrative tasks or use trace log message files to troubleshoot VoIP network problems.
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C H A P T E R  1
Prerequisites for Cisco VLT

This section provides general information about using and supporting Cisco VLT in your system:

• Cisco Unified Communications Manager, page 1

• System Hardware and Operating System, page 2

• Cisco VLT Software, page 3

Cisco Unified Communications Manager
To use Cisco VLT with Cisco Unified Communications Manager, follow these steps:

Procedure

1 Download and install one of the following versions: Cisco CallManager 3.3, Cisco Unified CallManager
4.0, 4.1, 5.0, 5.1, and Cisco Unified Communications Manager 6.0, 7.0, 7.1, 8.0, 9.0, or 10.0(1).

2 Configure Cisco Unified Communications Manager to generate SDI trace log message files. Set the SDI
logging level to the highest value.

Note • For versions 9.0 and later, the SDI traces are logged into SDL trace file.

• Enable Correlation TagMapping Trace flag under SDL configuration must be enabled. For more
information, see the Cisco Unified Serviceability Administration Guide.

Collect Cisco Unified Communications Manager message files and store them on your local system—either
manually or using Cisco .Unified Communications Manager RTMT. For more information, refer to the Cisco
Unified Communications Manager RTMTManual at the following URL: http://www.cisco.com/en/US/docs/
voice_ip_comm/cucm/service/9_0/rtmt/CUCM_BK_CA3A517A_00_
cisco-unified-rtmt-administration-90.pdfhttp://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/service/
10_0_1/rtmt/CUCM_BK_CA30A928_00_cisco-unified-rtmt-administration-100.pdf. You can install RTMT,
which works for resolutions 800*600 and above, on any of the following platforms:

• Microsoft Windows 98

• Microsoft Windows 2000

Cisco Voice Log Translator 2.7(9) User Guide    
    OL-32061-01 1

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/service/9_0/rtmt/CUCM_BK_CA3A517A_00_cisco-unified-rtmt-administration-90.pdf
http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/service/9_0/rtmt/CUCM_BK_CA3A517A_00_cisco-unified-rtmt-administration-90.pdf
http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/service/9_0/rtmt/CUCM_BK_CA3A517A_00_cisco-unified-rtmt-administration-90.pdf
http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/service/10_0_1/rtmt/CUCM_BK_CA30A928_00_cisco-unified-rtmt-administration-100.pdf
http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/service/10_0_1/rtmt/CUCM_BK_CA30A928_00_cisco-unified-rtmt-administration-100.pdf


• Microsoft Windows XP

• Microsoft Windows Vista

• Microsoft Windows 7 Operating System

• Microsoft Windows 8 (32-bit and 64-bit)

• Microsoft Windows 8.1 (32-bit and 64-bit)

• Microsoft Windows Server 2012 R2 (64-bit)

• Red Hat Linux with KDE or Gnome desktop client

System Hardware and Operating System
Your system memory must meet the following requirements:

• A minimum of 24 MB of free memory for start up operation

• Must be able to correctly parse a 2 MB log file

• Virtual (swapable) memory must not be lower than the value recommended by Microsoft Windows, if
your system has less than 512 MB of physical memory.

Your system must run one of the following platforms (the platform must support the Sun Microsystems Java
runtime environment):

• Red Hat Linux version 9 or Red Hat Enterprise Linux AS 3.0

• Microsoft Windows 8

• Microsoft Windows 8.1

•Windows Server 2012 R2

• Microsoft Windows 7 Operating System

• Microsoft Windows Vista

• Microsoft Windows 2003

• Microsoft Windows 2000 (including Windows 2000, Windows 2000 Professional, and Windows 2000
Server)

• Microsoft Windows XP

Youmust install CiscoVLT on amachine other than your CiscoUnified Communications
Manager server. Cisco VLT can use significant system CPU and memory resources
and, if installed on the same machine, might impact Cisco Unified Communications
Manager performance.

Note
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Cisco VLT Software
Follow this procedure to download Cisco VLT software and install it on a writable partition.

Although earlier versions may be listed on the website, you can download only the latest version. You
cannot upgrade from a previous version; you must do a clean install of the latest version, during which
you are prompted to manually uninstall any earlier version.

Note

Before You Begin

• Install Cisco Unified Communications Manager RTMT. (Optional)

• Ensure that you have a Cisco login and password.
Procedure

1 Go to the following URL:

http://www.cisco.com/cisco/software/navigator.html?mdfid=278875240&i=rp.

2 Choose Unified Communications > Call Control > Cisco Unified Communications Manager
(CallManager).

3 Choose the version of Cisco Unified Communications Manager you need to download Cisco VLT.

4 Choose Voice Log Translator (VLT) Software.

The Linux or Windows installer can be chosen for download.

5 Confirm the location of the executable file. The default location (which can be changed) is as follows:

• Linux: /opt/cisco/vlt

• Windows: C:\Program Files\Cisco\VLT

6 Choose the installation type:

• Standalone

• Plug-in

A standalone system can run as a plug-in. A plug-in system cannot run as a standalone.Note

7 Create a folder to store trace log message files. This folder must be on the same physical or logical network
drive or on a network neighborhood path, such as\\server-name\folder-name\log-file-name.
It cannot be a URL.
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C H A P T E R  2
Restrictions for Cisco VLT

The following sections provide information on the restrictions for Cisco VLT version 2.7(9).

• Languages, page 5

• File Types, page 5

• System Resources, page 6

• System Instances, page 6

• System Performance, page 6

• Display Capabilities, page 6

• User Interface, page 6

• Endianness, page 7

Languages
Cisco VLT supports only English operating systems and English locale.

File Types
Cisco VLT supports only Cisco Unified Communications Manager and Java Telephony Application
Programming Interface (JTAPI) client message files.

Cisco VLT supports Cisco Unified Communications Manager SDI files but not Signal Distribution Layer
(SDL) files:

• This is true for versions prior to Cisco Unified Communications Manager 9.0.

• For versions startingwith CiscoUnified CommunicationsManager 9.0 and later, SDI traces are interleaved
in SDL trace files and Cisco VLT supports parsing of these interleaved SDL trace files.
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System Resources
Cisco VLT can use significant system CPU and memory resources, and can potentially impact performance
on a shared system. See the note in the System Hardware and Operating System, on page 2 section about
the importance of installing Cisco VLT on a machine other than your Cisco Unified CommunicationsManager
server.

Cisco VLT supports a maximum memory usage of 1 GB. However, system performance may degrade before
reaching the maximum value.

System Instances
You can install only one Cisco VLT in each system.

A maximum of two running instances, one standalone and one plug-in, are allowed at the same time.

System Performance
Cisco VLT installed on a 2.4 GHz Intel Pentium 4 CPU performs as follows:

• Installation time—5 minutes (approximate)

• Program startup—20 seconds (approximate)

• Memory consumption—Up to 10 MB per 2.5 MB of trace log file size

• File loading—10 seconds (approximate) per 2.5 MB of trace log file size

Cisco VLT may exhaust memory if more than 100 SDI files of at least 2.5 MB each are
opened.

Note

Display Capabilities
Although Cisco VLT supports both H.225 and H.245 messages, you cannot identify them because the H.245
port information contained in an H.225message is not available in the Cisco Unified CommunicationsManager
log files.

User Interface
For Cisco VLT running as a plug-in in Cisco Unified CommunicationsManager RTMT, the following applies:

• There is no Cisco VLTmenu bar. Functions that are provided by the menu bar in a standalone Cisco VLT
(not running in RTMT) are provided by the Cisco VLT toolbar, pop-up menu on the 'Messages' table,
or keystroke. To avoid conflict with RTMT functions, some keystrokes, such as F3 and Ctrl-F4, are
disabled or behave differently for standalone Cisco VLT.
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• There is no Cisco VLT 'About window' for version information and 'Help Topics' function for online
documentation. The online documentation link is referenced in the RTMT documentation launching
function and the VLT plug-in version information is shown in the RTMT 'About window'.

• There are no accessibility options.

• There are no shortcut keys.

Endianness
Cisco VLT supports only little-endian, and is not aware of the endianness of trace files.

Endianness refers to the order in which a computer processor stores and transmits the individual bytes of
a multiple-byte data item. For more information see the glossary.

Note
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C H A P T E R  3
Information About Cisco VLT

Cisco VLT enables you to display and filter trace log message lists, display associated raw or translated
message texts, and find specific information within those texts.

This section contains these topics:

• Cisco VLT Capabilities, page 9

• Troubleshooting a Typical Cisco VLT Use Scenario, page 10

• Cisco VLT GUI Display and Navigation, page 11

• Cisco VLT Message Translations, page 14

Cisco VLT Capabilities
This section contains information on these topics:

• Signaling Protocols, on page 9

• Search Functions, on page 10

Signaling Protocols
Cisco VLT handles the following file types (in separate calls or in a single call):

• H.225 and H.245

• JTAPI

• Media Gateway Control Protocol (MGCP) and Call Associated Signaling (CAS)

• Q.931

• Session Description Protocol (SDP)

• Simple Client Control Protocol (SCCP)

• Session Initiation Protocol (SIP)
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Search Functions
Cisco VLT offers two search functions:

• The Filter function (see the Filtering the Trace Log Message List, on page 20) uses the list of messages
in the Messages upper pane and the associated raw messages in the Messages Translation lower pane.

• The Find in Messages Translation function (see the Finding Information in Trace Log Message Text,
on page 23) operates on the current message in the Messages Translation lower pane.

Other Functions
You can do the following with Cisco VLT:

• Open trace logmessage files and displaymessage lists and associatedmessages for all supported signaling
protocols in the same window (see the Displaying a List of Trace Log Messages, on page 17).

• Filter a trace log message list to do the following (see the Finding Information in Trace Log Message
Text, on page 23 section):

◦Display or exclude keepalive messages.

◦Display messages for a particular call (as identified by its call reference) or for all calls involving
a particular device IP address, direction (send or receive), protocol, command, message, or channel.
For example, you can display all messages related to the T1 1/0:3 on gateway A.B.C.D.

◦Display messages for calls with specified criteria.

◦Display messages by call reference; each message contains show timestamp, protocol, calling
number, and called number. For example, you can display all messages for a particular call leg
(any supported protocol) or for both legs (SCCP side and MGCP/Q.931 side) of a call.

◦Displaymessages for calls whose device IP address, direction (send or receive), protocol, command,
message, call reference, or channel contains a text string.

◦Specify a level of translation (raw, simple, or detailed) for the text of a trace log message
(see Finding Information in Trace LogMessage Text, on page 23). You can copy the message
text to the clipboard, export translated messages to a text file, and search for a specific test
string in message text.

If the signaling protocol for a message is invalid or not supported, you can display the
message in raw format only.

Note

Troubleshooting a Typical Cisco VLT Use Scenario
If you are an experienced administrator, familiar with Cisco products (including Cisco Unified Communications
Manager, IOS command-line interface, and networking concepts and technologies) and are responsible for
post-installation support of enterprise voice installations, use the following procedure to troubleshoot a scenario:

   Cisco Voice Log Translator 2.7(9) User Guide
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Procedure

1 Receive notification of a problem with a Cisco Unified Communications Manager or JTAPI application.

2 Enable trace logging on relevant Cisco Unified Communications Manager servers or JTAPI clients.

3 Retrieve the following information about the problem call:

• Time of call, including the minutes and seconds

• Called-party and calling-party phone numbers

• Nodes involved (Cisco Unified Communications Manager, gateway, JTAPI application, etc.)

• Call flow (whether transfer, conference, or forward are involved; whether the call is internal or
external; types of devices involved, etc.)

4 Collect trace log message files from the Cisco Unified Communications Manager or JTAPI client, usually
several files surrounding the time of the event.

5 Open the file whose time stamp is closest to the reported trouble time. (Alternatively, depending on
circumstances, open the entire collection of trace files at once.)

6 Search each file's translated message text (by using the Find in Messages Translation function) until you
locate the called or calling phone number for the trouble-causing call. Note the call reference.

7 Filter the display based on call reference to display all messages that pertain to that call.

8 Troubleshoot as needed. Possible actions depend on the type of problem, but include the following:

• Save the one or more trace log message translations that pertain to the call to a flat file, open them
with a text editor, and locate the exact timestamp or other helpful information.

• Compare two or more message translations (typically for different calls) by using the Filter >
by Highlighted Rows function to display the translations together. Comparing the translations for
a successful and a failed call is a useful troubleshooting technique.

Cisco VLT GUI Display and Navigation
The Cisco VLT user interface has a toolbar at the top, followed by two display panes (Cisco VLTGUI Display
and Navigation, on page 11 [standalone system] and Cisco VLT GUI Display and Navigation, on page 11
[plug-in system]):

• Messages upper pane—Displays a list of trace log messages from one or more files.

Cisco Voice Log Translator 2.7(9) User Guide    
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• Messages Translation lower pane—Displays the raw or translated text of a highlighted message.

Figure 1: Cisco VLT User Interface (Standalone System)

Figure 2: Cisco VLT User Interface (Plug-In System)
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The window allows for typical GUI display control such as window resize, column resize, vertical and
horizontal scroll, minimize, restore, and close. You can also grab and move the border between the Messages
upper pane and the Messages Translation lower pane.

You navigate the Cisco VLT interface using the toolbar as shown in Cisco VLT GUI Display and Navigation,
on page 11.

Figure 3: Cisco VLT Toolbar

The toolbar has both a top line (with text) and a bottom line (with icons).
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To navigate using the top line. choose one of the displayed choices—File, Edit, Filter, View, or Help. These
selections open a successive context-sensitive display of new choices, as shown in Cisco VLT GUI Display
and Navigation, on page 11.

Figure 4: Cisco VLT Toolbar: Successive Display of Choices

Alternatively, you can navigate using the icons on the bottom line. Icons for Open Log Files, Open and Add
Log Files into Current Log Panel, Save Translated Messages, Copy, Paste, Find in Translated Message,
Advanced Filter, and Call References duplicate most of the text options for the top line.

Cisco VLT Message Translations
Cisco VLT allows you to view message (raw) text at one of two translation levels. Examples of raw and
translated messages, and how they display the same information (in this case, the code word X in an MGCP
NTFY message), are as follows:

• Raw message (Cisco VLT Message Translations, on page 14)—Displays the code word as X:9

• Simple translation (Cisco VLT Message Translations, on page 14)—Displays the code word as
RequestIdentifer(X): 9
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• Detailed translation (Cisco VLT Message Translations, on page 14)—Displays the code word as X: 9
-- Request ID is 9

Figure 5: Cisco VLT Raw Message

Figure 6: Cisco VLT Simple Translation

Figure 7: Cisco VLT Detailed Translation
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C H A P T E R  4
How to Use Cisco VLT

The following sections provide information on using Cisco VLT.

• Displaying a List of Trace Log Messages, page 17

• Filtering the Trace Log Message List, page 20

• Finding Information in Trace Log Message Text, page 23

Displaying a List of Trace Log Messages
You can open trace log message files and display a list of messages as follows:

• Display a list of messages for a set of log files—refer to Detailed Steps, on page 18 in the Summary
Steps, on page 17 section.

• Display a list of messages for an additional set of log files, in the same pane or a new pane—refer to
Detailed Steps, on page 18 in the Summary Steps, on page 17 section.

• Edit the message-list display—refer to Detailed Steps, on page 18 in the Summary Steps, on page 17
section.

Summary Steps
To display a list of trace log messages, follow these summarized steps:

Procedure

1 Choose Start > Programs > Cisco VLT > VLT.

2 Choose File > Open > Open > Yes/No.

3 Choose File > Append > Open > Yes/No.

4 Choose View...

5 Choose File > Save Translation.

6 Choose File > Close and File > Exit.
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Detailed Steps
To display a list of trace log messages, follow these detailed steps:

1 Choose Start > Programs > Cisco VLT > VLT to open Cisco VLT.

2 In the Open Files box, go to the folder where the trace log message files are stored, highlight one or more
filenames (use <Ctrl> or <Shift> as needed to select multiple messages) and click Open.

The first 1000 selected files open in a single pane, sorted by timestamp.

The number of files that you can open is limited only by available system memory. If files are large,
system performance may be affected.

Note

If you open multiple log files, the tab displays only the first filename.Note

1 Open an additional set of log files, if needed:

• Choose File > Append.

• Highlight one or more filenames and click Open.

2 Edit the Messages upper pane display:

• To display or hide columns, choose View > Columns, check or uncheck the boxes, as needed.
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• To display all calls in a file, chooseView > List All CallRefs. A new window displays the following
information depending on protocol and message types: timestamp, protocol, call reference, calling
party, and called party. Close the window when finished.

Figure 8: Cisco VLT View Menu

To change the display contrast and font size, follow these steps:

Procedure:

1 Choose View > Configuration as shown in Detailed Steps, on page 18.

2 Choose a log level (off, fatal, error, warn, info, debug, or all).

3 Choose a theme (default or high contrast).

4 Choose a font size (small, normal, or large).

5 Click OK.

Figure 9: Cisco VLT Configuration Window

6 Edit the Messages Translation lower pane display by toggling among the following choices: Raw, Simple,
and Detailed.
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If the signaling protocol for a message is invalid or not supported, you can display the message in raw
format only.

Note

7 To open and display the trace log files that contain one or more particular messages, highlight the messages,
right-click, and selectOpen Trace File. Newwindows display the trace log files. To search for a particular
text string, use the Find box. Close the windows when you are finished.

To display a list of valid wildcards and operations, choose Help > Regular Expression Reference.Note

8 To save a message translation to a flat text (.txt file extension) file, choose File > Save Translation. In
the Save File box, enter a location and name for the new file, and click Save.

9 When you are finished, close any active messages-list windows by choosing File >Close. Exit Cisco VLT
by choosing File > Exit.

Filtering the Trace Log Message List
You can filter a trace log message list to do the following:

• Display or exclude keep-alive messages, see Detailed Steps, on page 21 below.

• Display a list of messages with criteria that you check or supply, or with the same criteria as those
possessed by messages that you highlight, see Detailed Steps, on page 21 below. Criteria includes the
following:

◦Retries—Messages that are flagged as retried messages.

◦Highlighted device IP—Device IP address where messages are sent or received. Typically includes
Cisco Unified Communications Manager, Cisco IOS gateways, IP phones, and more.

◦Highlighted direction—Receive or Send.

◦Highlighted protocol—H.225, H.245, JTAPI, MGCP, Q.931, SCCP, or SIP.

◦Highlighted message type—Example: Q.931 SETUP messages.

◦Highlighted call reference—The call-reference string in the CallRef column.

◦Highlighted channel—A voice port on a device. Examples: B channels on a PRI, a voice port on
an IP phone, a CTI port for JTAPI.

◦Highlighted call—All messages that are associated with the call for which one or more messages
are highlighted, across multiple signaling protocols (MGCP, Q.931, SCCP, and SIP).

◦Highlighted rows—Only the highlighted messages use <Ctrl> or <Shift> as needed to select
multiple rows. If you highlight multiple messages, the Messages Translation lower pane displays
the message for the last selected message.

◦Keyword—Messages that contain a specified text string.

◦Abnormal disconnect—Messages that have abnormal disconnect causes (cause codes that designate
abnormal disconnect vary by protocol). This applies to calls that disconnect for reasons other than
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Normal Call Clearing or User Busy. Calls that disconnect because the user dials an invalid prefix
or other numbers is classified as an abnormal disconnect.

◦Excluding keepalive.

◦Display a list of messages for calls with specified criteria—this is useful if you prefer to enter
parameters directly instead of selecting messages in the Messages upper pane, see Detailed
Steps, on page 21 below.

Summary Steps
To filter the trace log message list, perform the following steps:

Procedure

1 Display message list.

2 Choose Exclude KeepAlive.

3 Choose Filter...

4 Choose Filter > Advanced Filter...

5 Choose File > Close and File > Exit.

Detailed Steps
To filter the trace log message list, perform the following detailed steps:

1 Display the desired message list (see the Displaying a List of Trace Log Messages, on page 17).

2 To suppress display of keepalive messages, check the Exclude KeepAlive box.

3 To display messages that contain a specific text string, enter the text in the Keyword box and press Enter.

4 To define a filter based on existing message displays, do the following:

The Filter function operates on the list of messages in the Messages upper pane.Note

Cisco Voice Log Translator 2.7(9) User Guide    
   OL-32061-01 21

How to Use Cisco VLT
Summary Steps



In contrast, the Find in Messages Translation function (see the Finding Information in Trace LogMessage
Text, on page 23), operates on the current message in the Messages Translation lower pane.

Note

• Highlight one or more messages (use <Ctrl> or <Shift> as needed to select multiple messages) with
the desired device IP, direction, protocol, message type, call reference, channel, or call.

• Click Filter (or right-click the highlighted message), then check the desired filter criteria and, if
prompted, enter required information such as keywords (Detailed Steps, on page 21). (To see a list
of filter criteria, see the discussion preceding this procedure.) Column headings for the desired criteria
display in parentheses.

• Repeat, as needed, to further filter by other criteria.

To disable a filter, click the column headings in parentheses or choose Filter > Clear All Filters.Note

Figure 10: Cisco VLT Filter Menu

5 A customized filter is useful if you know the parameters and prefer to enter them directly instead of
constructing filters by selecting messages in the Messages upper pane. To define your own customized
filter, do the following:

6 Choose Filter > Advanced Filter.
7 Check and uncheck the displayed conditions as appropriate. Review the displayed values for each condition

and edit them using wildcards and simple AND and OR operations.

To display a list of valid wildcards and operations, click ?.Note
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To clear all entries, click Clear. To reload the current filter, click Current.Note

8 Click Ok. A filtered list displays.
9 When you are done, do the following:

10 Close any active messages-list windows by choosing File > Close.
11 Exit Cisco VLT by choosing File > Exit.

Finding Information in Trace Log Message Text
You can do the following with the text of a trace log message:

• Specify a level of translation—raw, simple, or detailed (Detailed Steps, on page 23 below).

• Copy message text to the clipboard (Detailed Steps, on page 23 below).

• Search for a specific message-text string (Detailed Steps, on page 23 below).

• Display the desired message text.

Summary Steps
To find information in trace log message text, perform the following steps:

Procedure

1 Display message list.

2 Choose Raw, Simple, or Detailed.

3 Choose Edit > Copy.

4 Choose Edit > Find in Messages Translation.

5 Choose File > Close and File > Exit.

Detailed Steps
To find information in trace log message text, perform the following detailed steps:

1 Display the desired message list (see the Displaying a List of Trace Log Messages, on page 17).

2 Specify a level of translation by toggling among the following choices—Raw, Simple, or Detailed (see
samples of each in the Cisco VLT Message Translations, on page 14).

3 To copy a message translation to the Windows clipboard, do the following:

4 Highlight the message or translation that you want to copy.
5 Choose Edit > Copy or click the Copy icon.
6 To search for a specific text string in the Messages Translations lower pane for all messages listed in the

Messages upper pane, do the following:
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The Find in Messages Translation function operates on the current message in the Messages Translation
lower pane.

Note

In contrast, the Filter function (see the Filtering the Trace Log Message List, on page 20), operates on
the list of messages in the Messages upper pane.

Note

7 Choose Edit > Find in Messages Translation or click the Find in Translated Message icon.
8 In the Text to Find box, type a text string using wildcards and simple AND and OR operations, then click

Find Next. The first match is highlighted (Detailed Steps, on page 23).

To display a list of valid wildcards and operations, choose Help > Regular Expression Reference.Note

9 Choose Edit > Find Again to highlight additional instances.

Figure 11: Cisco VLT Edit Menu

10 When you are finished, do the following:

11 Close any active messages-list windows by choosing File > Close.
12 Choose File > Exit to exit Cisco VLT.
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C H A P T E R  5
Troubleshooting

The following table lists troubleshooting techniques for Cisco VLT.

Table 1: Troubleshooting Cisco VLT

Recommended ActionPossible CauseSymptom

Log off and log on again to activate the
environment variables

Some Cisco VLT system
environment variables are not
activated during the same
windows-terminal service session
when Cisco VLT is installed on a
Windows 2000 Server platform

Cisco VLT on aWindows
2000 Server platform
cannot be launched using
a remote desktop tool

NoneThe messages or their protocols are
unsupported

You can display raw
messages but not
simple-translation or
detailed-translation
messages

Display the first log file in the call flow
then append subsequent log files (See the
Displaying a List of Trace Log Messages,
on page 17

Calls in the call flow span multiple
log files

A list of messages shows
only those calls at the
beginning or end of a call
flow

NoneCisco VLT displays only
information that is available and
appropriate for the protocol and
message type. For example,
Cisco VLT does not display
CallRef information for SCCP
Keepalive messages because those
messages do not contain such
information

The display does not list
all possible call criteria

Install EnglishWindows and set the locale
to English

TheWindows platform may not be
set to run the English version

The display shows odd
characters
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C H A P T E R  6
Additional References

This section contains the following information:

• Related Documents, page 27

• Standards, page 27

• MIBs, page 28

• RFCs, page 28

• Technical Assistance, page 29

Related Documents
This table lists additional documents for Cisco VLT information.

Table 2: Related Documentation

Document LocationRelated Topic

Cisco Unified Communications Manager library athttp://
www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_
support_series_home.html

Cisco Unified Communications
Manager and
Cisco Unified Communications
Manager Express documents

Cisco IOS Voice Configuration Library at http://www.cisco.com/
en/US/docs/ios/12_3/vvf_c/
cisco_ios_voice_configuration_library_glossary/vcl.htm

Cisco IOS Voice Configuration
Library documents, including library
preface and glossary

Standards
This table lists the standards referenced in this user guide.
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Table 3: Industry Standards

TitleStandard

ITU-T: Call Signaling and RAS in H.323 VOIP ArchitectureH.225

ITU-T: Control Protocol for Multimedia CommunicationH.245

Java Telephony API (JTAPI) Specification 1.4 Final Release 2JTAPI

RFC 3435: Media Gateway Control ProtocolMGCP

ITU: Q.931: ISDN Network Layer Protocol for SignalingQ.931

Cisco SCCP: Simple Client Control ProtocolSCCP

SIP: Session Initiation ProtocolSIP

MIBs
This table lists the MIBs for Cisco VLT.

Table 4: Cisco VLT MIBs

MIBs LinkMIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and
feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

None

RFCs
This table lists the RFC documents for Cisco VLT.

Table 5: RFC Documents

TitleRFC

SDP: Session Description ProtocolRFC 2327

SIP: Session Initiation ProtocolRFC 3261
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Technical Assistance
This table lists the URL for Technical Assistance and Support.

Table 6: Technical Assistance Information

LinkDescription

http://www.cisco.com/techsupportThe Cisco Technical Support & Documentation website
contains thousands of pages of searchable technical
content, including links to products, technologies,
solutions, technical tips, and tools. Registered Cisco.com
users can log in from this page to access even more
content.
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C H A P T E R  7
Glossary

This table contains definitions for terms used in this document.

Call Signaling and RAS in H.323 VoIP Architecture; an ITU standard in the H.323 VoIP
architecture. Governs session establishment and packetization where the transmission path
includes one or more packet-based networks that provide non guaranteed quality of service.

H.225

Control Protocol for Multimedia Communication; an ITU standard in the H.323 VoIP
architecture. Governs control signaling and endpoint control.

H.245

Standard for packet-based video, audio, and data conferencing. Umbrella standard that
describes the architecture of a conferencing system and refers to other standards (H.245,

H.323

H.225.0, and Q.931) to describe its actual protocols. Defines a common set of codecs, call
setup and negotiating procedures, and basic data-transport methods that allow dissimilar
communication devices to communicate with each other.

Channel-associated signaling. The transmission of signaling information within the voice
channel. CAS signaling often is referred to as robbed-bit signaling because user bandwidth
is being robbed by the network for other purposes.

CAS

Way of expressing the order in which a computer processor stores and transmits the
individual bytes of a multiple-byte item of data. Big-endian processors store the most

endianness

significant byte at the memory location with the lowest address. Little-endian processors
store it at the location with the highest address.

Processors from different manufacturers vary in endianness (for example, Intel x86 uses
little and PowerPC uses big). Difficulties can potentially arise when data moves between
systems of different endianness. For example, the IP address 10.1.1.13 could be interpreted
as 13.1.1.10.

Java Telephony Application Programming Interface. A call-control model developed by
Sun Microsystems.

JTAPI

Media Gateway Control Protocol. Protocol that enables media gateway controllers and
media gateways to communicate for call control on VoIP networks.

MGCP
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ISDN Network Layer Protocol for Signaling; an ITU standard. Governs layer 3 ISDN call
establishment, maintenance, and termination of logical network connections between two
devices.

Q.931

Skinny (or Simple) Client Control Protocol. Cisco-proprietary protocol that defines
call-connection methods and signaling between IP phones and a router. Allows IP phones

SCCP

to coexist in an H.323 environment. Savings in memory size, processor power, and
complexity makes the protocol desirable.

Session Description Protocol. Protocol for describing multimedia sessions for the purposes
of session announcement, session invitation, and other forms ofmultimedia session initiation.

SDP

Session Initiation Protocol. Protocol, developed as an alternative to H.323, that equips
platforms to signal the setup of voice and multimedia calls over IP networks.

SIP

See Internetworking Terms and Acronyms for terms not included in this glossary.Note
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