Catalyst 6500 Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース12.2(33)SXH 以降のリリース
サーバ アクセスの mLACP の設定
サーバ アクセスの mLACP の設定
発行日;2012/08/23 | 英語版ドキュメント(2012/08/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

サーバ アクセスの mLACP の設定

サーバ アクセスの mLACP の概要

サーバ アクセスの mLACP の概要

mLACP 操作の概要

サーバ アクセスの mLACP の機能コンポーネント

mLACP システム ID

mLACP ポート ID

ポート チャネル ID

障害保護のシナリオ

mLACP フェールオーバー

概要

ダイナミック ポート プライオリティ

リバーティブ モードと非リバーティブ モード

シャーシ間冗長マネージャを使用したピア モニタリング

サーバ アクセスの mLACP に関する注意事項および制約事項

サーバ アクセスの mLACP の設定

mLACP PoA の設定値の要約

mLACP のグローバル オプションの設定

シャーシ間通信チャネルの設定

ICC ポートの設定

ICCP ルーティングの設定

シャーシ間冗長グループの設定

シャーシ間冗長グループの設定

mLACP ポート チャネル インターフェイスの設定

mLACP メンバ ポートの設定

PoA フェールオーバーの強制

mLACP のトラブルシューティング

アクティブ PoA の確認

show lacp multi-chassis group

show lacp multi-chassis port-channel

show etherchannel summary

show etherchannel channel_id port-channel

show lacp internal

show lacp neighbor

スタンバイ PoA の確認

show lacp multi-chassis group

show lacp multi-chassis portchannel

show etherchannel summary

show etherchannel channel_id port-channel

show lacp internal

show lacp neighbor

サーバ アクセスの mLACP の設定

この章では、サーバ アクセスのマルチ シャーシ LACP(mLACP)機能を設定する方法について説明します。Release 12.2(33) SXJ 以降のリリースでは、サーバ アクセスの mLACP 機能をサポートします。この章で説明する内容は、次のとおりです。

「サーバ アクセスの mLACP の概要」

「サーバ アクセスの mLACP に関する注意事項および制約事項」

「サーバ アクセスの mLACP の設定」


) • EtherChannel の詳細については、「EtherChannel の設定」 を参照してください。

IEEE 802.3ad Link Aggregation Control Protocol(LACP)の詳細については、「IEEE 802.3ad LACP EtherChannel 設定の概要」を参照してください。


 

サーバ アクセスの mLACP の概要

ここでは、サーバ アクセスの mLACP について説明します。

「サーバ アクセスの mLACP の概要」

「mLACP 操作の概要」

「障害保護のシナリオ」

「mLACP フェールオーバー」

サーバ アクセスの mLACP の概要

サーバ アクセスの mLACP 機能は、Catalyst 6500 スイッチ ペアから 1 台のサーバへの単一冗長レイヤ 2 LACP リンクをサポートします。図 20-1 に、サーバに接続しているスイッチを示します。

図 20-1 サーバ アクセスの mLACP のトポロジ

 

サーバ アクセスの mLACP トポロジでは、サーバは 2 つのレイヤ 2 リンクを介して接続されたデュアル ホーム接続デバイスです。サーバでは、レイヤ 2 LACP EtherChannel のメンバとして設定されたポートにリンクが接続されています。これらのリンクは、1 つのリンクのみが常にアクティブで、これによりレイヤ 2 のループを防ぎ、スパニングツリー プロトコル(STP)要件に対する制限が行われない、アクティブ スタンバイ冗長モードで機能します。

各リンクは、接続点(PoA)として機能するスイッチに接続します。スイッチには、レイヤ 2 マルチ シャーシ EtherChannel(MCEC)のメンバとして設定されたポートにリンクが接続されています。MCEC は、シャーシ間通信チャネル上(ICC)でシャーシ間通信プロトコル(ICCP)を使用して、PoA 間の状態を同期します。


) • PoA として設定されたスイッチは、他の複数のスイッチとの mLACP ピア関係を形成できません。

スイッチからサーバへの接続は、PoA での mLACP ポート チャネル インターフェイスと、サーバでの LACP ポート チャネル インターフェイスとの間の接続です。


 

mLACP 操作の概要

ここでは、mLACP 操作について説明します。

「サーバ アクセスの mLACP の機能コンポーネント」

「mLACP システム ID」

「mLACP ポート ID」

「ポート チャネル ID」

サーバ アクセスの mLACP の機能コンポーネント

次の表に、PoA で互換性を持つように設定する必要がある機能コンポーネントを示します。

 

アクティブ PoA(スイッチ A)
スタンバイ PoA(スイッチ B)

コンポーネント:

シャーシ間通信チャネル(ICC)

定義:

PoA に接続して ICCP トラフィックだけを伝送するするリンク。

注:

ICC は、シャーシ間通信プロトコル(ICCP)トラフィックだけをサポートします。

スイッチ A では、 ip address インターフェイス コマンドで、ICC リンクのスイッチ A 側で IP アドレスを設定します。

スイッチ B では、 ip address インターフェイス コマンドで、ICC リンクのスイッチ B 側で IP アドレスを設定します。

コンポーネント:

mLACP 冗長グループ

定義:

仮想 LACP ピアを形成する 2 つの PoA。

注:

1 つの mLACP 冗長グループで、複数の mLACP ポート チャネル インターフェイスをサポートできます。

mLACP 冗長グループは、両方の PoA で同じ mLACP シャーシ間 グループ ID を持ちます。

ポート チャネル インターフェイスで設定されている mLACP シャーシ間グループ ID は、mLACP 冗長グループのメンバとしてこれらを設定します。

スイッチ A では、 member ip redundancy group コマンドで、スイッチ B 上の ICC-link IP アドレスをポイントします。

スイッチ B では、 member ip redundancy group コマンドで、スイッチ A 上の ICC-link IP アドレスをポイントします。

スイッチ A では、 mlacp system-priority redundancy group コマンドで、 mLACP システム ID 値の一部として冗長グループの PoA で使用される、スイッチ A の mLACP システム プライオリティ 値を設定します。

スイッチ B では、 mlacp system-priority redundancy group コマンドで、 mLACP システム ID 値の一部として冗長グループの PoA で使用される、スイッチ B の mLACP システム プライオリティ 値を設定します。

スイッチ A では、 mlacp system-mac redundancy group コマンドで、 mLACP システム ID 値の一部として冗長グループの PoA で使用される、スイッチ A の mLACP システム プライオリティ 値を設定します。

スイッチ B では、 mlacp system-mac redundancy group コマンドで、 mLACP システム ID 値の一部として冗長グループの PoA で使用される、スイッチ B の mLACP システム プライオリティ 値を設定します。

スイッチ A では、 mlacp node-id redundancy group コマンドで、 mLACP ポート ID 値の一部として冗長グループの PoA で使用される、スイッチ A の mLACP ポート番号 値を設定します。

スイッチ B では、 mlacp node-id redundancy group コマンドで、 mLACP ポート ID 値の一部として冗長グループの PoA で使用される、スイッチ B の mLACP ポート番号 値を設定します。

スイッチ A では、 backbone interface redundancy group コマンドで、ネットワークとの間でサーバ トラフィックを伝送するスイッチ A の物理ポートで mLACP リンク ステータス モニタリングを設定します。

スイッチ B では、 backbone interface redundancy group コマンドで、ネットワークとの間でサーバ トラフィックを伝送するスイッチ B の物理ポートで mLACP リンク ステータス モニタリングを設定します。

コンポーネント:

ポート チャネル インターフェイス

定義:

DHD 接続リンクを設定するポート チャネル インターフェイス コマンド。

注:

各ポート チャネル インターフェイスは、1 台のサーバへの 1 つのレイヤ 2 リンクをサポートします。

ポート チャネル インターフェイスは、一致する interface port-channel ポート チャネル インターフェイス コマンド ID 値を使用して両方の PoA で設定されている必要があります。

mLACP シャーシ間グループ ID を mlacp interchassis group ポート チャネル インターフェイス コマンド ID 値として両方の PoA で使用します。

スイッチ A では、 mlacp lag-priority ポート チャネル インターフェイス コマンドは、 mLACP ポート ID 値の一部として冗長グループの PoA で使用される、スイッチ A の mLACP ポート プライオリティ 値を設定します。

スイッチ B では、 mlacp lag-priority ポート チャネル インターフェイス コマンドは、 mLACP ポート ID 値の一部として冗長グループの PoA で使用される、スイッチ B の mLACP ポート プライオリティ 値を設定します。

コンポーネント:

ポート インターフェイス

定義:

mLACP ポート チャネル インターフェイスのメンバとしてレイヤ 2 DHD 接続リンクを設定するインターフェイス コマンド。

注:

mLACP ポートチャネル ID 値を使用して設定されている channel-group インターフェイス コマンドは、ポートを mLACP ポート チャネル インターフェイスのメンバにします。

mLACP システム ID

各 mLACP 冗長グループでは、最小の mLACP システム ID 値を持つ PoA がリンク選択 PoA となります。リンク選択 PoA は、アクティブになるリンクの選択を制御します。mLACP システム ID の比較は、mLACP システム ID 値の符号なし整数値の数値比較です。

mLACP は、2 バイトの mLACP システム プライオリティ 値を最上位 2 オクテットとして、および設定された mLACP システム MAC アドレス 値を 8 バイト mLACP システム ID 値の最下位オクテットとして使用します。


) サーバ アクセスの mLACP 機能は、アクティブ リンク選択の DHD コントロールをサポートしません。PoA mLACP システム ID 値よりも数値的に高い LACP システム ID 値を持つように、DHD の LACP インスタンスを設定します。


mLACP システム プライオリティ

mlacp system-priority redundancy group コマンドは、mLACP システム プライオリティ値を設定します。低い値は、リンク選択 PoA として PoA の選択に影響を与えます。

mLACP システム MAC アドレス

mlacp system-mac redundancy group コマンドは mLACP システム MAC アドレスを設定します。低い値は、リンク選択 PoA として PoA の選択に影響を与えます。


) mLACP システム MAC 値は、PoA と DHD 間で送信される LACP PDU だけで使用されます。


mLACP ポート ID

各冗長グループでは、冗長グループの各ポート チャネル インターフェイスに関して、リンク選択 PoA は mLACP ポート ID 値が最も低いリンクを選択してアクティブにします。mLACP ポート ID の比較は、mLACP ポート ID 値の符号なし整数値の数値比較です。

mLACP は、2 バイトの mLACP ポート プライオリティ 値を最上位 2 オクテットとして、および設定された mLACP ポート番号 を 4 バイト mLACP ポート ID 値の最下位 2 オクテットとして使用します。

mLACP ポート プライオリティ

mlacp lag-priority ポートチャネル インターフェイス コマンドは、mLACP ポート プライオリティ値を設定します。低い値は、リンクの選択をアクティブにするのに役立ちます。

mLACP ポート番号

mlacp node-id redundancy group コマンドは、mLACP ポート番号を設定します。低い値は、リンクの選択をアクティブにするのに役立ちます。

ポート チャネル ID

port-channel id_number コマンドを使用してポート チャネル ID を作成し、 channel-group id_number インターフェイス コンフィギュレーション モード コマンドを使用して物理ポートをその ID に関連付けます。mLACP 冗長グループ内の 2 つの PoA でのポート チャネル ID は一致する必要があります。DHD 上のポート チャネル ID は、PoA で設定された値と異なっていてもかまいません。

障害保護のシナリオ

サーバ アクセスの mLACP 機能には、ポート障害、リンク障害、および PoA 障害からの保護によるネットワーク復元力が備わっています。この機能は 5 つに分類できます。図 20-2 に、文字 A ~ E で示した、ネットワーク内の障害ポイントを示します。

A:サーバ上のポートの障害

B:サーバ接続リンクの障害

C:アクティブ PoA でのサーバ接続ポートの障害

D:アクティブ PoA の障害

E:バックボーン インターフェイスの障害

図 20-2 サーバ アクセスの mLACP 保護の障害ポイント

 

これらのいずれかの障害が発生すると、mLACP は、アクティブ PoA からスタンバイ PoA へのスイッチオーバーを起動します。

概要

mLACP は、次の状況でフェールオーバーを強制実行します。

アクティブ PoA がサーバとの通信を失った場合(障害ポイント A、B、または C)、またはアクティブ PoA でのすべてのバックボーン インターフェイスに障害が発生した場合(障害ポイント E)、mLACP は、スタンバイ PoA のリンクにフェールオーバーします。(PoA フェールオーバーは発生しません)。

アクティブ PoA に障害が発生したことを ICRM がスタンバイ PoA に通知すると、スタンバイ PoA がアクティブになります。


) DHD はフェールオーバーの決定には関与しません。


ダイナミック ポート プライオリティ

デフォルトのフェールオーバー方式は、LACP の選択ロジックで、必要なスタンバイ リンクを SELECTED 状態および Collecting_Distributing 状態へ移行する場合、ローカル メンバ リンク上のダイナミック ポート プライオリティの変更を使用します。この状態の変更は、現在のアクティブ PoA にあるすべての対象メンバ リンクの LACP アクター ポート プライオリティ値が、スタンバイ PoA のポート プライオリティ(スタンバイ PoA のポートに、リンクをバンドルするためにより高い要求を付与する)よりも高い数値に変更されたときに発生します。アクター ポート プライオリティを変更すると、冗長グループ内のすべてのピアに対して mLACP Port Config Type-Length-Value(TLV)メッセージを送信します。これらのメッセージは、現在アクティブな PoA がそのロールを解放しようとしていることをスタンバイ PoA に知らせる通知としても機能します。次に、LACP はスタンバイ リンクを SELECTED 状態に移行し、現在アクティブなすべてのリンクを STANDBY に移行します。

ダイナミック ポート プライオリティの変更は、実行コンフィギュレーションまたは NVRAM 設定に対して自動的に書き出されません。現在のプライオリティをリロード時に使用する場合は、 mlacp lag-priority コマンドを設定して、その設定を保存します。

リバーティブ モードと非リバーティブ モード

mLACP 機能は、ダイナミック ポート プライオリティ機能をリバーティブ モードと非リバーティブ モードの両方に使用します。デフォルトの動作はリバーティブであり、これは単一シャーシ LACP でのデフォルトです。非リバーティブ モードは、mLACP でのみサポートされている lacp failover non-revertive コマンドをインターフェイス コンフィギュレーション モードで使用して、ポート チャネルごとにイネーブルにできます。

非リバーティブ モードはフェールオーバーを制限するため、トラフィックの損失が発生する可能性があります。ダイナミック ポート プライオリティの変更は、新たにアクティブになった PoA が、障害の発生した PoA が回復したあとでも引き続きアクティブであることを確認するために使用されます。

リバーティブ モード操作により、設定済みのプライマリ PoA が障害から回復したあとに、この PoA を強制的にアクティブ状態に戻します。ダイナミック ポート プライオリティの変更は、回復中の PoA がそのアクティブ ロールを再開できるようにするために必要なときに使用されます。

シャーシ間冗長マネージャを使用したピア モニタリング

シャーシ間冗長マネージャ(ICRM)は、次の方式を使用してピアをモニタできます。

Routewatch(RW):この方式がデフォルトです。

双方向フォワーディング検出(BFD):冗長グループは monitor peer bfd コマンドを指定して設定する必要があります。


) 冗長スーパーバイザ エンジンを使用したステート フル スイッチオーバー(SSO)配置の場合は、SSO フェールオーバー後に両方の PoA がアクティブになることを回避するために、BFD モニタリングと ICCP 接続のスタティック ルートを設定します。Routewatch は SSO をサポートしません。


各冗長グループ ピア内の各ピア(メンバ IP アドレスで指定)には、モニタリング隣接関係があります。同じ IP アドレスを持つ 2 つのピアがある場合、隣接関係はモニタリング モードに関係なく共有されます。たとえば、冗長グループ 1 と 2 がメンバ IP アドレス 10.10.10.10 とピア関係を持っている場合、10.10.10.10 への隣接関係は 1 つのみとなり、両方の冗長グループで共有されます。冗長グループ間で異なるモニタリング方式を使用できます。


) BFD は routewatch に完全に依存します。BFD モニタリングを開始するには、ICRM に対するピアへのルートが必要です。BFD には routewatch の意も含まれます。隣接関係のステータスが誤っているように思われることがありますが、ステータスは正確に状態を示しています。また、ピア PoA へのルートが、システム間の直接接続(バックツーバック)リンクを経由していない場合、BFD によって誤った結果がもたらされる可能性があります。


次の例では、 show redundancy interface コマンドの出力を示します。

Router# show redundancy interface
 
Redundancy Group 1 (0x1)
Applications connected: mLACP
Monitor mode: Route-watch
member ip: 201.0.0.1 ‘mlacp-201’, CONNECTED
Route-watch for 201.0.0.1 is UP
mLACP state: CONNECTED
 
ICRM fast-failure detection neighbor table
IP Address Status Type Next-hop IP Interface
========== ====== ==== =========== =========
201.0.0.1 UP RW
 

表 20-1 に、 show redundancy interchassis コマンドによって表示される隣接ステータスを示します。

 

表 20-1 show redundancy interchassis コマンドのステータス情報

隣接タイプ
隣接ステータス
意味

RW

DOWN

Routewatch または BFD が設定済みですが、指定された IP アドレスへのルートがありません。

RW

UP

Routewatch または BFD が設定済みです。Routewatch が実行中です。これは、ピアへの有効なルートがあることを示します。BFD が設定済みで、隣接ステータスが UP の場合、BFD はルートの隣接インターフェイスに設定されていない可能性があります。

BFD

DOWN

BFD が設定済みです。ルートが存在し、ルートの隣接は、BFD がイネーブルになっているインターフェイスに対して設定されています。BFD は開始されていますがピアがダウンしています。ピアが存在しないか、BFD がピアのインターフェイスに設定されていないため、DOWN ステータスの可能性があります。

BFD

UP

BFD が設定済みで動作可能です。

(注) 隣接タイプが BFD の場合、routewatch は、BFD のステータスに関係なく稼働しています。

サーバ アクセスの mLACP に関する注意事項および制約事項

サーバ アクセスの mLACP を設定する場合、次の注意事項および制約事項に従ってください。

PFC3A モードは、サーバ アクセスの mLACP 機能をサポートしません。

VSS モードは、サーバ アクセスの mLACP 機能をサポートしません。

100 以下の VLAN を、PoA として設定されたスイッチでアクティブにできます。

サーバ アクセスの mLACP 機能で設定されたスイッチは、Wireless Services Module(WiSM:WS-SVC-WISM-1-K9)または Wireless Services Module 2(WiSM-2:WS-SVC-WISM2-K9)をサポートできません。サーバ アクセスの mLACP 機能で設定されたスイッチに WiSM モジュールを取り付けないでください。WiSM モジュールが取り付けられているスイッチでサーバ アクセスの mLACP 機能を設定しないでください。( CSCtn90999

サーバ アクセスの mLACP 機能は、次をサポートしています。

接続ポイント(PoA)として設定された、Supervisor Engine 720 または Supervisor Engine 720-10GE を搭載した Catalyst 6500 スイッチのペア。


) PoA として設定されたスイッチは、複数の他のスイッチとの mLACP ピア関係を形成できません。


デュアル ホーム接続デバイス(DHD)として設定された、完全準拠 IEEE 802.3ad LACP をサポートするサーバ。


) CLI は、この制限を強制しませんが、IEEE 802.3ad LACP をサポートするサーバだけが、テストおよびサポートされている DHD です。


各 PoA から各 DHD への 1 つのレイヤ 2 アクセス リンク。


) CLI は、この制限を強制しませんが、各 PoA から各 DHD への 1 つのレイヤ 2 アクセス リンクだけが、テストおよびサポートされている設定です。


各 PoA の mLACP ポート チャネル インターフェイスごとに 1 つのレイヤ 2 アクセス ポートを備えたスイッチ ペアでの mLACP レイヤ 2 ポート チャネル インターフェイス。


) CLI は、この制限を強制しませんが、各 PoA の mLACP ポート チャネル インターフェイスごとの 1 つのレイヤ 2 アクセス ポートだけが、テストおよびサポートされている設定です。


サーバ アクセスの mLACP 機能には、mLACP 拡張モードがあります。

mLACP 拡張モードはデフォルトでディセーブルです。

port-channel mode mlacp-extended コマンドの入力後に mLACP 拡張モードをイネーブルにするには、リロードする必要があります。

mLACP 拡張モードがイネーブルでない場合、スイッチは、1 ~ 256 の番号が付けられた 128 の PaGP、LACP、または mLACP ポート チャネル インターフェイスをサポートします。これらのポート チャネル インターフェイスは、QoS、および ACL をサポートします。

mLACP 拡張モードがイネーブルの場合、スイッチは次をサポートします。

1 ~ 256 の番号が付けられた 128 の PaGP、LACP、または mLACP ポート チャネル インターフェイス。
これらのポート チャネル インターフェイスは、QoS および ACL をサポートします。

257 ~ 512 の番号が付けられた 128 の追加 mLACP ポート チャネル インターフェイス。
これらのポート チャネル インターフェイスは、QoS および ACL をサポートしません。

各 PoA がすべてのサーバ トラフィックを完全にサポートできるように PoA ネットワーク アクセスを設定します。ある PoA を他の PoA のネットワーク アクセス パスに含めないでください。

PoA 間のリンクにサーバ トラフィックがないことを確認します。

PoA 間のポイントツーポイント接続としてシャーシ間通信チャネル(ICC)を設定します。

ICCP トラフィックだけを伝送するように ICC を設定します。


) ICC でのトラフィック量は比較的低くなります。


mLACP の動作は、ICC が正しく機能している場合にのみサポートされます。可能な場合は、冗長接続として ICC を設定します。たとえば、利用可能なポート チャネル容量がある場合は、2 リンク EtherChannel として ICC を設定できます。

mLACP は半二重リンクをサポートしません。

mLACP は複数のネイバーをサポートしません。

ポート チャネルを mLACP に変換すると、サービスが中断する可能性があります。

DHD システム プライオリティは、PoA システム プライオリティよりも低く(数値的に高く)する必要があります。

サーバ アクセスの mLACP の設定

ここでは、サーバ アクセスの mLACP の設定方法について説明します。

「mLACP PoA の設定値の要約」

「mLACP のグローバル オプションの設定」

「シャーシ間通信チャネルの設定」

「シャーシ間冗長グループの設定」

「PoA フェールオーバーの強制」

「mLACP のトラブルシューティング」

「アクティブ PoA の確認」

「スタンバイ PoA の確認」

mLACP PoA の設定値の要約

表 20-2 に、PoA スイッチで調整する必要がある値のリストを示します。

 

表 20-2 調整された mLACP 設定値

アクティブ PoA(スイッチ A)
スタンバイ PoA(スイッチ B)
interface type slot / port
description connected to switch B
ip address 10.0.0. 1 255.255.255.255
interface type slot / port
description connected to switch A
ip address 10.0.0. 2 255.255.255.255
interface loopback 0
description Supports routing to switch B
interface loopback 0
description Supports routing to switch A
mpls ldp router-id loopback 0 force
mpls ldp router-id loopback 0 force
redundancy
interchassis group 10
member ip 10.0.0. 2
mlacp system-mac 0001.0001.0001
redundancy
interchassis group 10
member ip 10.0.0. 1
mlacp system-priority 2
mlacp system-mac 0002.0002.0002
mlacp node-id 2
interface port-channel 50
mlacp interchassis group 10
interface port-channel 50
mlacp interchassis group 10
mlacp lag-priority 2
interface type slot / port
description connected to DHD
channel-group 50 mode passive
interface type slot/port
description connected to DHD
channel-group 50 mode passive

) この要約の項では、サーバ アクセスの mLACP 機能に設定する必要があるコマンドをすべて示しているわけではありません。詳しい設定手順については、次の各項を参照してください。


mLACP のグローバル オプションの設定

mLACP のグローバル オプションを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# port-channel mode mlacp-extended

(任意)128 の追加 mLACP ポート チャネル インターフェイスの設定をサポートする mLACP 拡張モードをイネーブルにします。

コマンドの入力後に mLACP 拡張モードをイネーブルにするには、リロードする必要があります。

ステップ 4

Router(config)# errdisable recovery cause mlacp-minlink

ポート チャネルのフェールオーバー状態からの自動リカバリをイネーブルにします。

ステップ 5

Router(config)# end

特権 EXEC モードに戻ります。

シャーシ間通信チャネルの設定

ここでは、シャーシ間通信チャネル(ICC)を設定する方法について説明します。

「ICC ポートの設定」

「ICCP ルーティングの設定」

ICC ポートの設定

ICC ポートを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# interface type 1 slot/port

ICC ポートを選択します。

ステップ 4

Router(config-if)# description peer_description

他の PoA に接続する ICC ポートについて説明します。

ステップ 5

Router(config-if)# ip address ip_address mask

ICC ポートの IP アドレスを設定します。

として使用されます。

ステップ 6

Router(config-if)# mpls ip

インターフェイスで MPLS をイネーブルにします。

ステップ 7

Router(config-if)# bfd interval 600 min_rx 600 multiplier 6

シャーシ間冗長マネージャ(ICRM)トラフィックをサポートするように BFD を設定します。

ステップ 8

Router(config-if)# shutdown

インターフェイスをディセーブルにします。

ステップ 9

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 10

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 11

Router(config)# end

特権 EXEC モードに戻ります。

1.type = fastethernetgigabitethernet、または tengigabitethernet

次に、他の PoA のスイッチに接続されているポートを設定する例を示します。

Router> enable
Router# configure terminal
Router(config-if)# interface fastethernet 1/1
Router(config-if)# description Connected to switch B
Router(config-if)# ip address 10.0.0.1 255.255.255.255
Router(config-if)# bfd interval 600 min_rx 600 multiplier 6
Router(config-if)# shutdown
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# end

ICCP ルーティングの設定

ICCP ルーティングを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# ip route ip_address mask icc_port

ICC ポートを経由して他の PoA 上のループバック インターフェイスの IP アドレスをポイントするスタティック ルートを設定します。

ステップ 4

Router(config)# interface loopback_interface

ICCP ルーティングをサポートするようにループバック インターフェイスを設定します。(既存のループバック インターフェイスを使用できます)。

ステップ 5

Router(config-if)# description loopback_description

ループバック インターフェイスについて説明します。

ステップ 6

Router(config-if)# ip address ip_address mask

ICC ポートの IP アドレスを設定します。

ステップ 7

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 8

Router(config)# mpls ldp router-id loopback_interface force

ステップ 4 で作成したループバック インターフェイスを使用するように MPLS LDP を設定します。

ステップ 9

Router(config)# end

特権 EXEC モードに戻ります。

次に、他の PoA のスイッチに接続されているポートを設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# ip route 200.0.0.2 255.255.255.255 fastethernet 1/1
Router(config-if)# interface loopback 0
Router(config-if)# description Supports routing to switch B
Router(config-if)# ip address 100.0.0.1 255.255.255.255
Router(config-if)# exit
Router(config)# mpls ldp router-id 0 force
Router(config)# end

シャーシ間冗長グループの設定

ここでは、シャーシ間冗長グループを設定する方法について説明します。

「シャーシ間冗長グループの設定」

「mLACP ポート チャネル インターフェイスの設定」

「mLACP メンバ ポートの設定」

シャーシ間冗長グループの設定

シャーシ間冗長グループを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 4

Router(config-red)# interchassis group group_id

シャーシ間グループを作成し、シャーシ間冗長モードを開始します。

を使用します。

ステップ 5

Router(config-r-ic)# member ip ip_address

mLACP ピア メンバ グループの IP アドレスを設定します。他の PoA の ICC ポートで設定されている IP アドレスを使用します( シャーシ間通信チャネルの設定ステップ 5)。

ステップ 6

Router(config-r-ic)# mlacp system-mac { 0001.0001.0001 | 0002.0002.0002 }

アクティブ リンクを選択する PoA を選択する mLACP システム ID 値の一部である mLACP システム MAC アドレス 値を定義します。

0001.0001.0001 を使用してアクティブ PoA を設定します。

0002.0002.0002 を使用してスタンバイ PoA を設定します。

ステップ 7

Router(config-r-ic)# mlacp system-priority { 1 | 2 }

アクティブ リンクを選択する PoA を選択する mLACP システム ID 値の一部である mLACP システム プライオリティ 値を定義します。

プライオリティが 1 のアクティブ PoA を設定します。

プライオリティが 2 のスタンバイ PoA を設定します。

ステップ 8

Router(config-r-ic)# mlacp node-id { 1 | 2 }

アクティブ リンクの選択に使用する mLACP ポート ID 値の一部として使用される mLACP ポート番号 値を定義します。

アクティブ リンクを持つ PoA でノード ID 1 を設定します。

スタンバイ リンクを持つ PoA でノード ID 2 を設定します。

ステップ 9

Router(config-r-ic)# backbone interface type slot/port

ネットワークとの間でサーバ トラフィックを伝送する物理ポートで mLACP リンク ステータス モニタリングを設定します。

コマンドを入力します。

ステップ 10

Router(config-r-ic)# monitor peer bfd

ピアの状態をモニタするための BFD オプションを設定します。デフォルトのオプションは route-watch です。

次に、アクティブ PoA としてスイッチを設定するシャーシ間冗長グループを設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# redundancy
Router(config-red)# interchassis group 10
Router(config-r-ic)# member ip 10.0.0.2
Router(config-r-ic)# mlacp node-id 1
Router(config-r-ic)# mlacp system-mac 0001.0001.0001
Router(config-r-ic)# mlacp system-priority 1
Router(config-r-ic)# monitor peer bfd

mLACP ポート チャネル インターフェイスの設定

mLACP ポート チャネル インターフェイスを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface port-channel port_channel_id

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

port_channel_id 値の範囲は 1 ~ 256 です。

mLACP 拡張モードでは、この値は 1 ~ 512 の範囲で指定します。

1 ~ 256 の番号が付けられた 128 の PaGP、LACP、または mLACP ポート チャネル インターフェイスを設定できます。これらのポート チャネル インターフェイスは、QoS、および ACL をサポートします。

257 ~ 512 の番号が付けられた 128 の追加 mLACP ポート チャネル インターフェイスを設定できます。これらのポート チャネル インターフェイスは、QoS および ACL をサポートしません。

mLACP 冗長グループ内の他のリンクのポート チャネル インターフェイスの他の PoA で同じポート チャネル ID を設定する必要があります。

ステップ 4

Router(config-if)# switchport

ポート チャネル インターフェイスをレイヤ 2 スイッチング用に設定します。

ステップ 5

Router(config-if)# switchport access

ポート チャネル インターフェイスをアクセス ポートとして設定します。

ステップ 6

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 7

Router(config-if)# mlacp interchassis group group_id

ポート チャネル インターフェイスを mLACP 冗長グループに関連付けます。「シャーシ間冗長グループの設定」ステップ 4 で設定された group_id を使用します。

ステップ 8

Router(config-r-ic)# mlacp node-id { 1 | 2 }

アクティブ リンクの選択に使用する mLACP ポート ID 値の一部として使用される mLACP ポート番号 値を定義します。

プライオリティが 1 のアクティブ リンクを持つ PoA を設定します。

プライオリティが 2 のスタンバイ リンクを持つ PoA を設定します。

ステップ 9

Router(config-if)# lacp max-bundle 1

アクティブなメンバ ポートの最大数を設定します。

(注) CLI は唯一の値として 1 を適用しませんが、この値が唯一テストされ、サポートされる値です。

ステップ 10

Router(config-if)# port-channel min-links 1

メンバ ポートの最小数を設定します。

(注)

CLI は唯一の値として 1 を適用しませんが、この値が唯一テストされ、サポートされる値です。

EtherChannel の他のリンクが他の PoA にあります。

ステップ 11

Router(config-if)# lacp failover non-revertive

(任意)非リバーティブへの mLACP スイッチオーバーを設定します。リバーティブ モードがデフォルトであり、180 秒の遅延ありです。

コマンドは、CLI に存在しますがサポートされていません。

次に、mLACP ポート チャネル インターフェイスを設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# interface port-channel 50
Router(config-if)# switchport
Router(config-if)# switchport access
Router(config-if)# no shutdown
Router(config-if)# mlacp lag-priority 1
Router(config-if)# mlacp interchassis group 10
Router(config-if)# lacp max-bundle 1
Router(config-if)# port-channel min-links 1

mLACP メンバ ポートの設定

mLACP メンバ ポートを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# interface type 2 slot/port

設定する LAN ポートを選択します。

ステップ 4

Router(config-if)# no ip address

この LAN ポートに IP アドレスが割り当てられていないことを確認します。

ステップ 5

Router(config-if)# switchport

LAN ポートをレイヤ 2 スイッチング用に設定します。

ステップ 6

Router(config-if)# switchport mode access

LAN ポートをアクセス ポートとして設定します。

ステップ 7

Router(config-if)# switchport access vlan vlan_id

LAN ポートを VLAN のメンバとして設定します。

ステップ 8

Router(config-if)# channel-protocol lacp

LACP EtherChannel プロトコルをイネーブルにします。

ステップ 9

Router(config-if)# channel-group port_channel_id mode { active | passive }

LAN ポートを mLACP ポート チャネル インターフェイスのメンバとして設定し、モードを指定します。適切な mLACP ポート チャネル インターフェイス上に設定された port_channel_id 値を使用します。

ステップ 10

Router(config-if)# mlacp lag-priority { 1 | 2 }

アクティブ リンクの選択に使用する mLACP ポート ID 値の一部として使用される mLACP ポート プライオリティ 値を定義します。

プライオリティが 1 のアクティブ リンクを設定します。

プライオリティが 2 のスタンバイ リンクを設定します。

ステップ 11

Router(config-if)# shutdown

インターフェイスをディセーブルにします。

ステップ 12

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

2.type = fastethernetgigabitethernet、または tengigabitethernet

次に、mLACP メンバ ポートをアクティブ リンクとして設定する例を示します。

Router> enable
Router# configure terminal
Router(config-if)# interface gigabitethernet 1/1
Router(config-if)# no ip address
Router(config-if)# switchport
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 10
Router(config-if)# channel-protocol lacp
Router(config-if)# channel-group 10 mode passive
Router(config-if)# mlacp lag-priority 1
Router(config-if)# no shutdown

PoA フェールオーバーの強制

mlacp lag-priority コマンドは、次の 2 通りの方法で PoA フェールオーバーを強制実行するために使用することもできます。

アクティブ PoA の LAG プライオリティを、スタンバイ PoA での LAG プライオリティよりも大きい値に設定します。この設定では、PoA がアクティブになる前にスタンバイ リンクでの LACP リンク状態遷移が最小数しか必要でないため、最速のフェールオーバーが発生します。

スタンバイ PoA の LAG プライオリティを、アクティブ PoA での LAG プライオリティよりも小さい値に設定します。この設定では、スタンバイ リンクが発生してアクティブになる前に、リンクが OUT_OF_SYNC を DHD に通知する必要があるため、フェールオーバーにかかる時間が若干長くなります。

ダイナミック ポート プライオリティ管理を使用してフェールオーバーを強制実行すると、場合によっては、運用上のプライオリティと設定済みのプライオリティが異なる可能性があります。この場合、設定済みのバージョンは、ポート チャネルが非リバーティブ モードで動作している場合を除き、変更されません。現在の運用上のプライオリティを表示するには、 show lacp multichassis port-channel コマンドを入力します。設定済みのプライオリティ値を表示するには、 show running-config コマンドを使用します。

mLACP のトラブルシューティング

次の debug コマンドを使用して、mLACP をトラブルシューティングします。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# debug redundancy interchassis { all | application | error | event | monitor }

シャーシ間冗長マネージャのデバッグをイネーブルにします。

ステップ 3

Router# debug mpls ldp iccp

InterChassis Control Protocol(ICCP)のデバッグをイネーブルにします。

ステップ 4

Router# debug lacp [ all | event | fsm | misc | multi-chassis [ all | database | lacp-mgr | redundancy-group | user-interface ] | packet ]

LACP アクティビティのデバッグをイネーブルにします。

アクティブ PoA の確認

次の show コマンドを使用すると、アクティブ PoA での mLACP の動作を確認する統計情報および設定パラメータを表示できます。

「show lacp multi-chassis group」

「show lacp multi-chassis port-channel」

「show etherchannel summary」

「show etherchannel channel_id port-channel」

「show lacp internal」

「show lacp neighbor」

show lacp multi-chassis group

show lacp multi-chassis group コマンドを使用すると、LACP パラメータ、ローカル設定、バックボーン アップリンクのステータス、ピア情報、ノード ID、チャネル、状態、プライオリティ、アクティブおよび非アクティブ リンクが表示されます。

DC35-5# show lacp multi-chassis group 100
Interchassis Redundancy Group 10
 
Operational LACP Parameters:
RG State: Synchronized
System-Id: 1.0001.0001.0001
ICCP Version: 0
Backbone Uplink Status: Connected
Local Configuration:
Node-id: 1
System-Id: 1.0001.0001.0001
 
Peer Information:
State: Up
Node-id: 2
System-Id: 2.0002.0002.0002
ICCP Version: 0
 
State Flags: Active - A
Standby - S
Down - D
AdminDown - AD
Standby Reverting - SR
Unknown - U
mLACP Channel-groups
Channel State Priority Active Links Inactive Links
Group Local/Peer Local/Peer Local/Peer Local/Peer
50 A/S 1/2 1/1 0/0

show lacp multi-chassis port-channel

show lacp multi-chassis port-channel コマンドを使用すると、インターフェイス ポート チャネルの値、チャネル グループ、LAG の状態、プライオリティ、非アクティブ リンク ピア設定、およびスタンバイ リンクが表示されます。

DC35-5# show lacp multi-chassis port-channel1
Interface Port-channel50
Local Configuration:
Address: 00d0.d32e.d23f
Channel Group: 50
State: Active
LAG State: Up
Priority: 1
Inactive Links: 0
Total Active Links: 1
Bundled: 1
Selected: 1
Standby: 0
Unselected: 0
 
Peer Configuration:
Interface: Port-channel50
Address: 0002.fcbd.cee5
Channel Group: 50
State: Standby
LAG State: Up
Priority: 2
Inactive Links: 0
Total Active Links: 1
Bundled: 0
Selected: 0
Standby: 1
Unselected: 0

show etherchannel summary

show etherchannel summary コマンドを使用すると、mLACP メンバ リンクのステータスとアイデンティティが表示されます。

DC35-5# show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator
 
M - not in use, no aggregation due to minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
d - default port
 
w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators: 1
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
50 Po50(SU) LACP Fa1/44(P)

show etherchannel channel_id port-channel

show etherchannel channel_id port-channel コマンドを使用すると、EtherChannel およびポート チャネルのステータスとアイデンティティが表示されます。

DC35-5# show etherchannel 50 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po50 (Primary Aggregator)
 
------------
 
Age of the Port-channel = 0d:01h:15m:10s
Logical slot/port = 14/5 Number of ports = 1
HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = LACP
Fast-switchover = disabled
 
 
Load share deferral = disabled
 
Ports in the Port-channel:
 
Index Load Port EC state No of bits
------+------+------------+------------------+-----------
0 FF Fa1/44 mLACP-active 8
 
Time since last port bundled: 0d:00h:14m:18s Fa1/44
Time since last port Un-bundled: 0d:00h:14m:20s Fa1/44
 
Last applied Hash Distribution Algorithm: Adaptive

show lacp internal

show lacp internal コマンドを使用すると、デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

DC35-5# show lacp internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 50
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa1/44 SA bndl-act 1 0x32 0x32 0x912D 0x3D
 
Peer (DC35-6) mLACP member links

show lacp neighbor

show lacp neighbor コマンドを使用すると、ネイバー デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

DC35-5# show lacp neighbor
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 50 neighbors
 
Partner's information:
 
Partner Partner LACP Partner Partner Partner Partner Partner
Port Flags State Port Priority Admin Key Oper Key Port Number Port State
Fa1/44 SA bndl-act 32768 0x0 0xAC 0x62D 0x3D

スタンバイ PoA の確認

次の show コマンドを使用すると、スタンバイ PoA での mLACP 機能の動作を確認するための統計情報および設定パラメータを表示できます。

「show lacp multi-chassis group」

「show lacp multi-chassis portchannel」

「show etherchannel summary」

「show lacp internal」

show lacp multi-chassis group

show lacp multi-chassis group コマンドを使用すると、LACP パラメータ、ローカル設定、バックボーン アップリンクのステータス、ピア情報、ノード ID、チャネル、状態、プライオリティ、アクティブおよび非アクティブ リンクが表示されます。

DC35-6# show lacp multi-chassis group
Interchassis Redundancy Group 10
 
Operational LACP Parameters:
RG State: Synchronized
System-Id: 1.0001.0001.0001
ICCP Version: 0
Backbone Uplink Status: Connected
Local Configuration:
Node-id: 2
System-Id: 2.0002.0002.0002
 
Peer Information:
State: Up
Node-id: 1
System-Id: 1.0001.0001.0001
ICCP Version: 0
 
State Flags: Active - A
Standby - S
Down - D
AdminDown - AD
Standby Reverting - SR
Unknown - U
mLACP Channel-groups
Channel State Priority Active Links Inactive Links
Group Local/Peer Local/Peer Local/Peer Local/Peer
50 S/A 2/1 1/1 0/0

show lacp multi-chassis portchannel

show lacp multi-chassis portchannel コマンドを使用すると、インターフェイス ポート チャネルの値、チャネル グループ、LAG の状態、プライオリティ、非アクティブ リンク ピア設定、およびスタンバイ リンクが表示されます。

DC35-6# show lacp multi-chassis port-channel
Interface Port-channel50
Local Configuration:
Address: 0002.fcbd.cee5
Channel Group: 50
State: Standby
LAG State: Up
Priority: 2
Inactive Links: 0
Total Active Links: 1
Bundled: 0
Selected: 0
Standby: 1
Unselected: 0
 
Peer Configuration:
Interface: Port-channel50
Address: 00d0.d32e.d23f
Channel Group: 50
State: Active
LAG State: Up
Priority: 1
Inactive Links: 0
Total Active Links: 1
Bundled: 1
Selected: 1
Standby: 0
Unselected: 0

show etherchannel summary

show etherchannel summary コマンドを使用すると、mLACP メンバ リンクのステータスとアイデンティティが表示されます。

DC35-6# show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator
 
M - not in use, no aggregation due to minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
d - default port
 
w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators: 1
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
50 Po50(SU) LACP Fa3/44(P)

show etherchannel channel_id port-channel

show etherchannel channel_id port-channel コマンドを使用すると、EtherChannel およびポート チャネルのステータスとアイデンティティが表示されます。

DC35-6# show etherchannel 50 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po50 (Primary Aggregator)
 
------------
 
Age of the Port-channel = 0d:01h:17m:40s
Logical slot/port = 14/5 Number of ports = 1
HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = LACP
Fast-switchover = disabled
 
 
Load share deferral = disabled
 
Ports in the Port-channel:
 
Index Load Port EC state No of bits
------+------+------------+------------------+-----------
0 FF Fa3/44 mLACP-stdby 8
 
Time since last port bundled: 0d:00h:16m:59s Fa3/44
Time since last port Un-bundled: 0d:00h:17m:00s Fa3/44
 
Last applied Hash Distribution Algorithm: Adaptive

show lacp internal

show lacp internal コマンドを使用すると、デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

DC35-6# show lacp internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 50
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa3/44 SA bndl-sby 2 0x32 0x32 0xA32D 0x5
 
Peer (DC35-5^C^C) mLACP member links

show lacp neighbor

show lacp neighbor コマンドを使用すると、ネイバー デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

DC35-6# show lacp neighbor
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 50 neighbors
 
Partner's information:
 
Partner Partner LACP Partner Partner Partner Partner Partner
Port Flags State Port Priority Admin Key Oper Key Port Number Port State
Fa3/44 FA bndl-sby 32768 0x0 0xAC 0x32D 0xF