Catalyst 6500 Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース12.2(33)SXH 以降のリリース
A-VPLS の設定
A-VPLS の設定
発行日;2012/08/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

A-VPLS の設定

について

に関する制約事項

の設定

ECMP および FAT 疑似配線によるロード バランシングのイネーブル化

ポートチャネル ロードバランシングのイネーブル化

仮想イーサネット インターフェイス設定の一部としての明示的な PE ルータ指定

MPLS トラフィック エンジニアリング トンネルの設定

GRE トンネルの設定

ルーテッド Pseudo-Wire(RPW)およびルーテッド VPLS

A-VPLS の設定

この章では、レイヤ 2 バーチャル プライベート ネットワーク(L2VPN)Advanced Virtual Private LAN Service(A-VPLS)の設定方法について説明します。A-VPLS は Release 12.2(33)SXI4 以降のリリースでサポートされます。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Master Command List, Release 12.2SX』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html


 

この章で説明する内容は、次のとおりです。

「A-VPLS について」

「A-VPLSに関する制約事項」

「A-VPLS の設定」

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html


 

A-VPLS について

A-VPLS では、VPLS に次の機能拡張を追加しています。

複数の等価コスト コア方向パス間のプロバイダー エッジ(PE)とコア インターフェイスでフロー ラベルを使用してトラフィックをロード バランシングする機能。

冗長 PE ルータのサポート。

A-VPLS では、Flow Aware Transport(FAT)疑似配線機能を使用して PE およびコア ルータ両方の PE 冗長性とロード バランシングを実現します。等価コスト マルチ パスが使用されている場合 FAT の疑似配線がコア トラフィックをロード バランシングするために使用されます。PE ルータは、各パケット(フロー ラベル)に追加の MPLS ラベルを追加します。各フローに一意のフロー ラベルがあります。FAT 疑似配線の詳細については、PWE3 インターネットドラフト『 Flow Aware Transport of MPLS Pseudowires 』(draft-bryant-filsfils-fat-pw)を参照してください。

A-VPLSに関する制約事項

Release 12.2(33) SXJ1 以降のリリースでは、A-VPLS トラフィックを伝送する MPLS PE コア方向のポートとして ES+ モジュール ポートの設定をサポートしています。

7600-SIP-400 における次のコア方向のポート タイプでは、Release 12.2(33)SXI4a 以降のリリースで A-VPLS がサポートされます。

ギガ ビットおよび 10 ギガビット イーサネット SPA(2X1GE-V1、2X1GE-V2、および 1X10GE-V2 SPA)

Packet over Sonet(POS)SPA(2XOC3、4XOC3、1XOC12、および 1XOC48)

Release 12.2(33) SXI4a 以降のリリースでは、次のタイプの設定がサポートされます。

転送 vpls モードでの neighbor コマンドによる PE ルータの設定の MPLS コア。

明示パスを使用した MPLS トラフィック エンジニアリング トンネリングによる PE ルータの設定の MPLS コア。

MPLS over GRE トンネルを介した PE ルータの設定の IP コア。

route-via コマンド、BGP オートディスカバリ、PE 出力ポートへの明示的な VLAN 割り当てなどの他の設定方法はサポートされません。

A-VPLS のサポート対象は次のとおりです。

ES+ ラインカードがないスイッチ:

- 最大 32 の EtherChannel ポートチャネル インターフェイス。 (ES+ ライン カードでは、ポートチャネル インターフェイスがサポートされていません)

- load-balance flow コマンドで設定されているネイバーの数を引いた最大 60 の VPLS ネイバー。

ES+ ラインカードを備えたスイッチ(7600-SIP-400 の有無は関係ない):

- 最大 30 の EtherChannel ポートチャネル インターフェイス。 (ES+ ライン カードでは、ポートチャネル インターフェイスがサポートされていません)

- load-balance flow コマンドで設定されているネイバーの数を引いた最大 30 の VPLS ネイバー。

A-VPLS には、ノンストップ フォワーディングとステートフル スイッチオーバーが必要です。

A-VPLS は次の機能と連動します。

明示パスが設定されている MPLS トラフィック エンジニアリング トンネル。

トンネル宛先へのスタティック ルートが設定された総称ルーティング カプセル化(GRE トンネル)。

MPLS トラフィック エンジニアリングおよび GRE トンネルの詳細については、次のマニュアルを参照してください。

『MPLS Traffic Engineering and Enhancements』

『Implementing Tunnels』

Any Transport over MPLS Virtual Circuit Connection Verification(VCCV)機能をサポートする ping コマンドや traceroute コマンドは、FAT 疑似配線上ではサポートされません。

VPLS オートディスカバリ機能は、A-VPLS でサポートされません。

コア ルータでは、パケット転送にコアが IP を使用する場合、ロード バランシングはサポートされません。

A-VPLS の設定

ここでは、A-VPLS を設定する方法について説明します。

「ECMP および FAT 疑似配線によるロード バランシングのイネーブル化」(必須)

「ポートチャネル ロードバランシングのイネーブル化」(必須)

「仮想イーサネット インターフェイス設定の一部としての明示的な PE ルータ指定」(任意)

「MPLS トラフィック エンジニアリング トンネルの設定」(任意)

「GRE トンネルの設定」(任意)

ECMP および FAT 疑似配線によるロード バランシングのイネーブル化

次の手順は、プロバイダー エッジ(PE)ルータでロード バランシングを設定してコアの P ルータでイネーブルにする方法について説明します。コア P ルータで設定は不要です。

エッジ ルータでロード バランシングをイネーブルにするには、 load-balance flow コマンドを発行します。ロード バランシング規則は port-channel load-balance コマンドのパラメータで設定されます(「ポートチャネル ロードバランシングのイネーブル化」を参照)。

コアのロード バランシングをイネーブルにするには、両方の PE ルータで flow-label enable コマンドを発行します。 load-balance flow コマンドと flow-label enable コマンドを組み合わせて発行する必要があります。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# pseudowire-class name

指定した名前の疑似配線クラスを確立して、疑似配線クラス コンフィギュレーション モードに入ります。

ステップ 4

Router(config-pw)# encapsulation mpls

MPLS トンネリングのカプセル化タイプを指定します。

ステップ 5

Router(config-pw)# load-balance flow

ECMP のロード バランシングをイネーブルにします。

ステップ 6

Router(config-pw)# flow-label enable

疑似配線のフロー ラベルのインポジションおよびディスポジションをイネーブルにします。

ステップ 7

Router(config-pw)# end

疑似配線クラス コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ポートチャネル ロードバランシングのイネーブル化

次の作業では、バンドル内のポート間の負荷分散方式を設定するポート チャネル ロード バランシングをイネーブルにする方法を説明します。 port-channel load-balance コマンドが設定されていない場合、ロード バランシングはデフォルト パラメータで実行されます。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# port-channel load-balance method

バンドル ポート間での負荷分散方式を指定します。

ステップ 4

Router(config)# exit

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

仮想イーサネット インターフェイス設定の一部としての明示的な PE ルータ指定

トラフィックが通過する必要があるルートを指定するには、いくつかの方法があります。

PE ルータの仮想イーサネット インターフェイスの設定の一部としての明示的な指定

MPLS トラフィック エンジニアリング トンネルの設定

GRE トンネルの設定

次の作業では、仮想イーサネット インターフェイス設定の一部として、明示的に PE ルータを指定する方法について説明します。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface virtual-ethernet num

仮想イーサネット インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

Router(config-if)# transport vpls mesh

疑似配線のフル メッシュを作成して、VPLS 転送モードを開始します。

ステップ 5

Router(config-if-transport)# neighbor remote-router-id [ pw-class pw-class-name]

疑似配線で使用される PE ルータを指定します。

ステップ 6

Router(config-if-transport)# exit

VPLS 転送コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

Router(config-if)# switchport

ポートをレイヤ 2 スイッチング用に設定します。

ステップ 8

Router(config-if)# switchport mode trunk

永続的なトランキング モードをイネーブルにし、リンクをトランク リンクに変換するようにネゴシエーションを行います。

ステップ 9

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

トランク上で許可される VLAN のリストを設定します。

ステップ 10

Router(config)# exit

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

MPLS トラフィック エンジニアリング トンネルの設定

トラフィックが通過する必要があるルートを指定するには、いくつかの方法があります。

PE ルータの仮想イーサネット インターフェイスの設定の一部としての明示的な指定

MPLS トラフィック エンジニアリング トンネルの設定

GRE トンネルの設定

次の作業では、MPLS トラフィック エンジニアリング トンネルを設定する方法について説明します。MPLS トラフィック エンジニアリング トンネルの詳細については、『 MPLS Traffic Engineering and Enhancements 』を参照してください。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface tunnel number

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

Router(config-if)# ip unnumbered type number

トンネル インターフェイスに IP アドレスを割り当てます。MPLS トラフィック エンジニアリング トンネル インターフェイスは単一方向リンクを表すため、番号なしにする必要があります。

ステップ 5

Router(config-if)# tunnel destination ip-address

トンネルの宛先を指定します。 ip-address キーワードは、ホスト宛先の IP アドレス(ドット付き 10 進表記)です。

ステップ 6

Router(config-if)# tunnel mode mpls traffic-eng

トンネル カプセル化モードを MPLS トラフィック エンジニアリングに設定します。

ステップ 7

Router(config-if)# tunnel mpls traffic-eng autoroute announce

拡張 SPF 計算でトンネルを使用するように IGP を設定します。

ステップ 8

Router(config-if)# tunnel mpls traffic-eng path-option number { dynamic | explicit { name path-name } | identifier path-number } [ lockdown ]

指定した IP 明示パス、またはトラフィック エンジニアリング トポロジ データベースからダイナミックに計算されたパスを使用するように、トンネルを設定します。明示パスが現在使用可能でない場合は、ダイナミック パスが使用されます。

ステップ 9

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

GRE トンネルの設定

トラフィックが通過する必要があるルートを指定するには、いくつかの方法があります。

PE ルータの仮想イーサネット インターフェイスの設定の一部としての明示的な指定

MPLS トラフィック エンジニアリング トンネルの設定

GRE トンネルの設定

次の作業では、GRE トンネルの設定方法について説明します。GRE トンネルの詳細については、『Implementing Tunnels』を参照してください。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface type number

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。トンネルを設定するには、type 引数に tunnel を使用します。

ステップ 4

Router(config-if)# tunnel mode { gre ip | gre multipoint }

トンネルで使用されるカプセル化プロトコルを指定します。

ステップ 5

Router(config-if)# mpls ip

トンネルで MPLS をイネーブルにします。

ステップ 6

outer(config-if)# tunnel source { ip-address | interface-type interface-number }

トンネル送信元を設定します。

送信元 IP アドレスを指定するには、 ip-address 引数を使用します。

使用するインターフェイスを指定する場合は、 interface-type 引数および interface-number 引数を使用します。

(注) トンネルの送信元および宛先 IP アドレスの両方の PE ルータで定義する必要があります。

ステップ 7

Router(config-if)# tunnel destination { hostname | ip-address }

トンネル宛先を設定します。

ホストの宛先の名前を指定するには、hostname 引数を使用します。

ホストの宛先の IP アドレスを指定する場合は、ip-address 引数を使用します。

(注) トンネルの送信元および宛先 IP アドレスの両方の PE ルータで定義する必要があります。

ステップ 8

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 9

Router(config)# ip route ip-address tunnel num

スタティック ルートを作成します。

次の例は、3 つのサポートされる A-VPLS 設定方法を示します。

明示的なピア PE ルータの指定

次に、VLAN 10 および 20 で 2 つの VPLS ドメインを作成する例を示します。各 VPLS ドメインには、ピア PE ルータ 10.2.2.2 および 10.3.3.3 への 2 つの疑似配線が含まれます。ロード バランシングは、 load-balance flow コマンドと flow-label enable コマンドでイネーブルにします。

pseudowire-class cl1
encap mpls
load-balance flow
flow-label enable
!
port-channel load-balance src-mac
!
interface virtual-ethernet 1
transport vpls mesh
neighbor 10.2.2.2 pw-class cl1
neighbor 10.3.3.3 pw-class cl1
switchport
switchport mode trunk
switchport trunk allowed vlan 10, 20

MPLS トラフィック エンジニアリング トンネルの使用方法

次の例では、2 つの VPLS ドメインの作成を示し、MPLS トラフィック エンジニアリング トンネルを使用して明示パスを指定します。

pseudowire-class cl1
encap mpls
load-balance flow
flow-label enable
!
port-channel load-balance src-mac
!
interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.1.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name LSP1
!
ip explicit-path name LSP1 enable
next-address 192.168.2.2
next-address loose 192.168.1.1
!
interface Tunnel2
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 172.16.1.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit name LSP2
!
ip explicit-path name LSP2 enable
next-address 172.16.2.2
next-address loose 172.16.1.1
!
interface virtual-ethernet 1
transport vpls mesh
neighbor 10.2.2.2 pw-class cl1
neighbor 10.3.3.3 pw-class cl1
switchport
switchport mode trunk
switchport trunk allowed vlan 10,20

MPLS over GRE トンネルの使用方法

次に、VLAN 10 および 20 で 2 つの VPLS ドメインを作成する例を示します。各 VPLS ドメインには、ピア PE 10.2.2.2 および 10.3.3.3 への 2 つの疑似配線が含まれます。疑似配線はコアが IP であるため MPLS over GRE トンネルです。

pseudowire-class cl1
encap mpls
load-balance flow
!
port-channel load-balance src-mac
!
interface tunnel 1
tunnel mode gre ip
mpls ip
tunnel source 10.1.1.1
tunnel destination 10.2.2.2
!
interface tunnel 2
tunnel mode gre ip
mpls ip
tunnel source 10.1.1.1
tunnel destination 10.3.3.3
!
interface virtual-ethernet 1
transport vpls mesh
neighbor 10.2.2.2 pw-class cl1
neighbor 10.3.3.3 pw-class cl1
switchport
switchport mode trunk
switchport trunk allowed vlan 10, 20
 
ip route 10.2.2.2 255.255.255.255 Tunnel1
ip route 10.3.3.3 255.255.255.255 Tunnel2

ルーテッド Pseudo-Wire(RPW)およびルーテッド VPLS

RPW およびルーテッド VPLS はレイヤ 3 トラフィックをルーティングし、プロバイダー エッジ(PE)デバイス間の疑似配線接続でレイヤ 2 フレームを切り替えることができます。Ethernet over MPLS(EoMPLS)の形式のポイントツーポイント PE 接続、および Virtual Private LAN Service(VPLS)マルチポイント PE 接続の両方がサポートされます。フレームをこれらのインターフェイスとの間でルーティングできる機能は、同じスイッチ上のレイヤ 3 ネットワーク(VPN またはグローバル)への疑似配線の終了、またはレイヤ 2 トンネルを介したレイヤ 3 フレームのトンネリング(EoMPLS または VPLS)をサポートします。この機能は、MPLS トラフィック エンジニアリング(MPLS-TE)および高速再ルーティング(FRR)機能を介して物理インターフェイスまたはデバイスの障害時のネットワーク収束をサポートします。特に、機能は、VPLS ドメイン上のレイヤ 3 マルチキャストの MPLS TE-FRR 保護をイネーブルにします。


) RPW が A-VPLS モードで設定されている場合、TE/FRR は A-VPLS が ECMP 上で実行され、ECMP 収束が TE/FRR と同等であるため、サポートされません。


疑似配線のルーティング サポートを設定するには、仮想 LAN(VLAN)インターフェイス設定のレイヤ 3 ドメイン(VPN またはグローバル)の IP アドレスおよびその他のレイヤ 3 機能を設定します。次の例では、VLAN 100 インターフェイスに IP アドレス 10.10.10.1 を割り当て、マルチキャスト PIM をイネーブルにします。(レイヤ 2 フォワーディングは VFI VFI100 によって定義されます)。

interface vlan 100
xconnect vfi VFI100
ip address 10.10.10.1 255.255.255.0
ip pim sparse-mode
 

次の例では、VPN ドメイン VFI200 の IP アドレス 20.20.20.1 を割り当てます。(レイヤ 2 フォワーディングは VFI VFI200 によって定義されます)。

interface vlan 200
xconnect vfi VFI200
ip vrf forwarding VFI200
ip address 20.20.20.1 255.255.255.0