Catalyst 6500 Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース12.2(33)SXH 以降のリリース
イーサネット サービス プラス ラインカードの設定
イーサネット サービス プラス ラインカードの設定
発行日;2012/08/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

イーサネット サービス プラス ラインカードの設定

Release 12.2SX ES+ラインカードのサポートおよび制約事項

ラインカードの設定

ES+ラインカード タイプの表示

ES+ラインカードのリセット

QoS の設定

サポートするインターフェイス

QoS 機能

入力 QoS 機能

出力 QoS 機能

分類の設定

分類の概要

分類の制約事項および使用上のガイドライン

ポリシングの設定

ポリシングの概要

ポリシングの制約事項および使用上のガイドライン

ポリシー マップ、クラス マップ、およびポリシングの設定

インターフェイスへの QoS トラフィック ポリシーの結合

マーキングの設定

マーキングの概要

マーキングの制約事項および使用上のガイドライン

ポリシー マップ、クラス マップ、およびマーキングの設定

シェーピングの設定

シェーピングの制約事項および使用上のガイドライン

クラス マップ、ポリシー マップ、およびシェーピングの設定

QoS キュー スケジューリングの設定

QoS キュー スケジューリングの制約事項および使用上のガイドライン

WRED の設定

帯域幅と CBWFQ の設定

LLQ の設定

階層型 QoS の設定

階層型 QoS の概要

階層型 QoS の例

MPLS トラフィック エンジニアリング Class-Based Tunnel Selection の設定

MPLS トラフィック エンジニアリングの概要

MPLS トラフィック エンジニアリング Class-Based Tunnel Selection の制約事項および使用上のガイドライン

同じヘッドエンドおよび同じテールエンドでの複数の MPLS メンバー TE または DS-TE トンネルの作成

マスター トンネルの作成、メンバー トンネルの結合、およびマスター トンネルの認識

MPLS の設定の確認

IPoDWDM の設定

IPoDWDM-Capable ES+ラインカード

ES+ラインカードの WAN PHY および OTN サポート

WAN、PHY、および OTN の概要

制約事項および使用上の注意事項

ITU-T G.709 転送モードの設定

DWDM プロビジョニング

OTN モードのアラーム アサーションの有効化

Field-Programmable Device のアップグレード

FPD イメージおよびパッケージの概要

FPD クイック アップグレード

Cisco IOS Release をアップグレードする前の FPD の迅速なアップグレード(推奨)

Cisco IOS Release をアップグレードしたあとの FPD の迅速なアップグレード

FPD イメージのアップグレード

新しい Cisco IOS Release への移行

運用中でないシステムでの FPD イメージのアップグレード

FPD 関連の省略可能な手順

FPD イメージ アップグレードの例

トラブルシューティング

Cisco IOS Event Tracer を使用した問題のトラブルシューティング

XFP の問題のトラブルシューティング

ES+ラインカードの活性挿抜の準備

ES+ラインカードの活性取り外しの準備

ES+ラインカードの非アクティブ化およびアクティブ化の確認

非アクティブ化およびアクティブ化の設定例

イーサネット サービス プラス ラインカードの設定

この章では、イーサネット サービス プラス(ES+)ラインカードでサポートされる機能を設定する方法について説明します。Release 12.2(33)SXJ1 以降のリリースでは、ES+ ラインカードをサポートしています。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Master Command List, Release 12.2SX』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html

L2VPN Advanced VPLS(A-VPLS)機能のトラフィックを伝送する MPLS コア P ルータ ポートとして ES+ ラインカード ポートを設定できます。「A-VPLS の設定」 を参照してください。


 

この章で説明する内容は、次のとおりです。

「Release 12.2SX ES+ ラインカードのサポートおよび制約事項」

「ラインカードの設定」

「QoS の設定」

「MPLS トラフィック エンジニアリング Class-Based Tunnel Selection の設定」

「IPoDWDM の設定」

「Field-Programmable Device のアップグレード」

「トラブルシューティング」

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html


 

Release 12.2SX ES+ ラインカードのサポートおよび制約事項

イーサネット サービス プラス Extended Transport(ES+XT)ラインカード:

 

トランシーバ:

LAN/WAN PHY、OTN/G.709

ポート
製品 ID
DFC
ネットワーク プロセッサ(NP)

4 台の 10GE ポート:
(デュアル ファブリック接続)

76-ES+XT-4TG3CXL

DFC3CXL

ポート 1:NP0
ポート 2:NP1
ポート 3:NP2
ポート 4:NP3

76-ES+XT-4TG3C

DFC3C

2 台の 10GE ポート:
(1 つのファブリック接続)

76-ES+XT-2TG3CXL

DFC3CXL

ポート 1:NP0
ポート 2:NP1

76-ES+XT-2TG3C

DFC3C

イーサネット サービス プラス(ES+)ラインカード:

 

トランシーバ:

XFP

ポート
製品 ID
DFC
ネットワーク プロセッサ(NP)

4 台の 10GE ポート:
(デュアル ファブリック接続)

7600-ES+4TG3CXL

DFC3CXL

ポート 1:NP0
ポート 2:NP1
ポート 3:NP2
ポート 4:NP3

7600-ES+4TG3C

DFC3C

2 台の 10GE ポート:
(1 つのファブリック接続)

7600-ES+2TG3CXL

DFC3CXL

ポート 1:NP0
ポート 2:NP1

7600-ES+2TG3C

DFC3C

ES+ ラインカードは、Supervisor Engine 720-10GE および Supervisor Engine 720 でサポートされています。

ES+ ラインカードは、Supervisor Engine 32 ではサポートされません。

ES+ ラインカードは、PFC3A モードではサポートされません。

ES+ ラインカードでは、次のインターフェイス タイプをサポートしません。

レイヤ 2 アクセス ポートまたはトランク ポート( switchport コマンドで設定されているポート)。

ポート チャネル インターフェイス(ES+ ラインカードのポートを EtherChannel のメンバにすることはできません)。

サービス インスタンス

CDP は、ES+ ラインカードのポート( CSCtk12860 )上でデフォルトでディセーブルです。

ラインカードの設定

ここでは、ES+ ラインカードの設定について説明します。

「ES+ ラインカード タイプの表示」

「ES+ ラインカードのリセット」

ES+ ラインカード タイプの表示

ES+ ラインカード タイプを確認するには、 show module コマンドを使用します。他に、ES+ ラインカードのハードウェア情報を表示する、 show idprom コマンド、 show running-config interface コマンドなどのコマンドもあります。

次に、スロット 8 に装着された ES+ ラインカードに対する show module コマンドの出力の例を示します。

Router# show module es_plus_slot
 
 

次に、スロット 8 に装着された ES+ ラインカードに対する show idprom コマンドの出力の例を示します。

Router# show idprom module es_plus_slot
 
 

次に、新しく作成したインターフェイスが実行コンフィギュレーションに表示されていることを確認するための show running-config interface コマンドの出力例を示します。

Router# show running-config interface es_plus_slot
 

ES+ ラインカードのリセット

ES+ ラインカードをリセットするには、特権 EXEC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router# hw-module module slot reset

指定スロットの ES+ ラインカードの電源をオフにしてからオンに切り替えます。

QoS の設定

ここでは、ES+ ラインカードでの Quality of Service(QoS)の設定について説明します。


) ES+ ラインカード上の QoS は、レイヤ 2 のフレーム サイズを使用します。


この章は、次の内容で構成されています。

「サポートするインターフェイス」

「QoS 機能」

「分類の設定」

「ポリシングの設定」

「マーキングの設定」

「シェーピングの設定」

「QoS キュー スケジューリングの設定」

「階層型 QoS の設定」

サポートするインターフェイス

ES+ ラインカードでは、次のインターフェイス タイプの QoS をサポートします。

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

SVI インターフェイス

入力トラスト

トラストとは、着信フレームに記載されているとおりに既存プライオリティを信頼する(残す)か、またはプライオリティをゼロに書き換えるようにポートに指示するポート割り当てのことです。

パケットは、プライオリティ値がパケット ヘッダーにすでに書き込まれている状態でインターフェイスに到着します。ルータは、定義済みルールに従って有効なアプリケーションまたはネットワーク デバイスがプライオリティ設定を設定しているかどうか、ユーザがより良いサービスを期待してプライオリティ設定を設定しているかどうかを判断する必要があります。

ルータは、プライオリティ値を受け入れるか別の値に変更するかを決める必要があります。ルータは、ポートの「トラスト」設定を使用してこの決断を行います。

レイヤ 3 インターフェイス(ルーテッド ポート)およびレイヤ 3 サブ インターフェイスは、DiffServ コード ポイント(DSCP)をデフォルトで常に信頼します。

入力タイプ オブ サービス(ToS)を変更するには、マーキングを使用します。マーキングの詳細については、「マーキングの設定」を参照してください。


) ES+ ラインカードは、CoS の入力マーキングが、ルーティングされたインターフェイスに設定されると、パケットを trust cos とマーキングします。そのため、set cos value コマンドを使用して設定された CoS 値は発信パケットに保持されます。この CoS 値は EARL によって上書きされたり、DSCP から抽出されたりしません。


入力分類

分類ではトラフィック記述子が使用されて特定グループにパケットが分類され、そのパケットが定義されてネットワークで QoS 処理用にアクセスできるようになります。パケット分類を使用すると、複数のプライオリティ レベルまたはサービス クラスにネットワーク トラフィックを区分できます。

トラフィックは、次の判断のために分類されます。

さらに処理を進めるようにマーク付けするかどうか

レート制限固有のトラフィック タイプにポリシングを行うかどうか

分類の設定の詳細については、「分類の設定」を参照してください。

入力ポリシング

ポリシングでは、特定ポートまたは VLAN ポートの一群を通過するトラフィックで使用できる帯域幅を制限できます。ポリシングは、ルータが送受信するデータ量をキロバイト/秒単位で定義することで動作します。

ポリシングを設定すると、QoS 値がドロップされるかマーキングされて、ルータのデータ フローが制限されます。ルータでは、ポリシングにより、インターフェイスの帯域幅だけに基づく場合よりも低いレベルに、特定タイプのレートを制限できます。

ポリシングの設定の詳細については、「ポリシングの設定」を参照してください。

入力マーキング

トラフィックは、分類後にマーキングできます。マーキングは、パケットの分類ビットを選択的に修正し、ネットワーク内でトラフィックを識別する方法です。その他のインターフェイスは、マーキングに基づいてトラフィックをマッチングできます。マーキングの設定の詳細については、「マーキングの設定」を参照してください。

出力分類

分類ではトラフィック記述子が使用されて特定グループにパケットが分類され、そのパケットが定義されてネットワークで QoS 処理用にアクセスできるようになります。パケット分類を使用すると、複数のプライオリティ レベルまたはサービス クラスにネットワーク トラフィックを区分できます。

トラフィックは、次の判断のために分類されます。

さらに処理を進めるようにマーク付けするかどうか

レート制限固有のトラフィック タイプでキューに入れるかどうか

分類の設定の詳細については、「分類の設定」を参照してください。

出力ポリシング

ES+ ラインカードでは、出力ポート ポリシングをサポートします。

出力マーキング

トラフィックの分類後、ルータはトラフィックをマーキングできます。パケットの分類ビットを選択的に修正し、指定マーキングに基づいてパケットを差別化するためにマーキングを使用します。マーキングの設定の詳細については、「マーキングの設定」を参照してください。

出力シェーピング

トラフィック シェーピングでは、インターフェイスから出力されるトラフィックを制御して、リモート ターゲット インターフェイスの速度にフローを合わせ、指定されているポリシーにトラフィックを準拠させることができます。ダウンストリーム要件を満たして、データとレートが一致しないトポロジのボトルネックを解消するため、シェーピングを使用できます。シェーピングの設定の詳細については、「シェーピングの設定」を参照してください。

出力キュー スケジューリング

出力ラインカードは、輻輳とバッファのオーバーフローの防止に役立つクラスベース均等化キューイング(CBWFQ)や重み付けランダム早期検出(WRED)の輻輳回避を使用します。 出力スケジューリングの設定の詳細については、「帯域幅と CBWFQ の設定」を参照してください。

分類の概要

QoS の分類機能を使用して、ネットワーク トラフィックを選択し、クラス別に分類して、一定の一致条件に基づいてその後の QoS 処理が実行されるようにします。デフォルト クラスである「class-default」は、設定されているクラス マップのどの選択条件とも一致しないトラフィックが振り分けられるクラスです。

分類の制約事項および使用上のガイドライン

QoS 分類を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

SVI の ES+ ラインカードの分類は、EoMPLS および VPLS でのみサポートされます。

match not コマンドはサポートされません。

表 A-1 で、サポートされる QoS 分類機能について説明します。

 

表 A-1 QoS 分類機能のサポート

機能(match コマンド)
サポートするインターフェイス

アクセス リスト(ACL)番号のマッチング
match access-group コマンド)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

(注) 拒否 ACL は ES+ ラインカードでサポートされていません。

サービス クラス(CoS)のマッチング
match cos コマンド)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)(レイヤ 3 インターフェイスで適用されるサブインターフェイスのトラフィックおよびポリシーマップとのマッチング用)

レイヤ 3 サブインターフェイス

SVI インターフェイス(EoMPLS および VPLS 専用)

入力 VLAN のマッチング
match input vlan コマンド)

入力側の非インテリジェント ラインカードおよび出力側の ES+ ラインカードによって使用されるレイヤ 3 インターフェイス(ルーテッド ポート)の出力。出力側でサービス ポリシーが適用され、入力側からの VLAN とのマッチングが行われます。

IP DSCP のマッチング
match ip dscp コマンド)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

IP precedence のマッチング
match ip precedence コマンド)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

MPLS Experimental(EXP)ビットのマッチング
match mpls experimental コマンド)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

VLAN のマッチング
match vlan コマンド)

(注) レイヤ 2 IEEE 802.1Q フレームの外部 VLAN とマッチングします。

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)(EoMPLS および VPLS 専用の SVI の分類)

レイヤ 3 サブインターフェイス

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# class-map [ match-all | match-any ] class-map-name

トラフィック クラスを作成します。

match-all :(任意)クラスで定義されたすべてのマッチング ステートメントの論理積を使用し、クラス マップのすべての一致基準と一致しなければならないことを指定します。これがデフォルトです。

match-any :(任意)クラスで定義されたすべてのマッチング ステートメントの論理和を使用し、1 つ以上の一致基準と一致しなければならないことを指定します。

class-map-name :ユーザ定義のクラス名を指定します。

(注) 一意のクラス マップを 1000 まで定義できます。

ステップ 4

Router(config-cmap)# match type

トラフィックに適用する一致基準を指定します。 type は、 表 A-1 に示す、サポートされている match コマンドの 1 つを表します。

コマンド ステートメントを指定できます。

次の例は、ipp5 というクラス マップを設定して、IP precedence 5 のマッチング ステートメントを入力する方法を示しています。

Router> enable
Router# configure terminal
Router(config)# class-map ipp5
Router(config-cmap)# match ip precedence 5
 

複数のマッチング ステートメントでのクラス マッチングを設定する例を次に示します。

Router> enable
Router# configure terminal
Router(config)# class-map match-any many (id 1047)
Router(config-cmap)# match ip precedence 3
Router(config-cmap)# match access-group 100
Router(config-cmap)# match mpls experimental 5
 

指定 ACLS でクラス マッチングを設定する例を次に示します。

Router> enable
Router# configure terminal
Router(config)# class-map match-all acl9 (id 1049)
Router(config-cmap)# match access-group name rock
 

次の例は、show class-map コマンドを使用して、指定クラス マップのクラス マップ情報を表示する方法を示しています。

Router# show class-map ipp5
class map match-all ipp5 (id 1)
match ip precedence 5
 

次の例は、show class-map コマンドを使用して、拡張 ACL のクラス マップ情報マッチングを表示する方法を示しています。

Router# show class-map acl5
class map match-all acl5 (id 1042)
match access-group 102
 

次の例は、HQoS ポリシーの親クラスの VLAN で分類を確認する方法を示しています。

Router# show policy-map match
policy map match
class vlan11
shape average 2000000 8000 8000
service-policy match4
class vlan12
shape average 2000000 8000 8000
service-policy match4
class vlans
shape average 500000000 2000000 2000000
service-policy match2

ポリシングの概要

ES+ ラインカードは次の QoS 機能をサポートします。

個別アクション

複数のアクション

シングル レート、2 カラーおよび 3 カラー ポリサー

粒度

精度(レートおよびバケットの深さ)

統計情報

パーセントベース ポリサー

デュアル レート、3 カラー、パーセントベース ポリサー

カラー ブラインド モード(カラー認識ポリサーはサポートされません)

階層型ポリシー(最大 2 レベル)

さまざまなレートでの 255 のプロファイル

ポリシングは、次のインターフェイスのタイプの入力および出力でサポートされます。

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

ポリシングの制約事項および使用上のガイドライン

ポリシングを設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

ES+ ラインカードでは、ラインカードごとに最大 1,024 の一意のグローバル ポリシーマップがサポートされます。

ポリシーマップごとのクラス マップ数は最大 255 です。

ポリサー CIR および PIR は 64,000 bps ~ 10 Gbps の任意の値です。

サービス ポリシーで、ポリシング アクションの一部としてクラス ベース マーキングとマーキングの両方を設定した場合、ポリシングを使用するマーキングがクラス ベース マーキングより優先されます。

ポリシングをプライオリティ アクションと組み合わせて設定する場合:

その他の帯域幅クラスがポリシーマップに設定されている場合は、exceed または violate アクションのいずれかをドロップする必要があります。conform アクションは任意のアクションです。

その他の帯域幅クラスが設定されていない場合は、conform、exceed、violate は任意のアクションです。

NP ごとに最大 48,000 のポリサーが、1 レート 2 カラーまたは 2 レート 3 カラーのポリサー用にサポートされます。

表 A-2 に、どのポリシング機能が ES+ ラインカードでサポートされているかに関する情報を示します。

 

表 A-2 QoS ポリシング機能のサポート

ポリシング コマンド
ポリシング アクション(set コマンド)

police bps value conform-action action exceed-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

COS 値を設定します(set cos コマンド)。

police cir percent % conform-action action exceed-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

COS 値を設定します(set cos コマンド)。

COS-inner 値を設定します(set cos-inner コマンド)。

police cir bps value pir bps value conform-action action exceed-action action violate-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

CoS 値を設定します(set cos コマンド)。

CoS-inner 値を設定します(set cos-inner コマンド)。

police cir percent % pir percent % conform-action action exceed-action action violate-action action

パケットを伝送します(transmit アクション)。

パケットをドロップします( drop コマンド)。

IP precedence 値を設定します( set ip precedence コマンド)。

IP DSCP 値を設定します( set ip dscp コマンド)。

インポジションの MPLS EXP ビット(0 ~ 7)を設定します( set-mpls-experimental-imposition コマンド)。

topmost ラベルの MPLS EXP ビットを設定します( set-mpls-experimental-topmost コマンド)。

COS 値を設定します(set cos コマンド)。

COS-inner 値を設定します(set cos-inner コマンド)。

ポリシー マップ、クラス マップ、およびポリシングの設定

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# policy-map policy-map-name

トラフィック ポリシーを作成または変更し、 policy-map-name が設定するトラフィック ポリシーの名前を指定するポリシーマップ コンフィギュレーション モードを開始します。名前には、40 文字までの英数字を使用できます。

ステップ 4

Router (config-pmap)# class { class-name | class-default }

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシーマップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 5

Router(config-pmap-c)# police bps-value conform-action action exceed-action action

トークン バケット アルゴリズムを使用してトラフィック クラスが使用できる最大帯域幅を指定します。

bps value:平均速度をビット/秒で指定します。有効値の範囲は 16000 ~ 10 Gb/s です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

または

Router(config-pmap-c)# police cir percent percentage conform-action action exceed-action action

インターフェイスで使用可能な帯域の割合に基づくトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。認定情報レート(CIR)がトラフィックのポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

percentage :CIR 帯域幅の割合を指定します。有効値の範囲は 1 ~ 100 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

または

Router(config-pmap-c)# police cir bps-value pir bps-value conform-action action exceed-action action violate-action action

CIR および最大情報レート(PIR)の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィック ポリシングに使用されることを示します。

pir:最大情報レートを指定します。PIR がトラフィック ポリシングに使用されることを示します。

bps-value:平均速度をビット/秒で指定します。有効値の範囲は 64000 ~ 200000000 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

または

Router(config-pmap-c)# police cir percent percentage pir percent percentage conform-action action exceed-action action violate-action action

CIR および PIR の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィック ポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

percentage :CIR または PIR の帯域幅の割合を指定します。有効値の範囲は 1 ~ 100 です。

pir:最大情報レートを指定します。PIR がトラフィック ポリシングに使用されることを示します。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

次の例では、すべてのアクションは別の行で設定されています。

Router# (config)# policy-map ABC
Router(config-pmap)# class class-default
Router(config-pmap-c)# police 10000000 8000 8000
Router(config-pmap-c-police)# conform-action set-cos-transmit 2
Router(config-pmap-c-police)# exceed-action set-cos-transmit 1
Router(config-pmap-c-police)# end
Router# show policy-map ABC
Policy Map ABC
Class class-default
police cir 10000000 bc 8000 be 8000
conform-action set-cos-transmit 2
exceed-action set-cos-transmit 1
 

次の例では、1 レート 2 カラー ポリサーを設定します。

Router(config)# policy-map 1r2c
Router(config-pmap)# class class-default
Router(config-pmap-c)# police 2000000
Router(config-pmap-c-police)# conform-action transmit
Router(config-pmap-c-police)# exceed-action drop
Router(config-pmap-c-police)# end
Router# show policy-map 1r2c
Policy Map 1r2c
Class class-default
police cir 2000000 bc 62500
conform-action transmit
exceed-action drop
 

次の例では、1 レート 2 カラー ポリサーをパーセントで設定します。

Router(config)# policy-map 1r2c_percent
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir percent 20
Router(config-pmap-c-police)# conform-action set-cos-transmit 0
Router(config-pmap-c-police)# exceed-action drop
Router(config-pmap-c-police)# end
Router# show policy-map 1r2c_percent
Policy Map 1r2c_percent
Class class-default
police cir percent 20
conform-action set-cos-transmit 0
exceed-action drop
 

次の例では、2 レート 3 カラー ポリサーを設定します。

Router(config)# policy-map 2r3c
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir 2000000 pir 3000000
Router(config-pmap-c-police)# conform-action set-prec-transmit 3
Router(config-pmap-c-police)# exceed-action set-prec-transmit 2
Router(config-pmap-c-police)# violate-action set-prec-transmit 1
Router(config-pmap-c-police)# end
Router# show policy-map 2r3c
Policy Map 2r3c
Class class-default
police cir 2000000 bc 62500 pir 3000000 be 93750
conform-action set-prec-transmit 3
exceed-action set-prec-transmit 2
violate-action set-prec-transmit 1
 

次の例では、2 レート 3 カラー ポリサーをパーセントで設定します。

Router(config)# policy-map 2r3c_percent
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir percent 10 pir percent 20
Router(config-pmap-c-police)# conform-action transmit
Router(config-pmap-c-police)# exceed-action set-cos-transmit 0
Router(config-pmap-c-police)# violate-action drop
Router(config-pmap-c-police)# end
Router# show policy-map 2r3c_percent
Policy Map 2r3c_percent
Class class-default
police cir percent 10 pir percent 20
conform-action transmit
exceed-action set-cos-transmit 0
violate-action drop
 

次の例では、64 Kbps の CIR で class-default にシングル レート、2 カラー ポリサー、送信の conform アクション、およびドロップの exceed アクションを可能な限り小さな Bc で設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map police
Router(config-pmap)# class test8
Router(config-pmap-c)# police 64000 2000
 

次の例では、class-default にシングル レート、2 カラー ポリサー、およびポリシングを指定して子ポリシーを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map police5
Router(config-pmap)# class test18
Router(config-pmap-c)# service policy child-level
Router(config-pmap-c)# police cir 64000 50
 

次の例は、クラスおよびポリシー マップの 2R3C 設定を示しています。

Router> enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class cos2
Router(config-pmap-c)# police 1000000 pir 2000000 conform-action set-cos-transmit 3 exceed-action set-cos-transmit 1 violate-action drop
 

次の例では、64 Kbps の CIR および CIR の 2 倍の PIR で class-default にデュアル レート、3 カラー ポリサー、送信の conform アクション、および exceed アクション マーク dscp af11 および violate マーク dscp cs1 を Bc のデフォルト設定で設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map qos_test
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir 64000 bc 2000 pir 128000 be 2000 conform-action transmit exceed-action set-dscp-transmit af11 violate-action set-dscp-transmit cs1
 

次の例では、class-default にデュアル レート、3 カラー ポリサーを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class class-default
Router(config-pmap-c)# police cir percent 20 pir percent 40 conform-action transmit exceed-action set-prec-transmit 1 violate-action drop
 

ポリシングを検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map

設定されたすべてのポリシーマップを表示します。

Router# show policy-map policy-map-name

ユーザ指定ポリシーマップを表示します。

Router# show policy-map interface

インターフェイスに適用されたすべての入力および出力ポリシーの統計情報および設定を表示します。

次の例は、show policy-map interface コマンドを EXEC モードで使用してポリシング統計を表示する方法を示しています。

Router# show policy-map interface
TenGigabitEthernet3/1
service-policy output: x
class-map: a (match-all)
0 packets, 0 bytes
5 minute rate 0 bps
match: ip precedence 0
police:
1000000 bps, 10000 limit, 10000 extended limit
conformed 0 packets, 0 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: drop
conformed 0 bps, exceed 0 bps, violate 0 bps

インターフェイスへの QoS トラフィック ポリシーの結合

トラフィック クラスでトラフィック ポリシーをイネーブルにするには、インターフェイス上でトラフィック ポリシーを設定しておく必要があります。トラフィック ポリシーは、イーサネット サブインターフェイスとメイン インターフェイスにも結合できます。トラフィック ポリシーは、インターフェイス(入力)に着信するトラフィックおよびそのインターフェイス(出力)から送信されるトラフィックに適用できます。

「入力インターフェイスへの QoS トラフィック ポリシーの結合」

「出力インターフェイスへの QoS トラフィック ポリシーの結合」

入力インターフェイスへの QoS トラフィック ポリシーの結合

入力インターフェイスにトラフィック ポリシーを結合すると、そのインターフェイスに着信したトラフィックにポリシーが適用されます。入力インターフェイスにトラフィック ポリシーを結合するには、インターフェイス コンフィギュレーション モードから次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# service-policy input policy-map-name

インターフェイスの入力方向にトラフィック ポリシーを結合します。 policy-map-name には、設定するトラフィック ポリシーの名前を指定します。

出力インターフェイスへの QoS トラフィック ポリシーの結合

出力インターフェイスにトラフィック ポリシーを結合すると、そのインターフェイスから送信されるトラフィックにポリシーが適用されます。出力インターフェイスにトラフィック ポリシーを結合するには、インターフェイス コンフィギュレーション モードから次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# service-policy output policy-map-name

インターフェイスの出力方向にトラフィック ポリシーを結合します。 policy-map-name には、設定するトラフィック ポリシーの名前を指定します。

マーキングの概要

トラフィック クラスの作成後、トラフィック ポリシーを設定することによって、これらのクラスで選択されたトラフィックに特定のアクションを適用するように、マーキング機能を設定できます。

通常、パケット マークは識別用です。パケットがマーキングされたあと、ダウンストリーム デバイスはマーキングに基づいてトラフィックを識別し、ネットワーク要求に従ってトラフィックを分類します。この分類が発生するのは、マークを基準としてパケットを識別するようにトラフィック クラス内の match コマンド( match ip precedence match ip dscp match cos など)が設定されている場合です。その後、このトラフィック クラスを使用するトラフィック ポリシーによって、マーキング済みトラフィックに適した QoS 機能が設定されます。

場合によっては、識別以外の目的にマーキングを使用できます。たとえば、Distributed WRED では IP precedence、IP DSCP、または MPLS EXP 値を使用して、パケットを検出したり、ドロップしたりすることができます。

マーキングの制約事項および使用上のガイドライン

ES+ ラインカードにおいてクラスベース マーキングを設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

クラス マップごとのマーキング ステートメントの数に制限はありません。

マーキングは親で設定できます。

EARL マーキングは使用されません。

マーキングは、キューイング ポリシーと組み合わせることができます。

マーキング統計は、show policy-map interface コマンドの出力には含まれません。マーキング統計の代わりに分類統計を参照してください。

表 A-3 で、サポートされる QoS クラスベース マーキング機能について説明します。

 

表 A-3 QoS クラスベース マーキング機能のサポート

マーキング機能(set コマンド)
サポートするインターフェイス

IP DSCP の設定

set ip dscp コマンド:0 ~ 63 の値を使用して、タイプ オブ サービス(ToS)バイトで IP DiffServ コード ポイント(DSCP)をマーキング)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

IP precedence の設定

set ip precedence コマンド:0 ~ 7 の値を使用して、IP ヘッダーの precedence 値をマーキング)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

レイヤ 2 IEEE 802.1Q CoS の設定

set cos コマンド:802.1Q タグ付きフレームで 0 ~ 7 の CoS 値をマーキング)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)(レイヤ 3 インターフェイスで適用されるサブインターフェイスのトラフィックおよびポリシーマップとのマッチング用)

レイヤ 3 サブインターフェイス

ラベル インポジションでの MPLS Experimental(EXP)ビットの設定

set mpls experimental imposition コマンド)

次のインターフェイス タイプの入力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

MPLS EXP topmost の設定

set mpls experimental topmost コマンド)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

ポリシー マップ、クラス マップ、およびマーキングの設定

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# policy-map policy-map-name

トラフィック ポリシーを作成または変更し、 policy-map-name が設定するトラフィック ポリシーの名前を指定するポリシーマップ コンフィギュレーション モードを開始します。名前には、40 文字までの英数字を使用できます。

ステップ 4

Router(config-pmap)# class { class-name | class-default }

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシーマップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 5

Router(config-pmap-c)# set type

トラフィックに適用するマーキング アクションを指定します。 type は、 表 A-3 に示す、サポートされている set コマンドの形式の 1 つを表します。

次の例は、policy1 というサービス ポリシーの作成を示しています。このサービス ポリシーは、class コマンドの使用により、以前定義した分類ポリシーに関連付けられます。この例では、class1 という分類ポリシーが設定されていることを前提とします。

Router> enable
Router# configure terminal
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# set ip precedence 1
 

次の例では、インポーズされた MPLS EXP ビットを 1 に設定するようにマーキングを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class test
Router(config-pmap-c)# set mpls experimental imposition 1
 

次の例では、内部 cos 値を設定するようにマーキングを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class test
Router(config-pmap-c)# set cos inner 1
 

次の例では、インポーズされた MPLS EXP ビットを 1 に設定するようにマーキングを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map test
Router(config-pmap)# class test
Router(config-pmap-c)# set mpls experimental topmost 1
 

マーキングを検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map

設定されたすべてのポリシーマップを表示します。

Router# show policy-map policy-map-name

ユーザ指定ポリシーマップを表示します。

Router# show policy-map interface

インターフェイスに適用されたすべての入力および出力ポリシーの統計情報および設定を表示します。

シェーピングの制約事項および使用上のガイドライン

シェーピングを設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

親レベルでは最大 256、子レベルおよびフラット ポリシーでは 64 のシェーピング プロファイルがサポートされます。

シェーピングは階層のどのレベルでも実行できます。

シェーピング レートは、64 Kbps からリンク レートの範囲です。

デュアル シェーパーはサポートされません。

メイン インターフェイスは、2 レベルのポリシーマップをサポートします。

親ユーザ定義クラス

子ユーザ定義クラス

子レベル シェーパーのシェーパー CIR の粒度:

64,000 ~ 32,768,000 bps、粒度は 16,000 bps

32,768,000 ~ 131,008,000 bps、粒度は 64,000 bps

親レベル シェーパーのシェーパー CIR の粒度は次のとおりです。

64,000 bps ~ 10 Gbps の任意の値が可能

リーフ ポリシーマップの最大シェーパー レートは 130 Mb/s です。

shape average percent コマンドはサポートされません。

表 A-4 に、サポートされる QoS トラフィック シェーピング機能をリストします。

 

表 A-4 QoS トラフィック シェーピング機能のサポート

トラフィック シェーピング機能(コマンド)
目的

クラスベース シェーピング

shape average コマンド)

次のインターフェイス タイプの入力および出力:

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

クラス マップ、ポリシー マップ、およびシェーピングの設定

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# class-map [ match-all | match-any ] class-map-name

クラスとパケットの照合に使用されるクラス マップを作成します。

ステップ 4

Router(config-cmap)# match [ ip dscp ip-dscp-value | ip precedence ip-precedence-value | mpls experimental mpls-exp-value]

指定 IP DSCP、IP precedence、MPLS EXP のうちいずれかの値を一致基準として指定します。

ステップ 5

Router(config)# policy-map policy-name

設定するポリシーマップの名前を指定します。

ステップ 6

Router(config-pmap)# class class-name

サービス ポリシーに含まれる定義済みクラスの名前を指定します。

ステップ 7

Router(config-pmap-c)# shape average cir [bc] [be]

平均レート トラフィック シェーピングを指定します。

次の例は、メイン インターフェイスでのトラフィック シェーピングを示しています。インターフェイス tengi1/1 から出力されるトラフィックは、10 Mb/s のレートでシェーピングされます。

Router> enable
Router# configure terminal
Router(config)# class-map class-interface-all
Router(config-cmap)# match ip precedence 2
Router(config-cmap)# exit
Router(config)# policy-map dts-interface-all-action
Router(config-pmap)# class class-interface-all
Router(config-pmap-c)# shape average 10000000
Router(config-pmap-c)# exit
Router(config)# interface tengi1/1
Router(config-if)# service-policy output dts-interface-all-action
 

次の例では、シェーピングは HQoS ポリシーマップの親レベルで適用されます。

Router> enable
Router# configure terminal
Router(config)# policy-map child2
Router(config-pmap)# class prec5
Router(config-pmap-c)# shape average 100000000
Router(config)# policy-map pcd
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 300000000
Router(config-if)# service-policy child2
 

次の例では、default-class に WRED を指定したシェーピング ポリシーを設定します。

Router> enable
Router# configure terminal
Router(config)# policy map qos_test
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape ave 100mbps
Router(config-pmap-c)# random-detect dscp-based aggregate
 

トラフィック シェーピングを検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show interface [interface-name]

トラフィック シェーピングの詳細ステータスを表示します。

Router# show policy policy-name

指定トラフィック ポリシーを構成するすべてのクラスの設定を表示します。

Router# show policy policy-name class class-name

指定トラフィック ポリシーの指定クラスの設定を表示します。

QoS キュー スケジューリングの制約事項および使用上のガイドライン

キューイング機能を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

子レベルでポリシーマップごとに設定できるデータ キューの数は、プライオリティ キューの設定によって異なります。

プライオリティ キューが設定されていない場合は、各加入者は最大 8 つの通常のキューを持つことができます。

任意のプライオリティ レベルのプライオリティ キューが設定されている場合は、各加入者は 2 つのプライオリティ キューおよび最大 6 つの通常のキューを持つことができます。

プライオリティ キューが 1 つだけ設定されている場合は、その他のプライオリティ キューは保留され、通常のキューとして使用できません。

NP ごとに入力に 4k の親キューおよび出力に 8k の親キュー(設定不能)。

NP ごとに入力に 32K の子キューおよび出力に 64k の子キュー(設定不能)。

サブインターフェイスの親 class-default はさらにスケーリングされます。

親のユーザ定義クラスマップは、レイヤ 3 インターフェイス(ルーテッド ポート、出力のみ)でサポートされます。

QoS キュー スケジューリングでは、次のコマンドがサポートされます。

bandwidth x kbps

bandwidth percent x%

bandwidth remaining percent x %

queue-limit queue-size

queue-limit queue-size packets

random-detect

random-detect min-threshold max-threshold mark-prob

random-detect dscp-based aggregate

random-detect dscp 0-63 min-threshold max-threshold mark-prob

random-detect prec-based

random-detect precedence 0-7 min-threshold max-threshold mark-prob

WRED の概要

WRED は、一般的に IP precedence に基づいてパケットを選択的にドロップします。より高い IP precedence のパケットは、低い IP precedence のパケットよりもドロップしにくくなります。WRED は、次のインターフェイスの出力でサポートされます。

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

WRED 集約および非集約モード

WRED 集約モードおよび非集約モードでは、WRED の動作を提供するために、ハードウェア リソースが内部で使用される方法を定義します。8 つの WRED カーブがあります。WRED 非集約モードでは、単一値または precedence 値が 1 つの WRED カーブにマッピングされ、WRED 集約モードでは、複数の DSCP 値が 1 つの WRED カーブにマッピングされます。

random-detect dscp(集約)CLI で定義されているサブクラス(DSCP precedence)のセットが、1 つのハードウェア WRED リソースに集約されます。これらのサブクラスの統計情報も集約されます。

WRED の制約事項および使用上のガイドライン

WRED を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

WRED サポートは、precedence ベース、DSCP ベース、CoS ベースです。random-detect コマンドを使用したデフォルトは、precedence ベースの WRED です。

DSCP は DSCP ベースは集約モードでのみサポートされ、64 の値を取るため、複数の DSCP 値を 8 つの WRED カーブそれぞれにマッピングします。例:DSCP 30、50、60 は WRED Curve1、DSCP 10、40 は WRED Curve2 を取ります。

CoS は非集約モードでのみサポートされ、8 つの値を取るため、単一値を 8 つの WRED カーブそれぞれにマッピングします。

IP prec は集約モードおよび非集約モードの両方でサポートされます。

インターフェイスごとのサポートは次のとおりです。

サブインターフェイスの場合、WRED は DSCP ベースと precedence ベースだけをサポートします。

キュー制限は WRED コマンドではサポートされていません。

WRED は、親クラスではサポートされません。

WRED はすべてのプライオリティ レベルのプライオリティ キューではサポートされません。

クラス キューのランダム検出にはキューイング機能が必要です。

デフォルト クラスのランダム検出にはキューイング機能は不要です。

ES+ ラインカードでは、discard-class ベース、ECN、および WRED はサポートされません。

ES+ ラインカードでは集約 WRED がサポートされます。

キューごとに 8 つのカーブがサポートされます。

WRED の show policymap interface コマンドでは、送信されたパケットおよびテール ドロップの数が表示されません。ランダム ドロップだけが表示されます。

最大しきい値は 16 ~ 1000000 である必要があります。

MPLS パケットの EXP ベース WRED がサポートされます。

ポリシー マップ、クラス マップ、および WRED の設定

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# policy-map policy-name

設定するポリシーマップの名前を指定します。

ステップ 4

Router(config-pmap)# class class-name

サービス ポリシーに含まれる定義済みクラスの名前を指定します。

ステップ 5

Router(config-pmap-c)# shape average cir [ bc ] [ be ]

指定クラスの指定ビット レートにトラフィックをシェーピングします。

ステップ 6

Router(config-pmap-c)# random-detect

WRED をイネーブルにします。

WRED 設定の例を次に示します。

Router> enable
Router# configure terminal
Router(config)# policy-map wredtest
Router(config-pmap)# class cos5
Router(config-pmap-c)# shape average 200000000
Router(config-pmap-c)# random-detect dscp-based aggregate
Router(config-pmap-c)# random-detect dscp values 0 min 100 max 200 mark-prob 1
Router(config-pmap-c)# random-detect dscp values 1 min 300 max 500 mark-prob 1
Router(config-pmap-c)# random-detect dscp values 2 min 600 max 900 mark-prob 1
 

次の例では、IPP=1、3、5、7 と一致するクラス マップを設定し、出力インターフェイスに適用される WRED ポリシーを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map wred
Router(config-pmap)# class IPP1
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
Router(config-pmap)# class IPP3
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
Router(config-pmap)# class IPP5
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# random-detect precedence-based
 

次の例は、 show policy map interface コマンドの出力を示しています(送信パケットは表示されません)。

Router> enable
Router# configure terminal
Router# show policy-map interface tengig 11/1
TenGigabitEthernet11/1:
 
Service-policy output: temp_parent
 
Class-map: class-default (match-any)
139358 packets, 71351296 bytes
5 minute offered rate 1745000 bps, drop rate 283000 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
queue limit 2048 packets
(queue depth/total drops/no-buffer drops) 0/104062/0
(pkts output/bytes output) 35296/18071552
shape (average) cir 10000000, bc 40000, be 40000
target shape rate 10000000
 
Service-policy : temp
 
Counters last updated 00:00:00 ago
 
Class-map: class-default (match-any)
139358 packets, 71351296 bytes
5 minute offered rate 1745000 bps, drop rate 1304000 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps
queue limit 2048 packets
(queue depth/total drops/no-buffer drops) 0/104062/0
(pkts output/bytes output) 35296/18071552
Exp-weight-constant: 9 (1/512)
Mean queue depth: 0 packets
class Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes thresh thresh prob

帯域幅および CBWFQ の概要

CBWFQ は、ユーザ定義のトラフィック クラスをサポートするために、標準的な WFQ 機能を拡張したものです。CBWFQ では、一致基準およびアクセス コントロール リスト(ACL)に基づいてトラフィック クラスを定義します。

帯域幅は、次のインターフェイス タイプの出力でサポートされます。

レイヤ 3 インターフェイス(ルーテッド ポート)

レイヤ 3 サブインターフェイス

WFQ は、階層型 QoS の特定のレベルのキューイング エンティティに対する帯域幅または残りの帯域幅の割り当てを決定する方法です。エンティティに付加された WFQ 設定のコミットおよび超過重みに基づいて各エンティティに帯域幅および残りの帯域幅を配布できます。WFQ のコミットおよび超過重みは、あとで同じまたは類似の帯域幅設定を共有するかどうかに基づいて WFQ プロファイルが 1 つ以上のキューイング エンティティに付加される WFQ プロファイル レジスタに最初にプログラムされます。

レイヤ 3 およびレイヤ 4 レベル WFQ プロファイルは 1 個のハードウェア プールに属し、レイヤ間で共通に使用できます。

帯域幅および CBWFQ の制約事項および使用上のガイドライン

帯域幅および CBWFQ を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

bandwidth kbps および bandwidth percent x% コマンドがサポートされます。

bandwidth remaining percent コマンドは子レベルでサポートされます。bandwidth remaining ratio コマンドは、親および子レベルでサポートされます。

QoS ポリシーマップ内で使用される bandwidth コマンドはクラス間で一貫している必要があります。

ポリシー マップ、クラス マップおよび帯域幅の設定

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# policy-map policy-map-name

トラフィック ポリシーを作成または変更し、 policy-map-name が設定するトラフィック ポリシーの名前を指定するポリシーマップ コンフィギュレーション モードを開始します。名前には、40 文字までの英数字を使用できます。

ステップ 4

Router(config)# class { class-name | class-default }

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシーマップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 5

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent | percent percent}}

クラスに割り当てる帯域幅の量(kbps 単位)または使用可能な帯域幅に占める割合を指定します。設定する帯域幅の量は、レイヤ 2 オーバーヘッドも十分処理できる量にする必要があります。

次の例は、トラフィック クラス 1 および 2 に割り当てる帯域幅の容量を指定する、policy1 というサービス ポリシーを示しています。

Router> enable
Router# configure terminal
Router(config)# class-map class1
Router(config-cmap)# match ip dscp 30
Router(config-cmap)# exit
Router(config)# class-map class2
Router(config-cmap)# match ip dscp 10
Router(config-cmap)# exit
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 30000
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth 20000
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# interface tengigabitethernet 2/1
Router(config-if)# service-policy output policy1
Router(config-if)# exit
 

次の例では、bandwidth コマンドを使用してレート保証が設定された複数のユーザ クラスを持つ QoS ポリシーを設定します。

 
Router(config)# policy-map policy1
Router(config)# class c1
Router(config-pmap-c)# bandwidth percent 1%
Router(config-pmap)# class c2
Router(config-pmap-c)# bandwidth percent 10%
Router(config-pmap)# class c3
Router(config-pmap-c)# bandwidth percent 88%
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth 1%
 

次の例では、レート保証が設定されている複数のユーザ クラスを持つ QoS ポリシーを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map child_policy
Router(config-pmap)# class video
Router(config-pmap-c)# police 10000000
Router(config-pmap)# class critical
Router(config-pmap-c)# bandwidth remaining percent 80
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth remaining percent 20
 

CBWFQ を検証するには、次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map policy-map

指定ポリシーマップを構成するすべてのクラスの設定を表示します。

Router# show policy-map policy-map class class-name

指定ポリシーマップの指定クラスの設定を表示します。

Router# show policy-map interface interface-name

指定インターフェイスのすべてのポリシーマップ用に設定されているすべてのクラスの設定を表示します。

Router# show queue interface-type interface-number

特定のインターフェイスのキューイングの設定と統計情報を表示します。

LLQ の概要

低遅延キューイング(LLQ)では、priority コマンドを使用してポリシーマップ内のクラス マップに帯域幅を割り当てます。

LLQ は、次のインターフェイスの出力でサポートされます。

メイン レイヤ 3 インターフェイス

レイヤ 3 サブインターフェイス

LLQ の制約事項および使用上のガイドライン

LLQ を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

入力 LLQ はサポートされていません

出力 LLQ

LLQ/PQ は ES+ レイヤ 3 およびレイヤ 3 サブインターフェイスでは出力でのみサポートされます。

デュアル プライオリティ キューはサポートされます(プライオリティ レベル 1 とプライオリティ レベル 2)。

LLQ 設定は子ポリシーで許可されます。

priority および priority level コマンドがサポートされますが、同じポリシーマップで両方のコマンドを使用することはできません。

ビット レートによる基本的なプライオリティ/低遅延キューはサポートされません。

パーセントによる基本的な低遅延キューはサポートされません。

ビット レートによるプライオリティ キューはサポートされません。

LLQ の設定

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# policy-map policy-name

設定するポリシーマップの名前を指定します。

ステップ 4

Router(config-pmap)# class { class-name | class-default }

サービス ポリシーに含まれる定義済みクラスの名前を指定します。

ステップ 5

Router(config-pmap-c)# police bps-value conform-action action exceed-action action

トークン バケット アルゴリズムを使用してトラフィック クラスが使用できる最大帯域幅を指定します。

bps-value:平均速度をビット/秒で指定します。有効値の範囲は 64000 ~ 200000000 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

または

Router(config-pmap-c)# police cir percent % conform-action action exceed-action action

インターフェイスで使用可能な帯域の割合に基づくトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィック ポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

%:CIR の帯域幅割合を指定します。有効値の範囲は 1 ~ 100 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

または

Router(config-pmap-c)# police cir bps-value pir bps-value conform-action action exceed-action action violate-action action

CIR および PIR の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィック ポリシングに使用されることを示します。

pir:最大情報レートを指定します。PIR がトラフィック ポリシングに使用されることを示します。

bps-value:平均速度をビット/秒で指定します。有効値の範囲は 64000 ~ 200000000 です。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

または

Router(config-pmap-c)# police cir percent percentage pir percent % conform-action action exceed-action action violate-action action

CIR および PIR の 2 つのレートを使用してトラフィック ポリシングを設定します。

cir:認定情報レートを指定します。CIR がトラフィック ポリシングに使用されることを示します。

percent:帯域幅の割合を CIR の計算に使用することを指定します。

%:CIR または PIR の帯域幅割合を指定します。有効値の範囲は 1 ~ 100 です。

pir:最大情報レートを指定します。PIR がトラフィック ポリシングに使用されることを示します。

action:パケットが適合または超過したときにパケットに対して実行するアクションを指定します。 表 A-2 に、可能なアクションを示します。

ステップ 6

Router(config-pmap-c)# priority [level] {1-2}

ポリシーマップに属するトラフィック クラスに、厳密なプライオリティを指定します。

次の例では、厳密なプライオリティが設定されているクラス c1 に簡単な LLQ QoS ポリシーを設定します。

Router> enable
Router# configure terminal
Router(config)# policy map qos_llq
Router(config-pmap)# class c1
Router(config-pmap-c)# police 500000000
Router(config-pmap-c)# priority
 

次の例では、テスト用の最小パーセント値とデフォルトのバースト値が設定されている複数のプライオリティ クラスを持つ LLQ ポリシーを設定します。

Router> enable
Router# configure terminal
Router(config-pmap)# class-map voice
Router(config-pmap-c)# police cir percent 10
Router(config-pmap-c)# priority
Router(config-pmap)# class-map video
Router(config-pmap-c)# police cir percent 20
Router(config-pmap-c)# priority
Router(config-pmap)# class-default

階層型 QoS の概要

ES+ ラインカードでは、Cisco モジュラ QoS CLI(MQC)を使用して設定する階層型 QoS(H-QoS)がサポートされます。次の H-QoS 機能がサポートされます。

2 レベルの H-QoS(メイン インターフェイスで結合されている場合、2 レベルのポリシー マップには 3 レベルの階層があります)。

精密な QoS:ポリシングおよびシェーピング、64 Kbps のデータ レート

カラー ブラインド ポリシング:2 レート 3 カラー ポリサーおよび 1 レート 2 カラー ポリサー


) カラー認識ポリシングはサポートされません。


出力分類

TenGigabitEthernet 802.1Q サブインターフェイスの QoS

出力クラスベース均等化キューイング(CBWFQ)

低遅延キューイング(LLQ)(入力および出力)

IP/MPLS およびレイヤ 2 CoS 分類の出力 H-QoS

イーサネット L2VPN での AToM QoS 機能

階層型ポリシング

ES+ ラインカードの拡張:

128,000 のキュー

16,000 のトラフィック シェーパー

NP あたり 48,000 のポリサー

出力の NP あたり 8,000 の H-QoS ポリシーマップ。

ES+ ラインカードごとに 24000 のポリサー。

階層型 QoS の設定中は、次の制約事項に従ってください。

最大 128,000 のキューをサポート。

最大 16,000 のトラフィック シェーパーをサポート。

NP ごとに最大 48,000 のポリサーをサポート。

出力の NP あたり最大 8,000 の H-QoS ポリシーマップおよび入力の NP あたり最大 3904 のポリシーマップをサポート。

階層型 QoS を設定する際は、次の制約事項および使用上のガイドラインに従ってください。

ポートあたり 16 キューまでサポート。

ポート チャネルあたり 16 キューまでサポート。

単一のファブリック接続 ES+ ラインカードはラインカードごとに最大 24000 のポリサーをサポートします。

デュアル ファブリック接続 ES+ ラインカードはラインカードごとに最大 48000 のポリサーをサポートします。

出力の NP あたり最大 8,000 の H-QoS ポリシーマップおよび入力の NP あたり最大 3904 の H-QoS ポリシーマップがサポートされます。

子ポリシーが QoS キューイング機能で適用される場合、キューイング機能を持つ子クラスだけがポートあたりのキュー制約事項として考慮されます。親クラスは考慮されません。

子ポリシーが QoS キューイング機能で適用されない場合、親クラスがポートあたりのキュー制約事項として考慮されます。

ES+ ラインカードは、物理(メイン)インターフェイスおよびサブインターフェイス(論理レイヤ)の親クラスと子クラスの階層レベルをサポートします。

2 レベルのポリシーマップには、メイン インターフェイスに結合している場合は 3 レベルの階層、サブインターフェイスに結合している場合は 4 レベルの階層があります。

表 A-5 に、サポートされる H-QoS 機能を示します。

 

表 A-5 階層型 QoS 機能のサポート

インターフェイスのタイプ
マーキング
ポリシング
シェーピング
帯域幅
プライオリティとプライオリティの割合(%)
プライオリティとポリシング
WRED

レイヤ 3 インターフェイス(ルーテッド ポート)

CoS、precedence/DSCP、EXP

Yes

Yes

Yes

No

Yes

Yes

レイヤ 3 サブインターフェイス

CoS、precedence/DSCP、EXP

Yes

Yes

Yes

No

Yes

Yes

階層型 QoS の例

次の例では、クラスごとに異なる割合の帯域幅を割り当てる子ポリシーを設定します。

Router> enable
Router# configure terminal
Router(config)# policy-map child
Router(config-pmap)# class user-a
Router(config-pmap-c)# bandwidth percent 40
Router(config-pmap-c)# exit
Router(config-pmap)# class user-b
Router(config-pmap-c)# bandwidth percent 60
Router(config-pmap-c)# exit
Router(config-pmap)# exit
 

次の例では、出力サブインターフェイスに親サービス ポリシーを適用します。

Router> enable
Router# configure terminal
Router(config)# interface tengigabitethernet 2/1.1
Router(config-if-srv)# encapsulation dot1q 11
Router(config-if)# service-policy output parent
 

次の例は、メイン インターフェイスに 2 レベル H-QoS ポリシーを設定する方法を示しています。

Router(config)# policy-map child_1
Router(config-pmap)# class prec1
Router(config-pmap-c)# priority level 1
Router(config-pmap-c)# exit
Router(config-pmap)# class prec2
Router(config-pmap-c)# priority level 2
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# police 100000
Router(config-pmap-c)# exit
Router(config)# policy-map HQoS_parent
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# service-policy child_1
 

次の例は、サブインターフェイスに 2 レベル H-QoS ポリシーを設定する方法を示しています。

Router(config)# policy-map child_1
Router(config-pmap)# class cos1
Router(config-pmap-c)# priority level 1
Router(config-pmap-c)# exit
Router(config-pmap)# class cos 2
Router(config-pmap-c)# priority level 2
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# police 100000
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# policy-map HQoS_parent
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 100000000
Router(config-pmap-c)# service-policy child_1
 

次の例では、メイン インターフェイスに入力 2 レベル H-QoS ポリシーを設定します。

Router(config)# policy-map child_1
Router(config-pmap)# class prec123
Router(config-pmap-c)# random-detect precedence based
Router(config-pmap-c)# exit
Router(config-pmap)# class prec456
Router(config-pmap-c)# shape average 10000000
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap)# exit
Router(config)# policy-map HQoS_parent
Router(config-pmap)# class ACL_c1
Router(config-pmap-c)# police 100000
Router(config-pmap-c)# priority level 1
Router(config-pmap-c)# service policy child_1
Router(config-pmap-c)# exit
Router(config-pmap)# class ACL_c2
Router(config-pmap-c)# police 100000
Router(config-pmap-c)# priority level 2
Router(config-pmap-c)# service policy child_2
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# police 100000
Router(config-pmap-c)# service policy child_3
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# policy-map HQos_grandparent
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape 100000000
Router(config-pmap-c)# service-policy HQoS_parent

MPLS トラフィック エンジニアリング Class-Based Tunnel Selection の設定

「MPLS トラフィック エンジニアリングの概要」

「MPLS トラフィック エンジニアリング Class-Based Tunnel Selection の制約事項および使用上のガイドライン」

「同じヘッドエンドおよび同じテールエンドでの複数の MPLS メンバー TE または DS-TE トンネルの作成」

「マスター トンネルの作成、メンバー トンネルの結合、およびマスター トンネルの認識」

「MPLS の設定の確認」

MPLS トラフィック エンジニアリングの概要

マルチプロトコル ラベル スイッチング(MPLS)トラフィック エンジニアリング(TE)を使用すると、同じトンネル ヘッドエンドと同じテールエンド間でさまざまな TE トンネルに、さまざまなサービス クラス(CoS)値を指定してトラフィックを動的にルーティングしたり転送したりできます。TE トンネルは、標準の TE トンネルまたは DiffServ-aware TE(DS-TE)トンネルにできます。

同じヘッドエンドから同じテールエンドの間で、さまざまな CoS 値を伝送するように設定された一連の TE/DS-TE トンネルは、「トンネル バンドル」と呼ばれます。トンネルは、マスター トンネルを作成し、そのマスター トンネルにメンバー トンネルを結合することによって「バンドル(束ねる)」されます。設定後、CBTS は次の要件を満たすトンネルに、各パケットを動的にルーティングして転送します。

パケットの CoS を伝送するように設定されていること。

パケットの宛先に対応する正しいテールエンドがある。

CBTS は DS-TE トンネル経由でダイナミック ルーティングを行い、設定が最小限で済むので、大規模なネットワークにおいて DS-TE の配置が大幅に軽減されます。

CBTS は、8 種類のトンネルですべての CoS 値、または複数のトンネルに複数の CoS 値を配布できます。

CBTS を使用すると、トンネル バンドルである TE トンネルに、さまざまなインターフェイスを通じてヘッドエンド ルータを終了させることもできます。

CBTS 設定には、次の処理の実行が含まれます。

同じヘッドエンドとテールエンドを指定して複数の(DS-)TE トンネルを作成し、各トンネルに対して、そのトンネルで伝送する CoS を指示します。

マスター トンネルを作成してメンバー トンネルを結合し、ルーティング時にマスター トンネルが認識されるようにします。

MPLS トラフィック エンジニアリング Class-Based Tunnel Selection の制約事項および使用上のガイドライン

MPLS トラフィック エンジニアリング Class-Based Tunnel Selection(CBTS)を設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

CBTS には、次の前提条件があります。

すべてのトンネル インターフェイスで MPLS がイネーブルになっている必要があります。

汎用コンフィギュレーション モードでシスコ エクスプレス フォワーディング(CEF)または分散 CEF(dCEF)をイネーブルにする必要があります。

CBTS には次の制限事項があります。

特定の宛先に対するすべての CoS 値は、同じテールエンドが終端となるトンネルで伝送されます。すべての CoS 値がトンネルで伝送されるか、またはトンネルでまったく値が伝送されないかのいずれかです。したがって、1 つの宛先について、一部の CoS 値を DS-TE トンネルでマッピングし、その他の CoS 値を最短パス優先(SPF)ラベル配布プロトコル(LDP)または SPF IP パスでマッピングすることはできません。

マスター トンネルにラベル スイッチ パス(LSP)は設定されません。標準のトラフィック エンジニアリング属性(帯域幅、パス オプション、高速再ルーティング)は、マスター トンネルには関連しません。TE 属性(帯域幅、帯域幅プール、プリエンプション、プライオリティ、パス オプションなど)は、トンネルごとに完全に独立して設定されます。

CBTS では、複数のトンネルで特定の EXP 値のロードバランシングを図ることはできません。特定の experimental(EXP)値を伝送するように 2 つ以上のトンネルが設定されている場合、CBTS はその中から 1 つのトンネルを選択してこの EXP 値を伝送します。EXP 値は定義済みルールによって計算されます。

CBTS は、バンピングの集約制御をサポートします。したがって、他のトンネルがダウンした場合に使用する、デフォルトのトンネルを定義できます。ただし、デフォルトのトンネルがダウンした場合、CBTS ではバンピングを制御できません。CBTS はさらに細かいバンピング制御はサポートしません。たとえば、音声トンネルがダウンした場合、音声は T2 にリダイレクトされますが、ビデオ トンネルがダウンした場合は、T3 にリダイレクトされます。

Any Transport over MPLS(AToM)、MPLS TE Automesh、または Label-Controlled(LC)ATM では、CBTS の動作はサポートされません。

同じヘッドエンドおよび同じテールエンドでの複数の MPLS メンバー TE または DS-TE トンネルの作成

同じヘッドエンドおよび同じテールエンドで複数の MPLS メンバー TE または DS-TE トンネルを作成し、各トンネルで伝送する EXP 値を設定するには、次の作業を行います。この作業は、グローバル コンフィギュレーション モードから始めます。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface tunnel number

トンネル インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

number :作成または設定するトンネル インターフェイスの番号。

ステップ 4

Router(config-if)# ip unnumbered type number

明示的な IP アドレスをインターフェイスに割り当てずにインターフェイス上の IP 処理をイネーブルにします。

type :ルータに IP アドレスが割り当てられている別のインターフェイスのタイプ。

number :ルータに IP アドレスが割り当てられている別のインターフェイスの番号。番号付けされていない別のインターフェイスは指定できません。

ステップ 5

Router(config-if)# tunnel destination { hostname | ip-address }

このパス オプションのトンネルの宛先を指定します。

hostname :宛先ホストの名前。

ip-address :宛先ホストの IP アドレス(4 つの部分からなるドット付き 10 進表記)。

ステップ 6

Router(config-if)# tunnel mode mpls traffic-eng

トンネルのモードを、TE 用の MPLS に設定します。

ステップ 7

Router(config-if)# tunnel mpls traffic-eng bandwidth [ sub-pool | global ] bandwidth

MPLS TE トンネルの帯域幅を設定します。トンネルに自動帯域幅を設定する場合は、 tunnel mpls traffic-eng bandwidth コマンドを使用して、初期トンネル帯域幅を設定します。これは、自動帯域幅メカニズムによって調整されます。

sub-pool :(任意)サブプール トンネルを指定します。

global :(任意)グローバル プール トンネルを指定します。このキーワードの入力は必須ではありません。 sub-pool キーワードが指定されていない場合、すべてのトンネルはグローバル プールになります。ただし、DiffServ-aware トラフィック エンジニアリング(DS-TE)以前のイメージを使用しているユーザがこのキーワードを入力した場合は、受け入れられます。

bandwidth :MPLS トラフィック エンジニアリング トンネル用に取り置く帯域(キロビット/秒)。範囲は 1 ~ 4294967295 です。

コマンドを設定できます。

ステップ 8

Router(config-if)# tunnel mpls traffic-eng exp [ list-of-exp-values ] [ default ]

MPLS TE トンネル用の EXP 値を 1 つまたは複数指定します。

list-of-exp-values :指定したトンネルに伝送させる EXP 値(1 つまたは複数)。有効範囲は 0 ~ 7 です。

default :指定したトンネルに、次の条件に該当するすべての EXP 値を伝送させます。

別のトンネルに明示的に割り当てられていない

現在ダウンしているトンネルに 割り当てられている

ステップ 9

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

同じヘッドエンド ルータで繰り返し、このヘッドエンドから同じテールエンドへのその他のトンネルを作成します。

マスター トンネルの作成、メンバー トンネルの結合、およびマスター トンネルの認識

マスター トンネルを作成してメンバー トンネルを結合し、ルーティング時にマスター トンネルが認識されるようにするには、次の作業を行います。この作業は、グローバル コンフィギュレーション モードから始めます。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface tunnel number

トンネル インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。 number は、作成または設定するトンネル インターフェイスの番号です。

ステップ 4

Router(config-if)# ip unnumbered type number

明示的な IP アドレスをインターフェイスに割り当てずにインターフェイス上の IP 処理をイネーブルにします。

type :ルータに IP アドレスが割り当てられている別のインターフェイスのタイプ。

number :ルータに IP アドレスが割り当てられている別のインターフェイスの番号。番号付けされていない別のインターフェイスは指定できません。

ステップ 5

Router(config-if)# tunnel destination { hostname | ip-address }

このパス オプションのトンネルの宛先を指定します。

hostname :宛先ホストの名前。

ip-address :宛先ホストの IP アドレス(4 つの部分からなるドット付き 10 進表記)。

ステップ 6

Router(config-if)# tunnel mode mpls traffic-eng exp-bundle master

これが CBTS 設定に対応するマスター トンネルであることを指定します。

ステップ 7

Router(config-if)# tunnel mode mpls traffic-eng exp-bundle member tunnel-id

マスター トンネルにメンバー トンネルを結合します。

tunnel-id :マスター トンネルに結合するトンネル インターフェイスの番号。

メンバー トンネルごとにこのコマンドを繰り返します。

ステップ 8

Router(config-if)# tunnel mpls traffic-eng autoroute announce

Interior Gateway Protocol(IGP)で、拡張最短パス優先(SPF)の計算に(トンネルがアップの場合)トンネルを使用することを指定します。

ステップ 9

Router(config-if)# tunnel mpls traffic-eng autoroute metric { absolute | relative } value

(任意)IGP 拡張 SPF 計算で使用する MPLS TE トンネル メトリックを指定します。

absolute :絶対メトリック モード。正のメトリック値を入力できます。

relative :相対メトリック モード。正、負、またはゼロの値を入力できます。

value :IGP 拡張 SPF 計算で使用するメトリック。相対値は -10 ~ 10 です。

(注) 相対メトリック値は -10 ~ +10 ですが、負の値を指定してトンネル メトリックを設定すると、誤設定と見なされます。トンネルのテールエンドへのメトリックが 4 であるとルーティング テーブルから判断される場合、ループバック アドレスに到達するためのコストとして 1 が追加されているため、トンネルのテールエンド ルータへの実際のコストは 3 です。この場合、相対メトリックとして設定できる最小値は -3 です。


) TE トンネルまたは DS-TE トンネルがルーティングで認識されるようにするために、自動ルートの代わりにスタティック ルーティングを使用することもできます。


マルチプロトコル ラベル スイッチング(MPLS)トラフィック エンジニアリング(TE)Class-Based Tunnel Selection(CBTS)の設定例を示します。Tunnel1、Tunnel2、および Tunnel3 はメンバー トンネル、Tunnel4 はマスター トンネルです。

Router> enable
Router# configure terminal
Router(config)# interface tunnel1
Router(config-if)# ip unnumbered loopback0
Router(config-if)# tunnel destination 24.1.1.1
Router(config-if)# tunnel mode mpls traffic-eng
Router(config-if)# tunnel mpls traffic-eng bandwidth sub-pool 30000
Router(config-if)# tunnel mpls traffic-eng exp 5
Router(config-if)# exit
 
Router(config)# interface tunnel2
Router(config-if)# ip unnumbered loopback0
Router(config-if)# tunnel destination 24.1.1.1
Router(config-if)# tunnel mode mpls traffic-eng
Router(config-if)# tunnel mpls traffic-eng bandwidth 50000
Router(config-if)# tunnel mpls traffic-eng exp 3 4
Router(config-if)# exit
 
Router(config)# interface tunnel3
Router(config-if)# ip unnumbered loopback0
Router(config-if)# tunnel destination 24.1.1.1
Router(config-if)# tunnel mode mpls traffic-eng
Router(config-if)# tunnel mpls traffic-eng bandwidth 10000
Router(config-if)# tunnel mpls traffic-eng exp default
Router(config-if)# exit
 
Router(config)# interface tunnel4
Router(config-if)# ip unnumbered loopback0
Router(config-if)# tunnel destination 24.1.1.1
Router(config-if)# tunnel mode mpls traffic-eng
Router(config-if)# tunnel mpls traffic-eng exp-bundle master
Router(config-if)# tunnel mpls traffic-eng exp-bundle member tunnel1
Router(config-if)# tunnel mpls traffic-eng exp-bundle member tunnel2
Router(config-if)# tunnel mpls traffic-eng exp-bundle member tunnel3
Router(config-if)# tunnel mpls traffic-eng autoroute announce

MPLS の設定の確認

次の show コマンドを使用すると、MPLS TE または DS-TE トンネルが動作しており、かつ IGP にアナウンスされているかどうかを確認できます。いずれのコマンドも、特権 EXEC コンフィギュレーション モードで入力します。

 

コマンド
目的

show mpls traffic-eng topology { A . B .C. D | igp-id { isis nsap-address | ospf A . B .C. D } [ brief ]}

このノードで現在認識されている、MPLS トラフィック エンジニアリング グローバル トポロジが表示されます。

A . B . C . D :IP アドレス(インターフェイス アドレスに対するルータ識別子)でノードを指定します。

igp-id :IGP ルータ識別子でノードを指定します。

isis nsap-address :Integrated Intermediate System-to-Intermediate System(IS-IS)を使用している場合、ルータ識別情報(nsap-address)でノードを指定します。

ospf A . B . C . D :Open Shortest Path First(OSPF)を使用している場合、ルータ識別子でノードを指定します。

brief :トポロジの概略を示します。

show mpls traffic-eng exp

EXP マッピングを表示します。

show ip cef [ type number ] [ detail ]

転送情報ベース(FIB)内のエントリを表示するか、または FIB の概要を表示します。

type number :FIB エントリの表示対象となるインターフェイスのタイプおよび番号を指定します。

detail :詳細な FIB エントリ情報を表示します。

show mpls forwarding-table [ network { mask | length } [ detail ]]

MPLS ラベル転送情報ベース(LFIB)の内容を表示します。

network :宛先ネットワーク番号を指定します。

mask :指定のネットワークで使用するネットワーク マスクを指定します。

length :宛先マスクのビット数を指定します。

detail :ロング形式で情報を表示します。カプセル化長、MAC ストリング長、最大伝送単位(MTU)、およびすべてのラベルが含まれます。

show mpls traffic-eng autoroute

内部ゲートウェイ プロトコル(IGP)にアナウンスされているトンネルを表示します。

show mpls traffic-eng topology コマンドの出力で、MPLS TE グローバル トポロジを表示します。

Router# show mpls traffic-eng topology 10.0.0.1
 
IGP Id: 10.0.0.1, MPLS TE Id:10.0.0.1 Router Node (ospf 10 area 0) id 1
link[0]: Broadcast, DR: 180.0.1.2, nbr_node_id:6, gen:18
frag_id 0, Intf Address:180.0.1.1
TE metric:1, IGP metric:1, attribute_flags:0x0
SRLGs: None
physical_bw: 100000 (kbps), max_reservable_bw_global: 1000 (kbps)
max_reservable_bw_sub: 0 (kbps)
Global Pool Sub Pool
Total Allocated Reservable Reservable
BW (kbps) BW (kbps) BW (kbps)
--------------- ----------- ----------
bw[0]: 0 1000 0
bw[1]: 0 1000 0
bw[2]: 0 1000 0
bw[3]: 0 1000 0
bw[4]: 0 1000 0
bw[5]: 0 1000 0
bw[6]: 0 1000 0
bw[7]: 100 900 0
 
link[1]: Broadcast, DR: 180.0.2.2, nbr_node_id:7, gen:19
frag_id 1, Intf Address:180.0.2.1
TE metric:1, IGP metric:1, attribute_flags:0x0
SRLGs: None
physical_bw: 100000 (kbps), max_reservable_bw_global: 1000 (kbps)
max_reservable_bw_sub: 0 (kbps)
Global Pool Sub Pool
Total Allocated Reservable Reservable
BW (kbps) BW (kbps) BW (kbps)
--------------- ----------- ----------
bw[0]: 0 1000 0
bw[1]: 0 1000 0
bw[2]: 0 1000 0
bw[3]: 0 1000 0
bw[4]: 0 1000 0
bw[5]: 0 1000 0
bw[6]: 0 1000 0
bw[7]: 0 1000 0
 

show mpls traffic-eng exp コマンドの出力で、トンネルの EXP マッピング情報を表示します。

Router# show mpls traffic-eng exp
 
Destination: 10.0.0.9
Master: Tunnel10 Status: IP
 
Members: Status Conf EXP Actual EXP
Tunnel1 UP/ACTIVE 5 5
Tunnel2 UP/ACTIVE default 0 1 2 3 4 6 7
Tunnel3 UP/INACTIVE(T) 2
Tunnel4 DOWN 3
Tunnel5 UP/ACTIVE(NE)
 
(T)=Tailend is different to master
(NE)=There is no exp value configured on this tunnel.
 

show ip cef detail コマンドの出力で、トンネルの詳細な FIB エントリ情報を表示します。

Router# show ip cef tunnel1 detail
 
IP CEF with switching (Table Version 46), flags=0x0
31 routes, 0 reresolve, 0 unresolved (0 old, 0 new), peak 2
2 instant recursive resolutions, 0 used background process
8 load sharing elements, 8 references
6 in-place/0 aborted modifications
34696 bytes allocated to the FIB table data structures
universal per-destination load sharing algorithm, id 9EDD49E1
1(0) CEF resets
Resolution Timer: Exponential (currently 1s, peak 1s)
Tree summary:
8-8-8-8 stride pattern
short mask protection disabled
31 leaves, 23 nodes using 26428 bytes
Table epoch: 0 (31 entries at this epoch)
Adjacency Table has 13 adjacencies
10.0.0.9/32, version 45, epoch 0, per-destination sharing
0 packets, 0 bytes
tag information set, all rewrites inherited
local tag: tunnel head
via 0.0.0.0, Tunnel1, 0 dependencies
traffic share 1
next hop 0.0.0.0, Tunnel1
valid adjacency
tag rewrite with Tu1, point2point, tags imposed {12304}
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
internal 0 packets, 0 bytes
 

show mpls forwarding-table detail コマンドの出力で、MPLS LFIB からの詳細情報を表示します。

Router# show mpls forwarding 10.0.0.9 detail
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
Tun hd Untagged 10.0.0.9/32 0 Tu1 point2point
MAC/Encaps=14/18, MRU=1500, Tag Stack{12304}, via Fa6/0
00027D884000000ED70178A88847 03010000
No output feature configured
Per-exp selection: 1
Untagged 10.0.0.9/32 0 Tu2 point2point
MAC/Encaps=14/18, MRU=1500, Tag Stack{12305}, via Fa6/1
00027D884001000ED70178A98847 03011000
No output feature configured
Per-exp selection: 2 3
Untagged 10.0.0.9/32 0 Tu3 point2point
MAC/Encaps=14/18, MRU=1500, Tag Stack{12306}, via Fa6/1
00027D884001000ED70178A98847 03012000
No output feature configured
Per-exp selection: 4 5
Untagged 10.0.0.9/32 0 Tu4 point2point
MAC/Encaps=14/18, MRU=1500, Tag Stack{12307}, via Fa6/1
00027D884001000ED70178A98847 03013000
No output feature configured
Per-exp selection: 0 6 7
 

show mpls traffic-eng autoroute コマンドの出力で、内部ゲートウェイ プロトコル(IGP)にアナウンスされているトンネルを表示します。

Router# show mpls traffic-eng autoroute
 
MPLS TE autorouting enabled
destination 10.0.0.9, area ospf 10 area 0, has 4 tunnels
Tunnel1 (load balancing metric 20000000, nexthop 10.0.0.9)
(flags: Announce)
Tunnel2 (load balancing metric 20000000, nexthop 10.0.0.9)
(flags: Announce)
Tunnel3 (load balancing metric 20000000, nexthop 10.0.0.9)
(flags: Announce)
Tunnel4 (load balancing metric 20000000, nexthop 10.0.0.9)
(flags: Announce)

IPoDWDM の設定

「IPoDWDM-Capable ES+ ラインカード」

「ES+ ラインカードの WAN PHY および OTN サポート」

IPoDWDM-Capable ES+ ラインカード

高密度波長分割多重(IPoDWDM)は次の ES+ ラインカードでサポートされます。

76-ES+XT-2TG3CXL

76-ES+XT-4TG3CXL

WAN、PHY、および OTN の概要

ES+ ラインカードのポートは、光転送ネットワーク(OTN)およびワイドエリア ネットワーク(WAN)PHY をサポートします。

この機能は、ES+ ラインカードの OTN および WAN PHY をサポートするソフトウェア機能を提供します。

WAN PHY は、10 GB SONET インフラストラクチャを使用し、次の方法で WAN のファシリティにアクセスします。

ダーク ファイバ

ダーク波長

SONET TDM ネットワーク

この機能が光増幅器を必要としないストア アンド フォワード ネットワーク設計を実装する短距離ネットワークに必要な低コストの光ソリューションを提供します。

OTN は ITU が開発した光転送階層(OTH)に基づきます。OTN は ITU G.872「Architecture for the Optical Transport Network (OTN)」で定義されたネットワーク アーキテクチャに基づきます。G.872 標準は、光チャネル(OCh)、光多重化セクション(OMS)、および光伝送セクション(OTS)で構成されるアーキテクチャを定義します。光チャネルのデジタル オーバーヘッドを含むデジタル フレーム信号の使用により、OCh の管理要件を実装できます。また、前方誤り訂正(FEC)システムの使用により、システム パフォーマンスを向上できます。この機能を実装するために導入された 2 種類の新しいデジタル レイヤ ネットワークは ODU および OTU です。

OTN アーキテクチャ(ITU-T G.872 標準)は、2 つのインターフェイス クラスを定義しています。

ドメイン間インターフェイス(IrDI):OTN IrDI インターフェイス クラスはオペレータ インターフェイスの両側のインターフェイス(3R(再増幅、再シェーピング、再タイミング)処理付き)を定義します。オペレータ インターフェイスも同じオペレータ内の異なるベンダー間のインターフェイスにできます。

ドメイン内インターフェイス(IaDI):IaDI インターフェイス クラスは、オペレータまたはベンダー ドメイン内のインターフェイスを定義します。

OTN には次の利点があります。

より強力な前方誤り訂正

より多くのレベルのタンデム接続モニタリング(TCM)

クライアント信号の透過転送

スイッチングの拡張性

制約事項および使用上の注意事項

ES+ ラインカードの WAN PHY/OTN サポートを設定する場合は、次の制約事項および使用上のガイドラインに従ってください。

WAN PHY および DWDM ファシリティを使用する 2 台のスイッチング装置間の距離が使用される XFP によって異なります。関連する XFP のデータ シートを参照してください。

MAC アドレスは WAN PHY および LAN PHY で共通です。WAN PHY は OC-192c/VC 464c のペイロード レートと互換性のある速度で動作します。

ITU-T G.709 転送モードの設定

インターフェイス コンフィギュレーション モードで transport-mode コマンドを使用して、LAN、WAN、OTN の転送モードを設定します。 transport-mode コマンドの otn オプションには bit-transparent サブオプションがあり、これを使用して OPU1e または OPU2e にビット透過マッピングを設定できます。


) Cisco INTEL OC192 + 10GBASE-L XFP のハードウェアの組み合わせは、次の転送モード設定では INTEL XFP および OTN 間でビット レートの互換性がないためサポートされません。

opu1e:固定スタッフィングのない OPU1e 上の 10GBASE-R(11.0491Gb/s)

opu2e:固定スタッフィングのある OPU2e 上の 10GBASE-R(11.0957Gb/s)


 

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface tengigabitethernet slot / port

設定する 10 ギガビット イーサネット インターフェイスを指定します。

ステップ 4

Router(config-if)# transport-mode { lan | wan | otn bit-transparent { opu1e | opu2e }}

トランスペアレント モードを設定します。

DWDM プロビジョニング

すべての DWDM プロビジョニングの設定はコントローラで行われます。DWDM コントローラを設定するには、グローバル コンフィギュレーション モードで controller dwdm コマンドを使用します。

コントローラがシャットダウン状態の場合にだけ g709 コンフィギュレーション コマンドを使用できます。パラメータを設定したあとで no shutdown コマンドを使用して、コントローラのシャットダウン ステートを解除し、コントローラをアップ ステートに移行できるようにします。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# controller dwdm slot / port

DWDM コントローラを設定します。

IP over DWDM コマンドの例は次のとおりです。

Router# show run int tengigabitethernet 2/3
Building configuration...
 
Current configuration : 96 bytes
!
interface TenGigabitEthernet2/3
ip address 11.11.11.2 255.255.255.0
transport-mode otn bit-transparent opu2e
end
 
Router# show controller dwdm 2/3
G709 Information:
 
Controller dwdm 3/1, is down (shutdown)
 
Transport mode LAN (10GBASE-R, 10.3125Gb/s)
 
TAS state is : OOS
Description: connected to a ginsu LC
G709 status : Disabled
 
OTU
LOS = 18 LOF = 0 LOM = 0
AIS = 0 BDI = 1 BIP = 14504
TIM = 0 IAE = 0 BEI = 2289
 
ODU
AIS = 0 BDI = 0 TIM = 0
OCI = 0 LCK = 0 PTIM = 0
BIP = 14500 BEI = 2266
 
FEC Mode: FEC
EC(current second) = 0
EC = 31361 UC = 56318597
 
 
pre-FEC BER < 9.00E-11
Q > 6.45 Q Margin > 7.52 DBQ
Detected Alarms: NONE
Asserted Alarms: NONE
Detected Alerts: NONE
Asserted Alerts: NONE
Alarm reporting enabled for: LOS LOF LOM OTU-AIS OTU-IAE OTU-BDI OTU-TIM ODU-AIS ODU-OCI ODU-LCK ODU-BDI ODU-PTIM ODU-TIM ODU-BIP Alert reporting enabled for: OTU-SM-TCA ODU-SD-BER ODU-SF-BER ODU-PM-TCA BER thresholds: ODU-SF = 10e-3 ODU-SD = 10e-6 TCA thresholds: SM = 10e-3 PM = 10e-3
 
OTU TTI Sent String ASCII: This_is_a_static_string
OTU TTI Received String ASCII:
OTU TTI Received String HEX : 0000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000
000000000000000000000000000000 OTU TTI Expected String ASCII: This_is_a_static_string
 
ODU TTI Sent String ASCII: This_is_a_static_string
ODU TTI Received String ASCII:
ODU TTI Received String HEX : 0000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000
000000000000000000000000000000 ODU TTI Expected String ASCII: This_is_a_static_string
 
Optics Information:
 
optics type: DWDM XFP Tunable
Wavelength: C-band, channel 10, 1558.17 nm, 192.40 THz Transceiver Rx optical power = -40.0 dBm
Transceiver Tx power = 1.5 dBm
TX Laser current bias = 20988 uAmps
 
Virtual Link Info:
 
Adjacency info: This_is_a_static_string
 
 
C7600 Node ID :
 
0 :26:B :28:68:80
 
 
Connectivity Info:
 
Network Connection ID : This_is_a_static_string
 
 
Network SRLG values:
 
 
Set 1: 6142 19113 14477 26689 4989 31230
Set 2: 14967 7234 29164 19852 15452 17460
Set 3: 14852 28561 6364 12832 21486 14312
Set 4: 30337 19184 28532 15403 21048 27105
Set 5: 18102 24607 16426 14253 21500 21952
Set 6: 13523 17545 7863 538 5251 18205
Set 7: 22331 27781 17862 26935 10028 16539
Set 8: 865 29015 7144 20299 27504 2190
Set 9: 13470 7222 8500 6988 18852 20882
Set 10: 21512 702 14117 1870 19304 13075
Set 11: 11919 26281 1898 18454 9948 15302
Set 12: 24263 24747 5275 29138 17325 19226
Set 13: 10917 18739 16263 20739 13147 18471
Set 14: 1126 24967 26662 16266 32124 32739
Set 15: 20342 29828 7591 18968 2421 24934
Set 16: 3366 27109 22805 3591 7227 9339
 
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int tengigabitethernet 2/3
Router(config-if)# transport-mode ?
lan 10GBASE-R LAN pass-through (10.3125Gb/s)
otn 10GE over Optical Transport Network (G.709)
wan 10GBASE-W WAN SONET/SDH (9.95328Gb/s)
 
Router(config-if)# transport-mode otn ?
bit-transparent 10GBASE-R transparently mapped into OTU-2
 
Router(config-if)# transport-mode otn bit-transparent ?
opu1e 10GBASE-R over OPU1e without fixed stuffing (11.0491Gb/s)
opu2e 10GBASE-R over OPU2e with fixed stuffing (11.0957Gb/s)
 
 
Router(config-if)# transport-mode otn bit-transparent opu2e
Router(config-if)# end
Router# show int tengigabitethernet2/3
TenGigabitEthernet2/3 is up, line protocol is up (connected)
Hardware is X40G 10Gb 802.3, address is 00d0.03e2.1c00 (bia 00d0.03e2.1c00)
Internet address is 11.11.11.1/24
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 10Gb/s, clock source internal
Transport mode OTN (10GBASE-R over OPU2e with fixed stuffing, 11.0957Gb/s)
input flow-control is off, output flow-control is off
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:03, output 00:00:03, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
L2 Switched: ucast: 0 pkt, 0 bytes - mcast: 2360 pkt, 221372 bytes
L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast
L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes
2392 packets input, 223718 bytes, 0 no buffer
Received 2477 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
2477 packets output, 229905 bytes, 0 underruns
0 output errors, 0 collisions, 13 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
 
Router#
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# controller dwdm 2/3
Router(config-controller)# ?
Controller configuration commands:
default Set a command to its defaults
description Controller specific description
exit Exit from controller configuration mode
g709 Configure G709 parameters
help Description of the interactive help system
no Negate a command or set its defaults
shutdown Configure dwdm controller processing
 
Router(config-controller)# g709 ?
fec Configure FEC mode
odu Configure odu parameters
otu Configure otu parameters
tti-processing Configure Trail Trace Identifier processing
 
Router(config-controller)# g709 fec ?
disable Disable FEC
enhanced Enhanced FEC mode
standard Standard FEC mode
 
Router(config-controller)# g709 odu ?
overhead Configure ODU overhead
report Configure odu alarm reporting
threshold Configure odu threshold
Router(config-controller)#g709 odu overhead ?
tti Configure ODU Trail Trace Identifier buffer
 
Router(config-controller)#g709 odu overhead tti ?
expected Set expected TTI
sent Set transmit TTI
 
Router(config-controller)#g709 odu overhead tti expected ?
ascii Enter ASCII string
hex Enter hex string- Length should be even number
 
Router(config-controller)#g709 odu overhead tti expected ascii ?
WORD LINE ASCII text (Max 64 characters)
 
Router(config-controller)#g709 odu overhead tti expected hex ?
Hex-data LINE Hex nibbles (Max 128- The string length should
be an even number)
Router(config-controller)#g709 odu overhead tti sent ?
ascii Enter ASCII string
hex Enter hex string- Length should be even number
 
Router(config-controller)#g709 odu overhead tti sent ascii ?
WORD LINE ASCII text (Max 64 characters)
 
Router(config-controller)#g709 odu overhead tti sent hex ?
Hex-data LINE Hex nibbles (Max 128- The string length should
be an even number)
Router(config-controller)# g709 odu report ?
ais Set Alarm Indication Signal reporting status
bdi Set Backward Defect Indication reporting status
lck Set Upstream Connection Locked reporting status
oci Set Open Connection Indication reporting status
pm-tca Set Path Monitoring BER TCA reporting status
ptim Set Payload Type Identifier Mismatch reporting status
sd-ber Set SM BER in excess of SD threshold reporting status
sf-ber Set SM BER in excess of SF threshold reporting status
tim Set Trace Identifier Mismatch reporting status
 
Router(config-controller)# g709 odu threshold ?
pm-tca Set Path Monitoring Threshold Crossing Alert threshold
sd-ber Set Signal Degrade BER threshold
sf-ber Set Signal Failure BER threshold
 
Router(config-controller)# g709 odu threshold pm-tca ?
<3-9> Bit Error Rate (10 to the minus n) (default 3)
<cr>
 
Router(config-controller)# g709 odu threshold sd-ber ?
<3-9> Bit Error Rate (10 to the minus n) (default 6)
<cr>
 
Router(config-controller)# g709 odu threshold sf-ber ?
<3-9> Bit Error Rate (10 to the minus n) (default 3)
<cr>
Router(config-controller)# g709 otu ?
overhead Configure OTU overhead
report Configure otu alarm reporting
threshold Configure otu threshold
 
Router(config-controller)#g709 otu overhead ?
tti Configure OTU Trail Trace Identifier buffer
 
Router(config-controller)#g709 otu overhead tti ?
expected Set expected TTI
sent Set transmit TTI
 
Router(config-controller)#g709 otu overhead tti expected ?
ascii Enter ASCII string
hex Enter hex string- Length should be even number
 
Router(config-controller)#g709 otu overhead tti expected ascii ?
WORD LINE ASCII text (Max 64 characters)
 
Router(config-controller)#g709 otu overhead tti expected hex ?
Hex-data LINE Hex nibbles (Max 128- The string length should be an
even number)
 
Router(config-controller)#g709 otu overhead tti sent ?
ascii Enter ASCII string
hex Enter hex string- Length should be even number
 
Router(config-controller)#g709 otu overhead tti sent ascii ?
WORD LINE ASCII text (Max 64 characters)
 
Router(config-controller)#g709 otu overhead tti sent hex ?
Hex-data LINE Hex nibbles (Max 128- The string length should be an
even number)
 
Router(config-controller)# g709 otu report ?
ais Set Alarm Indication Signal reporting status
bdi Set Backward Defect Indication reporting status
iae Set Incoming Alignment Error reporting status
lof Set OTU Loss of Frame reporting status
lom Set Loss of Multiple Frame reporting status
los Set Loss of Signal reporting status
sm-tca Set Section Monitoring BER TCA reporting status
tim Set Trace Identifier Mismatch reporting status
 
Router(config-controller)# g709 otu threshold ?
sm-tca Set Section Monitoring Threshold Crossing Alert threshold
 
Router(config-controller)# g709 otu threshold sm-tca ?
<3-9> Bit Error Rate (10 to the minus n) (default 3)
<cr>

OTN モードのアラーム アサーションの有効化

デフォルトでは、すべての OTN モードのアラームはイネーブルです。OTN アラームを制御するには、すべてのアラームをディセーブルにし、次の手順を実行して、特定のアラームをイネーブルにします。標準 FEC がデフォルト FEC モードです。アラームのステータスおよび FEC モードを確認するには、 show controller コマンドを使用します。OTN モードのアラーム アサーションをイネーブルにするには、この項で詳述されている手順を実行します。両方のルータで同じ転送モードまたは FEC モードを設定します。FEC モードの standard と disable は相互に互換性があります。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# controller dwdm slot / port

DWDM コントローラを設定します。

ステップ 4

Router(config-controller)# shutdown

DWDM コントローラをシャットダウンします。

ステップ 5

Router(config-controller)# { g709 | no g709 } fec { disable | standard | enhanced }

FEC モードを設定します。

ステップ 6

Router(config-controller)# { g709 | no g709 } otu report { ais | bdi | iae | lof | los | sm-tca | tim }

サポートされる otu アラームを指定し、otu しきい値を設定します。デフォルトでは、すべてのアラームが報告されます。

ステップ 7

Router(config-controller)# { g709 | no g709 } odu report { ais | bdi | lck | oci | pm-tca | ptim | sd-ber | sf-ber | tim }

サポートされる odu アラームを指定し、odu しきい値を設定します。デフォルトでは、すべてのアラームが報告されます。

ステップ 8

Router(config-controller)# { g709 | no g709 } otu threshold sm-tca val

信号劣化または信号障害アラートをモニタするセクションを検出するしきい値を設定します。

ステップ 9

Router(config-controller)# { g709 | no g709 } odu threshold { pm-tca | sd-ber | sf-ber } t_value

ber しきい値制限を 10 の t_value 乗に設定します。

ステップ 10

Router(config-controller)# { g709 | no g709 } otu overhead tti { expected | sent } { ascii | hex } tti-string

otu レベルのトレール トレース識別名を指定します。

ステップ 11

Router(config-controller)# { g709 | no g709 } odu overhead tti { expected | sent } { ascii | hex } tti-string

odu レベルのトレール トレース識別名を指定します。

ステップ 12

Router(config-controller)# no shutdown

コントローラを no shutdown モードに設定します。

ステップ 13

Router(config-controller)# end

セッションを終了します。


) FEC モードを EFEC に変更する前に shutdown コマンドを使用してインターフェイスをシャットダウンする必要があります。


Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# controller dwdm 4/21
Router(config-controller)# shutdown
Router(config-controller)# g709 fec enhanced
Router(config-controller)# g709 otu report los
Router(config-controller)# no g709 otu report lof
Router(config-controller)# no g709 otu threshold sm-tca
Router(config-controller)# g709 odu threshold sd-ber 3
Router(config-controller)# no shutdown
Router(config-controller)# end
 

アラーム アサーションの設定を確認するには、 show controllers コマンドを使用します。

Router# show controllers dwdm 4/21
Controller dwdm 4/2, is up (no shutdown)
 
TAS state is : IS
G709 status : Enabled
 
OTU
LOS = 1 LOF = 0 LOM = 0
AIS = 0 BDI = 1 BIP = 0
TIM = 0 IAE = 0 BEI = 0
 
ODU
AIS = 0 BDI = 0 TIM = 0
OCI = 0 LCK = 0 PTIM = 0
BIP = 0 BEI = 0
 
FEC Mode: FEC
EC(current second) = 0
EC = 0 UC = 0
pre-FEC BER < 9.00E-11
Q > 6.45 Q Margin > 7.52 DBQ
Detected Alarms: NONE
Asserted Alarms: NONE
Detected Alerts: NONE
Asserted Alerts: NONE
Alarm reporting enabled for: LOS LOF LOM OTU-AIS OTU-IAE OTU-BDI ODU-AIS ODU-OCI ODU-LCK ODU-BDI ODU-PTIM ODU-BIP Alert reporting enabled for: OTU-SM-TCA ODU-SD-BER ODU-SF-BER ODU-PM-TCA BER thresholds: ODU-SF = 10e-3 ODU-SD = 10e-6 TCA thresholds: SM = 10e-3 PM = 10e-3
 
OTU TTI Sent String ASCII: Tx TTI Not Configured
OTU TTI Received String ASCII:
OTU TTI Received String HEX : 0000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000
000000000000000000000000000000O OTU TTI Expected String ASCII: Exp TTI Not Configured
 
ODU TTI Sent String ASCII: Tx TTI Not Configured
ODU TTI Received String ASCII:
ODU TTI Received String HEX : 0000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000
000000000000000000000000000000 ODU TTI Expected String ASCII: Exp TTI Not Configured

Field-Programmable Device のアップグレード

Field-Programmable Device(FPD)は個別のアップグレードをサポートしています。この章は、次の内容で構成されています。

「FPD イメージおよびパッケージの概要」

「FPD クイック アップグレード」

「FPD イメージのアップグレード」

「FPD 関連の省略可能な手順」

「FPD イメージ アップグレードの例」

FPD イメージおよびパッケージの概要

FPD イメージ パッケージを使用すると、FPD イメージをアップグレードできます。ES+ ラインカードをサポートする Cisco IOS イメージがリリースされると、その Cisco IOS ソフトウェア リリースに付属する FPD イメージ パッケージもリリースされます。FPD イメージ パッケージは Cisco.com から入手でき、Cisco Software Center ページからアクセスできます。ここでは、Cisco IOS ソフトウェア イメージもダウンロードできます。

ES+ ラインカードでは、Cisco IOS イメージをアップグレードする場合、新しい Cisco IOS Release を使用してルータを起動する前に、FPD イメージ パッケージ ファイルをダウンロードする必要があります。ES+ ラインカードで FPD のアップグレードを必要としているのに、Cisco IOS イメージが FPD イメージ パッケージを検出できない場合、FPD イメージが不適合であることを示すシステム メッセージが表示されます。この場合、Cisco.com の Cisco Software Center にアクセスして、使用する Cisco IOS ソフトウェア リリースに対応した FPD イメージ パッケージをダウンロードする必要があります。ES+ ラインカードの FPD が不適合である場合、適合するまで、ES+ ラインカードのすべてのインターフェイスがディセーブルになります。

ES+ ラインカードでは、次の FPD アップグレード可能なコンポーネントがあります。

ベース ボード

ROMMON

I/O Field-Programmable Gate Array(FPGA)

Selene FPGA

リンク FPGA 付きリンク ドーター カード

DFC

パケット エンジン FPGA

K'(k プライム)FPGA


) FPD 自動アップグレード機能が検索するのは、使用されている Cisco IOS Release とバージョン番号が同じ FPD イメージ パッケージ ファイルだけです。システム上の FPD イメージ パッケージ ファイルが Cisco IOS Release に適合するようにし、FPD イメージ パッケージ ファイルの名前は変更しないでください。


FPD クイック アップグレード

ここでは、ES+ ラインカードの FPD をアップグレードする場合の情報を提供します。ここで説明する手順は、動作中のネットワーク環境で常に実行できるとはかぎらず、また、FPD のアップグレードに使用できる唯一の方法でもありません。この項では、次のトピックについて取り上げます。

「Cisco IOS Release をアップグレードする前の FPD の迅速なアップグレード(推奨)」

「Cisco IOS Release をアップグレードしたあとの FPD の迅速なアップグレード」

Cisco IOS Release をアップグレードする前の FPD の迅速なアップグレード(推奨)


ステップ 1 Cisco IOS イメージを適用する場合、アップグレードする Cisco IOS イメージの FPD イメージ パッケージをルータ上のいずれかのフラッシュ ディスクにダウンロードし、そのあとで Cisco IOS の新しいバージョンを起動します。FPD イメージ パッケージは、Cisco IOS イメージを取得するためにアクセスした同じサイトから入手できます。FPD イメージ パッケージの名前は変更しないでください。

ステップ 2 新バージョンの Cisco IOS を使用して起動します。新しい Cisco IOS が起動されると、デフォルトでルータ フラッシュ ファイル システムから FPD イメージ パッケージが検索され、IOS の起動プロセスの一環として、FPD イメージが自動的に更新されます。


 

Cisco IOS Release をアップグレードしたあとの FPD の迅速なアップグレード


ステップ 1 FPD アップグレードは、Cisco IOS をリロードしたあと、常に必要というわけではありません。Cisco IOS をすでにリロードしている場合は、 show hw-module all fpd コマンドを入力して、すべてのシステム FPD が適合しているかどうかを確認します。FPD が適合している場合は、追加処理は必要ありません。アップグレードが必要な FPD がある場合は、ステップ 2 に進みます。

ステップ 2 特定の Cisco IOS ソフトウェアをダウンロードした cisco.com サイトにアクセスし、FPD イメージ パッケージを検索します。

ステップ 3 この FPD イメージ パッケージをルータのフラッシュ ディスクにダウンロードします。FPD イメージ パッケージの名前は変更しないでください。

システム上の FPD 関連の設定を変更しないでください( upgrade fpd auto または upgrade fpd path が変更されている場合は、コマンドの no 形式を使用してデフォルト設定に戻します)。Cisco IOS Release ソフトウェアをリブートします。新しい Cisco IOS が起動されると、デフォルトでフラッシュ ファイル システムから FPD イメージ パッケージが検索され、IOS の起動プロセスの一環として、FPD イメージが自動的に更新されます。


 

FPD イメージのアップグレード

ここでは、FPD イメージの更新が必要となる一般的なシナリオの一部を示します。次のシナリオについて説明します。

「新しい Cisco IOS Release への移行」

「運用中でないシステムでの FPD イメージのアップグレード」

Cisco IOS Release をアップグレードする前の FPD イメージのアップグレード(推奨)

Cisco IOS の旧リリースをまだ使用していて、新しいバージョンの Cisco IOS をロードする準備を行う場合、新しい Cisco IOS Release に対応するように FPD をアップグレードします。FPD をアップグレードする場合には、IOS をアップグレードする前に、アップグレード後の IOS Release に対応する FPD イメージ パッケージを格納する方法を推奨します。これは、この方法が簡単で迅速であるためです。このタイプの FPD アップグレードを実行するには、次の手順を実行します。


ステップ 1 アップグレード前の Cisco IOS Release を実行している状態で、Cisco IOS の新バージョンに対応する FPD イメージ パッケージを、ルータのいずれかのフラッシュ ファイル システムに格納します。特定の IOS Release に対応する FPD イメージ パッケージは、cisco.com の Cisco IOS ソフトウェア イメージのダウンロード元と同じ場所から入手できます。この操作を行っても現在の FPD には影響を与えないため、スイッチおよび ES+ ラインカードは通常どおりの動作を続けます。


注意 FPD イメージ パッケージのファイル名は変更しないでください。Cisco IOS はファイル名を使用して FPD イメージ パッケージのファイルを検索します。FPD イメージ パッケージのファイル名を変更すると、ファイルを検出できなくなります。

ステップ 2 アップグレードした新しい Cisco IOS イメージを使用してルータをリブートします。ブート プロセスの一部として、ルータは FPD イメージ パッケージを検索します。FPD イメージ パッケージ検索のデフォルト設定では、特定の Cisco IOS Release に対応する FPD イメージ パッケージがフラッシュ ファイル システムから検索されます。起動プロセス中に FPD イメージ パッケージが検出され、アップグレードを必要とするすべての FPD がアップグレードされます。

ステップ 3 ルータの起動後、 show hw-module all fpd コマンドを入力して、アップグレードが正常に行われたかどうかを確認します。


 

新しい Cisco IOS Release をアップグレードしたあとの FPD イメージのアップグレード

ここでは、すでに Cisco IOS Release をアップグレードしているものの、FPD イメージをアップグレードする必要がある場合の、アップグレード方法について説明します。

新しい Cisco リリースの起動後に FPD アップグレードを実行するには、次の手順を実行します


ステップ 1 ES+ ラインカードの FPD イメージが適合しているかどうかが不明な場合は、 show hw-module all fpd コマンドを入力して、すべての ES+ ラインカードの適合性を確認します。すべての ES+ ラインカードが適合している場合、このアップグレードを実行する必要はありません。

ステップ 2 FPD のアップグレードが必要な場合、Cisco IOS の新バージョンに対応する FPD イメージ パッケージを、ルータのフラッシュ ディスク、あるいはアクセス可能な FTP または TFTP サーバに格納します。FPD イメージ パッケージは、cisco.com の Cisco IOS ソフトウェア イメージをダウンロードした同じ場所から入手できます。

ステップ 3 upgrade hw-module [ slot slot-number ] file-url コマンドを入力します。 file-url コマンドにより、FPD イメージ パッケージの保管場所が示されます。

複数の ES+ ラインカードでアップグレードが必要な場合は、各ハードウェアを個別に更新する必要があります。


) 新しい Cisco IOS Release を実行している状態で、何らかの FPD アップグレード エラーが原因で ES+ ラインカードがディセーブルまたは電源がオフになった場合、FPD のアップグレードを行うには hw-module reset コマンドを使用してラインカードをリロードするしか方法はありません(必要な FPD バンドル ファイルがファイル システムにコピー済みであることを前提とします)。upgrade hw-module コマンドは、ラインカードがアップ ステートの場合にだけ機能します。


ステップ 4 show hw-module all fpd コマンドを入力して、アップグレードが正常に行われたかどうかを確認します。


 

運用中でないシステムでの FPD イメージのアップグレード

運用中のシステムに ES+ ラインカードを追加すると、ES+ ラインカードに現在ルータを実行している Cisco IOS Release に適合しない FPD イメージ バージョンが含まれていることがある可能性が示されます。また、FPD アップグレード処理は CPU 中心の処理になる可能性があるため、運用中のシステムで実行すると時間がかかる場合があります。パフォーマンスへの影響は、ネットワーク トラフィックの負荷、使用する処理エンジンのタイプ、ES+ ラインカードのタイプ、設定されているサービスのタイプなど、さまざまな要因によって異なります。ES+ ラインカードの FPD イメージをアップグレードするには運用中でないシステムを使用します。

アップグレードを開始する前に、次のことを確認します。

ターゲットとなる運用中のシステムによって実行されているのと同じバージョンの Cisco IOS ソフトウェア リリースが、予備システムで実行されていること。

自動アップグレード機能が予備システムでイネーブルになっていること(自動アップグレード機能はデフォルトではイネーブルです。 upgrade fpd auto コマンドを使用してイネーブルにすることもできます)。

次の手順を使用して、予備システムでアップグレードを実行します。


ステップ 1 FPD イメージ パッケージ ファイルを、ルータのフラッシュ ファイル システム、または予備システムがアクセスできる TFTP または FTP サーバにダウンロードします。ルータはデフォルトで、FPD イメージ パッケージをフラッシュ ファイル システムから検索するため、通常はフラッシュ ファイル システムにファイルを格納しています。フラッシュ ファイル システムが満杯の場合は、 upgrade fpd path コマンドを使用して、ルータが適切な場所から FPD イメージ パッケージを検索するように設定します。

ステップ 2 予備システムに ES+ ラインカードを取り付けます。

アップグレードが必要な場合、システムは必要な FPD イメージの更新を実行します。したがって、この ES+ ラインカードを対象となる実働システムに取り付けた場合、FPD のアップグレード処理は実行されません。

ステップ 3 show hw-module all fpd コマンドを入力して、アップグレードが正常に行われたかどうかを確認します。

ステップ 4 アップグレード後、予備システムから ES+ ラインカードを取り外します。

ステップ 5 対象となる実働システムに ES+ ラインカードを取り付けます。


 

システムの適合性の確認

アップグレードの実行に利用できる予備システムがない場合、自動アップグレード機能をディセーブルにしてから ES+ ラインカードを取り付けることにより、システムの適合性をチェックできます(自動アップグレード機能は、デフォルトでイネーブルです。 no upgrade fpd auto コマンドを使用してディセーブルにできます)。

ES+ ラインカードの FPD イメージがシステムに適合している場合、自動アップグレード機能を再びイネーブルにするだけで作業は完了します(自動アップグレード機能は、 upgrade fpd auto コマンドを使用すると再びイネーブルにすることができます)。

ES+ ラインカードの FPD イメージがシステムに適合していない場合、その ES+ ラインカードはディセーブルになりますが、自動アップグレードを試行してシステム パフォーマンスに影響を与えることはありません。

ES+ ラインカードの FPD イメージがシステムに適合しているかどうかを確認する手順は、次のとおりです。


ステップ 1 no upgrade fpd auto グローバル コンフィギュレーション コマンドを使用して、自動アップグレード機能をディセーブルにします。

ステップ 2 システムに ES+ ラインカードを取り付けます。

FPD イメージが適合している場合、起動後に ES+ ラインカードが正常に動作します。

FPD イメージが適合していない場合、ES+ ラインカードはディセーブルになります。この時点で、システムがオフラインになるスケジュールされたメンテナンスを待機し、「FPD イメージのアップグレード」で概説した手順のいずれかを使用して FPD アップグレードを手動で実行することを推奨します。

ステップ 3 upgrade fpd auto グローバル コンフィギュレーション コマンドを使用して、自動アップグレード機能を再びイネーブルにします。


 

FPD 関連の省略可能な手順

ここでは、FPD 関連の省略可能な機能について説明します。ここで説明する手順はいずれも、FPD アップグレードを行う際に必須ではありませんが、状況によって役立つ場合があります。内容は次のとおりです。

「ES+ ラインカードの FPD イメージの手動アップグレード」

「FTP または TFTP サーバからの FPD のアップグレード」

「FPD イメージ パッケージ ファイルへのデフォルト パスの変更」

「現在の FPD イメージ バージョンおよび最低限必要なバージョンの表示」

「デフォルトの FPD イメージ パッケージに関する情報の表示」

ES+ ラインカードの FPD イメージの手動アップグレード

ES+ ラインカードの現在の FPD バージョンを手動でアップグレードするには、次のコマンドを使用します。

Router# upgrade hw-module [slot slot-number] file file-url
 

この例で、 slot-number は ES+ ラインカードが取り付けられているスロット、 file-url は、FPD イメージ パッケージ ファイルの場所および名前です。


注意 ES+ ラインカードによっては、イメージのアップグレードに長時間かかる場合があります。

FTP または TFTP サーバからの FPD のアップグレード

一般に推奨できる FPD イメージのアップグレード方法は、FPD イメージ パッケージをフラッシュ ファイル システムにダウンロードし、FPD 自動アップグレードを利用する方法です。デフォルトの場合、システムは FPD が不適合であることを検出すると、フラッシュ ファイル システムから FPD イメージ パッケージ ファイルを検索します。

フラッシュから FPD イメージをロードするデフォルトの動作を変更するには、 upgrade fpd path グローバル コンフィギュレーション コマンドを使用します。このコマンドでは、FPD イメージ パッケージ ファイルの検索パスをルータのフラッシュ ファイル システム以外の場所に設定できます。

大規模な構成で、システム全体を特定の Cisco IOS ソフトウェア リリースにアップグレードする場合には、関連するすべてのシステムからアクセス可能な FTP または TFTP サーバに FPD イメージ パッケージ ファイルを格納する方法を推奨します。 upgrade fpd path グローバル コンフィギュレーション コマンドを使用して、その FTP または TFTP サーバから FPD イメージ パッケージ ファイルを検索するようにルータを設定したあと、システムを新しい Cisco IOS Release を使ってリロードします。


) この方法は、システムのフラッシュ カードに FPD イメージ パッケージ ファイルを格納できる十分なディスク領域がない場合にも使用できます。


FPD イメージ パッケージ ファイルを FTP または TFTP サーバにダウンロードする手順は、次のとおりです。


ステップ 1 FPD イメージ パッケージ ファイルを FTP または TFTP サーバにコピーします。

ステップ 2 グローバル コンフィギュレーション モードで upgrade fpd path コマンドを使用し、FPD イメージ パッケージを FTP または TFTP サーバから検索するようにルータを設定します。

たとえば、対象となるシステムのコンソールから次のいずれかのグローバル コンフィギュレーション コマンドを入力します。

Router(config)# upgrade fpd path tftp://my_tftpserver/fpd_pkg_dir/

または

Router(config)# upgrade fpd path ftp://login:password@my_ftpserver/fpd_pkg_dir/
 

) 上記の各例の最後にある「/」は、必ず入力する必要があります。末尾の「/」なしでパスを指定すると、コマンドが正常に機能しません。


これらの例で、 my_tftpserver または my_ftpserver はサーバ名のパス、 fpd_pkg_dir は FPD イメージ パッケージを格納している TFTP サーバのディレクトリ、 login:password は FTP ログイン名およびパスワードです。

ステップ 3 show running-config コマンドの出力を調べ、FPD 自動アップグレード機能がイネーブルであることを確認します。(出力で upgrade fpd auto と表示されたコンフィギュレーション行を探します。出力に upgrade コマンドがない場合、デフォルト設定である upgrade fpd auto がイネーブルです)。自動アップグレードがディセーブルである場合は、 upgrade fpd auto グローバル コンフィギュレーション コマンドを使用して自動 FPD アップグレードをイネーブルにします。

ステップ 4 show upgrade fpd file コマンドを入力して、ルータとデフォルトの FPD イメージ パッケージが正しく接続されていることを確認します。このコマンドを使用して FPD イメージ パッケージ関連の出力が生成される場合は、アップグレードが適切に機能しています。

ステップ 5 設定を保存し、新しい Cisco IOS Release を使用してシステムをリロードします。

リロード後のシステム起動時に、すべての ES+ ラインカードについて必要な FPD イメージ バージョンのチェックが行われ、アップグレードが必要な場合には、自動的にアップグレード処理が実行されます。アップグレード処理ごとに、FTP または TFTP サーバ上の FPD イメージ パッケージ ファイルから、システムによって ES+ ラインカードに必要な FPD イメージが抽出されます。


 

FPD イメージ パッケージ ファイルへのデフォルト パスの変更

FPD イメージの自動アップグレードを実行する際、デフォルトでは Cisco IOS ソフトウェアはフラッシュ ファイル システムから FPD イメージ パッケージ ファイルを検索します。


) フラッシュ ファイル システムのいずれかに FPD イメージ パッケージ ファイルを格納するだけの十分なスペースがあることを確認してください。


FPD イメージ パッケージ ファイルを別の場所に保管することもできます。ただし、デフォルトではフラッシュ ファイル システムが検索されるため、Cisco IOS ソフトウェアがアクセスできる別の場所(FTP サーバ、TFTP サーバなど)を検索するように、FPD イメージ パッケージ ファイルの場所を変更する必要があります。それには、 upgrade fpd path fpd-pkg-dir-url グローバル コンフィギュレーション コマンドを使用します。 fpd-pkg-dir-url は、ルータが FPD イメージ パッケージを検索する代替の場所です。

fpd-pkg-dir-url を指定する場合は、次の点に注意してください。

fpd-pkg-dir-url は FPD イメージ パッケージのパスですが、FPD イメージ パッケージ自体は fpd-pkg-dir-url の一部分として指定しないでください。次のとおり入力します。

upgrade fpd path tftp://mytftpserver/myname/myfpdpkgpath/

ファイル名は指定されていません。

fpd-pkg-dir-url の最後の「/」は、必ず入力する必要があります。

upgrade fpd path グローバル コンフィギュレーション コマンドで、別の場所にある FPD イメージ パッケージ ファイルをルータに指定させない場合、システムはスイッチのフラッシュ ファイル システムから FPD イメージ パッケージ ファイルを検索します。

アップグレードが必要な場合に FPD イメージ パッケージ ファイルの検出に失敗すると、ES+ ラインカードはディセーブルになります。ES+ ラインカードは、FPD が適合しないとオンラインにならないため、FPD アップグレードが必要な場合でも自動アップグレード機能がディセーブルに設定されているときは、ES+ ラインカードもディセーブルになります。

現在の FPD イメージ バージョンおよび最低限必要なバージョンの表示

ルータに取り付けられている ES+ ラインカードの現在の FPD イメージ バージョンを表示するには、 show hw-module [ slot-number | all ] fpd コマンドを使用します。このコマンドで、 slot-number は ES+ ラインカードが取り付けられているスロット番号です。 all キーワードを使用すると、すべてのルータ スロットのハードウェアに関する情報が表示されます。

次の例は、この show コマンドを使用したときの出力を示しています。

この例の出力表示では、システムの ES+ ラインカードで使用されている FPD バージョンが最低要件を満たしていることを示しています。

Router# show hw-module all fpd
 

次に、特定のスロットで ES+ ラインカードに対して FPD を確認する場合の出力例を示します。

Router# show hw-module slot 9 fpd
 

デフォルトの FPD イメージ パッケージに関する情報の表示

現在の Cisco IOS Release でサポートされる ES+ ラインカード、およびアップグレードに必要な FPD イメージ パッケージを調べるには、 show upgrade fpd package default コマンドを使用します。

Router# show upgrade fpd package default
 

FPD イメージ アップグレードの例

ここでは、自動および手動での FPD イメージ アップグレードの例を示します。次のような例があります。

「自動 FPD イメージ アップグレードの例」

「手動 FPD イメージ アップグレードの例」

自動 FPD イメージ アップグレードの例

次の例では、 upgrade fpd auto を使用して自動アップグレードを実行します。

Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# upgrade fpd ?
auto Auto upgrade all FPD images
path Set path to locate the FPD image package file for auto upgrade
 
Router(config)# upgrade fpd auto ?
<cr>
 
Router(config)# upgrade fpd auto
Router(config)# exit
Router# show version
*Jun 18 10:27:00.078 sum08: %SYS-5-CONFIG_I: Configured from console by consoh ver
Cisco IOS Software, rsp72043_rp Software (rsp72043_rp-ADVENTERPRISEK9_DBG-M), Version 12.2(nightly.SR080616) NIGHTLY BUILD, synced to rainier RAINIER_BASE_FOR_V122_33_SRA_THROTTLE
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Tue 17-Jun-08 00:10 by cuotran
 
ROM: System Bootstrap, Version 12.2(33r)SRB3, RELEASE SOFTRouterRE (fc1)
 
Router uptime is 22 hours, 29 minutes
Uptime for this control processor is 22 hours, 29 minutes
System returned to ROM by reload (SP by reload)
System image file is "disk0:rsp72043-adventerprisek9_dbg-mz.autobahn76_061608"
Last reload type: Normal Reload

手動 FPD イメージ アップグレードの例

次の例では、スロット 8 の ES+ ラインカードの FPD が手動でアップグレードされます。

Router# upgrade hw-module slot 8 ?
fpd Field programmable device upgrade option
Router# upgrade hw-module slot 8 fpd ?
file Upgrade with field programmable device package/bundle file
 
Router# upgrade hw-module slot 8 fpd file c
Router# upgrade hw-module slot 8 fpd file d
*Jun 17 13:24:12.531 sum08: %FPD_MGMT-3-INCOMP_IMG_VER: Incompatible I/O FPGA (FPD ID=2) image version detected for 7600-ES+40G3CXL card in slot 8. Detected version = 0.16, minimum required version = 0.17. Current HW version = 0.118.
*Jun 17 13:24:12.531 sum08: %FPD_MGMT-3-INCOMP_IMG_VER: Incompatible 40x1G LinkFPGA (FPD ID=6) image version detected for 7600-ES+40G card in slot-dc 8-2. Detected version = 0.14, minimum required version = 0.15. Current HW version = 0.106.
*Jun 17 13:24:12.531 sum08: %FPD_MGMT-5-UPGRADE_ATTEMPT: Attempting to automatically upgrade the FPD image(s) for 7600-ES+40G3CXL card in slot 8. Use 'show upgrade fpd progress' command to view the upgrade progress ...
*Jun 17 13:24:12.547 sum08: %FPD_MGMT-6-BUNDLE_DOWNLOAD: Downloading FPD image bundle for 7600-ES+40G3CXL card in slot 8 ...i
Router#upgrade hw-module slot 8 fpd file disk
*Jun 17 16:24:12.551: %FABRIC_INTF_ASIC-DFC8-5-FABRICSYNC_DONE: Fabric ASIC 0 Channel 1: Fabric sync done.
*Jun 17 16:24:12.575: %FABRIC_INTF_ASIC-DFC8-5-FABRICSYNC_DONE: Fabric ASIC 1 Channel 1: Fabric sync done.

トラブルシューティング

ここでは、ES+ ラインカードの動作のトラブルシューティングに使用できる技法について説明します。

「Cisco IOS Event Tracer を使用した問題のトラブルシューティング」

「XFP の問題のトラブルシューティング」

「ES+ ラインカードの活性挿抜の準備」

ここでは、基本的なインターフェイスのトラブルシューティング情報を示します。XFP トランシーバに問題がある場合は、「Cisco IOS Event Tracer を使用した問題のトラブルシューティング」の手順に従って、インターフェイス設定に問題がないかどうかを調べてください。

Cisco IOS Event Tracer を使用した問題のトラブルシューティング


) Event Tracer 機能はソフトウェア診断ツールとして使用することを目的としており、Cisco Technical Assistance Center(TAC)担当者の指示がある場合以外は設定しないでください。


Event Tracer 機能は、Cisco IOS ソフトウェアのトラブルシューティングを行うためのバイナリ トレース ファシリティを提供します。シスコのサービス担当者はこの機能を使用して、Cisco IOS ソフトウェアの動作を詳しく調べることができます。また、オペレーティング システムがまれに誤作動した場合や、冗長システムでルート プロセッサがスイッチオーバーした場合にも、この機能を利用して問題を診断できます。

イベント トレースの機能は、イベント トレースと連携するようにプログラムされた特定の Cisco IOS ソフトウェア サブシステム コンポーネントから情報メッセージを読み取り、これらのコンポーネントからシステム メモリにメッセージを記録することです。メモリに格納されたトレース メッセージは、画面に表示するか、ファイルに保存してあとで分析することができます。

Event Tracer 機能の使用方法については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios/netmgmt/configuration/guide/nm_event_tracer.html

XFP の問題のトラブルシューティング

XFP トランシーバをトラブルシューティングする場合は、次のコマンドを発行します。

 

コマンド
目的

Router# show interfaces [interface interface-number] capabilities [ module number]

各モジュール、各インターフェイス、またはすべてのインターフェイスのインターフェイス機能を表示します。

Router# show interfaces [interface interface-number] status [ err-disabled | module number]

インターフェイスのステータスを表示します。

Router# show interfaces [interface interface-number] transceiver [ threshold violations ] [ detail | { module number}]

デジタル オプティカル モニタリング(DOM)がイネーブルな光トランシーバに関する情報が表示されます。

Router# show idprom interface

ポートに接続されているトランシーバの IDPROM を表示します。

光電力定格がリンクに適していることを確認します。リンクの両端において、次のコマンドの出力で「+」、「++」、「-」、「--」をチェックして、電力定格が正しいことを確認します。

Router# show interface tengigabitethernet 2/1 transceiver detail
Transceiver monitoring is disabled for all interfaces.
 
ITU Channel not available (Wavelength not available),
Transceiver is internally calibrated.
mA: milliamperes, dBm: decibels (milliwatts), NA or N/A: not applicable.
++ : high alarm, + : high warning, - : low warning, -- : low alarm.
A2D readouts (if they differ), are reported in parentheses.
The threshold values are calibrated.
 
High Alarm High Warn Low Warn Low Alarm
Temperature Threshold Threshold Threshold Threshold
Port (Celsius) (Celsius) (Celsius) (Celsius) (Celsius)
---------- ------------------ ---------- --------- --------- ---------
Te2/1 29.6 74.0 70.0 0.0 -4.0
 
High Alarm High Warn Low Warn Low Alarm
Voltage Threshold Threshold Threshold Threshold
Port (Volts) (Volts) (Volts) (Volts) (Volts)
---------- --------------- ---------- --------- --------- ---------
Te2/1 N/A N/A N/A N/A N/A
 
High Alarm High Warn Low Warn Low Alarm
Current Threshold Threshold Threshold Threshold
Port (milliamperes) (mA) (mA) (mA) (mA)
---------- ----------------- ---------- --------- --------- ---------
Te2/1 56.8 -- N/A N/A N/A N/A
 
Optical High Alarm High Warn Low Warn Low Alarm
Transmit Power Threshold Threshold Threshold Threshold
Port (dBm) (dBm) (dBm) (dBm) (dBm)
---------- ----------------- ---------- --------- --------- ---------
Te2/1 1.6 7.9 3.9 0.0 -4.0
 
Optical High Alarm High Warn Low Warn Low Alarm
Receive Power Threshold Threshold Threshold Threshold
Port (dBm) (dBm) (dBm) (dBm) (dBm)
---------- ----------------- ---------- --------- --------- ---------
Te2/1 -1.2 ++ -3.0 -7.0 -24.0 -28.2
 

アラームまたは警告がない場合は、次の確認を行います。

リンクの両端で同じトランシーバ タイプを使用する必要があります。

トランシーバ(LR、IR、ZR)は、リンクの長さに適切である必要があります。

電力定格の制御に減衰器を使用します。

ES+ ラインカードの活性挿抜の準備

活性挿抜(OIR)は、XFP トランシーバのそれぞれに加えて ES+ ラインカードをサポートします。

トランシーバを取り付けたまま ES+ ラインカードを取り外すか、ES+ ラインカードが装着されたまま ES+ ラインカードからトランシーバを個別に削除できます。

活性挿抜のサポートに関する具体的な内容は次のとおりです。

「ES+ ラインカードの活性取り外しの準備」

「ES+ ラインカードの非アクティブ化およびアクティブ化の確認」

「非アクティブ化およびアクティブ化の設定例」

ES+ ラインカードの活性取り外しの準備

OIR を実行するには、ES+ ラインカードの電源をオフにして(取り付けられている光トランシーバは自動的に非アクティブになる)、有効である ES ラインカードを取り外します。

no power enable module コマンドを使用して ES+ ラインカードを適切に非アクティブにすることを推奨しますが、最初に非アクティブにしなくても、Cisco 7600 シリーズ ルータから ES+ ラインカードを取り外すことは可能です。ES+ ラインカードを取り外す場合に、まず ES+ ラインカードを非アクティブにするには、 no power enable module グローバル コンフィギュレーション コマンドを使用します。このコマンドを使用して ES+ ラインカードを非アクティブにすると、その ES+ ラインカードに取り付けられている各光トランシーバは自動的に非アクティブになります。したがって、各光トランシーバを非アクティブにしてから ES+ ラインカードを非アクティブにする必要はありません。

通常動作時は、ES+ ラインカードの各サブスロットにブランク フィラー プレート、または光トランシーバを装着する必要があります。

ES+ ラインカードの非アクティブ化

ES+ ラインカードおよびそれに取り付けられている光トランシーバを非アクティブにしてからラインカードを取り外すには、次のコマンドをグローバル コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config)# no power enable module slot

インストールされているインターフェイスをシャットダウンし、指定スロットで ES+ ラインカードを非アクティブにします。

ES+ ラインカードの再アクティブ化

ES+ ラインカードを非アクティブにした場合は、OIR を実行したかどうかに関係なく、 power enable module グローバル コンフィギュレーション コマンドを使用して ES+ ラインカードを再びアクティブにする必要があります。

ES+ ラインカードに取り付けられている光トランシーバを非アクティブにするコマンドを実行しなかったが、 no power enable module コマンドを使用して ES+ ラインカードを非アクティブにした場合、ES+ ラインカードの OIR 後に光トランシーバを再びアクティブにする必要はありません。取り付けられている光トランシーバは、ルータで ES+ ラインカードが再びアクティブになると、自動的に再びアクティブになります。

たとえば、ES+ ラインカードをルータから取り外し、別の ES+ ラインカードに交換したとします。新しい ES+ ラインカードには、同じ光トランシーバを取り付けました。ルータ上で power enable module コマンドを入力すると、光トランシーバは新しい ES+ ラインカードで自動的に再びアクティブになります。

ES+ ラインカードを非アクティブにしたあとで、ES+ ラインカードおよびそれに取り付けられている光トランシーバをアクティブにするには、次のコマンドをグローバル コンフィギュレーション モードで使用します。

 

コマンド
目的

Router(config)# power enable module slot

指定スロットの ES+ ラインカード、およびそれに取り付けられている光トランシーバをアクティブにします。

slot :ES+ ラインカードが取り付けられているシャーシ スロット番号を指定します。

ES+ ラインカードの非アクティブ化およびアクティブ化の確認

ES+ ラインカードが非アクティブになったかどうかを確認するには、特権 EXEC コンフィギュレーション モードで show module コマンドを入力します。確認する ES+ ラインカードに対応した [Status] フィールドを調べます。

次の例は、スロット 10 の ES+ ラインカードが非アクティブであることを示しています。非アクティブ化は、[PwrDown] ステータスで示されます。

Router# show module 10
 

ES+ ラインカードがアクティブ化されていて、適切に動作しているかどうかを確認するには、 show module コマンドを入力して、次の例のように、[Status] フィールドが「Ok」であるか調べます。

Router# show module 10
 

非アクティブ化およびアクティブ化の設定例

ここでは、ES+ ラインカードおよび光トランシーバの非アクティブ化およびアクティブ化の例を示します。

「ES+ ラインカード設定の非アクティブ化の例」

「ES+ ラインカード設定のアクティブ化の例」

ES+ ラインカード設定の非アクティブ化の例

ES+ ラインカードの OIR を実行する場合は、ES+ ラインカードを非アクティブにします。次の例では、ルータのスロット 5 に取り付けられている ES+ ラインカード、その光トランシーバ、すべてのインターフェイスが非アクティブになります。対応するコンソール メッセージも示します。

Router# configure terminal
Router(config)# no power enable module 5
1w4d: %OIR-6-REMCARD: Card removed from slot 5, interfaces disabled
1w4d: %C6KPWR-SP-4-DISABLED: power to module in slot 5 set off (admin request)

ES+ ラインカード設定のアクティブ化の例

ES+ ラインカードを以前非アクティブにした場合は、ES+ ラインカードをアクティブにします。光トランシーバを非アクティブにしなかった場合、光トランシーバは、ES+ ラインカードの再アクティブ化によって自動的に再びアクティブになります。

次の例では、(光トランシーバを非アクティブにする hw-module subslot shutdown コマンドが発行されていない限り)ルータのスロット 5 に取り付けられている ES+ ラインカード、光トランシーバ、すべてのインターフェイスがアクティブになります。

Router# configure terminal
Router(config)# power enable module 5
 
Notice that there are no corresponding console messages shown with activation. If you re-enter the power enable module command, a message is displayed indicating that the module is already enabled:
 
Router(config)# power enable module 5
% module is already enabled