EtherChannel の設定
EtherChannel の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/12/19 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

EtherChannel の設定

EtherChannel の概要

EtherChannel 機能の概要

EtherChannel 設定の概要

EtherChannel の設定の概要

EtherChannel の手動設定

PAgP による EtherChannel 設定

IEEE 802.3ad LACP による EtherChannel の設定

LACP の 1:1 冗長性の概要

ポート チャネル インターフェイスの概要

ロード バランシングの概要

EtherChannel 機能の設定時の注意事項および制約事項

EtherChannel の設定

レイヤ 3 EtherChannel のポート チャネル論理インターフェイスの設定

チャネル グループの設定

LACP のシステム プライオリティおよびシステム ID の設定

EtherChannel ロード バランシングの設定

EtherChannel のハッシュ分散アルゴリズムの設定

ハッシュ分散アルゴリズムのグローバル設定

ポート チャネルへのハッシュ分散アルゴリズムの設定

EtherChannel Min-Links 機能の設定

LACP 1:1 冗長性の設定

LACP ポート チャネルの自動インターリーブ ポート プライオリティの設定

EtherChannel の設定

この章では、Cisco IOS Release 12.2SX のレイヤ 2 またはレイヤ 3 LAN ポートに EtherChannel を設定する方法について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Master Command List, Release 12.2SX』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html


 


ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html


 

この章で説明する内容は、次のとおりです。

「EtherChannel の概要」

「EtherChannel 機能の設定時の注意事項および制約事項」

「EtherChannel の設定」

EtherChannel の概要

ここでは、EtherChannel の機能について説明します。

「EtherChannel 機能の概要」

「EtherChannel 設定の概要」

「ポート チャネル インターフェイスの概要」

「LACP の 1:1 冗長性の概要」

「ロード バランシングの概要」

EtherChannel 機能の概要

EtherChannel は、個々のイーサネット リンクを 1 つの論理リンクにバンドルすることによって、最大 8 つの物理リンクを合計した帯域幅を提供します。

Cisco IOS Release 12.2SX は、最大 128 の EtherChannel をサポートします。任意のスイッチング モジュール上の(設定に互換性のある)LAN ポートを 8 つまで使用して、1 つの EtherChannel を形成できます。各 EtherChannel の LAN ポートは、すべて同じ速度で、レイヤ 2 ポートまたはレイヤ 3 LAN ポートのどちらか一方として設定されている必要があります。


) スイッチに接続するネットワーク装置によって、1 つの EtherChannel にバンドルできるポート数が制限される場合があります。


EtherChannel 内のセグメントで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックがその EtherChannel 内の残りのセグメントに切り替えられます。障害が発生した場合、EtherChannel 機能はスイッチ、EtherChannel、および障害リンクを識別するトラップを送信します。EtherChannel の 1 つのセグメントに着信したブロードキャストおよびマルチキャスト パケットが、EtherChannel の別のセグメントに戻されることはありません。

EtherChannel 設定の概要

ここでは、EtherChannel を設定する手順について説明します。

「EtherChannel の設定の概要」

「EtherChannel の手動設定」

「PAgP による EtherChannel 設定」

「IEEE 802.3ad LACP による EtherChannel の設定」

EtherChannel の設定の概要

EtherChannel を形成するには、EtherChannel を手動で設定するか、Port Aggregation Control Protocol(PAgP)または Link Aggregation Control Protocol(LACP)を使用します。EtherChannel プロトコルを使用すると、接続先のネットワーク装置とダイナミックにネゴシエーションを行うことにより、同様な特性を持つポートが EtherChannel を形成できます。PAgP はシスコ システムズ独自のプロトコルであり、LACP は IEEE 802.3ad で定義されたプロトコルです。

PAgP および LACP はお互いに相互運用しません。PAgP を使用するように設定されたポートは、LACP を使用するように設定されたポートと EtherChannel を形成できません。LACP を使用するように設定されたポートは、PAgP を使用するように設定されたポートと EtherChannel を形成できません。どちらのポートも、手動で設定したポートとは相互運用しません。

表 17-1 に、ユーザ側で設定変更可能な EtherChannel モードを示します。

 

表 17-1 EtherChannel のモード

モード
説明

on

LAN ポートを無条件かつ強制的にチャネル化するモード。 on モードでは、 on モードの LAN ポート グループが、 on モードの別の LAN ポート グループに接続されている場合にだけ、使用可能な EtherChannel が存在します。 on モードで設定されたポートはネゴシエーションを行わないため、ポート間にネゴシエーション トラフィックは発生しません。EtherChannel プロトコルでは、 on モードを設定できません。一方の端が on モードを使用する場合は、もう一方の端も同じモードを使用する必要があります。

auto

PAgP モード。LAN ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した PAgP パケットには応答しますが、PAgP ネゴシエーションは開始しません(デフォルト)。

desirable

PAgP モード。LAN ポートをアクティブ ネゴシエーション ステートにします。ポートは PAgP パケットを送信して、他の LAN ポートとのネゴシエーションを開始します。

passive

LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません(デフォルト)。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

EtherChannel の手動設定

手動設定された EtherChannel ポートは、EtherChannel プロトコル パケットを交換しません。手動設定された EtherChannel が形成されるのは、EtherChannel 内のすべてのポート設定に互換性がある場合だけです。

PAgP による EtherChannel 設定

PAgP を使用すると、LAN ポート間で PAgP パケットを交換することにより、EtherChannel を自動的に作成できます。PAgP パケットが交換されるのは、 auto モードおよび desirable モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能をダイナミックに学習し、他の LAN ポートに通知します。PAgP は、正確に一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。作成された EtherChannel は、単一ブリッジ ポートとしてスパニング ツリーに追加されます。

auto モードおよび desirable モードでは、PAgP は LAN ポート間でネゴシエーションを行い、ポート速度、トランキング ステートなどの一定の基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 番号も使用します。

LAN ポート間で PAgP モードが異なっていても、モードが矛盾しないかぎり EtherChannel を形成できます。次に例を示します。

desirable モードの LAN ポートは、 desirable モードの別の LAN ポートと EtherChannel を形成できます。

desirable モードの LAN ポートは、 auto モードの別の LAN ポートと EtherChannel を形成できます。

auto モードの LAN ポートは、どちらのポートもネゴシエーションを開始しないので、 auto モードの別の LAN ポートとは EtherChannel を形成できません。

IEEE 802.3ad LACP による EtherChannel の設定

LACP では、LAN ポート間で LACP パケットを交換することによる、EtherChannel の自動作成をサポートしています。LACP パケットが交換されるのは、 passive モードおよび active モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能をダイナミックに学習し、他の LAN ポートに通知します。LACP は、正確に一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。作成された EtherChannel は、単一ブリッジ ポートとしてスパニング ツリーに追加されます。

passive モードおよび active モードでは、LACP は LAN ポート間でネゴシエーションを行い、ポート速度、トランキング ステートなどの一定の基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 番号も使用します。

LAN ポート間で LACP モードが異なっていても、モードが矛盾しないかぎり EtherChannel を形成できます。次に例を示します。

active モードの LAN ポートは、 active モードの別の LAN ポートと EtherChannel を形成できます。

active モードの LAN ポートは、 passive モードの別の LAN ポートと EtherChannel を形成できます。

passive モードの LAN ポートは、どちらのポートもネゴシエーションを開始しないので、 passive モードの別の LAN ポートとは EtherChannel を形成できません。

LACP では次のパラメータを使用します。

LACP システム プライオリティ:LACP が稼動しているスイッチごとに LACP システム プライオリティを設定する必要があります。システム プライオリティは自動設定、または Command-Line Interface(CLI; コマンドライン インターフェイス)から設定できます(「LACP のシステム プライオリティおよびシステム ID の設定」を参照)。LACP はシステム ID を形成するために、システム プライオリティとスイッチの MAC アドレスを使用します。また、他のシステムとのネゴシエーション中にもこれらを使用します。


LACP のシステム ID は、LACP システム プライオリティ値とスイッチの MAC アドレスを組み合わせたものです。


LACP ポート プライオリティ:LACP を使用するように設定されたポートごとに、LACP ポート プライオリティを設定する必要があります。ポート プライオリティは自動設定、または CLI から設定できます(「チャネル グループの設定」を参照)。LACP はポート プライオリティとポート番号を使用してポート ID を形成します。ハードウェアの制限により互換性のあるすべてのポートを集約できない場合、LACP はポート プライオリティを使用して、スタンバイ モードにする必要があるポートを決定します。

LACP 自動インターリーブ ポート プライオリティ:LACP 自動インターリーブ ポート プライオリティを設定すると、Distributed EtherChannel(DEC; 分散 EtherChannel)または Multichassis EtherChannel(MEC; マルチシャーシ EtherChannel)のいずれかの同一ポート チャネルの一部である異なるスロット間で、バンドル ポートおよびホット スタンバイ ポートの有効な分配を作成できます。自動インターリーブ ポート プライオリティを設定するには、 lacp active-port distribution automatic コマンドを使用します。バンドル ポート分配は CLI から設定できます(「チャネル グループの設定」を参照)。自動インターリーブ ポート プライオリティ機能をイネーブルにすると、ポート リンクが作成されたときの位置に基づいて、自動的にバンドル ポートが分配されます。ただし、有効になるのはより高い LACP システム プライオリティのシステム上で設定した場合だけです。すべてのポートで自動インターリーブ ポート プライオリティ機能をイネーブルにするには、インターフェイス ポート チャネルで shutdown および no shutdown を実行する必要があります。

LACP 管理キー:LACP は、LACP を使用するように設定されたポートごとに、チャネル グループ ID 番号と同じ管理キー値を自動的に設定します。管理キーは、他のポートと集約されるポートの機能を定義します。他のポートと集約されるポート機能は、次の要因によって決まります。

データ レート、デュプレックス機能、ポイントツーポイント型や共有型メディアなどのポートの物理特性

ユーザが作成した設定に関する制限事項

LACP を使用するように設定されたポート上で、LACP は EtherChannel 内の互換性のあるポートの最大数を、ハードウェアで許容されている最大数(8 ポート)以下の値で設定しようとします。互換性のあるすべてのポートを LACP が集約できない場合(たとえば、リモート システムのハードウェア制限が厳しい場合)、チャネルにアクティブに追加できないすべてのポートはホット スタンバイ ステートになり、チャネル ポートのいずれかに障害が発生した場合だけ使用されます。さらに 8 つのスタンバイ ポートを設定できます(EtherChannel には合計 16 のポートが関連付けられます)。

LACP の 1:1 冗長性の概要

Release 12.2(33)SXH 以降のリリースでは、LACP の 1:1 冗長性機能により、1 つのアクティブ リンクを備えた EtherChannel 設定と、ホットスタンバイ リンクへの高速スイッチオーバーが実現します。

LACP の 1:1 冗長性を使用するには、2 つのポート(1 つはアクティブ、もう 1 つはスタンバイ)で LACP EtherChannel を設定します。アクティブ リンクがダウンしても、EtherChannel はアップ状態のままで、ホット スタンバイ リンクへの高速スイッチオーバーが実行されます。障害となったリンクが再度動作可能になると、EtherChannel が高速スイッチオーバーを再度実行し、元のアクティブ リンクに戻します。

LACP 1:1 冗長性機能(特に高速スイッチオーバー機能)が正しく機能するためには、リンクの両方の端で機能をイネーブルにしておく必要があります。

ポート チャネル インターフェイスの概要

各 EtherChannel には、番号付きのポート チャネル インターフェイスが 1 つずつあります。1 ~ 256 の番号が付けられた最大 128 のポートチャネル インターフェイスを設定できます。ポート チャネル インターフェイスに適用した設定の内容は、そのポート チャネル インターフェイスに割り当てられたすべての LAN ポートに反映されます。

EtherChannel を設定すると、ポート チャネル インターフェイスに適用した設定は、EtherChannel に作用します。一方、LAN ポートに適用した設定は、適用先の LAN ポートだけに作用します。EtherChannel のすべてのポートのパラメータを変更する場合は、Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)コマンドまたはレイヤ 2 EtherChannel をトランクとして設定するコマンドなどのコンフィギュレーション コマンドをポート チャネル インターフェイスに適用します。

ロード バランシングの概要

EtherChannel は、フレーム ヘッダー内のバイナリ情報の一部を、チャネル内の 1 つのリンクを選択する数値に変換することによって、EtherChannel 内のリンク間でトラフィックをロード バランシングします。

リンクを選択する数値を導出するためのヘッダー情報を設定できます。EtherChannel のロード バランシングの方式では、MAC アドレス、IP アドレス、またはレイヤ 4 ポート番号を使用できます。送信元または宛先、あるいはその両方のアドレスまたはポートから情報を取得するように設定できます。選択したモードは、スイッチ上で設定されているすべての EtherChannel に適用されます。EtherChannel のロード バランシングには Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)レイヤ 2 ポート情報も使用できます。PFC3C/CXL ハードウェアをインストールした場合、EtherChannel のロード バランシングではデフォルトで VLAN 情報も考慮されます。

使用する設定で最多の種類のロード バランシング条件を提供するオプションを使用してください。たとえば、EtherChannel 上のトラフィックが 1 つの MAC アドレスにだけ送信され、かつ EtherChannel ロード バランシングの基準として宛先 MAC アドレスを使用している場合、EtherChannel は常に EtherChannel 内の同じリンクを選択します。IP アドレスの送信元アドレスを使用すると、ロード バランシングが向上することがあります。

EtherChannel 機能の設定時の注意事項および制約事項

EtherChannel インターフェイスを正しく設定しないと、ネットワーク ループなどの問題を回避するために、一部の EtherChannel インターフェイスが自動的にディセーブルになることがあります。設定に関する問題を回避するために、次の注意事項および制約事項に従ってください。

この章で説明するコマンドは、スーパーバイザ エンジンおよび冗長スーパーバイザ エンジンのポートも含めて、すべての レイヤ 2 イーサネット ポートに対して使用できます。

WS-X6148-GE-TX および WS-X6148V-GE-TX スイッチング モジュールは、EtherChannel 単位で 1 Gbps を超えるトラフィックをサポートしません。

EtherChannel への Inter Switch Link(ISL; スイッチ間リンク)トランキングをサポートしていないメンバー ポートを追加すると、Cisco IOS ソフトウェアは、EtherChannel を ISL トランクとして設定しないように、自動的に switchport trunk encapsulation dot1q コマンドをポートチャネル インターフェイスに追加します。EtherChannel がトランクでない場合、 switchport trunk encapsulation dot1q コマンドが非アクティブになります。

冗長スーパーバイザ エンジン上のポートも含め、すべてのモジュール上のすべてのレイヤ 2 イーサネット ポートが、EtherChannel(最大 8 つの LAN ポート)をサポートします。これらの LAN ポートは、物理的に隣接している LAN ポートでなくても、また同じモジュール上の LAN ポートでなくてもかまいません。

同じ EtherChannel プロトコルを使用するように EtherChannel 内のすべての LAN ポートを設定します。1 つの EtherChannel 内では 2 つの EtherChannel プロトコルを実行できません。

EtherChannel 内のすべての LAN ポートが、同じ速度および同じデュプレックス モードで動作するように設定してください。

LACP は半二重をサポートしません。LACP EtherChannel 内の半二重ポートは中断ステートになります。

EtherChannel のすべての LAN ポートをイネーブルにしてください。EtherChannel 内の LAN ポートを 1 つシャットダウンすると、リンク障害として扱われ、そのポートのトラフィックが EtherChannel 内の残りのポートの 1 つに転送されます。

LAN ポートの 1 つが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先ポートである場合には、EtherChannel は形成されません。

レイヤ 3 EtherChannel の場合は、チャネル内の LAN ポートに対してではなく、ポート チャネル論理インターフェイスに対してレイヤ 3 アドレスを割り当ててください。

レイヤ 2 EtherChannel の場合

EtherChannel 内のすべての LAN ポートを同じ VLAN に割り当てるか、またはトランクとして設定してください。

トランキング LAN ポートから EtherChannel を設定する場合は、すべてのトランクでトランキング モードが同じであることを確認してください。EtherChannel 内の LAN ポートをそれぞれ異なるトランク モードに設定すると、予期しない結果が生じる可能性があります。

EtherChannel は、トランキング レイヤ 2 EtherChannel 内のすべての LAN ポートで同じ許容範囲の VLAN をサポートします。VLAN の許容範囲が異なる場合、LAN ポートは EtherChannel を形成しません。

STP ポート パス コストが異なる LAN ポートは、設定に互換性があるかぎり、EtherChannel を形成できます。異なる STP ポート パス コストを設定しても、LAN ポートが EtherChannel を形成できなくなるわけではありません。

プロトコル フィルタリングの設定が LAN ポートで異なっている場合には、EtherChannel を形成できません。

EtherChannel でだけスタティック MAC アドレスを設定し、EtherChannel の物理メンバー ポートでは設定しません。

EtherChannel の設定後は、ポート チャネル インターフェイスに適用した設定が EtherChannel に作用します。LAN ポートに適用した設定は、設定を適用した LAN ポートだけに作用します。

QoS がイネーブルであれば、 no mls qos channel-consistency ポートチャネル インターフェイス コマンドを入力し、キュー構造が異なるポート(たとえば、完全優先キューのあるポートと完全優先キューのないポート)を持つ EtherChannel をサポートします。


注意 手動モードと PAgP モードまたは LACP モード、または EtherChannel が設定されていないポートが混在していると、深刻なトラフィックの問題を引き起こす場合があります。たとえば、on モードで設定されたポートを、desirable モードで設定されたポート、または EtherChannel が設定されていないポートに接続した場合、ブリッジ ループが発生し、ブロードキャスト ストームが起きる可能性があります。一方の端が on モードを使用する場合は、もう一方の端も同じモードを使用する必要があります。

大きく異なる方法でスイッチ経由のデータを渡すポートから EtherChannel を形成すると、深刻なトラフィックの問題を引き起こす場合があります。たとえば、DFC があるモジュールとないモジュールのポート、no mls qos channel-consistency ポートチャネル インターフェイス コマンドをイネーブルにした場合、QoS ポート パラメータ(バッファ サイズおよびキュー タイプ)が大きく異なるポートなどです。このような EtherChannels はディセーブルにしてください。

レイヤ 3 EtherChannel のポート チャネル論理インターフェイスの設定


) • レイヤ 2 EtherChannel を設定する場合は、手動で作成したポート チャネル論理インターフェイスにレイヤ 2 LAN ポートを追加できません。レイヤ 2 EtherChannel を設定している場合は、ここに記載されている手順を実行しないでください(「チャネル グループの設定」を参照)。

レイヤ 3 EtherChannel を設定する場合は、ここに記載されたポート チャネル論理インターフェイスを手動で作成し、レイヤ 3 LAN ポートをチャネル グループに追加する必要があります(「チャネル グループの設定」を参照)。

レイヤ 3 LAN ポートから EtherChannel に IP アドレスを移動するには、レイヤ 3 LAN ポートから IP アドレスを削除したあとで、その IP アドレスをポート チャネル論理インターフェイス上で設定する必要があります。


 

レイヤ 3 EtherChannel 用のポート チャネル インターフェイスを作成するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel group_number

ポート チャネル インターフェイスを作成します。

ステップ 2

Router(config-if)# ip address ip_address mask

EtherChannel に IP アドレスおよびサブネット マスクを割り当てます。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface port-channel group_number

設定を確認します。

group_number は 1 ~ 256 を指定でき、最大 128 のポートチャネル インターフェイスを作成できます。次に、インターフェイス Port-channel 1 を作成する例を示します。

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 172.32.52.10 255.255.255.0
Router(config-if)# end
 

次に、インターフェイス Port-channel 1 の設定を確認する例を示します。

Router# show running-config interface port-channel 1
Building configuration...
 
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
Router#

チャネル グループの設定


) • レイヤ 3 EtherChannel を設定する場合は、ポート チャネル論理インターフェイスを手動で作成してから(「レイヤ 3 EtherChannel のポート チャネル論理インターフェイスの設定」を参照)、ここに記載されているように、レイヤ 3 LAN ポートをチャネル グループに追加する必要があります。

レイヤ 2 EtherChannel を設定するには、ここに記載されているように、ポート チャネル論理インターフェイスを自動作成する channel-group コマンドを使用して、LAN ポートを設定します。手動で作成したポート チャネル インターフェイスにレイヤ 2 LAN ポートを組み込むことはできません。

Cisco IOS がレイヤ 2 EtherChannel 用のポート チャネル インターフェイスを作成するには、レイヤ 2 LAN ポートが接続され、動作している必要があります。


 

チャネル グループを設定するには、LAN ポートごとに次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type 1 slot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if)# no ip address

この LAN ポートに IP アドレスが割り当てられていないことを確認します。

ステップ 3

Router(config-if)# channel-protocol ( lacp | pagp }

(任意)選択した LAN ポート上で、 channel-group コマンドの適用範囲を、 channel-protocol コマンドを使用して設定された EtherChannel プロトコルに制限します。

ステップ 4

Router(config-if)# channel-group group_number mode { active | auto | desirable | on | passive }

ポート チャネル内の LAN ポートを設定し、モードを指定します(表 17-1を参照)。PAgP は、auto および desirable モードだけをサポートします。LACP は、active および passive モードだけをサポートします。

ステップ 5

Router(config-if)# lacp port-priority priority_value

(任意、LACP 用)有効な値は 1 ~ 65535 です。値が大きいほど、プライオリティは低くなります。デフォルト値は 32768 です。

ステップ 6

Router(config-if)# shutdown

インターフェイスをディセーブルにします。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 9

Router# show running-config interface type 1 slot/port

Router# show interfaces type 1 slot/port etherchannel

設定を確認します。

1.type = fastethernetgigabitethernet、または tengigabitethernet

次に、ポート FastEthernet 5/6 および 5/7 を、ポート チャネル 2、PAgP、モード desirable に設定する例を示します。

Router# configure terminal
Router(config)# interface range fastethernet 5/6 -7
Router(config-if)# channel-group 2 mode desirable
Router(config-if)# shutdown
Router(config-if)# no shutdown
Router(config-if)# end

range キーワードの詳細については、「インターフェイスの範囲設定」を参照してください。


次に、インターフェイス Port-channel 2 の設定を確認する例を示します。

Router# show running-config interface port-channel 2
Building configuration...
 
Current configuration:
!
interface Port-channel2
no ip address
switchport
switchport access vlan 10
switchport mode access
end
Router#
 

次に、ポート FastEthernet 5/6 の設定を確認する例を示します。

Router# show running-config interface fastethernet 5/6
Building configuration...
 
Current configuration:
!
interface FastEthernet5/6
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
Router# show interfaces fastethernet 5/6 etherchannel
Port state = Down Not-in-Bndl
Channel group = 12 Mode = Desirable-Sl Gcchange = 0
Port-channel = null GC = 0x00000000 Pseudo port-channel = Po1
2
Port index = 0 Load = 0x00 Protocol = PAgP
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
 
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/2 d U1/S1 1s 0 128 Any 0
 
Age of the port in the current state: 04d:18h:57m:19s
 

次に、LAN ポートを設定したあとに、インターフェイス Port-channel 2 の設定を確認する例を示します。

Router# show etherchannel 12 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po12
------------
 
Age of the Port-channel = 04d:18h:58m:50s
Logical slot/port = 14/1 Number of ports = 0
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = PAgP
 
Router#

LACP のシステム プライオリティおよびシステム ID の設定

LACP のシステム ID は、LACP システム プライオリティ値とスイッチの MAC アドレスを組み合わせたものです。

LACP のシステム プライオリティおよびシステム ID を設定するには、次の作業を実行します。

 

コマンド
目的

ステップ 1

Router(config)# lacp system-priority priority_value

(任意、LACP 用)有効な値は 1 ~ 65535 です。値が大きいほど、プライオリティは低くなります。デフォルト値は 32768 です。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show lacp sys-id

設定を確認します。

次に、LACP のシステム プライオリティを設定する例を示します。

Router# configure terminal
Router(config)# lacp system-priority 23456
Router(config)# end
Router(config)#
 

次に、設定を確認する例を示します。

Router# show lacp sys-id
23456,0050.3e8d.6400
Router#
 

システム プライオリティが最初に表示され、次にスイッチの MAC アドレスが表示されます。

EtherChannel ロード バランシングの設定

EtherChannel ロード バランシングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# port-channel per-module load-balance

(任意)モジュール単位で、ロード バランシングの方式を指定する機能を有効にします。

ステップ 2

Router(config)# port-channel load-balance { src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port } [ module slot ]

EtherChannel ロード バランシングの方式を設定します。この方式はすべてのポート チャネルにグローバルに適用されます。任意で、特定のモジュールにロード バランシングの方式を設定することもできます。

Router(config)# no port-channel load-balance

デフォルトの EtherChannel ロード バランシングに戻します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show etherchannel load-balance

設定を確認します。

ロード バランシング方式のキーワードの意味は、次のとおりです。

dst-ip :宛先 IP アドレス

dst-mac :宛先 MAC アドレス

dst-port :宛先レイヤ 4 ポート

mpls :MPLS パケットのロード バランシング

src-dst-ip :送信元および宛先 IP アドレス

src-dst-mac :送信元および宛先 MAC アドレス

src-dst-port :送信元および宛先レイヤ 4 ポート

src-ip :送信元 IP アドレス

src-mac :送信元 MAC アドレス

src-port :送信元レイヤ 4 ポート

module キーワード(任意)を指定すると、ロード バランシング方式を特定のモジュールに対して指定できます。この機能は、DFC を装備したスイッチング モジュールでだけサポートされています。この機能をモジュールに設定する前に、モジュールごとのロード バランシングをグローバルに有効化する必要があります。

次に、送信元および宛先 IP アドレスを使用するように EtherChannel を設定する例を示します。

Router# configure terminal
Router(config)# port-channel load-balance src-dst-ip
Router(config)# end
Router(config)#
 

次に、設定を確認する例を示します。

Router# show etherchannel load-balance
 
EtherChannel Load-Balancing Configuration:
src-dst-ip enhanced
mpls label-ip
 
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination IP address
IPv6: Source XOR Destination IP address
MPLS: Label or IP
 
Router#

) この例では、enhanced キーワードによって PFC3C/CXL ハードウェアがインストールされていることが示され、その結果、ロード バランシングの方式には VLAN 情報も含まれます。


EtherChannel のハッシュ分散アルゴリズムの設定

12.2(33)SXH よりも前のリリースでは、固定アルゴリズムと呼ばれる負荷分散アルゴリズムがサポートされています。EtherChannel にポートを追加したり、EtherChannel からポートを削除したりする場合、スイッチにより、EtherChannel 内の各ポートのポート ASIC が更新されますが、更新時、各ポートが短時間停止します。

12.2(33)SXH 以降のリリースでは、適合アルゴリズムと呼ばれるアルゴリズムもサポートされています。適合アルゴリズムでは、既存のメンバー ポートに対してポート ASIC を更新する必要がありません。

デフォルトのアルゴリズムは、固定アルゴリズムです。適合アルゴリズムに対し、グローバルな値を設定できます。また、個々のポート チャネルにアルゴリズムを指定できます。

アルゴリズムを変更した場合、変更は次のメンバー リンク イベント(link down、link up、addition、deletion、no shutdown、および shutdown)から適用されます。アルゴリズムを変更するコマンドを入力すると、次のメンバー リンク イベントまでコマンドが反映されないという警告がコマンド コンソールで発行されます。


) 外部デバイスの中には、固定アルゴリズムが必要なものもあります。たとえば、Service Control Engine(SCE)では、着信パケットと発信パケットが同じポートを使用する必要があります。



) ロード バランシングの方式を変更した場合、DFC 搭載のスイッチング モジュールまたはデュアル スーパーバイザ エンジン設定のアクティブなスーパーバイザ エンジンにおいて、EtherChannel ポートのフラップが発生します。


ハッシュ分散アルゴリズムのグローバル設定

負荷分散型アルゴリズムをグローバルに設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# port-channel hash-distribution { adaptive | fixed }

ハッシュ分散アルゴリズムを適合または固定に設定します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

次に、ハッシュ分散アルゴリズムを、適合アルゴリズムにグローバルに設定する例を示します。

Router(config)# port-channel hash-distribution adaptive

ポート チャネルへのハッシュ分散アルゴリズムの設定

ハッシュ分散アルゴリズムを特定のポート チャネルに設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel channel-num

ポート チャネルのインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# port-channel port hash-distribution { adaptive | fixed }

このインターフェイスにハッシュ分散アルゴリズムを設定します。

ステップ 3

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了します。

次に、ポート チャネル 10 に対して、ハッシュ分散アルゴリズムを適合として設定する例を示します。

Router (config)# interface port-channel 10
Router (config-if)# port-channel port hash-distribution adaptive

EtherChannel Min-Links 機能の設定

EtherChannel min-links 機能は、 LACP EtherChannel でサポートされています。この機能を使用すると、ポート チャネル インターフェイスをリンク アップ ステートに移行するために、リンク アップ ステートであり、EtherChannel にバンドルされていなければならないメンバー ポートの最小数を設定できます。EtherChannel min-links 機能を使用して低帯域幅の LACP EtherChannel をアクティブにしないようにできます。またこの機能により、アクティブなメンバー ポートが少なすぎて必要な最小帯域幅を供給できないような場合に、LACP EtherChannel を非アクティブにすることもできます。また、LACP の max-bundle 値を min-links と同時に指定した場合、その設定は検証され、min-links 値が max-bundle 値と適合しない(min-links 値が max-bundle 値より大きい)と、エラー メッセージが返されます。

EtherChannel min-links 機能を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel group_number

LACP ポート チャネル インターフェイスを選択します。

ステップ 2

Router(config-if)# port-channel min-links number

ポート チャネル インターフェイスをリンク アップ ステートに移行するために、リンク アップ ステートになっていて、EtherChannel にバンドルされていなければならないメンバー ポートの最小数を設定します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface port-channel group_number

Router# show interfaces type 2 slot/port etherchannel

設定を確認します。

2.type = fastethernetgigabitethernet、または tengigabitethernet


) EtherChannel min-links 機能は、EtherChannel の一端にだけ設定した場合でも正常に機能しますが、最適な結果を得るために、同じ数の最小リンクを EtherChannel の両端に設定してください。


次に、EtherChannel でアクティブなメンバー ポートが 2 つ未満の場合に、ポート チャネル インターフェイス 1 を非アクティブに設定する例を示します。

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# port-channel min-links 2
Router(config-if)# end

LACP 1:1 冗長性の設定

LACP 1:1 冗長性機能のためには、LACP EtherChannel に 2 つのリンクが必要です。アクティブになるのはそのうちの一方だけです。ポート プライオリティ値が小さい(つまり、プライオリティの高い)方のリンクがアクティブ リンクになり、もう一方のリンクはホット スタンバイ ステートになります。LACP の max-bundle は 1 に設定する必要があります。

LACP 1:1 冗長性機能を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel group_number

LACP ポート チャネル インターフェイスを選択します。

ステップ 2

Router(config-if)# lacp fast-switchover

この EtherChannel の高速スイッチオーバー機能をイネーブルにします。

ステップ 3

Router(config-if)# lacp max-bundle 1

アクティブ メンバー ポートの最大数を 1 に設定します。

ステップ 4

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 5

Router# show running-config interface port-channel group_number

Router# show interfaces type 3 slot/port etherchannel

設定を確認します。

3.type = fastethernetgigabitethernet、または tengigabitethernet


) LACP 1:1 冗長性機能(特に高速スイッチオーバー機能)が正しく機能するためには、EtherChannel の両方の端で機能をイネーブルにしておく必要があります。


次に、LACP EtherChannel を 1:1 冗長性に設定する例を示します。ファスト イーサネット ポート 5/6 は、デフォルトの 32768 より大きいポート プライオリティ番号(つまり、低いプライオリティ)で設定されるため、スタンバイ ポートになります。

Router# configure terminal
Router(config)# lacp system-priority 33000
Router(config)# interface range fastethernet 5/6 -7
Router(config-if)# channel-protocol lacp
Router(config-if)# channel-group 1 mode active
Router(config)# interface fastethernet 5/6
Router(config-if)# lacp port-priority 33000
Router(config)# interface port-channel 1
Router(config-if)# lacp fast-switchover
Router(config-if)# lacp max-bundle 1
Router(config-if)# end


ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html


 

LACP ポート チャネルの自動インターリーブ ポート プライオリティの設定

ポート チャネルで LACP の自動インターリーブ ポート プライオリティを設定するには、ポート チャネル インターフェイスで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel channel-group

設定するポート チャネル インターフェイスを選択します。

ステップ 2

Router(config-if)# lacp active-port distribution automatic

インターリーブ ポート プライオリティを使用するポート チャネルを設定します。


) インターリーブ ポート プライオリティをイネーブルにするには、shutdown および no shutdown を実行する必要があります。


ステップ 3

Router(config-if)# shutdown

インターフェイスをディセーブルにします。

ステップ 4

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Router# show etherchannel channel-group port-channel

Router# show etherchannel channel-group summary

設定を確認します。

次の例では、ポート チャネルの自動インターリーブ ポート プライオリティを設定する方法を示します。

Router(config)# interface port-channel23
Router(config-if)# lacp active-port distribution automatic
Please shut/no shut the port-channel for configuration to take effect immediately.
Router(config-if)# shutdown
Router(config-if)# no shutdown
 
Router(config-if)# end
 

次に、インターフェイス Port-channel 23 の設定を確認する例を示します。

Router# show running interfaces port-channel23
Building configuration...
 
Current configuration : 81 bytes
!
interface Port-channel23
no switchport
no ip address
lacp max-bundle 4
lacp active-port distribution automatic
end
 

次に、EtherChannel 23 の設定を確認する例を示します。

Router# show etherchannel 23 summary
 
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator
 
M - not in use, no aggregation due to minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
d - default port
 
w - waiting to be aggregated
Number of channel-groups in use: 9
Number of aggregators: 9
 
Group Port-channel Protocol Ports
------+-------------+-----------+---------------------------------------
23 Po23(RU) LACP Gi1/1/21(P) Gi1/1/22(P) Gi1/1/23(H)
Gi1/1/24(H) Gi2/1/17(P) Gi2/1/18(P)
Gi2/1/19(H) Gi2/1/20(H)
 
Last applied Hash Distribution Algorithm: Fixed
 

) 上記の例では、4 つのバンドル ポートがシャーシ/スロットごとに 2 つ分配されています。