Cisco Nexus 5000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス Cisco NX-OS Release 5.x
show コマンド
show コマンド
発行日;2012/07/19 | 英語版ドキュメント(2012/07/12 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

show コマンド

show ip eigrp

show ip eigrp accounting

show ip eigrp interfaces

show ip eigrp neighbors

show ip eigrp route

show ip eigrp route-map statistics

show ip eigrp topology

show ip eigrp traffic

show running-config eigrp

show コマンド

この章では、Cisco NX-OS Enhanced Interior Gateway Routing Protocol(EIGRP) show コマンドについて説明します。

show ip eigrp

Enhanced IGRP(EIGRP)プロセスのサマリーを表示するには、 show ip eigrp コマンドを使用します。

show ip eigrp [ instance-tag ]

 
構文の説明

instance-tag

(任意)EIGRP インスタンスの名前。 instance-tag には最大 20 文字の英数字文字列を指定します。大文字と小文字は区別されます。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、すべての EIGRP インスタンスを表示する例を示します。

switch# show ip eigrp
IP-EIGRP AS 65535 ID 3.1.1.1 VRF default
Process-tag: Test1
Status: running
Authentication mode: none
Authentication key-chain: none
Metric weights: K1=1 K2=0 K3=1 K4=0 K5=0
IP proto: 88 Multicast group: 224.0.0.10
Int distance: 90 Ext distance: 170
Max paths: 8
Number of EIGRP interfaces: 8 (0 loopbacks)
Number of EIGRP passive interfaces: 0
Number of EIGRP peers: 8
Redistributing:
direct route-map SVI-EIGRP
Graceful-Restart: Enabled
Stub-Routing: Disabled
NSF converge time limit/expiries: 120/0
NSF route-hold time limit/expiries: 240/0
NSF signal time limit/expiries: 20/0
Redistributed max-prefix: Disabled
switch#
 

 
関連コマンド

コマンド
説明

router eigrp

EIGRP インスタンスを設定します。

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

 

show ip eigrp accounting

Enhanced IGRP(EIGRP)プロセスのプレフィックス アカウンティング情報を表示するには、 show ip eigrp accounting コマンドを使用します。

show ip eigrp [ instance-tag ] accounting [ vrf { vrf-name | all | default | management }]

 
構文の説明

instance-tag

(任意)EIGRP インスタンスの名前。このオプションは、VRF インスタンスが指定されていない場合に使用できます。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

vrf vrf-name

(任意)VRF インスタンスの名前を指定します。 vrf-name 引数には、大文字と小文字が区別される最大 32 文字の任意の英数字文字列を指定できます。

all

(任意)すべての VRF インスタンスを指定します。

default

(任意)デフォルトの VRF を指定します。

management

(任意)管理 VRF を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP アカウンティング情報を表示する例を示します。

switch# show ip eigrp accounting
IP-EIGRP Accounting Statistics for AS 65535 VRF default
Total Prefix Count: 3536
 
States: A-Adjacency, P-Pending, D-Down
 
State Address/Source Interface Prefix Restart Restart/
Count Count Reset(s)
A Redistributed ---- 118 0 0
A 10.20.150.2 Po2001 3413 0 0
A 10.20.200.2 Po2000 3418 0 0
A 10.0.1.1 Eth1/26 3419 0 0
A 10.50.2.1 Eth2/5 3419 0 0
A 10.50.1.1 Eth2/6 3419 0 0
A 10.50.3.1 Eth2/7 3419 0 0
A 10.20.5.2 Eth3/11 3419 0 0
A 10.20.6.2 Eth3/12 3419 0 0
switch#

 
関連コマンド

コマンド
説明

router eigrp

EIGRP インスタンスを設定します。

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

 

show ip eigrp interfaces

Enhanced IGRP(EIGRP)に設定されたインターフェイスに関する情報を表示するには、 show ip eigrp interfaces コマンドを使用します。

show ip eigrp [ instance-tag ] interfaces [ { ethernet slot / port | loopback if_number | port-channel number | vlan vlan-id } ] [ brief ] [ vrf { vrf-name | all | default | management }]

 
構文の説明

instance-tag

(任意)EIGRP インスタンス。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ethernet slot / port

(任意)イーサネット インターフェイス、およびスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

loopback if_number

(任意)ループバック インターフェイスを指定します。ループバック インターフェイスの番号は 0 ~ 1023 です。

port-channel number

(任意)EtherChannel インターフェイスおよび EtherChannel 番号を指定します。指定できる範囲は 1 ~ 4096 です。

vlan vlan-id

(任意)VLAN インターフェイスを指定します。有効な範囲は 1 ~ 4094 です。

brief

(任意)EIGRP インターフェイス情報の概要を表示します。

vrf vrf-name

(任意)VRF インスタンスの名前を指定します。 vrf-name 引数には、大文字と小文字が区別される最大 32 文字の任意の英数字文字列を指定できます。

all

(任意)すべての VRF インスタンスを指定します。

default

(任意)デフォルトの VRF を指定します。

management

(任意)管理 VRF を指定します。

 
コマンド デフォルト

VRF またはインターフェイスが指定されていない場合、このコマンドはデフォルトの VRF のすべてのインターフェイスを表示します。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

どのインターフェイス EIGRP がアクティブであり、インターフェイスに関連した EIGRP の情報を学習するかを決定するには、 show ip eigrp interfaces コマンドを使用します。

インターフェイスを指定すると、そのインターフェイスのみが表示されます。指定されない場合、EIGRP を実行しているすべてのインターフェイスが表示されます。

Autonomous System(AS; 自律システム)を指定すると、指定された AS のルーティング システムのみが表示されます。指定されない場合、すべての EIGRP プロセスが表示されます。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP インターフェイスに関する情報を表示する例を示します。

switch# show ip eigrp interfaces brief
IP-EIGRP interfaces for process 65535 VRF default
 
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Eth1/26 1 0/0 16 0/1 64 0
Eth2/5 1 0/0 16 0/1 64 0
Eth2/6 1 0/0 16 0/1 64 0
Eth2/7 1 0/0 13 0/1 50 0
Eth3/11 1 0/0 18 0/1 80 0
Eth3/12 1 0/0 14 0/1 64 0
Po2000 1 0/0 13 0/1 72 0
Po2001 1 0/0 20 0/1 128 0
switch#
 

次に、特定の EIGRP インターフェイスに関する情報を表示する例を示します。

switch# show ip eigrp interfaces ethernet 2/5
IP-EIGRP interfaces for process 65535 VRF default
 
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Eth2/5 1 0/0 16 0/1 64 0
Hello interval is 5 sec
Holdtime interval is 15 sec
Next xmit serial <none>
Un/reliable mcasts: 0/178 Un/reliable ucasts: 292/17
Mcast exceptions: 4 CR packets: 4 ACKs suppressed: 8
Retransmissions sent: 8 Out-of-sequence rcvd: 146
Authentication mode is not set
switch#
 

 
関連コマンド

コマンド
説明

show ip eigrp neighbors

EIGRP によって検出されたネイバーを表示します。

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

 

show ip eigrp neighbors

Enhanced IGRP(EIGRP)によって検出されたネイバーの情報を表示するには、 show ip eigrp neighbors コマンドを使用します。

show ip eigrp [ instance-tag ] neighbors [ detail ] [ { ethernet slot / port | loopback if_number | port-channel number | vlan vlan-id } ] [ vrf { vrf-name | all | default | management }]

 
構文の説明

instance-tag

(任意)EIGRP インスタンスの名前。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

detail

(任意)詳細な EIGRP ネイバー情報を表示します。

ethernet slot / port

(任意)イーサネット インターフェイス、およびスロット番号とポート番号を指定します。スロット番号は 1 ~ 255、ポート番号は 1 ~ 128 です。

loopback if_number

(任意)ループバック インターフェイスを指定します。ループバック インターフェイスの番号は 0 ~ 1023 です。

port-channel number

(任意)EtherChannel インターフェイスおよび EtherChannel 番号を指定します。指定できる範囲は 1 ~ 4096 です。

vlan vlan-id

(任意)VLAN インターフェイスを指定します。有効な範囲は 1 ~ 4094 です。

vrf vrf-name

(任意)VRF インスタンスの名前を指定します。 vrf-name 引数には、大文字と小文字が区別される最大 32 文字の任意の英数字文字列を指定できます。

all

(任意)すべての VRF インスタンスを指定します。

default

(任意)デフォルトの VRF を指定します。

management

(任意)管理 VRF を指定します。

 
コマンド デフォルト

VRF またはインターフェイスが指定されていない場合、このコマンドはすべてのインターフェイス上のデフォルト VRF に関するすべてのネイバーを表示します。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

ネイバーがアクティブになる、また非アクティブになるときを決定するには、 show ip eigrp neighbors コマンドを使用します。このコマンドは、特定の転送問題のデバッグにも役立ちます。

このコマンドには、LAN Base Services ライセンスが必要です。

次の例では、EIGRP ネイバーに関する情報を表示する方法を示します。

switch# show ip eigrp neighbors
IP-EIGRP neighbors for process 65535 VRF default
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
7 10.20.150.2 Po2001 12 03:44:02 20 200 0 10331
6 10.20.200.2 Po2000 14 03:44:02 13 200 0 158157
5 10.40.1.1 Eth1/26 13 03:44:14 16 200 0 158164
4 10.50.2.1 Eth2/5 12 03:44:14 16 200 0 158166
3 10.50.1.1 Eth2/6 13 03:44:15 16 200 0 158165
2 10.50.3.1 Eth2/7 11 03:44:15 13 200 0 158167
1 10.20.5.2 Eth3/11 14 03:44:16 18 200 0 158158
0 10.20.6.2 Eth3/12 11 03:44:17 14 200 0 158163
switch#
 

次の例では、EIGRP ネイバーに関する詳細情報を表示する方法を示します。

switch# show ip eigrp neighbors detail
IP-EIGRP neighbors for process 65535 VRF default
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
7 10.20.150.2 Po2001 10 03:45:21 20 200 0 10331
Version 12.4/1.2, Retrans: 4, Retries: 0, Prefixes: 3413
6 10.20.200.2 Po2000 12 03:45:22 13 200 0 158157
Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 3418
5 10.40.1.1 Eth1/26 11 03:45:34 16 200 0 158164
Version 12.4/1.2, Retrans: 5, Retries: 0, Prefixes: 3419
4 10.50.2.1 Eth2/5 12 03:45:34 16 200 0 158166
Version 12.4/1.2, Retrans: 8, Retries: 0, Prefixes: 3419
3 10.50.1.1 Eth2/6 12 03:45:35 16 200 0 158165
Version 12.4/1.2, Retrans: 4, Retries: 0, Prefixes: 3419
2 10.50.3.1 Eth2/7 13 03:45:35 13 200 0 158167
Version 12.4/1.2, Retrans: 3, Retries: 0, Prefixes: 3419
1 10.20.5.2 Eth3/11 12 03:45:36 18 200 0 158158
Version 12.4/1.2, Retrans: 7, Retries: 0, Prefixes: 3419
0 10.20.6.2 Eth3/12 10 03:45:36 14 200 0 158163
Version 12.4/1.2, Retrans: 5, Retries: 0, Prefixes: 3419
switch#
 

 
関連コマンド

コマンド
説明

clear ip eigrp neighbors

EIGRP のネイバーをクリアします。

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

show ip eigrp route

Enhanced Interior Gateway Routing Protocol(EIGRP)ルートを表示するには、任意のモードで show ip eigrp route-map statistics コマンドを使用します。

show ip eigrp [ instance-tag ] route [ ip-prefix / length ] [ active ] [ all-links ] [ detail-links ] [ pending ] [ summary ] [ zero-successors ] [ vrf { vrf-name | all | default | management }]

 
構文の説明

instance-tag

(任意)EIGRP インスタンスの名前。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ip-prefix / length

(任意)スラッシュ(/)と数字で表示されたネットワーク マスクを使用した、4 つの部分からなるドット付き 10 進表記の IP アドレス。たとえば、/8 は、マスクの最初の 8 ビットが 1 であり、アドレスの対応するビットはネットワーク アドレスであることを示します。

active

(任意)EIGRP トポロジ テーブル内のアクティブ エントリのみ表示します。

all-links

(任意)EIGRP トポロジ テーブルのエントリをすべて表示します。

detail-links

(任意)EIGRP トポロジ テーブル内の全エントリの詳細情報を表示します。

pending

(任意)ネイバーからの更新を待機しているか、ネイバーへの応答を待機している、EIGRP トポロジ テーブル内のすべてのエントリを表示します。

summary

(任意)EIGRP トポロジ テーブルのサマリーを表示します。

zero-successors

(任意)EIGRP トポロジ テーブル内の使用可能なルートを表示します。

vrf vrf-name

(任意)VRF インスタンスの名前を指定します。 vrf-name 引数には、大文字と小文字が区別される最大 32 文字の任意の英数字文字列を指定できます。

all

(任意)すべての VRF インスタンスを指定します。

default

(任意)デフォルトの VRF を指定します。

management

(任意)管理 VRF を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP ルートを表示する例を示します。

switch# show ip eigrp route
IP-EIGRP Topology Table for AS(65535)/ID(3.1.1.1) VRF default
 
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
 
P 192.0.2.0/24, 7 successors, FD is 13056
via 192.0.2.1 (13056/12800), Ethernet2/7
via 192.0.2.5 (13056/12800), Ethernet1/26
via 192.0.2.3 (13056/12800), Ethernet3/12
via 192.0.2.6 (13056/12800), Ethernet3/11
via 192.0.2.4 (13056/12800), port-channel2000
via 192.0.2.2 (13056/12800), Ethernet2/6
via 192.0.2.7 (13056/12800), Ethernet2/5
P 192.0.2.1/24, 7 successors, FD is 13056
via 192.0.2.1 (13056/12800), Ethernet2/7
via 192.0.2.2 (13056/12800), Ethernet2/6
via 192.0.2.3 (13056/12800), Ethernet3/12
via 192.0.2.4 (13056/12800), port-channel2000
via 192.0.2.6 (13056/12800), Ethernet3/11
via 192.0.2.5 (13056/12800), Ethernet1/26
via 192.0.2.7 (13056/12800), Ethernet2/5
P 192.0.2.5/24, 7 successors, FD is 13056
via 192.0.2.1 (13056/12800), Ethernet2/7
<--Output truncated-->
switch#
 

 
関連コマンド

コマンド
説明

clear ip eigrp route-map statistics

EIGRP のルート マップ統計情報をクリアします。

show ip eigrp traffic

EIGRP トラフィックの統計情報を表示します。

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

show ip eigrp route-map statistics

Enhanced Interior Gateway Routing Protocol(EIGRP)のルート再配布統計情報を表示するには、任意のモードで show ip eigrp route-map statistics コマンドを使用します。

show ip eigrp [ instance-tag ] route-map statistics redistribute { bgp id | direct | eigrp id | ospf id | rip id | static } [ vrf { vrf-name | all | default | management }]

 
構文の説明

instance-tag

(任意)EIGRP インスタンスの名前。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

bgp

ボーダー ゲートウェイ プロトコル(BGP)のポリシー統計情報を表示します。

direct

直接接続されたルートのポリシー統計情報のみを表示します。

eigrp

EIGRP のポリシー統計情報を表示します。

ospf

OSPF プロトコルのポリシー統計情報を表示します。

rip

Routing Information Protocol(RIP)のポリシー統計情報を表示します。

static

IP スタティック ルートのポリシー統計情報を表示します。

id

bgp キーワードは、Autonomous System(AS; 自律システム)番号です。2 バイト番号の範囲は 1 ~ 65535 です。4 バイト番号の範囲は 1.0 ~ 65535.65535 です。

eigrp キーワードは、ルートの再配布元である EIGRP インスタンスの名前です。値は文字列の形式を取ります。10 進数を入力できますが、Cisco NX-OS はこれを文字列として内部に保存します。

ospf キーワードは、ルートの再配布元である OSPF インスタンスの名前です。値は文字列の形式を取ります。10 進数を入力できますが、Cisco NX-OS はこれを文字列として内部に保存します。

vrf vrf-name

(任意)VRF インスタンスの名前を指定します。 vrf-name 引数には、大文字と小文字が区別される最大 32 文字の任意の英数字文字列を指定できます。

all

(任意)すべての VRF インスタンスを指定します。

default

(任意)デフォルトの VRF を指定します。

management

(任意)管理 VRF を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP のルート マップ統計情報を表示する例を示します。

switch# show ip eigrp route-map statistics redistribute direct
C: No. of comparisions, M: No. of matches
 
route-map SVI-EIGRP permit 10
match source-protocol direct C: 129 M: 0
Total accept count for policy: 129
Total reject count for policy: 0
switch#
 

 
関連コマンド

コマンド
説明

clear ip eigrp route-map statistics

EIGRP のルート マップ統計情報をクリアします。

show ip eigrp traffic

EIGRP トラフィックの統計情報を表示します。

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

show ip eigrp topology

EIGRP トポロジ テーブルを表示するには、 show eigrp topology コマンドを使用します。

show ip eigrp [ instance-tag ] topology [ ip-address/length ] [ active | all-links | detail-links | pending | summary | zero-successors ] [ vrf { vrf-name | all | default | management }]

 
構文の説明

instance-tag

(任意)EIGRP インスタンスの名前。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

ip-address / length

(任意)スラッシュ(/)と数字で表示されたネットワーク マスクを使用した、4 つの部分からなるドット付き 10 進表記の IP アドレス。たとえば、/8 は、マスクの最初の 8 ビットが 1 であり、アドレスの対応するビットはネットワーク アドレスであることを示します。

active

(任意)EIGRP トポロジ テーブル内のアクティブ エントリのみ表示します。

all-links

(任意)EIGRP トポロジ テーブルのエントリをすべて表示します。

detail-links

(任意)EIGRP トポロジ テーブル内の全エントリの詳細情報を表示します。

pending

(任意)ネイバーからの更新を待機しているか、ネイバーへの応答を待機している、EIGRP トポロジ テーブル内のすべてのエントリを表示します。

summary

(任意)EIGRP トポロジ テーブルのサマリーを表示します。

zero-successors

(任意)EIGRP トポロジ テーブル内の使用可能なルートを表示します。

vrf vrf-name

(任意)VRF インスタンスの名前を指定します。 vrf-name 引数には、大文字と小文字が区別される最大 32 文字の任意の英数字文字列を指定できます。

all

(任意)すべての VRF インスタンスを指定します。

default

(任意)デフォルトの VRF を指定します。

management

(任意)管理 VRF を指定します。

 
コマンド デフォルト

VRF が指定されていない場合、このコマンドはデフォルトの VRF の情報を表示します。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

Diffusing Update Algorithm(DUAL; 拡散更新アルゴリズム)ステートを判断し、DUAL 問題をデバッグするには、 show ip eigrp topology コマンドを使用します。

キーワードまたは引数を指定せずに show ip eigrp topology コマンドを使用すると、Cisco NX-OS はフィジブル サクセサであるルートのみを表示します。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP トポロジ テーブルを表示する例を示します。指定された内部ルートおよび外部ルートの EIGRP メトリックが表示されます。

switch# show ip eigrp topology 192.0.2.0/24
IP-EIGRP (AS 65535): Topology entry for 192.0.2.0/24
State is Passive, Query origin flag is 1, 7 Successor(s), FD is 13056
Routing Descriptor Blocks:
192.0.2.1 (Ethernet2/7), from 192.0.2.1, Send flag is 0x0
Composite metric is (13056/12800), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 310 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 0
Administrator tag is 0 (0x00000000)
192.0.2.2 (Ethernet2/6), from 192.0.2.2, Send flag is 0x0
Composite metric is (13056/12800), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 310 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 40
Administrator tag is 0 (0x00000000)
192.0.2.3 (Ethernet3/12), from 192.0.2.3, Send flag is 0x0
Composite metric is (13056/12800), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 310 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 40
Administrator tag is 0 (0x00000000)
192.0.2.6 (Ethernet3/11), from 192.0.2.6, Send flag is 0x0
Composite metric is (13056/12800), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 310 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 40
Administrator tag is 0 (0x00000000)
192.0.2.4 (port-channel2000), from 192.0.2.4, Send flag is 0x0
Composite metric is (13056/12800), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 310 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 40
Administrator tag is 0 (0x00000000)
192.0.2.2 (Ethernet2/6), from 192.0.2.2, Send flag is 0x0
Composite metric is (13056/12800), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 310 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 40
Administrator tag is 0 (0x00000000)
192.0.2.7 (Ethernet2/5), from 192.0.2.7, Send flag is 0x0
Composite metric is (13056/12800), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 310 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 40
Administrator tag is 0 (0x00000000)
192.0.2.200 (port-channel2001), from 192.0.2.200, Send flag is 0x0
Composite metric is (13312/13056), Route is External
Vector metric:
Minimum bandwidth is 500000 Kbit
Total delay is 320 microseconds
Reliability is 200/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
External data:
Originating router is 1.1.1.1
AS number of route is 0
External protocol is OSPF, external metric is 40
Administrator tag is 0 (0x00000000)
switch#
 

次に、EIGRP トポロジ テーブル内のすべてのエントリを表示する例を示します。

switch(config)# show ip eigrp topology all-links
 

次に、EIGRP トポロジ テーブル内のすべてのエントリの詳細情報を表示する例を示します。

switch(config)# show ip eigrp topology detail-links
 

次に、トポロジ テーブルのサマリーを表示する例を示します。

switch(config)# show ip eigrp topology summary
IP-EIGRP Topology Table for AS(65535)/ID(3.1.1.1) VRF default
 
Head serial 3, next serial 15631
3536 routes, 0 pending replies, 0 dummies
IP-EIGRP(0) enabled on 8 interfaces, 8 neighbors present on 8 interfaces
Quiescent interfaces: Eth3/11 Po2000 Po2001 Eth2/7 Eth2/5 Eth2/6 Eth1/26 Eth3/12
switch#
 

次に、トポロジ テーブルのアクティブ エントリを表示する例を示します。

switch(config-if)# show ip eigrp topology active
 

次に、トポロジ テーブルのゼロ サクセサを表示する例を示します。

switch(config-router)# show ip eigrp topology zero-successors
 

次に、保留のエントリを表示する例を示します。

switch(config)# show ip eigrp topology pending

 

 
関連コマンド

コマンド
説明

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

show ip eigrp traffic

送受信される Enhanced IGRP(EIGRP)パケットの数を表示するには、 show ip eigrp traffic コマンドを使用します。

show ip eigrp [ instance-tag ] traffic [ vrf { vrf-name | all | default | management }]

 
構文の説明

instance-tag

(任意)EIGRP インスタンスの名前。インスタンス タグには最大 20 文字の英数字を使用できます。大文字と小文字を区別します。

vrf vrf-name

(任意)VRF インスタンスの名前を指定します。 vrf-name 引数には、大文字と小文字が区別される最大 32 文字の任意の英数字文字列を指定できます。

all

(任意)すべての VRF インスタンスを指定します。

default

(任意)デフォルトの VRF を指定します。

management

(任意)管理 VRF を指定します。

 
コマンド デフォルト

VRF が指定されていない場合、このコマンドはデフォルトの VRF の情報を表示します。

 
コマンド モード

任意のコマンド モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

この EIGRP インスタンスによって送受信されたパケットの数を確認するには、 show ip eigrp traffic コマンドを使用します。

また、接続またはコンフィギュレーション上の問題のために、あるノードからのパケットがネイバー ノードに到達していないかを判断するには、このコマンドが便利です。

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP トラフィック統計情報を表示する例を示します。

switch# show ip eigrp traffic
IP-EIGRP Traffic Statistics for AS 65535 VRF default
Hellos sent/received: 29838/44756
Updates sent/received: 1448/1775
Queries sent/received: 33/47
Replies sent/received: 31/31
Acks sent/received: 1759/2061
Input queue high water mark 33, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
Hello Process ID: (no process)
PDM Process ID: (no process)
switch#

 
関連コマンド

コマンド
説明

show running-config eigrp

EIGRP の実行コンフィギュレーション情報を表示します。

show running-config eigrp

IPv4 ネットワークの Enhanced Interior Gateway Routing Protocol(EIGRP)の実行コンフィギュレーションを表示するには、show running-config eigrp コマンドを使用します。

show running-config eigrp

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

EXEC モード

 
コマンド履歴

リリース
変更内容

5.0(3)N1(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、LAN Base Services ライセンスが必要です。

次に、EIGRP の実行コンフィギュレーションを表示する例を示します。

switch# show running-config eigrp
 
!Command: show running-config eigrp
!Time: Mon Feb 28 05:47:18 2011
 
version 5.0(3)N1(1)
feature eigrp
 
router eigrp Test1
autonomous-system 65535
default-metric 500000 30 200 1 1500
redistribute direct route-map SVI-EIGRP
 
interface port-channel2000
ip router eigrp Test1
 
interface port-channel2001
ip router eigrp Test1
 
interface Ethernet1/26
ip router eigrp Test1
 
interface Ethernet2/5
ip router eigrp Test1
 
interface Ethernet2/6
ip router eigrp Test1
 
interface Ethernet2/7
ip router eigrp Test1
 
interface Ethernet3/11
ip router eigrp Test1
 
interface Ethernet3/12
ip router eigrp Test1
 
 
switch#

 
関連コマンド

コマンド
説明

router ospf

OSPF インスタンスを作成します。