Cisco MDS 9000 ファミリ CLI コンフィギュレーション ガイド リリース 3.x Cisco MDS SAN-OS for Release 3.0(1) ~ 3.3(3)
コンフィギュレーション ファイルの操作
コンフィギュレーション ファイルの操作
発行日;2013/09/03 | 英語版ドキュメント(2011/01/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

コンフィギュレーション ファイルの操作

コンフィギュレーション ファイルの管理

コンフィギュレーション ファイルの表示

スイッチへのコンフィギュレーション ファイルのダウンロード

リモート サーバからの場合

外部の CompactFlash ディスク(slot0:)からの場合

外部デバイスへのコンフィギュレーション ファイルの保存

リモート サーバへの場合

外部の CompactFlash ディスク(slot0:)への場合

実行コンフィギュレーションの保存

ファブリックへのスタートアップ コンフィギュレーションの保存

スタートアップ コンフィギュレーション ファイルのロック解除

コンフィギュレーション ファイルのコピー

コンフィギュレーション ファイルのバックアップ

以前のコンフィギュレーションへのロールバック

設定された冗長モードの復元

スタンバイ スーパーバイザ モジュールのファイル システムへのアクセス

コンフィギュレーション ファイルの削除

コンフィギュレーション ファイルの操作

この章では、他のデバイスからアクセスできるように、コンフィギュレーション ファイルを使用してスイッチを初期設定する方法について説明します。この章は、次の項で構成されています。

「コンフィギュレーション ファイルの管理」

「スタンバイ スーパーバイザ モジュールのファイル システムへのアクセス」

「コンフィギュレーション ファイルの削除」

コンフィギュレーション ファイルの管理

コンフィギュレーション ファイルには、1 台または複数のスイッチを設定する場合に必要となるコマンドの一部、またはすべてを格納できます。たとえば、同じハードウェア構成の複数のスイッチに同じコンフィギュレーション ファイルをダウンロードすることにより、モジュールおよびポートを同じ設定にすることができます。

ここでは、コンフィギュレーション ファイルの使用方法および次の内容について説明します。

「コンフィギュレーション ファイルの表示」

「スイッチへのコンフィギュレーション ファイルのダウンロード」

「外部デバイスへのコンフィギュレーション ファイルの保存」

「実行コンフィギュレーションの保存」

「ファブリックへのスタートアップ コンフィギュレーションの保存」

「スタートアップ コンフィギュレーション ファイルのロック解除」

「コンフィギュレーション ファイルのコピー」

「コンフィギュレーション ファイルのバックアップ」

「以前のコンフィギュレーションへのロールバック」

「設定された冗長モードの復元」

コンフィギュレーション ファイルの表示

実行コンフィギュレーション ファイルを表示するには、 show running-config コマンドを使用します。

switch# show running-config
Building Configuration ...
interface port-channel 98
interface fc1/1
interface fc1/2
interface mgmt0
ip address 172.22.95.112 255.255.255.0
no shutdown
vsan database
vsan 2
clock summer-time Pacific 1 Sun Apr 02:00 5 Sun Oct 02:00 60
switchname switch112
 

スタートアップ コンフィギュレーション ファイルを表示するには、 show startup-config コマンドを使用します。

switch# show startup-config
interface port-channel 98
interface fc1/1
channel-group 98 force
no shutdown
interface mgmt0
ip address 172.22.95.112 255.255.255.0
boot system system-237; ep-41
boot kickstart boot-237 ep-41
ip domain-name cisco.com
 

スイッチへのコンフィギュレーション ファイルのダウンロード

別のスイッチから作成またはダウンロードされたコンフィギュレーション ファイルを使用して、Cisco MDS 9000 ファミリのスイッチを設定できます。さらに、スーパーバイザ モジュール上のブートフラッシュ デバイスにコンフィギュレーション ファイルを保存し、外部の CompactFlash ディスクに保存されたコンフィギュレーションを使用してスイッチを設定できます。

リモート サーバを使用してコンフィギュレーション ファイルのダウンロードを始める前に、次の作業を行います。

ダウンロードするコンフィギュレーション ファイルが、リモート サーバの正しいディレクトリにあることを確認します。

ファイルに対する許可が正しく設定されていることを確認します。ファイルのアクセス権は、誰でも読み取り可能に設定されている必要があります。

スイッチがリモート サーバへのルートを持つことを確認します。サブネット間でトラフィックをルーティングするルータまたはデフォルト ゲートウェイがない場合は、スイッチおよびリモート サーバは同一のサブネットワーク上にある必要があります。

ping コマンドを使用して、リモート サーバへの接続を確認します。

リモート サーバからの場合

TFTP、FTP、SCP、または SFTP を使用してリモート サーバからダウンロードしたコンフィギュレーション ファイルを使用して Cisco MDS 9000 ファミリのスイッチを設定するには、次の手順を実行します。


ステップ 1 コンソール ポートまたは Telnet セッションか SSH セッションを使用して、スイッチにログインします。

ステップ 2 copy scheme :// url system:running-config コマンドを使用して、リモート サーバからダウンロードしたコンフィギュレーション ファイルを使用してスイッチを設定します。ここで、 scheme は TFTP、FTP、SCP、または SFTP で、 url はリモート サーバ上のソース ファイルへのパスです。

コンフィギュレーション ファイルがダウンロードされ、ファイルの各行に指定されているコマンドが、順に実行されます。


 

次のコマンドを使用して、リモート サーバから実行コンフィギュレーションにコンフィギュレーション ファイルをダウンロードします。

switch# copy scheme://url system:running-config
 

外部の CompactFlash ディスク(slot0:)からの場合


) スイッチにログインしてから、物理メディアを slot0: に挿入する必要があります。


外部の CompactFlash ディスクに保存されたコンフィギュレーション ファイルを使用して Cisco MDS 9000 ファミリのスイッチを設定するには、次の手順を実行します。


ステップ 1 コンソール ポートまたは Telnet セッションか SSH セッションを使用して、スイッチにログインします。

ステップ 2 アクティブ スーパーバイザ モジュールの slot0: に CompactFlash デバイスを挿入します。

ステップ 3 cd および dir コマンドを使用して、コンフィギュレーション ファイルを検索します。(「コンフィギュレーション ファイルのコピー」を参照)。

ステップ 4 copy slot0: source file system:running-config コマンドを使用して、外部の CompactFlash ディスクに保存されたコンフィギュレーション ファイルを使用してスイッチを設定します。

ファイルが行単位で読み取られ、指定されているコマンドが実行されます。


 

次のコマンドを使用して、外部の CompactFlash から実行コンフィギュレーションにコンフィギュレーション ファイルをダウンロードします。

switch copy slot0:dns-config.cfg system:running-config
 

外部デバイスへのコンフィギュレーション ファイルの保存

内部ストレージに保存されたコンフィギュレーション ファイルをリモート サーバまたはスイッチの外部フラッシュ デバイスに保存できます。

リモート サーバへの場合

TFTP、FTP、SCP、SFTP などのリモート サーバにコンフィギュレーション ファイルを保存するには、次の手順を実行します。


ステップ 1 コンソール ポートまたは Telnet セッションか SSH セッションを使用して、スイッチにログインします。

ステップ 2 copy system:running-config scheme :// url コマンドを使用して、コンフィギュレーションを保存します。ここで、 scheme は TFTP、FTP、SCP、または SFTP で、 url はリモート サーバ上のターゲット ファイルへのパスです。


 

次のコマンドを使用して、リモート サーバに実行コンフィギュレーション ファイルを保存します。

switch# copy system:running-config scheme://url
 

次のコマンドを使用して、リモート サーバにスタートアップ コンフィギュレーション ファイルを保存します。

switch# copy nvram:startup-config scheme://url
 

外部の CompactFlash ディスク(slot0:)への場合

外部の CompactFlash デバイスにコンフィギュレーション ファイルを保存するには、次の手順を実行します。


ステップ 1 コンソール ポートから、または Telnet セッションを使用して、スイッチにログインします。

ステップ 2 copy system:running-config slot0: destination file コマンドを使用して実行コンフィギュレーション ファイルを保存するか、copy nvram:startup-config destination file を使用してスタートアップ コンフィギュレーション ファイルを保存します。


 

次のコマンドを使用して、外部 CompactFlash ディスクに実行コンフィギュレーション ファイルを保存します。

switch# copy system:running-config slot0:dns-config.cfg
 

次のコマンドを使用して、外部 CompactFlash ディスクにスタートアップ コンフィギュレーション ファイルを保存します。

switch# copy nvram:startup-config slot0:dns-config.cfg
 

実行コンフィギュレーションの保存

システム メモリに実行コンフィギュレーションを作成したあと、スタートアップ コンフィギュレーションを NVRAM に保存できます。

次の copy コマンドを使用してコンフィギュレーションを NVRAM に保存します。

switch# copy system:running-config nvram:startup-config
 

copy running-config startup-config コマンドは前のコマンドのエイリアスで、このマニュアル全体でよく使用されます。

別のスイッチによって開始されたコピー動作を取り消すには、次のコマンドを使用します。

switch# system startup-config abort
 

ローカルでファブリック全体で動作を取り消すには、コンソールまたは発信側スイッチの Telnet セッションで Ctrl+c を入力します。

「モジュール設定の保存」を参照してください。

ファブリックへのスタートアップ コンフィギュレーションの保存

Cisco Fabric Services(CFS)を使用して、ファブリック内の他のスイッチに、コンフィギュレーションをそのローカル NVRAM に保存するよう指示することができます。

次の copy コマンドを使用した NVRAM:

switch# copy running-config startup-config fabric
 

) ファブリック内のリモート スイッチが copy running-config startup-config fabric 処理に失敗している場合、要求は発信側スイッチで廃棄され、発信側スイッチの CLI セッションに障害エラーが表示されます。


show cfs application コマンドを使用して、Fabric Startup Configuration Manager(FSCM)アプリケーションがイネーブルになっていることを確認できます。

switch# show cfs application
 
---------------------------------------------------------------
Application Enabled Scope
---------------------------------------------------------------
ntp No Physical-all
fscm Yes Physical-fc
islb No Physical-fc
role No Physical-all
rscn No Logical
radius No Physical-all
fctimer No Physical-fc
syslogd No Physical-all
callhome No Physical-all
fcdomain No Logical
device-alias Yes Physical-fc
 
Total number of entries = 11
 

スタートアップ コンフィギュレーション ファイルのロック解除

スタートアップ コンフィギュレーション ファイルは、スイッチ上のアプリケーションでロックできます。スタートアップ コンフィギュレーション ファイルのロックを表示するには、次のコマンドを入力します。

switch# show system internal sysmgr startup-config locks
 

スタートアップ コンフィギュレーション ファイルのロックを解除するには、次のコマンドを入力します。

switch# system startup-config unlock 10
 

コンフィギュレーション ファイルのコピー

copy コマンドの構文を次に示し、 表 9-1 で説明します。

switch# copy scheme://server/filename scheme://server/filename
 

 

表 9-1 copy コマンドの構文

スキーム
サーバ
ファイル名

bootflash

sup-active
sup-standby
sup-1 または module-5
sup-2 または module-6
sup-local
sup-remote

ユーザ指定

slot0

--

ユーザ指定

volatile

--

ユーザ指定

nvram

--

startup-config または snapshot-config

system

--

running-config

tftp1

IPv4 アドレス、IPv6 アドレス、または DNS 名

ユーザ指定

ftp

scp(secure copy)

sftp

core

slot-number

プロセス識別番号

1.ファイルのダウンロードおよびアップロードを行う場合、TFTP 制限によって TFTP クライアントが 32 MB のファイル サイズに、一部の TFTP サーバが 16 MB のサイズに制限されます。

次に、アクティブ スーパーバイザ モジュール(Cisco MDS 9506 および Cisco MDS 9509 スイッチのスロット 5 の sup-1、または Cisco MDS 9513 スイッチのスロット 7)のブートフラッシュからスタンバイ スーパーバイザ モジュール(Cisco MDS 9506 および Cisco MDS 9509 スイッチのスロット 6 の sup-2、または CIsco MDS 9513 スイッチのスロット 8)のブートフラッシュにファイルをコピーする例を示します。

switch# copy bootflash:system_image bootflash://sup-2/system_image
 

次に、NVRAM の既存のコンフィギュレーションの内容を上書きする例を示します。

switch# copy nvram:snapshot-config nvram:startup-config
Warning: this command is going to overwrite your current startup-config.
Do you wish to continue?{y/n} [y] y
 

次に、bootflash: ファイル システムに実行コンフィギュレーションをコピーする例を示します。

switch# copy system:running-config bootflash:my-config
 

次に、IPv4 アドレスで識別された SCP サーバからブートフラッシュにシステム イメージ ファイルをコピーする例を示します。

switch# copy scp://user@10.1.7.2/system-image bootflash:system-image
 

次に、IPv4 アドレスで識別された SFTP サーバから volatile: ファイル システムにスクリプト ファイルをコピーする例を示します。

switch# copy sftp://172.16.10.100/myscript.txt volatile:myscript.txt

show version image コマンドを使用して、ダウンロードしたイメージが有効であることを確認します。


コンフィギュレーション ファイルのバックアップ

すべてのスイッチ コンフィギュレーションは、内部 system: および nvram: ファイル システムに存在します。内部ファイル システムが壊れると、コンフィギュレーションが失われるおそれがあります。コンフィギュレーション ファイルは定期的に保存およびバックアップしてください。また、新しいソフトウェア コンフィギュレーションをインストールしたり、新しいソフトウェア コンフィギュレーションに移行する前に、コンフィギュレーション ファイルをバックアップしてください。

次に、スイッチ上のあらかじめ定義された場所にスタートアップ コンフィギュレーションのスナップショットを作成する方法を示します(バイナリ ファイル)。

switch# copy nvram:startup-config nvram:snapshot-config
 

次に、bootflash: ファイル システムにスタートアップ コンフィギュレーション コピーをバックアップする方法を示します(ASCII ファイル)。

switch# copy nvram:startup-config bootflash:my-config
 

次に、TFTP サーバにスタートアップ コンフィギュレーションをバックアップする方法を示します(ASCII ファイル)。

switch# copy nvram:startup-config tftp://172.16.10.100/my-config
 

次に、bootflash: ファイル システムに実行コンフィギュレーションをバックアップする方法を示します(ASCII ファイル)。

switch# copy system:running-config bootflash:my-config
 

以前のコンフィギュレーションへのロールバック

メモリ破損などの障害が発生し、バックアップされたバージョンからコンフィギュレーションを復元することが必要になる場合があります。

次に、以前保存した実行コンフィギュレーションのスナップショット コピーにロールバックする例を示します(バイナリ ファイル)。

switch# copy nvram:snapshot-config nvram:startup-config
 

) スナップショットがすでに作成されている場合にのみ、ロール バック コマンドを発行できます。そうでない場合、「No snapshot-config found」エラー メッセージが表示されます。



copy running-config startup-config コマンドを発行するたびに、バイナリ ファイルが作成され、ASCII ファイルが更新されます。有効なバイナリ コンフィギュレーション ファイルを使用すると、ブート全体の時間が大幅に短縮されます。バイナリ ファイルはアップロードできませんが、その内容を使用して既存のスタートアップ コンフィギュレーションを上書きできます。write erase コマンドを実行すると、バイナリ ファイルが消去されます。


設定された冗長モードの復元


ヒント Cisco MDS 9509 スイッチの電源装置の冗長モードとして連結モードを設定する場合、保存されたコンフィギュレーションにロールバックする前に write erase および reload コマンド シーケンスを使用する際は注意してください。このコマンド シーケンスを使用すると、スイッチは出荷時の初期状態に戻ります。

write erase コマンドおよび reload コマンドを使用して、スイッチの設定を出荷時の初期状態に戻します。また、このシーケンスは、電源装置の冗長モード設定を冗長モード(デフォルト)に戻します。

電源装置のタイプ、入力電圧、シャーシ内のモジュール(ラインカード)数によっては、冗長モードがシステムのリブート後にラインカードの電源投入を妨げることもあります(「電源コンフィギュレーション モード」を参照)。このシーケンスを使用する場合、電源が切断されたラインカードに適用されるコマンドはスイッチ上で強制されません(実行コンフィギュレーションの一部ではありません)。

保存されたコンフィギュレーションにロール バックする前に write erase および reload コマンド シーケンスを使用する場合は、次の手順を実行します。


ステップ 1 (最初から設定されている場合は、)手動で冗長モード設定を連結モードに変更します。

ステップ 2 すべてのモジュールがオンラインになるまで待ちます(モジュール ステータスが show module コマンドへの応答で ok を表示するまで)。

ステップ 3 保存したコンフィギュレーションにロール バックします(「以前のコンフィギュレーションへのロールバック」を参照)。


 

スタンバイ スーパーバイザ モジュールのファイル システムへのアクセス

アクティブ スーパーバイザ モジュール上のセッションからスタンバイ スーパーバイザ モジュール(リモート)上のすべてのファイル システムにアクセスできます。これは、アクティブ スーパーバイザ モジュールにファイルをコピーしたら、同じファイルをスタンバイ スーパーバイザ モジュール上にも存在させる必要がある場合に役立ちます。

スタンバイ スーパーバイザ モジュールのファイルを一覧表示するには、 dir scheme ://sup-remote コマンドを使用します。

switch# dir bootflash://sup-remote
12198912 Aug 27 16:29:18 2003 m9500-sf1ek9-kickstart-mzg.1.3.0.39a.bin
1864931 Apr 29 12:41:59 2003 dplug2
12288 Apr 18 20:23:11 2003 lost+found/
12097024 Nov 21 16:34:18 2003 m9500-sf1ek9-kickstart-mz.1.3.1.1.bin
41574014 Nov 21 16:34:47 2003 m9500-sf1ek9-mz.1.3.1.1.bin
Usage for bootflash://sup-remote
67747169 bytes used
116812447 bytes free
184559616 bytes total
 

スタンバイ スーパーバイザ モジュールのファイル システムからファイルを削除するには、 delete scheme ://sup-remote を使用します。

switch# delete bootflash://sup-remote/aOldConfig.txt
 

コンフィギュレーション ファイルの削除

スイッチのメモリ ロケーションからコンフィギュレーション ファイルを削除するには、 delete コマンドを使用します。

次に、bootflash: ファイル システムからファイルを削除する例を示します。

switch# delete bootflash:dns_config.cfg
 

次に、外部 CompactFlash(slot0)ファイル システムからファイルを削除する例を示します。

switch# delete slot0:dns_config.cfg
 

次に、スロット 0 に挿入されたフラッシュ カードから test という名前のファイルを削除する例を示します。

switch# delete slot0:test
Delete slot0:test?[y/n]: y
 

次に、 my-dir 全体とその内容をすべて削除する例を示します。

switch# delete bootflash:my-dir
 

次に、スタンバイ スーパーバイザ モジュールの bootflash: にあるファイルを削除する例を示します。

switch# delete bootflash://sup-remote/aOldConfig