Cisco MDS 9000 ファミリ CLI コンフィギュレーション ガイド リリース 3.x Cisco MDS SAN-OS for Release 3.0(1) ~ 3.3(3)
インターフェイスの設定
インターフェイスの設定
発行日;2013/09/03 | 英語版ドキュメント(2011/01/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

インターフェイスの設定

ファイバ チャネル インターフェイス

第 1 世代インターフェイス設定の注意事項

インターフェイス モードの概要

E ポート

F ポート

FL ポート

NP ポート

TL ポート

TE ポート

SD ポート

ST ポート

Fx ポート

B ポート

auto モード

N ポート ID バーチャライゼーション

インターフェイス ステートの概要

管理ステート

動作ステート

理由コード

ファイバ チャネル インターフェイスの設定

正常なシャットダウン

管理ステートの設定インターフェイスの管理ステートの設定

インターフェイス モードの設定

システムのデフォルト ポート モード F の設定

ポート速度の設定

自動検知

N ポート ID バーチャライゼーションのイネーブル化

インターフェイスの説明の概要

インターフェイスの説明の設定

フレームのカプセル化の概要

受信データ フィールド サイズの概要

受信データ フィールド サイズの設定

ビーコン LED の識別

速度 LED の概要

標識モードの概要

標識モードの設定

ビット エラーしきい値の概要

スイッチ ポート 属性のデフォルト値

SFP トランスミッタ タイプの概要

インターフェイス情報の表示

プライベート ループの TL ポート

TL ポートについて

TL ポート ALPA キャッシュの概要

TL ポート情報の表示

ALPA キャッシュへのエントリの手動追加

ALPA キャッシュの内容の表示

ALPA キャッシュのクリア

バッファ クレジット

Buffer-to-Buffer Credit の概要

Buffer-to-Buffer Credit の設定

パフォーマンス バッファの概要

パフォーマンス バッファの設定

拡張 BB_credit の概要

第 1 世代スイッチング モジュールの拡張 BB_credit

第 2 世代スイッチング モジュールの拡張 BB_credit

拡張 BB_credit の設定

BB_credit 情報の表示

管理インターフェイス

管理インターフェイスの概要

管理インターフェイスの設定

管理インターフェイスの設定の表示

VSAN インターフェイス

VSAN インターフェイスの概要

VSAN インターフェイスの作成

VSAN インターフェイス情報の表示

デフォルト設定値

インターフェイスの設定

スイッチの主要な機能は、1 つのデータ リンクから別のリンクへとフレームをリレーすることです。このためには、フレームが送受信されるインターフェイスの特性を定義する必要があります。インターフェイスは、ファイバ チャネル インターフェイス、ギガビット イーサネット インターフェイス、管理インターフェイス(mgmt0)、VSAN インターフェイスのうちいずれかに設定できます。

この章では、スイッチを起動し、稼働させるための基本的なインターフェイス設定について説明します。内容は次のとおりです。

「ファイバ チャネル インターフェイス」

「プライベート ループの TL ポート」

「バッファ クレジット」

「管理インターフェイス」

「VSAN インターフェイス」

「デフォルト設定値」

mgmt0 インターフェイスの設定の詳細については、「初期設定」および「IP サービスの設定」を参照してください。

ギガビット イーサネット インターフェイスの設定の詳細については、「ギガビット イーサネット インターフェイスでの IPv4 の設定」および「ギガビット イーサネット インターフェイスでの IPv6 の設定」を参照してください。


ヒント スイッチの設定を始める前に、シャーシのモジュールが設計どおりに機能していることを確認してください。任意の時点でモジュールのステータスを確認するには、EXEC モードで show module コマンドを発行します(「モジュール ステータスの確認」を参照)。

ファイバ チャネル インターフェイス

ここでは、モード、フレームのカプセル化、SFP、速度を含む(がそれに限定されない)ファイバ チャネル インターフェイスの特性について説明します。

この項では、次のトピックについて取り上げます。

「第 1 世代インターフェイス設定の注意事項」

「インターフェイス モードの概要」

「N ポート ID バーチャライゼーション」

「インターフェイス ステートの概要」

「ファイバ チャネル インターフェイスの設定」

「正常なシャットダウン」

「インターフェイス モードの設定」

「ポート速度の設定」

「N ポート ID バーチャライゼーションのイネーブル化」

「インターフェイスの説明の概要」

「インターフェイスの説明の設定」

「フレームのカプセル化の概要」

「受信データ フィールド サイズの概要」

「受信データ フィールド サイズの設定」

「ビーコン LED の識別」

「標識モードの概要」

「ビット エラーしきい値の概要」

「スイッチ ポート 属性のデフォルト値」

「SFP トランスミッタ タイプの概要」

「インターフェイス情報の表示」

第 1 世代インターフェイス設定の注意事項

第 1 世代インターフェイス設定の注意事項は、次のハードウェアに適用されます。

32 ポートの 2 Gbps または 1 Gbps スイッチング モジュール インターフェイス

Cisco MDS 9140 および 9120 スイッチ インターフェイス

これらのホスト最適化ポートを設定する場合は、ポート モードに関する次の注意事項が適用されます。

各 4 ポートのグループの最初のポートだけを E ポートとして設定できます(ポート 1 ~ 4 の最初のポート、ポート 5 ~ 8 の 5 のポートなど)。そのグループの最初のポートが E ポートとして設定された場合は、各グループのその他の 3 つのポート(ポート 2 ~ 4、6 ~ 8 など)は使用できず、shutdown ステートのままになります。

32 ポート スイッチング モジュールで write erase コマンドを実行し、 no system default switchport shutdown コマンドを含むテキスト ファイルからスイッチに保存済み設定をコピーする場合、手動設定せずに E ポートをアップさせるには、テキスト ファイルをスイッチに再度コピーする必要があります。

その他の 3 つのポートのいずれかがイネーブルである場合は、最初のポートを E ポートとして設定できません。その他の 3 つのポートは、引き続きイネーブル状態になります。

auto モードは、Cisco 9100 シリーズの 32 ポート スイッチング モジュール、またはホスト最適化ポートで使用できません(Cisco MDS 9120 スイッチの 16 のホスト最適化ポートおよび Cisco MDS 9140 スイッチの 32 のホスト最適化ポート)。

Cisco 9100 シリーズの 32 ポート スイッチング モジュールおよびホスト最適化ポートのデフォルト ポート モードは、Fx(Fx は、F または FL にネゴシエート)です(Cisco MDS 9120 スイッチの 16 のホスト最適化ポートおよび Cisco MDS 9140 スイッチの 32 のホスト最適化ポート)。

32 ポート スイッチング モジュールでは FICON がサポートされません。


) 16 ポート スイッチング モジュールで E ポートを設定することを推奨します。32 ポート ホスト最適化スイッチング モジュールで E ポートを設定する必要がある場合は、4 ポート グループのその他 3 つのポートを使用できません。



) Cisco MDS 9100 シリーズでは、白抜き(9120 スイッチの 4 ポートおよび 9140 スイッチの 8 ポート)のポートの左端のグループは、16 ポート スイッチング モジュールのようにフル回線レートです。他のポート(9120 スイッチの 16 ポートおよび 9140 スイッチの 32 ポート)は、32 ポート スイッチング モジュールのようにホスト最適化ポートです。4 つのホスト最適化ポートの各グループのルールは、32 ポート スイッチング モジュールのルールと同じです。


インターフェイス モードの概要

スイッチ内の物理ファイバ チャネル インターフェイスはそれぞれ、複数あるポート モードのいずれかで動作できます。これらのモードは、E ポート、F ポート、FL ポート、TL ポート、TE ポート、SD ポート、ST ポート、および B ポートです(図 13-1 を参照)。これらのモードに加えて、各インターフェイスを auto ポート モードまたは Fx ポート モードに設定できます。これら 2 つのモードは、インターフェイスの初期化中にポート タイプを判別します。

図 13-1 Cisco MDS 9000 ファミリ スイッチ ポート モード

 


) デフォルトでは、インターフェイスが VSAN 1 に作成されます。「VSAN の設定と管理」を参照してください。


各インターフェイスには、管理設定と動作ステータスが対応付けられています。

管理設定は、修正を加えない限り変更されません。この設定には、管理モードで設定できる各種の属性があります。

動作ステータスは、インターフェイス速度のような指定された属性の現在のステータスを表します。このステータスは変更できず、読み取り専用です。インターフェイスがダウンの状態のときは、値の一部(たとえば、動作速度)が有効にならない場合があります。


) モジュールを取り外して同じタイプのモジュールで置き換えても、設定は保持されます。別のタイプのモジュールを挿入すると、元の設定は保持されなくなります。


次に、各インターフェイス モードの概要を示します。

E ポート

拡張ポート(E ポート)モードでは、インターフェイスがファブリック拡張ポートとして機能します。このポートを別の E ポートに接続し、2 つのスイッチ間でスイッチ間リンク(ISL)を作成できます。E ポートはフレームをスイッチ間で伝送し、ファブリックを設定および管理できるようにします。リモート N ポートおよび NL ポート宛てフレームのスイッチ間コンジットとして機能します。E ポートは、クラス 2、クラス 3、およびクラス F サービスをサポートします。

別のスイッチに接続された E ポートも、PortChannel を形成するように設定できます(「PortChannel の設定」を参照)。


) 16 ポート モジュールで E ポートを設定することを推奨します。32 ポート オーバーサブスクライブ モジュールで E ポートを設定する必要がある場合は、4 ポートのグループ(たとえばポート 1 から 4、5 から 8 など)で最初のポートだけを使用できます。その他 3 つのポートは使用できません。


F ポート

ファブリック ポート(F ポート)モードでは、インターフェイスがファブリック ポートとして機能します。このポートを N ポートとして動作する周辺装置(ホストまたはディスク)に接続できます。F ポートは、1 つの N ポートだけに接続できます。F ポートは、クラス 2 とクラス 3 サービスをサポートします。

FL ポート

ファブリック ループ ポート(FL ポート)モードでは、インターフェイスがファブリック ループ ポートとして機能します。このポートを 1 つまたは複数の NL ポート(他のスイッチの FL ポートを含む)に接続し、パブリック アービトレート型ループを形成することができます。初期化の際に 2 つ以上の FL ポートがアービトレート型ループで検出されると、1 つの FL ポートだけが動作可能になり、その他の FL ポートが不参加モードになります。FL ポートは、クラス 2 とクラス 3 サービスをサポートします。


) FL ポート モードは、4 ポートの 10 Gbps スイッチング モジュール インターフェイスでサポートされません。


NP ポート

NP ポート は、NPV モードになっているデバイスのポートであり、F ポートでコア スイッチに接続されます。NP ポートは N ポートのように動作しますが、N ポート動作を提供することに加えて、複数の物理 N ポートのプロキシとして機能します。

NP ポートおよび NPV の詳細については、「NPV の設定」を参照してください。

TL ポート

トランスレーティブ ループ ポート(TL ポート)モードでは、インターフェイスがトランスレーティブ ループ ポートとして機能します。1 つまたは複数のプライベート ループ装置(NL ポート)に接続できます。TL ポートは Cisco MDS 9000 ファミリ スイッチに特有で、FL ポートとプロパティが似ています。TL ポートは、プライベート ループ装置と次のいずれかの装置間の通信をイネーブルにします。

ファブリックの任意のスイッチに接続された装置

ファブリック内のパブリック ループにある装置

ファブリック内の異なるプライベート ループにある装置

同一プライベート ループにある装置

TL ポートは、クラス 2 とクラス 3 サービスをサポートします。

プライベート ループ装置は、アービトレート型ループに存在するレガシー装置を表します。これらの装置は同一の物理ループ上にある装置だけと通信するので、スイッチ ファブリックを認識しません(「TL ポート ALPA キャッシュの概要」を参照)。


ヒント TL ポートに接続された装置は、最大 64 のゾーン メンバーを含むゾーン内に設定することを推奨します。


) TL ポート モードは、第 2 世代スイッチング モジュール インターフェイスでサポートされません。


TE ポート

トランキング E ポート(TE ポート)モードでは、インターフェイスがトランキング拡張ポートとして機能します。別の TE ポートに接続し、2 つのスイッチ間で Extended ISL(EISL)を作成します。TE ポートは、Cisco MDS 9000 ファミリ スイッチに特有のポートです。E ポートの機能を拡張して、次の内容をサポートします。

VSAN(仮想 SAN)トランキング。

Quality of Service(QoS)パラメータの転送

ファイバ チャネル トレース(fctrace)機能

TE ポート モードでは、すべてのフレームが VSAN 情報を含む EISL フレーム フォーマットで送信されます。相互接続されたスイッチは VSAN ID を使用して、1 つまたは複数の VSAN からのトラフィックを同一の物理リンク上で多重化します。この機能は、Cisco MDS 9000 ファミリではトランキングと呼ばれます(「トランキングの設定」を参照)。TE ポートは、クラス 2、クラス 3、およびクラス F サービスをサポートします。

SD ポート

SPAN 宛先ポート(SD ポート)モードでは、インターフェイスがスイッチド ポート アナライザ(SPAN)として機能します。スイッチド ポート アナライザ(SPAN)機能は、Cisco MDS 9000 ファミリ スイッチ特有のものです。ファイバ チャネル インターフェイスを通過するネットワーク トラフィックをモニタします。このモニタリングは、SD ポートに接続された標準ファイバ チャネル アナライザ(または同様のスイッチ プローブ)を使用して行われます。SD ポートはフレームを受信しません。送信元トラフィックのコピーを送信するだけです。SPAN 機能は他の機能に割り込むことなく、SPAN 送信元ポートのネットワーク トラフィックのスイッチングに影響しません(「SPAN を使用したネットワーク トラフィックのモニタリング」 を参照)。

ST ポート

SPAN トンネル ポート(ST ポート)モードでは、インターフェイスが RSPAN ファイバ チャネル トンネルの送信元スイッチ内の入口ポートとして機能します。ST ポート モードとリモート SPAN(RSPAN)機能は、Cisco MDS 9000 ファミリ スイッチに特有の機能です。ST ポート モードに設定されている場合、インターフェイスを任意の装置に設定できないので、通常のファイバ チャネル トラフィックに使用できません(「SPAN の設定」を参照)。


) Cisco MDS 9124 ファブリック スイッチ、HP c-Class BladeSystem 用のシスコ ファブリック スイッチ、IBM BladeCenter 用のシスコ ファブリック スイッチでは、ST ポート モードがサポートされません。


Fx ポート

Fx ポートとして設定されたインターフェイスは、F ポートまたは FL ポート モードのいずれかで動作します。Fx ポート モードは、インターフェイスの初期化中に、接続された N ポートまたは NL ポートに応じて判別されます。この管理設定は、インターフェイスがその他のモードで動作するのを禁止します。たとえば、別のスイッチにインターフェイスが接続されるのを防ぎます。

B ポート

E ポートが一般的にファイバ チャネル スイッチを相互接続するのに対して、シスコ製の PA-FC-1G ファイバ チャネル ポート アダプタなど、一部の SAN 拡張装置は、ブリッジ ポート(B ポート)モデルを実装して地理的に分散したファブリックを接続します。このモデルは、T11 Standard FC-BB-2 に記載されたとおりに B ポートを使用します。

図 13-1 は、IP ネットワークによる一般的な SAN 拡張を表しています。

FCIP ピアがファイバ チャネル B ポートだけをサポートする SAN 拡張装置の場合、FCIP リンクに対して B ポート モードをイネーブルにする必要があります。B ポートがイネーブルにされている場合、E ポート機能もイネーブルにされ、共存します。B ポートをディセーブルにしても、E ポート機能はイネーブルのままです(「IP ストレージの設定」を参照)。

auto モード

auto モードに設定されたインターフェイスは、F ポート、FL ポート、E ポート、または TE ポートのいずれかのモードで動作します。ポート モードは、インターフェイスの初期設定中に決定されます。たとえば、インターフェイスがノード(ホストまたはディスク)に接続されている場合、N ポートまたは NL ポート モードに応じて F ポートまたは FL ポートとして動作します。インターフェイスがサードパーティ製のスイッチに接続されている場合、E ポート モードで動作します。インターフェイスが Cisco MDS 9000 ファミリの別のスイッチに接続されている場合、TE ポート モードとして動作します(「トランキングの設定」を参照)。

TL ポートと SD ポートは初期化中に判別されず、管理上設定されます。


) Storage Services Module(SSM)のファイバ チャネル インターフェイスは自動モードで設定できません。


N ポート ID バーチャライゼーション

N port identifier virtualization(NPIV; N ポート識別子仮想化)は単一 N ポートに複数の FC ID を割り当てる手段を提供します。この機能を使用すると、N ポート上の複数のアプリケーションが異なる ID を使用したり、アクセス コントロール、ゾーニング、ポート セキュリティをアプリケーション レベルで実装したりできます。図 13-2 に、NPIV の使用例を示します。

図 13-2 NPIV の例

 

NPIV 対応アプリケーションで複数の N ポート ID を使用できるようにするには、MDS スイッチ上のすべての VSAN で NPIV をグローバルにイネーブルにする必要があります。


) すべての N ポート ID は同じ VSAN 内で割り当てられます。


インターフェイス ステートの概要

インターフェイス ステートは、インターフェイスの管理設定および物理リンクのダイナミック ステートによって異なります。

管理ステート

管理ステートは、インターフェイスの管理設定を表します( 表 13-1 を参照)。

 

表 13-1 管理ステート

管理ステート
説明

Up

インターフェイスはイネーブルです。

Down

インターフェイスはディセーブルです。インターフェイスをシャットダウンして管理上のディセーブル状態にした場合は、物理リンク層ステートの変更が無視されます。

動作ステート

動作ステートは、インターフェイスの現在の動作ステートを示します( 表 13-2 を参照)。

 

表 13-2 動作ステート

動作ステート
説明

Up

インターフェイスは、トラフィックを要求に応じて送受信しています。このステートにするためには、インターフェイスが管理上アップの状態、インターフェイス リンク層ステートがアップの状態で、インターフェイスの初期化が完了している必要があります。

Down

インターフェイスが(データ)トラフィックを送信または受信できません。

Trunking

インターフェイスが TE モードで正常に動作しています。

理由コード

理由コードは、インターフェイスの動作ステートに左右されます( 表 13-3 を参照)。

 

表 13-3 インターフェイス ステートの理由コード

管理設定
動作ステータス
原因コード

Up

Up

なし。

Down

Down

管理上のダウン:管理のためにインターフェイスをダウンとして設定すると、インターフェイスはディセーブルになります。トラフィックが受信または送信されません。

Up

Down

表 13-4 を参照してください。


表 13-4 に示されている理由コードは一部だけです。


管理ステートが up、動作ステートが down の場合、理由コードは、動作不能理由コードに基づいて異なります( 表 13-4 を参照)。

 

表 13-4 動作不能ステートの理由コード

理由コード(長いバージョン)
説明
適用可能なモード

Link failure or not connected

物理層リンクが正常に動作していません。

All

SFP not present

Small Form-Factor Pluggable(SFP)ハードウェアが接続されていません。

Initializing

物理層リンクが正常に動作しており、プロトコル初期化が進行中です。

Reconfigure fabric in progress

ファブリックが現在再設定されています。

Offline

Cisco SAN-OS ソフトウェアは指定された R_A_TOV 時間だけ待機してから、初期化を再試行します。

Inactive

インターフェイス VSAN が削除されているか、suspended ステートにあります。

インターフェイスを正常に動作させるには、設定されたアクティブな VSAN にポートを割り当てます。

Hardware failure

ハードウェア障害が検出されました。

Error disabled

エラー条件は、管理上の注意を必要とします。さまざまな理由でインターフェイスがエラーディセーブルになることがあります。次に例を示します。

設定障害。

互換性のない BB_credit 設定。

インターフェイスを動作させるには、最初にこのステートの原因となるエラー条件を修正してから、インターフェイスを管理上のシャット ダウン状態またはイネーブル状態にします。

FC redirect failure

ファイバ チャネルのリダイレクトがルートをプログラムできないので、ポートは分離されます。

No port activation license available

ポート ライセンスがないため、ポートはアクティブでありません。

SDM failure

SDM がルートをプログラムできないので、ポートは分離されます。

Isolation due to ELP failure

ポート ネゴシエーションが失敗しました。

E ポートと TE ポートのみ

Isolation due to ESC failure

ポート ネゴシエーションが失敗しました。

Isolation due to domain overlap

Fibre Channel Domain(fcdomain)のオーバーラップ。

Isolation due to domain ID assignment failure

割り当てられたドメイン ID が無効です。

Isolation due to the other side of the link E port isolated

リンクのもう一方の端の E ポートが分離しています。

Isolation due to invalid fabric reconfiguration

ファブリックの再設定によりポートが分離されました。

Isolation due to domain manager disabled

fcdomain 機能がディセーブルです。

Isolation due to zone merge failure

ゾーン結合に失敗しました。

Isolation due to VSAN mismatch

ISL の両端の VSAN が異なります。

Nonparticipating

FL ポートがループ操作に参加できません。1 つのループ内に複数の FL ポートが存在する場合に発生します。この場合、FL ポート 1 つを除くすべてが自動的に非参加モードになります。

FL ポートおよび TL ポートだけ

PortChannel administratively down

PortChannel に所属するインターフェイスがダウンの状態です。

PortChannel インターフェイスだけ

Suspended due to incompatible speed

PortChannel に所属するインターフェイスに互換性のない速度が存在します。

Suspended due to incompatible mode

PortChannel に所属するインターフェイスに互換性のないモードが存在します。

Suspended due to incompatible remote switch WWN

不適切な接続が検出されました。PortChannel のすべてのインターフェイスが同じスイッチ ペアに接続されている必要があります。

ファイバ チャネル インターフェイスの設定

ファイバ チャネル インターフェイスを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

(注) ファイバ チャネル インターフェイスが設定された場合、自動的に一意の World Wide Name(WWN)が割り当てられます。インターフェイスの動作ステートが up の場合、ファイバ チャネル ID(FC ID)も割り当てられます。

インターフェイスの範囲を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1 - 4 , fc2/1 - 3

switch(config-if)#

ファイバ チャネル インターフェイスの範囲を選択し、インターフェイス コンフィギュレーション サブモード 3 を開始します。

(注) このコマンドでは、カンマの前後にスペースを挿入します。

HP c-Class BladeSystem 用のシスコ ファブリック スイッチおよび IBM BladeCenter 用シスコ ファブリック スイッチの場合は、ある範囲のインターフェイスを内部ポート間または外部ポート間で設定できますが、同一範囲内で両方のインターフェイス タイプを混在させることはできません。たとえば、「ベイ 1 ~ 10、ベイ 12」または「外部 0、外部 15 ~ 18」は有効な範囲ですが、「ベイ 1 ~ 5、外部 15 ~ 17」は有効な範囲ではありません。

正常なシャットダウン

ポートのインターフェイスはデフォルトでシャットダウンされます(初期設定を変更しない限り)。

Cisco SAN-OS ソフトウェアは、E ポート モードで動作しているインターフェイスの次の操作に反応してグレースフル シャットダウンを実行します。

ユーザがインターフェイスをシャットダウンした場合。

Cisco SAN-OS ソフトウェア アプリケーションが、その機能の一部としてポートのシャットダウンを実行した場合。

正常なシャットダウンでは、インターフェイスがシャットダウンされたとき、フレームが失われません。ユーザまたは Cisco SAN-OS ソフトウェアがシャットダウンを行うと、シャットダウン リンクに接続されているスイッチは相互に調整し、ポートのすべてのフレームをリンクで安全に送信してからシャットダウンします。この拡張機能により、フレーム損失の可能性が低くなります。

次の状況では、正常なシャットダウンを実行できません。

スイッチからポートを物理的に取り外した場合。

in-order-delivery(IOD)がイネーブルである場合(「順序どおりの配信」を参照)。

Min_LS_interval 間隔が 10 秒より長い場合(「FSPF のグローバル設定」を参照)。


) この E ポート インターフェイスのどちらかの側にある両方のスイッチが MDS スイッチであり、Cisco SAN-OS Release 2.0(1b) 以上を実行している場合に限り、この機能は動作します。


管理ステートの設定インターフェイスの管理ステートの設定

インターフェイスを正常にシャット ダウンするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# shutdown

インターフェイスを正常にシャットダウンし、トラフィック フローを管理上ディセーブルにします(デフォルト)。

トラフィック フローをイネーブルにするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# no shutdown

no プレフィックスが使用された場合(動作ステートは up)、管理上トラフィックを許可するようにトラフィック フローをイネーブルにします。

インターフェイス モードの設定

インターフェイス モードを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport mode F

switch(config-if)#

ポートの管理モードを設定します。動作ステートは、auto、E、F、FL、Fx、TL、または SD ポート モードに設定できます。

(注) Fx ポートとは、F ポートまたは FL ポート(ホスト接続のみ)を意味し、これには E ポートは含まれません。

switch(config-if)# switchport mode auto

switch(config-if)#

E、F、FL、または TE ポート モード(TL または SD ポート モードではない)の操作をオートネゴシエーションするようにインターフェイス モードを設定します。

(注) TL ポートおよび SD ポートを自動的に設定することはできません。このポートは管理上設定する必要があります。

(注) SSM のファイバ チャネル インターフェイスを auto モードに設定することはできません。

システムのデフォルト ポート モード F の設定

system default switchport mode F コマンドは、すべてのファイバ チャネル ポートの管理モードをモード F に設定するとともに、不要なスイッチ間リンク(ISL)の形成によるトラフィックの中断を回避します。このコマンドは、 write erase または reload の実行後の起動中に実行されるセットアップ ユーティリティの一部です。また、このコマンドをコンフィギュレーション モードでコマンドラインから実行することもできます。このコマンドは、次のポートのコンフィギュレーションを管理モード F に変更します。

ダウンしていて、アウトオブサービスではない、すべてのポート。

動作モードが F であり、管理モードが F でない、動作しているすべての F ポート

このコマンドは、次のポートの設定には影響しません。

すべてのユーザ設定のポート(ダウンしている場合でも)。

F ポート以外のアップしているすべてのポート。ただし、F ポート以外のポートがダウンしている場合、このコマンドはそれらのポートの管理モードを変更します。

例 13-1 は、このコマンドをセットアップ ユーティリティで実行する方法を示します。例 13-2 は、このコマンドをコマンドラインから実行する方法を示します。

例 13-1 セットアップ ユーティリティ

Configure default switchport mode F (yes/no) [n]: y

例 13-2 コマンドライン

switch(config)# system default switchport mode F


) ISL の一部であるポートがポート モード F に変更されないようにするには、自動モードではなくポート モード E にポートを設定します。



) このコマンドをコマンドラインから実行した場合、スイッチの動作は正常なままです。いずれのポートもフラップされません。


CLI でファイバ チャネル ポートの管理モードをモード F に設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# system default switchport mode F

ファイバ チャネル ポートの管理モードをモード F に設定します(該当する場合)。

 

switch(config)# no system default switchport mode F

ファイバ チャネル ポートの管理モードをデフォルトに設定します(ユーザ設定の場合を除く)。


) スイッチ セットアップ ユーティリティの詳細については、「初期設定」を参照してください。


ポート速度の設定

デフォルトでは、インターフェイスのポート速度はスイッチによって自動計算されます。


注意 ポート速度の変更は、中断を伴う操作です。

インターフェイスのポート速度を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc 1/1

mgmt0 インターフェイスを選択して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport speed 1000

インターフェイスのポート速度を 1000 Mbps に設定します。

数値は、Mbps 単位の速度を表します。1 Gbps インターフェイスには 1000 Mbps の速度、2 Gbps インターフェイスには 2000 Mbps の速度、4 Gbps インターフェイスには 4000 、または auto (デフォルト)を設定できます。

switch(config-if)# no switchport speed

インターフェイスの出荷時の設定( auto )管理速度に戻します。

HP c-Class BladeSystem 用の Cisco ファブリック スイッチおよび IBM BladeCenter 用 Cisco ファブリック スイッチの 内部ポート の場合、ポート速度 1 Gbps はサポートされません。オートネゴシエーションは、2 ~ 4 Gbps だけでサポートされます。BladeCenter が「T」シャーシである場合、ポート速度は 2 Gbps に固定され、オートネゴシエーションはイネーブルになりません。

自動検知

デフォルトではすべての 4 Gbps スイッチング モジュール インターフェイスで速度自動検知がイネーブルになっています。この設定を使用すると、4 Gbps スイッチング モジュールのインターフェイスは 1 Gbps、2 Gbps、または 4 Gbps の速度で動作します。専用レート モードで動作するインターフェイスに対して自動検知をイネーブルにすると、ポートが 1 Gbps または 2 Gbps の動作速度をネゴシエートした場合でも、4 Gbps 帯域幅が予約されます。

48 ポートおよび 24 ポートの 4 Gbps ファイバ チャネル スイッチング モジュールで未使用帯域幅の無駄を防ぐには、デフォルトの 4 Gbps ではなく、必要な帯域幅の 2 Gbps だけを指定します。この機能では、ポートのレート制限設定を超えなければ、ポート グループ内で未使用帯域幅が共有されます。自動検知に設定されている共有レート ポートにも、この機能を使用できます。


ヒント 2 Gbps までのトラフィックをサポートする(つまり自動検知機能がある 4 Gbps ではない)ホストを 4 Gbps スイッチング モジュールに移行するときは、最大帯域幅を 2 Gbps にして自動検知を使用します。

N ポート ID バーチャライゼーションのイネーブル化

NPIV 対応アプリケーションで複数の N ポート ID を使用できるようにするには、MDS スイッチ上のすべての VSAN で NPIV をグローバルにイネーブルにする必要があります。


) すべての N ポート ID は同じ VSAN 内で割り当てられます。


スイッチの NPIV をイネーブルまたはディセーブルにするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# npiv enable

スイッチ上のすべての VSAN の NPIV をイネーブルにします。

ステップ 3

switch(config)# no npiv enable

スイッチ上の NPIV をディセーブルにします(デフォルト)。

インターフェイスの説明の概要

インターフェイスの説明は、トラフィックを識別したり、インターフェイスの使用状況を知る場合に役立ちます。インターフェイスの説明には、任意の英数字の文字列を使用できます。

インターフェイスの説明の設定

インターフェイスの説明を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport description cisco-HBA2

インターフェイスの説明を設定します。ストリングの長さは、最大 80 文字まで可能です。

switch(config-if)# no switchport description

インターフェイスの説明をクリアします。

フレームのカプセル化の概要

switchport encap eisl コマンドは、SD ポート インターフェイスにだけ適用されます。このコマンドは、SD ポート モードにあるインターフェイスによって送信されたすべてのフレームのフレーム形式を判別します。カプセル化を EISL に設定すると、すべての発信フレームは、SPAN 送信元に関係なく EISL フレーム形式で送信されます。

switchport encap eisl コマンドは、デフォルトではディセーブルです。カプセル化をイネーブルにする場合、すべての発信フレームがカプセル化され、 show interface SD_port_interface コマンド出力に新しい行( Encapsulation is eisl )が表示されます(「フレームのカプセル化」を参照)。

受信データ フィールド サイズの概要

ファイバ チャネル インターフェイスの受信データ フィールド サイズも設定できます。デフォルトのデータ フィールド サイズが 2112 バイトの場合、フレームの長さは 2148 バイトです。

受信データ フィールド サイズの設定

ファイバ チャネル インターフェイスの受信データ フィールド サイズも設定できます。デフォルトのデータ フィールド サイズが 2112 バイトの場合、フレームの長さは 2148 バイトです。

受信データ フィールド サイズを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport fcrxbufsize 2000

選択されたインターフェイスのデータ フィールド サイズを 2000 バイトに減らします。デフォルトは 2112 バイトで、範囲は 256 ~ 2112 バイトです。

ビーコン LED の識別

図 13-3 は、16 ポート スイッチング モジュールのステータス LED、リンク LED、速度 LED を示しています。

図 13-3 Cisco MDS 9000 ファミリ スイッチのインターフェイス モード

1

ステータス LED1

3

リンク LED 1 および速度 LED2

2

1/2 Gbps ファイバ チャネル ポート グループ3

4

資産タグ4

nullnullnullnull

速度 LED の概要

各ポートの左側にはリンク LED、右側には速度 LED があります。

速度 LED では、ポート インターフェイスの速度が次のように示されます。

消灯:そのポートに接続しているインターフェイスは 1000 Mbps で機能しています。

点灯(緑):そのポートに接続しているインターフェイスは 2000 Mbps で機能しています(2 Gbps インターフェイスの場合)。

速度 LED は、標識モードがイネーブルであるかディセーブルであるかも示します。

消灯または緑で点灯:標識モードはディセーブルです。

緑で点滅:標識モードはイネーブルです。LED は 1 秒間隔で点滅します。

標識モードの概要

デフォルトの場合、標識モードはすべてのスイッチでディセーブルです。標識モードは緑の点滅で示され、指定インターフェイスの物理的な場所を識別できます。

標識モードを設定しても、インターフェイスの動作には影響しません。

標識モードの設定

指定したインターフェイスまたはインターフェイスの範囲の標識モードをイネーブルにするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport beacon

インターフェイスの標識モードをイネーブルにします。

switch(config-if)# no switchport beacon

インターフェイスの標識モードをディセーブルにします。


) インターフェイスの分離の原因となる外部ループバックが検出されると、緑の点滅が自動的に始まります。緑の点滅により、標識モード設定は無効になります。外部ループバックが削除されると、LED の状態は復元され、標識モード設定が反映されます。


ビット エラーしきい値の概要

ビット エラー レートしきい値は、パフォーマンスの低下がトラフィックに重大な影響を与える前にエラー レートの増加を検出するために、スイッチにより使用されます。

ビット エラーは、次の理由で発生することがあります。

ケーブル故障または不良

GBIC または SFP 故障または不良

GBIC または SFP は 1 Gbps で動作するように指定されているが、2 Gbps で使用されている。

GBIC または SFP は 2 Gbps で動作するように指定されているが、4 Gbps で使用されている。

長距離に短距離ケーブルが使用されている、または短距離に長距離ケーブルが使用されている。

瞬間的な同期ずれ

ケーブルの片端または両端の接続のゆるみ

片端または両端での不適切な GBIC 接続または SFP 接続

5 分間に 15 のエラー バーストが発生すると、ビット エラー レートしきい値が検出されます。デフォルトでは、しきい値に達するとスイッチはインターフェイスをディセーブルにします。 shutdown/no shutdown コマンドを発行して、インターフェイスを再度イネーブルにできます。

しきい値を超えてもインターフェイスがディセーブルにならないようにスイッチを設定できます。デフォルトの場合、しきい値によってインターフェイスはディセーブルになります。

インターフェイスのビット エラーしきい値をディセーブルにするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport ignore bit-errors

ビット エラーしきい値イベントを検出したとき、インターフェイスがディセーブルにならないようにします。

switch(config-if)# no switchport ignore bit-errors

ビット エラーしきい値イベントを検出したとき、インターフェイスがイネーブルにならないようにします。


switchport ignore bit-errors コマンドが設定されているかどうかに関係なく、ビット エラーしきい値イベントが検出されると、スイッチで syslog メッセージが生成されます。


スイッチ ポート 属性のデフォルト値

各種のスイッチ ポート属性の属性デフォルト値を設定できます。これらの属性は、この時点でそれぞれを指定しなくても、今後のすべてのスイッチ ポート設定にグローバルに適用されます。

スイッチ ポート属性を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# no system default switchport shutdown

switch(config)#

インターフェイス管理ステートのデフォルト設定を up に設定します (出荷時のデフォルト設定は down です)。

ヒント このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

switch(config)# system default switchport shutdown

switch(config)#

インターフェイス管理ステートのデフォルト設定を down に設定します。これが出荷時のデフォルト設定です。

ヒント このコマンドは、管理ステートに対してユーザ設定が存在しないインターフェイスにだけ適用されます。

switch(config)# system default switchport trunk mode auto

switch(config)#

インターフェイスの管理トランク モード ステートのデフォルト設定を auto に設定します。

(注) デフォルト設定のトランク モードは on です。

SFP トランスミッタ タイプの概要

Small Form-Factor Pluggable(SFP)ハードウェア トランスミッタは、 show interface brief コマンドで表示される際に略語で示されます。関連する SFP がシスコによって割り当てられた拡張 ID を持つ場合、 show interface コマンドと show interface brief コマンドは、トランスミッタ タイプではなく、ID を表示します。 show interface transceiver コマンドと show interface fc slot / port transceiver コマンドは、シスコがサポートする SFP に対して両方の値を表示します。 表 13-5 にコマンド出力で使用される略語の意味を示します(「インターフェイス情報の表示」を参照)。

 

表 13-5 SFP トランスミッタの略語

定義
略語
GBIC 仕様で定義される標準トランスミッタ

短波レーザー

swl

長波レーザー

lwl

コスト削減長波レーザー

lwcr

電気的

elec

Cisco がサポートする SFP に割り当てられた拡張トランスミッタ

CWDM-1470

c1470

CWDM-1490

c1490

CWDM-1510

c1510

CWDM-1530

c1530

CWDM-1550

c1550

CWDM-1570

c1570

CWDM-1590

c1590

CWDM-1610

c1610

インターフェイス情報の表示

show interface コマンドは、EXEC モードから呼び出され、インターフェイスの設定を表示します。引数を入力せずにこのコマンドを実行すると、スイッチ内に設定されたすべてのインターフェイスの情報が表示されます。例 13-3 13-10 を参照してください。

例 13-3 すべてのインターフェイスの表示

switch# show interface
fc1/1 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:0b:00:05:30:00:8d:de
Admin port mode is F
Port mode is F, FCID is 0x610000
Port vsan is 2
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 16
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
134 frames input, 8468 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
154 frames output, 46072 bytes
0 discards, 0 errors
1 input OLS, 1 LRR, 0 NOS, 0 loop inits
1 output OLS, 0 LRR, 1 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
fc1/9 is trunking
Hardware is Fibre Channel, SFP is long wave laser cost reduced
Port WWN is 20:09:00:05:30:00:97:9e
Peer port WWN is 20:0b:00:0b:5f:a3:cc:00
Admin port mode is E, trunk mode is on
Port mode is TE
Port vsan is 100
Speed is 2 Gbps
Transmit B2B Credit is 255
Receive B2B Credit is 255
Receive data field Size is 2112
Beacon is turned off
Trunk vsans (admin allowed and active) (1,100,3000)
Trunk vsans (up) (1,100,3000)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
5 minutes input rate 280 bits/sec, 35 bytes/sec, 0 frames/sec
5 minutes output rate 176 bits/sec, 22 bytes/sec, 0 frames/sec
4609939 frames input, 8149405708 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
4638491 frames output, 7264731728 bytes
0 discards, 0 errors
3 input OLS, 9 LRR, 1 NOS, 0 loop inits
9 output OLS, 7 LRR, 1 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
fc1/13 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:0d:00:05:30:00:97:9e
Admin port mode is auto, trunk mode is on
Port mode is F, FCID is 0x650100
Port vsan is 100
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 16
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
8696 frames input, 3227212 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
16799 frames output, 6782444 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
sup-fc0 is up
Hardware is Fibre Channel
Speed is 1 Gbps
139597 packets input, 13852970 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
139516 packets output, 16759004 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 

インターフェイス情報を表示するのに引数(インターフェイスの範囲、または複数の指定されたインターフェイス)を指定することもできます。次の形式でコマンドを発行して、インターフェイスの範囲を指定できます。

interface fc1/1 - 5 , fc2/5 - 7

) ダッシュ(-)とカンマ(,)の前後にはスペースが必要です。


例 13-4 複数の指定されたインターフェイスの表示

switch# show interface fc3/13 , fc3/16
fc3/13 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:8d:00:05:30:00:97:9e
Admin port mode is FX
Port mode is F, FCID is 0x7b0300
Port vsan is 1
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 12
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
1856 frames input, 116632 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
1886 frames output, 887712 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 1 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.
 
fc3/16 is up
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:90:00:05:30:00:97:9e
Admin port mode is FX
Port mode is F, FCID is 0x7d0100
Port vsan is 3000
Speed is 2 Gbps
Transmit B2B Credit is 3
Receive B2B Credit is 12
Receive data field Size is 2112
Beacon is turned off
5 minutes input rate 504 bits/sec, 63 bytes/sec, 0 frames/sec
5 minutes output rate 520 bits/sec, 65 bytes/sec, 0 frames/sec
47050 frames input, 10311824 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
62659 frames output, 10676988 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
1 output OLS, 1 LRR, 0 NOS, 1 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.

例 13-5 特定のインターフェイスの表示

switch# show interface fc2/2
fc2/2 is trunking
Port description is Trunk to Core-4
Hardware is Fibre Channel, SFP is short wave laser
Port WWN is 20:42:00:05:30:00:97:9e
Peer port WWN is 20:cc:00:05:30:00:50:9e
Admin port mode is E, trunk mode is on
Port mode is TE
Port vsan is 1
Speed is 2 Gbps
Transmit B2B Credit is 255
Receive B2B Credit is 255
Receive data field Size is 2112
Beacon is turned off
Belongs to port-channel 2
Trunk vsans (admin allowed and active) (1,100,3000)
Trunk vsans (up) (1)
Trunk vsans (isolated) (100,3000)
Trunk vsans (initializing) ()
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 32 bits/sec, 4 bytes/sec, 0 frames/sec
2214834 frames input, 98673588 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
2262415 frames output, 343158368 bytes
0 discards, 0 errors
1 input OLS, 1 LRR, 1 NOS, 0 loop inits
2 output OLS, 1 LRR, 0 NOS, 0 loop inits
16 receive B2B credit remaining
3 transmit B2B credit remaining.

例 13-6 ポートの説明の表示

switch# show interface description
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
fc3/1 test intest
fc3/2 --
fc3/3 --
fc3/4 TE port
fc3/5 --
fc3/6 --
fc3/10 Next hop switch 5
fc3/11 --
fc3/12 --
fc3/16 --
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
port-channel 1 --
port-channel 5 --
port-channel 6 --

例 13-7 要約形式でのインターフェイス情報の表示

switch# show interface brief
 
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc1/1 1 E on trunking swl TE 2 1
fc1/2 1 E on trunking swl TE 2 1
fc1/3 1 auto on SFPAbsent -- -- --
fc1/4 1 auto on SFPAbsent -- -- --
fc1/5 3000 auto on up swl F 2 --
...
fc2/2 1 E on trunking swl TE 2 2
fc2/3 1 auto on down c1610 -- --
fc2/4 1 auto on down c1590 -- --
fc2/5 3000 auto on notConnected lwcr -- --
fc2/6 1 auto on SFPAbsent -- -- --
...
fc3/16 3000 FX -- up swl F 2 --
fc3/17 1 FX -- SFPAbsent -- -- --
...
-------------------------------------------------------------------------------
Interface Status IP Address Speed MTU
-------------------------------------------------------------------------------
GigabitEthernet4/1 SFPAbsent -- auto 1500
...
GigabitEthernet4/6 down 10.1.1.2/8 auto 3000
GigabitEthernet4/7 down 10.1.1.27/24 auto 1500
GigabitEthernet4/8 down -- auto 1500
 
-------------------------------------------------------------------------------
Interface Status Oper Mode Oper Speed
(Gbps)
-------------------------------------------------------------------------------
iscsi4/1 down --
...
-------------------------------------------------------------------------------
Interface Status Speed
(Gbps)
-------------------------------------------------------------------------------
sup-fc0 up 1
 
-------------------------------------------------------------------------------
Interface Status IP Address Speed MTU
-------------------------------------------------------------------------------
mgmt0 up 172.19.48.96/25 100 Mbps 1500
 
-------------------------------------------------------------------------------
Interface Vsan Admin Status Oper Oper
Trunk Mode Speed
Mode (Gbps)
-------------------------------------------------------------------------------
port-channel 1 1 on trunking TE 4
port-channel 2 1 on trunking TE 4
 
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status Oper Profile Port-channel
Mode Trunk Mode
Mode
-------------------------------------------------------------------------------
fcip10 1 auto on notConnected -- 10 --

例 13-8 インターフェイス カウンタの表示

switch# show interface counters
fc3/1
5 minutes input rate 24 bits/sec, 3 bytes/sec, 0 frames/sec
5 minutes output rate 16 bits/sec, 2 bytes/sec, 0 frames/sec
3502 frames input, 268400 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
3505 frames output, 198888 bytes
0 discards
1 input OLS, 1 LRR, 1 NOS, 0 loop inits
2 output OLS, 1 LRR, 1 NOS, 0 loop inits
1 link failures, 1 sync losses, 1 signal losses
.
.
.
fc9/8
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 frames input, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
0 frames output, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
0 link failures, 0 sync losses, 0 signal losses
16 receive B2B credit remaining
3 transmit B2B credit remaining.
...
sup-fc0
114000 packets input, 11585632 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
113997 packets output, 10969672 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 
mgmt0
31557 packets input, 2230860 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
26618 packets output, 16824342 bytes, 0 underruns
0 output errors, 0 collisions, 7 fifo
0 carrier errors
 
vsan1
0 packets input, 0 bytes, 0 errors, 0 multicast
0 packets output, 0 bytes, 0 errors, 0 dropped
.
.
.
port-channel 1
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 frames input, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards, 0 CRC, 0 unknown class
0 too long, 0 too short
0 frames output, 0 bytes
0 class-2 frames, 0 bytes
0 class-3 frames, 0 bytes
0 class-f frames, 0 bytes
0 discards
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
0 link failures, 0 sync losses, 0 signal losses
 

) インターフェイス 9/8 および 9/9 は、トランキング ポートではなく、クラス 2、3、および F 情報を表示します。


例 13-9 要約形式でのインターフェイス カウンタの表示

switch# show interface counters brief
 
-------------------------------------------------------------------------------
Interface Input (rate is 5 min avg) Output (rate is 5 min avg)
----------------------------- -----------------------------
Rate Total Rate Total
Mbits/s Frames Mbits/s Frames
-------------------------------------------------------------------------------
fc3/1 0 3871 0 3874
fc3/2 0 3902 0 4232
fc3/3 0 3901 0 4138
fc3/4 0 3895 0 3894
fc3/5 0 3890 0 3897
fc9/8 0 0 0 0
fc9/9 0 5 0 4
fc9/10 0 4186 0 4182
fc9/11 0 4331 0 4315
 
-------------------------------------------------------------------------------
Interface Input (rate is 5 min avg) Output (rate is 5 min avg)
----------------------------- -----------------------------
Rate Total Rate Total
Mbits/s Frames Mbits/s Frames
-------------------------------------------------------------------------------
port-channel 1 0 0 0 0
port-channel 2 0 3946 0 3946
 

show interface transceiver コマンドは、Cisco MDS 9100 シリーズのスイッチで、SFP が存在する場合のみ実行できます(例 13-10 を参照)。


例 13-10 トランシーバ情報の表示

switch# show interface transceiver
fc1/1 SFP is present
name is CISCO-AGILENT
part number is QFBR-5796L
revision is
serial number is A00162193
fc-transmitter type is short wave laser
cisco extended id is unknown (0x0)
...
fc1/9 SFP is present
name is FINISAR CORP.
part number is FTRJ-1319-7D-CSC
revision is
serial number is H11A6ER
fc-transmitter type is long wave laser cost reduced
cisco extended id is unknown (0x0)
...
 

例 13-11 では、すべてのインターフェイスの情報を含む実行コンフィギュレーション全体を表示しています。スイッチがリロードしたとき、インターフェイス コンフィギュレーション コマンドが正しい順序で実行するように、インターフェイスはコンフィギュレーション ファイルに複数のエントリを持っています。

例 13-11 全インターフェイスの実行コンフィギュレーションの表示

switch# show running-config
...
interface fc9/1
switchport speed 2000
...
interface fc9/1
switchport mode E
...
interface fc9/1
channel-group 11 force
no shutdown
 

例 13-12 では、指定したインターフェイスの実行コンフィギュレーション情報を表示しています。インターフェイス コンフィギュレーション コマンドがグループ化されます。

例 13-12 指定したインターフェイスの実行コンフィギュレーションの表示

switch# show running-config interface fc1/1
interface fc9/1
switchport speed 2000
switchport mode E
channel-group 11 force
no shutdown
 

例 13-13 では、 system default switchport mode F コマンドを実行した後の実行コンフィギュレーションを表示しています。例 13-14 では、2 つのインターフェイスを個別にモード FL に設定した後の実行コンフィギュレーションを表示しています。

例 13-13 system default switchport mode F コマンド実行後の実行コンフィギュレーションの表示

switch# show running-config
version 3.1(3)
system default switchport mode F
interface fc4/1
interface fc4/2
interface fc4/3
interface fc4/4
interface fc4/5
interface fc4/6
interface fc4/7
interface fc4/8
interface fc4/9
interface fc4/10

例 13-14 2 つのインターフェイスを個別にモード FL に設定した後の実行コンフィギュレーションの表示

switch# show running-config
version 3.1(3)
system default switchport mode F
interface fc4/1
switchport mode FL
interface fc4/2
interface fc4/3
switchport mode FL
interface fc4/4
interface fc4/5
interface fc4/6
interface fc4/7
interface fc4/8
interface fc4/9
interface fc4/1
 

例 13-15 では、 system default switchport mode F コマンドを実行した後のインターフェイス情報を要約形式で表示しています。例 13-16 では、2 つのインターフェイスを個別にモード FL に設定した後のインターフェイス情報を要約形式で表示しています。

例 13-15 system default switchport mode F コマンド実行後のインターフェイス情報の要約形式での表示

switch# sh int brief
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc4/1 1 F -- notConnected swl -- --
fc4/2 1 F -- notConnected swl -- --
fc4/3 1 F -- notConnected swl -- --
fc4/4 1 F -- notConnected swl -- --
fc4/5 1 F -- sfpAbsent -- -- --
fc4/6 1 F -- sfpAbsent -- -- --
fc4/7 1 F -- sfpAbsent -- -- --
fc4/8 1 F -- sfpAbsent -- -- --
fc4/9 1 F -- sfpAbsent -- -- --

例 13-16 2 つのインターフェイスを個別にモード FL に設定した後のインターフェイス情報の要約形式での表示

switch# show interface brief
 
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status SFP Oper Oper Port
Mode Trunk Mode Speed Channel
Mode (Gbps)
-------------------------------------------------------------------------------
fc4/1 1 FL -- notConnected swl -- --
fc4/2 1 F -- notConnected swl -- --
fc4/3 1 FL -- notConnected swl -- --
fc4/4 1 F -- notConnected swl -- --
fc4/5 1 F -- sfpAbsent -- -- --
fc4/6 1 F -- sfpAbsent -- -- --
fc4/7 1 F -- sfpAbsent -- -- --
fc4/8 1 F -- sfpAbsent -- -- --
fc4/9 1 F -- sfpAbsent -- -- --
fc4/10 1 F -- sfpAbsent -- -- --

プライベート ループの TL ポート

プライベート ループでは、インターフェイス モードを TL に設定する必要があります。ここでは、TL ポートについて説明します。ここで説明する内容は、次のとおりです。

「TL ポートについて」

「TL ポート ALPA キャッシュの概要」

「TL ポート情報の表示」

「ALPA キャッシュへのエントリの手動追加」

「ALPA キャッシュの内容の表示」

「ALPA キャッシュのクリア」

TL ポートについて

以下では TL ポート モードがサポートされていません。

第 2 世代スイッチング モジュール インターフェイス

Cisco MDS 9124 ファブリック スイッチ

HP c-Class BladeSystem 用の Cisco ファブリック スイッチ

IBM BladeCenter 用のシスコ ファブリック スイッチ

プライベート ループ装置は、アービトレート型ループに存在するレガシー装置を表します。これらの装置は同一の物理ループ上にある装置だけと通信するので、スイッチ ファブリックを認識しません。

レガシー装置をファイバ チャネル ネットワークで使用し、ループ外のデバイスがレガシー装置とやり取りしなければならないことがあります。通信機能は TL ポートで提供されます。「インターフェイス モードの概要」を参照してください。

プライベート ループを設定する場合、次の注意事項に従ってください。

最大 64 のファブリック デバイスをプライベート ループにプロキシできます。

ファブリック デバイスは、プライベート ループ デバイスと同じゾーンに存在しないと、プライベート ループにプロキシされません。

TL ポートの各プライベート デバイスは、別のゾーンに含めることができます。

ループのすべてのデバイスはプライベート ループとして扱われます。設定ポート モードが TL である場合は、プライベートおよびパブリックのデバイスをループで混在させることはできません。

TL ポートでサポートされる FC4 タイプは SCSI(FCP)だけです。

同一プライベート ループに存在するプライベート イニシエータからプライベート ターゲットへのやり取りでは、TL ポート サービスが起動されません。

表 13-6 は、Cisco MDS 9000 ファミリ スイッチでサポートされている TL ポート変換を示しています。図 13-4 は、TL ポート変換のサポート例です。

 

表 13-6 サポートされている TL ポート変換

変換元
変換先

プライベート イニシエータ

プライベート ターゲット

I1 から T1 またはその反対

プライベート イニシエータ

パブリック ターゲット:N ポート

I1 から T2 またはその反対

プライベート イニシエータ

パブリック ターゲット:NL ポート

I4 から T3 またはその反対

パブリック イニシエータ:N ポート

プライベート ターゲット

I2 から T1 またはその反対

パブリック イニシエータ:NL ポート

プライベート ターゲット

I3 から T1 またはその反対

図 13-4 TL ポート変換のサポート例

 

TL ポート ALPA キャッシュの概要

TL ポートは自動的に設定できませんが、Arbitrated Loop Physical Address(ALPA)キャッシュにエントリを手動で設定できます。一般的には、ALPA をデバイスに割り当てると、ALPA キャッシュ エントリが自動的に入力されます。各デバイスは、Port World Wide Name(pWWN)によって識別します。デバイスに ALPA を割り当てると、そのデバイスのエントリが ALPA キャッシュで自動的に作成されます。

キャッシュには、最近割り当てられた ALPA 値のエントリが含まれます。このキャッシュはさまざまな TL ポートで維持されます。デバイスに ALPA がすでに存在する場合、Cisco SAN-OS ソフトウェアは同じ ALPA をデバイスに毎回割り当てようとします。ALPA キャッシュは永続ストレージに維持され、スイッチをリブートしても情報は保存されます。最大キャッシュ サイズは 1000 エントリです。キャッシュがいっぱいになって新しい ALPA が割り当てられると、Cisco SAN-OS ソフトウェアはアクティブでないキャッシュ エントリがある場合はそれを廃棄し、新しいエントリ用にスペースを作成します。TL ポートの詳細については、「TL ポート」を参照してください。

TL ポート情報の表示

プライベート ループ装置は、アービトレート型ループに存在するレガシー装置を表します。これらの装置は同一の物理ループ上にある装置だけと通信するので、スイッチ ファブリックを認識しません。

レガシー装置をファイバ チャネル ネットワークで使用し、ループ外のデバイスがレガシー装置とやり取りしなければならないことがあります。通信機能は TL ポートで提供されます。

TL ポートを設定するには、 switchport mode コマンドを使用します(「インターフェイス モードの設定」を参照)。

show tlport コマンドは、TL ポート インターフェイスの設定を表示します。このコマンドは、スイッチに設定されているすべての TL ポートのリストを出力し、関連付けられている VSAN、ポートの FC ID(ドメインおよびエリアのみ有効)、および TL ポートの現在の動作ステート(アップ状態か初期化中か)を表示します。例 13-17例 13-20 を参照してください。

例 13-17 すべての VSAN の TL ポートの表示

switch# show tlport list
-------------------------------
Interface Vsan FC-ID State
------------------------- ------
fc1/16 1 0x420000 Init
fc2/26 1 0x150000 Up
 

TL ポートにより、ファブリック デバイスをループにプロキシすることで、プライベート デバイス(ループ上に物理的に存在するデバイス)とファブリック デバイスが互いを認識できるようになります。ファブリック デバイスをプロキシするには、各ファブリック デバイスにループの ALPA を割り当てます。

これらのプロキシされたデバイスに加え、他の仮想デバイス(ローカルまたはリモート ドメイン コントローラ アドレス)にもループの ALPA を割り当てます。スイッチはプライベート デバイスとの通信用に ALPA を予約しており、SCSI イニシエータとして機能します。

show tlport interface コマンド出力の最初のカラムは、ループ上のデバイスの ALPA ID です。後続のカラムには、ポート WWN、各デバイスのノード WWN、SCSI イニシエータまたはターゲットとしてのデバイス、およびデバイスの実 FC ID が含まれます。

例 13-18 特定の TL ポートに関する詳細情報の表示

switch# show tlport interface fc1/16 all
fc1/16 is up, vsan 1, FCID 0x420000
--------------------------------------------------------------------------------
alpa pWWN nWWN SCSI Type Device FC-ID
--------------------------------------------------------------------------------
0x01 20:10:00:05:30:00:4a:de 20:00:00:05:30:00:4a:de Initiator Proxied 0xfffc42
0x73 22:00:00:20:37:39:ae:54 20:00:00:20:37:39:ae:54 Target Private 0x420073
0xef 20:10:00:05:30:00:4a:de 20:00:00:05:30:00:4a:de Initiator Switch 0x0000ef

例 13-19 プライベート デバイスの TL ポート情報の表示

switch# show tlport interface fc 1/16 private
fc1/16 is up, vsan 1, FCID 0x420000
------------------------------------------------------------------------
alpa pWWN nWWN SCSI Type FC-ID ------------------------------------------------------------------------
0x73 22:00:00:20:37:39:ae:54 20:00:00:20:37:39:ae:54 Target 0x420073
0x74 22:00:00:20:37:38:d3:de 20:00:00:20:37:38:d3:de Target 0x420074

例 13-20 プロキシされたデバイスの TL ポート情報の表示

switch# show tlport interface fc 1/16 proxied
fc1/16 is up, vsan 1, FCID 0x420000
------------------------------------------------------------------------
alpa pWWN nWWN SCSI Type FC-ID ------------------------------------------------------------------------
0x01 20:10:00:05:30:00:4a:de 20:00:00:05:30:00:4a:de Initiator 0xfffc42
0x02 21:00:00:e0:8b:01:95:e7 20:00:00:e0:8b:01:95:e7 Initiator 0x420100
 

ALPA キャッシュへのエントリの手動追加

手動で ALPA キャッシュにエントリを挿入するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# tlport alpa-cache interface fc1/2 pwwn 22:00:00:20:37:46:09:bd alpa 0x02

ALPA キャッシュへのエントリの手動追加を設定します。

ステップ 3

switch(config)# tlport alpa-cache interface fc1/3 pwwn 22:00:00:20:37:46:09:bd

ALPA キャッシュからこのエントリを削除します。

ALPA キャッシュの内容の表示

show tlport alpa-cache コマンドは、ALPA キャッシュの内容を表示します。

switch# show tlport alpa-cache
---------------------------------------------------------
alpa pWWN Interface
---------------------------------------------------------
0x02 22:00:00:20:37:46:09:bd fc1/2
0x04 23:00:00:20:37:46:09:bd fc1/2
 

最初のエントリは、pWWN が 22:00:00:20:37:46:09:bd であるデバイスが TL ポート fc1/2 にエクスポートされ、その後 pWWN に ALPA 0x02(使用可能な場合)が割り当てられることを示しています。

ALPA キャッシュのクリア

clear tlport alpa-cache コマンドは、ALPA キャッシュの内容全体をクリアします。

バッファ クレジット

ファイバ チャネル インターフェイスでは、すべてのパケットを送信先に確実に配信するために、バッファ クレジットが使用されます。ここでは、Cisco MDS ファミリ スイッチで使用可能なさまざまなバッファ クレジットについて説明します。ここで説明する内容は次のとおりです。

「Buffer-to-Buffer Credit の概要」

「Buffer-to-Buffer Credit の設定」

「パフォーマンス バッファの概要」

「パフォーマンス バッファの設定」

「拡張 BB_credit の概要」

「拡張 BB_credit の設定」

「BB_credit 情報の表示」

Buffer-to-Buffer Credit の概要

Buffer-to-Buffer credit(BB_credit)はフロー制御メカニズムで、スイッチがフレームを廃棄できない場合に、FC スイッチがバッファ不足にならないようにします。BB_credit は、ホップごとにネゴシエーションします。

receive BB_credit( fcrxbbcredit )値を各 FC インターフェイスに設定できます。ほとんどの場合、デフォルト設定を変更する必要がありません。


) 受信 BB_credit 値は、モジュール タイプおよびポート モードによって次のように決まります。

16 ポート スイッチング モジュールおよびフル レート ポートの場合、デフォルト値は、FX モードで 16、E モードまたは TE モードで 255 です。最大値は、すべてのモードで 255 です。必要に応じて、この値を変更できます。

32 ポート スイッチング モジュールおよびホスト最適化ポートの場合、デフォルト値は、FX モード、E モード、TE モードで 12 です。この値は変更できません。

第 2 世代スイッチング モジュールについては、「バッファ プール」を参照してください。


) Cisco MDS 9100 シリーズでは、白抜き(9120 スイッチの 4 ポートおよび 9140 スイッチの 8 ポート)のポートの左端のグループは、16 ポート スイッチング モジュールのようにフル回線レートです。他のポート(9120 スイッチの 16 ポートおよび 9140 スイッチの 32 ポート)は、32 ポート スイッチング モジュールのようにホスト最適化ポートです。4 つのホスト最適化ポートの各グループのルールは、32 ポート スイッチング モジュールのルールと同じです。


Buffer-to-Buffer Credit の設定

ファイバ チャネル インターフェイスの BB_credit を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport fcrxbbcredit default

デフォルトの使用可能な値を選択されたインターフェイスに適用します。使用可能な値は、ポート モードによって異なります。デフォルト値は、ポート機能に応じて割り当てられます。

switch(config-if)# switchport fcrxbbcredit 5

選択されたインターフェイスの BB_credit を 5 に割り当てます。BB_credit を割り当てる範囲は、1 ~ 255 です。

switch(config-if)# switchport fcrxbbcredit 5 mode E

ポートが E モードまたは TE モードで動作する場合は、この値を割り当てます。BB_credit を割り当てる範囲は、1 ~ 255 です。

switch(config-if)# switchport fcrxbbcredit 5 mode Fx

ポートが F モードまたは FL モードで動作する場合は、この値を割り当てます。BB_credit を割り当てる範囲は、1 ~ 255 です。

ステップ 4

switch(config-if# do show int fc1/1

fc1/1 is up

...

16 receive B2B credit remaining

3 transmit B2B credit remaining

送受信の BB_credit をこのインターフェイスのその他の関連インターフェイス情報とともに表示します。

(注) レジスタが読み取られるとき、BB_credit は正しい値です。データ トラフィックが遅いときに状況を確認するのに役立ちます。

パフォーマンス バッファの概要


) Cisco MDS 9124 ファブリック スイッチ、HP c-Class BladeSystem 用のシスコ ファブリック スイッチ、IBM BladeCeter 用のシスコ ファブリック スイッチでは、パフォーマンス バッファがサポートされません。


設定された受信 BB_credit 値に関係なく、パフォーマンス バッファと呼ばれるもう 1 つのバッファがスイッチ ポート パフォーマンスを改善します。組み込み型のスイッチ アルゴリズムを利用するのではなく、特定のアプリケーションにパフォーマンス バッファ値を手動で設定できます(たとえば、FCIP インターフェイス上でフレームを転送する場合など)。

任意の Cisco MDS 9000 ファミリ スイッチの各物理ファイバ チャネル インターフェイスに、設定された rxbbredit 値に加えて、割り当てるパフォーマンス バッファ サイズを指定できます。

デフォルトのパフォーマンス バッファ値は 0 です。 default オプションを使用すると、組み込み型のアルゴリズムが使用されます。このコマンドを指定しない場合、自動的に default オプションが使用されます。

パフォーマンス バッファの設定

ファイバ チャネル インターフェイスのパフォーマンス バッファを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# switchport fcrxbbcredit performance-buffers 45

選択されたインターフェイスのパフォーマンス バッファを 45 に割り当てます。値の範囲は 1 ~ 145 です。

switch(config-if)# switchport fcrxbbcredit performance-buffers default

組み込み型のアルゴリズムを使用する出荷時のデフォルトに戻します。


) パフォーマンス バッファ値および BB_credit の他の情報を表示するには、show interface bbcredit コマンドを使用します。


拡張 BB_credit の概要

長距離リンクには、BB_credit に加えて拡張 BB_credit フロー制御メカニズムを使用できます。

この項では、次のトピックについて取り上げます。

「第 1 世代スイッチング モジュールの拡張 BB_credit」

「第 2 世代スイッチング モジュールの拡張 BB_credit」

第 1 世代スイッチング モジュールの拡張 BB_credit

BB_credit 機能では、第 1 世代スイッチング モジュールに最大 255 の受信バッファを設定できます。長距離リンクの BB_credit を容易にするため、第 1 世代スイッチング モジュールのファイバ チャネル ポートで最大 3,500 の受信 BB_credit を設定できます。

第 1 世代スイッチング モジュールでこの機能を使用するには、次の要件を満たす必要があります。

ENTERPRISE_PKG ライセンスを取得する(「ライセンスの入手とインストール」を参照)。

Cisco MDS 9216i スイッチまたは MPS-14/2 モジュールにおいて、フルレートの 4 ポート グループに含まれる任意のポートでこの機能を設定する(図 13-5 を参照)。

図 13-5 拡張 BB_credit 機能のポート グループ サポート

 

拡張クレジット設定をサポートするポート グループは次のとおりです。

ポート 1 から 4(図 13-1 のグループ 1)のうちいずれかのポート

ポート 5 から 8(図 13-1 のグループ 2)のうちいずれかのポート

ポート 9 から 12(図 13-1 のグループ 3)のうちいずれかのポート


) 最後の 2 つのファイバ チャネル ポート(ポート 13 およびポート 14)および 2 つのギガビット イーサネット ポートでは、拡張 BB_credit 機能がサポートされません(図 13-1 を参照)。


必要な Cisco MDS スイッチでこの機能を明示的にイネーブルにする。

2,400 より多い BB_credit をポート グループの最初のポートに割り当てる必要がある場合は、4 ポート グループの残り 3 つのポートをディセーブルにする。

2,400 より少ない拡張 BB_credit をポート グループの 1 つのポートに割り当てる場合、そのポート グループの残り 3 つのポートでは、ポート モードに基づいて最大 255 の BB_credit をポート モードで保持できます。


) 残り 3 つのポートの受信 BB_credit 値は、ポート モードによって決まります。デフォルト値は、Fx モードでは 16、E モードまたは TE モードでは 255 です。最大値は、すべてのモードで 255 です。この値は、最大値の 255 の BB_credit を超えなければ、必要に応じて変更できます。


2,400 より多い(最大 3,500)拡張 BB_credit をポート グループのポートに割り当てる場合は、その他 3 つのポートをディセーブルにする必要があります。

BB_credit 値を変更すると、ポートがディセーブルになってから再びイネーブルになることに注意する。

中断を伴わずに Cisco SAN-OS Release 1.3 以下にダウングレードする必要がある場合は、この機能を(明示的に)ディセーブルにする。この機能をディセーブルにすると、既存の拡張 BB_credit 設定は完全に消去されます。


) 拡張 BB_credit 設定は、受信 BB_credit およびパフォーマンス バッファの設定より優先されます。


第 2 世代スイッチング モジュールの拡張 BB_credit

第 2 世代スイッチング モジュールでこの機能を使用するには、次の要件を満たす必要があります。

エンタープライズ パッケージ(ENTERPRISE_PKG)ライセンスを取得する(「ライセンスの入手とインストール」を参照)。

第 2 世代スイッチ モジュールの任意のポートでこの機能を設定する。第 2 世代スイッチング モジュールにおける拡張 BB_credit の詳細については、「拡張 BB_credit」を参照してください。


) Cisco MDS 9124 ファブリック スイッチでは拡張 BB_credit がサポートされません。


拡張 BB_credit の設定

MDS-14/2 インターフェイス、第 2 世代スイッチング モジュール インターフェイス(Cisco MDS 9124 ファブリック スイッチを除く)、または Cisco MDS 9216i スイッチのインターフェイスで拡張 BB_credit を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# fcrxbbcredit extended enable

拡張 BB_credit 機能をイネーブルにします。

switch(config)# no fcrxbbcredit extended enable

拡張 BB_credit 機能をディセーブルにします(デフォルト)。

ステップ 3

switch(config)# interface fc1/1

switch(config-if)#

ファイバ チャネル インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 4

switch(config-if)# switchport fcrxbbcredit extended 1500

選択されたインターフェイスに拡張 BB_credit 値として 1,500 クレジットを適用します。有効な範囲は 256 ~ 3,500 クレジットです。

switch(config-if)# no switchport fcrxbbcredit extended 1500

このポートの拡張 BB_credit 設定をクリアします。

ステップ 5

switch# do show interface fc3/2

fc3/2 is trunking

Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)

Port WWN is 20:82:00:05:30:00:2a:1e

Peer port WWN is 20:42:00:0b:46:79:f1:80

Admin port mode is auto, trunk mode is on

Port mode is TE

Port vsan is 1

Speed is 2 Gbps

Transmit B2B Credit is 255

Receive B2B Credit is 1500

Receive data field Size is 2112

...

インターフェイスがアップ状態の場合に、このインターフェイスの送受信 BB_credit 値とその他の関連インターフェイス情報を表示します。

(注) 受信 BB_credit 値には、拡張 BB_credit 設定が反映されます(該当する場合)。

BB_credit 情報の表示

BB_credit 情報を表示するには、 show interface bbcredit コマンドを使用します(例 13-21 および例 13-22 を参照)。

例 13-21 BB_credit 情報の表示

switch# show interface bbcredit
fc2/1 is down (SFP not present)
...
fc2/17 is trunking
Transmit B2B Credit is 255
Receive B2B Credit is 12
Receive B2B Credit performance buffers is 375
12 receive B2B credit remaining
255 transmit B2B credit remaining
fc2/18 is down (SFP not present)
fc2/19 is down (SFP not present)
fc2/20 is down (SFP not present)
fc2/21 is down (Link failure or not-connected)
...
fc2/31 is up
Transmit B2B Credit is 0
Receive B2B Credit is 12
Receive B2B Credit performance buffers is 48
12 receive B2B credit remaining
0 transmit B2B credit remaining
fc2/32 is down (Link failure or not-connected)

例 13-22 指定したファイバ チャネル インターフェイスの BB_credit 情報の表示

switch# show interface fc2/31 bbcredit
fc2/31 is up
Transmit B2B Credit is 0
Receive B2B Credit is 12
Receive B2B Credit performance buffers is 48
12 receive B2B credit remaining
0 transmit B2B credit remaining
 

管理インターフェイス

管理インターフェイス(mgmt0)を使用し、スイッチをリモートで設定できます。mgmt0 インターフェイスで接続を設定するには、IP バージョン 4(IPv4)パラメータ(IP アドレス、サブネット マスク、デフォルト ゲートウェイ)、または IP バージョン 6(IPv6)パラメータを設定し、スイッチに到達できるようにする必要があります。

ここでは、管理インターフェイスについて説明します。ここで説明する内容は、次のとおりです。

「管理インターフェイスの概要」

「管理インターフェイスの設定」

「管理インターフェイスの設定の表示」

管理インターフェイスの概要

管理インターフェイスの手動設定をはじめる前に、スイッチの IPv4 アドレスとサブネット マスク、または IPv6 アドレスを取得してください。

管理ポート(mgmt0)は自動検知であり、10/100/1000 Mbps の速度によって全二重モードで動作します。自動検知では、この速度とデュプレックス モードがサポートされます。スーパーバイザ 1 モジュールの場合、デフォルトの速度は 100 Mbps、デフォルトのデュプレックス モードは自動です。スーパーバイザ 2 モジュールの場合、デフォルトの速度は自動、デフォルトのデュプレックス モードは自動です。


) スイッチに接続して IP パケットを送信するには、デフォルト ゲートウェイを明示的に設定するか、サブネットごとにルートを追加する必要があります。


管理インターフェイスの設定

mgmt0 イーサネット インターフェイスを IPv4 上で接続するように設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface mgmt0

switch(config-if)#

スイッチの管理イーサネット インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# ip address 10.16.1.2 255.255.255.0

IPv4 アドレスおよび IPv4 サブネット マスクを設定します。

ステップ 4

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

switch(config-if)# exit

switch(config)#

コンフィギュレーション モードに戻ります。

ステップ 6

switch(config)# ip default-gateway 1.1.1.4

デフォルト ゲートウェイの IPv4 アドレスを設定します。

ステップ 7

switch(config)# exit

switch#

EXEC モードに戻ります。

ステップ 8

switch# copy running-config startup-config

(任意)ファイル システムへの設定の変更を保存します。

(注) 設定を保存する場合は、いつでもこのコマンドを発行できます。

mgmt0 イーサネット インターフェイスを IPv6 上で接続するように設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface mgmt0

switch(config-if)#

スイッチの管理イーサネット インターフェイスを選択し、インターフェイス コンフィギュレーション サブモードを開始します。

ステップ 3

switch(config-if)# ipv6 enable

IPv6 をイネーブルにし、インターフェイスにリンクローカル アドレスを割り当てます。

ステップ 4

switch(config-if)# ipv6 address ipv6 address 2001:0db8:800:200c::417a/64

インターフェイスの IPv6 ユニキャスト アドレスおよびプレフィックス長を指定します。

ステップ 5

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

switch(config-if)# end

switch#

EXEC モードに戻ります。

ステップ 7

switch# copy running-config startup-config

(任意)ファイル システムへの設定の変更を保存します。

(注) 設定を保存する場合は、いつでもこのコマンドを発行できます。

管理インターフェイスの設定の表示

管理インターフェイスの設定を表示するには、 show interface mgmt 0 コマンドを使用します。

switch# show interface mgmt 0
mgmt0 is up
Hardware is FastEthernet
Address is 000c.30d9.fdbc
Internet address is 10.16.1.2/24
MTU 1500 bytes, BW 100 Mbps full Duplex
26388 packets input, 6101647 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
10247 packets output, 2389196 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 

VSAN インターフェイス

VSAN はファイバ チャネル ファブリックに適用され、同一の物理インフラストラクチャで複数の独立 SAN トポロジーの設定を可能にします。VSAN の上に IP インターフェイスを作成して、このインターフェイスを使用してこの VSAN にフレームを送信できます。この機能を使用するには、この VSAN の IP アドレスを設定する必要があります。存在しない VSAN の VSAN インターフェイスは作成できません。

ここでは、VSAN インターフェイスについて説明します。ここで説明する内容は、次のとおりです。

「VSAN インターフェイスの概要」

「VSAN インターフェイスの作成」

「VSAN インターフェイス情報の表示」

VSAN インターフェイスの概要

VSAN インターフェイスを作成または削除するときは、次の注意事項に従ってください。

目的の VSAN のインターフェイスを作成する前に VSAN を作成します。VSAN が存在しない場合、インターフェイスを作成できません。

インターフェイス VSAN を作成します。インターフェイス VSAN は自動作成されません。

VSAN を削除すると、接続されたインターフェイスが自動的に削除されます。

各インターフェイスを 1 つの VSAN だけに設定します。


ヒント VSAN インターフェイスを設定したあと、IP アドレスまたは Virtual Router Redundancy Protocol(VRRP)機能を設定できます(「IP サービスの設定」を参照)。

VSAN インターフェイスの作成

VSAN インターフェイスを作成するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface vsan 2

switch(config-if)#

ID 2 で VSAN を設定します。

ステップ 3

switch(config-if)# no shutdown

VSAN インターフェイスをイネーブルにします。

VSAN インターフェイス情報の表示

VSAN インターフェイス情報を表示するには、 show interface vsan コマンドを使用します。

switch# show interface vsan 2
vsan2 is up, line protocol is up
WWPN is 10:00:00:05:30:00:59:1f, FCID is 0xb90100
Internet address is 10.1.1.1/24
MTU 1500 bytes, BW 1000000 Kbit
0 packets input, 0 bytes, 0 errors, 0 multicast
0 packets output, 0 bytes, 0 errors, 0 dropped
 

デフォルト設定値

表 13-7 に、インターフェイス パラメータのデフォルト設定を示します。

 

表 13-7 デフォルト インターフェイス パラメータ

パラメータ
デフォルト

インターフェイス モード

Auto

インターフェイス速度

Auto

管理状態

Shutdown(初期設定時に変更された場合を除く)

トランク モード

On(初期設定時に変更された場合を除く)

トランク許可 VSAN

1 ~ 4093

インターフェイス VSAN

デフォルト VSAN(1)

標識モード

Off(ディセーブル)

EISL カプセル化

ディセーブル

データ フィールド サイズ

2112 バイト

 


1.

 
「モジュール LED の識別」 を参照してください。

2.

 
「速度 LED の概要」 を参照してください。

4.

 
プラットフォームの Cisco MDS 9000 ファミリ ハードウェア インストール ガイドを参照してください