Cisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズの第 2 世代サービス統合型ルータソフトウェア コンフィギュレーション ガイド
ルータの基本設定
ルータの基本設定
発行日;2013/01/29 | 英語版ドキュメント(2011/08/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

ルータの基本設定

デフォルト コンフィギュレーション

グローバル パラメータの設定

I/O メモリの割り当ての設定

インターフェイス ポート

ギガビット イーサネット インターフェイスの設定

無線 LAN インターフェイスの設定

インターフェイス カードおよびモジュール インターフェイスの設定

ループバック インターフェイスの設定

設定の確認

コマンドライン アクセスの設定

スタティック ルートの設定

設定の確認

ダイナミック ルートの設定

ルーティング情報プロトコルの設定

設定の確認

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

設定の確認

ルータの基本設定

ここでは、Cisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズ サービス統合型ルータ(ISR)の設定手順を説明します。また、設定例および検証ステップについても記載されている場合があります。


) Cisco Internet Operating System(IOS)コマンドライン インターフェイスを使用してCisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズ サービス統合型ルータ初期設定を実行する方法については、付録 A「Cisco IOS CLI を使用した初期設定」を参照してください。


基本コンフィギュレーション

「デフォルト コンフィギュレーション」

「グローバル パラメータの設定」

インターフェイス コンフィギュレーション

「インターフェイス ポート」

「ギガビット イーサネット インターフェイスの設定」

「無線 LAN インターフェイスの設定」

「インターフェイス カードおよびモジュール インターフェイスの設定」

「ループバック インターフェイスの設定」

ルーティング設定

「コマンドライン アクセスの設定」

「スタティック ルートの設定」

「ダイナミック ルートの設定」

デフォルト コンフィギュレーション

Cisco ルータを初めて起動した場合でも、基本的な設定の一部はすでに実行されています。初期設定を表示するには、次の例に示すように、 show running-config コマンドを使用します。

Router# show running-config
Building configuration...
Current configuration : 723 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 3
login
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end

グローバル パラメータの設定

ルータにグローバル パラメータを設定するには、次の作業を行います。

手順の概要

1. configure terminal

2. hostname name

3. enable secret password

4. no ip domain-lookup

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

例:

Router> enable

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

次のコマンドを使用して、ルータとリモート ターミナルを接続します。

telnet router name or address

Login: login id

Password: *********

Router> enable

ステップ 2

hostname name

例:

Router(config)# hostname Router

Router(config)#

ルータ名を指定します。

ステップ 3

enable secret password

例:

Router(config)# enable secret cr1ny5ho

Router(config)#

ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。

ステップ 4

no ip domain-lookup

例:

Router(config)# no ip domain-lookup Router(config)#

ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。

グローバル パラメータ コマンドの詳細については、Cisco IOS リリース コンフィギュレーション ガイド のマニュアル セットを参照してください。

I/O メモリの割り当ての設定

Cisco 3925E および Cisco 3945E ルータの I/O メモリおよびプロセッサ メモリで使用中の DRAM の割合を変更するには、グローバル コンフィギュレーション モードで memory-size iomem i/o-memory-percentage コマンドを使用します。デフォルト メモリの割り当てに戻すには、このコマンドの no 形式を使用します。この手順では smartinit がイネーブルになります。

 

構文
説明

i/o-memory-percentage

I/O メモリに割り当てられる DRAM の割合。指定できる値は、5、10、15、20、25、30、40、および 50 です。I/O メモリには、少なくとも 201 MB のメモリが必要です。

 


ヒント memory-size iomem を 25% 未満に設定することを推奨します。25% を超える値は、IPsec 性能を向上させるためにだけ使用する必要があります。

コマンドラインで I/O メモリの割合を指定すると、プロセッサ メモリが自動的に DRAM メモリの残りの割合を取得します。

次の例では、DRAM メモリの 25% を I/O メモリに、残りの 75% をプロセッサ メモリに割り当てる例を示します。

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# memory-size iomem 5
IO memory size too small: minimum IO memory size is 201M
Router(config)#
Router(config)# memory-size iomem ?
<5-50> percentage of DRAM to use for I/O memory: 5, 10, 15, 20, 25, 30, 40, 50
 
Router(config)# memory-size iomem 25
Smart-init will be disabled and new I/O memory size will take effect upon reload.
Router(config)# end
 

IOMEM の設定の確認

Router# show run
Current configuration : 6590 bytes
!
! Last configuration change at 16:48:41 UTC Tue Feb 23 2010 !
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router1
!
!
no aaa new-model
!
memory-size iomem 25
!

インターフェイス ポート

表 7 は、Cisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズ サービス統合型ルータでサポートされているインターフェイスのリストです。

 

表 7 Cisco ルータによるインターフェイス

スロット、ポート、論理インターフェイス、インターフェイス
1941
29011
2911 & 2921
2951 & 3925 & 3945
3925E & 3945E

オンボード GE ポート

Gi0/0、Gi0/1

Gi0/0、Gi0/1

Gi0/0、Gi0/1、GI0/2

Gi0/0、Gi0/1、GI0/2

Gi0/0、Gi0/1、GI0/2、GI0/3

オンボード WLAN

Wlan-ap0

未サポート

未サポート

未サポート

未サポート

MGF へのオンボード WLAN GE 接続2

Wlan-Gi0/0

未サポート

未サポート

未サポート

未サポート

PCIe へのオンボード ISM GE インターフェイス

service-module-name- ISM 0/0

service-module- name- ISM 0/0

service-module- name- ISM 0/0

service-module- name- ISM 0/0

未サポート

MGF へのオンボード ISM GE 接続

service-module-name- ISM 0/1

service-module- name- ISM 0/1

service-module- name- ISM 0/1

service-module- name- ISM 0/1

未サポート

USB

usbflash0、usbflash1

usbtoken0、usbtoken1

usbflash0、usbflash1

usbtoken0、usbtoken1

usbflash0、usbflash1

usbtoken0、usbtoken1

usbflash0、usbflash1

usbtoken0、usbtoken1

usbflash0、usbflash1

usbtoken0、usbtoken1

HWIC および VWIC のインターフェイス

interface 0/0/ port
interface
0/1/ port

interface 0/0/ port
interface
0/1/ port
interface
0/2/ port
interface
0/3/ port

interface 0/0/ port
interface
0/1/ port
interface
0/2/ port
interface
0/3/ port

interface 0/0/ port
interface
0/1/ port
interface
0/2/ port
interface
0/3/ port

<int>0/0/<port>
<int>0/1/<port>
<int>0/2/<port>

倍幅 HWIC のインターフェイス

interface 0/1
port

interface 0/1/ port

interface 0/3/ port

interface 0/1/ port

interface 0/3/ port

interface 0/1/ port

interface 0/3/ port

<int>0/1/<port>

SM のインターフェイス

未サポート

未サポート

interface 1/ port

interface1-2/port3 interface1-4/port4

interface1-2/port
interface1-4/port

倍幅 SM のインターフェイス

未サポート

未サポート

未サポート

interface 2/port5 interface4/port6

interface 2/port
interface 4/port

SM で HWIC をインターフェイス

SM で VWIC をインターフェイス

未サポート

未サポート

interface1wic-slot/port

interface1-2/wic-
slot/port7

interface1-4/wic-
slot/port8

interface1-2/wic-
slot/port
interface1-4/wic-
slot/port

1.Cisco 2901 ルータでは、非同期インターフェイスを構成する付番形式は 0/スロット/ポートです。非同期インターフェイスに対応する回線を設定するには、インターフェイス番号を使用するだけで、非同期回線を指定できます。たとえば、回線 0/1/0 は、スロット 1 の WIC-2A/S 上のインターフェイス シリアル 0/1/0 と関連付けられた回線を示します。同様に、回線 0/2/1 は、スロット 2 の WIC-2AM 上のインターフェイス非同期 0/2/1 と関連付けられた回線を示します。

2.MGF = マルチギガビット ファブリック

3.Cisco 2951、Cisco 3925、Cisco 3925E ルータにだけ適用されます。

4.Cisco 3945 および Cisco 3945E ルータにだけ適用されます。

5.Cisco 2951、Cisco 3925、Cisco 3925E ルータにだけ適用されます。

6.Cisco 3945 および Cisco 3945E ルータにだけ適用されます。

7.Cisco 2951、Cisco 3925、Cisco 3925E ルータにだけ適用されます。

8.Cisco 3945 および Cisco 3945E ルータにだけ適用されます。

ギガビット イーサネット インターフェイスの設定

手動でオンボードのギガビット イーサネット(GE)インターフェイスを定義するには、グローバル コンフィギュレーション モードで開始して、次のステップに従います。

手順の概要

1. interface gigabitethernet slot/port

2. ip address ip-address mask

3. no shutdown

4. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface gigabitethernet slot/port

例:

Router(config)# interface gigabitethernet 0/1

Router(config-if)#

ルータ上で ギガビット イーサネット インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0

Router(config-if)#

指定した GE インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown

Router(config-if)#

GE インターフェイスをイネーブルにし、ステートを管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-if)# exit

Router(config)#

GE インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

無線 LAN インターフェイスの設定

Cisco 1941W ルータの無線 LAN インターフェイスは、 interface wlan-ap0 を介してルータへの接続を有効化します。ワイヤレス接続の設定の詳細については、を参照してください。

インターフェイス カードおよびモジュール インターフェイスの設定

Internal Services Module(ISM; 内部サービス モジュール)に挿入されたインターフェイス カードおよびモジュール、Enhanced High-speed WAN Interface Card(EHWIC; 高速 WAN インターフェイス カード )、Ethernet WAN Interface Card(EWIC; イーサネット WAN インターフェイス カード)、および Service Module(SM; サービス モジュール)スロットの設定については、Cisco.com にアクセスし、該当するインターフェイス カードまたはモジュール設定マニュアルを参照してください。

ループバック インターフェイスの設定

ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。

ループバック コマンドの詳細については、Cisco IOS リリース コンフィギュレーション ガイドのマニュアル セットを参照してください。

ループバック インターフェイスを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface Loopback 0

Router(config-if)#

ループバック インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 10.108.1.1 255.255.255.0

Router(config-if)#

ループバック インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

exit

例:

Router(config-if)# exit

Router(config)#

ループバック インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。この設定例は、スタティック IP アドレスとして機能する IP アドレス 200.200.100.1/24 のギガビット イーサネット インターフェイス上に設定されるループバック インターフェイスを示します。ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

設定の確認

ループバック インターフェイスが正しく設定されたかどうかを確認するには、show interface loopback コマンドを入力します。次の例のような確認用の出力が表示されます。

Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

ping を実行することによって、ループバック インターフェイスを確認する方法もあります。

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

コマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. line [ aux | console | tty | vty ] line-number

2. password password

3. login

4. exec-timeout minutes [ seconds ]

5. line [ aux | console | tty | vty ] line-number

6. password password

7. login

8. end

手順の詳細

 

コマンド
目的

ステップ 1

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line console 0

Router(config-line)#

回線コンフィギュレーション モードを開始します。続いて、回線のタイプを指定します。

この例では、アクセス用にコンソール端末を指定します。

ステップ 2

password password

例:

Router(config)# password 5dr4Hepw3

Router(config-line)#

コンソール端末回線に固有のパスワードを指定します。

ステップ 3

login

例:

Router(config-line)# login

Router(config-line)#

端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout minutes [ seconds ]

例:

Router(config-line)# exec-timeout 5 30

Router(config-line)#

ユーザ入力が検出されるまで EXEC コマンド インタープリタが待機する間隔を設定します。デフォルトは 10 分です。任意で、間隔値に秒数を追加します。

この例では、5 分 30 秒のタイムアウトを表示します。「0 0」のタイムアウトを入力すると、タイムアウトが発生しません。

ステップ 5

line [ aux | console | tty | vty ] line-number

例:

Router(config-line)# line vty 0 4

Router(config-line)#

リモート コンソール アクセス用の仮想端末を指定します。

ステップ 6

password password

例:

Router(config-line)# password aldf2ad1

Router(config-line)#

仮想端末回線に固有のパスワードを指定します。

ステップ 7

login

例:

Router(config-line)# login

Router(config-line)#

仮想端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 8

end

例:

Router(config-line)# end

Router#

回線コンフィギュレーション モードを終了します。続いて、特権 EXEC モードに戻ります。

次の設定は、コマンドライン アクセス コマンドを示します。

「default」と記されているコマンドは入力不要です。これらのコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
 

スタティック ルートの設定

スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。これらは、ルータ上で手動で設定されます。ネットワーク トポロジが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

2. end

手順の詳細

 

コマンド
目的

ステップ 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2

Router(config)#

IP パケットのスタティック ルートを指定します。

このコマンドとその他の設定可能なパラメータに関する詳細については、『 Cisco IOS IP Command Reference, Volume 2 of 4: Routing Protocols, Release 12.3 』を参照してください。

ステップ 2

end

例:

Router(config)# end

Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

次の設定例は、宛先 IP アドレスが 192.168.1.0、サブネット マスクが 255.255.255.0 のすべての IP パケットを、IP アドレス 10.10.10.2 の他の装置に対して、ギガビット インターフェイス上からスタティック ルートで送信します。具体的には、パケットが設定済みの PVC に送信されます。

「(default)」と記されているコマンドの入力は不要です。このコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

設定の確認

スタティック ルーティングが正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「S」で表されるスタティック ルートを探します。

次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 

ダイナミック ルートの設定

ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジに基づいて、ネットワーク プロトコルがパスを自動調整します。ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。

Cisco ルータは、Routing Information Protocol(RIP; ルーティング情報プロトコル)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、動的にルートを学習します。いずれかのルーティング プロトコルをルータに設定できます。

「ルーティング情報プロトコルの設定」

「拡張インテリア ゲートウェイ ルーティング プロトコルの設定」

ルーティング情報プロトコルの設定

ルータに RIP ルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. router rip

2. version { 1 | 2 }

3. network ip-address

4. no auto-summary

5. end

手順の詳細

 

コマンド
タスク

ステップ 1

router rip

例:

Router> configure terminal

Router(config)# router rip

Router(config-router)#

ルータ コンフィギュレーション モードを開始します。続いて、ルータの RIP をイネーブルにします。

ステップ 2

version { 1 | 2 }

例:

Router(config-router)# version 2

Router(config-router)#

RIP version 1 または 2 の使用を指定します。

ステップ 3

network ip-address

例:

Router(config-router)# network 192.168.1.1

Router(config-router)# network 10.10.7.1

Router(config-router)#

直接接続しているネットワークの各アドレスを使用して、RIP を適用するネットワーク リストを指定します。

ステップ 4

no auto-summary

例:

Router(config-router)# no auto-summary

Router(config-router)#

ネットワークレベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。これにより、サブプレフィックス ルーティング情報がクラスフル ネットワーク境界を越えて送信されます。

ステップ 5

end

例:

Router(config-router)# end

Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。

設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

設定の確認

RIP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「R」で表される RIP ルートを探します。次の例のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

ルータに拡張インテリア ゲートウェイ ルーティング プロトコル(EGRP)を設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. router eigrp as-number

2. network ip-address

3. end

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-number

例:

Router(config)# router eigrp 109

Router(config)#

ルータ コンフィギュレーション モードを開始して、ルータ上で EIGRP をイネーブルにします。Autonomous System(AS; 自律システム)番号は、他の EIGRP ルータへのルートを識別します。また、EIGRP 情報のタグ付けに使用されます。

ステップ 2

network ip-address

例:

Router(config)# network 192.145.1.0

Router(config)# network 10.10.12.115

Router(config)#

EIGRP を適用するネットワークのリストを指定します(直接接続されているネットワークの IP アドレスを使用)。

ステップ 3

end

例:

Router(config-router)# end

Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

次の設定例は、IP ネットワーク 192.145.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。EIGRP の AS 番号として、109 が割り当てられています。

設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

Router# show running-config
...
!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
...

設定の確認

IP EIGRP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「D」で表される EIGRP ルートを探します。次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0