Cisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズの第 2 世代サービス統合型ルータソフトウェア コンフィギュレーション ガイド
バックアップ データ回線およびリモート管理 の設定
バックアップ データ回線およびリモート管理の設定
発行日;2013/01/29 | 英語版ドキュメント(2011/08/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

バックアップ データ回線およびリモート管理の設定

バックアップ インターフェイスの設定

バックアップ インターフェイスの設定

ギガビット イーサネット フェールオーバー メディアの設定

プライマリおよびセカンダリ フェールオーバー メディアの割り当て

Auto-Detect のイネーブル化

セルラー ダイヤルオンデマンド ルーティング バックアップの設定

ダイヤラ ウォッチを使用した DDR バックアップの設定

浮動スタティック ルートを使用した DDR バックアップの設定

NAT および IPSec を設定したバックアップとしてのセルラー ワイヤレス モデム

コンソール ポートまたは補助ポート経由でのダイヤル バックアップおよびリモート管理の設定

ISDN S/T ポート経由でのデータ回線バックアップおよびリモート管理の設定

ISDN 設定の構成

バックアップ データ回線およびリモート管理の設定

Cisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズ サービス統合型ルータ(ISR)では、ISDN によるリモート管理およびバックアップ データ接続をサポートします。

ここでは、バックアップ データ回線およびリモート管理の設定方法について説明します。

「バックアップ インターフェイスの設定」

「コンソール ポートまたは補助ポート経由でのダイヤル バックアップおよびリモート管理の設定」

「ISDN S/T ポート経由でのデータ回線バックアップおよびリモート管理の設定」

バックアップ インターフェイスの設定

この項では、次のトピックを扱います。

「バックアップ インターフェイスの設定」

「ギガビット イーサネット フェールオーバー メディアの設定」

「セルラー ダイヤルオンデマンド ルーティング バックアップの設定」

バックアップ インターフェイスの設定

プライマリ インターフェイスがダウンしたことをルータが認識すると、バックアップ インターフェイスがイネーブルにされます。プライマリ接続が指定した期間で回復すると、バックアップ インターフェイスはディセーブルにされます。


) Dial-on-demand Routing(DDR; ダイヤルオンデマンド ルーティング)のバックアップについては、バックアップ インターフェイスがスタンバイ モードを終了しても、ルータでそのバックアップ インターフェイスに指定されたトラフィックが受信されない限り、バックアップ インターフェイスはイネーブルにされません。


バックアップ インターフェイスのあるルータを設定するには、グローバル コンフィギュレーション モードで始まる次の手順を実行します。

手順の概要

1. interface type number

2. backup interface interface-type interface-number

3. backup delay enable-delay disable-delay

4. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

 

Router(config)# interface atm 0/0/0

Router(config-if)#

バックアップ用に設定するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

この例では、ATM WAN 接続をバックアップ用に設定しています。

ステップ 2

backup interface interface-type interface-number

 

Router(config-if)# backup interface bri 0/0/1

Router(config-if)#

インターフェイスをセカンダリ(バックアップ)インターフェイスに指定します。

シリアル インターフェイスまたは非同期インターフェイスを指定できます。たとえば、serial 1 インターフェイスを serial 0/2/1 インターフェイスのバックアップに設定できます。

この例では、BRI(基本インターフェイス)を ATM 0/0/0 インターフェイスのバックアップ インターフェイスとして設定しています。

ステップ 3

backup delay enable-delay disable-delay

 

Router(config-if)# backup delay enable delay

ダウンしている物理インターフェイスとイネーブルになっているバックアップ インターフェイス間の遅延、および再度アップになっている物理インターフェイスとディセーブルになっているバックアップ インターフェイス間の遅延を指定します。

ステップ 4

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ギガビット イーサネット フェールオーバー メディアの設定

Cisco 2921、Cisco 2951、および Cisco 3900 シリーズ ルータには、銅線およびファイバの同時接続をサポートするギガビット イーサネット(GE)Small Form-factor Pluggable(SFP)ポートがあります。ネットワークがダウンした場合に、フェールオーバー冗長性を保つようメディアを設定できます。


) フェールオーバーまたは Auto-Detect を設定した Cisco 2921、Cisco 2951、または Cisco 3900 ルータはバックツーバック接続しないでください。この設定はサポートされていないため、予測できない動作をする場合があります。


プライマリおよびセカンダリ フェールオーバー メディアの割り当て

プライマリおよびセカンダリ フェールオーバー メディアを GE-SFP ポートに割り当てるには、EXEC モードから、次の手順を実行します。

手順の概要

1. configure terminal

2. interface gigabitethernet slot/port

3. media-type sfp

4. media-type sfp auto-failover

5. end

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Router> enable

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

次のコマンドを使用して、ルータとリモート ターミナルを接続します。

telnet router name or address

Login: login id

Password: *********

Router> enable

ステップ 2

interface gigabitethernet slot/port

 

Router(config)# interface gigabitethernet 0/1

Router(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

media-type sfp

 

Router(config-if)# media-type sfp

Router(config-if)#

 

Router(config-if)# media-type rj45

Router(config-if)#

SFP ポートをプライマリ メディアとして指定します。

または

RJ-45 をプライマリ メディアとして指定します。

ステップ 4

media-type sfp auto-failover

 

Router(config-if)# media-type sfp auto-failover

Router(config-if)#

 

Router(config-if)# media-type rj45 auto-failover

Router(config-if)#

SFP のあるポートを SFP から RJ-45 への自動フェールオーバーのプライマリ メディアとして設定します。

または

RJ-45 のあるポートを RJ-45 から SFP への自動フェールオーバーのプライマリ メディアとして設定します。

ステップ 5

end

グローバル コンフィギュレーション モードに戻ります。

Auto-Detect のイネーブル化

Auto-Detect 機能は、media-type が設定されていない場合にイネーブルにされます。この機能により、どのメディアが接続されているか自動的に検出され、リンクが稼働します。両方のメディアが接続されている場合、最初に稼働したメディアのリンクが稼働します。


) Auto-Detect 機能は、1 GigE SFP の場合だけ動作します。この機能は 100M SFP は検出されません。


Auto-Detect 機能をイネーブルにするには、インターフェイス コンフィギュレーション モードで no media-type コマンドを使用します。

Auto-Detect 機能を設定するには、グローバル コンフィギュレーション モードから次のステップに従います。

手順の概要

1. configure terminal

2. interface gigabitethernet slot/port

3. no media-type

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface gigabitethernet slot/port

 

Router(config)# interface gigabitethernet 0/1

Router(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no media-type

 

Router(config-if)# no media-type

GigabitEthernet0/1: Changing media to UNKNOWN.

You may need to update the speed and duplex settings for this interface.

Auto-Detect をイネーブルにします。1 GigE SFP が接続されている場合、速度 1000 および全二重に設定します。RJ45 接続は、速度 1000 および全二重の場合だけ動作します。SFP が接続されていない場合、RJ45 メディアにはすべての速度およびデュプレックスが使用できます。

(注) 1 GigE SFP が接続されている場合、速度 100 または 10 および半二重では設定しないでください。これらの設定では SFP が予測できない動作をする場合があります。

セルラー ダイヤルオンデマンド ルーティング バックアップの設定

必要な場合にプライマリ接続を監視し、セルラー インターフェイスでバックアップ接続を開始する場合、ルータは次のいずれかの方法を使用できます。

バックアップ インターフェイス:バックアップ インターフェイスはプライマリ インターフェイス回線プロトコルがダウンと認識されるまで、スタンバイ モード状態を保ちます。その後、バックアップ インターフェイスがアップします。「バックアップ インターフェイスの設定」を参照してください。

ダイヤラ ウォッチ:ダイヤラ ウォッチは、ダイヤル バックアップをルーティング機能と統合するバックアップ機能です。「ダイヤラ ウォッチを使用した DDR バックアップの設定」を参照してください。

浮動スタティック ルート:バックアップ インターフェイスを通ったルートには、プライマリ接続ルートのアドミニストレーティブ ディスタンスより長いため、プライマリ インターフェイスがダウンするまでルーティング テーブルにないアドミニストレーティブ ディスタンスがあります。プライマリ インターフェイスがダウンすると、浮動スタティック ルートが使用されます。「浮動スタティック ルートを使用した DDR バックアップの設定」を参照してください。

セルラー ワイヤレス モデム:Global System for Mobile Communications(GSM)ネットワークまたは Code Division Multiple Access(CDMA; 符号分割多重接続)ネットワークいずれかでネットワーク アドレス変換(NAT)および IPSec が設定されたバックアップとして 3G ワイヤレス モデムを設定するには、「NAT および IPSec を設定したバックアップとしてのセルラー ワイヤレス モデム」を参照してください。


) セルラー インターフェイスまたは任意の他の非同期シリアル インターフェイスのバックアップ インターフェイスは設定できません。


ダイヤラ ウォッチを使用した DDR バックアップの設定

ダイヤラ ウォッチを開始するには、インターフェイスを設定して Dial-on-demand Routing(DDR; ダイヤルオンデマンド ルーティング)およびバックアップを実行する必要があります。DDR 機能には dialer map など、従来の DDR コンフィギュレーション コマンドを使用します。バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにし、ダイヤラ リストを作成するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

手順の概要

1. configure terminal

2. interface type number

3. dialer watch group group-number

4. dialer watch-list group-number ip ip-address address-mask

5. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

6. ip access-list access list number permit ip source address

7. interface cellular 0

8. dialer string string

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type number

 

Router (config)# interface ATM 0

インターフェイスを指定します。

ステップ 3

dialer watch-group group-number

 

Router(config-if)# dialer watch-group 2

バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにします。

ステップ 4

dialer watch-list group-number ip ip-address address-mask

 

Router(config-if)# dialer watch-list 2 ip 10.4.0.254 255.255.0.0

監視されるすべての IP アドレスのリストを定義します。

ステップ 5

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}>

 

Router(config)# dialer-list 2 protocol ip permit

関係するトラフィックのダイヤラ リストを作成し、プロトコル全体に対してアクセスを許可します。

ステップ 6

ip access-list access-list-number permit ip-source-address

 

Router(config)# access list 2 permit 10.4.0.0

関係するトラフィックを定義します。

IP ネットワークへのトラフィック送信を回避するには、access list permit all コマンドは使用しないでください。これによって、コールが強制的に終了される場合があります。

ステップ 7

interface cellular 0

 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 8

dialer string string

または

dialer group dialer-group-number

 

Router (config-if)# dialer string cdma *** cdma ***

 

Router (config-if)# dialer group 2 *** gsm ***

CDMA だけ:dialer string string はダイヤラ スクリプトを指定します (ダイヤラ スクリプトは chat script コマンドで定義されます)。

GSM だけ:dialer group dialer-group-number はダイヤラ リストをダイヤラ インターフェイスにマップします。

浮動スタティック ルートを使用した DDR バックアップの設定

フローティング スタティック デフォルト ルートをセカンダリ インターフェイスで設定するには、グローバル コンフィギュレーション モードから、次のコマンドを使用します。


) IP クラスがルータでイネーブルになっていることを確認します。


手順の概要

1. configure terminal

2. ip route network-number network-mask { ip address | interface } [ administrative-distance ] [name name]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

端末からグローバル コンフィギュレーション モードを開始します。

ステップ 2

ip route network-number network-mask { ip-address | interface } [ administrative-distance ] [name name ]

 

Router (config)# ip route 0.0.0.0 Dialer 2 track 234

指定されたインターフェイスを介して、設定されているアドミニストレーティブ ディスタンスを使用して、浮動スタティック ルートを確立します。

プライマリ インターフェイスがダウンしたときだけバックアップ インターフェイスを使用するするよう、バックアップ インターフェイスを通したルートのアドミニストレーティブ ディスタンスをより高く設定する必要があります。

NAT および IPSec を設定したバックアップとしてのセルラー ワイヤレス モデム

次に、GSM ネットワークまたは CDMA ネットワークで NAT および IPsec を設定したバックアップとして 3G ワイヤレス モデムを設定する方法の例を示します。


) 送受信速度は設定できません。実際のスループットは、セルラー ネットワーク サービスによって異なります。


Router# sh run
Building configuration...
 
Current configuration : 5833 bytes
!
! Last configuration change at 18:26:15 UTC Wed Sep 30 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
service-module wlan-ap 0 bootimage autonomous
!
no ipv6 cef
ip source-route
ip cef
!
!
ip multicast-routing
!
ip dhcp pool miercom
network 10.1.0.0 255.255.0.0
default-router 10.1.0.254
dns-server 10.1.0.254
!
ip dhcp pool wlan-clients
network 10.9.0.0 255.255.0.0
default-router 10.9.0.254
dns-server 10.9.0.254
!
!
!
multilink bundle-name authenticated
!
chat-script gsm "" "atdt*99#" TIMEOUT 180 "CONNECT"
chat-script cdma "" "atdt#777" TIMEOUT 180 "CONNECT"
!
!
license udi pid CISCO1941W-A/K9 sn FHH1249P016
!
!
archive
log config
hidekeys
!
redundancy
!
!
!
track 234 ip sla 1 reachability
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
!
interface Wlan-GigabitEthernet0/0
description Internal switch interface connecting to the embedded AP
!
!
interface GigabitEthernet0/0
ip address dhcp
ip virtual-reassembly
load-interval 30
shutdown
duplex auto
speed auto
!
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip address 192.168.1.1 255.255.255.0
arp timeout 0
no mop enabled
no mop sysid
!
!
interface GigabitEthernet0/1
ip address 10.1.0.254 255.255.0.0
ip nat inside
ip virtual-reassembly
shutdown
duplex auto
speed auto
crypto ipsec client ezvpn hw-client-pri inside
crypto ipsec client ezvpn hw-client inside
!
!
interface Cellular0/0/0
no ip address
ip access-group 131 out
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer in-band
dialer pool-member 1
dialer idle-timeout 0
dialer-group 1
no peer default ip address
async mode interactive
no ppp lcp fast-start
ppp ipcp dns request
ppp timeout retry 120
ppp timeout ncp 30
fair-queue 64 16 0
!
routing dynamic
!
interface ATM0/1/0
no ip address
no atm ilmi-keepalive
no dsl bitswap
!
!
interface ATM0/1/0.1 point-to-point
ip virtual-reassembly
pvc 0/35
pppoe-client dial-pool-number 2
!
!
interface Vlan1
ip address 10.9.0.254 255.255.0.0
ip nat inside
ip virtual-reassembly
!
!
interface Dialer1
ip address negotiated
ip access-group 131 out
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 1
dialer idle-timeout 0
dialer string cdma
dialer persistent
dialer-group 1
no peer default ip address
no ppp lcp fast-start
ppp chap hostname nousername
ppp chap password 0 nopassword
ppp ipcp dns request
ppp timeout retry 120
ppp timeout ncp 30
fair-queue
crypto ipsec client ezvpn hw-client
!
!
interface Dialer2
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 2
dialer idle-timeout 0
dialer persistent
dialer-group 2
ppp authentication chap callin
ppp chap hostname ciscoenzo2@sbcglobal.net
ppp chap password 0 Enzo221
ppp pap sent-username ciscoenzo2@sbcglobal.net password 0 Enzo221
ppp ipcp dns request
no cdp enable
crypto ipsec client ezvpn hw-client-pri
!
!
ip local policy route-map track-primary-if
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source route-map nat2cell interface Dialer1 overload
ip nat inside source route-map nat2dsl interface Dialer2 overload
ip route 0.0.0.0 0.0.0.0 Dialer2 track 234
ip route 0.0.0.0 0.0.0.0 Dialer1 253
!
ip sla 1
icmp-echo 128.107.248.247 source-interface Dialer2
frequency 5
ip sla schedule 1 life forever start-time now
access-list 1 permit any
access-list 2 permit 10.1.0.0 0.0.255.255
access-list 100 deny ip 10.1.0.0 0.0.0.255 10.4.0.0 0.0.0.255
access-list 100 permit ip any any
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
access-list 101 permit ip host 1.1.1.1 any
access-list 102 permit icmp any host 128.107.248.247
access-list 131 deny ip 10.0.0.0 0.255.255.255 any log-input
access-list 131 permit ip any any
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
no cdp run
 
!
!
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer2 Null0
!
route-map nat2dsl permit 10
match ip address 101
match interface Dialer2
!
route-map nat2cell permit 10
match ip address 101
match interface Dialer1
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line 0/0/0
exec-timeout 0 0
script dialer cdma
login
modem InOut
no exec
transport input all
transport output all
autoselect ppp
rxspeed 3100000
txspeed 1800000
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
event manager applet pri_back
event track 234 state any
action 2.0 cli command "clear ip nat trans forced"
!
end
 
Router#

コンソール ポートまたは補助ポート経由でのダイヤル バックアップおよびリモート管理の設定

Cisco 3900 シリーズ ISR などの宅内装置が ISP に接続されている場合、IP アドレスはルータにダイナミックに割り当てられるか、中央管理機能を通してルータ ピアにより割り当てられます。プライマリ回線に障害が発生した場合にフェールオーバー ルートを提供するため、ダイヤル バックアップ機能を追加できます。Cisco 3900 シリーズ ISR はダイヤル バックアップおよびリモート管理に補助ポートを使用できます。

図 1 は、リモート管理アクセスおよびプライマリ WAN 回線にバックアップを提供する場合に使用するネットワーク コンフィギュレーションを示しています。

図 1 補助ポートによるダイヤル バックアップおよびリモート管理

 

 

1

Cisco 3900 シリーズ ルータ

A

メイン WAN リンク。インターネット サービス プロバイダーへのプライマリ接続です。

2

モデム

B

ダイヤル バックアップ。プライマリ回線がダウンした場合に Cisco 3900 ルータのフェールオーバー リンクとして機能します。

3

PC

C

リモート管理。Cisco IOS コンフィギュレーションへの変更または更新を可能にするダイヤルイン アクセスとして機能します。

Cisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズ ISR のダイヤル バックアップおよびリモート管理を設定するには、グローバル コンフィギュレーション モードで始まる次の手順を実行します。

手順の概要

1. ip name-server server-address

2. ip dhcp pool name

3. exit

4. chat-script script-name expect-send

5. interface type number

6. exit

7. interface type number

8. dialer watch-group group-number

9. exit

10. ip nat inside source { list access-list-number } { interface type number | pool name } [ overload ]

11. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

12. access-list access-list-number { deny | permit } source [ source-wildcard ]

13. dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

14. line [ aux | console | tty | vty ] line-number [ ending-line-number ]

15. modem enable

16. exit

17. line [ aux | console | tty | vty ] line-number [ ending-line-number ]

18. flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

手順の詳細

 

コマンド
目的

ステップ 1

ip name-server server-address

 

Router(config)# ip name-server 192.168.28.12

Router(config)#

ISP DNS IP アドレスを入力します。

ヒント 可能な場合は、複数のサーバ アドレスを追加できます。

ステップ 2

ip dhcp pool name

 

Router(config)# ip dhcp pool 1

Router(config-dhcp)#

ルータ上に DHCP アドレス プールを作成します。続いて、DHCP プール コンフィギュレーション モードを開始します。 name 引数は、ストリングまたは整数にすることができます。

DHCP アドレス プールを設定します。DHCP プール コンフィギュレーション モードで使用できるサンプル コマンドについては、「例」を参照してください。

ステップ 3

exit

 

Router(config-dhcp)# exit

Router(config)#

DHCP プール コンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードを開始します。

ステップ 4

chat-script script-name expect-send

 

Router(config)# chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102 T” TIMEOUT 45 CONNECT \c

Router(config)#

モデルをダイヤルし、リモート システムにログインするコマンドを提供するため DDR で使用するチャット スクリプトを設定します。定義されたスクリプトを使用して PSTN に接続されたモデムで通話します。

ステップ 5

interface type number

 

Router(config)# interface Async 1

Router(config-if)#

非同期インターフェイスを作成し、非同期インターフェイスのコンフィギュレーション モードを開始します。

非同期インターフェイスを設定します。非同期インターフェイス コンフィギュレーション モードで使用できるサンプル コマンドについては、「例」を参照してください。

ステップ 6

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 7

interface type number

 

Router(config)# interface Dialer 3

Router(config-if)#

ダイヤラ インターフェイスを作成し、ダイヤラ インターフェイスのコンフィギュレーション モードを開始します。

ステップ 8

dialer watch-group group-number

 

Router(config-if)# dialer watch-group 1

Router(config-if)#

ダイヤラ ウォッチ リストのグループ番号を指定します。

ステップ 9

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 10

ip nat inside source { list access-list-number } { interface type number | pool name } [ overload ]

 

Router(config)# ip nat inside source list 101 interface Dialer 3 overload

内部インターフェイス上のダイナミック アドレス変換をイネーブルにします。

ステップ 11

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

 

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2

Router(config)#

ダイヤラ インターフェイスにポイントする IP ルートをデフォルト ゲートウェイとして設定します。

ステップ 12

access-list access-list-number { deny | permit } source [ source-wildcard ]

 

Router(config)# access-list 1 permit 192.168.0.0 0.0.255.255 any

変換が必要なアドレスを示す拡張アクセス リストを定義します。

ステップ 13

dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

 

Router(config)# dialer watch-list 1 ip 22.0.0.2 255.255.255.255

Router(config)#

ピアへのルートが存在するかどうかにより、プライマリ リンクのステータスを評価します。アドレス 22.0.0.2 は、ISP のピア IP アドレスです。

ステップ 14

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

 

Router(config)# line console 0

Router(config-line)#

ライン インターフェイスのコンフィギュレーション モードを開始します。

ステップ 15

modem enable

 

Router(config-line)# modem enable

Router(config-line)#

コンソール ポートから補助ポート機能へポートを切り替えます。

ステップ 16

exit

 

Router(config-line)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

ステップ 17

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

 

Router(config)# line aux 0

Router(config)#

補助インターフェイスのコンフィギュレーション モードを開始します。

ステップ 18

flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

 

Router(config)# flowcontrol hardware

Router(config)#

ハードウェア信号フロー制御をイネーブルにします。

次に、PPP および IP Control Protocol(IPCP)アドレス ネゴシエーションにより ATM インターフェイスの IP アドレスを指定し、コンソール ポートでダイヤル バックアップを指定する場合の設定例を示します。

!
ip name-server 192.168.28.12
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool 1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
! Need to use your own correct ISP phone number.
modemcap entry MY-USER_MODEM:MSC=&F1S0=1
chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
TIMEOUT 45 CONNECT \c
!
!
!
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
! Dial backup and remote management physical interface.
interface Async1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 3
async default routing
async dynamic routing
async mode dedicated
ppp authentication pap callin
!
interface ATM0
mtu 1492
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
! Primary WAN link.
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! Dialer backup logical interface.
interface Dialer3
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 3
dialer idle-timeout 60
dialer string 5555102 modem-script Dialout
dialer watch-group 1
!
! Remote management PC IP address.
peer default ip address 192.168.2.2
no cdp enable
!
! Need to use your own ISP account and password.
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map.
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
!
! When primary link is up again, distance 50 will override 80 if dial backup
! has not timed out. Use multiple routes because peer IP addresses are alternated
! among them when the CPE is connected.
ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
ip route 0.0.0.0 0.0.0.0 Dialer1 150
no ip http server
ip pim bidir-enable
!
! PC IP address behind CPE.
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.168.0.0 0.0.255.255 any
!
! Watch multiple IP addresses because peers are alternated
! among them when the CPE is connected.
dialer watch-list 1 ip 64.161.31.254 255.255.255.255
dialer watch-list 1 ip 64.174.91.254 255.255.255.255
dialer watch-list 1 ip 64.125.91.254 255.255.255.255
!
! Dial backup will kick in if primary link is not available
! 5 minutes after CPE starts up.
dialer watch-list 1 delay route-check initial 300
dialer-list 1 protocol ip permit
!
! Direct traffic to an interface only if the dialer is assigned an IP address.
route-map main permit 10
match ip address 101
match interface Dialer1
!
route-map secondary permit 10
match ip address 103
match interface Dialer3
!
! Change console to aux function.
line con 0
exec-timedout 0 0
modem enable
stopbits 1
line aux 0
exec-timeout 0 0
! To enable and communicate with the external modem properly.
script dialer Dialout
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler max-task-time 5000
end
 

ISDN S/T ポート経由でのデータ回線バックアップおよびリモート管理の設定

この項では、次のトピックを扱います。

「ISDN 設定の構成」

「例」

Cisco 3900 シリーズ ルータではリモート管理に ISDN S/T ポートを使用できます。図 2 および 図 3 は、プライマリ WAN 回線のリモート管理アクセスおよびバックアップを実現する 2 種類の典型的なネットワーク コンフィギュレーションを示します。

図 2 は、ISDN スイッチに接続する前に Customer Premises Equipment(CPE; 宅内装置)スプリッタ、Digital Subscriber Line Access Multiplexer(DSLAM; デジタル加入者線アクセス マルチプレクサ)、および Central Office(CO; セントラル オフィス)スプリッタを経由するダイヤル バックアップを示します。

図 2 CPE スプリッタ、DSLAM、および CO スプリッタを経由するデータ回線バックアップ

 

 

1

Cisco 3900 シリーズ ルータ

A

プライマリ DSL インターフェイス、FE インターフェイス(Cisco 3900 シリーズ ルータ)

2

DSLAM

B

ISDN インターフェイス(ISDN S/T ポート)経由のダイヤル バックアップおよびリモート管理。プライマリ回線がダウンした場合にフェールオーバー リンクとして機能します。

3

ATM アグリゲータ

4

ISDN スイッチ

5

ISDN

C

プライマリ DSL リンクがダウンした場合に、ISDN インターフェイスから管理者にリモート管理機能を提供します。Cisco IOS コンフィギュレーションへの変更または更新を可能にするダイヤルイン アクセスとして機能します。

6

ISDN ピア ルータ

7

Web サーバ

8

管理者

図 3 は、ルータから ISDN スイッチへ直接接続されたダイヤル バックアップ リンクを示します。

図 3 ルータから ISDN スイッチへの直接接続データ回線バックアップ

 

 

1

PC

A

プライマリ DSL インターフェイス

2

Cisco 3900 シリーズ ISR

B

ISDN インターフェイス(ISDN S/T ポート)経由のダイヤル バックアップおよびリモート管理。プライマリ回線がダウンした場合にフェールオーバー リンクとして機能します。

3

DSLAM

4

アグリゲータ

5

ISDN スイッチ

C

プライマリ DSL リンクがダウンした場合に、ISDN インターフェイスから管理者にリモート管理機能を提供します。Cisco IOS コンフィギュレーションへの変更または更新を可能にするダイヤルイン アクセスとして機能します。

6

Web サーバ

7

管理者

ISDN 設定の構成


) バックアップ インターフェイスおよび浮動スタティック ルートの方式を使用してバックアップ ISDN 回線をアクティブにするには、対象トラフィックが存在している必要があります。ダイヤラ ウォッチによってバックアップ ISDN 回線をアクティブにするには、対象トラフィックは不要です。


バックアップ インターフェイスとして使用するルータ ISDN インターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて次の手順を実行します。

手順の概要

1. isdn switch-type switch-type

2. interface type number

3. encapsulation encapsulation-type

4. dialer pool-member number

5. isdn switch-type switch-type

6. exit

7. interface dialer dialer-rotary-group-number

8. ip address negotiated

9. encapsulation encapsulation-type

10. dialer pool number

11. dialer string dial-string# [ : isdn-subaddress ]

12. dialer-group group-number

13. exit

14. dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

手順の詳細

 

コマンド
目的

ステップ 1

isdn switch-type switch-type

 
Router(config)# isdn switch-type basic-net3
Router(config)#

ISDN スイッチ タイプを指定します。

この例では、豪州、欧州、および英国で使用するスイッチ タイプを指定しています。サポートされるその他のスイッチ タイプの詳細については、『 Cisco IOS Dial Technologies Command Reference』を参照してください

ステップ 2

interface type number

 
Router(config)# interface bri 0
Router(config-if)#

ISDN BRI のコンフィギュレーション モードを開始します。

ステップ 3

encapsulation encapsulation-type

 
Router(config-if)# encapsulation ppp
Router(config-if)#

BRI0 インターフェイスのカプセル化タイプを設定します。

ステップ 4

dialer pool-member number

 
Router(config-if)# dialer pool-member 1
Router(config-if)#

ダイヤラ プールのメンバーシップを指定します。

ステップ 5

isdn switch-type switch-type

 
Router(config-if)# isdn switch-type basic-net3
Router(config-if)#

ISDN スイッチ タイプを指定します。

ステップ 6

exit

 
Router(config-if)# exit
Router(config)#

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 7

interface dialer dialer-rotary-group-number

 
Router(config)# interface dialer 0
Router(config-if)#

ダイヤラ インターフェイス(番号 0 ~ 255)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip address negotiated

 
Router(config-if)# ip address negotiated
Router(config-if)#

インターフェイスの IP アドレスを PPP/IPCP(IP Control Protocol)アドレス ネゴシエーションで取得することを指定します。ピアから IP アドレスを取得します。

ステップ 9

encapsulation encapsulation-type

 

Router(config-if)# encapsulation ppp

Router(config-if)#

インターフェイスのカプセル化タイプを設定します。

ステップ 10

dialer pool number

 

Router(config-if)# dialer pool 1

Router(config-if)#

使用するダイヤラ プールを指定します。

この例では、BRI0 の dialer pool-member 値は 1 なので、dialer pool 1 という設定により dialer 0 インターフェイスが BRI0 インターフェイスに対応付けられます。

ステップ 11

dialer string dial-string# [ : isdn-subaddress ]

 

Router(config-if)# dialer string 384040

Router(config-if)#

ダイヤルする電話番号を指定します。

ステップ 12

dialer-group group-number

 

Router(config-if)# dialer group 1

Router(config-if)#

ダイヤラ グループ(1 ~ 10)にダイヤラ インターフェイスを割り当てます。

ステップ 13

exit

 

Router(config-if)# exit

Router(config)#

ダイヤラ インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 14

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

 

Router(config)# dialer-list 1 protocol ip permit

Router(config)#

指定したインターフェイス ダイヤラ グループ経由で転送する対象パケット用のダイヤラ リストを作成します。

この例では、dialer-list 1 が dialer-group 1 に対応します。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Dial Technologies Command Reference』を参照してください。

次に、集約ルータおよび ISDN ピア ルータを設定する例を示します。

アグリゲータは通常、コンセントレータ ルータであり、シスコ製ルータの非同期転送モード(ATM)Permanent Virtual Connection(PVC; 相手先固定接続)が終端します。次の設定例では、アグリゲータはイーサネット(PPPoE)サーバで PPP として設定されています。

ISDN ピア ルータは、ISDN インターフェイスを装備し、公衆 ISDN ネットワーク経由で Cisco ルータの ISDN インターフェイスに到達可能なルータです。ISDN ピア ルータは、ATM ネットワークがダウンした場合、Cisco ルータにインターネット アクセスできるようになります。

 
! This portion of the example configures the aggregator.
vpdn enable
no vpdn logging
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
!
interface Ethernet3
description “4700ref-1”
ip address 40.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Ethernet4
ip address 30.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Virtual-Template1
ip address 22.0.0.2 255.255.255.0
ip mtu 1492
peer default ip address pool adsl
!
interface ATM0
no ip address
pvc 1/40
encapsulation aal5snap
protocol pppoe
!
no atm limi-keepalive
!
ip local pool adsl 22.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
 
! This portion of the example configures the ISDN peer.
isdn switch-type basic-net3
!
interface Ethernet0
ip address 30.1.1.2 255.0.0.0
!
interface BRI0
description “to 836-dialbackup”
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer0
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 384020
dialer-group 1
peer default ip address pool isdn
!
ip local pool isdn 192.168.2.1
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 40.0.0.0 255.0.0.0 30.1.1.1
dialer-list 1 protocol ip permit