Cisco 3900 シリーズ、2900 シリーズ、および 1900 シリーズの第 2 世代サービス統合型ルータソフトウェア コンフィギュレーション ガイド
Cisco IOS CLI を使用した初期設定
Cisco IOS CLI を使用した初期設定
発行日;2013/01/29 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

Cisco IOS CLI を使用した初期設定

Cisco IOS CLI を使用した初期設定の前提条件

Cisco IOS CLI を使用した初期設定

ルータのホスト名の設定

イネーブルおよびイネーブル シークレット パスワードの設定

制約事項 

コンソールのアイドル特権 EXEC タイムアウトの設定

ギガビット イーサネット インターフェイスの設定

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

IP ルーティング

デフォルト ルート

デフォルト ネットワーク

ラスト リゾート ゲートウェイ

リモート コンソール アクセスのための仮想端末回線の設定

次の作業

補助回線の設定

ネットワーク接続の確認

前提条件

ルータ設定の保存

設定およびシステム イメージのバックアップ コピーの保存

Cisco IOS CLI を使用した初期設定

ここでは、Cisco Internet Operating System(IOS)コマンドライン インターフェイス(CLI)を使用した初期設定の方法について説明します。

「Cisco IOS CLI を使用した初期設定の前提条件」

「Cisco IOS CLI を使用した初期設定」


) ルータの初期設定を行うには、Cisco Configuration Professional Express Web ベース アプリケーションを使用することを推奨します。詳細については、Cisco.com の『Cisco Configuration Professional Express User Guide』(http://www.cisco.com/en/US/docs/net_mgmt/cisco_configuration_professional_express/version1_1/online_help/CCPE11.pdf)を参照してください。


 

Cisco 1941W ルータでのワイヤレス アクセス ポイントの初期設定

内蔵ワイヤレス access point(AP; アクセス ポイント)で、Cisco Internet Operating System(IOS)ソフトウェアの AP 自体のバージョンが実行されます。Cisco Configuration Professional Express を使用して、アクセス ポイント ソフトウェアの初期設定を行います。その他のワイヤレス パラメータの設定方法については、このマニュアルの 「無線デバイスの設定」 の章を参照してください。

Cisco IOS CLI を使用した初期設定の前提条件

シャーシの設置、ケーブルの接続、ハードウェアへの電源投入については、使用しているルータのハードウェア インストレーション ガイドの手順に従ってください。


ワンポイント アドバイス ルータに電源を投入する前に、AutoInstall プロセスが実行されないよう、すべての WAN ケーブルをルータから取り外します。WAN ケーブルが接続の両側のルータに取り付けられていて、ルータの NVRAM に有効なコンフィギュレーション ファイルが保存されていない場合(新しいインターフェイスを追加する場合など)、ルータの電源をオンにすると、AutoInstall の実行が試行される可能性があります。AutoInstall がリモートの TCP/IP ホストに接続されていないとルータが判断するのに、数分間かかることもあります。


Cisco IOS CLI を使用した初期設定

この項では、次の手順について説明します。

「ルータのホスト名の設定」(任意)

「イネーブルおよびイネーブル シークレット パスワードの設定」 (必須)

「コンソールのアイドル特権 EXEC タイムアウトの設定」(任意)

「ギガビット イーサネット インターフェイスの設定」 (必須)

「デフォルト ルートまたはラスト リゾート ゲートウェイの指定」 (必須)

「リモート コンソール アクセスのための仮想端末回線の設定」 (必須)

「補助回線の設定」(任意)

「ネットワーク接続の確認」 (必須)

「ルータ設定の保存」 (必須)

「設定およびシステム イメージのバックアップ コピーの保存」(任意)

ルータのホスト名の設定

ホスト名は CLI プロンプトとデフォルトの設定ファイル名に使用されます。ルータのホスト名を設定しないと、出荷時のデフォルトのホスト名である「Router」が使用されます。

ホスト名の大文字と小文字の区別が保持されることは期待しないでください。多くのインターネット ソフトウェア アプリケーションでは、大文字と小文字は同一に扱われます。通常実行するときに名前を大文字にすることは適切なこともありますが、表記法では、コンピュータ名はすべて小文字で表示されます。詳細については、RFC 1178 の「 Choosing a Name for Your Computer 」を参照してください。

名前は、Advanced Research Projects Agency Network(ARPANET)のホスト名に関する規則に従う必要があります。このルールではホスト名は文字で始まり、文字または数字で終わり、その間には文字、数字、またはハイフンしか使用できません。名前は 63 文字以下にする必要があります。詳細については、RFC 1035 の「 Domain Names--Implementation and Specification 」を参照してください。

手順の概要

1. enable

2. configure terminal

3. hostname name

4. ルータ プロンプトに新しいホスト名が表示されることを確認します。

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname myrouter

ネットワーク サーバのホスト名を指定または修正します。

ステップ 4

ルータ プロンプトに新しいホスト名が表示されることを確認します。

 

myrouter(config)#

--

ステップ 5

end

 

myrouter# end

(任意)特権 EXEC モードに戻ります。

イネーブルおよびイネーブル シークレット パスワードの設定

セキュリティのレイヤを追加するには、特にネットワークを経由するパスワードまたは TFTP サーバに保存されるパスワードの場合、 enable password コマンドまたは enable secret コマンドを使用します。どちらのコマンドも同じ結果を達成します。つまり、特権 EXEC(イネーブル)モードにアクセスするために入力する必要がある、暗号化されたパスワードを設定できます。

より高度な暗号化アルゴリズムが使用されるので、 enable secret コマンドを使用することを推奨します。 enable password コマンドを使用するのは、 enable secret コマンドを認識しない古いイメージの Cisco IOS ソフトウェアをブートする場合、または古いブート ROM をブートする場合だけです。

詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートと『 Improving Security on Cisco Routers 』テクニカル ノートも参照してください。

制約事項 

enable secret コマンドを設定した場合、このコマンドは enable password コマンドよりも優先されます。同時に 2 つのコマンドを有効にはできません。

手順の概要

1. enable

2. configure terminal

3. enable password password

4. enable secret password

5. end

6. enable

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

enable password password

 

Router(config)# enable password pswd2

(任意)多様な特権レベルに対して、アクセスを制御するローカル パスワードを設定します。

この手順を実行するのは、 enable secret コマンドを認識しない古いイメージの Cisco IOS ソフトウェアをブートする場合、または古いブート ROM をブートする場合だけです。

ステップ 4

enable secret password

 

Router(config)# enable secret greentree

enable password コマンドよりも強化したセキュリティ レイヤを指定します。

ステップ 3で入力したパスワードと同じパスワードを使用しないでください。

ステップ 5

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 6

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

新しいイネーブルまたはイネーブル シークレット パスワードが機能していることを確認します。

ステップ 7

end

 

Router(config)# end

(任意)特権 EXEC モードに戻ります。

コンソールのアイドル特権 EXEC タイムアウトの設定

ここでは、コンソール回線のアイドル特権 EXEC タイムアウトを設定する方法について説明します。デフォルトでは、特権 EXEC コマンド インタープリタは、ユーザ入力の検出を 10 分間待ってからタイムアウトします。

コンソール回線を設定するとき、通信パラメータの設定、自動ボー接続の指定、および使用している端末の端末操作パラメータの設定を行うこともできます。コンソール回線の設定方法の詳細については、『 Cisco IOS Configuration Fundamentals Configuration Guide 』の「Configuring Operating Characteristics for Terminals」、および『 Cisco IOS Network Management Configuration Guide 』の「Troubleshooting, Fault Management, and Logging」を参照してください。

手順の概要

1. enable

2. configure terminal

3. line console 0

4. exec-timeout minutes [ seconds ]

5. end

6. show running-config

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line console 0

 

Router(config)# line console 0

コンソール回線を設定し、回線コンフィギュレーション コマンドのコレクション モードを開始します。

ステップ 4

exec-timeout minutes [ seconds ]

 

Router(config-line)# exec-timeout 0 0

アイドル特権 EXEC タイムアウトを設定します。これは特権 EXEC コマンド インタープリタがユーザの入力が検出されるまで待つ間隔です。

次に、タイムアウトなしを指定する例を示します。exec-timeout 値を 0 に設定すると、ルータへのログイン後にタイムアウトでログアウトすることがなくなります。この場合、disable コマンドを使用して手動でログアウトせずにコンソールを離れると、セキュリティ上の問題が発生する可能性があります。

ステップ 5

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 6

show running-config

 

Router(config)# show running-config

実行コンフィギュレーション ファイルを表示します。

アイドル特権 EXEC タイムアウトを適切に設定したことを確認します。

次に、コンソールのアイドル特権 EXEC タイムアウトを 2 分 30 秒に設定する例を示します。

line console
exec-timeout 2 30
 

次に、コンソールのアイドル特権 EXEC タイムアウトを 10 秒に設定する例を示します。

line console
exec-timeout 0 10

ギガビット イーサネット インターフェイスの設定

ここでは、IP アドレスおよびインターフェイスの説明をルータのイーサネット インターフェイスに割り当てる方法について説明します。

ギガビット イーサネット インターフェイスに関する総合的な設定情報については、『 Cisco IOS Interface and Hardware Component Configuration Guide 』( http://www.cisco.com/en/US/docs/ios/12_2/interface/configuration/guide/icflanin.html )の「Configuring LAN Interfaces」を参照してください。

インターフェイスの付番方法の詳細については、ご使用のルータの『 Software Configuration Guide 』を参照してください。

手順の概要

1. enable

2. show ip interface brief

3. configure terminal

4. interface gigabitethernet 0/ port

5. description string

6. ip address ip-address mask

7. no shutdown

8. end

9. show ip interface brief

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

show ip interface brief

 

Router# show ip interface brief

IP に設定されているインターフェイスの簡単なステータスを表示します。

ルータ上にあるイーサネット インターフェイスの種類がわかります。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

interface gigabitethernet 0/ port

 

Router(config)# interface gigabitethernet 0/0

ギガビット イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

』を参照してください。

ステップ 5

description string

 

Router(config-if)# description GE int to 2nd floor south wing

(任意)インターフェイス設定に説明を追加します。

説明があると、そのインターフェイスに接続されているものを思い出しやすくなります。また、トラブルシューティングのために役立つこともあります。

ステップ 6

ip address ip-address mask

 

Router(config-if)# ip address 172.16.74.3 255.255.255.0

インターフェイスのプライマリ IP アドレスを設定します。

ステップ 7

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 9

show ip interface brief

 

Router# show ip interface brief

IP に設定されているインターフェイスの簡単なステータスを表示します。

イーサネット インターフェイスが起動し、正しく設定されていることを確認します。

ギガビット イーサネット インターフェイスの設定:例

!
interface GigabitEthernet0/0
description GE int to HR group
ip address 172.16.3.3 255.255.255.0
duplex auto
speed auto
no shutdown
!

show ip interface brief コマンドの出力例

Router# show ip interface brief
 
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 172.16.3.3 YES NVRAM up up
GigabitEthernet0/1 unassigned YES NVRAM administratively down down
Router#

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

ここでは、IP ルーティングをイネーブルにしてデフォルト ルートを指定する方法について説明します。デフォルト ルートの指定の代替手段については、『 Configuring a Gateway of Last Resort Using IP Commands 』テクニカル ノートを参照してください。

パケットのよりよいルートがない場合、および宛先が接続されているネットワークではない場合、Cisco IOS ソフトウェアはラスト リゾート ゲートウェイ(ルータ)を使用します。ここでは、デフォルト ルート(ラスト リゾート ゲートウェイを計算するルート候補)としてネットワークを選択する方法について説明します。ルーティング プロトコルがデフォルト ルート情報を伝播する方法は、プロトコルによって異なります。

IP ルーティングおよび IP ルーティング プロトコルの総合的な設定情報については、『 Cisco IOS IP Configuration Guide 』を参照してください。特に、「Configuring IP Addressing」の章および「Part 2: IP Routing Protocols」のすべての章を参照してください。

IP ルーティング

ルータがルーティングとブリッジ処理を同時に実行するように、Integrated Routing and Bridging(IRB)を設定できます。ルーティングがイネーブルかどうかに関係なく、ルータはネットワーク上の IP ホストとして動作します。IRB に関する詳細を表示するには、Cisco.com の次の URL を参照してください。
http://www.cisco.com/en/US/tech/tk389/tk815/tk855/tsd_technology_support_sub-protocol_home.html

IP ルーティングは Cisco IOS ソフトウェアで自動的にイネーブルにされます。IP ルーティングを設定すると、設定済みのデフォルト ルートなど、パケットの転送に設定済みまたは既存のルートが使用されます。


) このタスク セクションは、IP ルーティングをディセーブルにするときは適用されません。IP ルーティングをディセーブルにするときにデフォルト ルートを指定するには、Cisco.com の『Configuring a Gateway of Last Resort Using IP Commands』テクニカル ノートを参照してください。


デフォルト ルート

ルータは他のすべてのネットワークに対してルートを決定できないこともあります。ルーティング機能を実現するための一般的な方法は、スマート ルータとして複数のルータを使用し、残りのルータのデフォルト ルータをスマート ルータに設定します (スマート ルータには、インターネットワーク全体のルーティング テーブル情報があります)。これらのデフォルト ルートをダイナミックに渡すことや、個々のルータに設定することができます。

ほとんどのダイナミックな内部ルーティング プロトコルには、スマート ルータがダイナミックなデフォルト情報を生成し、それを他のルータに渡す処理を発生させるメカニズムが含まれます。

デフォルト ネットワーク

指定したデフォルト ネットワークに直接接続されているインターフェイスがルータにある場合、ルータで実行されるダイナミック ルーティング プロトコルによって、デフォルト ルートが生成されるか、デフォルト ルートが調達されます。RIP の場合、ルータは疑似ネットワーク 0.0.0.0 をアドバタイズします。IGRP の場合、ネットワーク自体がアドバタイズされ、外部ルートとしてフラグが付けられます。

ネットワークのデフォルトを生成するルータも、デフォルト ルータを必要とする場合があります。ルータが自身のデフォルト ルートを生成する方法の 1 つは、適切なデバイスを経由してネットワーク 0.0.0.0 に至るスタティック ルートを指定することです。

ラスト リゾート ゲートウェイ

デフォルト情報をダイナミック ルーティング プロトコルを介して渡している場合、その他の設定は不要です。ルーティング テーブルは定期的にスキャンされ、デフォルト ルートとして最適なデフォルト ネットワークが選択されます。RIP の場合、0.0.0.0 という唯一の選択肢しかありません。IGRP の場合、システム デフォルトの候補にすることができるネットワークが複数存在することもあります。Cisco IOS ソフトウェアではアドミニストレーティブ ディスタンスおよびメトリック情報の両方を使用して、デフォルト ルート(ラスト リゾート ゲートウェイ)を判断します。選択したデフォルト ルートは、 show ip route EXEC コマンドのラスト リゾート ゲートウェイの表示に表示されます。

ダイナミックなデフォルト情報がソフトウェアに渡されない場合、デフォルト ルートの候補を ip default-network グローバル コンフィギュレーション コマンドで指定します。この方法では、 ip default-network コマンドは引数として未接続ネットワークを使用します。このネットワークが任意のソース(ダイナミックまたはスタティック)のルーティング テーブルに表示される場合、デフォルト ルート候補としてフラグが付けられ、デフォルト ルートとして使用できる選択肢になります。

ルータのデフォルト ネットワークにインターフェイスがなく、そのネットワークに対するルートはある場合、そのネットワークはデフォルト パス候補と見なされます。ルート候補は検査され、アドミニストレーティブ ディスタンスおよびメトリックに基づいて最適な候補が選択されます。最適なデフォルト パスに対するゲートウェイは、ラスト リゾート ゲートウェイになります。

手順の概要

1. enable

2. configure terminal

3. ip routing

4. ip route dest-prefix mask next-hop-ip-address [ admin-distance ] [ permanent ]

5. ip default-network network-number
または
ip route dest-prefix mask next-hop-ip-address

6. end

7. show ip route

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip routing

 

Router(config)# ip routing

IP ルーティングをイネーブルにします。

ステップ 4

ip route dest-prefix mask next-hop-ip-address [ admin-distance ] [ permanent ]

 

Router(config)# ip route 192.168.24.0 255.255.255.0 172.28.99.2

スタティック ルートを確立します。

ステップ 5

ip default-network network-number

または

ip route dest-prefix mask next-hop-ip-address

 

Router(config)# ip default-network 192.168.24.0

 

Router(config)# ip route 0.0.0.0 0.0.0.0 172.28.99.1

ラスト リゾート ゲートウェイを計算するルート候補としてネットワークを選択します。

ラスト リゾート ゲートウェイを計算するために、ネットワーク 0.0.0.0 0.0.0.0 に対するスタティック ルートを作成します。

ステップ 6

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 7

show ip route

 

Router# show ip route

現在のルーティング テーブル情報を表示します。

ラスト リゾート ゲートウェイが設定されていることを確認します。

デフォルト ルートの指定:例

!
ip routing
!
ip route 192.168.24.0 255.255.255.0 172.28.99.2
!
ip default-network 192.168.24.0
!

show ip route コマンドの出力例

Router# show ip route
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
 
Gateway of last resort is 172.28.99.2 to network 192.168.24.0
 
172.24.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.24.192.0 is directly connected, GigaEthernet0
S 172.24.0.0 255.255.0.0 [1/0] via 172.28.99.0
S* 192.168.24.0 [1/0] via 172.28.99.2
172.16.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.16.99.0 is directly connected, GigaEthernet1
Router#

リモート コンソール アクセスのための仮想端末回線の設定

Virtual Terminal(VTY; 仮想端末)回線は、ルータに対してリモート アクセスするために使用されます。ここでは、電源があるユーザだけがルータをリモート アクセスできるように、パスワードを使用して仮想端末回線を設定する方法について説明します。

デフォルトで、ルータには 5 個の仮想端末回線があります。ただし、『Cisco IOS Terminal Services Configuration Guide, Release 12.4』に従って、追加の仮想端末回線を作成できます。「 Configuring Terminal Operating Characteristics for Dial-In Sessions 」の項を参照してください。

回線パスワードおよびパスワードの暗号化については、『Cisco IOS Security Configuration Guide, Release 12.4』を参照してください。「 Security with Passwords, Privilege Levels, and Login Usernames for CLI Sessions on Networking Devices 」の項を参照してください。アクセス リストで VTY 回線のセキュリティを保護する場合、『 Access Control Lists: Overview and Guidelines 』を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートを参照してください。

手順の概要

1. enable

2. configure terminal

3. line vty line-number [ ending-line-number ]

4. password password

5. login

6. end

7. show running-config

8. 別のネットワーク デバイスから、ルータに対する Telnet セッションの開始を試行します。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line vty line-number [ ending-line-number ]

 

Router(config)# line vty 0 4

リモート コンソール アクセスために、仮想端末回線(VTY)の回線コンフィギュレーション コマンドのコレクション モードを開始します。

ルータ上のすべての VTY 回線を設定していることを確認します。

コマンドを使用します。

ステップ 4

password password

 

Router(config-line)# password guessagain

回線のパスワードを指定します。

ステップ 5

login

 

Router(config-line)# login

ログイン時のパスワード チェックをイネーブルにします。

ステップ 6

end

 

Router(config-line)# end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

 

Router# show running-config

実行コンフィギュレーション ファイルを表示します。

リモート アクセスのために仮想端末回線を適切に設定したことを確認します。

ステップ 8

別のネットワーク デバイスから、ルータに対する Telnet セッションの開始を試行します。

 

Router# 172.16.74.3

Password:

ルータにリモート アクセスできること、および仮想端末回線のパスワードが正しく設定されていることを確認します。

次に、パスワードを使用して仮想端末回線を設定する例を示します。

!
line vty 0 4
password guessagain
login
!

次の作業

VTY 回線を設定したら、次の手順を実行します。

(任意)仮想端末回線のパスワードを暗号化するには、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」の章を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートを参照してください。

(任意)アクセス リストを使用して VTY 回線をセキュリティ保護するには、『 Cisco IOS Security Configuration Guide 』の「Part 3: Traffic Filtering and Firewalls」を参照してください。

補助回線の設定

ここでは、補助回線について回線コンフィギュレーション モードを開始する方法について説明します。補助回線の設定方法は、補助(AUX)ポートの具体的な実装によって異なります。補助回線の設定については、次のマニュアルを参照してください。

Configuring a Modem on the AUX Port for EXEC Dialin Connectivity 』テクニカル ノート http://www.cisco.com/en/US/tech/tk801/tk36/technologies_tech_note09186a0080094bbc.shtml

Configuring Dialout Using a Modem on the AUX Port 』サンプル設定 http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094579.shtml

Configuring AUX-to-AUX Port Async Backup with Dialer Watch 』サンプル設定 http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080093d2b.shtml

Modem-Router Connection Guide 』テクニカル ノート http://www.cisco.com/en/US/tech/tk801/tk36/technologies_tech_note09186a008009428b.shtml

手順の概要

1. enable

2. configure terminal

3. line aux 0

4. AUX ポートの特定の実装に合わせて回線を設定するには、テクニカル ノートと設定例を参照してください。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line aux 0

 

Router(config)# line aux 0

補助回線について回線コンフィギュレーション コマンドのコレクション モードを開始します。

ステップ 4

AUX ポートの特定の実装に合わせて回線を設定するには、テクニカル ノートと設定例を参照してください。

--

ネットワーク接続の確認

ここでは、ルータのネットワーク接続を確認する方法について説明します。

前提条件

このマニュアルで前述したすべての設定タスクを完了します。

適切に設定したネットワーク ホストにルータを接続する必要があります。

手順の概要

1. enable

2. ping [ ip-address | hostname ]

3. telnet { ip-address | hostname }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

ping [ ip-address | hostname ]

 

Router# ping 172.16.74.5

初期ネットワーク接続を診断します。

接続を確認するには、ネクスト ホップのルータ、または設定済みの各インターフェイスに接続しているホストに対して ping を実行します。

ステップ 3

telnet { ip-address | hostname }

 

Router# telnet 10.20.30.40

Telnet をサポートするホストにログインします。

VTY 回線パスワードをテストする場合、別のネットワーク デバイスからこの手順を実行し、ルータの IP アドレスを使用します。

次の表示は、IP アドレス 192.168.7.27 に対して ping を実行したときの出力例です。

Router# ping
 
Protocol [ip]:
Target IP address: 192.168.7.27
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/2/4 ms
 

次の表示は、IP ホスト名 username1 に対して ping を実行したときの出力例です。

Router# ping username1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/3/4 ms

ルータ設定の保存

ここでは、実行コンフィギュレーションを NVRAM のスタートアップ コンフィギュレーションに保存することで、次のシステム リロード時、または電源の再投入時に設定を失わない方法について説明します。NVRAM には、ルータ上に 256KB のストレージがあります。

手順の概要

1. enable

2. copy running-config startup-config

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

copy running-config startup-config

 

Router# copy running-config startup-config

実行中の設定をスタートアップ コンフィギュレーションに保存します。

設定およびシステム イメージのバックアップ コピーの保存

ファイルの破損時にファイルの回復を補助し、ダウンタイムを最小限に抑えるために、スタートアップ コンフィギュレーション ファイルおよび Cisco IOS ソフトウェア システム イメージ ファイルのバックアップ コピーをサーバに保存することを推奨します。

手順の概要

1. enable

2. copy nvram:startup-config { ftp: | rcp: | tftp: }

3. show {flash0 | flash1}:

4. copy {flash0 | flash1}: { ftp: | rcp: | tftp: }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

copy nvram:startup-config { ftp: | rcp: | tftp: }

 

Router# copy nvram:startup-config ftp:

スタートアップ コンフィギュレーション ファイルをサーバにコピーします。

コンフィギュレーション ファイルのコピーはバックアップ コピーとして使用できます。

プロンプトが表示されたら、コピー先の URL を入力します。

ステップ 3

show {flash0 | flash1}:

 

Router# show {flash0|flash1} :

フラッシュ メモリ ファイル システムのレイアウトとコンテンツを表示します。

システム イメージ ファイルの名前を確認します。

ステップ 4

copy {flash0 | flash1}: { ftp: | rcp: | tftp: }

 

Router# copy {flash0|flash1}: ftp :

フラッシュ メモリのファイルをサーバにコピーします。

システム イメージ ファイルをサーバにコピーし、バックアップ コピーとして使用します。

プロンプトが表示されたら、ファイル名とコピー先の URL を入力します。

スタートアップ コンフィギュレーションの TFTP サーバへのコピー:例

次に、スタートアップ コンフィギュレーションを TFTP サーバにコピーする例を示します。

Router# copy nvram:startup-config tftp:
 
Remote host[]? 172.16.101.101
 
Name of configuration file to write [rtr2-confg]? <cr>
Write file rtr2-confg on host 172.16.101.101?[confirm] <cr>
![OK]

フラッシュ メモリから TFTP サーバへのコピー:例

次に、特権 EXEC で show {flash0|flash1}: コマンドを使用してシステム イメージ ファイルの名前を確認し、 copy {flash0|flash1}: tftp: 特権 EXEC コマンドを使用して、システム イメージ(c3900-2is-mz)を TFTP サーバにコピーする例を示します。このルータはデフォルトのユーザ名とパスワードを使用しています。

Router# show {flash0|flash1}:
 
System flash directory:
File Length Name/status
1 4137888 c3900-c2is-mz
[4137952 bytes used, 12639264 available, 16777216 total]
16384K bytes of processor board System flash (Read/Write)\
 
Router# copy {flash0|flash1}: tftp:
 
IP address of remote host [255.255.255.255]? 172.16.13.110
filename to write on tftp host? c3600-c2is-mz
writing c3900-c2is-mz !!!!...
successful ftp write.