Commutateurs : Commutateurs Cisco Catalyst, série 6500

Exemple de configuration de commutateurs Catalyst pour l'équilibrage de charge réseau Microsoft

30 juillet 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (6 juin 2013) | Commentaires

Introduction

Ce document décrit la méthode de configuration de commutateurs Cisco Catalyst afin qu’ils interagissent avec l’équilibrage de charge réseau (NLB) Microsoft.

Contribué par Shashank Singh, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Logiciel courant de Cisco IOS® de commutateur de Catalyst 6500

  • Logiciel courant de Cisco IOS de commutateur du Catalyst 4500

  • Logiciel courant de Cisco IOS de commutateur du Catalyst 3550

  • Logiciel courant de Cisco IOS de commutateur de Catalyst 3560

  • Logiciel courant de Cisco IOS de commutateur de Catalyst 3750

  • Serveurs Microsoft Windows 2000/2003

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande. 

Informations générales

La technologie d’équilibrage de charge réseau (NLB) peut être utilisée pour répartir les demandes des clients dans un ensemble de serveurs. Afin de s’assurer que les clients bénéficient toujours de niveaux de performances acceptables, Windows NLB est fréquemment utilisé pour garantir la possibilité d’ajouter des serveurs supplémentaires pour faire évoluer les applications, notamment les serveurs Web basés sur IIS, à mesure que la charge client augmente. En outre, il permet de réduire les temps d’arrêt causés par des défaillances de serveurs. Les utilisateurs finaux n’ont jamais connaissance de la désactivation d’un serveur spécifique du système Windows NLB.

L’équilibrage de charge réseau est une technologie de mise en cluster proposée par Microsoft et intégrée à tous les systèmes d’exploitation de la gamme Windows 2000 Server et Windows Server 2003. NLB utilise un algorithme distribué pour équilibrer la charge du trafic réseau sur un certain nombre de serveurs.

Cette technologie regroupe les serveurs en un groupe multicast et tente d’utiliser l’adresse multicast IP et l’adresse MAC standard. Dans le même temps, elle fournit une adresse IP virtuelle unique servant d’adresse IP cible à tous les clients, ce qui signifie que les serveurs rejoignent le même groupe multicast, sans que les clients n’en aient conscience. Ils utilisent un accès unicast normal au VIP.

Vous pouvez configurer le NLB de sorte qu’il fonctionne dans l’un des modes suivants :

Mode Unicast

Par défaut, le NLB est défini en mode unicast. En mode unicast, NLB remplace l’adresse MAC réelle de chaque serveur du cluster par une adresse MAC NLB commune. Lorsque tous les serveurs du cluster possèdent la même adresse MAC, tous les paquets transférés à cette adresse sont envoyés à l’ensemble des membres du cluster. Cette configuration pose toutefois un problème. Lorsque les serveurs du cluster NLB sont connectés au même commutateur, deux ports du commutateur ne peuvent pas enregistrer la même adresse MAC. NLB résout ce problème en masquant l’adresse MAC du cluster. Le commutateur examine l’adresse MAC source dans l’en-tête de trame Ethernet afin de connaître les adresses MAC associées à ses ports. NLB crée une adresse MAC factice qu’il assigne à chaque serveur du cluster NLB. NLB attribue à chaque serveur NLB une adresse MAC factice différente, en fonction de l’ID d’hôte du membre. Cette adresse s’affiche dans l’en-tête de trame Ethernet.

Par exemple, l’adresse MAC du cluster NLB est 00-bf-ac-10-00-01. NLB en mode d'unicast prend l'adresse MAC de batterie et, pour chaque cluster member, NLB change-il le deuxième octet de sorte qu'il comprenne le membre NLB ? l'identification d'hôte s par exemple, le serveur le numéro 1 comme adresse MAC factice 00-01-ac-10-00-01, le numéro d'ID 2 d'hôte a l'adresse MAC factice 00-02-ac-10-00-01, ainsi de suite. Si une adresse MAC unique est enregistrée sur chaque port de commutation, les paquets ne sont pas livrés aux membres de la matrice. Les paquets doivent toujours être envoyés aux ports de commutation individuels en fonction de l’adresse MAC affectée à ce port. Une diffusion ARP est utilisée pour s’assurer que les trames sont livrées à tous les membres du cluster NLB lorsque chaque port de commutation connecté à un membre du cluster NLB enregistre une adresse MAC différente. Lorsque le routeur envoie une demande ARP afin d’obtenir l’adresse MAC de l’adresse IP virtuelle, la réponse contient un en-tête APR comportant l’adresse MAC réelle du cluster NLB (00-bf-ac-10-00-01 comme indiqué dans l’exemple ci-dessus) et non l’adresse MAC factice.

Les clients utilisent l’adresse MAC contenue dans l’en-tête ARP et non dans l’en-tête Ethernet. Le commutateur utilise l’adresse MAC contenue dans l’en-tête Ethernet et non celle de l’en-tête ARP. Un problème se pose lorsqu’un client envoie un paquet au cluster NLB avec une adresse MAC correspondant à l’adresse MAC du cluster (00-bf-ac-10-00-01) ; le commutateur recherche alors l’adresse MAC 00-bf-ac-10-00-01 dans la table CAM. Étant donné qu’aucun port n’est enregistré avec l’adresse MAC de cluster NLB 00-bf-ac-10-00-01, la trame est livrée à tous les ports de commutation. Cela entraîne une inondation du commutateur. L’inondation de commutateur entraîne des problèmes lorsqu’une quantité significative de trafic circule et lorsque d’autres serveurs se trouvent sur le même commutateur. Pour résoudre le problème de l’inondation de commutateur, il suffit de placer un simple concentrateur devant les membres du cluster NLB puis d’établir une liaison ascendante entre le concentrateur et un port de commutation. Grâce à cette solution, il n’est pas nécessaire de masquer l’adresse MAC du cluster NLB car le port de commutation unique connecté au concentrateur apprend l’adresse MAC du cluster NLB. Cela permet d’éviter que deux ports de commutation n’enregistrent la même adresse MAC. Lorsque le client envoie des paquets à l’adresse MAC du cluster NLB, le paquet est transmis directement au port de commutation connecté au concentrateur, puis aux membres du cluster NLB.

Mode Multicast

Il est également possible d’utiliser le mode multicast à la place du mode unicast dans la GUI de configuration de Microsoft NLB. En mode multicast, l’administrateur système clique sur le bouton IGMP Multicast dans la GUI de configuration de Microsoft NLB. Ce choix indique aux membres du cluster de répondre aux demandes ARP pour leurs adresses virtuelles à l’aide d’une adresse MAC multicast (0300.5e11.1111, par exemple), puis d’envoyer des paquets de rapport d’adhésion IGMP. Si IGMP Snooping est activé sur le commutateur local, les paquets IGMP transitant dans le commutateur sont interceptés. De cette façon, quand ARPs d'un client pour la batterie ? l'adresse IP virtuelle s, la batterie répond avec le MAC multicast par exemple 0300.5e11.1111. Lorsque le client envoie le paquet à l’adresse 0300.5e11.1111, le commutateur local le transmet à tous les ports connectés aux membres du cluster. Il est alors impossible d’inonder l’ensemble des ports avec le paquet ARP. Le problème avec le mode multicast est que l’adresse IP virtuelle est inaccessible si la tentative d’accès provient de l’extérieur du sous-réseau local car les périphériques Cisco n’acceptent pas les réponses ARP pour une adresse IP unicast contenant une adresse MAC multicast. La portion MAC de l’entrée ARP s’affiche alors comme incomplete (Incomplète). (Utilisez la commande show arp pour afficher la sortie.) Puisqu’il n’existe pas de portion MAC dans la réponse ARP, l’entrée ARP ne s’affiche jamais dans la table ARP. Finalement l’envoi de demandes ARP s’arrête et une réponse « ICMP Host unreachable » (Hôte ICMP inaccessible) est envoyée au client. Pour surmonter ce problème, utilisez l’entrée statique ARP pour remplir la table ARP (voir ci-dessous). En théorie, cela permet au périphérique Cisco de remplir sa table d’adresses MAC. Par exemple, si l’adresse IP virtuelle est 172.16.63.241 et si l’adresse MAC Multicast est 0300.5e11.1111, utilisez cette commande pour remplir la table ARP de manière statique :

arp 172.16.63.241 0300.5e11.1111

Toutefois, puisque les paquets entrants comportent une adresse IP cible unicast et une adresse MAC cible multicast, le périphérique Cisco ignore cette entrée commute tous les paquets à destination du cluster. Pour éviter cette commutation de processus, insérez une entrée de table d’adresses MAC statique (voir ci-dessous) afin de commuter les paquets à destination du cluster dans le matériel.

mac-address-table static 0300.5e11.1111 vlan 200 interface
fa2/3 fa2/4

Remarque: Statiquement la cartographie du MAC aux plusieurs ports est prise en charge seulement en logiciel sur le commutateur du Catalyst 4500. Utilisant cette configuration sur le Catalyst 4500 le commutateur peut entraîner la CPU de haute.

 

Remarque: Pour les commutateurs Cisco de la gamme Cisco Catalyst 6000/6500, vous devez ajouter le paramètre disable-snopping . Exemple :

mac-address-table static 0300.5e11.1111 vlan 200
interface fa2/3 fa2/4 disable-snooping

Le paramètre disable-snooping est essentiel et applicable uniquement aux commutateurs de la gamme Cisco Catalyst 6000/6500. Sans cette instruction, le comportement n’est pas affecté.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Configurations

Ce document utilise la configuration de commutateur Catalyst 6509 décrite dans cette section.

Cat6K#show running-config
Building configuration...
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6K
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin
!
redundancy
main-cpu
auto-sync standard
ip subnet-zero
!
!
interface GigabitEthernet1/1
no ip address
shutdown
!
interface GigabitEthernet1/2
no ip address
shutdown
!
interface FastEthernet2/1
description "Uplink to the Default Gateway"
no ip address
switchport
switchport access vlan 100
!
interface FastEthernet2/2
no ip address
shutdown
!
interface FastEthernet2/3
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/4
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/5
no ip address
shutdown
!
interface FastEthernet2/48
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
mac-address-table static 0300.5e11.1111 vlan 200 interface fa2/3 fa2/4 disable-snooping

! --- Creating a static entry in the switch for the multicast virtual mac.

! --- fa2/3 & fa2/4 are the ports connected to server.

!--- The disable-snooping is applicable only for Cisco Catalyst 6000/6500 series switches

arp 172.16.63.241 0300.5e11.1111

! --- 172.16.63.241 is the Virtual IP of 2 servers

interface Vlan100
ip address 172.17.63.240 255.255.255.192

!--- Client Side Vlan
!
interface Vlan200
ip address 10.1.1.250 255.255.255.0

!--- Server Vlan

!--- Important: Configure the default gateway

!--- of the Microsoft Server to this address.

!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.63.193
no ip http server
!
line con 0
line vty 0 4
login
!
end

Remarque: Assurez-vous que le cluster NLB est défini en mode multicast. Cisco vous recommande de ne pas utiliser d’adresses MAC multicast commençant par 01 car elles entrent en conflit avec la configuration IGMP.

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • show mac-address-table - Affiche une charge statique de table d'adresse MAC et une entrée dynamique spécifique ou la charge statique et les entrées dynamiques de table d'adresse MAC sur une interface ou un VLAN spécifique.

    Cat6K#show mac-address-table 0300.5e11.1111

              Mac Address Table
    -------------------------------------------

    Vlan    Mac Address      vType        Ports
    ---- -----------      --------     -----
    200    0300.5e11.1111     STATIC    Fa2/3 Fa2/4
  • show ip arp - Affiche le cache de Protocole ARP (Address Resolution Protocol).

    Cat6K#show ip arp
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  172.16.1.1            -     0300.5e11.1111  ARPA   Vlan200

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Informations connexes


Communauté de support Cisco - Conversations à l'affiche

La Communauté de support Cisco est un forum où vous pouvez poser vos questions et répondre à d'autres, offrir des conseils et collaborer avec des collègues. Voici quelques séances parmi les plus récentes et importantes présentées dans notre forum.


Document ID: 107995