簡介
本文說明如何解決與Secure Web Gateway(SWG)和Symantec產品與LiveUpdate的相容問題。
必要條件
需求
本文件沒有特定需求。
採用元件
本檔案中的資訊是根據Cisco Secure Web Gateway。
本文中的資訊是根據特定實驗室環境內的裝置所建立。文中使用到的所有裝置皆從已清除(預設)的組態來啟動。如果您的網路運作中,請確保您瞭解任何指令可能造成的影響。
問題
本文以LiveUpdate為Secure Web Gateway(SWG)和Symantec產品的使用者為目標。如果您沒有將這些產品與SWG配合使用,則本文不適用。
本文適用於Symantec使用者,在SAML使用者身份驗證處於活動狀態時,通過雲交付防火牆(CDFW)、AnyConnect SWG代理、PAC檔案或任何其他方法使用SWG。在預設配置中,使用SWG可能導致Symantec崩潰,從而導致Windows中出現藍色畫面。
強制性SAML和HTTPS排除
當SWG上的SAML身份驗證處於活動狀態時,所有並非來自支援會話的瀏覽器的查詢都會收到無法完成的重定向響應。在某些情況下,這可能會導致在請求應用程式中出現意外行為。
解決方案
- 將liveupdate.symantecliveupdate.com新增到HTTPS解密繞過清單。
- 如果在AnyConnect中使用PAC或SWG模組,請將liveupdate.symantecliveupdate.com新增到Domain Management > External Domains清單中。
原因
在Synamtec LiveUpdate中,必須將liveupdate.symantecliveupdate.com新增到HTTPS解密例外清單中,以允許LiveUpdate運行。這不包括來自SAML要求的這些請求,並使用標準策略響應來回應請求。