HEBRCOS AP5| SR B FMAPHR G T ¢
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B
FREM
ZR
FERAMNAY
APE| &35
us|g
U-Boot/Z 3 A FF
{£2kU-Boot5| § 7 X
Cos# =
AP RERE
show image inteqrity&y &
show filesystems & &
APF 4 B4R
AP NE SR
AP T
B GUIF TEAP
BNCLIIA TEHAP
REWLCHIAPH
BN GUIFAERFREWLCHIAP
BECLIARFREWLCHAP
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HEEE
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AN AAPEII TR, APHEBREMAPRE TR ENFHATIE,
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Cisco BB THLUTEE :

- CatalystFTo4k LANIZ #2569 E Atk AR
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« B RlAironet 3802 L&LIEA R
ANHEFHNEEHRETREXRENREFNIRZREN, AP FEANMERERYVEXAR
B(B®A)BE. MREBHWMELTFEIRS , BHAETHEMEGSHNEER R,
AP5| &3 12
UsI&

U-Boot /s 31 il

Cisco APTEU-BOOTEX T K5I & HE , ZEXREEETCOSHRZH, Bt AU-BOOTERR
, BERUTSR,

1. FHEH & A EEIAPEH SR O,

2. EPCLITALWBERF , AN ERENEBWAETCOMKEH, RIFEERE L&A/
COMiw .,

3. AR E BRI IRE N £H 115200 bpsiki 45,



AE  MRAPEERE |, BHRERIRE NG00,

4EEEARBER,

5B RE ¥ X (esc)iRM#H AU-BootiE = |, &R LAE FiETHit ESC to stop autoboot , HFESE
BEFT. EEZIEHAKON , TLXEAREFEINSERIER,
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U-Boot 2013.01-gelc49d93a (Jul 28 2023 - 09:08:14) SDK version: 2015_T2.0pl0

Board: Barbados-3K
SoC: MV88F6920 Rev Al
running 2 CPUs
CPU: ARM Cortex A9 MPCore (Rev 1) LE

CPU O
CPU @ 1800 [MHz]
L2 @ 900 [MHz]

TClock @ 250 [MHz]

DDR4 @ 900 [MHz]

DDR4 32 Bit width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM: 1 GiB

RST I2CO

NAND: ECC 4bits, 256 MiB

SF: Detected N25Q32A with page size 64 KiB, total 4 MiB

PCI-e 1 (IF O - bus 0) Root Complex Interface, Detected Link X1, GEN 2.0
PCI-e 2 (IF 1 - bus 1) Root Complex Interface, Detected Link X1, GEN 2.0

Map : Code: 0x3fed7000: 0x3ffad848
BSS: 0x3ffef314
Stack: 0x3f9c6f20
Heap: 0x3f9c7000: 0x3fed7000
U-Boot Environment: 0x00100000:0x00110000 (SPI)

Board configuration:
| port | Interface

I
| egigal | SGMII 0x01 |
| egigaz | SGMII | In-Band |
Net: egigal. eqgigaz? [PRTIME]

Hit ESC key to stop autoboot: O]
U-boot>>

U-BootBzI RE

FEU-Boot#E X T &£ A printenvin & 51| H 3 A S & P U-Boot IR R i 4115 B



BOOT=part
CASset=max
ENABLE_BREAK=1
FACTORY_RESET=0
MALLOC_len=5
MANUAL_BOOT=0
MEMORY_DEBUG=0
MPmode=SMP
PART_BOOTCNT=3
autoload=yes

baudrate=9600

b R EAEI S 2 X Rpart1, 1b515 2 XA HAFEU-BootR = TE X,

18 U-Boot5| &2 X
1. {f Fsetenve BOOT part <1-2> S F AR YH 5|20 K,

2. EASsaveenviR 79 XiEE,
3. EAprintenvip S RIEZH #1 5| § 2 X,

OOOOOOOOOOOOOOO



Saving Environment to SPI Flash...

SF: Detected N25Q32A with page size 64 KiB, total 4 MiB
Erasing SPI flash....Writing to SPI flash..... done
u-boot>> printenv

BOOT=part 2

4 fEAbootin S ERAFEEMN SIS 2 XB3IAP,

u-boot>> boot

Creating 1 MTD partitions on "nand0":
0x000000200000-0x000010000000 : "mtd=2"
UBI: attaching mtdl to ubiO

ubifsmount - mount UBIFS volume

Usage:
ubifsmount

- mount 'volume-name' volume
UnabTle to ubi mount UBIFS partition part 2
Trying alternate partition part2
UBIFS: mounted UBI device 0, volume 0, name "part2"

5EASAMNEENEIS 9 KBS,
COSH=

APXHRERE



AR BWEARZAIEFNMNBAP, XAFEARZBRIMAABERFN XGRS , HRIHFH
e B 324

MAP L EYCLIE A Privilegedmode 12 171X e dp 5 LA IE ZH BIAPBR & Ftmp B KK/
show image integrity@n &

L H 48 RAP £ B 2 BTAR R,
Primary 7 X iR A48 7R 2 BIAP 5| § b 2}

BackupZ XAR AR RAP&Z 13 MR A

AP-CW9162#show image integrity
/partl(primary) 17.15.3.28
part.bin : Good
ramfs_data_cisco.squashfs : Good



iox.tar.gz : Good
/part2(Backup) 17.9.6.40

part.bin : Good

ramfs_data_cisco.squashfs : Good

iox.tar.gz : Good

B LERBAGTELMAPSISIREAZE TR, APET —REMMBEEAFES XE3 :

BLE S| SHRE1 (EAF1E D MRAEIFAP )
/)
BLE S| SHE2 ( EAF2E D MAEIFAP )

show filesystems#p

R RAPHY M R4 1




7% : Mounted onFI Y /tmp T E R A TAPARNAPBRRFREN X HRERE

<#root>

AP-CW9162#show filesystems

Filesystem Size Used Available Use% Mounted on
none 114. 4M 4. 7M 109.7M 4% /tnp

AP tmpX 4 RELTMEF100MFEE KW KD, tmpXHREA TEHEAPIREH L,

AE  NMBAmpMHREZEFRI100MHFERE , MAREER T2 XM SE KAAPER ]
B, BEEEIEAT ED XNAPBEG T 875 5HAPHRZIREA17.6.6.
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Upgrade Path to Cisco |10S XE 17.15.x

Table 15, Upgrade Path to Cisco 105 XE Dublin 17.15.x {(where x = 1)

Current Software Upgrade Path for Deployments with Upgrade Path for Deployments
9130 0r 9124 Without 9130 or 9124
16.10.x = Upgrade first to 16.12.5 or 17.3.x and

then to 17.15.%.

16.11.% - Upgrade first to 16.12.5 or 17.3.x and
then to 17.15.x.

16.12.x Upgrade first to 17.3.5 or later or 17.6.x | Upgrade first to 17.3.5 or later or 17.6.x
or later, then to 17.9.6 or later or 17.12.x | or later, and then to 17.15.x.
or later, and then to 17.15.x.

17.1.x Upgrade first to 17.3.5 or later, then to Upgrade first to 17.3.5 or later and then
17.9.6 or later or 17.12.% or later, and to 17.15.x.
then to 17.15.x.

17.2.x Upgrade first to 17.3.5 or later, then to Upgrade first to 17.3.5 or later and then
17.9.6 or later or 17.12.x or later, and to 17.15.x,
then to 17.15.x.

173110 17.3.4 Upgrade first to 17.3.5 or later or 17.6.x | Upgrade directly to 17.15.x.
or later, then to 17.9.6 or later or
17.12.x or later, and then to 17.15.x.

17.3.4c or later Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.4.x Upgrade first to 17.6.x and then to Upgrade directly to 17.15.x.
17.15.x.

17.5.x Upgrade first to 17.6.x and then to Upgrade directly to 17.15.x.
17.15.x.

17.6.x Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.7.x Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.8.x Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.9.11t0 17.9.5 Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x
later, and then to 17.15.x

17.9.6 or later Upgrade directly to 17.15.x Upgrade directly to 17.15.x

17.10.x Upgrade to 17.12.x or later, and then to | Upgrade directly to 17.15.x
17.15.x

17.11.x% Upgrade to 17.12.x or later, and then to | Upgrade directly to 17.15.x
17.15.x

17.12.x% Upgrade directly to 17.15.x Upgrade directly to 17.15.x

17.13.x% Upgrade directly to 17.15.x Upgrade directly to 17.15.x

17.14.% Upgrade directly to 17.15.x Upgrade directly to 17.15.x

8.9.x or any 8.10.x version prior to Upgrade first to 8.10.171.0 or later, Upgrade directly to 17.15.x.

8.10.171.0 17.3.5 or later or 17.6.x or later, then to

17.9.6 or later or 17.12.x or later, and
thento 17.15.x

FHEHEN17.15. X KR

3. Cisco Wireless Solutions Software Compatibility Matrix& 7~ BFLE Tk 32 A 2 B 5 E48IE R H iR 2
B
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JEE : Access Point Released|Xf M TAPMAR 5, 1A SARAEE Manual AP Image
Download 5 A |, A1 A,

Table 5. Cisco Catalyst 9800 Wireless Controller and Supported Access Points

10S XE Release Access Point Image Access Point Supported Access Points
Version Number Release



isco |0S XE 17.15.3.28 15.3(3)JPT2 Cisco Wireless Wi-Fi 7 APs: 9176 (I/D1),
17.15.3 9178l, 9172(1)
Cisco Catalyst Wi-Fi 6E APs: 9136 (I)§ 9162

(1), 9163 (E), 9164 (1), 9166 (I/D1)

Cisco Catalyst Wi-Fi 6 APs: 9105AX (I/W),
9115AX (I/E), 9117AX (1), 9120AX (I/E/P),
9130AX (I/E)

Cisco Aironet APs: 1815 (I/W/M/T), 1830
(1),1840 (1), 1852 (I/E), 1800i, 2800 (I/E),
3800 (I/E/P), 4800 (1)

Outdoor and Industrial APs: 1542, 1560,
1570, and IW3702

Integrated Access Point in Cisco 1100 ISR
(ISR-AP1100AC, ISR-AP1101AC, and ISR-
AP1101AX)

Cisco Catalyst Industrial Wireless 6300
Heavy Duty Series Access Point, Cisco 6300
Series Embedded Services Access Point,
Cisco Catalyst 9124AX (I/D/E) Access
Points, Cisco Catalyst Industrial Wireless
9167 (I/E) Heavy Duty Access Points, Cisco
Catalyst IW9165D Heavy Duty Access Points,
Cisco Catalyst IW9165E Rugged Access
Points

Sensors: Cisco Aironet 1800s Active Sensor
Pluggable Modules: Wi-Fi 6 Pluggable
Module for Industrial Routers

T RABMIFR17.15.3

AFERBETENTRARSD , REHREFRAPBREGTEH G E,
AP T8 7%

£ /9800 WLCHRAP, T2 K EI800#LF L T Cisco I0S XEFA K H /Z s BR{& T H 2 M AKY
EAR.

FRAPRREI T EB T : APRRGTA T 2 MR EWLCH K,

« APBRERTR T & 78 VF £ BT INEAP 2 BT I EAPBRRER o
« FREWLCHREWLCEERAR , EMMBEWLC , RBAPTEAPIIALER T EHRA.

AP BR&T T 2
B GUITA T #APRE
1. MCiscofi T8 ¥ 2 T8 HiERI Cisco 10S XERMR IR A,
2. Bi¥Web GUI Administration > Software Management > Software Upgrade > Source File

Path > Select File > Select the 9800 Upgrade File to be uploaded to the controllerffCisco
|I0S XEM & L& FEIWLC,
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Dashboard
Monitoring

Configuration

HYEEGUI

3REAPKRTA T 2o

4.8 FDownload & Install,

Administration = >

Software
Upgrade

Software
Maintenance
Upgrade (SMU)

AP Service
Package (APSP)

AP Device
Package (APDP)

Cisco Catalyst 9800-CL Wireless Controller

Welcome cisco

Upgrade
Mode

One-Shot
Install
Upgrade (i)

Transport
Type

File System

w

¢ A

Software Management

INSTALL

B & @ e

v

Current Mode (until next reload): INSTALL

0O

My Desktop

bootflash

v Free Space: 4203.53 MB

Source File
Path*

djuafn
cisco

Software
Maintenance
Upgrade (SMU)

AP Service
Package (APSP)

AP Davice
Package (APDP)

T EWLCH R — RERE

{_.‘_.iggo Catalyst 9800-CL Wireless Controller

Welcome cisco

Transport
Type

File System

Source File
Path*

f

Administration = » Software Management

NSTAL

Current Mode (until next reload): INSTALL

[ Co9800-CL-universalkd.1...

AP Ima
Predownload
(i

&)

S5ARBAPBRERTA T8I AT RAP.

A B &

e T

fo)
«

LY
b
I"'\

There is an upgrade in progress. Please wait till it completes...

Free Space: 4201.58 MB

<

0%

Status

+.: Download Image/Package.
[ C9800-CL-unhersalkd.17.15.03.5PA bin

¥ Install Image/Fackage
> AP Image Predownload
> Activate Image/Package

» Commit




B CLIT T #H AP 5%

1. FHEFIZRRBRMHAT BEIWLC,

install add file bootflash:image.bin

2R T HEIFT B AP IEZERZ HISRH B EAP,

ap image predownload

G

ap name

image predownload

3. WITFTEAPE S EAPHAPT FEIRS.

show ap image

C1%

show ap name

image

AMFTBE TR FHMAP, FEAPSHAPHYRE,



ap image swap

C1%

ap name

image swap

C1%

ap image swap completed

SRR R ERRG . XSS BWLCERT NS H LARRATT 4.

install activate

6.—BWLCHELARHE , FRIXMEK,

install commit

FREWLCHAPFH
BEGUIFRFFHEWLCHIAP

1. MCiscofiff TEIE S TE B IEM Cisco |I0S XERR KRR,

2. X Web GUI Administration > Software Management > Software Upgrade > Source File
Path > Select File > Select the 9800 Upgrade File to be uploaded to the controllerf¥Cisco
|IOS XEM & E&FIWLC,
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"c||'5',':|c',' Cisco Catalyst 9800-CL Wireless Controller
e Welcome cisco A ﬁ A ¢, ‘.u 0 3

Administration ~ > Software Management

Software
Upgrade
Menitoring Software HJ Qll'ﬂde INSTALL v
A ode
Maintenance Current Mode (until next reload): INSTALL
9 Upgrade (SMU)
Configuration
One-Shot C]
AP Service Install
Package (APSP) Upgrade ()
) Transport My Desktop v
AP Device T&,lr]e
Package (APDP)
File System bootflash v Free Space: 4203.53 MB

& Troubleshooting

Source File
Path* & Select File

HEEEGUI
JER LERXMHE , BEBRFSEERWIEI  #REWLCHRRAPERGT T &
4.8 #HDownload and Install,

5HEFREE100% , F ERERG/BFIREEEE,



Software
Upgrade

Software
Maintenance
Upgrade (SMU)

AP Service
Package (APSP)

AP Device
Package (APDP)

Administration - > Software Management

There is an upgrade in progress. Please wait till it completes...

Upgrade INSTALL
Mode

Current Mode (until next reload): INSTALL

One-Shot D
Install
Upgrade (i)

Transport My Desktop
Type

File System bootflash
Source File

Path*

[ C9800-CL-universalk8.1...

AP Image O
Predownload

Free Space: 5691.86 MB

Hitless Software Upgrade (N + 1 Upgrade)

Enable O
Hitless
Upgrade

FREWLCHER — RERM G

Status

4. Download Image/Package.
(3 C2800-CL-universalkg. 17.15.03.SPA bin

? Install Image/Package
> Activate Image/Package

¥ Commit

3 Show Logs

o

0%

6EWLCHITRARER , RFHARFREH BE. X2FRWLCERTMEHH ST RAET 1,
7.BIGUIERIWLCE , BRRRAFMRA,

Software Upgrade

Software Maintenance Upgrade
(SMU)

AP Service Package (APSP)

AP Device Package (APDP)

Administration = »  Software Management

Upgrade Mode INSTALL
One-Shot Install O

Upgrade (1)

Transport Type My Desktop
File System bootflash

Source File Path*

AP Image O
Predownload (T)

Hitless Software Upgrade (N + 1 Upgrade)

Enable Hitless ]
Upgrade

& Download & Install

L4

L4

4 Click here for Latest Recommended Software

Current Mode (until next reload): INSTALL Manage

® Remove Inactive Files

2 Rollback

Free Space: 1717.17 MB




B CLIFA R FR/EWLCHAP

1R BR G L& B2 IR

copy tftp|ftp|sftp://

bootflash:

2.2 HIER L R RRA,

install add file bootflash:

MEHRG, X2FBWLCEM B H LARTMRATT 18,

install activate

4. —BWLCEL B AiAE |, iHiRERE,

install commit

FHIAPBRE T

EiFEN SRS R LERGERN XA RS HENAERF. WXAFRSHRRAFEARRREEARX
ey RS 2R

1. MCiscoBi # T 2 ¥h & T 8 B IR IAPRR GRS .
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2. MAPR G X HREFEXHRS R E XF,
3. f Farchive download-swin s MAPHICLIJE 31 ST FH R

& : archive download-swip 5 A] MV 4& 5 5 5EBR FTFTPRISFTP

#archive download-sw /reload

://L[your TFTP server's IP address]/[image filename.tar]

4. APEIE RN ARSS 28 T tarAH B3, X FEBAPES AR S5 25 i 8] Y 4% SR R AR X HY B i) o
5. HERIE , AP BFEM M B THHAPKRE,



AEE . MRAPF#EFarchive download-swin ¥ , 15 A3 S debug capwap console clilA
J8 Farchive download-swip &

56 UF
SRAPHERE , EASSRIEAPIRE, BEEEMAEISHK,
1. UEAPRR AR,

show version

2 WIERR TR



show image integrity

3.REEISTX,

show boot

EESEYS

o MU-boottE & C9120/C9115FA &
o HIREGTN TEHEEAS
« A4 Cisco Catalyst 9800k 12 #8554
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https://www.cisco.com/c/zh_cn/support/docs/wireless/catalyst-9120axi-access-point/217537-repairing-c9120-c9115-access-points-from.html
https://www.cisco.com/c/zh_cn/support/docs/wireless/catalyst-9120axi-access-point/217537-repairing-c9120-c9115-access-points-from.html
https://www.cisco.com/c/zh_cn/support/docs/wireless/catalyst-9120axi-access-point/217537-repairing-c9120-c9115-access-points-from.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_predwnld_image_ap_ewlc.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_upgrade_9800cl.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_upgrade_9800cl.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_upgrade_9800cl.html
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