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Introdução

Este documento descreve o processo detalhado do processo de inicialização do AP, o caminho 
de atualização do AP e os métodos de download de imagem do AP.

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

Conhecimento básico dos Catalyst Wireless LAN Controllers•

Componentes Utilizados



Catalyst 9800-CL, Cisco IOS® XE 17.15.3•
Access point Catalyst 9162•
Access point Cisco Aironet 3802•

As informações neste documento foram criadas a partir de dispositivos em um ambiente de 
laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma 
configuração (padrão) inicial. Se a rede estiver ativa, certifique-se de que você entenda o impacto 
potencial de qualquer comando.

Processo de inicialização do AP

Inicialização em U

Sequência de inicialização U-Boot

Os APs Cisco iniciam o processo de inicialização no modo U-BOOT, que ocorre antes do shell 
principal do COS. Para alcançar o modo U-BOOT, reveja estes passos.

Conecte um cabo de console à porta de console do AP.1. 
Abra um programa emulador de terminal no PC e configure a sessão para a porta COM 
serial apropriada. Verifique a porta COM a ser usada em seu dispositivo.

2. 

Defina o software emulador de terminal para usar a taxa de baud de 115200 bps.3. 



Note: Se não houver saída do AP, defina a taxa de baud como 9600.

4. Conecte a alimentação ao AP.

5. Entre no modo U-Boot através do botão escape (esc) no seu teclado, você vê a opção para 
Pressionar ESC para parar a inicialização automática como visto na captura de tela. Esta 
mensagem aparece na reinicialização do Ponto de acesso enquanto conectado à porta de 
console. 



Tela de inicialização U-Boot

Use o comando printenv no modo U-Boot para listar os vários detalhes do ambiente U-Boot para 
o Ponto de acesso.



U-Boot printenv

Esta saída indica que a partição de inicialização é part1. Esta partição de inicialização pode ser 
modificada no modo U-Boot.

Modificar partição de inicialização U-Boot

Ajuste a partição de inicialização atual com o comando setenve BOOT part <1-2>.1. 
Salve o ajuste de partição com o comando saveenv.2. 
Verifique a partição de inicialização atual com o comando printenv.3. 

 

u-boot>> setenv BOOT part 2 



u-boot>> saveenv 
Saving Environment to SPI Flash... 
SF: Detected N25Q32A with page size 64 KiB, total 4 MiB 
Erasing SPI flash....Writing to SPI flash.....done 
u-boot>> printenv 
BOOT=part 2 

 

4. Inicialize o AP com a partição de inicialização recém-configurada com o comando boot.

 

u-boot>> boot 
Creating 1 MTD partitions on "nand0": 
0x000000200000-0x000010000000 : "mtd=2" 
UBI: attaching mtd1 to ubi0 
ubifsmount - mount UBIFS volume 
 
Usage: 
ubifsmount 
 
        
 
 
    - mount 'volume-name' volume 
Unable to ubi mount UBIFS partition part 2 
Trying alternate partition part2 
UBIFS: mounted UBI device 0, volume 0, name "part2" 
 
 
 

 

5. O ponto de acesso é inicializado a partir da partição de inicialização selecionada.

Shell COS

Verificação do sistema de arquivos AP



Note: Recomenda-se recarregar o(s) AP(s) antes da atualização. Isso permite que todos 
os sistemas de arquivos em cache sejam atualizados e que os arquivos temporários 
sejam liberados antes da atualização.

A partir do CLI no AP, entre no modo privilegiado e execute esses comandos para verificar as 
imagens do AP atual e o tamanho do diretório tmp.

Comando show image integrity

Esta saída indica as versões atuais no AP.

A versão da partição Primary indica a versão de inicialização do AP atual.

A versão da partição de backup indica a versão de backup do AP.

 

AP-CW9162#show image integrity 
/part1(primary) 17.15.3.28 



    part.bin : Good 
    ramfs_data_cisco.squashfs : Good 
    iox.tar.gz : Good 
/part2(Backup) 17.9.6.40 
    part.bin : Good 
    ramfs_data_cisco.squashfs : Good 
    iox.tar.gz : Good 

 

Você pode alternar entre a versão atual de inicialização do AP com os comandos em negrito. O 
AP inicializa com a partição selecionada após o próximo recarregamento do AP:

configurar o caminho de inicialização 1 (inicializa o AP com a versão da parte 1)

or

configurar o caminho de inicialização 2 (inicializa o AP com a versão da parte 2)

Comando show filesystems

A saída indica a estrutura do sistema de arquivos do AP.



Note: A linha /tmp na coluna Montado em mostra a entrada do sistema de arquivos que é 
usada para o armazenamento de imagens de AP para uma atualização de AP.

 
<#root>

AP-CW9162#show filesystems 
Filesystem                Size      Used Available Use% Mounted on 
..... 

none                    114.4M      4.7M    109.7M   4% /tmp 

.....

 

É importante que o sistema de arquivos AP /tmp tenha um tamanho de 100M ou superior. O 
sistema de arquivos /tmp é usado para armazenar a atualização da imagem do AP. 



Note: Se a entrada do sistema de arquivos /tmp não for 100M ou maior, pode haver 
problemas com imagens AP muito grandes para a partição. Você precisa atualizar o AP 
para a versão 17.6.6 através de qualquer um dos métodos de download de imagem do 
AP que expande a partição.

Caminho de atualização de AP

Os APs Cisco exigem um caminho de atualização específico com referência à versão atual e à 
versão de destino. Neste guia, é usado o Cisco IOS XE versão 17.15.3. 

Procure o documento Release Notes e o Upgrade Path to Cisco IOS XE para a versão de 
atualização escolhida.

1. 

https://www.cisco.com/c/pt_br/support/wireless/catalyst-9800-series-wireless-controllers/products-release-notes-list.html


Notas de versão 17.15.X

2. A seção Antes de Atualizar fornece detalhes importantes sobre a versão de atualização. É 
recomendável revisar essas informações.

3. O Caminho de Atualização para a tabela Cisco IOS XE Cupertino 17.15.X contém detalhes 
sobre quais versões você pode atualizar diretamente.



Caminho de upgrade para 17.15.X

3. A Matriz de Compatibilidade de Software das Soluções Wireless da Cisco indica quais modelos 
de AP são compatíveis com a versão escolhida.

https://www.cisco.com/c/en/us/td/docs/wireless/compatibility/matrix/compatibility-matrix.html


Note: A coluna Access Point Release corresponde ao codinome da versão do AP. Esta 
versão do ponto de acesso é usada através do método de download manual da imagem 
do AP e deve ser anotada.

Matriz de compatibilidade sem fio 17.9.6 - Tabela Heading.png



Matriz de compatibilidade sem fio 17.15.3

4. Utilize a página Web de Download de Software para obter o pacote de atualização e, em 
seguida, prossiga com um método de Download de Imagem AP .

Métodos de download de imagem AP

Utilize a WLC 9800 para atualizar o AP. Esse processo envolve o download da atualização do 
Cisco IOS XE no chassi do 9800 e o início do download da imagem para pontos de acesso 
unidos.

Há dois métodos para atualizar imagens de AP: Pré-download da imagem do AP e atualização 
padrão do WLC.

O pré-download de imagem do AP permite o pré-carregamento do software de imagem do 
AP antes do recarregamento do AP.

•

A atualização padrão da WLC conclui a atualização na WLC, recarrega a WLC e os APs 
fazem download da nova versão no processo de junção de APs. 

•

Pré-download da imagem do AP

Pré-download da imagem do AP via GUI

Faça o download da versão preferencial da imagem do Cisco IOS XE no site de download 
do software Cisco .

1. 

https://software.cisco.com/download/home
https://software.cisco.com/download/home
https://software.cisco.com/download/home


Carregue a imagem do Cisco IOS XE no WLC via Web GUI Administration > Software 
Management > Software Upgrade > Source File Path > Select File > Select the 9800 
Upgrade File para ser carregado no controlador.

2. 

GUI de gerenciamento de software

3. Verifique o pré-download da imagem do AP.

4. Clique em Baixar e Instalar.



Pré-download da atualização do WLC - Imagem de instalação

5. Os APs são atualizados de acordo com o método de pré-download de imagem do AP.

Pré-download da imagem do AP via CLI

Adicione e expanda a imagem do controlador para o WLC.1. 

 

install add file bootflash:image.bin 

 

2. Descarregue a imagem para todos os APs ou para um AP específico unido à controladora.

 

ap image predownload 

 

or

 

ap name 
 
        
 
         image predownload 
 
 
 

 

3. Verifique o status de pré-download do AP para todos os APs ou para um AP específico .

 

show ap image 

 

or

 

show ap name 
 
        
 
         image 
 
 
 

 



4. Troque imagens de todos os APs, APs específicos ou APs que tenham concluído o pré-
download. 
 

 

ap image swap 

 

or

 

ap name 
 
        
 
         image swap 
 
 
 

 

or

 

ap image swap completed 

 

5. Ative a imagem recém-instalada. Isso faz com que a WLC seja recarregada e inicie com a nova 
versão.

 

install activate 

 

6. Quando a WLC estiver on-line e acessível, confirme a imagem.

 

install commit

 

Atualização de WLC e AP padrão

Atualização de WLC e AP padrão via GUI

Faça o download da versão preferencial da imagem do Cisco IOS XE no site de download 
do software Cisco .

1. 

https://software.cisco.com/download/home
https://software.cisco.com/download/home


Carregue a imagem do Cisco IOS XE no WLC via Web GUI Administration > Software 
Management > Software Upgrade > Source File Path > Select File > Select the 9800 
Upgrade File para ser carregado no controlador.

2. 

GUI de gerenciamento de software

3. Depois que o arquivo de origem for escolhido para upload, escolha qual opção melhor se 
adapta às suas necessidades: Atualização de WLC padrão ou pré-download de imagem do AP .

4. Clique em Baixar e Instalar.

5. A barra de progresso alcança 100% e o status da imagem de instalação/pacote é alcançado.



Atualização de WLC padrão - Imagem de instalação

6. Depois que a WLC executar as verificações finais, clique em Save Configuration & Ativate. Isso 
faz com que a WLC seja recarregada e inicie com a nova versão.

7. Depois que a WLC estiver acessível via GUI, confirme a versão atualizada.



Confirmar atualização

Atualização de WLC e AP padrão via CLI

1. Carregue a imagem no controlador.

 

copy tftp|ftp|sftp:// 
 
        
 
        / 
 
         
 
          bootflash: 
 
 
         
 
 

 

2. Instale a imagem no controlador.

 

install add file bootflash: 
 
 

 

3. Ative a nova imagem. Isso faz com que a WLC seja recarregada e inicie com a nova versão.

 



install activate 

 

4. Quando a WLC estiver on-line e acessível, confirme a imagem.

 

install commit

 

Download manual da imagem do AP

Utilize um aplicativo de servidor de arquivos de sua escolha no computador ou servidor. Este 
servidor de arquivos é o servidor que fornece ao AP os arquivos de atualização preferidos.

Faça o download da versão de imagem do AP preferencial no site de download de software 
da Cisco.

1. 

Salve o arquivo de software do AP no diretório do servidor de arquivos.2. 
Utilize o comando archive download-sw para iniciar o upgrade do arquivo a partir da CLI do 
seu AP.

3. 

https://software.cisco.com/download/home
https://software.cisco.com/download/home


Note: Os métodos de transporte disponíveis para o comando archive download-sw são 
limitados a TFTP e SFTP

 

#archive download-sw /reload 
 
        
 
        ://[your TFTP server's IP address]/[image filename.tar] 
 
 

 

4. O AP faz o download do arquivo de upgrade .tar do servidor de arquivos conforme as 
instruções. Isso leva algum tempo dependendo da taxa de transferência entre o AP e o servidor 
de arquivos.

5. Após a conclusão da transferência do arquivo, o AP automaticamente recarrega e inicializa a 
imagem do AP recém descarregada.



Note: Se o comando archive download-sw não for aceito pelo seu AP, insira o comando 
debug capwap console cli para habilitar o comando archive download-sw

Verificar

Após a conclusão do processo de atualização do AP, verifique a versão do AP, a integridade da 
imagem e a partição de inicialização com os comandos.

1. Verifique a versão do AP.

 

show version 

 

2. Verifique a integridade da imagem.

 



show image integrity

 

3. Verifique a partição de inicialização.

 

show boot 

 

Informações Relacionadas

Reparar pontos de acesso C9120/C9115 da inicialização U•
Download antecipado de uma imagem para um ponto de acesso•
Atualizando o software do controlador sem fio do Cisco Catalyst 9800•

https://www.cisco.com/c/pt_br/support/docs/wireless/catalyst-9120axi-access-point/217537-repairing-c9120-c9115-access-points-from.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_predwnld_image_ap_ewlc.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_upgrade_9800cl.html


Sobre esta tradução
A Cisco traduziu este documento com a ajuda de tecnologias de tradução automática e
humana para oferecer conteúdo de suporte aos seus usuários no seu próprio idioma,
independentemente da localização.
 
Observe que mesmo a melhor tradução automática não será tão precisa quanto as realizadas
por um tradutor profissional.
 
A Cisco Systems, Inc. não se responsabiliza pela precisão destas traduções e recomenda
que o documento original em inglês (link fornecido) seja sempre consultado.


