Problema
O módulo de segurança DNS do Umbrella no Cisco Secure Client (AnyConnect VPN Agent) permanece em um estado "Desabilitado" após a aplicação do arquivo de perfil do Umbrella devido à incompatibilidade de impressão digital do registro do dispositivo. Esse problema persiste em vários ambientes de rede, incluindo conexões de hotspot pessoais e de escritório corporativo.
Artefatos de diagnóstico, como capturas de tela, capturas de pacotes DART e arquivos de captura de pacotes, indicaram falhas de registro de dispositivo vinculadas a uma incompatibilidade de impressão digital no arquivo OrgInfo.json:
- O módulo Umbrella exibe o status "Desabilitado".
- O problema ocorre após a aplicação do arquivo de perfil do Umbrella.
- O problema é visto em várias redes.
- Registros de diagnóstico e capturas de pacotes mostram falhas de registro de dispositivo.
Ambiente
- Produto: Cisco Secure Client (AnyConnect VPN Agent) com módulo Umbrella
- Plataforma: SO Windows
- Recurso de segurança de DNS do Umbrella
- Arquivo de perfil Umbrella e OrgInfo.json envolvidos
- Ambientes de rede: escritório corporativo, hotspot pessoal
- Artefatos de diagnóstico: Pacote DART, captura de pacotes, captura de tela
- Versão de software: Todos
Resolução
Esse fluxo de trabalho detalhado resolve o estado "Desabilitado" do módulo Umbrella, corrigindo a incompatibilidade de impressão digital no arquivo OrgInfo.json e registrando novamente o dispositivo no serviço de nuvem Umbrella.
Faça download de um novo arquivo OrgInfo.json do painel SSE
Para garantir que o registro do dispositivo use a impressão digital correta:
- Obtenha um novo arquivo OrgInfo.json.
- Faça o download do arquivo OrgInfo.json atualizado diretamente do painel Cisco Secure Service Edge (SSE).
Pare o serviço Cisco Secure Client - AnyConnect VPN Agent
Para interromper o serviço é necessário modificar com segurança os arquivos associados ao módulo Umbrella:
Abra o Windows Services e pare o serviço chamado Cisco Secure Client - AnyConnect VPN Agent.
Excluir todo o conteúdo da pasta do módulo Umbrella
- Remova todos os dados potencialmente corrompidos ou desatualizados deste local.
- Excluir todos os arquivos e pastas contidos em:
C:/ProgramData/Cisco/Cisco Secure Client/Umbrella/
Cuidado: possível. Os detalhes mencionados aqui parecem conter procedimentos ou comandos que podem causar um impacto significativo se executados. Verifique se os procedimentos ou comandos mencionados acima foram avaliados por um SME ou Unidade de Negócios antes da execução ou recomendação.
Faça upload do novo arquivo OrgInfo.json
- Coloque o OrgInfo.json recém-baixado na pasta Umbrella designada.
- Copie o novo arquivo OrgInfo.json para:
C:/ProgramData/Cisco/Cisco Secure Client/Umbrella/
Reinicie o Cisco Secure Client Service
Reinicialize o Cisco Secure Client para que as alterações tenham efeito. Inicie o serviço Cisco Secure Client - AnyConnect VPN Agent nos Serviços do Windows.
(Se o problema persistir) Colete dados de diagnóstico para análise adicional
Se o dispositivo ainda falhar no registro, reúna um novo pacote DART para facilitar a solução de problemas mais detalhada. Use a ferramenta DART no Cisco Secure Client para coletar um novo pacote de diagnóstico.
Após executar essas etapas, o módulo Umbrella deve passar de um estado "Desabilitado" para um estado operacional, habilitando os recursos de segurança DNS conforme o esperado.
Causa
A causa raiz do problema era um arquivo OrgInfo.json inválido ou desatualizado contendo um valor de impressão digital de dispositivo incorreto. Essa incompatibilidade levou a solicitações de registro de dispositivo com falha para a API do Umbrella, resultando no módulo que permanece desabilitado. O erro foi confirmado por entradas de log que mostram "impressão digital não corresponde" e "falha ao criar ID de dispositivo" durante tentativas de registro.
Exemplo de trecho de registro dos registros do DART:
{"error":"invalid_request","message":"fingerprint does not match","code":400,"code_text":"Bad Request"}
Device Registration: failed to create device id
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