Configurar e solucionar problemas do WCCP no
FTD usando o modelo predefinido
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Introducao

Este documento descreve as etapas de configuragédo e Troubleshooting para WCCP no FTD.
Pré-requisitos
Requisitos

A Cisco recomenda que vocé tenha conhecimento destes topicos:

* Protocolo de Comunicacao de Cache de Web (WCCP - Web Cache Communications
Protocol) versao 2 (v2)

» Firepower Management Center (FMC)

» Firepower Threat Defense (FTD)

Componentes Utilizados

As informacdes neste documento sao baseadas nestas versdes de software e hardware:

» Centro de gerenciamento seguro de firewall (FMCv) v7.4.2
» Defesa contra ameacas de firewall seguroVirtual(FTDv) v7.4.2

As informacoes neste documento foram criadas a partir de dispositivos em um ambiente de
laboratdrio especifico. Todos os dispositivos utilizados neste documento foram iniciados com uma
configuracao (padréo) inicial. Se a rede estiver ativa, certifique-se de que vocé entenda o impacto
potencial de qualquer comando.



Configurar

O Protocolo de Comunicacédo de Cache de Web (WCCP - Web Cache Communication Protocol) é
usado para redirecionar o trafego da Web para um servidor de cache. Geralmente, é
implementado em dispositivos de rede, como roteadores e firewalls da Cisco, para redirecionar
HTTP, HTTS e FTD sobre solicitagdes HTTP para um servidor proxy.

O WCCP esta disponivel em diferentes versoes, incluindo WCCP v1, v2 e v3, com cada versao
oferecendo recursos e escalabilidade avangados.

Como funciona

» O computador do usuario Win10-0 faz uma solicitagdo HTTPS.

» Aqui, o Firewall FTD é o gateway para o PC do usuario. Ele recebe a solicitacéo

HTTP/HTTPS.

O FTD entende que a porta de destino é 443 e redireciona o trafego para DMZ

O DMZ encapsula o pacote com GRE e encaminha a solicitagdo ao servidor Proxy.

+ O servidor proxy examina o cache ou inicia uma nova conexao com o servidor original e
responde diretamente a maquina do usuario.
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Estas etapas demonstram a configuragdo do WCCP no FMC. O trafego com as portas 80 e 443
deve ser redirecionado da zona Inside para a zona DMZ.



Note: O documento descreve as etapas para service-id dinamico. As informacodes de
porta foram obtidas do cliente WCCP.

Passo 1: Faga login na GUI do FMC e navegue para Object > Object Management > Access List
> Extended >Add Extended Access List.

Crie duas listas de acesso estendidas.

1) Crie uma lista de acesso para redirecionar o trafego do usuario e clique em Salvar.



Edit Extended Access List Object

Name

I Redirect_traffic

Entries (3)

@ Block  WSA_serer

2 © Block

user_LanN

3 Allow

Allow Overrides

Note: Esta lista de acesso garante que vocé tenha Bloqueio de agao para o trafego que
vem do cliente WCCP em dire¢do ao FTD para evitar o loop na rede.



Além disso, vocé pode criar outra instrugcao com Action Block para garantir que a

comunicagao entre hosts internos nao seja enviada ao servidor proxy.

A instrucao final deve permitir todos os outros trafegos qualificados para
redirecionamento para o proxy.

2) Crie uma lista de acesso para identificar o cliente WCCP e clique em Save.

Name

[ wece-cuen

Entries (1)

1 o Allow WSA_server

Allow Overrides

Lista de acesso para identificar o cliente WCCP



Note: Configuragdo de uma lista de acesso estendida para incluir os enderecgos IP do
servidor WCCP.

Etapa 2: Navegue até Object > Object Management > FlexConfig > Text Object > Add Text Object
para adicionar o servico WCCP e Save.



Edit Text Object T

Mame:

Description:
Variable Type Count
Single v 1
1 a7
|| Allow Overrides

| Cancel | Save

Criando objeto de servigo wcep



Note: Neste exemplo, o ID de servico é 97. E aconselhavel selecionar um ID de servigo
entre 90 e 97, ja que estes sdo IDs de servigo personalizados que normalmente néao
entram em conflito com outros IDs de servigo atribuidos a protocolos especificos.

Para obter mais detalhes, consulte WCCP no ASA: Conceitos, limitacoes e configuracdo

Passo 3:

* Navegue até Object > Object Management > FlexConfig > Text Object e Search para
isServiceldentifer.

Text Object ['\"« isServiceldentifie]

Text objects define free-form text strings that you use as variables in a FlexConfig object. These objects can have single values or be a list of multiple values


https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html
https://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/116046-config-wccp-asa-00.html

* Modifique o isServiceldentifer de false para true.
» isServiceldentifer - Quando falso, usa o identificador standard web-cacheservice. Consulte o

documento Guia de configuracdo do Firepower Management Center

Edit Text Object @

Name:

iIsServiceldentifier

Description:

A flag to identity whether to use
service in wecep.

Variable Type Count
Single v =
1 true

Allow Overrides

» Override (0)

Modificar o valor de falso para verdadeiro



https://www.cisco.com/c/en/us/td/docs/security/firepower/70/configuration/guide/fpmc-config-guide-v70/flexconfig_policies.html

Note: Além disso, vocé pode criar um Objeto de Texto definido pelo usuario mostrado na
Etapa 2.

Passo 4:

* Navegue até Object > Object Management > Flex Config > FlexConfig Object.
* Procure a palavra-chave wccp.
+ Clique na opgéao Clone para o modelo Wccp_Configure.
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> AAA Server FlexConfig Object Add FlexConfig Object  [IESRIEET

* Access List

g Object include device configuration commands, variables, and scripting language instructions. It is used in FlexConfig polices.

Address Pools FlexConf

Application Filters
AS Path Nam o i
BFD Temglate
Wieep_ G The template is 2 mple of weep configur.. 'S

Cipher Suite List

? Community List
DHCP IPvE Pool
» Distinguished Name
DINS Server Group
» External Attributes
File List
"~ FlenConfig
FlexConfg Object
Text Object

Note: O objeto FlexConfig tem um modelo predefinido: Wcep_Configure. O modelo nao
pode ser anexado ao dispositivo. Vocé deve clona-lo.



Passo 5:
« Remova as variaveis $serviceldentifier da terceira linha e fornega sua propria variavel.
Add FlexConfig Object (7]
MName:
Weep_Configure_clone
Description:
The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert « Deployment: Once v Type: Append v
#set( $service = "web-cache")
#if( $isServiceldentifier == "true")
#set( Sservice = “$sepviceldentifier”
sl —

fset ( SwccpCli = "wccp")

#end
###fweccpRedirectlist is place-holder for extended ACL.
###8#Replace wecpRedirectlList with extended ACL defined in FMC by inserting policy-object of type extended ACL.

#if( S$wccpRedirectList )

#set( SweepCli = “SwoepCli redirect-list SwecpRedirectList")
fend
¥ Variables
Name Dimension Default Value il Override Description
(Type:Name) P
isServiceldentifier SINGLE true FREEFORM:I... false A flag to determine if service ...
serviceldentifier SINGLE 1 FREEFORM:... false service identifier number is to...

Cancel Save

—

Remover o identificador de servigo

* Insira o Text Object ccp-service como a variavel criada na etapa 2.
* No menu suspenso, selecione Inserir > Inserir objeto de politica > Objeto de texto



Add FlexConfig Object

Name:

[
Weep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

|. Insert . B Deployment: ' Once v | Type: ' Append

| Insert Policy Object Text Object

Insert System Variable » Network

Insert Secret Key Security Zones
#set ( SwecepGli = "Sweg .
####wccpGroupList is pl Standard ACL Object 3 acr.
f###Replace wecepGroupLi afined in FMC by inserting policy-object of type extended ACL.

§if ( $wecpGroupl Extended ACL Object

#set( SwecpCli =

#end Route Map

fend

Inserir 0 objeto wcep-service como variavel

* Fornega um Variable Namewccp-service.
» Procure wccp-service-object em Available Object.
+ Adicione o objeto e salve-o.



Insert Text Object Variable (7]

Variable Name:

| wecep-service ‘

Description:
Available Objects Selected Object
| 2, weep b4 ‘ weep-service-object .

WCCp-=-5erv [ ce-o

wecepPassword

Cancel Save

Adicionar objeto de servico wcep

Passo 6:

» Copie 0 nome da variavel wccpGroupList e fornega sua propria variavel.



Add FlexConfig Object

Name:

[ Wecep_Configure_clone l

Description

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

llnsertv s Deployment: Once v Type: Append vé

#set( $service = "web-cache")
#if( $isServiceldentifier == "true")
#set( $service = "$wecp-service")
fend

#set ( SwcopCli = "SwccpCli $service")
] ###fwocepGroup. t is place-holder for extended ACL.
] ####Replace wecpGrouplist with extended ACL defined in FMC by inserting policy-object of type extended ACL.
. #if ( $WCCPGroupList )
| #set( SweepCli = "SwoopCli group-list $weepGrouplist™)

Remover variavel wcepGrouplList predefinida

* No menu suspenso Inserir > Inserir objeto de politica > Objeto de ACL estendida.

Name:

| Weep_Configure_clone

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

r y r - r
|

Insert v i % Deployment: Once v Type: | Append

. Insert Policy Object Text Object

Insert System Variable »  Network

Insert Secret Key Security Zones

Standard ACL Object  § acr.
2fined in FMC by inserting policy-object of type extended ACL.
Extended ACL Object

¥ Variables

Adicionando ACL estendida wccpGrouplist

» Cole o nome wcepGrouplist que vocé copiou na etapa anterior da se¢cao Nome da variavel.



* Procure WCCP-CLIENT em Available Objects criados na etapa 1.
» Adicione e salve-o.

T ey

Insert Extended Access List Object Variable (7]

Variable Name:

i ‘ wccpGrouplist l

Description:

Available Objects C Selected Object

| | a search X BVCCP-CLIENT 7
D L‘Qedirect_traﬂﬁc

“*WCCP-CLIENT

Adicionar lista estendida de WCCP-CLIENT

Passo 7:

» Selecione wcepRedirectList para copiar e fornecer sua propria variavel.



Add FlexConfig Object

Name:

( Weep_Configure_clone ]

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v Deployment: I Once v ‘ Type: | Append
f#set ( $service = "web-cache")
#if( $isServiceldentifier == "true")

####Replace wecpRedirectList with extended ACL defined in FMC by inserting policy-object of type extended ACL.
=——P-iif | SwWccpRedirectList )

#end

Remover wccpRedirectList

* No menu suspenso, selecione Insert > Insert Policy Object > Extended ACL Object .

Add FlexConfig Object

Name:

[ Wecep_Configure_clone ]

Description:

The template is an example of
wccep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert v | k2 Deployment: [ Once v Type: | Append

| Insert Policy Object Text Object

Insert System Variable » Network

Insert Secret Key Security Zones

####wccpGrouplist is pl Standard ACL Object  j acL.

####Replace wcepGroupLi X pfined in FMC by inserting policy-object of type extended ACL.
#if( ) Extended ACL Object

#set ( $weepCli = "Sweer JupList™

#end Route Map
###dwccpRedirectlist is place-nolaer ror extended ACL.

#end

¥ Variables

Selecionar objeto de ACL estendida para wccpRedirectList

» Cole wcepRedirectList em Nome da Variavel.



* Procure Redirect_traffic em Available Object.
» Selecione Add e Save.

e el eileeiliaeosiisisaiiisisisiiisneiios e = = e e e e

Insert Extended Access List Object Variable @

Variable Name:

‘ wccpRedirectList ‘

Description:

Available Objects C Selected Object
‘ Q_ Search p 4 Lﬁzeorjirect_traﬁ“lc

£ Redirect_traffic

#VCCP-CLIENT

)

Adicionar ACL Redirect_traffic

Passo 8:

e Remover @wccpPassword



Add FlexConfig Object

Name:

[ Wecep_Configure_clone ‘

Description:
The template is an example of
wccep configuration. It can not be
A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

|- Insert v - [ Deployment: [ Once v | Type: [ Append '

$#44wcepGrouplist is place-holder for extended ACL.
st with extended ACL defined in FMC by inserting policy-object of type extended ACL.

t is place-holder for extended ACL.
irectList with extended ACL defined

in FMC by inserting policy-object of type extended ACL.

#foreach( $interfaceName in $security-zone)

Removida a senha wcep predefinida

+ Selecione a chave no menu suspenso Insert > Insert Secret Key.

Add FlexConfig Object

Name:

' Weep_Configure_clone ‘

Description:

The template is an example of
weep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

‘ Insert v k2 Deployment: [ Once v l Type: [ Append
Insert Policy Obiject 'S ace-holder for extended ACL.
¥ 20 st with extended ACL defined in FMC by inserting policy-object of type extended ACL.

In m Variable »
sert Syste ariable Cli group-list $weepGroupList™)

Insert Secret Ke
place-holder for extended ACL.

in FMC by inserting policy-object of type extended ACL.

#foreach( $interfaceName in $security-zone)

¥ Variables

Selecionar chave secreta

+ Cligue em Add Secret Key.



Insert Secret Key @

Add Secret Key

Name

~,
«

[ ] wccpPassword

Cancel Save

Adicionar chave secreta

* Insira um nome em Nome da chave secreta.
* Digite a senha.
* Insira a mesma senha em Confirmar senha e clique em Adicionar.



Add Secret Key

Secret Key name:*

‘ wccpPassword J

Password:*

[ Cancel ] Add

Adicionar chave secreta definida pelo usudrio




Note: Neste exemplo, a interface interna pertence a Security Zone in.

Etapa 9:

« Copie a zona de seguranca predefinida e substitua $ zona de seguranca por sua propria
variavel.



Edit FlexConfig Object

Name:

| Weep_Configure_clone |

Description:

The template is an example of
weep configuration. It can not

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Deployment: | Once

fforeach( $interfaceName in $SECUrity-ZONe |
weep interface $interfaceName §service redireet in

fend

v Variables
Name Dimension
wcepGrouplist SINGLE
wcecp-service SINGLE
interfaceName SINGLE
security-zone SINGLE

Copie o0 nome security-zone

Default Value

WCCP-CLIENT

97

in

in

Property
(Type:Name)

EXD_ACL:W...
FREEFORM:...
SECURITYZ...

SECURITYZ...

v | Type: | Append

Override

false

false

false

false

Description

» Selecione Security Zones no menu suspenso € Insert > Insert Policy Object.



Add FlexConfig Object

Name:

Wecep_Configure_clone

Description:

The template is an example of
wcep configuration. It can not be

A Copy-pasting any rich text might introduce line breaks while generating CLI. Please verify the CLI before deployment.

Insert B2 Deployment: I Once v ‘ Type: I Append

Insert Policy Object Text Object supList™)

Insert System Variable »  Network wded ACL.
. defined in FMC by inserting peolicy-object of type extended ACL.
Insert Secret Key Security Zones
¥5eT| PWCCPULL = “3»WCCE JRedirectList")
$end Standard ACL Object

#set ( SwcepCli = "Swecp Extended ACL Object vord ")
$WecpCli Route Map

#### Assiging wccp onto interface
#foreach( in $security-zone)

#end

¥ Variables

Selecionar a zona de seguranga

» Cole o nome da variavel como security-zone
+ Em Objetos Disponiveis, selecione a interface a Adicionar.
+ Click Save.



Insert Security Zone Variable (7]

Variable Name:

| security-zone |

Description:

Available Objects Selected Object
| C, Search ‘ in

o/

dmz

out

Cancel Save

Adicionando zona de seguranca
Etapa 10:

* Navegue até Devices > FlexConfig, clique em New Policy ou Edit uma politica existente.
+ Selecione o objeto Wccp_configure_clone configurado e clique em > para atribui-lo.
 Click Save.



Note: Para uma nova politica, assegure-se de atribuir a politica ao dispositivo FTD. Para
uma politica existente, a politica ja deve ter sido atribuida.

WCCP_config E=Z3

Wetp_ Condgure_clone

<7 Selected Append FlexConfigs

Etapa 11: Navegue até Implantar > Selecionar o dispositivo FTD > clique em Implantar.



Verificar

Passo 1: Verifique a configuragao atual.
Inicie a sessao no FTD CLI e execute o comandoshow running-config weep.

Exemplo de configuragao:

wccp 97 redirect-1ist Redirect_traffic group-Tist WCCP-CLIENT password ###*%*%*
wccp interface inside 97 redirect in

Para garantir que a configuracao tenha a senha correta, execute os comandos.
1) system support diagnostic-cli

2) enable

3) Pressione Enter sem senha

4) more system:running-config | include wecp

Passo 2: Verifique o status do WCCP

Executar o comando show weep

Global WCCP information:
Router information:
Router Identifier: -not yet determined-
Protocol Version: 2.0

Service Identifier: 97

Number of Cache Engines: 1

Number of routers: 2

Total Packets Redirected: 0

Redirect access-1ist: Redirect_traffic
Total Connections Denied Redirect: 0

Total Packets Unassigned: 0

Group access-Tist: WCCP-CLIENT
Total Messages Denied to Group: 0

Total Authentication failures: 0

Total Bypassed Packets Received: 0

Executar o comando show wccp 97 service

WCCP service information definition:



Type: Dynamic

Id: 97
Priority: 240
Protocol: 6
Options: 0x00000012
Hash: DstIP
A1t Hash: -none-
Ports: Destination:: 80 443 000000

Note: Aqui 97 € o service-id. Certifique-se de que vocé pode ver o numero de porta
aprendido do cliente WCCP em Portas: segao.

3) Run the command show wccp 97 view

Troubleshooting



Passo 1: Verifique se o FTD tem a rota da mesma interface que recebeu a solicitagdo do WCCP
do servidor Proxy.

Neste exemplo, o trafego é redirecionado para a interface dmz.

>show route
S 10.xx.xx.xx 255.yyy.yyy.yyy [1/0] via 10.zz.zz.z, dmz

Note: Aqui 10.xx.xx.xx € o IP do servidor proxy, 255.yyy.yyy.yyy € a mascara de rede,
10.zz.zz.z é o gateway do préximo salto.

Passo 2: Realize as capturas na interface interna e dmz para garantir que o trafego seja
redirecionado.

Captura na interface interna para a porta 443



capture capinside interface inside trace detail match tcp any any eq 443

Capturar na interface dmz:

capture capdmz interface dmz trace detail match gre any any

Note: Na interface dmz, vocé deve filtrar com o protocolo GRE. O pacote de
redirecionamento € encapsulado em um pacote GRE para o cliente wccp.

Passo 3: Depuragao para wccp

Execute os comandos:



debug weep event debu weep packet

O bug da Cisco IDCSCvn90518 foi levantado para aprimoramento para ter o suporte do FDM e do
modo nativo do FMC para a configuragdo do WCCP.



https://tools.cisco.com/bugsearch/bug/CSCvn90518

Sobre esta tradugao

A Cisco traduziu este documento com a ajuda de tecnologias de tradugéo automatica e
humana para oferecer conteudo de suporte aos seus usuarios no seu proprio idioma,
independentemente da localizagao.

Observe que mesmo a melhor tradugao automatica nao sera tao precisa quanto as realizadas
por um tradutor profissional.

A Cisco Systems, Inc. ndo se responsabiliza pela precisdo destas tradugdes e recomenda
que o documento original em inglés (link fornecido) seja sempre consultado.



