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Inleiding

Dit document beschrijft het gedetailleerde proces van het opstartproces van het toegangspunt, het 
upgradepad van het toegangspunt en de methoden voor het downloaden van het toegangspunt.

Voorwaarden

Vereisten

Cisco raadt kennis van de volgende onderwerpen aan:

Basiskennis van Catalyst Wireless LAN-controllers•



Gebruikte componenten

Catalyst 9800-CL, Cisco IOS® XE 17.15.3•
Catalyst 9162-toegangspunt•
Cisco Aironet 3802-toegangspunt•

De informatie in dit document is gebaseerd op de apparaten in een specifieke 
laboratoriumomgeving. Alle apparaten die in dit document worden beschreven, hadden een 
opgeschoonde (standaard)configuratie. Als uw netwerk live is, moet u zorgen dat u de potentiële 
impact van elke opdracht begrijpt.

AP Boot-proces

U-boot

U-Boot Startup-reeks

Cisco AP's beginnen het opstartproces in U-BOOT-modus die plaatsvindt voorafgaand aan de 
belangrijkste COS-shell. Om de U-BOOT-modus te bereiken, bekijkt u deze stappen.

Sluit een consolekabel aan op de poort van de AP-console.1. 
Open een terminalemulator op uw pc en stel de sessie in op de juiste seriële COM-poort. 
Controleer de COM-poort die op uw apparaat moet worden gebruikt.

2. 

Stel de terminalemulator in op 115200 bps baud rate.3. 



Opmerking: Als er geen uitvoer van het toegangspunt is, stelt u de baudsnelheid in op 
9600.

4. Sluit de stroom aan op het toegangspunt.

5. Voer de U-Boot-modus in door via de escape (esc) -knop op uw toetsenbord de optie te zien 
om ESC te raken om de autoboot te stoppen zoals te zien is in de schermafbeelding. Dit bericht 
wordt weergegeven wanneer het toegangspunt opnieuw wordt opgestart terwijl het is verbonden 
met de consolepoort. 



U-Boot Startup Screen

Gebruik de opdracht afdrukken vanuit de U-Boot-modus om de verschillende U-Boot-
omgevingsdetails voor het toegangspunt weer te geven.



U-Boot-printer

Deze uitvoer geeft aan dat de opstartpartitie deel 1 is. Deze opstartpartitie kan worden gewijzigd in 
de U-Boot-modus.

U-Boot Partition wijzigen

Pas de huidige opstartpartitie aan met de opdracht server BOOT part <1-2>.1. 
Sla de partitieaanpassing op met de opdracht saveenv.2. 
Controleer de huidige opstartpartitie met de opdracht printenv.3. 

 

u-boot>> setenv BOOT part 2 



u-boot>> saveenv 
Saving Environment to SPI Flash... 
SF: Detected N25Q32A with page size 64 KiB, total 4 MiB 
Erasing SPI flash....Writing to SPI flash.....done 
u-boot>> printenv 
BOOT=part 2 

 

4. Start het toegangspunt op met de nieuw geconfigureerde opstartpartitie met de opdracht 
opstarten.

 

u-boot>> boot 
Creating 1 MTD partitions on "nand0": 
0x000000200000-0x000010000000 : "mtd=2" 
UBI: attaching mtd1 to ubi0 
ubifsmount - mount UBIFS volume 
 
Usage: 
ubifsmount 
 
        
 
 
    - mount 'volume-name' volume 
Unable to ubi mount UBIFS partition part 2 
Trying alternate partition part2 
UBIFS: mounted UBI device 0, volume 0, name "part2" 
 
 
 

 

5. Opstartpunt wordt opgestart vanaf de geselecteerde opstartpartitie.

COS Shell

AP-bestandssysteemcontrole



Opmerking: het wordt aanbevolen de toegangspunten vóór de upgrade opnieuw te laden. 
Hierdoor kunnen alle bestandssystemen in de cache worden vernieuwd en tijdelijke 
bestanden worden doorgespoeld voorafgaand aan de upgrade.

Voer vanuit de CLI op het toegangspunt de Privileged-modus in en voer deze opdrachten uit om 
de huidige AP-images en de grootte van de tmp-directory te controleren.

integriteit van afbeelding tonen, opdracht

Deze uitvoer geeft de huidige versies op het toegangspunt aan.

De primaire partitieversie geeft de huidige opstartversie van het toegangspunt aan.

De back-uppartitieversie geeft de back-upversie van het toegangspunt aan.

 

AP-CW9162#show image integrity 
/part1(primary) 17.15.3.28 



    part.bin : Good 
    ramfs_data_cisco.squashfs : Good 
    iox.tar.gz : Good 
/part2(Backup) 17.9.6.40 
    part.bin : Good 
    ramfs_data_cisco.squashfs : Good 
    iox.tar.gz : Good 

 

U kunt switches tussen de huidige opstartversie van het toegangspunt met de vetgedrukte 
opdrachten. Het toegangspunt wordt opgestart met de geselecteerde partitie na de volgende 
herlaadbeurt van het toegangspunt:

Opstartpad 1 configureren (opstart AP met versie van deel 1)

of

Opstartpad 2 configureren (opstart AP met versie van deel 2)

bestandssystemen weergeven Opdracht

De uitvoer geeft de structuur van het bestandssysteem van het toegangspunt aan.



Opmerking: de tmp/tmp-rij in de kolom Gemonteerd op toont de bestandsindeling die 
wordt gebruikt voor de opslag van AP-images voor een AP-upgrade.

 
<#root>

AP-CW9162#show filesystems 
Filesystem                Size      Used Available Use% Mounted on 
..... 

none                    114.4M      4.7M    109.7M   4% /tmp 

.....

 

Het is belangrijk dat het AP / tmp-bestandssysteem een grootte van 100M of hoger heeft. Het 
/tmp-bestandssysteem wordt gebruikt om de upgrade van het AP-image op te slaan. 



Opmerking: als de invoer van het bestandssysteem /tmp niet 100M of groter is, kunnen er 
problemen zijn met AP-afbeeldingen die te groot zijn voor de partitie. U moet het 
toegangspunt upgraden naar versie 17.6.6 via een van de methoden voor het downloaden 
van images van het toegangspunt, waardoor de partitie wordt uitgebreid.

Pad voor AP-upgrade

Cisco-toegangspunten vereisen een specifiek upgradepad met betrekking tot de huidige en de 
bestemmingsversie. In deze handleiding wordt Cisco IOS XE versie 17.15.3 gebruikt. 

Blader naar het document met releasenotities en het upgradepad naar Cisco IOS XE voor 
de gekozen upgradeversie.

1. 

https://www.cisco.com/c/nl_nl/support/wireless/catalyst-9800-series-wireless-controllers/products-release-notes-list.html


Release notes 17.15.x

2. In het gedeelte Voordat u een upgrade uitvoert, vindt u belangrijke details over de 
upgradeversie. Het wordt aanbevolen om deze informatie te bekijken.

3. De tabel Upgrade Path to Cisco IOS XE Cupertino 17.15.X bevat details over de versies waaruit 
u rechtstreeks kunt upgraden.



Upgrade pad naar 17.15.x

3. De softwarecompatibiliteitsmatrix van Cisco Wireless Solutions geeft aan welke AP-modellen 
compatibel zijn met de door u gekozen versie.

https://www.cisco.com/c/en/us/td/docs/wireless/compatibility/matrix/compatibility-matrix.html


Opmerking: de kolom Vrijgave toegangspunt komt overeen met de codenaam van de AP-
versie. Deze Access Point Release wordt gebruikt via de methode Manual AP Image 
Download en moet worden genoteerd.

Matrix voor draadloze compatibiliteit 17.9.6 - Tabelkop.png



Matrix voor draadloze compatibiliteit 17.15.3

4. Gebruik de webpagina Software downloaden om het upgradepakket te verkrijgen en ga 
vervolgens door met de methode AP Image Download.

AP Image Download Methods

Gebruik de 9800 WLC om het toegangspunt te upgraden. Dit proces omvat het downloaden van 
de Cisco IOS XE-upgrade op het 9800-chassis en het starten van de image-download naar 
gekoppelde toegangspunten.

Er zijn twee manieren om AP-images te upgraden: AP Image Predownload en Standard WLC 
Upgrade.

Met AP Image Predownload kunt u de AP-afbeeldingssoftware vooraf laden voordat het 
toegangspunt opnieuw wordt geladen.

•

Standaard WLC-upgrade voltooit de upgrade op de WLC, laadt de WLC opnieuw en 
downloadt de AP's de nieuwe versie na het AP-aanmeldingsproces. 

•

AP Image Predownload

AP Image Predownload via GUI

Download de voorkeursversie van het Cisco IOS XE-image van de downloadsite voor Cisco-
software .

1. 

https://software.cisco.com/download/home
https://software.cisco.com/download/home
https://software.cisco.com/download/home


Upload het Cisco IOS XE-image naar de WLC via Web GUI Administration > Software 
Management > Software Upgrade > Source File Path > Select File > Select the 9800 
Upgrade File to be upload to the controller.

2. 

Software Management GUI

3. Controleer AP Image Predownload.

4. Klik op Downloaden en installeren.



WLC-upgrade vooraf downloaden - Image installeren

5. AP's worden geüpgraded volgens de methode voor het vooraf downloaden van het AP-image.

AP Image Predownload via CLI

Voeg de controllerafbeelding toe aan de WLC en vouw deze uit.1. 

 

install add file bootflash:image.bin 

 

2. Download het image naar alle toegangspunten of naar een specifiek toegangspunt dat is 
aangesloten op de controller.

 

ap image predownload 

 

of

 

ap name 
 
        
 
         image predownload 
 
 
 

 

3. Controleer de status van de predownload van het toegangspunt voor alle toegangspunten of 
een specifiek toegangspunt.

 

show ap image 

 

of

 

show ap name 
 
        
 
         image 
 



 
 

 

4. Wissel afbeeldingen uit van alle toegangspunten, specifieke toegangspunten of toegangspunten 
die vooraf zijn gedownload. 
 

 

ap image swap 

 

of

 

ap name 
 
        
 
         image swap 
 
 
 

 

of

 

ap image swap completed 

 

5. Activeer het nieuw geïnstalleerde image. Dit zorgt ervoor dat de WLC opnieuw wordt geladen 
en begint met de nieuwe versie.

 

install activate 

 

6. Zodra de WLC online en bereikbaar is, verbindt u de afbeelding.

 

install commit

 

Standaard WLC- en AP-upgrade



Standaard WLC- en AP-upgrade via GUI

Download de voorkeursversie van het Cisco IOS XE-image van de downloadsite voor Cisco-
software .

1. 

Upload het Cisco IOS XE-image naar de WLC via Web GUI Administration > Software 
Management > Software Upgrade > Source File Path > Select File > Select the 9800 
Upgrade File to be upload to the controller.

2. 

Software Management GUI

3. Nadat het bronbestand is gekozen voor uploaden, kiest u welke optie het beste bij uw 
behoeften past: Standaard WLC-upgrade of AP Image Predownload.

4. Klik op Downloaden en installeren.

5. De voortgangsbalk bereikt 100% en de status Installatiekopie/Pakket is bereikt.

https://software.cisco.com/download/home
https://software.cisco.com/download/home


Standaard WLC-upgrade - Image installeren

6. Nadat de WLC de laatste controles heeft uitgevoerd, klikt u op Configuratie opslaan en 
activeren. Dit zorgt ervoor dat de WLC opnieuw wordt geladen en begint met de nieuwe versie.

7. Nadat de WLC via de GUI bereikbaar is, verbindt u de bijgewerkte versie.



Upgrade vastleggen

Standaard WLC- en AP-upgrade via CLI

1. Upload de afbeelding naar de controller.

 

copy tftp|ftp|sftp:// 
 
        
 
        / 
 
         
 
          bootflash: 
 
 
         
 
 

 

2. Installeer het image op de controller.

 

install add file bootflash: 
 
 

 

3. Activeer de nieuwe afbeelding. Dit zorgt ervoor dat de WLC opnieuw wordt geladen en begint 
met de nieuwe versie.



 

install activate 

 

4. Zodra de WLC online en bereikbaar is, verbindt u de afbeelding.

 

install commit

 

Handmatig AP Image downloaden

Gebruik een bestandsservertoepassing van uw keuze op uw computer of server. Deze 
bestandsserver is de server die het toegangspunt van de voorkeursupgradebestanden voorziet.

Download de gewenste AP-afbeeldingsversie van de downloadsite voor Cisco-software.1. 
Sla het AP-softwarebestand op in de directory van uw bestandsserver.2. 
Gebruik de opdracht download-sw archiveren om de bestandsupgrade vanuit de CLI van uw 
toegangspunt te starten.

3. 

https://software.cisco.com/download/home


Opmerking: de beschikbare transportmethoden voor de opdracht archiefdownload-sw zijn 
beperkt tot TFTP en SFTP

 

#archive download-sw /reload 
 
        
 
        ://[your TFTP server's IP address]/[image filename.tar] 
 
 

 

4. AP downloadt het .tar-upgradebestand van de bestandsserver zoals aangegeven. Dit duurt 
enige tijd, afhankelijk van de overdrachtssnelheid tussen het toegangspunt en de bestandsserver.

5. Nadat de bestandsoverdracht is voltooid, laadt het toegangspunt het nieuw gedownloade 
toegangspunt automatisch opnieuw op en start het op.



Opmerking: Als de opdracht archiefdownload-sw niet wordt geaccepteerd door uw 
toegangspunt, voert u de opdracht debug capwap console cli in om de opdracht 
archiefdownload-sw in te schakelen

Verifiëren

Nadat het upgradeproces voor het toegangspunt is voltooid, controleert u de AP-versie, de 
integriteit van het image en de opstartpartitie met de opdrachten.

1. Controleer de AP-versie.

 

show version 

 

2. Controleer de integriteit van het image.



 

show image integrity

 

3. Controleer de opstartpartitie.

 

show boot 

 

Gerelateerde informatie

Repareer C9120/C9115-toegangspunten vanaf U-boot•
Een image vooraf downloaden naar een toegangspunt•
De Cisco Catalyst 9800 Wireless Controller-software bijwerken•

https://www.cisco.com/c/nl_nl/support/docs/wireless/catalyst-9120axi-access-point/217537-repairing-c9120-c9115-access-points-from.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_predwnld_image_ap_ewlc.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_upgrade_9800cl.html


Over deze vertaling
Cisco heeft dit document vertaald via een combinatie van machine- en menselijke
technologie om onze gebruikers wereldwijd ondersteuningscontent te bieden in hun eigen
taal. Houd er rekening mee dat zelfs de beste machinevertaling niet net zo nauwkeurig is als
die van een professionele vertaler. Cisco Systems, Inc. is niet aansprakelijk voor de
nauwkeurigheid van deze vertalingen en raadt aan altijd het oorspronkelijke Engelstalige
document (link) te raadplegen.


