Cisco Meraki Japan

アカウントをお持ちの場合

  •   パーソナライズされたコンテンツ
  •   製品とサポート

アカウントをお持ちでない場合

アカウントを作成

Cisco Meraki 以外のスイッチへのトランク リンクにおける推奨構成

ベンダーはデフォルトのスイッチ ポート設定「trunk all, with native vlan 1」を使用する傾向があるので、ほとんどのエンタープライズ スイッチのデフォルト設定は、何も変更せずにそのまま使用できます。Meraki MS スイッチを別のベンダーのスイッチに接続する場合、リンクのもう一方の遠端も同じように設定する必要があることに注意してください。そのように設定しない場合、VLAN またはネイティブ VLAN の不一致が原因で、リンクが期待どおりに動作しない可能性があります。一般的な設定の誤りとして、次のようなものがあります。

  • switchport mode
  • トランク カプセル化のタイプ(dot1q である必要があります)
  • ネイティブ VLAN が一致していない
  • 許可 VLAN が一致していない

 

次のシナリオでは、Cisco Meraki アクセス スイッチは別のスイッチ(Cisco Meraki 以外)にアップリンクされています。ネットワーク管理者は、VLAN 1、10、20、30 を許可し、Cisco Meraki のアップリンク ポートをトランク ネイティブ VLAN1 として設定しています。また、もう一方の側はデフォルトの設定(トランク ネイティブ VLAN 1)のままにしています。

このシナリオでは、VLAN 20 の Meraki スイッチに接続しているユーザは、トランク リンクの設定が一致していないため、接続を確立できません。トランクの両側の設定を一致させることをお勧めします。

Trunk VLANs mismatch.png  

Cisco Meraki スイッチの設定例(ポート 13 で接続されることを想定)

推奨構成

次の設定例は、上記の例で最適な動作を得るために、Meraki 以外のピア スイッチのトランク リンクをどのように設定する必要があるかを示しています。

 

Cisco Catalyst

ポート 1 で接続されることを想定:

!
interface GigabitEthernet1/0/1
 switchport mode trunk
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,10,20,30
!

 

Dell PowerConnect

注:Dell PowerConnect スイッチでは、デフォルトで LLDP が無効にされ、透明性が有効にされています。ダッシュボードでトポロジ機能を使用するには、LLDP を有効にし、透明性を無効にする必要があります。トポロジはすぐには更新されません。しばらく時間がかかることがあります。リアルタイムではありません。

 

ポート 1 で接続されることを想定:

!
  interface ethernet 1/g1
    switchport mode general
    switchport general allowed vlan add 10,20,30 tagged 
 !

 

HP ProCurve

ポート 1 で接続されることを想定:

switch1(config)# vlan 1
switch1(config)# vlan 10
switch1(config)# vlan 20
switch1(config)# vlan 30
switch1(vlan-1)# untagged 1
switch1(vlan-10)# tagged 1
switch1(vlan-20)# tagged 1
switch1(vlan-30)# tagged 1

 

その他のデバイス

Cisco Meraki VLAN タギングは 802.1q タギングの標準規格で動作するため、標準規格に準拠したスイッチは MS スイッチと連動するように設定できます。ベスト プラクティスおよび上記の例は、参照として使用する必要があります。ベンダー固有の推奨事項については、スイッチ ベンダーの 802.1q タギングおよびトランキングに関するドキュメントを参照してください。